RakNet: Deprecated List

RakNet 4.0
  • Main Page
  • Related Pages
  • Modules
  • Namespaces
  • Classes
  • Files
Deprecated List
Class RakNet::AutopatcherServer::ResultTypeAndBitstream
Class RakNet::HTTPConnection
, use HTTPConnection2
Member RakNet::RakPeer::ApplyNetworkSimulator (float packetloss, unsigned short minExtraPing, unsigned short extraPingVariance)
Use http://www.jenkinssoftware.com/forum/index.php?topic=1671.0 instead.
Member RakNet::RakPeerInterface::ApplyNetworkSimulator (float packetloss, unsigned short minExtraPing, unsigned short extraPingVariance)=0
Use http://www.jenkinssoftware.com/forum/index.php?topic=1671.0 instead.
Member RakNet::RM3SR_SERIALIZED_ALWAYS_IDENTICALLY
, use RM3SR_BROADCAST_IDENTICALLY_FORCE_SERIALIZATION
Member RakNet::RPC4::Call (const char *uniqueID, RakNet::BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel, const AddressOrGUID systemIdentifier, bool broadcast)
, use Signal() Send to the specified remote instance of RakPeer.
Member RakNet::RPC4::CallLoopback (const char *uniqueID, RakNet::BitStream *bitStream)
Use RegisterSlot() and Signal() with your own RakNetGUID as the send target Send to the attached instance of RakPeer. See RakPeerInterface::SendLoopback()
Member RakNet::RPC4::RegisterFunction (const char *uniqueID, void(*functionPointer)(RakNet::BitStream *userData, Packet *packet))
Use RegisterSlot
Member RakNet::RPC4::RegisterLocalCallback (const char *uniqueID, MessageID messageId)
Use RegisterSlot and invoke on self only when the packet you want arrives When a RakNet Packet with the specified identifier is returned, execute CallLoopback() on a function previously registered with RegisterFunction() For example, you could call "OnClosedConnection" whenever you get ID_DISCONNECTION_NOTIFICATION or ID_CONNECTION_LOST
Class RakNet::TeamBalancer
Use TeamManager intead
Member RakNet::TeamId
Use TeamManager intead
Group TEAM_BALANCER_GROUP
Use TeamManager intead
File TeamBalancer.h
Use TeamManager intead
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Modules

  • Modules
  • Namespaces
  • Classes
  • Files
Modules
Here is a list of all modules:
[detail level 1234]
\ PluginInterface2 |
\ Plugins |
o CloudComputing | Contains the CloudClient and CloudServer plugins
o DirectoryDeltaTransfer | Simple class to send changes between directories
o FileListTransfer | A plugin to provide a simple way to compress and incrementally send the files in the FileList structure
o MessageFilter | Remote incoming packets from unauthorized systems
o NatPunchthrough | Connect systems despite both systems being behind a router
o NatTypeDetection | Use a remote server with multiple IP addresses to determine what type of NAT your router is using
o PacketLogger | Print out incoming messages to a target destination
o RakNetTransport | UDP based transport implementation for the ConsoleServer
o ReadyEvent | Peer to peer synchronized ready and unready events
o RelayPlugin | A simple class to relay messages from one system to another through an intermediary
o ReplicaManager3 | Third implementation of object replication
o Router2 | Part of the NAT punchthrough solution, allowing you to connect to systems by routing through a shared connection
o RPC | Remote procedure calls, without external dependencies
o TeamBalancer | Set and network team selection (supports peer to peer or client/server)
o TeamManager | Automates networking and list management for teams
o UDPProxy | Forwards UDP datagrams from one system to another. Protocol independent
o Lobby2Plugin | SQL based lobby system, with support for users, friends, clans, emails, ranking, and a message board
| o Lobby2Commands | Commands that can be sent to Lobby2Server from Lobby2Client
| o Lobby2Notifications | Callbacks that the Lobby2System will send to you
| o Lobby2Server | Runs the server modules that asynchronously processes Lobby2Message
| \ Lobby2Client | Sends commands to Lobby2Server
o RoomsPlugin | Networked implementation of a rooms system, where members join and leave rooms
| o RoomsCommands | Commands that can be sent to RoomsPlugin
| \ RoomsNotifications | Notifications that RoomsPlugin sends to you
o RPC3 | Remote procedure calls, powered by the 3rd party library Boost
\ SQLite3Plugin | Code to transmit SQLite3 commands across the network
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: PluginInterface2

  • Files
Modules | Classes | Enumerations
PluginInterface2

Modules

Plugins

Classes

class RakNet::PluginInterface2

Enumerations

enum | RakNet::PluginReceiveResult { RakNet::RR_STOP_PROCESSING_AND_DEALLOCATE =0, RakNet::RR_CONTINUE_PROCESSING, RakNet::RR_STOP_PROCESSING }
enum | RakNet::PI2_LostConnectionReason { RakNet::LCR_CLOSED_BY_USER, RakNet::LCR_DISCONNECTION_NOTIFICATION, RakNet::LCR_CONNECTION_LOST }
enum | RakNet::PI2_FailedConnectionAttemptReason

Detailed Description

Enumeration Type Documentation

enum RakNet::PI2_FailedConnectionAttemptReason

Returns why a connection attempt failed

enum RakNet::PI2_LostConnectionReason

Reasons why a connection was lost

Enumerator:
LCR_CLOSED_BY_USER

Called RakPeer::CloseConnection()

LCR_DISCONNECTION_NOTIFICATION

Got ID_DISCONNECTION_NOTIFICATION.

LCR_CONNECTION_LOST

GOT ID_CONNECTION_LOST.

enum RakNet::PluginReceiveResult

For each message that arrives on an instance of RakPeer, the plugins get an opportunity to process them first. This enumeration represents what to do with the message

Enumerator:
RR_STOP_PROCESSING_AND_DEALLOCATE

The plugin used this message and it shouldn't be given to the user.

RR_CONTINUE_PROCESSING

This message will be processed by other plugins, and at last by the user.

RR_STOP_PROCESSING

The plugin is going to hold on to this message. Do not deallocate it but do not pass it to other plugins either.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Plugins

Modules | Classes
Plugins
PluginInterface2

Modules

CloudComputing
Contains the CloudClient and CloudServer plugins.
DirectoryDeltaTransfer
Simple class to send changes between directories.
FileListTransfer
A plugin to provide a simple way to compress and incrementally send the files in the FileList structure.
MessageFilter
Remote incoming packets from unauthorized systems.
NatPunchthrough
Connect systems despite both systems being behind a router.
NatTypeDetection
Use a remote server with multiple IP addresses to determine what type of NAT your router is using.
PacketLogger
Print out incoming messages to a target destination.
RakNetTransport
UDP based transport implementation for the ConsoleServer.
ReadyEvent
Peer to peer synchronized ready and unready events.
RelayPlugin
A simple class to relay messages from one system to another through an intermediary.
ReplicaManager3
Third implementation of object replication.
Router2
Part of the NAT punchthrough solution, allowing you to connect to systems by routing through a shared connection.
RPC
Remote procedure calls, without external dependencies.
TeamBalancer
Set and network team selection (supports peer to peer or client/server)
TeamManager
Automates networking and list management for teams.
UDPProxy
Forwards UDP datagrams from one system to another. Protocol independent.
Lobby2Plugin
SQL based lobby system, with support for users, friends, clans, emails, ranking, and a message board.
RoomsPlugin
Networked implementation of a rooms system, where members join and leave rooms.
RPC3
Remote procedure calls, powered by the 3rd party library Boost.
SQLite3Plugin
Code to transmit SQLite3 commands across the network.

Classes

class | RakNet::StatisticsHistoryPlugin
Input numerical values over time. Get sum, average, highest, lowest, standard deviation on recent or all-time values. More...
class | RakNet::TwoWayAuthentication
Implements two way authentication. More...

Detailed Description

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: CloudComputing

Classes
CloudComputing
Plugins

Contains the CloudClient and CloudServer plugins. More...

Classes

class | RakNet::CloudClient
Performs Post() and Get() operations on CloudMemoryServer. More...
class | RakNet::CloudClientCallback
class | RakNet::CloudAllocator
struct | RakNet::CloudKey
struct | RakNet::CloudQuery
class | RakNet::CloudServerQueryFilter
Zero or more instances of CloudServerQueryFilter can be attached to CloudServer to restrict client queries All attached instances of CloudServerQueryFilter on each corresponding operation, from all directly connected clients If any attached instance returns false for a given operation, that operation is silently rejected. More...
class | RakNet::CloudServer
Stores client data, and allows cross-server communication to retrieve this data. More...

Detailed Description

Contains the CloudClient and CloudServer plugins.

The CloudServer plugins operates on requests from the CloudClient plugin. The servers are in a fully connected mesh topology, which the clients are connected to any server. Clients can interact with each other by posting and subscribing to memory updates, without being directly connected or even knowing about each other.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::CloudClient Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • RakNet
  • CloudClient
Public Member Functions | Protected Member Functions | List of all members
RakNet::CloudClient Class Reference
CloudComputing

Performs Post() and Get() operations on CloudMemoryServer. More...

#include <CloudClient.h>

Inheritance diagram for RakNet::CloudClient:
RakNet::PluginInterface2

Public Member Functions

virtual void | SetDefaultCallbacks (CloudAllocator *_allocator, CloudClientCallback *_callback)
Set the default callbacks for OnGetReponse(), OnSubscriptionNotification(), and OnSubscriptionDataDeleted()
virtual void | Post (CloudKey *cloudKey, const unsigned char *data, uint32_t dataLengthBytes, RakNetGUID systemIdentifier)
Uploads data to the cloud.
virtual void | Release (DataStructures::List< CloudKey > &keys, RakNetGUID systemIdentifier)
Releases one or more data previously uploaded with Post()
virtual bool | Get (CloudQuery *cloudQuery, RakNetGUID systemIdentifier)
Gets data from the cloud.
virtual void | Unsubscribe (DataStructures::List< CloudKey > &keys, RakNetGUID systemIdentifier)
Unsubscribe from updates previously subscribed to using Get() with the CloudQuery::subscribeToResults set to true The keys and specificSystems parameters are logically treated as AND when checking subscriptions on the server The overload that does not take specificSystems unsubscribes to all passed keys, regardless of system You cannot unsubscribe specific systems when previously subscribed to updates from any system. To do this, first Unsubscribe() from all systems, and call Get() with the specificSystems parameter explicilty listing the systems you want to subscribe to.
virtual void | OnGetReponse (Packet *packet, CloudClientCallback *_callback=0, CloudAllocator *_allocator=0)
Call this when you get ID_CLOUD_GET_RESPONSE If callback or allocator are 0, the default callbacks passed to SetDefaultCallbacks() are used.
virtual void | OnGetReponse (CloudQueryResult *cloudQueryResult, Packet *packet, CloudAllocator *_allocator=0)
Call this when you get ID_CLOUD_GET_RESPONSE Different form of OnGetReponse that returns to a structure that you pass, instead of using a callback You are responsible for deallocation with this form If allocator is 0, the default callback passed to SetDefaultCallbacks() are used.
virtual void | OnSubscriptionNotification (Packet *packet, CloudClientCallback *_callback=0, CloudAllocator *_allocator=0)
Call this when you get ID_CLOUD_SUBSCRIPTION_NOTIFICATION If callback or allocator are 0, the default callbacks passed to SetDefaultCallbacks() are used.
virtual void | OnSubscriptionNotification (bool *wasUpdated, CloudQueryRow *row, Packet *packet, CloudAllocator *_allocator=0)
Call this when you get ID_CLOUD_SUBSCRIPTION_NOTIFICATION Different form of OnSubscriptionNotification that returns to a structure that you pass, instead of using a callback You are responsible for deallocation with this form If allocator is 0, the default callback passed to SetDefaultCallbacks() are used.
virtual void | DeallocateWithDefaultAllocator (CloudQueryResult *cloudQueryResult)
If you never specified an allocator, and used the non-callback form of OnGetReponse(), deallocate cloudQueryResult with this function.
virtual void | DeallocateWithDefaultAllocator (CloudQueryRow *row)
If you never specified an allocator, and used the non-callback form of OnSubscriptionNotification(), deallocate row with this function.
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Protected Member Functions

PluginReceiveResult OnReceive (Packet *packet)

Detailed Description

Performs Post() and Get() operations on CloudMemoryServer.

A CloudClient is a computer connected to one or more servers in a cloud configuration. Operations by one CloudClient can be received and subscribed to by other instances of CloudClient, without those clients being connected, even on different servers.

Member Function Documentation

virtual bool RakNet::CloudClient::Get | ( | CloudQuery * | cloudQuery,
 |  | RakNetGUID | systemIdentifier
 | ) |  |
virtual

Gets data from the cloud.

For a given query containing one or more keys, return data that matches those keys. The values will be returned in the ID_CLOUD_GET_RESPONSE packet, which should be passed to OnGetReponse() and will invoke CloudClientCallback::OnGet() CloudQuery::startingRowIndex is used to skip the first n values that would normally be returned.. CloudQuery::maxRowsToReturn is used to limit the number of rows returned. The number of rows returned may also be limited by CloudServer::SetMaxBytesPerDownload(); CloudQuery::subscribeToResults if set to true, will cause ID_CLOUD_SUBSCRIPTION_NOTIFICATION to be returned to us when any of the keys in the query are updated or are deleted. ID_CLOUD_GET_RESPONSE will be returned even if subscribing to the result list. Only later updates will return ID_CLOUD_SUBSCRIPTION_NOTIFICATION. Calling Get() with CloudQuery::subscribeToResults false, when you are already subscribed, does not remove the subscription. Use Unsubscribe() for this. Resubscribing using the same CloudKey but a different or no specificSystems overwrites the subscribed systems for those keys.

Parameters
[in] | cloudQuery | One or more keys, and optional parameters to perform with the Get
[in] | systemIdentifier | A remote system running CloudServer that we are already connected to.
[in] | specificSystems | It is possible to get or subscribe to updates only for specific uploading CloudClient instances. Pass the desired instances here. The overload that does not have the specificSystems parameter is treated as subscribing to all updates from all clients.
virtual void RakNet::CloudClient::OnGetReponse | ( | Packet * | packet,
 |  | CloudClientCallback * | _callback = 0,
 |  | CloudAllocator * | _allocator = 0
 | ) |  |
virtual

Call this when you get ID_CLOUD_GET_RESPONSE If callback or allocator are 0, the default callbacks passed to SetDefaultCallbacks() are used.

Parameters
[in] | packet | Packet structure returned from RakPeerInterface
[in] | _callback | Callback to be called from the function containing output parameters. If 0, default is used.
[in] | _allocator | Allocator to be used to allocate data. If 0, default is used.
virtual void RakNet::CloudClient::OnGetReponse | ( | CloudQueryResult * | cloudQueryResult,
 |  | Packet * | packet,
 |  | CloudAllocator * | _allocator = 0
 | ) |  |
virtual

Call this when you get ID_CLOUD_GET_RESPONSE Different form of OnGetReponse that returns to a structure that you pass, instead of using a callback You are responsible for deallocation with this form If allocator is 0, the default callback passed to SetDefaultCallbacks() are used.

Parameters
[out] | cloudQueryResult | A pointer to a structure that will be filled out with data
[in] | packet | Packet structure returned from RakPeerInterface
[in] | _allocator | Allocator to be used to allocate data. If 0, default is used.
PluginReceiveResult RakNet::CloudClient::OnReceive ( Packet * packet )
protectedvirtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

virtual void RakNet::CloudClient::OnSubscriptionNotification | ( | Packet * | packet,
 |  | CloudClientCallback * | _callback = 0,
 |  | CloudAllocator * | _allocator = 0
 | ) |  |
virtual

Call this when you get ID_CLOUD_SUBSCRIPTION_NOTIFICATION If callback or allocator are 0, the default callbacks passed to SetDefaultCallbacks() are used.

Parameters
[in] | packet | Packet structure returned from RakPeerInterface
[in] | _callback | Callback to be called from the function containing output parameters. If 0, default is used.
[in] | _allocator | Allocator to be used to allocate data. If 0, default is used.
virtual void RakNet::CloudClient::OnSubscriptionNotification | ( | bool * | wasUpdated,
 |  | CloudQueryRow * | row,
 |  | Packet * | packet,
 |  | CloudAllocator * | _allocator = 0
 | ) |  |
virtual

Call this when you get ID_CLOUD_SUBSCRIPTION_NOTIFICATION Different form of OnSubscriptionNotification that returns to a structure that you pass, instead of using a callback You are responsible for deallocation with this form If allocator is 0, the default callback passed to SetDefaultCallbacks() are used.

Parameters
[out] | wasUpdated | If true, the row was updated. If false, it was deleted. result will contain the last value just before deletion
[out] | row | A pointer to a structure that will be filled out with data
[in] | packet | Packet structure returned from RakPeerInterface
[in] | _allocator | Allocator to be used to allocate data. If 0, default is used.
virtual void RakNet::CloudClient::Post | ( | CloudKey * | cloudKey,
 |  | const unsigned char * | data,
 |  | uint32_t | dataLengthBytes,
 |  | RakNetGUID | systemIdentifier
 | ) |  |
virtual

Uploads data to the cloud.

Data uploaded to the cloud will be stored by the server sent to, identified by systemIdentifier. As long as you are connected to this server, the data will persist. Queries for that data by the Get() operation will return the RakNetGUID and SystemAddress of the uploader, as well as the data itself. Furthermore, if any clients are subscribed to the particular CloudKey passed, those clients will get update notices that the data has changed Passing data with the same cloudKey more than once will overwrite the prior value. This call will silently fail if CloudServer::SetMaxUploadBytesPerClient() is exceeded

Parameters
[in] | cloudKey | Identifies the data being uploaded
[in] | data | A pointer to data to upload. This pointer does not need to persist past the call
[in] | dataLengthBytes | The length in bytes of data
[in] | systemIdentifier | A remote system running CloudServer that we are already connected to.
virtual void RakNet::CloudClient::Release | ( | DataStructures::List< CloudKey > & | keys,
 |  | RakNetGUID | systemIdentifier
 | ) |  |
virtual

Releases one or more data previously uploaded with Post()

If a remote system has subscribed to one or more of the keys uploaded, they will get ID_CLOUD_SUBSCRIPTION_NOTIFICATION notifications containing the last value uploaded before deletions

Parameters
[in] | cloudKey | Identifies the data to release. It is possible to remove uploads from multiple Post() calls at once.
[in] | systemIdentifier | A remote system running CloudServer that we are already connected to.
virtual void RakNet::CloudClient::SetDefaultCallbacks | ( | CloudAllocator * | _allocator,
 |  | CloudClientCallback * | _callback
 | ) |  |
virtual

Set the default callbacks for OnGetReponse(), OnSubscriptionNotification(), and OnSubscriptionDataDeleted()

Pointers to CloudAllocator and CloudClientCallback can be stored by the system if desired. If a callback is not provided to OnGetReponse(), OnSubscriptionNotification(), OnSubscriptionDataDeleted(), the callback passed here will be used instead.

Parameters
[in] | _allocator | An instance of CloudAllocator
[in] | _callback | An instance of CloudClientCallback
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/CloudClient.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::CloudClientCallback Class Reference

  • Class Hierarchy
  • Class Members
  • RakNet
  • CloudClientCallback
Public Member Functions | List of all members
RakNet::CloudClientCallback Class Reference
CloudComputing

#include <CloudClient.h>

Public Member Functions

virtual void | OnGet (RakNet::CloudQueryResult *result, bool *deallocateRowsAfterReturn)
Called in response to ID_CLOUD_GET_RESPONSE.
virtual void | OnSubscriptionNotification (RakNet::CloudQueryRow *result, bool wasUpdated, bool *deallocateRowAfterReturn)
Called in response to ID_CLOUD_SUBSCRIPTION_NOTIFICATION.

Detailed Description

Parses ID_CLOUD_GET_RESPONSE and ID_CLOUD_SUBSCRIPTION_NOTIFICATION in a convenient callback form

Member Function Documentation

virtual void RakNet::CloudClientCallback::OnGet | ( | RakNet::CloudQueryResult * | result,
 |  | bool * | deallocateRowsAfterReturn
 | ) |  |
inlinevirtual

Called in response to ID_CLOUD_GET_RESPONSE.

Parameters
[out] | result | Contains the original query passed to Get(), and a list of rows returned.
[out] | deallocateRowsAfterReturn | CloudQueryResult::rowsReturned will be deallocated after the function returns by default. Set to false to not deallocate these pointers. The pointers are allocated through CloudAllocator.
virtual void RakNet::CloudClientCallback::OnSubscriptionNotification | ( | RakNet::CloudQueryRow * | result,
 |  | bool | wasUpdated,
 |  | bool * | deallocateRowAfterReturn
 | ) |  |
inlinevirtual

Called in response to ID_CLOUD_SUBSCRIPTION_NOTIFICATION.

Parameters
[out] | result | Contains the row updated
[out] | wasUpdated | If true, the row was updated. If false, it was deleted. result will contain the last value just before deletion
[out] | deallocateRowAfterReturn | result will be deallocated after the function returns by default. Set to false to not deallocate these pointers. The pointers are allocated through CloudAllocator.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/CloudClient.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::CloudAllocator Class Reference

  • CloudAllocator
Public Member Functions | List of all members
RakNet::CloudAllocator Class Reference
CloudComputing

#include <CloudCommon.h>

Inheritance diagram for RakNet::CloudAllocator:
RakNet::CloudServer

Public Member Functions

virtual CloudQueryRow * | AllocateCloudQueryRow (void)
Allocate a row.
virtual void | DeallocateCloudQueryRow (CloudQueryRow *row)
Free a row.
virtual unsigned char * | AllocateRowData (uint32_t bytesNeededForData)
Allocate CloudQueryRow::data.
virtual void | DeallocateRowData (void *data)
Free CloudQueryRow::data.

Detailed Description

Allocates CloudQueryRow and the row data. Override to use derived classes or different allocators

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/CloudCommon.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::CloudKey Struct Reference

  • CloudKey
Public Attributes | List of all members
RakNet::CloudKey Struct Reference
CloudComputing

#include <CloudCommon.h>

Public Attributes

RakNet::RakString primaryKey
uint32_t secondaryKey
Identifies the secondary key. This is intended to be a subcategory enumeration, such as PLAYER_LIST or RUNNING_SCORES.

Detailed Description

Serves as a key to identify data uploaded to or queried from the server.

Member Data Documentation

RakNet::RakString RakNet::CloudKey::primaryKey

Identifies the primary key. This is intended to be a major category, such as the name of the application Must be non-empty

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/CloudCommon.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::CloudQuery Struct Reference

  • CloudQuery
Public Attributes | List of all members
RakNet::CloudQuery Struct Reference
CloudComputing

#include <CloudCommon.h>

Public Attributes

DataStructures::List< CloudKey > keys
uint32_t | startingRowIndex
If limiting the number of rows to return, this is the starting offset into the list. Has no effect unless maxRowsToReturn is > 0.
uint32_t | maxRowsToReturn
Maximum number of rows to return. Actual number may still be less than this. Pass 0 to mean no-limit.
bool | subscribeToResults
If true, automatically get updates as the results returned to you change. Unsubscribe with CloudMemoryClient::Unsubscribe()

Detailed Description

Data members used to query the cloud

Member Data Documentation

DataStructures::List<CloudKey> RakNet::CloudQuery::keys

List of keys to query. Must be at least of length 1. This query is run on uploads from all clients, and those that match the combination of primaryKey and secondaryKey are potentially returned If you pass more than one key at a time, the results are concatenated so if you need to differentiate between queries then send two different queries

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/CloudCommon.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::CloudServerQueryFilter Class Reference

  • CloudServerQueryFilter
Public Member Functions | List of all members
RakNet::CloudServerQueryFilter Class Referenceabstract
CloudComputing

Zero or more instances of CloudServerQueryFilter can be attached to CloudServer to restrict client queries All attached instances of CloudServerQueryFilter on each corresponding operation, from all directly connected clients If any attached instance returns false for a given operation, that operation is silently rejected. More...

#include <CloudServer.h>

Public Member Functions

virtual bool | OnPostRequest (RakNetGUID clientGuid, SystemAddress clientAddress, CloudKey key, uint32_t dataLength, const char *data)=0
virtual bool | OnReleaseRequest (RakNetGUID clientGuid, SystemAddress clientAddress, DataStructures::List< CloudKey > &cloudKeys)=0
virtual bool | OnGetRequest (RakNetGUID clientGuid, SystemAddress clientAddress, CloudQuery &query, DataStructures::List< RakNetGUID > &specificSystems)=0
virtual bool | OnUnsubscribeRequest (RakNetGUID clientGuid, SystemAddress clientAddress, DataStructures::List< CloudKey > &cloudKeys, DataStructures::List< RakNetGUID > &specificSystems)=0

Detailed Description

Zero or more instances of CloudServerQueryFilter can be attached to CloudServer to restrict client queries All attached instances of CloudServerQueryFilter on each corresponding operation, from all directly connected clients If any attached instance returns false for a given operation, that operation is silently rejected.

Member Function Documentation

virtual bool RakNet::CloudServerQueryFilter::OnGetRequest | ( | RakNetGUID | clientGuid,
 |  | SystemAddress | clientAddress,
 |  | CloudQuery & | query,
 |  | DataStructures::List< RakNetGUID > & | specificSystems
 | ) |  |
pure virtual

Called when a local client wants to query data If you return false, the client will get no response at all

Returns
true to allow, false to reject
virtual bool RakNet::CloudServerQueryFilter::OnPostRequest | ( | RakNetGUID | clientGuid,
 |  | SystemAddress | clientAddress,
 |  | CloudKey | key,
 |  | uint32_t | dataLength,
 |  | const char * | data
 | ) |  |
pure virtual

Called when a local client wants to post data

Returns
true to allow, false to reject
virtual bool RakNet::CloudServerQueryFilter::OnReleaseRequest | ( | RakNetGUID | clientGuid,
 |  | SystemAddress | clientAddress,
 |  | DataStructures::List< CloudKey > & | cloudKeys
 | ) |  |
pure virtual

Called when a local client wants to release data that it has previously uploaded

Returns
true to allow, false to reject
virtual bool RakNet::CloudServerQueryFilter::OnUnsubscribeRequest | ( | RakNetGUID | clientGuid,
 |  | SystemAddress | clientAddress,
 |  | DataStructures::List< CloudKey > & | cloudKeys,
 |  | DataStructures::List< RakNetGUID > & | specificSystems
 | ) |  |
pure virtual

Called when a local client wants to stop getting updates for data If you return false, the client will keep getting updates for that data

Returns
true to allow, false to reject
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/CloudServer.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::CloudServer Class Reference

  • CloudServer
Public Member Functions | Protected Member Functions | List of all members
RakNet::CloudServer Class Reference
CloudComputing

Stores client data, and allows cross-server communication to retrieve this data. More...

#include <CloudServer.h>

Inheritance diagram for RakNet::CloudServer:
RakNet::PluginInterface2 RakNet::CloudAllocator

Public Member Functions

void | SetMaxUploadBytesPerClient (uint64_t bytes)
Max bytes a client can upload Data in excess of this value is silently ignored defaults to 0 (unlimited)
void | SetMaxBytesPerDownload (uint64_t bytes)
Max bytes returned by a download. If the number of bytes would exceed this amount, the returned list is truncated However, if this would result in no rows downloaded, then one row will be returned.
void | AddServer (RakNetGUID systemIdentifier)
Add a server, which is assumed to be connected in a fully connected mesh to all other servers and also running the CloudServer plugin The other system must also call AddServer before getting the subscription data, or it will be rejected. Sending a message telling the other system to call AddServer(), followed by calling AddServer() locally, would be sufficient for this to work.
void | RemoveServer (RakNetGUID systemIdentifier)
Removes a server added through AddServer()
void | GetRemoteServers (DataStructures::List< RakNetGUID > &remoteServersOut)
void | Clear (void)
Frees all memory. Does not remove query filters.
void | ForceExternalSystemAddress (SystemAddress forcedAddress)
Report the specified SystemAddress to client queries, rather than what RakPeer reads. This is useful if you already know your public IP This only applies to future updates, so call it before updating to apply to all queries.
void | AddQueryFilter (CloudServerQueryFilter *filter)
Adds a callback called on each query. If all filters returns true for an operation, the operation is allowed. If the filter was already added, the function silently fails.
void | RemoveQueryFilter (CloudServerQueryFilter *filter)
Removes a callback added with AddQueryFilter() The instance is not deleted, only unreferenced. It is up to the user to delete the instance, if necessary.
void | RemoveAllQueryFilters (void)
Removes all instances of CloudServerQueryFilter added with AddQueryFilter(). The instances are not deleted, only unreferenced. It is up to the user to delete the instances, if necessary.
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Protected Member Functions

virtual void | Update (void)
Update is called every time a packet is checked for .
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.

Additional Inherited Members

- Private Member Functions inherited from RakNet::CloudAllocator
virtual CloudQueryRow * | AllocateCloudQueryRow (void)
Allocate a row.
virtual void | DeallocateCloudQueryRow (CloudQueryRow *row)
Free a row.
virtual unsigned char * | AllocateRowData (uint32_t bytesNeededForData)
Allocate CloudQueryRow::data.
virtual void | DeallocateRowData (void *data)
Free CloudQueryRow::data.

Detailed Description

Stores client data, and allows cross-server communication to retrieve this data.

Member Function Documentation

void RakNet::CloudServer::AddQueryFilter ( CloudServerQueryFilter * filter )

Adds a callback called on each query. If all filters returns true for an operation, the operation is allowed. If the filter was already added, the function silently fails.

Parameters
[in] filter An externally allocated instance of CloudServerQueryFilter. The instance must remain valid until it is removed with RemoveQueryFilter() or RemoveAllQueryFilters()
void RakNet::CloudServer::AddServer ( RakNetGUID systemIdentifier )

Add a server, which is assumed to be connected in a fully connected mesh to all other servers and also running the CloudServer plugin The other system must also call AddServer before getting the subscription data, or it will be rejected. Sending a message telling the other system to call AddServer(), followed by calling AddServer() locally, would be sufficient for this to work.

Note
This sends subscription data to the other system, using RELIABLE_ORDERED on channel 0
Parameters
[in] systemIdentifier Identifier of the remote system
void RakNet::CloudServer::ForceExternalSystemAddress ( SystemAddress forcedAddress )

Report the specified SystemAddress to client queries, rather than what RakPeer reads. This is useful if you already know your public IP This only applies to future updates, so call it before updating to apply to all queries.

Parameters
[in] forcedAddress The systmeAddress to return in queries. Use UNASSIGNED_SYSTEM_ADDRESS (default) to use what RakPeer returns
void RakNet::CloudServer::GetRemoteServers ( DataStructures::List< RakNetGUID > & remoteServersOut )

Return list of servers added with AddServer()

Parameters
[out] remoteServers List of servers added
virtual void RakNet::CloudServer::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
protectedvirtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::CloudServer::OnReceive ( Packet * packet )
protectedvirtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

void RakNet::CloudServer::RemoveQueryFilter ( CloudServerQueryFilter * filter )

Removes a callback added with AddQueryFilter() The instance is not deleted, only unreferenced. It is up to the user to delete the instance, if necessary.

Parameters
[in] filter An externally allocated instance of CloudServerQueryFilter. The instance must remain valid until it is removed with RemoveQueryFilter() or RemoveAllQueryFilters()
void RakNet::CloudServer::RemoveServer ( RakNetGUID systemIdentifier )

Removes a server added through AddServer()

Parameters
[in] systemIdentifier Identifier of the remote system
void RakNet::CloudServer::SetMaxBytesPerDownload ( uint64_t bytes )

Max bytes returned by a download. If the number of bytes would exceed this amount, the returned list is truncated However, if this would result in no rows downloaded, then one row will be returned.

Parameters
[in] bytes Max bytes a client can download from a single Get(). 0 means unlimited.
void RakNet::CloudServer::SetMaxUploadBytesPerClient ( uint64_t bytes )

Max bytes a client can upload Data in excess of this value is silently ignored defaults to 0 (unlimited)

Parameters
[in] bytes Max bytes a client can upload. 0 means unlimited.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/CloudServer.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: DirectoryDeltaTransfer

Namespaces
DirectoryDeltaTransfer
Plugins

Simple class to send changes between directories. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Simple class to send changes between directories.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Typedefs | Enumerations | Functions | Variables
RakNet Namespace Reference
DirectoryDeltaTransfer

Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc. More...

Classes

class | AutopatcherRepositoryInterface
An interface used by AutopatcherServer to get the data necessary to run an autopatcher. This is up to you to implement for custom repository solutions. More...
class | BitStream
class | CloudClient
Performs Post() and Get() operations on CloudMemoryServer. More...
class | CloudClientCallback
class | CloudAllocator
struct | CloudKey
struct | CloudQuery
class | CloudServerQueryFilter
Zero or more instances of CloudServerQueryFilter can be attached to CloudServer to restrict client queries All attached instances of CloudServerQueryFilter on each corresponding operation, from all directly connected clients If any attached instance returns false for a given operation, that operation is silently rejected. More...
class | CloudServer
Stores client data, and allows cross-server communication to retrieve this data. More...
class | CommandParserInterface
The interface used by command parsers. More...
class | ConnectionGraph2
A one hop connection graph. More...
class | ConsoleServer
The main entry point for the server portion of your remote console application support. More...
class | DataCompressor
Does compression on a block of data. Not very good compression, but it's small and fast so is something you can compute at runtime. More...
class | HuffmanEncodingTree
This generates special cases of the huffman encoding tree using 8 bit keys with the additional condition that unused combinations of 8 bits are treated as a frequency of 1. More...
class | HuffmanEncodingTreeFactory
Creates instances of the class HuffmanEncodingTree. More...
class | EmailSender
Rudimentary class to send email from code. More...
struct | FileListNode
Represents once instance of a file. More...
class | FileListProgress
Callback interface set with FileList::SetCallback() in case you want progress notifications when FileList::AddFilesFromDirectory() is called. More...
class | FLP_Printf
Implementation of FileListProgress to use RAKNET_DEBUG_PRINTF. More...
class | FileListTransfer
A plugin to provide a simple way to compress and incrementally send the files in the FileList structure. More...
class | FileListTransferCBInterface
Used by FileListTransfer plugin as a callback for when we get a file. More...
class | HTTPConnection
Use HTTPConnection to communicate with a web server. More...
class | HTTPConnection2
Use HTTPConnection2 to communicate with a web server. More...
struct | InternalPacketRefCountedData
Used in InternalPacket when pointing to sharedDataBlock, rather than allocating itself. More...
struct | InternalPacket
class | LogCommandParser
Adds the ability to send logging output to a remote console. More...
class | MessageFilter
Assigns systems to FilterSets. Each FilterSet limits what kinds of messages are allowed. More...
class | NatPunchthroughClient
Client code for NATPunchthrough. More...
class | NatPunchthroughServer
Server code for NATPunchthrough. More...
class | NatTypeDetectionClient
Client code for NatTypeDetection. More...
class | NatTypeDetectionServer
Server code for NatTypeDetection. More...
class | NetworkIDManager
class | NetworkIDObject
Unique shared ids for each object instance. More...
class | PacketConsoleLogger
Packetlogger that logs to a remote command console. More...
class | PacketFileLogger
Packetlogger that outputs to a file. More...
class | PacketLogger
Writes incoming and outgoing messages to the screen. This will write all incoming and outgoing messages to the console window, or to a file if you override it and give it this functionality. More...
class | PacketOutputWindowLogger
Packetlogger that outputs to the output window in the debugger. Windows only. More...
class | PluginInterface2
class | Rackspace2EventCallback
Callback interface to receive the results of operations. More...
class | RackspaceEventCallback_Default
Callback interface to receive the results of operations, with a default result. More...
class | Rackspace
Code that uses the TCPInterface class to communicate with the Rackspace API servers. More...
class | RakNetCommandParser
This allows a console client to call most of the functions in RakPeer. More...
struct | RakNetStatistics
Network Statisics Usage. More...
class | RakNetTransport2
Use RakNetTransport if you need a secure connection between the client and the console server. More...
struct | PublicKey
Passed to RakPeerInterface::Connect() More...
struct | SocketDescriptor
Describes the local socket to use for RakPeer::Startup. More...
struct | SystemAddress
Network address for a system. More...
struct | RakNetGUID
struct | Packet
This represents a user message from another system. More...
class | RakPeer
Main interface for network communications. More...
class | RakPeerInterface
The main interface for network communications. More...
class | RakString
String class. More...
class | RakWString
String class for Unicode. More...
class | ReadyEvent
Peer to peer synchronized ready and unready events. More...
class | RelayPlugin
A simple class to relay messages from one system to another, identifying remote systems by a string. More...
class | ReliabilityLayer
Datagram reliable, ordered, unordered and sequenced sends. Flow control. Message splitting, reassembly, and coalescence. More...
class | ReplicaManager3
System to help automate game object construction, destruction, and serialization. More...
struct | LastSerializationResult
struct | SerializeParameters
class | Connection_RM3
Each remote system is represented by Connection_RM3. Used to allocate Replica3 and track which instances have been allocated. More...
class | Replica3
Base class for your replicated objects for the ReplicaManager3 system. More...
class | Replica3Composite
Use Replica3 through composition instead of inheritance by containing an instance of this templated class Calls to parent class for all functions Parent class must still define and functions though! More...
class | Router2
Class interface for the Router2 system. More...
class | RPC4GlobalRegistration
Instantiate this class globally if you want to register a function with RPC4 at the global space. More...
class | RPC4
The RPC4 plugin is just an association between a C function pointer and a string. More...
class | SimpleMutex
An easy to use mutex. More...
class | StatisticsHistory
Input numerical values over time. Get sum, average, highest, lowest, standard deviation on recent or all-time values. More...
class | StatisticsHistoryPlugin
Input numerical values over time. Get sum, average, highest, lowest, standard deviation on recent or all-time values. More...
class | StringCompressor
Writes and reads strings to and from bitstreams. More...
class | StringTable
Writes a string index, instead of the whole string. More...
struct | RemoteClient
Stores information about a remote client. More...
class | TeamBalancer
Set and network team selection (supports peer to peer or client/server) More...
struct | TeamSelection
Parameter to TM_World::ReferenceTeamMember() More...
class | TM_TeamMember
A member of one or more teams. More...
class | TM_Team
A team, containing a list of TM_TeamMember instances. More...
class | TM_World
Stores a list of teams which may be enforcing a balanced number of members. More...
class | TeamManager
Automates networking and list management for teams. More...
class | TelnetTransport
Use TelnetTransport to easily allow windows telnet to connect to your ConsoleServer. More...
class | ThreadsafePacketLogger
Same as PacketLogger, but writes output in the user thread. More...
class | TransportInterface
Defines an interface that is used to send and receive null-terminated strings. More...
class | TwoWayAuthentication
Implements two way authentication. More...
class | UDPForwarder
Forwards UDP datagrams. Independent of RakNet's protocol. More...
struct | UDPProxyClientResultHandler
class | UDPProxyClient
Communicates with UDPProxyCoordinator, in order to find a UDPProxyServer to forward our datagrams. More...
class | UDPProxyCoordinator
Middleman between UDPProxyServer and UDPProxyClient, maintaining a list of UDPProxyServer, and managing state for clients to find an available forwarding server. More...
struct | UDPProxyServerResultHandler
class | UDPProxyServer
UDPProxyServer to control our instance of UDPForwarder. More...
class | VariableDeltaSerializer
Class to compare memory values of variables in a current state to a prior state Results of the comparisons will be written to a bitStream, such that only changed variables get written
Can be used with ReplicaManager3 to Serialize a Replica3 per-variable, rather than comparing the entire object against itself
Usage:
BR> More...
class | VariableListDeltaTracker
class | RakVoice
Voice compression and transmission interface. More...
class | AutopatcherServerLoadNotifier_Printf
Sample implementation of AutopatcherServerLoadNotifier using printf. More...
class | AutopatcherServer
The server plugin for the autopatcher. Must be running for the client to get patches. More...
class | AutopatcherPostgreRepository
class | Lobby2Client
Class used to send commands to Lobby2Server. More...
struct | Lobby2Message
A Lobby2Message encapsulates a networked function call from the client. More...
struct | Lobby2Callbacks
struct | Lobby2Printf
struct | IndexedIntegerValue
Used to unify different platforms for room search and search properties. Only applies if specifically used. More...
struct | IndexedBinaryValue
Used to unify different platforms for room search and search properties. Only applies if specifically used. More...
struct | Platform_Startup
Platform specific startup. Unused on the PC. More...
struct | Platform_Shutdown
Platform specific startup. Unused on the PC. More...
struct | System_CreateDatabase
Create all tables and stored procedures on a system that does not already have them. More...
struct | System_DestroyDatabase
Destroy all tables and stored procedures created with System_CreateDatabase. More...
struct | System_CreateTitle
Each title essentially corresponds to a game. For example, the same lobby system may be used for both asteroids and Pac-man. When logging in, and for some functions, it is necessary to specify which title you are logging in under. This way users playing asteroids do not interact with users playing pac-man, where such interations are game specific (such as ranking). More...
struct | System_DestroyTitle
Destroy a previously added title. More...
struct | System_GetTitleRequiredAge
Get the required age set with System_CreateTitle. More...
struct | System_GetTitleBinaryData
Get the binary data set with System_CreateTitle. More...
struct | System_RegisterProfanity
Adds the input strings to a table of profanity. non-unique or empty strings can be ignored. This table will be used internally to ensure that handles and clan names do not contain profanity. Multiple calls add to the table. This table will be used for functions that take a user-defined string that is highly visible, such as clan and user names. It does not need to be checked for emails or message boards. More...
struct | System_BanUser
Bans a specific user (will be most likely called by a moderator). Adds the user's primary key to a ban table, along with the name of the moderator, the reason for the ban. Banning is used to prevent the banned user from logging on for some specified duration. A date column should be present and automatically filled in. When bans are expired, the ban can be deleted from the database. However, a separate table should log bans, so that even expired bans can be looked up in case. More...
struct | System_UnbanUser
Unban a user banned with System_BanUser. More...
struct | CDKey_Add
Adds CDKeys to the database. Duplicate CDKeys for a particular title are ignored. CDKeys can be identical for different titles. More...
struct | CDKey_GetStatus
Returns if a CD key was previously added with AddCDKey. More...
struct | CDKey_Use
Associates a cd key with a user, such that the cd key cannot be used again. If Client_Login() is called with check cd key as true, then this table will be checked to make sure UserCDKey() was previously called with this user and a valid key. If this user is already associated with a CD Key, add the new key, and use the most recent key. All CD Key usage should be logged in a separate table, including the date used and result. More...
struct | CDKey_FlagStolen
Flags one or more CD keys as stolen. Stolen CD keys will prevent Client_Login() if check cd key is true. They will also prevent these cd keys from being used with CDKey_Use. If this key is already in use by certain users for this particular title, then log this similarly to how CDKey_Use does so. More...
struct | Client_Login
Logon with a previously registered account. More...
struct | Client_Logoff
Logoff, after logging in. More...
struct | Client_RegisterAccount
This creates a new account in the database, which can be used in a subsequent call to Login. Most parameters are optional. handle is not optional, and must be unique using case-insensitive compare. emailAddress should be validated to have a sensible format, including an @ sign and a period with a 3 letter extension. allowLoginWithoutEmailAddressValidation is used in Client_Login to potentially disallow logon attempts with unverified email addresses. More...
struct | System_SetEmailAddressValidated
For the client with the given handle, mark a column emailAddressValidated as true or false as appropriate. This is potentially used in Client_Login. More...
struct | Client_ValidateHandle
Looks up in the database if this handle is already in use, subject to the usual constraints of handles. This will be used by the user to quickly check for available handles. More...
struct | System_DeleteAccount
Flags as deleted an account registered with RegisterAccount. Accounts are not actually deleted, only tagged as deleted. More...
struct | System_PruneAccounts
Unused accounts are deleted. This is cascading, such that emails and other tables that reference this key are also deleted. unused accounts are defined as: More...
struct | Client_GetEmailAddress
Returns the email address associated with a specific handle, invalid handle. This is used for password recovery. More...
struct | Client_GetPasswordRecoveryQuestionByHandle
Returns the passwordRecoveryQuestion associated with handle, invalid handle. More...
struct | Client_GetPasswordByPasswordRecoveryAnswer
Returns the password associated with a handle, if the passwordRecoveryAnswer is correct. More...
struct | Client_ChangeHandle
Changes the handle for a user. More...
struct | Client_UpdateAccount
Will update any or all of the inputs that were previously passed to Client_RegisterAccount, except handle. More...
struct | Client_GetAccountDetails
Get the parameters set with Client_RegisterAccount. More...
struct | Client_StartIgnore
Adds the specified user to an ignore list for my user. Recommended to store the primary key of the remote user, both for speed and so if the other use changes their handle it still works. The ignore list is checked for friend invites, emails, and elsewhere where indicated. Ignoring is uni-directional, so if A ignores B, A will block messages from B where appropriate, but B will not immediately block messages from A. More...
struct | Client_StopIgnore
Removes an entry in the database such that myHandle will no longer ignore theirHandle. More...
struct | Client_GetIgnoreList
Returns all users I have ignored. More...
struct | Client_PerTitleBinaryStorage
For each combination of user and title, structures can be stored. More...
struct | Client_SetPresence
Sets in-memory information about your login state, such as which game you are playing, or if you are playing a game Online friends will be notified when you presence changes For the XBOX, just use XUserSetProperty and XUserSetContext directly, as there is no analogue to this function. More...
struct | Client_GetPresence
Gets in-memory information about a user's login state, such as which game they are playing, or if they are playing a game This can also be a quick way to query if a user is logged in or not. If they are not logged in, presence will be set to Lobby2Presence::NOT_ONLINE. More...
struct | Friends_SendInvite
Stores in the database an add friend invite from my handle to their handle. The combination of my handle and their handle must be unique, so you cannot send more than one add friend invite to a single user. Sends an email to their handle the subject, body, and binary data. Note: if myHandle is ignored by theirHandle, then the function fails. See Client_StartIgnore. More...
struct | Friends_AcceptInvite
Stores in the database that this user is now my friend. This is bidirectional, which is to say if someone accepts an add friend invite, they are my friend, and I am their friend. Recommended to store by primary key for speed and in case the friend's handle changes. Store in the emails table from my handle to their handle the subject, body, and binary data. Note: if myHandle is ignored by theirHandle, then the function fails. See AddToIgnoreList. More...
struct | Friends_RejectInvite
Removes from the database the pending add friend invite. Operation completes even if ignored. Unless ignored, store in the emails table from my handle to their handle the subject, body, binary data, and procedure type flag. More...
struct | Friends_GetInvites
Returns all invites for this user. More...
struct | Friends_GetFriends
Gets all friends to this user. More...
struct | Friends_Remove
Ends a friendship between two users. Remove from the database the friend entry between my handle and their handle. As with accept add friend invite, this is bidirectional. Either user can terminate the friendship. Store in the emails table from my handle to their handle the subject, body, and binary data, and procedure type flag. More...
struct | BookmarkedUsers_Add
Remembers a user, with a type integer and description for you to use, if desired. More...
struct | BookmarkedUsers_Remove
Remove a user added with BookmarkedUsers_Add. More...
struct | BookmarkedUsers_Get
Returns all users added to BookmarkedUsers_Add. More...
struct | Emails_Send
Adds to an emails table from myHandle (store primary key) to recipient handles (store primary key) the specified subject, body, and binary data. Emails are persistent, therefore emails should be stored in a separate table and referenced by the user. Deleting the user does not delete previously send email. Emails should have an automatic timestamp to store when they were created. Email should be flagged as sent=true (boolean), markedRead=true (boolean), deletedBySender=false (boolean), deletedByReciever=false (boolean). More...
struct | Emails_Get
Returns emails as noted. Emails which were marked deleted are not returned. More...
struct | Emails_Delete
Deletes an email with a specified ID. This ID is returned in GetEmail and should uniquely identify an email (it's fine to use the primary key). Note: Emails are not actually deleted from the database in this function. This just sets the deletedBySender or deletedByReciever flags. Emails are actually stored in a log recording past emails and sender and receiver primary key. They are not truly destroyed until done so with System_PruneAccounts. More...
struct | Emails_SetStatus
Sets the status flag for an email. This is a property defined by and used by the user. More...
struct | Ranking_SubmitMatch
Will record in the database the results of a match. This will store in the database the the match which is defined by the the match notes, match id, winner and loser participant primary keys, winner and loser participant scores, and binary data. More...
struct | Ranking_GetMatches
Gets matches recorded with Ranking_SubmitMatch ordered from most recent to least recent. Each returned match has all columns submitted to Ranking_SubmitMatch, except binary data, which can be retrieved with Ranking_GetMatchBinaryData. Additionally, each returned match returns the primary key of each match, to be passed to Ranking_GetMatchBinaryData. More...
struct | Ranking_GetMatchBinaryData
Because of the large amount of binary data potentially returned, this function is used to retrieve binary data for a particular match. More...
struct | Ranking_GetTotalScore
When a match is submitted with Ranking_SubmitMatch, the total running score and number of matches played for each player for each game title and game mode combination should be recorded. Because matches can be pruned wth PruneMatches(), the total score sum and number of scores submitted should be stored, rather than summed up from prior submitted matches. More...
struct | Ranking_WipeScoresForPlayer
Resets the sum of all submitted scores to 0, the number of scores submitted to 0. More...
struct | Ranking_WipeMatches
Deletes all matches submitted with submit match. Also deletes all scores for all players associated with this titleName and gameType (e.g. same thing that WipeScoresForPlayer does, but for all players). More...
struct | Ranking_PruneMatches
Will delete all matches submitted with SubmitMatch over PruneTime days old. Will also prune matches if the total storage space of all matches exceeds PruneSizeMB megabytes in the database. More...
struct | Ranking_UpdateRating
Add or update a rating for a user, in a particular game and game mode. More...
struct | Ranking_WipeRatings
Deletes all ratings for all players for this combination of titleName and gameType. More...
struct | Ranking_GetRating
Get rating for a player. More...
struct | Clans_Create
userHandle updates the clanDescription and clanBinaryData of a clan with the specified clanHandle. userHandle must be the clan leader. More...
struct | Clans_SetProperties
userHandle updates the clanDescription and clanBinaryData of a clan with the specified clanHandle. userHandle must be the clan leader. More...
struct | Clans_GetProperties
Returns clanDescription and clanBinaryData for the given clan. More...
struct | Clans_SetMyMemberProperties
Each member of each clan has the the properties clanMemberDescription and clanMemberBinaryData which default to empty. These properties can be set here, and retrieved via GetClanMemberProperties. More...
struct | Clans_GrantLeader
myPrimaryKey becomes a subleader. newLeaderHandle becomes the leader. An email is sent with Emails_Send() to all members with the specified subject and body More...
struct | Clans_SetSubleaderStatus
Promotes a clan member to a subleader, or demotes a subleader to a regular member. On promotion, email is sent to all members from myPrimary key with the specified subject and body. On demotion, email is sent to all leaders from myPrimary key with the specified subject and body. More...
struct | Clans_SetMemberRank
Lets the clan leader set the rank property for a clan member. More...
struct | Clans_GetMemberProperties
Returns properties for a clan member of a given clan. More...
struct | Clans_ChangeHandle
Renames the clan. Note that this may be called asynchronously, in which case the stored procedure should account for this occuring at the same time as another function that uses the old clan handle. More...
struct | Clans_Leave
Remove user identified by myPrimaryKey from clan identified by clanHandle. More...
struct | Clans_Get
Returns all clans that userHandle is a member of. Clans and clan members should be sorted by name, using ascending or descending sort as specified. More...
struct | Clans_SendJoinInvitation
if myPrimaryKey is a leader or subleader of clanHandle, and invitedUserHandle is a valid user not already invited to this clan, add this user to the invite table. The invite table contains the clan, who send the invite, and who the invite was sent to, and when it was sent. Invites expire after expiration time in seconds. Also, use Emails_Send() to send an email from myPrimaryKey to invitedUserHandle with the specified subject and body. More...
struct | Clans_WithdrawJoinInvitation
if myPrimaryKey is a leader or subleader of clanHandle, and invitedUserHandle is a valid user with an invite to this clan, remove this invite. Also, use Emails_Send() to send an email from myPrimaryKey to invitedUserHandle with the specified subject and body. More...
struct | Clans_AcceptJoinInvitation
If myPrimaryKey has an invitation to the specified clan, add him to the clan. Fail on specified output parameters. Use Emails_Send() to send an email from myPrimaryKey to all clan members with the specified subject and body. More...
struct | Clans_RejectJoinInvitation
If we have an open clan invitation, reject it (just delete it from the database). More...
struct | Clans_DownloadInvitationList
Returns all invites sent by Clans_SendJoinInvitation that were not yet acted upon (withdrawn, accepted, rejected). More...
struct | Clans_SendJoinRequest
Function has two forms: More...
struct | Clans_WithdrawJoinRequest
Withdraws a previously sent clan join request via SendClanJoinRequest. Use Emails_Send() to send an email from myPrimaryKey to the clan leader and all subleaders with the specified subject and body. More...
struct | Clans_AcceptJoinRequest
A clan leader or subleader accepts a join request from requestingUserHandle to this clan. requestingUserHandle joins the clan as a regular member. Use Emails_Send() to send an email from requestingUserHandle to all clan members with the specified subject and body. More...
struct | Clans_RejectJoinRequest
Rejects a clan join request from requestingUserHandle. Send an email from myPrimaryKey to requestingUserHandle with the specified subject and body. More...
struct | Clans_DownloadRequestList
Returns all open requests this user has sent to clans, that have not yet acted upon (withdrawn, accepted, rejected, expired). More...
struct | Clans_KickAndBlacklistUser
Kicks a user from the clan and/or blacklists a user so they cannot join. Only a clan leader or subleader can perform this operation. The operation can only be performed on members of lower status (leader can perform on subleader or regular member or nonmember, subleader on regular members or nonmember). If a member is banned, they are added to the banned table which contains the member's primary key, which user banned them, and the reason. Email is sent from myPrimaryKey to all leaders if a clan member is banned. Emails is furthermore sent to all clan members if successfully kicked. More...
struct | Clans_UnblacklistUser
Removes a user from the blacklist for this clan. More...
struct | Clans_GetBlacklist
Returns a list of all members blacklisted from this clan. Each element in the list contains the handle of the user that did the ban, who was banned, when the user was banned, and the reason passed to ClanKickAndBlacklistUser. More...
struct | Clans_GetMembers
Returns all clan members for this clan. Each entry returned contains handle, description, binary data, status (leader, regular member, subleader). More...
struct | Clans_GetList
Returns all clans names. More...
struct | Clans_CreateBoard
Creates a new clan board for clan members to post in using AddPostToClanBoard. Clan boards are unique, and are destroyed when the clan is destroyed, or if DestroyClanBoard is called. More...
struct | Clans_DestroyBoard
Success, invalid parameter syntax, myPrimaryKey is not the leader or subleader of clanHandle, unknown myPrimaryKey, unknown clanHandle, unknown clanBoardName. More...
struct | Clans_CreateNewTopic
Each clan has a clan board that only clan members can post to. This adds a topic to the clan board. Posts should reference the primary key of the poster, so that even if the poster chagnes his or her handle, the post author is updated properly. Each post automatically stores the timestamp when it was created. Banned users may not add new posts to the clan board. More...
struct | Clans_ReplyToTopic
Replies to a topic created with Clans_CreateTopic(). If postId references a post within a topic, just add the reply to the last post. Banned users may not add new posts to the clan board. More...
struct | Clans_RemovePost
The clan leader or subleaders may remove posts or topics from a clan board. More...
struct | Clans_GetBoards
Gets clan boards created for clanHandle. Boards are returned if we are a clan member, or if allowPublicReads in Clans_CreateBoard() was passed as false. However, if we are banned from this clan, no boards are returned. More...
struct | Clans_GetTopics
Gets topics (posts that are not replies to other posts, created with Clans_CreateTopic()) for the specified clanHandle and clanBoardName. If we are not a clan member and the clan was created with allowPublicReads==false, then the user is not allowed to read topics. More...
struct | Clans_GetPosts
Gets all posts for a particular topic. If postId is not a topic but is instead a post in a topic, treat it as if the topic postId was passed. If we are not a clan member and the clan was created with allowPublicReads==false, then the user is not allowed to read topics. More...
class | Lobby2Plugin
Both Lobby2Server and Lobby2Client derive from this class. More...
struct | Lobby2Presence
struct | Lobby2ServerCommand
class | Lobby2Server
The base class for the lobby server, without database specific functionality. More...
class | Lobby2Server_PGSQL
PostgreSQL specific functionality to the lobby server. More...
struct | RoomsPluginFunc
Base class for rooms functionality. More...
struct | CreateRoom_Func
Create a room. Each user can be in at most one room, so will fail if the user is already in a room. More...
struct | EnterRoom_Func
Joins a room if possible. If not, creates a room. More...
struct | JoinByFilter_Func
Joins a room given the filter parameters and desired room member mode. More...
struct | LeaveRoom_Func
Leaves a room. You can leave at any time, even if the room is locked. More...
struct | GetInvitesToParticipant_Func
struct | SendInvite_Func
Sends an invitation to someone. More...
struct | AcceptInvite_Func
Accept an invitation from a user to a room. More...
struct | StartSpectating_Func
Begin spectating. Spectators are considered room members that are not playing the game, only watching. More...
struct | StopSpectating_Func
Stop spectating. This will rejoin the room as a player, using a reserved slot if we were invited, and a public slot if not or if there are no reserved slots. More...
struct | GrantModerator_Func
Give moderator to another player. Moderators cannot be spectators. More...
struct | ChangeSlotCounts_Func
Change the allowed slot counts for the room. Setting fewer slot counts than the number of players does not kick out players, though it may prevent changing spectator status. More...
struct | SetCustomRoomProperties_Func
Sets a table of user-defined room properties. More...
struct | GetRoomProperties_Func
Given a named room, return the properties of that room, including member list. More...
struct | ChangeRoomName_Func
Change the name of the room. More...
struct | SetHiddenFromSearches_Func
Set or unset the room hidden from searches. If a room is hidden from searches, it can only be joined through invitations. More...
struct | SetDestroyOnModeratorLeave_Func
Sets or unsets to destroy the room when the moderator leaves the room. More...
struct | SetReadyStatus_Func
Sets or unsets the user as flagged 'ready'. More...
struct | GetReadyStatus_Func
Gets the ready states for every user in the room, excluding spectators. More...
struct | SetRoomLockState_Func
Lock or unlock the room. More...
struct | GetRoomLockState_Func
Gets the lock state of the room. More...
struct | AreAllMembersReady_Func
If all members have been set to ready using SetReadyStatus_Func, this operation will set allReady to true. More...
struct | KickMember_Func
Kick a member out of the room. This will also automatically ban that member from rejoining as long as the moderator does not change, or the member is unbanned. More...
struct | UnbanMember_Func
Allow a member previously kicked out of the room to rejoin. More...
struct | GetBanReason_Func
For a given room, get the reason parameter of KickMember_Func when we were kicked out. More...
struct | AddUserToQuickJoin_Func
Enter quick join mode. More...
struct | RemoveUserFromQuickJoin_Func
Leave quick join mode. More...
struct | IsInQuickJoin_Func
Returns if you are waiting in quick join mode. More...
struct | SearchByFilter_Func
Return all rooms that pass the roomQuery filter. More...
struct | ChangeHandle_Func
Change your handle. More...
struct | Chat_Func
Send a chat message. More...
struct | Bitstream_Func
Send an arbitrary binary message. More...
struct | RoomsPluginNotification
Base class for notification callbacks. More...
struct | QuickJoinExpired_Notification
The quick join duration has expired without joining or creating any rooms. More...
struct | QuickJoinEnteredRoom_Notification
Quick join succeeded, and you are now in a room. More...
struct | RoomMemberStartedSpectating_Notification
Another room member has started spectating. More...
struct | RoomMemberStoppedSpectating_Notification
Another room member has stopped spectating. More...
struct | ModeratorChanged_Notification
The room has a new moderator (possibly you) More...
struct | SlotCountsSet_Notification
The slot counts in the room has changed. More...
struct | CustomRoomPropertiesSet_Notification
The custom properties for the room has changed. More...
struct | RoomNameSet_Notification
The name of the room has been changed. More...
struct | HiddenFromSearchesSet_Notification
The room is now hidden, or no longer hidden, from searches. More...
struct | RoomMemberReadyStatusSet_Notification
Another room member has changed their ready status. More...
struct | RoomLockStateSet_Notification
The room is now, or is no longer, locked. More...
struct | RoomMemberKicked_Notification
A room member has been kicked out of the room (possibly you) More...
struct | RoomMemberHandleSet_Notification
A room member has changed their handle. More...
struct | RoomMemberLeftRoom_Notification
struct | RoomMemberJoinedRoom_Notification
A room member has joined the room. More...
struct | RoomInvitationSent_Notification
You have received an invitation to a room. More...
struct | RoomInvitationWithdrawn_Notification
A previous room invitation is no longer valid (possibly due to moderator change, or the room no longer exists) More...
struct | RoomDestroyedOnModeratorLeft_Notification
The moderator has left the room, and everyone left is a spectator, or the room was set to be destroyed when the moderator leftYou are no longer in the room. More...
struct | Chat_Notification
You got a chat message from another user. More...
struct | Bitstream_Notification
You got a generic bitstream message from another user. More...
class | RoomsPlugin
Used to create rooms for players where they can matchmake. More...
class | AutopatcherMySQLRepository
class | RPC3
The RPC3 plugin allows you to call remote functions as if they were local functions, using the standard function call syntax. More...
class | SQLite3PluginResultInterface
Handles results of calls to SQLite3Plugin::_sqlite3_exec() Results from calling SQLite3Plugin::_sqlite3_exec() are handled in this callback. You should implement the callback, and let the plugin know about it via SQLite3Plugin::AddResultHandler() Be sure to call SQLite3Plugin::RemoveResultHandler() or SQLite3Plugin::ClearResultHandlers() if you delete the callback. More...
class | SQLite3PluginResultInterface_Printf
class | SQLite3ClientPlugin
class | SQLite3ServerPlugin
Exec SQLLite commands over the network. More...

Typedefs

typedef uint24_t | MessageNumberType
typedef MessageNumberType | OrderingIndexType
typedef unsigned char | UniqueIDType
typedef unsigned char | MessageID
First byte of a network message.
typedef uint8_t | WorldId
typedef unsigned char | TeamId
typedef unsigned char | NoTeamId
A subcategory of not being on a team. For example, 0 may mean no team for a player, while 1 may mean no team for a spectator. Defined by the user.
typedef uint16_t | TeamMemberLimit

Enumerations

enum NATTypeDetectionResult {
NAT_TYPE_NONE, NAT_TYPE_FULL_CONE, NAT_TYPE_ADDRESS_RESTRICTED, NAT_TYPE_PORT_RESTRICTED,
NAT_TYPE_SYMMETRIC, NAT_TYPE_UNKNOWN, NAT_TYPE_DETECTION_IN_PROGRESS, NAT_TYPE_SUPPORTS_UPNP
}
All possible types of NATs (except NAT_TYPE_COUNT, which is an internal value) More...
enum | PluginReceiveResult { RR_STOP_PROCESSING_AND_DEALLOCATE =0, RR_CONTINUE_PROCESSING, RR_STOP_PROCESSING }
enum | PI2_LostConnectionReason { LCR_CLOSED_BY_USER, LCR_DISCONNECTION_NOTIFICATION, LCR_CONNECTION_LOST }
enum | PI2_FailedConnectionAttemptReason
enum | RackspaceEventType
Result codes for Rackspace commands /sa Rackspace::EventTypeToString()
enum RNSPerSecondMetrics {
USER_MESSAGE_BYTES_PUSHED, USER_MESSAGE_BYTES_SENT, USER_MESSAGE_BYTES_RESENT, USER_MESSAGE_BYTES_RECEIVED_PROCESSED,
USER_MESSAGE_BYTES_RECEIVED_IGNORED, ACTUAL_BYTES_SENT, ACTUAL_BYTES_RECEIVED
}
enum ConnectionState {
IS_PENDING, IS_CONNECTING, IS_CONNECTED, IS_DISCONNECTING,
IS_SILENTLY_DISCONNECTING, IS_DISCONNECTED, IS_NOT_CONNECTED
}
Returned from RakPeerInterface::GetConnectionState() More...
enum | PublicKeyMode { PKM_INSECURE_CONNECTION, PKM_ACCEPT_ANY_PUBLIC_KEY, PKM_USE_KNOWN_PUBLIC_KEY, PKM_USE_TWO_WAY_AUTHENTICATION }
Used with the PublicKey structure. More...
enum ReadyEventSystemStatus {
RES_NOT_WAITING, RES_WAITING, RES_READY, RES_ALL_READY,
RES_UNKNOWN_EVENT
}
enum RM3ConstructionState {
RM3CS_SEND_CONSTRUCTION, RM3CS_ALREADY_EXISTS_REMOTELY, RM3CS_ALREADY_EXISTS_REMOTELY_DO_NOT_CONSTRUCT, RM3CS_NEVER_CONSTRUCT,
RM3CS_NO_ACTION, RM3CS_MAX
}
Return codes for Connection_RM3::GetConstructionState() and Replica3::QueryConstruction() More...
enum | RM3DestructionState { RM3DS_SEND_DESTRUCTION, RM3DS_DO_NOT_QUERY_DESTRUCTION, RM3DS_NO_ACTION, RM3DS_MAX }
enum RM3SerializationResult {
RM3SR_BROADCAST_IDENTICALLY, RM3SR_BROADCAST_IDENTICALLY_FORCE_SERIALIZATION, RM3SR_SERIALIZED_UNIQUELY, RM3SR_SERIALIZED_ALWAYS,
RM3SR_SERIALIZED_ALWAYS_IDENTICALLY, RM3SR_DO_NOT_SERIALIZE, RM3SR_NEVER_SERIALIZE_FOR_THIS_CONNECTION, RM3SR_MAX
}
enum | RM3QuerySerializationResult { RM3QSR_CALL_SERIALIZE, RM3QSR_DO_NOT_CALL_SERIALIZE, RM3QSR_NEVER_CALL_SERIALIZE, RM3QSR_MAX }
enum Replica3P2PMode {
R3P2PM_SINGLE_OWNER, R3P2PM_MULTI_OWNER_CURRENTLY_AUTHORITATIVE, R3P2PM_MULTI_OWNER_NOT_CURRENTLY_AUTHORITATIVE, R3P2PM_STATIC_OBJECT_CURRENTLY_AUTHORITATIVE,
R3P2PM_STATIC_OBJECT_NOT_CURRENTLY_AUTHORITATIVE
}
enum RPCErrorCodes {
RPC_ERROR_FUNCTION_NOT_REGISTERED, RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RPC_ERROR_OBJECT_DOES_NOT_EXIST, RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE,
RPC_ERROR_FUNCTION_NOT_REGISTERED, RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RPC_ERROR_CALLING_CPP_AS_C, RPC_ERROR_CALLING_C_AS_CPP
}
Error codes returned by a remote system as to why an RPC function call cannot execute. More...
enum | JoinTeamType { JOIN_ANY_AVAILABLE_TEAM, JOIN_SPECIFIC_TEAM, JOIN_NO_TEAM }
enum | Lobby2MessageID
enum RPCErrorCodes {
RPC_ERROR_FUNCTION_NOT_REGISTERED, RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RPC_ERROR_OBJECT_DOES_NOT_EXIST, RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE,
RPC_ERROR_FUNCTION_NOT_REGISTERED, RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RPC_ERROR_CALLING_CPP_AS_C, RPC_ERROR_CALLING_C_AS_CPP
}
Error codes returned by a remote system as to why an RPC function call cannot execute. More...

Functions

int RAK_DLL_EXPORT | RegisteredCommandComp (const char *const &key, const RegisteredCommand &data)
List of commands registered with RegisterCommand()
RakNet::Time RAK_DLL_EXPORT | GetTime (void)
RakNet::TimeMS RAK_DLL_EXPORT | GetTimeMS (void)
RakNet::TimeUS RAK_DLL_EXPORT | GetTimeUS (void)
RAK_DLL_EXPORT bool | GreaterThan (RakNet::Time a, RakNet::Time b)
a > b?
RAK_DLL_EXPORT bool | LessThan (RakNet::Time a, RakNet::Time b)
a < b?
bool RAK_DLL_EXPORT | CanConnect (NATTypeDetectionResult type1, NATTypeDetectionResult type2)
RAK_DLL_EXPORT const char * | NATTypeDetectionResultToString (NATTypeDetectionResult type)
Return a technical string representin the enumeration.
RAK_DLL_EXPORT const char * | NATTypeDetectionResultToStringFriendly (NATTypeDetectionResult type)
void RAK_DLL_EXPORT | StatisticsToString (RakNetStatistics *s, char *buffer, int verbosityLevel)
__L2_MSG_DB_HEADER (Console_GetRoomDetails, Steam)
__L2_MSG_DB_HEADER (Console_CreateRoom, Steam)
__L2_MSG_DB_HEADER (Console_JoinRoom, Steam)
__L2_MSG_DB_HEADER (Console_LeaveRoom, Steam)
__L2_MSG_DB_HEADER (Console_SendRoomChatMessage, Steam)

Variables

const SystemAddress | UNASSIGNED_SYSTEM_ADDRESS
Index of an invalid SystemAddress.
const SystemIndex | UNASSIGNED_PLAYER_INDEX = 65535
Index of an unassigned player.
const NetworkID | UNASSIGNED_NETWORK_ID = (uint64_t) -1
Unassigned object ID.

Detailed Description

Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Forward declaration.

See Also
AutopatcherClient class for database driven patching, including binary deltas and search by date.

To use, first set the path to your application. For example "C:/Games/MyRPG/"
To allow other systems to download files, call AddUploadsFromSubdirectory, where the parameter is a path relative
to the path to your application. This includes subdirectories.
For example:
SetApplicationDirectory("C:/Games/MyRPG/");
AddUploadsFromSubdirectory("Mods/Skins/");
would allow downloads from
"C:/Games/MyRPG/Mods/Skins/*.*" as well as "C:/Games/MyRPG/Mods/Skins/Level1/*.*"
It would NOT allow downloads from C:/Games/MyRPG/Levels, nor would it allow downloads from C:/Windows
While pathToApplication can be anything you want, applicationSubdirectory must match either partially or fully between systems.

Typedef Documentation

typedef uint24_t RakNet::MessageNumberType

This is the counter used for holding packet numbers, so we can detect duplicate packets. It should be large enough that if the variables Internally assumed to be 4 bytes, but written as 3 bytes in ReliabilityLayer::WriteToBitStreamFromInternalPacket

typedef MessageNumberType RakNet::OrderingIndexType

This is the counter used for holding ordered packet numbers, so we can detect out-of-order packets. It should be large enough that if the variables were to wrap, the newly wrapped values would no longer be in use. Warning: Too large of a value wastes bandwidth!

typedef unsigned char RakNet::UniqueIDType
See Also
NetworkIDObject.h

Enumeration Type Documentation

enum RakNet::ConnectionState

Returned from RakPeerInterface::GetConnectionState()

Enumerator:
IS_PENDING

Connect() was called, but the process hasn't started yet.

IS_CONNECTING

Processing the connection attempt.

IS_CONNECTED

Is connected and able to communicate.

IS_DISCONNECTING

Was connected, but will disconnect as soon as the remaining messages are delivered.

IS_SILENTLY_DISCONNECTING

A connection attempt failed and will be aborted.

IS_DISCONNECTED

No longer connected.

IS_NOT_CONNECTED

Was never connected, or else was disconnected long enough ago that the entry has been discarded.

enum RakNet::NATTypeDetectionResult

All possible types of NATs (except NAT_TYPE_COUNT, which is an internal value)

Enumerator:
NAT_TYPE_NONE

Works with anyone.

NAT_TYPE_FULL_CONE

Accepts any datagrams to a port that has been previously used. Will accept the first datagram from the remote peer.

NAT_TYPE_ADDRESS_RESTRICTED

Accepts datagrams to a port as long as the datagram source IP address is a system we have already sent to. Will accept the first datagram if both systems send simultaneously. Otherwise, will accept the first datagram after we have sent one datagram.

NAT_TYPE_PORT_RESTRICTED

Same as address-restricted cone NAT, but we had to send to both the correct remote IP address and correct remote port. The same source address and port to a different destination uses the same mapping.

NAT_TYPE_SYMMETRIC

A different port is chosen for every remote destination. The same source address and port to a different destination uses a different mapping. Since the port will be different, the first external punchthrough attempt will fail. For this to work it requires port-prediction (MAX_PREDICTIVE_PORT_RANGE>1) and that the router chooses ports sequentially.

NAT_TYPE_UNKNOWN

Hasn't been determined. NATTypeDetectionClient does not use this, but other plugins might.

NAT_TYPE_DETECTION_IN_PROGRESS

In progress. NATTypeDetectionClient does not use this, but other plugins might.

NAT_TYPE_SUPPORTS_UPNP

Didn't bother figuring it out, as we support UPNP, so it is equivalent to NAT_TYPE_NONE. NATTypeDetectionClient does not use this, but other plugins might.

enum RakNet::PublicKeyMode

Used with the PublicKey structure.

Enumerator:
PKM_INSECURE_CONNECTION

The connection is insecure. You can also just pass 0 for the pointer to PublicKey in RakPeerInterface::Connect()

PKM_ACCEPT_ANY_PUBLIC_KEY

Accept whatever public key the server gives us. This is vulnerable to man in the middle, but does not require distribution of the public key in advance of connecting.

PKM_USE_KNOWN_PUBLIC_KEY

Use a known remote server public key. PublicKey::remoteServerPublicKey must be non-zero. This is the recommended mode for secure connections.

PKM_USE_TWO_WAY_AUTHENTICATION

Use a known remote server public key AND provide a public key for the connecting client. PublicKey::remoteServerPublicKey, myPublicKey and myPrivateKey must be all be non-zero. The server must cooperate for this mode to work. I recommend not using this mode except for server-to-server communication as it significantly increases the CPU requirements during connections for both sides. Furthermore, when it is used, a connection password should be used as well to avoid DoS attacks.

enum RakNet::RNSPerSecondMetrics
Enumerator:
USER_MESSAGE_BYTES_PUSHED

How many bytes per pushed via a call to RakPeerInterface::Send()

USER_MESSAGE_BYTES_SENT

How many user message bytes were sent via a call to RakPeerInterface::Send(). This is less than or equal to USER_MESSAGE_BYTES_PUSHED. A message would be pushed, but not yet sent, due to congestion control

USER_MESSAGE_BYTES_RESENT

How many user message bytes were resent. A message is resent if it is marked as reliable, and either the message didn't arrive or the message ack didn't arrive.

USER_MESSAGE_BYTES_RECEIVED_PROCESSED

How many user message bytes were received, and returned to the user successfully.

USER_MESSAGE_BYTES_RECEIVED_IGNORED

How many user message bytes were received, but ignored due to data format errors. This will usually be 0.

ACTUAL_BYTES_SENT

How many actual bytes were sent, including per-message and per-datagram overhead, and reliable message acks.

ACTUAL_BYTES_RECEIVED

How many actual bytes were received, including overead and acks.

Function Documentation

RakNet::__L2_MSG_DB_HEADER | ( | Console_GetRoomDetails | ,
 |  | Steam |
 | ) |  |

Input

Output

RakNet::__L2_MSG_DB_HEADER | ( | Console_CreateRoom | ,
 |  | Steam |
 | ) |  |

Input If public, anyone can join. Else friends only

Output

RakNet::__L2_MSG_DB_HEADER | ( | Console_JoinRoom | ,
 |  | Steam |
 | ) |  |

Input

RakNet::__L2_MSG_DB_HEADER | ( | Console_LeaveRoom | ,
 |  | Steam |
 | ) |  |

Input

RakNet::__L2_MSG_DB_HEADER | ( | Console_SendRoomChatMessage | ,
 |  | Steam |
 | ) |  |

Input

bool RAK_DLL_EXPORT RakNet::CanConnect | ( | NATTypeDetectionResult | type1,
 |  | NATTypeDetectionResult | type2
 | ) |  |
Returns
Can one system with NATTypeDetectionResult type1 connect to type2
RakNet::Time RAK_DLL_EXPORT RakNet::GetTime ( void )

Same as GetTimeMS Holds the time in either a 32 or 64 bit variable, depending on __GET_TIME_64BIT

RakNet::TimeMS RAK_DLL_EXPORT RakNet::GetTimeMS ( void )

Return the time as 32 bit

Note
The maximum delta between returned calls is 1 second - however, RakNet calls this constantly anyway. See NormalizeTime() in the cpp.
RakNet::TimeUS RAK_DLL_EXPORT RakNet::GetTimeUS ( void )

Return the time as 64 bit

Note
The maximum delta between returned calls is 1 second - however, RakNet calls this constantly anyway. See NormalizeTime() in the cpp.
RAK_DLL_EXPORT const char* RakNet::NATTypeDetectionResultToStringFriendly ( NATTypeDetectionResult type )

Return a friendly string representing the enumeration None and relaxed can connect to anything Moderate can connect to moderate or less Strict can connect to relaxed or less

void RAK_DLL_EXPORT RakNet::StatisticsToString | ( | RakNetStatistics * | s,
 |  | char * | buffer,
 |  | int | verbosityLevel
 | ) |  |

Verbosity level currently supports 0 (low), 1 (medium), 2 (high)

Parameters
[in] | s | The Statistical information to format out
[in] | buffer | The buffer containing a formated report
[in] | verbosityLevel | 0 low 1 medium 2 high 3 debugging congestion control
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: FileListTransfer

Classes
FileListTransfer
Plugins

A plugin to provide a simple way to compress and incrementally send the files in the FileList structure. More...

Classes

class RakNet::FileListTransfer
A plugin to provide a simple way to compress and incrementally send the files in the FileList structure. More...

Detailed Description

A plugin to provide a simple way to compress and incrementally send the files in the FileList structure.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::FileListTransfer Class Reference

  • FileListTransfer
Public Member Functions | List of all members
RakNet::FileListTransfer Class Reference
FileListTransfer

A plugin to provide a simple way to compress and incrementally send the files in the FileList structure. More...

#include <FileListTransfer.h>

Inheritance diagram for RakNet::FileListTransfer:
RakNet::PluginInterface2

Public Member Functions

void | StartIncrementalReadThreads (int numThreads, int threadPriority=-99999)
Optionally start worker threads when using _incrementalReadInterface for the Send() operation.
unsigned short | SetupReceive (FileListTransferCBInterface *handler, bool deleteHandler, SystemAddress allowedSender)
Allows one corresponding Send() call from another system to arrive.
void | Send (FileList *fileList, RakNet::RakPeerInterface *rakPeer, SystemAddress recipient, unsigned short setID, PacketPriority priority, char orderingChannel, IncrementalReadInterface *_incrementalReadInterface=0, unsigned int _chunkSize=262144 *4 *16)
Send the FileList structure to another system, which must have previously called SetupReceive().
unsigned int | GetPendingFilesToAddress (SystemAddress recipient)
Return number of files waiting to go out to a particular address.
void | CancelReceive (unsigned short setId)
Stop a download.
void | RemoveReceiver (SystemAddress systemAddress)
Remove all handlers associated with a particular system address.
bool | IsHandlerActive (unsigned short setId)
Is a handler passed to SetupReceive still running?
void | AddCallback (FileListProgress *cb)
Adds a callback to get progress reports about what the file list instances do.
void | RemoveCallback (FileListProgress *cb)
Removes a callback.
void | ClearCallbacks (void)
Removes all callbacks.
void | GetCallbacks (DataStructures::List< FileListProgress * > &callbacks)
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | Update (void)
Update is called every time a packet is checked for .
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Detailed Description

A plugin to provide a simple way to compress and incrementally send the files in the FileList structure.

Similar to the DirectoryDeltaTransfer plugin, except that it doesn't send deltas based on pre-existing files or actually write the files to disk.

Usage: Call SetupReceive to allow one file set to arrive. The value returned by FileListTransfer::SetupReceive()
is the setID that is allowed.
It's up to you to transmit this value to the other system, along with information indicating what kind of files you want to get.
The other system should then prepare a FileList and call FileListTransfer::Send(), passing the return value of FileListTransfer::SetupReceive()
as the setID parameter to FileListTransfer::Send()

Member Function Documentation

void RakNet::FileListTransfer::AddCallback ( FileListProgress * cb )

Adds a callback to get progress reports about what the file list instances do.

Parameters
[in] cb A pointer to an externally defined instance of FileListProgress. This pointer is held internally, so should remain valid as long as this class is valid.
void RakNet::FileListTransfer::GetCallbacks ( DataStructures::List< FileListProgress * > & callbacks )

Returns all callbacks added with AddCallback()

Parameters
[out] callbacks The list is set to the list of callbacks
virtual void RakNet::FileListTransfer::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
virtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::FileListTransfer::OnReceive ( Packet * packet )
virtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

void RakNet::FileListTransfer::RemoveCallback ( FileListProgress * cb )

Removes a callback.

Parameters
[in] cb A pointer to an externally defined instance of FileListProgress that was previously added with AddCallback()
void RakNet::FileListTransfer::Send | ( | FileList * | fileList,
 |  | RakNet::RakPeerInterface * | rakPeer,
 |  | SystemAddress | recipient,
 |  | unsigned short | setID,
 |  | PacketPriority | priority,
 |  | char | orderingChannel,
 |  | IncrementalReadInterface * | _incrementalReadInterface = 0,
 |  | unsigned int | _chunkSize = 262144 *4 *16
 | ) |  |

Send the FileList structure to another system, which must have previously called SetupReceive().

Parameters
[in] | fileList | A list of files. The data contained in FileList::data will be sent incrementally and compressed among all files in the set
[in] | rakPeer | The instance of RakNet to use to send the message. Pass 0 to use the instance the plugin is attached to
[in] | recipient | The address of the system to send to
[in] | setID | The return value of SetupReceive() which was previously called on recipient
[in] | priority | Passed to RakPeerInterface::Send()
[in] | orderingChannel | Passed to RakPeerInterface::Send()
[in] | _incrementalReadInterface | If a file in fileList has no data, _incrementalReadInterface will be used to read the file in chunks of size chunkSize
[in] | _chunkSize | How large of a block of a file to read/send at once. Large values use more memory but transfer slightly faster.
unsigned short RakNet::FileListTransfer::SetupReceive | ( | FileListTransferCBInterface * | handler,
 |  | bool | deleteHandler,
 |  | SystemAddress | allowedSender
 | ) |  |

Allows one corresponding Send() call from another system to arrive.

Parameters
[in] | handler | The class to call on each file
[in] | deleteHandler | True to delete the handler when it is no longer needed. False to not do so.
[in] | allowedSender | Which system to allow files from.
Returns
A set ID value, which should be passed as the setID value to the Send() call on the other system. This value will be returned in the callback and is unique per file set. Returns 65535 on failure (not connected to sender)
void RakNet::FileListTransfer::StartIncrementalReadThreads | ( | int | numThreads,
 |  | int | threadPriority = -99999
 | ) |  |

Optionally start worker threads when using _incrementalReadInterface for the Send() operation.

Parameters
[in] | numThreads | how many worker threads to start
[in] | threadPriority | Passed to the thread creation routine. Use THREAD_PRIORITY_NORMAL for Windows. For Linux based systems, you MUST pass something reasonable based on the thread priorities for your application.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/FileListTransfer.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: MessageFilter

Classes
MessageFilter
Plugins

Remote incoming packets from unauthorized systems. More...

Classes

class RakNet::MessageFilter
Assigns systems to FilterSets. Each FilterSet limits what kinds of messages are allowed. More...

Detailed Description

Remote incoming packets from unauthorized systems.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::MessageFilter Class Reference

  • MessageFilter
Public Member Functions | List of all members
RakNet::MessageFilter Class Reference
MessageFilter

Assigns systems to FilterSets. Each FilterSet limits what kinds of messages are allowed. More...

#include <MessageFilter.h>

Inheritance diagram for RakNet::MessageFilter:
RakNet::PluginInterface2

Public Member Functions

void | SetAutoAddNewConnectionsToFilter (int filterSetID)
void | SetAllowMessageID (bool allow, int messageIDStart, int messageIDEnd, int filterSetID)
void | SetAllowRPC4 (bool allow, const char *uniqueID, int filterSetID)
void | SetActionOnDisallowedMessage (bool kickOnDisallowed, bool banOnDisallowed, RakNet::TimeMS banTimeMS, int filterSetID)
void | SetDisallowedMessageCallback (int filterSetID, void *userData, void(*invalidMessageCallback)(RakPeerInterface *peer, AddressOrGUID addressOrGUID, int filterSetID, void *userData, unsigned char messageID))
void | SetTimeoutCallback (int filterSetID, void *userData, void(*invalidMessageCallback)(RakPeerInterface *peer, AddressOrGUID addressOrGUID, int filterSetID, void *userData))
void | SetFilterMaxTime (int allowedTimeMS, bool banOnExceed, RakNet::TimeMS banTimeMS, int filterSetID)
int | GetSystemFilterSet (AddressOrGUID addressOrGUID)
void | SetSystemFilterSet (AddressOrGUID addressOrGUID, int filterSetID)
unsigned | GetSystemCount (int filterSetID) const
unsigned | GetFilterSetCount (void) const
int | GetFilterSetIDByIndex (unsigned index)
void | DeleteFilterSet (int filterSetID)
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Detailed Description

Assigns systems to FilterSets. Each FilterSet limits what kinds of messages are allowed.

The MessageFilter plugin is used for security where you limit what systems can send what kind of messages.
You implicitly define FilterSets, and add allowed message IDs to these FilterSets.
You then add systems to these filters, such that those systems are limited to sending what the filters allows.
You can automatically assign systems to a filter.
You can automatically kick and possibly ban users that stay in a filter too long, or send the wrong message.
Each system is a member of either zero or one filters.
Add this plugin before any plugin you wish to filter (most likely just add this plugin before any other).

Member Function Documentation

void RakNet::MessageFilter::DeleteFilterSet ( int filterSetID )

Delete a FilterSet. All systems formerly subscribed to this filter are now unrestricted.

Parameters
[in] filterSetID The ID of the filter set to delete.
unsigned RakNet::MessageFilter::GetFilterSetCount ( void ) const

Returns the total number of filter sets.

Returns
The total number of filter sets.
int RakNet::MessageFilter::GetFilterSetIDByIndex ( unsigned index )

Returns the ID of a filter set, by index

Parameters
[in] An index between 0 and GetFilterSetCount()-1 inclusive
unsigned RakNet::MessageFilter::GetSystemCount ( int filterSetID ) const

Returns the number of systems subscribed to a particular filter set Using anything other than -1 for filterSetID is slow, so you should store the returned value.

Parameters
[in] filterSetID The filter set to limit to. Use -1 for none (just returns the total number of filter systems in that case).
int RakNet::MessageFilter::GetSystemFilterSet ( AddressOrGUID addressOrGUID )

Get the filterSetID a system is using. Returns -1 for none.

Parameters
[in] addressOrGUID The system we are referring to
virtual void RakNet::MessageFilter::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
virtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual void RakNet::MessageFilter::OnNewConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | bool | isIncoming
 | ) |  |
virtual

Called when we got a new connection

Parameters
[in] | systemAddress | Address of the new connection
[in] | rakNetGuid | The guid of the specified system
[in] | isIncoming | If true, this is ID_NEW_INCOMING_CONNECTION, or the equivalent

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::MessageFilter::OnReceive ( Packet * packet )
virtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

void RakNet::MessageFilter::SetActionOnDisallowedMessage | ( | bool | kickOnDisallowed,
 |  | bool | banOnDisallowed,
 |  | RakNet::TimeMS | banTimeMS,
 |  | int | filterSetID
 | ) |  |

What action to take on a disallowed message. You can kick or not. You can add them to the ban list for some time By default no action is taken. The message is simply ignored. param[in] 0 for permanent ban, >0 for ban time in milliseconds.

Parameters
[in] | kickOnDisallowed | kick the system that sent a disallowed message.
[in] | banOnDisallowed | ban the system that sent a disallowed message. See banTimeMS for the ban duration
[in] | banTimeMS | Passed to the milliseconds parameter of RakPeer::AddToBanList.
[in] | filterSetID | A user defined ID to represent a filter set. If no filter with this ID exists, one will be created with default settings.
void RakNet::MessageFilter::SetAllowMessageID | ( | bool | allow,
 |  | int | messageIDStart,
 |  | int | messageIDEnd,
 |  | int | filterSetID
 | ) |  |

Allow a range of message IDs Always allowed by default: ID_CONNECTION_REQUEST_ACCEPTED through ID_DOWNLOAD_PROGRESS Usually you specify a range to make it easier to add new enumerations without having to constantly refer back to this function.

Parameters
[in] | allow | True to allow this message ID, false to disallow. By default, all messageIDs except the noted types are disallowed. This includes messages from other plugins!
[in] | messageIDStart | The first ID_* message to allow in the range. Inclusive.
[in] | messageIDEnd | The last ID_* message to allow in the range. Inclusive.
[in] | filterSetID | A user defined ID to represent a filter set. If no filter with this ID exists, one will be created with default settings.
void RakNet::MessageFilter::SetAllowRPC4 | ( | bool | allow,
 |  | const char * | uniqueID,
 |  | int | filterSetID
 | ) |  |

Allow a specific RPC4 call

Precondition
MessageFilter must be attached before RPC4
Parameters
[in] | uniqueID | Identifier passed to RegisterFunction()
[in] | filterSetID | A user defined ID to represent a filter set. If no filter with this ID exists, one will be created with default settings.
void RakNet::MessageFilter::SetAutoAddNewConnectionsToFilter ( int filterSetID )

Automatically add all new systems to a particular filter Defaults to -1

Parameters
[in] filterSetID Which filter to add new systems to. <0 for do not add.
void RakNet::MessageFilter::SetDisallowedMessageCallback | ( | int | filterSetID,
 |  | void * | userData,
 |  | void(*)(RakPeerInterface *peer, AddressOrGUID addressOrGUID, int filterSetID, void *userData, unsigned char messageID) | invalidMessageCallback
 | ) |  |

Set a user callback to be called on an invalid message for a particular filterSet

Parameters
[in] | filterSetID | A user defined ID to represent a filter set. If no filter with this ID exists, one will be created with default settings.
[in] | userData | A pointer passed with the callback
[in] | invalidMessageCallback | A pointer to a C function to be called back with the specified parameters.
void RakNet::MessageFilter::SetFilterMaxTime | ( | int | allowedTimeMS,
 |  | bool | banOnExceed,
 |  | RakNet::TimeMS | banTimeMS,
 |  | int | filterSetID
 | ) |  |

Limit how long a connection can stay in a particular filterSetID. After this time, the connection is kicked and possibly banned. By default there is no limit to how long a connection can stay in a particular filter set.

Parameters
[in] | allowedTimeMS | How many milliseconds to allow a connection to stay in this filter set.
[in] | banOnExceed | True or false to ban the system, or not, when allowedTimeMS is exceeded
[in] | banTimeMS | Passed to the milliseconds parameter of RakPeer::AddToBanList.
[in] | filterSetID | A user defined ID to represent a filter set. If no filter with this ID exists, one will be created with default settings.
void RakNet::MessageFilter::SetSystemFilterSet | ( | AddressOrGUID | addressOrGUID,
 |  | int | filterSetID
 | ) |  |

Assign a system to a filter set. Systems are automatically added to filter sets (or not) based on SetAutoAddNewConnectionsToFilter() This function is used to change the filter set a system is using, to add it to a new filter set, or to remove it from all existin filter sets.

Parameters
[in] | addressOrGUID | The system we are referring to
[in] | filterSetID | A user defined ID to represent a filter set. If no filter with this ID exists, one will be created with default settings. If -1, the system will be removed from all filter sets.
void RakNet::MessageFilter::SetTimeoutCallback | ( | int | filterSetID,
 |  | void * | userData,
 |  | void(*)(RakPeerInterface *peer, AddressOrGUID addressOrGUID, int filterSetID, void *userData) | invalidMessageCallback
 | ) |  |

Set a user callback to be called when a user is disconnected due to SetFilterMaxTime

Parameters
[in] | filterSetID | A user defined ID to represent a filter set. If no filter with this ID exists, one will be created with default settings.
[in] | userData | A pointer passed with the callback
[in] | invalidMessageCallback | A pointer to a C function to be called back with the specified parameters.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/MessageFilter.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: NatPunchthrough

Classes
NatPunchthrough
Plugins

Connect systems despite both systems being behind a router. More...

Classes

class | RakNet::NatPunchthroughClient
Client code for NATPunchthrough. More...
class | RakNet::NatPunchthroughServer
Server code for NATPunchthrough. More...
class | RakNet::UDPForwarder
Forwards UDP datagrams. Independent of RakNet's protocol. More...
class | RakNet::UDPProxyCoordinator
Middleman between UDPProxyServer and UDPProxyClient, maintaining a list of UDPProxyServer, and managing state for clients to find an available forwarding server. More...

Detailed Description

Connect systems despite both systems being behind a router.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::NatPunchthroughClient Class Reference

  • NatPunchthroughClient
Public Member Functions | List of all members
RakNet::NatPunchthroughClient Class Reference
NatPunchthrough

Client code for NATPunchthrough. More...

#include <NatPunchthroughClient.h>

Inheritance diagram for RakNet::NatPunchthroughClient:
RakNet::PluginInterface2

Public Member Functions

void | FindRouterPortStride (const SystemAddress &facilitator)
bool | OpenNAT (RakNetGUID destination, const SystemAddress &facilitator)
PunchthroughConfiguration * | GetPunchthroughConfiguration (void)
void | SetDebugInterface (NatPunchthroughDebugInterface *i)
void | GetUPNPPortMappings (char *externalPort, char *internalPort, const SystemAddress &natPunchthroughServerAddress)
Get the port mappings you should pass to UPNP (for miniupnpc-1.6.20120410, for the function UPNP_AddPortMapping)
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Detailed Description

Client code for NATPunchthrough.

Maintain connection to NatPunchthroughServer to process incoming connection attempts through NatPunchthroughClient
Client will send datagrams to port to estimate next port
Will simultaneously connect with another client once ports are estimated.

See Also
NatTypeDetectionClient See also http://www.jenkinssoftware.com/raknet/manual/natpunchthrough.html

Member Function Documentation

void RakNet::NatPunchthroughClient::FindRouterPortStride ( const SystemAddress & facilitator )

If the instance of RakPeer running NATPunchthroughServer was bound to two IP addresses, then you can call FindRouterPortStride() This will determine the stride that your router uses when assigning ports, if your router is full-cone This function is also called automatically when you call OpenNAT - however, calling it earlier when you are connected to the facilitator will speed up the process

Parameters
[in] destination The system to punch. Must already be connected to facilitator
PunchthroughConfiguration* RakNet::NatPunchthroughClient::GetPunchthroughConfiguration ( void )

Modify the system configuration if desired Don't modify the variables in the structure while punchthrough is in progress

virtual void RakNet::NatPunchthroughClient::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
virtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual void RakNet::NatPunchthroughClient::OnNewConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | bool | isIncoming
 | ) |  |
virtual

Called when we got a new connection

Parameters
[in] | systemAddress | Address of the new connection
[in] | rakNetGuid | The guid of the specified system
[in] | isIncoming | If true, this is ID_NEW_INCOMING_CONNECTION, or the equivalent

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::NatPunchthroughClient::OnReceive ( Packet * packet )
virtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

bool RakNet::NatPunchthroughClient::OpenNAT | ( | RakNetGUID | destination,
 |  | const SystemAddress & | facilitator
 | ) |  |

Punchthrough a NAT. Doesn't connect, just tries to setup the routing table

Parameters
[in] | destination | The system to punch. Must already be connected to facilitator
[in] | facilitator | A system we are already connected to running the NatPunchthroughServer plugin
See Also
OpenNATGroup() You will get ID_NAT_PUNCHTHROUGH_SUCCEEDED on success You will get ID_NAT_TARGET_NOT_CONNECTED, ID_NAT_TARGET_UNRESPONSIVE, ID_NAT_CONNECTION_TO_TARGET_LOST, ID_NAT_ALREADY_IN_PROGRESS, or ID_NAT_PUNCHTHROUGH_FAILED on failures of various types However, if you lose connection to the facilitator, you may not necessarily get above
void RakNet::NatPunchthroughClient::SetDebugInterface ( NatPunchthroughDebugInterface * i )

Sets a callback to be called with debug messages

Parameters
[in] i Pointer to an interface. The pointer is stored, so don't delete it while in progress. Pass 0 to clear.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/NatPunchthroughClient.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::NatPunchthroughServer Class Reference

  • NatPunchthroughServer
Public Member Functions | List of all members
RakNet::NatPunchthroughServer Class Reference
NatPunchthrough

Server code for NATPunchthrough. More...

#include <NatPunchthroughServer.h>

Inheritance diagram for RakNet::NatPunchthroughServer:
RakNet::PluginInterface2

Public Member Functions

void | SetDebugInterface (NatPunchthroughServerDebugInterface *i)
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Detailed Description

Server code for NATPunchthrough.

Maintain connection to NatPunchthroughServer to process incoming connection attempts through NatPunchthroughClient
Server maintains two sockets clients can connect to so as to estimate the next port choice
Server tells other client about port estimate, current public port to the server, and a time to start connection attempts

See Also
NatTypeDetectionClient See also http://www.jenkinssoftware.com/raknet/manual/natpunchthrough.html

Member Function Documentation

virtual void RakNet::NatPunchthroughServer::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
virtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual void RakNet::NatPunchthroughServer::OnNewConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | bool | isIncoming
 | ) |  |
virtual

Called when we got a new connection

Parameters
[in] | systemAddress | Address of the new connection
[in] | rakNetGuid | The guid of the specified system
[in] | isIncoming | If true, this is ID_NEW_INCOMING_CONNECTION, or the equivalent

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::NatPunchthroughServer::OnReceive ( Packet * packet )
virtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

void RakNet::NatPunchthroughServer::SetDebugInterface ( NatPunchthroughServerDebugInterface * i )

Sets a callback to be called with debug messages

Parameters
[in] i Pointer to an interface. The pointer is stored, so don't delete it while in progress. Pass 0 to clear.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/NatPunchthroughServer.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::UDPForwarder Class Reference

  • UDPForwarder
Public Member Functions | List of all members
RakNet::UDPForwarder Class Reference
NatPunchthrough

Forwards UDP datagrams. Independent of RakNet's protocol. More...

#include <UDPForwarder.h>

Public Member Functions

void | Startup (void)
void | Shutdown (void)
Stops the system, and frees all sockets.
void | SetMaxForwardEntries (unsigned short maxEntries)
int | GetMaxForwardEntries (void) const
int | GetUsedForwardEntries (void) const
UDPForwarderResult | StartForwarding (SystemAddress source, SystemAddress destination, RakNet::TimeMS timeoutOnNoDataMS, const char *forceHostAddress, unsigned short socketFamily, unsigned short *forwardingPort, __UDPSOCKET__ *forwardingSocket)
void | StopForwarding (SystemAddress source, SystemAddress destination)

Detailed Description

Forwards UDP datagrams. Independent of RakNet's protocol.

Member Function Documentation

int RakNet::UDPForwarder::GetMaxForwardEntries ( void ) const
Returns
The maxEntries parameter passed to SetMaxForwardEntries(), or the default if it was never called
int RakNet::UDPForwarder::GetUsedForwardEntries ( void ) const
Returns
How many entries have been used
void RakNet::UDPForwarder::SetMaxForwardEntries ( unsigned short maxEntries )

Sets the maximum number of forwarding entries allowed Set according to your available bandwidth and the estimated average bandwidth per forwarded address.

Parameters
[in] maxEntries The maximum number of simultaneous forwarding entries. Defaults to 64 (32 connections)
UDPForwarderResult RakNet::UDPForwarder::StartForwarding | ( | SystemAddress | source,
 |  | SystemAddress | destination,
 |  | RakNet::TimeMS | timeoutOnNoDataMS,
 |  | const char * | forceHostAddress,
 |  | unsigned short | socketFamily,
 |  | unsigned short * | forwardingPort,
 |  | __UDPSOCKET__ * | forwardingSocket
 | ) |  |

Forwards datagrams from source to destination, and vice-versa Does nothing if this forward entry already exists via a previous call

Precondition
Call Startup()
Note
RakNet's protocol will ensure a message is sent at least every 15 seconds, so if routing RakNet messages, it is a reasonable value for timeoutOnNoDataMS, plus an some extra seconds for latency
Parameters
[in] | source | The source IP and port
[in] | destination | Where to forward to (and vice-versa)
[in] | timeoutOnNoDataMS | If no messages are forwarded for this many MS, then automatically remove this entry.
[in] | forceHostAddress | Force binding on a particular address. 0 to use any.
[in] | socketFamily | IP version: For IPV4, use AF_INET (default). For IPV6, use AF_INET6. To autoselect, use AF_UNSPEC.
[out] | forwardingPort | New opened port for forwarding
[out] | forwardingSocket | New opened socket for forwarding
Returns
UDPForwarderResult
void RakNet::UDPForwarder::Startup ( void )

Starts the system. Required to call before StartForwarding

void RakNet::UDPForwarder::StopForwarding | ( | SystemAddress | source,
 |  | SystemAddress | destination
 | ) |  |

No longer forward datagrams from source to destination

Parameters
[in] | source | The source IP and port
[in] | destination | Where to forward to
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/UDPForwarder.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::UDPProxyCoordinator Class Reference

  • UDPProxyCoordinator
Public Member Functions | List of all members
RakNet::UDPProxyCoordinator Class Reference
NatPunchthrough

Middleman between UDPProxyServer and UDPProxyClient, maintaining a list of UDPProxyServer, and managing state for clients to find an available forwarding server. More...

#include <UDPProxyCoordinator.h>

Inheritance diagram for RakNet::UDPProxyCoordinator:
RakNet::PluginInterface2

Public Member Functions

void | SetRemoteLoginPassword (RakNet::RakString password)
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Detailed Description

Middleman between UDPProxyServer and UDPProxyClient, maintaining a list of UDPProxyServer, and managing state for clients to find an available forwarding server.

When NAT Punchthrough fails, it is possible to use a non-NAT system to forward messages from us to the recipient, and vice-versa The class to forward messages is UDPForwarder, and it is triggered over the network via the UDPProxyServer plugin. The UDPProxyClient connects to UDPProxyCoordinator to get a list of servers running UDPProxyServer, and the coordinator will relay our forwarding request

Member Function Documentation

virtual void RakNet::UDPProxyCoordinator::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
virtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::UDPProxyCoordinator::OnReceive ( Packet * packet )
virtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

void RakNet::UDPProxyCoordinator::SetRemoteLoginPassword ( RakNet::RakString password )

For UDPProxyServers logging in remotely, they must pass a password to UDPProxyServer::LoginToCoordinator(). It must match the password set here. If no password is set, they cannot login remotely. By default, no password is set

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/UDPProxyCoordinator.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: NatTypeDetection

Classes
NatTypeDetection
Plugins

Use a remote server with multiple IP addresses to determine what type of NAT your router is using. More...

Classes

class | RakNet::NatTypeDetectionClient
Client code for NatTypeDetection. More...
class | RakNet::NatTypeDetectionServer
Server code for NatTypeDetection. More...

Detailed Description

Use a remote server with multiple IP addresses to determine what type of NAT your router is using.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::NatTypeDetectionClient Class Reference

  • NatTypeDetectionClient
Public Member Functions | List of all members
RakNet::NatTypeDetectionClient Class Reference
NatTypeDetection

Client code for NatTypeDetection. More...

#include <NatTypeDetectionClient.h>

Inheritance diagram for RakNet::NatTypeDetectionClient:
RakNet::PluginInterface2

Public Member Functions

void | DetectNATType (SystemAddress _serverAddress)
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnDetach (void)
Called when the interface is detached.
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Detailed Description

Client code for NatTypeDetection.

See NatTypeDetectionServer.h for algorithm To use, just connect to the server, and call DetectNAT You will get back ID_NAT_TYPE_DETECTION_RESULT with one of the enumerated values of NATTypeDetectionResult found in NATTypeDetectionCommon.h See also http://www.jenkinssoftware.com/raknet/manual/natpunchthrough.html

See Also
NatPunchthroughClient
NatTypeDetectionServer

Member Function Documentation

void RakNet::NatTypeDetectionClient::DetectNATType ( SystemAddress _serverAddress )

Send the message to the server to detect the nat type Server must be running NatTypeDetectionServer We must already be connected to the server

Parameters
[in] serverAddress address of the server
virtual void RakNet::NatTypeDetectionClient::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
virtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::NatTypeDetectionClient::OnReceive ( Packet * packet )
virtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/NatTypeDetectionClient.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::NatTypeDetectionServer Class Reference

  • NatTypeDetectionServer
Public Member Functions | List of all members
RakNet::NatTypeDetectionServer Class Reference
NatTypeDetection

Server code for NatTypeDetection. More...

#include <NatTypeDetectionServer.h>

Inheritance diagram for RakNet::NatTypeDetectionServer:
RakNet::PluginInterface2

Public Member Functions

void | Startup (const char *nonRakNetIP2, const char *nonRakNetIP3, const char *nonRakNetIP4)
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Detailed Description

Server code for NatTypeDetection.

Sends to a remote system on certain ports and addresses to determine what type of router, if any, that client is behind Requires that the server have 4 external IP addresses

  1. Server has 1 instance of RakNet. Server has four external ip addresses S1 to S4. Five ports are used in total P1 to P5. RakNet is bound to S1P1. Sockets are bound to S1P2, S2P3, S3P4, S4P5
  2. Client with one port using RakNet (C1). Another port not using anything (C2).
  3. C1 connects to S1P1 for normal communication.
  4. S4P5 sends to C2. If arrived, no NAT. Done. (If didn't arrive, S4P5 potentially banned, do not use again).
  5. S2P3 sends to C1 (Different address, different port, to previously used port on client). If received, Full-cone nat. Done. (If didn't arrive, S2P3 potentially banned, do not use again).
  6. S1P2 sends to C1 (Same address, different port, to previously used port on client). If received, address-restricted cone nat. Done.
  7. Server via RakNet connection tells C1 to send to to S3P4. If address of C1 as seen by S3P4 is the same as the address of C1 as seen by S1P1 (RakNet connection), then port-restricted cone nat. Done
  8. Else symmetric nat. Done.

See also http://www.jenkinssoftware.com/raknet/manual/natpunchthrough.html

See Also
NatPunchthroughServer
NatTypeDetectionClient

Member Function Documentation

virtual void RakNet::NatTypeDetectionServer::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
virtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::NatTypeDetectionServer::OnReceive ( Packet * packet )
virtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

void RakNet::NatTypeDetectionServer::Startup | ( | const char * | nonRakNetIP2,
 |  | const char * | nonRakNetIP3,
 |  | const char * | nonRakNetIP4
 | ) |  |

Start the system, binding to 3 external IPs not already in useS

Parameters
[in] | nonRakNetIP2 | First unused external IP
[in] | nonRakNetIP3 | Second unused external IP
[in] | nonRakNetIP4 | Third unused external IP
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/NatTypeDetectionServer.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: PacketLogger

Classes
PacketLogger
Plugins

Print out incoming messages to a target destination. More...

Classes

class | RakNet::PacketConsoleLogger
Packetlogger that logs to a remote command console. More...
class | RakNet::PacketFileLogger
Packetlogger that outputs to a file. More...
class | RakNet::PacketLogger
Writes incoming and outgoing messages to the screen. This will write all incoming and outgoing messages to the console window, or to a file if you override it and give it this functionality. More...
class | RakNet::PacketOutputWindowLogger
Packetlogger that outputs to the output window in the debugger. Windows only. More...
class | RakNet::ThreadsafePacketLogger
Same as PacketLogger, but writes output in the user thread. More...

Detailed Description

Print out incoming messages to a target destination.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::PacketConsoleLogger Class Reference

  • PacketConsoleLogger
Public Member Functions | List of all members
RakNet::PacketConsoleLogger Class Reference
PacketLogger

Packetlogger that logs to a remote command console. More...

#include <PacketConsoleLogger.h>

Inheritance diagram for RakNet::PacketConsoleLogger:
RakNet::PacketLogger RakNet::PluginInterface2

Public Member Functions

virtual void | WriteLog (const char *str)
Override this to log strings to wherever. Log should be threadsafe.
- Public Member Functions inherited from RakNet::PacketLogger
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
Events on low level sends and receives. These functions may be called from different threads at the same time.
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | LogHeader (void)
Logs out a header for all the data.
virtual void | SetPrefix (const char *_prefix)
Prepend this string to output logs.
virtual void | SetSuffix (const char *_suffix)
Append this string to output logs. (newline is useful here)
void | SetLogDirectMessages (bool send)
Log the direct sends and receives or not. Default true.
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)

Additional Inherited Members

- Protected Member Functions inherited from RakNet::PacketLogger
virtual bool UsesReliabilityLayer (void) const

Detailed Description

Packetlogger that logs to a remote command console.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/PacketConsoleLogger.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::PacketFileLogger Class Reference

  • PacketFileLogger
Public Member Functions | List of all members
RakNet::PacketFileLogger Class Reference
PacketLogger

Packetlogger that outputs to a file. More...

#include <PacketFileLogger.h>

Inheritance diagram for RakNet::PacketFileLogger:
RakNet::PacketLogger RakNet::PluginInterface2

Public Member Functions

virtual void | WriteLog (const char *str)
Override this to log strings to wherever. Log should be threadsafe.
- Public Member Functions inherited from RakNet::PacketLogger
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
Events on low level sends and receives. These functions may be called from different threads at the same time.
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | LogHeader (void)
Logs out a header for all the data.
virtual void | SetPrefix (const char *_prefix)
Prepend this string to output logs.
virtual void | SetSuffix (const char *_suffix)
Append this string to output logs. (newline is useful here)
void | SetLogDirectMessages (bool send)
Log the direct sends and receives or not. Default true.
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)

Additional Inherited Members

- Protected Member Functions inherited from RakNet::PacketLogger
virtual bool UsesReliabilityLayer (void) const

Detailed Description

Packetlogger that outputs to a file.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/PacketFileLogger.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::PacketLogger Class Reference

  • PacketLogger
Public Member Functions | Protected Member Functions | List of all members
RakNet::PacketLogger Class Reference
PacketLogger

Writes incoming and outgoing messages to the screen. This will write all incoming and outgoing messages to the console window, or to a file if you override it and give it this functionality. More...

#include <PacketLogger.h>

Inheritance diagram for RakNet::PacketLogger:
RakNet::PluginInterface2 RakNet::PacketConsoleLogger RakNet::PacketFileLogger RakNet::PacketOutputWindowLogger RakNet::ThreadsafePacketLogger

Public Member Functions

virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
Events on low level sends and receives. These functions may be called from different threads at the same time.
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | LogHeader (void)
Logs out a header for all the data.
virtual void | WriteLog (const char *str)
Override this to log strings to wherever. Log should be threadsafe.
virtual void | SetPrefix (const char *_prefix)
Prepend this string to output logs.
virtual void | SetSuffix (const char *_suffix)
Append this string to output logs. (newline is useful here)
void | SetLogDirectMessages (bool send)
Log the direct sends and receives or not. Default true.
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)

Protected Member Functions

virtual bool UsesReliabilityLayer (void) const

Detailed Description

Writes incoming and outgoing messages to the screen. This will write all incoming and outgoing messages to the console window, or to a file if you override it and give it this functionality.

Member Function Documentation

virtual void RakNet::PacketLogger::OnAck | ( | unsigned int | messageNumber,
 |  | SystemAddress | remoteSystemAddress,
 |  | RakNet::TimeMS | time
 | ) |  |
virtual

Called when we get an ack for a message we reliably sent

Precondition
To be called, UsesReliabilityLayer() must return true
Parameters
[in] | messageNumber | The numerical identifier for which message this is
[in] | remoteSystemAddress | The player we sent or got this packet from
[in] | time | The current time as returned by RakNet::GetTimeMS()

Reimplemented from RakNet::PluginInterface2.

virtual void RakNet::PacketLogger::OnDirectSocketReceive | ( | const char * | data,
 |  | const BitSize_t | bitsUsed,
 |  | SystemAddress | remoteSystemAddress
 | ) |  |
virtual

Called on a receive from the socket, per datagram, that does not go through the reliability layer

Precondition
To be called, UsesReliabilityLayer() must return true
Parameters
[in] | data | The data being sent
[in] | bitsUsed | How many bits long data is
[in] | remoteSystemAddress | Which system this message is being sent to

Reimplemented from RakNet::PluginInterface2.

virtual void RakNet::PacketLogger::OnInternalPacket | ( | InternalPacket * | internalPacket,
 |  | unsigned | frameNumber,
 |  | SystemAddress | remoteSystemAddress,
 |  | RakNet::TimeMS | time,
 |  | int | isSend
 | ) |  |
virtual

Called on a send or receive of a message within the reliability layer

Precondition
To be called, UsesReliabilityLayer() must return true
Parameters
[in] | internalPacket | The user message, along with all send data.
[in] | frameNumber | The number of frames sent or received so far for this player depending on isSend . Indicates the frame of this user message.
[in] | remoteSystemAddress | The player we sent or got this packet from
[in] | time | The current time as returned by RakNet::GetTimeMS()
[in] | isSend | Is this callback representing a send event or receive event?

Reimplemented from RakNet::PluginInterface2.

virtual void RakNet::PacketLogger::OnPushBackPacket | ( | const char * | data,
 |  | const BitSize_t | bitsUsed,
 |  | SystemAddress | remoteSystemAddress
 | ) |  |
virtual

System called RakPeerInterface::PushBackPacket

Parameters
[in] | data | The data being sent
[in] | bitsUsed | How many bits long data is
[in] | remoteSystemAddress | The player we sent or got this packet from

Reimplemented from RakNet::PluginInterface2.

virtual void RakNet::PacketLogger::OnReliabilityLayerNotification | ( | const char * | errorMessage,
 |  | const BitSize_t | bitsUsed,
 |  | SystemAddress | remoteSystemAddress,
 |  | bool | isError
 | ) |  |
virtual

Called when the reliability layer rejects a send or receive

Precondition
To be called, UsesReliabilityLayer() must return true
Parameters
[in] | bitsUsed | How many bits long data is
[in] | remoteSystemAddress | Which system this message is being sent to

Reimplemented from RakNet::PluginInterface2.

virtual bool RakNet::PacketLogger::UsesReliabilityLayer ( void ) const
inlineprotectedvirtual

Queried when attached to RakPeer Return true to call OnDirectSocketSend(), OnDirectSocketReceive(), OnReliabilityLayerNotification(), OnInternalPacket(), and OnAck() If true, then you cannot call RakPeer::AttachPlugin() or RakPeer::DetachPlugin() for this plugin, while RakPeer is active

Reimplemented from RakNet::PluginInterface2.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/PacketLogger.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::PacketOutputWindowLogger Class Reference

  • PacketOutputWindowLogger
Public Member Functions | List of all members
RakNet::PacketOutputWindowLogger Class Reference
PacketLogger

Packetlogger that outputs to the output window in the debugger. Windows only. More...

#include <PacketOutputWindowLogger.h>

Inheritance diagram for RakNet::PacketOutputWindowLogger:
RakNet::PacketLogger RakNet::PluginInterface2

Public Member Functions

virtual void | WriteLog (const char *str)
Override this to log strings to wherever. Log should be threadsafe.
- Public Member Functions inherited from RakNet::PacketLogger
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
Events on low level sends and receives. These functions may be called from different threads at the same time.
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | LogHeader (void)
Logs out a header for all the data.
virtual void | SetPrefix (const char *_prefix)
Prepend this string to output logs.
virtual void | SetSuffix (const char *_suffix)
Append this string to output logs. (newline is useful here)
void | SetLogDirectMessages (bool send)
Log the direct sends and receives or not. Default true.
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)

Additional Inherited Members

- Protected Member Functions inherited from RakNet::PacketLogger
virtual bool UsesReliabilityLayer (void) const

Detailed Description

Packetlogger that outputs to the output window in the debugger. Windows only.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/PacketOutputWindowLogger.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::ThreadsafePacketLogger Class Reference

  • ThreadsafePacketLogger
Public Member Functions | List of all members
RakNet::ThreadsafePacketLogger Class Reference
PacketLogger

Same as PacketLogger, but writes output in the user thread. More...

#include <ThreadsafePacketLogger.h>

Inheritance diagram for RakNet::ThreadsafePacketLogger:
RakNet::PacketLogger RakNet::PluginInterface2

Public Member Functions

virtual void | Update (void)
Update is called every time a packet is checked for .
- Public Member Functions inherited from RakNet::PacketLogger
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
Events on low level sends and receives. These functions may be called from different threads at the same time.
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | LogHeader (void)
Logs out a header for all the data.
virtual void | WriteLog (const char *str)
Override this to log strings to wherever. Log should be threadsafe.
virtual void | SetPrefix (const char *_prefix)
Prepend this string to output logs.
virtual void | SetSuffix (const char *_suffix)
Append this string to output logs. (newline is useful here)
void | SetLogDirectMessages (bool send)
Log the direct sends and receives or not. Default true.
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)

Additional Inherited Members

- Protected Member Functions inherited from RakNet::PacketLogger
virtual bool UsesReliabilityLayer (void) const

Detailed Description

Same as PacketLogger, but writes output in the user thread.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/ThreadsafePacketLogger.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNetTransport

Classes
RakNetTransport
Plugins

UDP based transport implementation for the ConsoleServer. More...

Classes

class RakNet::RakNetTransport2
Use RakNetTransport if you need a secure connection between the client and the console server. More...

Detailed Description

UDP based transport implementation for the ConsoleServer.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::RakNetTransport2 Class Reference

  • RakNetTransport2
Public Member Functions | List of all members
RakNet::RakNetTransport2 Class Reference
RakNetTransport

Use RakNetTransport if you need a secure connection between the client and the console server. More...

#include <RakNetTransport2.h>

Inheritance diagram for RakNet::RakNetTransport2:
RakNet::TransportInterface RakNet::PluginInterface2

Public Member Functions

bool | Start (unsigned short port, bool serverMode)
void | Stop (void)
Stop the transport provider. You can clear memory and shutdown threads here.
void | Send (SystemAddress systemAddress, const char *data,...)
void | CloseConnection (SystemAddress systemAddress)
Packet * | Receive (void)
void | DeallocatePacket (Packet *packet)
SystemAddress | HasNewIncomingConnection (void)
SystemAddress | HasLostConnection (void)
virtual CommandParserInterface * | GetCommandParser (void)
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Detailed Description

Use RakNetTransport if you need a secure connection between the client and the console server.

RakNetTransport automatically initializes security for the system. Use the project CommandConsoleClient to connect To the ConsoleServer if you use RakNetTransport

Member Function Documentation

void RakNet::RakNetTransport2::CloseConnection ( SystemAddress systemAddress )
virtual

Disconnect systemAddress . The binary address and port defines the SystemAddress structure.

Parameters
[in] systemAddress The player/address to disconnect

Implements RakNet::TransportInterface.

void RakNet::RakNetTransport2::DeallocatePacket ( Packet * packet )
virtual

Deallocate the Packet structure returned by Receive

Parameters
[in] The packet to deallocate

Implements RakNet::TransportInterface.

virtual CommandParserInterface* RakNet::RakNetTransport2::GetCommandParser ( void )
inlinevirtual

Your transport provider can itself have command parsers if the transport layer has user-modifiable features For example, your transport layer may have a password which you want remote users to be able to set or you may want to allow remote users to turn on or off command echo

Returns
0 if you do not need a command parser - otherwise the desired derivation of CommandParserInterface

Implements RakNet::TransportInterface.

SystemAddress RakNet::RakNetTransport2::HasLostConnection ( void )
virtual

If a system loses the connection, you should queue that event and return the systemAddress/address of that player in this function.

Returns
The SystemAddress/address of the system

Implements RakNet::TransportInterface.

SystemAddress RakNet::RakNetTransport2::HasNewIncomingConnection ( void )
virtual

If a new system connects to you, you should queue that event and return the systemAddress/address of that player in this function.

Returns
The SystemAddress/address of the system

Implements RakNet::TransportInterface.

virtual void RakNet::RakNetTransport2::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
virtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual void RakNet::RakNetTransport2::OnNewConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | bool | isIncoming
 | ) |  |
virtual

Called when we got a new connection

Parameters
[in] | systemAddress | Address of the new connection
[in] | rakNetGuid | The guid of the specified system
[in] | isIncoming | If true, this is ID_NEW_INCOMING_CONNECTION, or the equivalent

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::RakNetTransport2::OnReceive ( Packet * packet )
virtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

Packet* RakNet::RakNetTransport2::Receive ( void )
virtual

Return a string. The string should be allocated and written to Packet::data . The byte length should be written to Packet::length . The player/address should be written to Packet::systemAddress If your transport protocol adds special formatting to the data stream you should parse it out before returning it in the packet and thus only return a string in Packet::data

Returns
The packet structure containing the result of Receive, or 0 if no data is available

Implements RakNet::TransportInterface.

void RakNet::RakNetTransport2::Send | ( | SystemAddress | systemAddress,
 |  | const char * | data,
 |  |  | ...
 | ) |  |
virtual

Send a null-terminated string to systemAddress If your transport method requires particular formatting of the outgoing data (e.g. you don't just send strings) you can do it here and parse it out in Receive().

Parameters
[in] | systemAddress | The player to send the string to
[in] | data | format specifier - same as RAKNET_DEBUG_PRINTF
[in] ... format specification arguments - same as RAKNET_DEBUG_PRINTF

Implements RakNet::TransportInterface.

bool RakNet::RakNetTransport2::Start | ( | unsigned short | port,
 |  | bool | serverMode
 | ) |  |
virtual

Start the transport provider on the indicated port.

Parameters
[in] | port | The port to start the transport provider on
[in] | serverMode | If true, you should allow incoming connections (I don't actually use this anywhere)
Returns
Return true on success, false on failure.

Implements RakNet::TransportInterface.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/RakNetTransport2.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: ReadyEvent

Classes | Enumerations
ReadyEvent
Plugins

Peer to peer synchronized ready and unready events. More...

Classes

class RakNet::ReadyEvent
Peer to peer synchronized ready and unready events. More...

Enumerations

enum RakNet::ReadyEventSystemStatus {
RakNet::RES_NOT_WAITING, RakNet::RES_WAITING, RakNet::RES_READY, RakNet::RES_ALL_READY,
RakNet::RES_UNKNOWN_EVENT
}

Detailed Description

Peer to peer synchronized ready and unready events.

Enumeration Type Documentation

enum RakNet::ReadyEventSystemStatus

Returns the status of a remote system when querying with ReadyEvent::GetReadyStatus

Enumerator:
RES_NOT_WAITING

--------— Normal states ------------— The remote system is not in the wait list, and we have never gotten a ready or complete message from it. This is the default state for valid events

RES_WAITING

We are waiting for this remote system to call SetEvent(thisEvent,true).

RES_READY

The remote system called SetEvent(thisEvent,true), but it still waiting for other systems before completing the ReadyEvent.

RES_ALL_READY

The remote system called SetEvent(thisEvent,true), and is no longer waiting for any other systems. This remote system has completed the ReadyEvent

RES_UNKNOWN_EVENT

Error code, we couldn't look up the system because the event was unknown.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::ReadyEvent Class Reference

  • ReadyEvent
Public Member Functions | Protected Member Functions | List of all members
RakNet::ReadyEvent Class Reference
ReadyEvent

Peer to peer synchronized ready and unready events. More...

#include <ReadyEvent.h>

Inheritance diagram for RakNet::ReadyEvent:
RakNet::PluginInterface2

Public Member Functions

bool | SetEvent (int eventId, bool isReady)
void | ForceCompletion (int eventId)
bool | DeleteEvent (int eventId)
bool | IsEventSet (int eventId)
bool | IsEventCompletionProcessing (int eventId) const
bool | IsEventCompleted (int eventId) const
bool | HasEvent (int eventId)
unsigned | GetEventListSize (void) const
int | GetEventAtIndex (unsigned index) const
bool | AddToWaitList (int eventId, RakNetGUID guid)
bool | RemoveFromWaitList (int eventId, RakNetGUID guid)
bool | IsInWaitList (int eventId, RakNetGUID guid)
unsigned | GetRemoteWaitListSize (int eventId) const
RakNetGUID | GetFromWaitListAtIndex (int eventId, unsigned index) const
ReadyEventSystemStatus | GetReadyStatus (int eventId, RakNetGUID guid)
void | SetSendChannel (unsigned char newChannel)
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Protected Member Functions

virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.

Detailed Description

Peer to peer synchronized ready and unready events.

For peer to peer networks in a fully connected mesh.
Solves the problem of how to tell if all peers, relative to all other peers, are in a certain ready state.
For example, if A is connected to B and C, A may see that B and C are ready, but does not know if B is ready to C, or vice-versa.
This plugin uses two stages to solve that problem, first, everyone I know about is ready. Second, everyone I know about is ready to everyone they know about.
The user will get ID_READY_EVENT_SET and ID_READY_EVENT_UNSET as the signal flag is set or unset
The user will get ID_READY_EVENT_ALL_SET when all systems are done waiting for all other systems, in which case the event is considered complete, and no longer tracked.

See Also
FullyConnectedMesh2

Member Function Documentation

bool RakNet::ReadyEvent::AddToWaitList | ( | int | eventId,
 |  | RakNetGUID | guid
 | ) |  |

Adds a system to wait for to signal an event before considering the event complete and returning ID_READY_EVENT_ALL_SET. As we add systems, if this event was previously set to true with SetEvent, these systems will get ID_READY_EVENT_SET. As these systems disconnect (directly or indirectly through the router) they are removed.

Note
If the event completion process has already started, you cannot add more systems, as this would cause the completion process to fail
Parameters
[in] | eventId | A user-defined number previously passed to SetEvent that has not yet completed
[in] | guid | An address to wait for event replies from. Pass UNASSIGNED_SYSTEM_ADDRESS for all currently connected systems. Until all systems in this list have called SetEvent with this ID and true, and have this system in the list, we won't get ID_READY_EVENT_COMPLETE
Returns
True on success, false on unknown eventId (this should be considered an error)
bool RakNet::ReadyEvent::DeleteEvent ( int eventId )

Deletes an event. We will no longer wait for this event, and any systems that we know have set the event will be forgotten. Call this to clear memory when events are completed and you know you will never need them again.

Parameters
[in] eventId A user-defined identifier
Returns
True on success. False (failure) on unknown eventId
void RakNet::ReadyEvent::ForceCompletion ( int eventId )

When systems can call SetEvent() with isReady==false, it is possible for one system to return true from IsEventCompleted() while the other systems return false This can occur if a system SetEvent() with isReady==false while the completion message is still being transmitted. If your game has the situation where some action should be taken on all systems when IsEventCompleted() is true for any system, then call ForceCompletion() when the action begins. This will force all systems to return true from IsEventCompleted().

Parameters
[in] eventId A user-defined identifier to immediately set as completed
int RakNet::ReadyEvent::GetEventAtIndex ( unsigned index ) const

Returns the event ID stored at a particular index. EventIDs are stored sorted from least to greatest.

Parameters
[in] index Index into the array, from 0 to GetEventListSize()
Returns
The event ID stored at a particular index
unsigned RakNet::ReadyEvent::GetEventListSize ( void ) const

Returns the total number of events stored in the system.

Returns
The total number of events stored in the system.
RakNetGUID RakNet::ReadyEvent::GetFromWaitListAtIndex | ( | int | eventId,
 |  | unsigned | index
 | ) |  | const

Returns the system address of a system at a particular index, for this event.

Parameters
[in] | eventId | A user-defined identifier
[in] | index | Index into the array, from 0 to GetWaitListSize()
Returns
The system address of a system at a particular index, for this event.
ReadyEventSystemStatus RakNet::ReadyEvent::GetReadyStatus | ( | int | eventId,
 |  | RakNetGUID | guid
 | ) |  |

For a remote system, find out what their ready status is (waiting, signaled, complete).

Parameters
[in] | eventId | A user-defined identifier
[in] | guid | Which system we are checking up on
Returns
The status of this system, for this particular event.
See Also
ReadyEventSystemStatus
unsigned RakNet::ReadyEvent::GetRemoteWaitListSize ( int eventId ) const

Returns the total number of systems we are waiting on for this event. Does not include yourself

Parameters
[in] eventId A user-defined identifier
Returns
The total number of systems we are waiting on for this event.
bool RakNet::ReadyEvent::HasEvent ( int eventId )

Returns if this is a known event. Events may be known even if we never ourselves referenced them with SetEvent, because other systems created them via ID_READY_EVENT_SET.

Parameters
[in] eventId A user-defined identifier
Returns
true if we have this event, false otherwise
bool RakNet::ReadyEvent::IsEventCompleted ( int eventId ) const

Returns if the wait list is a subset of the completion list. Call this after all systems you want to wait for have been added with AddToWaitList If you are waiting for a specific number of systems (such as players later connecting), also check GetRemoteWaitListSize(eventId) to be equal to 1 less than the total number of participants.

Parameters
[in] eventId A user-defined identifier
Returns
True on completion. False (failure) on unknown eventId, or the set is not completed.
bool RakNet::ReadyEvent::IsEventCompletionProcessing ( int eventId ) const

Returns if the event is about to be ready and we are negotiating the final packets. This will usually only be true for a very short time, after which IsEventCompleted should return true. While this is true you cannot add to the wait list, or SetEvent() isReady to false anymore.

Parameters
[in] eventId A user-defined identifier
Returns
True if any other system has completed processing. Will always be true if IsEventCompleted() is true
bool RakNet::ReadyEvent::IsEventSet ( int eventId )

Returns what was passed to SetEvent()

Returns
The value of isReady passed to SetEvent(). Also returns false on unknown event.
bool RakNet::ReadyEvent::IsInWaitList | ( | int | eventId,
 |  | RakNetGUID | guid
 | ) |  |

Returns if a particular system is waiting on a particular event.

Parameters
[in] | eventId | A user-defined identifier
[in] | guid | The system we are checking up on
Returns
True if this system is waiting on this event, false otherwise.
virtual void RakNet::ReadyEvent::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
protectedvirtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::ReadyEvent::OnReceive ( Packet * packet )
protectedvirtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

bool RakNet::ReadyEvent::RemoveFromWaitList | ( | int | eventId,
 |  | RakNetGUID | guid
 | ) |  |

Removes systems from the wait list, which should have been previously added with AddToWaitList

Note
Systems that directly or indirectly disconnect from us are automatically removed from the wait list
Parameters
[in] guid The system to remove from the wait list. Pass UNASSIGNED_RAKNET_GUID for all currently connected systems.
Returns
True on success, false on unknown eventId (this should be considered an error)
bool RakNet::ReadyEvent::SetEvent | ( | int | eventId,
 |  | bool | isReady
 | ) |  |

Sets or updates the initial ready state for our local system. If eventId is an unknown event the event is created. If eventId was previously used and you want to reuse it, call DeleteEvent first, or else you will keep the same event signals from before Systems previously or later added through AddToWaitList() with the same eventId when isReady=true will get ID_READY_EVENT_SET Systems previously added through AddToWaitList with the same eventId will get ID_READY_EVENT_UNSET For both ID_READY_EVENT_SET and ID_READY_EVENT_UNSET, eventId is encoded in bytes 1 through 1+sizeof(int)

Parameters
[in] | eventId | A user-defined identifier to wait on. This can be a sequence counter, an event identifier, or anything else you want.
[in] | isReady | True to signal we are ready to proceed with this event, false to unsignal
Returns
False if event status is ID_READY_EVENT_FORCE_ALL_SET, or if we are setting to a status we are already in (no change). Otherwise true
void RakNet::ReadyEvent::SetSendChannel ( unsigned char newChannel )

This channel will be used for all RakPeer::Send calls

Parameters
[in] newChannel The channel to use for internal RakPeer::Send calls from this system. Defaults to 0.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/ReadyEvent.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RelayPlugin

Classes
RelayPlugin
Plugins

A simple class to relay messages from one system to another through an intermediary. More...

Classes

class RakNet::RelayPlugin
A simple class to relay messages from one system to another, identifying remote systems by a string. More...

Detailed Description

A simple class to relay messages from one system to another through an intermediary.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::RelayPlugin Class Reference

  • RelayPlugin
Public Member Functions | List of all members
RakNet::RelayPlugin Class Reference
RelayPlugin

A simple class to relay messages from one system to another, identifying remote systems by a string. More...

#include <RelayPlugin.h>

Inheritance diagram for RakNet::RelayPlugin:
RakNet::PluginInterface2

Public Member Functions

RelayPlugin ()
Constructor.
virtual | ~RelayPlugin ()
Destructor.
RelayPluginEnums | AddParticipantOnServer (const RakString &key, const RakNetGUID &guid)
Forward messages from any system, to the system specified by the combination of key and guid. The sending system only needs to know the key.
void | RemoveParticipantOnServer (const RakNetGUID &guid)
Remove a chat participant.
void | SetAcceptAddParticipantRequests (bool accept)
If true, then if the client calls AddParticipantRequestFromClient(), the server will call AddParticipantOnServer() automatically Defaults to false.
void | AddParticipantRequestFromClient (const RakString &key, const RakNetGUID &relayPluginServerGuid)
Request from the client for the server to call AddParticipantOnServer()
void | RemoveParticipantRequestFromClient (const RakNetGUID &relayPluginServerGuid)
Remove yourself as a participant.
void | SendToParticipant (const RakNetGUID &relayPluginServerGuid, const RakString &destinationGuid, BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel)
Request that the server relay bitStream to the system designated by key.
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Detailed Description

A simple class to relay messages from one system to another, identifying remote systems by a string.

Member Function Documentation

RelayPluginEnums RakNet::RelayPlugin::AddParticipantOnServer | ( | const RakString & | key,
 |  | const RakNetGUID & | guid
 | ) |  |

Forward messages from any system, to the system specified by the combination of key and guid. The sending system only needs to know the key.

Parameters
[in] | key | A string to identify the target's RakNetGUID. This is so the sending system does not need to know the RakNetGUID of the target system. The key should be unique among all guids added. If the key is not unique, only one system will be sent to (at random).
[in] | guid | The RakNetGuid of the system to send to. If this system disconnects, it is removed from the internal hash
Returns
RPE_ADD_CLIENT_TARGET_NOT_CONNECTED, RPE_ADD_CLIENT_NAME_ALREADY_IN_USE, or RPE_ADD_CLIENT_OK
void RakNet::RelayPlugin::AddParticipantRequestFromClient | ( | const RakString & | key,
 |  | const RakNetGUID & | relayPluginServerGuid
 | ) |  |

Request from the client for the server to call AddParticipantOnServer()

Precondition
The server must have called SetAcceptAddParticipantRequests(true) or the request will be ignored
Parameters
[in] | key | A string to identify out system. Passed to key on AddParticipantOnServer()
[in] | relayPluginServerGuid | the RakNetGUID of the system running RelayPlugin
virtual void RakNet::RelayPlugin::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
virtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::RelayPlugin::OnReceive ( Packet * packet )
virtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

void RakNet::RelayPlugin::SendToParticipant | ( | const RakNetGUID & | relayPluginServerGuid,
 |  | const RakString & | destinationGuid,
 |  | BitStream * | bitStream,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel
 | ) |  |

Request that the server relay bitStream to the system designated by key.

Parameters
[in] | relayPluginServerGuid | the RakNetGUID of the system running RelayPlugin
[in] | destinationGuid | The key value passed to AddParticipant() earlier on the server. If this was not done, the server will not relay the message (it will be silently discarded).
[in] | bitStream | The data to relay
[in] | priority | See the parameter of the same name in RakPeerInterface::Send()
[in] | reliability | See the parameter of the same name in RakPeerInterface::Send()
[in] | orderingChannel | See the parameter of the same name in RakPeerInterface::Send()
void RakNet::RelayPlugin::SetAcceptAddParticipantRequests ( bool accept )

If true, then if the client calls AddParticipantRequestFromClient(), the server will call AddParticipantOnServer() automatically Defaults to false.

Parameters
[in] accept true to accept, false to not.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/RelayPlugin.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: ReplicaManager3

Classes | Typedefs | Enumerations
ReplicaManager3
Plugins

Third implementation of object replication. More...

Classes

class | RakNet::ReplicaManager3
System to help automate game object construction, destruction, and serialization. More...
struct | RakNet::LastSerializationResult
struct | RakNet::SerializeParameters
class | RakNet::Connection_RM3
Each remote system is represented by Connection_RM3. Used to allocate Replica3 and track which instances have been allocated. More...
class | RakNet::Replica3
Base class for your replicated objects for the ReplicaManager3 system. More...

Typedefs

typedef uint8_t RakNet::WorldId

Enumerations

enum RakNet::RM3ConstructionState {
RakNet::RM3CS_SEND_CONSTRUCTION, RakNet::RM3CS_ALREADY_EXISTS_REMOTELY, RakNet::RM3CS_ALREADY_EXISTS_REMOTELY_DO_NOT_CONSTRUCT, RakNet::RM3CS_NEVER_CONSTRUCT,
RakNet::RM3CS_NO_ACTION, RakNet::RM3CS_MAX
}
Return codes for Connection_RM3::GetConstructionState() and Replica3::QueryConstruction() More...
enum | RakNet::RM3DestructionState { RakNet::RM3DS_SEND_DESTRUCTION, RakNet::RM3DS_DO_NOT_QUERY_DESTRUCTION, RakNet::RM3DS_NO_ACTION, RakNet::RM3DS_MAX }
enum RakNet::RM3SerializationResult {
RakNet::RM3SR_BROADCAST_IDENTICALLY, RakNet::RM3SR_BROADCAST_IDENTICALLY_FORCE_SERIALIZATION, RakNet::RM3SR_SERIALIZED_UNIQUELY, RakNet::RM3SR_SERIALIZED_ALWAYS,
RakNet::RM3SR_SERIALIZED_ALWAYS_IDENTICALLY, RakNet::RM3SR_DO_NOT_SERIALIZE, RakNet::RM3SR_NEVER_SERIALIZE_FOR_THIS_CONNECTION, RakNet::RM3SR_MAX
}
enum | RakNet::RM3QuerySerializationResult { RakNet::RM3QSR_CALL_SERIALIZE, RakNet::RM3QSR_DO_NOT_CALL_SERIALIZE, RakNet::RM3QSR_NEVER_CALL_SERIALIZE, RakNet::RM3QSR_MAX }
enum RakNet::Replica3P2PMode {
RakNet::R3P2PM_SINGLE_OWNER, RakNet::R3P2PM_MULTI_OWNER_CURRENTLY_AUTHORITATIVE, RakNet::R3P2PM_MULTI_OWNER_NOT_CURRENTLY_AUTHORITATIVE, RakNet::R3P2PM_STATIC_OBJECT_CURRENTLY_AUTHORITATIVE,
RakNet::R3P2PM_STATIC_OBJECT_NOT_CURRENTLY_AUTHORITATIVE
}

Detailed Description

Third implementation of object replication.

Typedef Documentation

typedef uint8_t RakNet::WorldId

Used for multiple worlds. World 0 is created automatically by default

Used for multiple worlds.

Enumeration Type Documentation

enum RakNet::Replica3P2PMode

Used for Replica3::QueryConstruction_PeerToPeer() and Replica3::QuerySerialization_PeerToPeer() to describe how the object replicates between hosts

Enumerator:
R3P2PM_SINGLE_OWNER

The Replica3 instance is constructed and serialized by one system only. Example: Your avatar. No other player serializes or can create your avatar.

R3P2PM_MULTI_OWNER_CURRENTLY_AUTHORITATIVE

The Replica3 instance is constructed and/or serialized by different systems This system is currently in charge of construction and/or serialization Example: A pickup. When an avatar holds it, that avatar controls it. When it is on the ground, the host controls it.

R3P2PM_MULTI_OWNER_NOT_CURRENTLY_AUTHORITATIVE

The Replica3 instance is constructed and/or serialized by different systems Another system is in charge of construction and/or serialization, but this system may be in charge at a later time Example: A pickup held by another player. That player sends creation of that object to new connections, and serializes it until it is dropped.

R3P2PM_STATIC_OBJECT_CURRENTLY_AUTHORITATIVE

The Replica3 instance is a static object (already exists on the remote system). This system is currently in charge of construction and/or serialization

R3P2PM_STATIC_OBJECT_NOT_CURRENTLY_AUTHORITATIVE

The Replica3 instance is a static object (already exists on the remote system). Another system is in charge of construction and/or serialization, but this system may be in charge at a later time

enum RakNet::RM3ConstructionState

Return codes for Connection_RM3::GetConstructionState() and Replica3::QueryConstruction()

Indicates what state the object should be in for the remote system

Enumerator:
RM3CS_SEND_CONSTRUCTION

This object should exist on the remote system. Send a construction message if necessary If the NetworkID is already in use, it will not do anything If it is not in use, it will create the object, and then call DeserializeConstruction

RM3CS_ALREADY_EXISTS_REMOTELY

This object should exist on the remote system. The other system already has the object, and the object will never be deleted. This is true of objects that are loaded with the level, for example. Treat it as if it existed, without sending a construction message. Will call Serialize() and SerializeConstructionExisting() to the object on the remote system

RM3CS_ALREADY_EXISTS_REMOTELY_DO_NOT_CONSTRUCT

Same as RM3CS_ALREADY_EXISTS_REMOTELY but does not call SerializeConstructionExisting()

RM3CS_NEVER_CONSTRUCT

This object will never be sent to the target system This object will never be serialized from this system to the target system

RM3CS_NO_ACTION

Don't do anything this tick. Will query again next tick.

RM3CS_MAX

Max enum.

enum RakNet::RM3DestructionState

If this object already exists for this system, should it be removed?

Enumerator:
RM3DS_SEND_DESTRUCTION

This object should not exist on the remote system. Send a destruction message if necessary.

RM3DS_DO_NOT_QUERY_DESTRUCTION

This object will never be destroyed by a per-tick query. Don't call again.

RM3DS_NO_ACTION

Don't do anything this tick. Will query again next tick.

RM3DS_MAX

Max enum.

enum RakNet::RM3QuerySerializationResult

First pass at topology to see if an object should be serialized

Enumerator:
RM3QSR_CALL_SERIALIZE

Call Serialize() to see if this object should be serializable for this connection.

RM3QSR_DO_NOT_CALL_SERIALIZE

Do not call Serialize() this tick to see if this object should be serializable for this connection.

RM3QSR_NEVER_CALL_SERIALIZE

Never call Serialize() for this object and connection. This system will not serialize this object for this topology.

RM3QSR_MAX

Max enum.

enum RakNet::RM3SerializationResult

Return codes when constructing an object

Enumerator:
RM3SR_BROADCAST_IDENTICALLY

This object serializes identically no matter who we send to We also send it to every connection (broadcast). Efficient for memory, speed, and bandwidth but only if the object is always broadcast identically.

RM3SR_BROADCAST_IDENTICALLY_FORCE_SERIALIZATION

Same as RM3SR_BROADCAST_IDENTICALLY, but assume the object needs to be serialized, do not check with a memcmp Assume the object changed, and serialize it Use this if you know exactly when your object needs to change. Can be faster than RM3SR_BROADCAST_IDENTICALLY. An example of this is if every member variable has an accessor, changing a member sets a flag, and you check that flag in Replica3::QuerySerialization() The opposite of this is RM3SR_DO_NOT_SERIALIZE, in case the object did not change

RM3SR_SERIALIZED_UNIQUELY

Either this object serializes differently depending on who we send to or we send it to some systems and not others. Inefficient for memory and speed, but efficient for bandwidth However, if you don't know what to return, return this

RM3SR_SERIALIZED_ALWAYS

Do not compare against last sent value. Just send even if the data is the same as the last tick If the data is always changing anyway, or you want to send unreliably, this is a good method of serialization Can send unique data per connection if desired. If same data is sent to all connections, use RM3SR_SERIALIZED_ALWAYS_IDENTICALLY for even better performance Efficient for memory and speed, but not necessarily bandwidth

RM3SR_SERIALIZED_ALWAYS_IDENTICALLY
Deprecated:
, use RM3SR_BROADCAST_IDENTICALLY_FORCE_SERIALIZATION
RM3SR_DO_NOT_SERIALIZE

Do not serialize this object this tick, for this connection. Will query again next autoserialize timer.

RM3SR_NEVER_SERIALIZE_FOR_THIS_CONNECTION

Never serialize this object for this connection Useful for objects that are downloaded, and never change again Efficient

RM3SR_MAX

Max enum.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::ReplicaManager3 Class Reference

  • ReplicaManager3
Public Member Functions | Protected Member Functions | List of all members
RakNet::ReplicaManager3 Class Referenceabstract
ReplicaManager3

System to help automate game object construction, destruction, and serialization. More...

#include <ReplicaManager3.h>

Inheritance diagram for RakNet::ReplicaManager3:
RakNet::PluginInterface2

Public Member Functions

virtual Connection_RM3 * | AllocConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID) const =0
Implement to return a game specific derivation of Connection_RM3.
virtual void | DeallocConnection (Connection_RM3 *connection) const =0
Implement to destroy a class instanced returned by AllocConnection()
void | SetAutoManageConnections (bool autoCreate, bool autoDestroy)
Enable or disable automatically assigning connections to new instances of Connection_RM3.
bool | GetAutoCreateConnections (void) const
bool | GetAutoDestroyConnections (void) const
void | AutoCreateConnectionList (DataStructures::List< RakNetGUID > &participantListIn, DataStructures::List< Connection_RM3 * > &participantListOut, WorldId worldId=0)
Call AllocConnection() and PushConnection() for each connection in participantList.
bool | PushConnection (RakNet::Connection_RM3 *newConnection, WorldId worldId=0)
Track a new Connection_RM3 instance.
RakNet::Connection_RM3 * | PopConnection (RakNetGUID guid, WorldId worldId=0)
Stop tracking a connection.
void | Reference (RakNet::Replica3 *replica3, WorldId worldId=0)
Adds a replicated object to the system.
void | Dereference (RakNet::Replica3 *replica3, WorldId worldId=0)
Removes a replicated object from the system.
void | DereferenceList (DataStructures::List< Replica3 * > &replicaListIn, WorldId worldId=0)
Removes multiple replicated objects from the system.
void | GetReplicasCreatedByGuid (RakNetGUID guid, DataStructures::List< Replica3 * > &replicaListOut, WorldId worldId=0)
Returns all objects originally created by a particular system.
void | GetReplicasCreatedByMe (DataStructures::List< Replica3 * > &replicaListOut, WorldId worldId=0)
Returns all objects originally created by your system.
void | GetReferencedReplicaList (DataStructures::List< Replica3 * > &replicaListOut, WorldId worldId=0)
Returns the entire list of Replicas that we know about.
unsigned | GetReplicaCount (WorldId worldId=0) const
Returns the number of replicas known about.
Replica3 * | GetReplicaAtIndex (unsigned index, WorldId worldId=0)
Returns a replica by index.
unsigned int | GetConnectionCount (WorldId worldId=0) const
Returns the number of connections.
Connection_RM3 * | GetConnectionAtIndex (unsigned index, WorldId worldId=0) const
Returns a connection pointer previously added with PushConnection()
Connection_RM3 * | GetConnectionBySystemAddress (const SystemAddress &sa, WorldId worldId=0) const
Returns a connection pointer previously added with PushConnection()
Connection_RM3 * | GetConnectionByGUID (RakNetGUID guid, WorldId worldId=0) const
Returns a connection pointer previously added with PushConnection.()
void | SetDefaultOrderingChannel (char def)
void | SetDefaultPacketPriority (PacketPriority def)
void | SetDefaultPacketReliability (PacketReliability def)
void | SetAutoSerializeInterval (RakNet::Time intervalMS)
void | GetConnectionsThatHaveReplicaConstructed (Replica3 *replica, DataStructures::List< Connection_RM3 * > &connectionsThatHaveConstructedThisReplica, WorldId worldId=0)
Return the connections that we think have an instance of the specified Replica3 instance.
bool | GetAllConnectionDownloadsCompleted (WorldId worldId=0) const
Returns if GetDownloadWasCompleted() returns true for all connections.
void | AddWorld (WorldId worldId)
ReplicaManager3 can support multiple worlds, where each world has a separate NetworkIDManager, list of connections, replicas, etc A world with id 0 is created automatically. If you want multiple worlds, use this function, and ReplicaManager3::SetNetworkIDManager() to have a different NetworkIDManager instance per world.
void | RemoveWorld (WorldId worldId)
Deallocate a world added with AddWorld, or the default world with id 0 Deallocating a world will also stop tracking and updating all connections and replicas associated with that world.
WorldId | GetWorldIdAtIndex (unsigned int index)
Get one of the WorldId values added with AddWorld()
unsigned int | GetWorldCount (void) const
Returns the number of world id specifiers in memory, added with AddWorld() and removed with RemoveWorld()
void | SetNetworkIDManager (NetworkIDManager *_networkIDManager, WorldId worldId=0)
NetworkIDManager * | GetNetworkIDManager (WorldId worldId=0) const
void | BroadcastDestructionList (DataStructures::List< Replica3 * > &replicaListSource, const SystemAddress &exclusionAddress, WorldId worldId=0)
virtual void | Update (void)
Call interfaces, send data.
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Protected Member Functions

virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnDetach (void)
Called when the interface is detached.

Detailed Description

System to help automate game object construction, destruction, and serialization.

ReplicaManager3 tracks your game objects and automates the networking for replicating them across the network
As objects are created, destroyed, or serialized differently, those changes are pushed out to other systems.
To use:

  1. Derive from Connection_RM3 and implement Connection_RM3::AllocReplica(). This is a factory function where given a user-supplied identifier for a class (such as name) return an instance of that class. Should be able to return any networked object in your game.
  2. Derive from ReplicaManager3 and implement AllocConnection() and DeallocConnection() to return the class you created in step 1.
  3. Derive your networked game objects from Replica3. All pure virtuals have to be implemented, however defaults are provided for Replica3::QueryConstruction(), Replica3::QueryRemoteConstruction(), and Replica3::QuerySerialization() depending on your network architecture.
  4. When a new game object is created on the local system, pass it to ReplicaManager3::Reference().
  5. When a game object is destroyed on the local system, and you want other systems to know about it, call Replica3::BroadcastDestruction()

At this point, all new connections will automatically download, get construction messages, get destruction messages, and update serialization automatically.

Member Function Documentation

void RakNet::ReplicaManager3::AddWorld ( WorldId worldId )

ReplicaManager3 can support multiple worlds, where each world has a separate NetworkIDManager, list of connections, replicas, etc A world with id 0 is created automatically. If you want multiple worlds, use this function, and ReplicaManager3::SetNetworkIDManager() to have a different NetworkIDManager instance per world.

Parameters
[in] worldId A unique identifier for this world. User-defined
virtual Connection_RM3* RakNet::ReplicaManager3::AllocConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID
 | ) |  | const
 pure virtual

Implement to return a game specific derivation of Connection_RM3.

The connection object represents a remote system connected to you that is using the ReplicaManager3 system.
It has functions to perform operations per-connection.
AllocConnection() and DeallocConnection() are factory functions to create and destroy instances of the connection object.
It is used if autoCreate is true via SetAutoManageConnections() (true by default). Otherwise, the function is not called, and you will have to call PushConnection() manually

Note
If you do not want a new network connection to immediately download game objects, SetAutoManageConnections() and PushConnection() are how you do this.
See Also
SetAutoManageConnections()
Parameters
[in] | systemAddress | Address of the system you are adding
[in] | rakNetGUID | GUID of the system you are adding. See Packet::rakNetGUID or RakPeerInterface::GetGUIDFromSystemAddress()
Returns
The new connection instance.
void RakNet::ReplicaManager3::AutoCreateConnectionList | ( | DataStructures::List< RakNetGUID > & | participantListIn,
 |  | DataStructures::List< Connection_RM3 * > & | participantListOut,
 |  | WorldId | worldId = 0
 | ) |  |

Call AllocConnection() and PushConnection() for each connection in participantList.

Parameters
[in] | participantListIn | The list of connections to allocate
[in] | participantListOut | The connections allocated, if any
[in] | worldId | Used for multiple worlds. World 0 is created automatically by default. See AddWorld()
void RakNet::ReplicaManager3::BroadcastDestructionList | ( | DataStructures::List< Replica3 * > & | replicaListSource,
 |  | const SystemAddress & | exclusionAddress,
 |  | WorldId | worldId = 0
 | ) |  |

Send a network command to destroy one or more Replica3 instances Usually you won't need this, but use Replica3::BroadcastDestruction() instead. The objects are unaffected locally

Parameters
[in] | replicaList | List of Replica3 objects to tell other systems to destroy.
[in] | exclusionAddress | Which system to not send to. UNASSIGNED_SYSTEM_ADDRESS to send to all.
[in] | worldId | Used for multiple worlds. World 0 is created automatically by default. See AddWorld()
virtual void RakNet::ReplicaManager3::DeallocConnection ( Connection_RM3 * connection ) const
pure virtual

Implement to destroy a class instanced returned by AllocConnection()

Most likely just implement as {delete connection;}
It is used if autoDestroy is true via SetAutoManageConnections() (true by default). Otherwise, the function is not called and you would then be responsible for deleting your own connection objects.

Parameters
[in] connection The pointer instance to delete
void RakNet::ReplicaManager3::Dereference | ( | RakNet::Replica3 * | replica3,
 |  | WorldId | worldId = 0
 | ) |  |

Removes a replicated object from the system.

The object is not deallocated, it is up to the caller to do so.
This is called automatically from the destructor of Replica3, so you don't need to call it manually unless you want to stop tracking an object before it is destroyed.

Parameters
[in] | replica3 | The object to stop tracking
[in] | worldId | Used for multiple worlds. World 0 is created automatically by default. See AddWorld()
void RakNet::ReplicaManager3::DereferenceList | ( | DataStructures::List< Replica3 * > & | replicaListIn,
 |  | WorldId | worldId = 0
 | ) |  |

Removes multiple replicated objects from the system.

Same as Dereference(), but for a list of objects.
Useful with the lists returned by GetReplicasCreatedByGuid(), GetReplicasCreatedByMe(), or GetReferencedReplicaList().

Parameters
[in] | replicaListIn | List of objects
[in] | worldId | Used for multiple worlds. World 0 is created automatically by default. See AddWorld()
bool RakNet::ReplicaManager3::GetAllConnectionDownloadsCompleted ( WorldId worldId = 0 ) const

Returns if GetDownloadWasCompleted() returns true for all connections.

Parameters
[in] worldId Used for multiple worlds. World 0 is created automatically by default. See AddWorld()
Returns
True when all downloads have been completed
bool RakNet::ReplicaManager3::GetAutoCreateConnections ( void ) const
Returns
What was passed to the autoCreate parameter of SetAutoManageConnections()
bool RakNet::ReplicaManager3::GetAutoDestroyConnections ( void ) const
Returns
What was passed to the autoDestroy parameter of SetAutoManageConnections()
Connection_RM3* RakNet::ReplicaManager3::GetConnectionAtIndex | ( | unsigned | index,
 |  | WorldId | worldId = 0
 | ) |  | const

Returns a connection pointer previously added with PushConnection()

Parameters
[in] | index | An index, from 0 to GetConnectionCount()-1.
[in] | worldId | Used for multiple worlds. World 0 is created automatically by default. See AddWorld()
Returns
A Connection_RM3 pointer
Connection_RM3* RakNet::ReplicaManager3::GetConnectionByGUID | ( | RakNetGUID | guid,
 |  | WorldId | worldId = 0
 | ) |  | const

Returns a connection pointer previously added with PushConnection.()

Parameters
[in] | guid | The guid of the connection to return
[in] | worldId | Used for multiple worlds. World 0 is created automatically by default. See AddWorld()
Returns
A Connection_RM3 pointer, or 0 if not found
Connection_RM3* RakNet::ReplicaManager3::GetConnectionBySystemAddress | ( | const SystemAddress & | sa,
 |  | WorldId | worldId = 0
 | ) |  | const

Returns a connection pointer previously added with PushConnection()

Parameters
[in] | sa | The system address of the connection to return
[in] | worldId | Used for multiple worlds. World 0 is created automatically by default. See AddWorld()
Returns
A Connection_RM3 pointer, or 0 if not found
unsigned int RakNet::ReplicaManager3::GetConnectionCount ( WorldId worldId = 0 ) const

Returns the number of connections.

Returns the number of connections added with ReplicaManager3::PushConnection(), minus the number removed with ReplicaManager3::PopConnection()

Parameters
[in] worldId Used for multiple worlds. World 0 is created automatically by default. See AddWorld()
Returns
The number of registered connections
void RakNet::ReplicaManager3::GetConnectionsThatHaveReplicaConstructed | ( | Replica3 * | replica,
 |  | DataStructures::List< Connection_RM3 * > & | connectionsThatHaveConstructedThisReplica,
 |  | WorldId | worldId = 0
 | ) |  |

Return the connections that we think have an instance of the specified Replica3 instance.

This can be wrong, for example if that system locally deleted the outside the scope of ReplicaManager3, if QueryRemoteConstruction() returned false, or if DeserializeConstruction() returned false.

Parameters
[in] | replica | The replica to check against.
[in] | worldId | Used for multiple worlds. World 0 is created automatically by default. See AddWorld()
[out] | connectionsThatHaveConstructedThisReplica | Populated with connection instances that we believe have replica allocated
NetworkIDManager* RakNet::ReplicaManager3::GetNetworkIDManager ( WorldId worldId = 0 ) const

Returns what was passed to SetNetworkIDManager(), or the instance on RakPeerInterface if unset.

Parameters
[in] worldId Used for multiple worlds. World 0 is created automatically by default. See AddWorld()
void RakNet::ReplicaManager3::GetReferencedReplicaList | ( | DataStructures::List< Replica3 * > & | replicaListOut,
 |  | WorldId | worldId = 0
 | ) |  |

Returns the entire list of Replicas that we know about.

This is all Replica3 instances passed to Reference, as well as instances we downloaded and created via Connection_RM3::AllocReference()

Parameters
[out] | List | of Replica3 instances to be returned
[in] | worldId | Used for multiple worlds. World 0 is created automatically by default. See AddWorld()
Replica3* RakNet::ReplicaManager3::GetReplicaAtIndex | ( | unsigned | index,
 |  | WorldId | worldId = 0
 | ) |  |

Returns a replica by index.

Returns one of the items in the list that would be returned by GetReferencedReplicaList()

Parameters
[in] | index | An index, from 0 to GetReplicaCount()-1.
[in] | worldId | Used for multiple worlds. World 0 is created automatically by default. See AddWorld()
Returns
A Replica3 instance
unsigned RakNet::ReplicaManager3::GetReplicaCount ( WorldId worldId = 0 ) const

Returns the number of replicas known about.

Returns the size of the list that would be returned by GetReferencedReplicaList()

Parameters
[in] worldId Used for multiple worlds. World 0 is created automatically by default. See AddWorld()
Returns
How many replica objects are in the list of replica objects
void RakNet::ReplicaManager3::GetReplicasCreatedByGuid | ( | RakNetGUID | guid,
 |  | DataStructures::List< Replica3 * > & | replicaListOut,
 |  | WorldId | worldId = 0
 | ) |  |

Returns all objects originally created by a particular system.

Originally created is defined as the value of Replica3::creatingSystemGUID, which is automatically assigned in ReplicaManager3::Reference().
You do not have to be directly connected to that system to get the objects originally created by that system.

Parameters
[in] | guid | GUID of the system we are referring to. Originally passed as the guid parameter to ReplicaManager3::AllocConnection()
[out] | List | of Replica3 instances to be returned
[in] | worldId | Used for multiple worlds. World 0 is created automatically by default. See AddWorld()
void RakNet::ReplicaManager3::GetReplicasCreatedByMe | ( | DataStructures::List< Replica3 * > & | replicaListOut,
 |  | WorldId | worldId = 0
 | ) |  |

Returns all objects originally created by your system.

Calls GetReplicasCreatedByGuid() for your own system guid.

Parameters
[out] | List | of Replica3 instances to be returned
[in] | worldId | Used for multiple worlds. World 0 is created automatically by default. See AddWorld()
unsigned int RakNet::ReplicaManager3::GetWorldCount ( void ) const

Returns the number of world id specifiers in memory, added with AddWorld() and removed with RemoveWorld()

Returns
The number of worlds added
WorldId RakNet::ReplicaManager3::GetWorldIdAtIndex ( unsigned int index )

Get one of the WorldId values added with AddWorld()

WorldId 0 is created by default. Worlds will not necessarily be in the order added with AddWorld(). Edit RemoveWorld() changing RemoveAtIndexFast() to RemoveAtIndex() to preserve order.

Parameters
[in] index A value between 0 and GetWorldCount()-1
Returns
One of the WorldId values added with AddWorld()
virtual void RakNet::ReplicaManager3::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
protectedvirtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual void RakNet::ReplicaManager3::OnNewConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | bool | isIncoming
 | ) |  |
protectedvirtual

Called when we got a new connection

Parameters
[in] | systemAddress | Address of the new connection
[in] | rakNetGuid | The guid of the specified system
[in] | isIncoming | If true, this is ID_NEW_INCOMING_CONNECTION, or the equivalent

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::ReplicaManager3::OnReceive ( Packet * packet )
protectedvirtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

RakNet::Connection_RM3* RakNet::ReplicaManager3::PopConnection | ( | RakNetGUID | guid,
 |  | WorldId | worldId = 0
 | ) |  |

Stop tracking a connection.

On call, for each replica returned by GetReplicasCreatedByGuid(), QueryActionOnPopConnection() will be called. Depending on the return value, this may delete the corresponding replica.
If autoDestroy is true in the call to SetAutoManageConnections() (true by default) then this is called automatically when the connection is lost. In that case, the returned connection instance is deleted.

Parameters
[in] | guid | of the connection to get. Passed to ReplicaManager3::AllocConnection() originally.
[in] | worldId | Used for multiple worlds. World 0 is created automatically by default. See AddWorld()
bool RakNet::ReplicaManager3::PushConnection | ( | RakNet::Connection_RM3 * | newConnection,
 |  | WorldId | worldId = 0
 | ) |  |

Track a new Connection_RM3 instance.

If autoCreate is false for SetAutoManageConnections(), then you need this function to add new instances of Connection_RM3 yourself.
You don't need to track this pointer yourself, you can get it with GetConnectionAtIndex(), GetConnectionByGUID(), or GetConnectionBySystemAddress().

Parameters
[in] | newConnection | The new connection instance to track.
[in] | worldId | Used for multiple worlds. World 0 is created automatically by default. See AddWorld()
void RakNet::ReplicaManager3::Reference | ( | RakNet::Replica3 * | replica3,
 |  | WorldId | worldId = 0
 | ) |  |

Adds a replicated object to the system.

Anytime you create a new object that derives from Replica3, and you want ReplicaManager3 to use it, pass it to Reference().
Remote systems already connected will potentially download this object the next time ReplicaManager3::Update() is called, which happens every time you call RakPeerInterface::Receive().
You can also call ReplicaManager3::Update() manually to send referenced objects right away

Parameters
[in] | replica3 | The object to start tracking
[in] | worldId | Used for multiple worlds. World 0 is created automatically by default. See AddWorld()
void RakNet::ReplicaManager3::RemoveWorld ( WorldId worldId )

Deallocate a world added with AddWorld, or the default world with id 0 Deallocating a world will also stop tracking and updating all connections and replicas associated with that world.

Parameters
[in] worldId A worldId value previously added with AddWorld()
void RakNet::ReplicaManager3::SetAutoManageConnections | ( | bool | autoCreate,
 |  | bool | autoDestroy
 | ) |  |

Enable or disable automatically assigning connections to new instances of Connection_RM3.

ReplicaManager3 can automatically create and/or destroy Connection_RM3 as systems connect or disconnect from RakPeerInterface.
By default this is on, to make the system easier to learn and setup.
If you don't want all connections to take part in the game, or you want to delay when a connection downloads the game, set autoCreate to false.
If you want to delay deleting a connection that has dropped, set autoDestroy to false. If you do this, then you must call PopConnection() to remove that connection from being internally tracked. You'll also have to delete the connection instance on your own.

Parameters
[in] | autoCreate | Automatically call ReplicaManager3::AllocConnection() for each new connection. Defaults to true. Also see AutoCreateConnectionList()
[in] | autoDestroy | Automatically call ReplicaManager3::DeallocConnection() for each dropped connection. Defaults to true.
void RakNet::ReplicaManager3::SetAutoSerializeInterval ( RakNet::Time intervalMS )

Every intervalMS milliseconds, Connection_RM3::OnAutoserializeInterval() will be called.
Defaults to 30.
Pass with <0 to disable. Pass 0 to Serialize() every time RakPeer::Recieve() is called
If you want to control the update interval with more granularity, use the return values from Replica3::Serialize().

Parameters
[in] intervalMS How frequently to autoserialize all objects. This controls the maximum number of game object updates per second.
void RakNet::ReplicaManager3::SetDefaultOrderingChannel ( char def )
Parameters
[in] Default ordering channel to use for object creation, destruction, and serializations
void RakNet::ReplicaManager3::SetDefaultPacketPriority ( PacketPriority def )
Parameters
[in] Default packet priority to use for object creation, destruction, and serializations
void RakNet::ReplicaManager3::SetDefaultPacketReliability ( PacketReliability def )
Parameters
[in] Default packet reliability to use for object creation, destruction, and serializations
void RakNet::ReplicaManager3::SetNetworkIDManager | ( | NetworkIDManager * | _networkIDManager,
 |  | WorldId | worldId = 0
 | ) |  |

Sets the networkIDManager instance that this plugin relys upon.
Uses whatever instance is attached to RakPeerInterface if unset.
To support multiple worlds, you should set it to a different manager for each instance of the plugin

Parameters
[in] | _networkIDManager | The externally allocated NetworkIDManager instance for this plugin to use.
[in] | worldId | Used for multiple worlds. World 0 is created automatically by default. See AddWorld()
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/ReplicaManager3.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::LastSerializationResult Struct Reference

  • LastSerializationResult
Public Attributes | List of all members
RakNet::LastSerializationResult Struct Reference
ReplicaManager3

#include <ReplicaManager3.h>

Public Attributes

RakNet::Replica3 * replica

Detailed Description

Represents the serialized data for an object the last time it was sent. Used by Connection_RM3::OnAutoserializeInterval() and Connection_RM3::SendSerializeIfChanged()

Member Data Documentation

RakNet::Replica3* RakNet::LastSerializationResult::replica

The replica instance we serialized

Note
replica MUST be the first member of this struct because I cast from replica to LastSerializationResult in Update()
The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/ReplicaManager3.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::SerializeParameters Struct Reference

  • SerializeParameters
Public Attributes | List of all members
RakNet::SerializeParameters Struct Reference
ReplicaManager3

#include <ReplicaManager3.h>

Public Attributes

RakNet::BitStream | outputBitstream [RM3_NUM_OUTPUT_BITSTREAM_CHANNELS]
RakNet::BitStream * | lastSentBitstream [RM3_NUM_OUTPUT_BITSTREAM_CHANNELS]
RakNet::Time | messageTimestamp
PRO | pro [RM3_NUM_OUTPUT_BITSTREAM_CHANNELS]
RakNet::Connection_RM3 * destinationConnection
Passed to RakPeerInterface::Send().
BitSize_t | bitsWrittenSoFar
RakNet::Time | whenLastSerialized
RakNet::Time | curTime

Detailed Description

Parameters passed to Replica3::Serialize()

Member Data Documentation

BitSize_t RakNet::SerializeParameters::bitsWrittenSoFar

For prior serializations this tick, for the same connection, how many bits have we written so far? Use this to limit how many objects you send to update per-tick if desired

RakNet::Time RakNet::SerializeParameters::curTime

Current time, in milliseconds. curTime - whenLastSerialized is how long it has been since this object was last sent

RakNet::BitStream* RakNet::SerializeParameters::lastSentBitstream[RM3_NUM_OUTPUT_BITSTREAM_CHANNELS]

Last bitstream we sent for this replica to this system. Read, but DO NOT MODIFY

RakNet::Time RakNet::SerializeParameters::messageTimestamp

Set to non-zero to transmit a timestamp with this message. Defaults to 0 Use RakNet::GetTime() for this

RakNet::BitStream RakNet::SerializeParameters::outputBitstream[RM3_NUM_OUTPUT_BITSTREAM_CHANNELS]

Write your output for serialization here If nothing is written, the serialization will not occur Write to any or all of the NUM_OUTPUT_BITSTREAM_CHANNELS channels available. Channels can hold independent data

PRO RakNet::SerializeParameters::pro[RM3_NUM_OUTPUT_BITSTREAM_CHANNELS]

Passed to RakPeerInterface::Send(). Defaults to ReplicaManager3::SetDefaultPacketPriority(). Passed to RakPeerInterface::Send(). Defaults to ReplicaManager3::SetDefaultPacketReliability(). Passed to RakPeerInterface::Send(). Defaults to ReplicaManager3::SetDefaultOrderingChannel().

RakNet::Time RakNet::SerializeParameters::whenLastSerialized

When this object was last serialized to the connection 0 means never

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/ReplicaManager3.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Connection_RM3 Class Reference

  • Connection_RM3
Public Types | Public Member Functions | List of all members
RakNet::Connection_RM3 Class Referenceabstract
ReplicaManager3

Each remote system is represented by Connection_RM3. Used to allocate Replica3 and track which instances have been allocated. More...

#include <ReplicaManager3.h>

Public Types

enum ConstructionMode { QUERY_REPLICA_FOR_CONSTRUCTION, QUERY_REPLICA_FOR_CONSTRUCTION_AND_DESTRUCTION, QUERY_CONNECTION_FOR_REPLICA_LIST }
List of enumerations for how to get the list of valid objects for other systems. More...

Public Member Functions

virtual Replica3 * | AllocReplica (RakNet::BitStream *allocationIdBitstream, ReplicaManager3 *replicaManager3)=0
Class factory to create a Replica3 instance, given a user-defined identifier.
virtual void | GetConstructedReplicas (DataStructures::List< Replica3 * > &objectsTheyDoHave)
Get list of all replicas that are constructed for this connection.
bool | HasReplicaConstructed (RakNet::Replica3 *replica)
virtual void | SerializeOnDownloadStarted (RakNet::BitStream *bitStream)
virtual void | DeserializeOnDownloadStarted (RakNet::BitStream *bitStream)
virtual void | SerializeOnDownloadComplete (RakNet::BitStream *bitStream)
virtual void | DeserializeOnDownloadComplete (RakNet::BitStream *bitStream)
SystemAddress | GetSystemAddress (void) const
RakNetGUID | GetRakNetGUID (void) const
bool | GetDownloadWasCompleted (void) const
virtual bool | QueryGroupDownloadMessages (void) const
Return whether or not downloads to our system should all be processed the same tick (call to RakPeer::Receive() )
virtual ConstructionMode | QueryConstructionMode (void) const
Queries how to get the list of objects that exist on remote systems.
virtual void | QueryReplicaList (DataStructures::List< Replica3 * > &newReplicasToCreate, DataStructures::List< Replica3 * > &existingReplicasToDestroy)
Callback used when QueryConstructionMode() returns QUERY_CONNECTION_FOR_REPLICA_LIST.
virtual bool | QuerySerializationList (DataStructures::List< Replica3 * > &replicasToSerialize)
Override which replicas to serialize and in what order for a connection for a ReplicaManager3::Update() cycle.

Detailed Description

Each remote system is represented by Connection_RM3. Used to allocate Replica3 and track which instances have been allocated.

Important function: AllocReplica() - must be overridden to create an object given an identifier for that object, which you define for all objects in your game

Member Enumeration Documentation

enum RakNet::Connection_RM3::ConstructionMode

List of enumerations for how to get the list of valid objects for other systems.

Enumerator:
QUERY_REPLICA_FOR_CONSTRUCTION

For every object that does not exist on the remote system, call Replica3::QueryConstruction() every tick. Do not call Replica3::QueryDestruction() Do not call Connection_RM3::QueryReplicaList()

QUERY_REPLICA_FOR_CONSTRUCTION_AND_DESTRUCTION

For every object that does not exist on the remote system, call Replica3::QueryConstruction() every tick. Based on the call, the object may be sent to the other system. For every object that does exist on the remote system, call Replica3::QueryDestruction() every tick. Based on the call, the object may be deleted on the other system. Do not call Connection_RM3::QueryReplicaList()

QUERY_CONNECTION_FOR_REPLICA_LIST

Do not call Replica3::QueryConstruction() or Replica3::QueryDestruction() Call Connection_RM3::QueryReplicaList() to determine which objects exist on remote systems This can be faster than QUERY_REPLICA_FOR_CONSTRUCTION and QUERY_REPLICA_FOR_CONSTRUCTION_AND_DESTRUCTION for large worlds See GridSectorizer.h under /Source for code that can help with this

Member Function Documentation

virtual Replica3* RakNet::Connection_RM3::AllocReplica | ( | RakNet::BitStream * | allocationIdBitstream,
 |  | ReplicaManager3 * | replicaManager3
 | ) |  |
pure virtual

Class factory to create a Replica3 instance, given a user-defined identifier.

Identifier is returned by Replica3::WriteAllocationID() for what type of class to create.
This is called when you download a replica from another system.
See Replica3::Dealloc for the corresponding destruction message.
Return 0 if unable to create the intended object. Note, in that case the other system will still think we have the object and will try to serialize object updates to us. Generally, you should not send objects the other system cannot create.

See Also
Replica3::WriteAllocationID(). Sample implementation:
{RakNet::RakString typeName; allocationIdBitstream->Read(typeName); if (typeName=="Soldier") return new Soldier; return 0;}
Parameters
[in] | allocationIdBitstream | user-defined bitstream uniquely identifying a game object type
[in] | replicaManager3 | Instance of ReplicaManager3 that controls this connection
Returns
The new replica instance
virtual void RakNet::Connection_RM3::DeserializeOnDownloadComplete ( RakNet::BitStream * bitStream )
inlinevirtual

Receives whatever was written in DeserializeOnDownloadComplete()

Parameters
[in] bitStream Written in SerializeOnDownloadComplete()
virtual void RakNet::Connection_RM3::DeserializeOnDownloadStarted ( RakNet::BitStream * bitStream )
inlinevirtual

Receives whatever was written in SerializeOnDownloadStarted()

Parameters
[in] bitStream Written in SerializeOnDownloadStarted()
virtual void RakNet::Connection_RM3::GetConstructedReplicas ( DataStructures::List< Replica3 * > & objectsTheyDoHave )
virtual

Get list of all replicas that are constructed for this connection.

Parameters
[out] objectsTheyDoHave Destination list. Returned in sorted ascending order, sorted on the value of the Replica3 pointer.
bool RakNet::Connection_RM3::GetDownloadWasCompleted ( void ) const
inline
Returns
True if ID_REPLICA_MANAGER_DOWNLOAD_COMPLETE arrived for this connection
RakNetGUID RakNet::Connection_RM3::GetRakNetGUID ( void ) const
inline
Returns
Returns the RakNetGUID passed to the constructor of this object
SystemAddress RakNet::Connection_RM3::GetSystemAddress ( void ) const
inline
Returns
The system address passed to the constructor of this object
bool RakNet::Connection_RM3::HasReplicaConstructed ( RakNet::Replica3 * replica )

Returns true if we think this remote connection has this replica constructed

Parameters
[in] replica3 Which replica we are querying
Returns
True if constructed, false othewise
virtual ConstructionMode RakNet::Connection_RM3::QueryConstructionMode ( void ) const
inlinevirtual

Queries how to get the list of objects that exist on remote systems.

The default of calling QueryConstruction for every known object is easy to use, but not efficient, especially for large worlds where many objects are outside of the player's circle of influence.
QueryDestruction is also not necessarily useful or efficient, as object destruction tends to happen in known cases, and can be accomplished by calling Replica3::BroadcastDestruction() QueryConstructionMode() allows you to specify more efficient algorithms than the default when overriden.

Returns
How to get the list of objects that exist on the remote system. You should always return the same value for a given connection
virtual bool RakNet::Connection_RM3::QueryGroupDownloadMessages ( void ) const
inlinevirtual

Return whether or not downloads to our system should all be processed the same tick (call to RakPeer::Receive() )

Normally the system will send ID_REPLICA_MANAGER_DOWNLOAD_STARTED, ID_REPLICA_MANAGER_CONSTRUCTION for all downloaded objects, ID_REPLICA_MANAGER_SERIALIZE for each downloaded object, and lastly ID_REPLICA_MANAGER_DOWNLOAD_COMPLETE. This enables the application to show a downloading splash screen on ID_REPLICA_MANAGER_DOWNLOAD_STARTED, a progress bar, and to close the splash screen and activate all objects on ID_REPLICA_MANAGER_DOWNLOAD_COMPLETE However, if the application was not set up for this then it would result in incomplete objects spread out over time, and cause problems If you return true from QueryGroupDownloadMessages(), then these messages will be returned all in one tick, returned only when the download is complete

Note
ID_REPLICA_MANAGER_DOWNLOAD_STARTED calls the callback DeserializeOnDownloadStarted()
ID_REPLICA_MANAGER_DOWNLOAD_COMPLETE calls the callback DeserializeOnDownloadComplete()
virtual void RakNet::Connection_RM3::QueryReplicaList | ( | DataStructures::List< Replica3 * > & | newReplicasToCreate,
 |  | DataStructures::List< Replica3 * > & | existingReplicasToDestroy
 | ) |  |
inlinevirtual

Callback used when QueryConstructionMode() returns QUERY_CONNECTION_FOR_REPLICA_LIST.

This advantage of this callback is if that there are many objects that a particular connection does not have, then we do not have to iterate through those objects calling QueryConstruction() for each of them.
BR> See GridSectorizer in the Source directory as a method to find all objects within a certain radius in a fast way.
BR>

Parameters
[out] | newReplicasToCreate | Anything in this list will be created on the remote system
[out] | existingReplicasToDestroy | Anything in this list will be destroyed on the remote system
virtual bool RakNet::Connection_RM3::QuerySerializationList ( DataStructures::List< Replica3 * > & replicasToSerialize )
inlinevirtual

Override which replicas to serialize and in what order for a connection for a ReplicaManager3::Update() cycle.

By default, Connection_RM3 will iterate through queryToSerializeReplicaList and call QuerySerialization() on each Replica in that list queryToSerializeReplicaList is populated in the order in which ReplicaManager3::Reference() is called for those objects. If you write to to replicasToSerialize and return true, you can control in what order and for which replicas to call QuerySerialization() Example use case: We have more data to send then the bandwidth supports, so want to prioritize sends. For example enemies shooting are more important than animation effects When QuerySerializationList(), sort objects by priority, and write the list to replicasToSerialize, optionally skipping objects with a lower serialization frequency If you hit your bandwidth limit when checking SerializeParameters::bitsWrittenSoFar, you can return RM3SR_DO_NOT_SERIALIZE for all remaining items

Note
Only replicas written to replicasToSerialize are transmitted. Even if you returned RM3SR_SERIALIZED_ALWAYS a prior ReplicaManager3::Update() cycle, the replica will not be transmitted if it is not in replicasToSerialize
If you do not know what objects are candidates for serialization, you can use queryToSerializeReplicaList as a source for your filtering or sorting operations
Parameters
[in] replicasToSerialize List of replicas to call QuerySerialization() on
Returns
Return true to use replicasToSerialize (replicasToSerialize may be empty if desired). Otherwise return false.
virtual void RakNet::Connection_RM3::SerializeOnDownloadComplete ( RakNet::BitStream * bitStream )
inlinevirtual

When a new connection connects, after constructing and serialization all objects, SerializeOnDownloadComplete() is called

Parameters
[out] bitStream Passed to DeserializeOnDownloadComplete()
virtual void RakNet::Connection_RM3::SerializeOnDownloadStarted ( RakNet::BitStream * bitStream )
inlinevirtual

When a new connection connects, before sending any objects, SerializeOnDownloadStarted() is called

Parameters
[out] bitStream Passed to DeserializeOnDownloadStarted()
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/ReplicaManager3.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Replica3 Class Reference

  • Replica3
Public Member Functions | Public Attributes | List of all members
RakNet::Replica3 Class Referenceabstract
ReplicaManager3

Base class for your replicated objects for the ReplicaManager3 system. More...

#include <ReplicaManager3.h>

Inheritance diagram for RakNet::Replica3:
RakNet::NetworkIDObject RakNet::Replica3Composite< parent_type >

Public Member Functions

virtual | ~Replica3 ()
virtual void | WriteAllocationID (RakNet::Connection_RM3 *destinationConnection, RakNet::BitStream *allocationIdBitstream) const =0
Write a unique identifer that can be read on a remote system to create an object of this same class.
virtual RM3ConstructionState | QueryConstruction (RakNet::Connection_RM3 *destinationConnection, ReplicaManager3 *replicaManager3)=0
Ask if this object, which does not exist on destinationConnection should (now) be sent to that system.
virtual RM3DestructionState | QueryDestruction (RakNet::Connection_RM3 *destinationConnection, ReplicaManager3 *replicaManager3)
Ask if this object, which does exist on destinationConnection should be removed from the remote system.
virtual bool | QueryRemoteConstruction (RakNet::Connection_RM3 *sourceConnection)=0
We're about to call DeserializeConstruction() on this Replica3. If QueryRemoteConstruction() returns false, this object is deleted instead.
virtual bool | QueryRelayDestruction (Connection_RM3 *sourceConnection) const
We got a message from a connection to destroy this replica Return true to automatically relay the destruction message to all our other connections For a client in client/server, it does not matter what this funtion returns For a server in client/server, this should normally return true For a peer in peer to peer, you can normally return false since the original destroying peer would have told all other peers about the destruction If a system gets a destruction command for an object that was already destroyed, the destruction message is ignored.
virtual void | SerializeConstruction (RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *destinationConnection)=0
Write data to be sent only when the object is constructed on a remote system.
virtual bool | DeserializeConstruction (RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *sourceConnection)=0
Read data written by Replica3::SerializeConstruction()
virtual void | SerializeConstructionExisting (RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *destinationConnection)
virtual void | DeserializeConstructionExisting (RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *sourceConnection)
virtual void | SerializeDestruction (RakNet::BitStream *destructionBitstream, RakNet::Connection_RM3 *destinationConnection)=0
Write extra data to send with the object deletion event, if desired.
virtual bool | DeserializeDestruction (RakNet::BitStream *destructionBitstream, RakNet::Connection_RM3 *sourceConnection)=0
Read data written by Replica3::SerializeDestruction()
virtual
RakNet::RM3ActionOnPopConnection 		QueryActionOnPopConnection (RakNet::Connection_RM3 *droppedConnection) const =0
The system is asking what to do with this replica when the connection is dropped.
virtual void | OnPoppedConnection (RakNet::Connection_RM3 *droppedConnection)
Notification called for each of our replicas when a connection is popped.
virtual void | DeallocReplica (RakNet::Connection_RM3 *sourceConnection)=0
Override with {delete this;}.
virtual
RakNet::RM3QuerySerializationResult 		QuerySerialization (RakNet::Connection_RM3 *destinationConnection)=0
Implement with QuerySerialization_ClientSerializable(), QuerySerialization_ServerSerializable(), or QuerySerialization_PeerToPeer()
virtual void | OnUserReplicaPreSerializeTick (void)
Called for each replica owned by the user, once per Serialization tick, before Serialize() is called. If you want to do some kind of operation on the Replica objects that you own, just before Serialization(), then overload this function.
virtual RM3SerializationResult | Serialize (RakNet::SerializeParameters *serializeParameters)=0
Serialize our class to a bitstream.
virtual void | OnSerializeTransmission (RakNet::BitStream *bitStream, RakNet::Connection_RM3 *destinationConnection, BitSize_t bitsPerChannel[RM3_NUM_OUTPUT_BITSTREAM_CHANNELS], RakNet::Time curTime)
Called when the class is actually transmitted via Serialize()
virtual void | Deserialize (RakNet::DeserializeParameters *deserializeParameters)=0
Read what was written in Serialize()
virtual void | PostSerializeConstruction (RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *destinationConnection)
Called after SerializeConstruction completes for all objects in a given update tick.
Writes to PostDeserializeConstruction(), which is called after all objects are created for a given Construction tick(). Override to send data to PostDeserializeConstruction(), such as the NetworkID of other objects to resolve pointers to.
virtual void | PostDeserializeConstruction (RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *sourceConnection)
virtual void | PostSerializeConstructionExisting (RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *destinationConnection)
Same as PostSerializeConstruction(), but for objects that returned RM3CS_ALREADY_EXISTS_REMOTELY from QueryConstruction.
virtual void | PostDeserializeConstructionExisting (RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *sourceConnection)
Same as PostDeserializeConstruction(), but for objects that returned RM3CS_ALREADY_EXISTS_REMOTELY from QueryConstruction.
virtual void | PreDestruction (RakNet::Connection_RM3 *sourceConnection)
virtual RM3ConstructionState | QueryConstruction_ClientConstruction (RakNet::Connection_RM3 *destinationConnection, bool isThisTheServer)
Default call for QueryConstruction().
virtual bool | QueryRemoteConstruction_ClientConstruction (RakNet::Connection_RM3 *sourceConnection, bool isThisTheServer)
virtual RM3ConstructionState | QueryConstruction_ServerConstruction (RakNet::Connection_RM3 *destinationConnection, bool isThisTheServer)
Default call for QueryConstruction().
virtual bool | QueryRemoteConstruction_ServerConstruction (RakNet::Connection_RM3 *sourceConnection, bool isThisTheServer)
Default call for QueryRemoteConstruction(). Allow the server to create this object, but not the client.
virtual RM3ConstructionState | QueryConstruction_PeerToPeer (RakNet::Connection_RM3 *destinationConnection, Replica3P2PMode p2pMode=R3P2PM_SINGLE_OWNER)
Default call for QueryConstruction().
virtual bool | QueryRemoteConstruction_PeerToPeer (RakNet::Connection_RM3 *sourceConnection)
Default call for QueryRemoteConstruction().
virtual
RakNet::RM3QuerySerializationResult 		QuerySerialization_ClientSerializable (RakNet::Connection_RM3 *destinationConnection, bool isThisTheServer)
Default call for QuerySerialization().
virtual
RakNet::RM3QuerySerializationResult 		QuerySerialization_ServerSerializable (RakNet::Connection_RM3 *destinationConnection, bool isThisTheServer)
Default call for QuerySerialization().
virtual
RakNet::RM3QuerySerializationResult 		QuerySerialization_PeerToPeer (RakNet::Connection_RM3 *destinationConnection, Replica3P2PMode p2pMode=R3P2PM_SINGLE_OWNER)
Default call for QuerySerialization().
virtual RM3ActionOnPopConnection | QueryActionOnPopConnection_Client (RakNet::Connection_RM3 *droppedConnection) const
Default: If we are a client, and the connection is lost, delete the server's objects.
virtual RM3ActionOnPopConnection | QueryActionOnPopConnection_Server (RakNet::Connection_RM3 *droppedConnection) const
Default: If we are a server, and the connection is lost, delete the client's objects and broadcast the destruction.
virtual RM3ActionOnPopConnection | QueryActionOnPopConnection_PeerToPeer (RakNet::Connection_RM3 *droppedConnection) const
Default: If we are a peer, and the connection is lost, delete the peer's objects.
virtual void | BroadcastDestruction (void)
RakNetGUID | GetCreatingSystemGUID (void) const
bool | WasReferenced (void) const
- Public Member Functions inherited from RakNet::NetworkIDObject
virtual void | SetNetworkIDManager (NetworkIDManager *manager)
virtual NetworkIDManager * | GetNetworkIDManager (void) const
Returns what was passed to SetNetworkIDManager.
virtual NetworkID | GetNetworkID (void)
virtual void | SetNetworkID (NetworkID id)
virtual void | SetParent (void *_parent)
virtual void * | GetParent (void) const

Public Attributes

RakNetGUID creatingSystemGUID
RakNetGUID deletingSystemGUID
GUID of the system that caused the item to send a deletion command over the network.

Additional Inherited Members

- Protected Attributes inherited from RakNet::NetworkIDObject
NetworkID | networkID
The network ID of this object.
void * | parent
The parent set by SetParent()

Detailed Description

Base class for your replicated objects for the ReplicaManager3 system.

To use, derive your class, or a member of your class, from Replica3.

Constructor & Destructor Documentation

virtual RakNet::Replica3::~Replica3 ( )
virtual

Before deleting a local instance of Replica3, call Replica3::BroadcastDestruction() for the deletion notification to go out on the network. It is not necessary to call ReplicaManager3::Dereference(), as this happens automatically in the destructor

Member Function Documentation

virtual void RakNet::Replica3::BroadcastDestruction ( void )
virtual

Call to send a network message to delete this object on other systems.
Call it before deleting the object

virtual void RakNet::Replica3::DeallocReplica ( RakNet::Connection_RM3 * sourceConnection )
pure virtual

Override with {delete this;}.

  1. Got a remote message to delete this object which passed DeserializeDestruction(), OR
  2. ReplicaManager3::SetAutoManageConnections() was called autoDestroy true (which is the default setting), and a remote system that owns this object disconnected) OR <>
    Override with {delete this;} to actually delete the object (and any other processing you wish).
    If you don't want to delete the object, just do nothing, however, the system will not know this. You may wish to call Dereference() if the object should no longer be networked, but remain in memory. You are responsible for deleting it yoruself later.
    destructionBitstream may be 0 if the object was deleted locally

Implemented in RakNet::Replica3Composite< parent_type >.

virtual void RakNet::Replica3::Deserialize ( RakNet::DeserializeParameters * deserializeParameters )
pure virtual

Read what was written in Serialize()

Reads the contents of the class from SerializationParamters::serializationBitstream.
Called whenever Serialize() is called with different data from the last send.

Parameters
[in] | serializationBitstream | Bitstream passed to Serialize()
[in] | timeStamp | 0 if unused, else contains the time the message originated on the remote system
[in] | sourceConnection | Which system sent to us

Implemented in RakNet::Replica3Composite< parent_type >.

virtual bool RakNet::Replica3::DeserializeConstruction | ( | RakNet::BitStream * | constructionBitstream,
 |  | RakNet::Connection_RM3 * | sourceConnection
 | ) |  |
pure virtual

Read data written by Replica3::SerializeConstruction()

Reads whatever data was written to constructionBitstream in Replica3::SerializeConstruction()

Parameters
[out] | constructionBitstream | Bitstream written to in Replica3::SerializeConstruction()
[in] | sourceConnection | System that sent us this network message.
Returns
true to accept construction of the object. false to reject, in which case the object will be deleted via Replica3::DeallocReplica()

Implemented in RakNet::Replica3Composite< parent_type >.

virtual void RakNet::Replica3::DeserializeConstructionExisting | ( | RakNet::BitStream * | constructionBitstream,
 |  | RakNet::Connection_RM3 * | sourceConnection
 | ) |  |
inlinevirtual

Same as DeserializeConstruction(), but for an object that already exists on the remote system. Used if you return RM3CS_ALREADY_EXISTS_REMOTELY from QueryConstruction

Reimplemented in RakNet::Replica3Composite< parent_type >.

virtual bool RakNet::Replica3::DeserializeDestruction | ( | RakNet::BitStream * | destructionBitstream,
 |  | RakNet::Connection_RM3 * | sourceConnection
 | ) |  |
pure virtual

Read data written by Replica3::SerializeDestruction()

Return true to delete the object. BroadcastDestruction() will be called automatically, followed by ReplicaManager3::Dereference.
Return false to not delete it. If you delete it at a later point, you are responsible for calling BroadcastDestruction() yourself.

Implemented in RakNet::Replica3Composite< parent_type >.

RakNetGUID RakNet::Replica3::GetCreatingSystemGUID ( void ) const

creatingSystemGUID is set the first time Reference() is called, or if we get the object from another system

Returns
System that originally created this object
virtual void RakNet::Replica3::OnSerializeTransmission | ( | RakNet::BitStream * | bitStream,
 |  | RakNet::Connection_RM3 * | destinationConnection,
 |  | BitSize_t | bitsPerChannel[RM3_NUM_OUTPUT_BITSTREAM_CHANNELS],
 |  | RakNet::Time | curTime
 | ) |  |
inlinevirtual

Called when the class is actually transmitted via Serialize()

Use to track how much bandwidth this class it taking

virtual void RakNet::Replica3::PostDeserializeConstruction | ( | RakNet::BitStream * | constructionBitstream,
 |  | RakNet::Connection_RM3 * | sourceConnection
 | ) |  |
inlinevirtual

Called after DeserializeConstruction completes for all objects in a given update tick.
This is used to resolve dependency chains, where two objects would refer to each other in DeserializeConstruction, yet one had not been constructed yet In PostDeserializeConstruction(), you know that all objects have already been created, so can resolve NetworkIDs to pointers safely. You can also use it to trigger some sort of event when you know the object has completed deserialization.

Parameters
[in] | constructionBitstream | BitStream written in PostSerializeConstruction()
[in] | sourceConnection | System that sent us this network message.

Reimplemented in RakNet::Replica3Composite< parent_type >.

virtual void RakNet::Replica3::PreDestruction ( RakNet::Connection_RM3 * sourceConnection )
inlinevirtual

Called after DeserializeDestruction completes for the object successfully, but obviously before the object is deleted.
Override to trigger some sort of event when you know the object has completed destruction.

Parameters
[in] sourceConnection System that sent us this network message.

Reimplemented in RakNet::Replica3Composite< parent_type >.

virtual RakNet::RM3ActionOnPopConnection RakNet::Replica3::QueryActionOnPopConnection ( RakNet::Connection_RM3 * droppedConnection ) const
pure virtual

The system is asking what to do with this replica when the connection is dropped.

Return QueryActionOnPopConnection_Client, QueryActionOnPopConnection_Server, or QueryActionOnPopConnection_PeerToPeer

Implemented in RakNet::Replica3Composite< parent_type >.

virtual RM3ConstructionState RakNet::Replica3::QueryConstruction | ( | RakNet::Connection_RM3 * | destinationConnection,
 |  | ReplicaManager3 * | replicaManager3
 | ) |  |
pure virtual

Ask if this object, which does not exist on destinationConnection should (now) be sent to that system.

If ReplicaManager3::QueryConstructionMode() returns QUERY_CONNECTION_FOR_REPLICA_LIST or QUERY_REPLICA_FOR_CONSTRUCTION_AND_DESTRUCTION (default), then QueyrConstruction() is called once per tick from ReplicaManager3::Update() to determine if an object should exist on a given system.
Based on the return value, a network message may be sent to the other system to create the object.
If QueryConstructionMode() is overriden to return QUERY_CONNECTION_FOR_REPLICA_LIST, this function is unused.

Note
Defaults are provided: QueryConstruction_PeerToPeer(), QueryConstruction_ServerConstruction(), QueryConstruction_ClientConstruction(). Return one of these functions for a working default for the relevant topology.
Parameters
[in] | destinationConnection | Which system we will send to
[in] | replicaManager3 | Plugin instance for this Replica3
Returns
What action to take

Implemented in RakNet::Replica3Composite< parent_type >.

virtual RM3ConstructionState RakNet::Replica3::QueryConstruction_ClientConstruction | ( | RakNet::Connection_RM3 * | destinationConnection,
 |  | bool | isThisTheServer
 | ) |  |
virtual

Default call for QueryConstruction().

Both the client and the server is allowed to create this object. The network topology is client/server

Parameters
[in] | destinationConnection | destinationConnection parameter passed to QueryConstruction()
[in] | isThisTheServer | True if this system is the server, false if not.
virtual RM3ConstructionState RakNet::Replica3::QueryConstruction_PeerToPeer | ( | RakNet::Connection_RM3 * | destinationConnection,
 |  | Replica3P2PMode | p2pMode = R3P2PM_SINGLE_OWNER
 | ) |  |
virtual

Default call for QueryConstruction().

All clients are allowed to create all objects. The object is not relayed when remotely created

Parameters
[in] | destinationConnection | destinationConnection parameter passed to QueryConstruction()
[in] | p2pMode | If controlled only by this system ever, pass R3P2PM_SINGLE_OWNER. Otherwise pass R3P2PM_MULTI_OWNER_CURRENTLY_AUTHORITATIVE or R3P2PM_MULTI_OWNER_NOT_CURRENTLY_AUTHORITATIVE
virtual RM3ConstructionState RakNet::Replica3::QueryConstruction_ServerConstruction | ( | RakNet::Connection_RM3 * | destinationConnection,
 |  | bool | isThisTheServer
 | ) |  |
virtual

Default call for QueryConstruction().

Only the server is allowed to create this object. The network topology is client/server

Parameters
[in] | destinationConnection | destinationConnection parameter passed to QueryConstruction()
[in] | isThisTheServer | True if this system is the server, false if not.
virtual RM3DestructionState RakNet::Replica3::QueryDestruction | ( | RakNet::Connection_RM3 * | destinationConnection,
 |  | ReplicaManager3 * | replicaManager3
 | ) |  |
inlinevirtual

Ask if this object, which does exist on destinationConnection should be removed from the remote system.

If ReplicaManager3::QueryConstructionMode() returns QUERY_REPLICA_FOR_CONSTRUCTION_AND_DESTRUCTION (default), then QueryDestruction() is called once per tick from ReplicaManager3::Update() to determine if an object that exists on a remote system should be destroyed for a given system.
Based on the return value, a network message may be sent to the other system to destroy the object.
Note that you can also destroy objects with BroadcastDestruction(), so this function is not useful unless you plan to delete objects for only a particular connection.
If QueryConstructionMode() is overriden to return QUERY_CONNECTION_FOR_REPLICA_LIST, this function is unused.

Parameters
[in] | destinationConnection | Which system we will send to
[in] | replicaManager3 | Plugin instance for this Replica3
Returns
What action to take. Only RM3CS_SEND_DESTRUCTION does anything at this time.

Reimplemented in RakNet::Replica3Composite< parent_type >.

virtual bool RakNet::Replica3::QueryRemoteConstruction ( RakNet::Connection_RM3 * sourceConnection )
pure virtual

We're about to call DeserializeConstruction() on this Replica3. If QueryRemoteConstruction() returns false, this object is deleted instead.

By default, QueryRemoteConstruction_ServerConstruction() does not allow clients to create objects. The client will get Replica3::DeserializeConstructionRequestRejected().
If you want the client to be able to potentially create objects for client/server, override accordingly.
Other variants of QueryRemoteConstruction_* just return true.

Note
Defaults are provided: QueryRemoteConstruction_PeerToPeer(), QueryRemoteConstruction_ServerConstruction(), QueryRemoteConstruction_ClientConstruction(). Return one of these functions for a working default for the relevant topology.
Parameters
[in] sourceConnection Which system sent us the object creation request message.
Returns
True to allow the object to pass onto DeserializeConstruction() (where it may also be rejected), false to immediately reject the remote construction request

Implemented in RakNet::Replica3Composite< parent_type >.

virtual bool RakNet::Replica3::QueryRemoteConstruction_ClientConstruction | ( | RakNet::Connection_RM3 * | sourceConnection,
 |  | bool | isThisTheServer
 | ) |  |
virtual

Default call for QueryRemoteConstruction().

Both the client and the server is allowed to create this object. The network topology is client/server The code means on the client or the server, allow creation of Replica3 instances

Parameters
[in] | sourceConnection | destinationConnection parameter passed to QueryConstruction()
[in] | isThisTheServer | True if this system is the server, false if not.
virtual bool RakNet::Replica3::QueryRemoteConstruction_PeerToPeer ( RakNet::Connection_RM3 * sourceConnection )
virtual

Default call for QueryRemoteConstruction().

All clients are allowed to create all objects. The object is not relayed when remotely created

Parameters
[in] sourceConnection destinationConnection parameter passed to QueryConstruction()
virtual bool RakNet::Replica3::QueryRemoteConstruction_ServerConstruction | ( | RakNet::Connection_RM3 * | sourceConnection,
 |  | bool | isThisTheServer
 | ) |  |
virtual

Default call for QueryRemoteConstruction(). Allow the server to create this object, but not the client.

Only the server is allowed to create this object. The network topology is client/server The code means if this is the server, and I got a command to create a Replica3 to ignore it. If this is the client, to allow it.

Parameters
[in] | sourceConnection | destinationConnection parameter passed to QueryConstruction()
[in] | isThisTheServer | True if this system is the server, false if not.
virtual RakNet::RM3QuerySerializationResult RakNet::Replica3::QuerySerialization ( RakNet::Connection_RM3 * destinationConnection )
pure virtual

Implement with QuerySerialization_ClientSerializable(), QuerySerialization_ServerSerializable(), or QuerySerialization_PeerToPeer()

QuerySerialization() is a first pass query to check if a given object should serializable to a given system. The intent is that the user implements with one of the defaults for client, server, or peer to peer.
Without this function, a careless implementation would serialize an object anytime it changed to all systems. This would give you feedback loops as the sender gets the same message back from the recipient it just sent to.
If more than one system can serialize the same object then you will need to override to return true, and control the serialization result from Replica3::Serialize(). Be careful not to send back the same data to the system that just sent to you!

Returns
True to allow calling Replica3::Serialize() for this connection, false to not call.

Implemented in RakNet::Replica3Composite< parent_type >.

virtual RakNet::RM3QuerySerializationResult RakNet::Replica3::QuerySerialization_ClientSerializable | ( | RakNet::Connection_RM3 * | destinationConnection,
 |  | bool | isThisTheServer
 | ) |  |
virtual

Default call for QuerySerialization().

Use if the values you are serializing are generated by the client that owns the object. The serialization will be relayed through the server to the other clients.

Parameters
[in] | destinationConnection | destinationConnection parameter passed to QueryConstruction()
[in] | isThisTheServer | True if this system is the server, false if not.
virtual RakNet::RM3QuerySerializationResult RakNet::Replica3::QuerySerialization_PeerToPeer | ( | RakNet::Connection_RM3 * | destinationConnection,
 |  | Replica3P2PMode | p2pMode = R3P2PM_SINGLE_OWNER
 | ) |  |
virtual

Default call for QuerySerialization().

Use if the values you are serializing are on a peer to peer network. The peer that owns the object will send to all. Remote peers will not send.

Parameters
[in] | destinationConnection | destinationConnection parameter passed to QueryConstruction()
[in] | p2pMode | If controlled only by this system ever, pass R3P2PM_SINGLE_OWNER. Otherwise pass R3P2PM_MULTI_OWNER_CURRENTLY_AUTHORITATIVE or R3P2PM_MULTI_OWNER_NOT_CURRENTLY_AUTHORITATIVE
virtual RakNet::RM3QuerySerializationResult RakNet::Replica3::QuerySerialization_ServerSerializable | ( | RakNet::Connection_RM3 * | destinationConnection,
 |  | bool | isThisTheServer
 | ) |  |
virtual

Default call for QuerySerialization().

Use if the values you are serializing are generated only by the server. The serialization will be sent to all clients, but the clients will not send back to the server.

Parameters
[in] | destinationConnection | destinationConnection parameter passed to QueryConstruction()
[in] | isThisTheServer | True if this system is the server, false if not.
virtual RM3SerializationResult RakNet::Replica3::Serialize ( RakNet::SerializeParameters * serializeParameters )
pure virtual

Serialize our class to a bitstream.

User should implement this function to write the contents of this class to SerializationParamters::serializationBitstream.
If data only needs to be written once, you can write it to SerializeConstruction() instead for efficiency.
Transmitted over the network if it changed from the last time we called Serialize().
Called every time the time interval to ReplicaManager3::SetAutoSerializeInterval() elapses and ReplicaManager3::Update is subsequently called.

Parameters
in/out] serializeParameters Parameters controlling the serialization, including destination bitstream to write to
Returns
Whether to serialize, and if so, how to optimize the results

Implemented in RakNet::Replica3Composite< parent_type >.

virtual void RakNet::Replica3::SerializeConstruction | ( | RakNet::BitStream * | constructionBitstream,
 |  | RakNet::Connection_RM3 * | destinationConnection
 | ) |  |
pure virtual

Write data to be sent only when the object is constructed on a remote system.

SerializeConstruction is used to write out data that you need to create this object in the context of your game, such as health, score, name. Use it for data you only need to send when the object is created.
After SerializeConstruction() is called, Serialize() will be called immediately thereafter. However, they are sent in different messages, so Serialize() may arrive a later frame than SerializeConstruction() For that reason, the object should be valid after a call to DeserializeConstruction() for at least a short time.

Note
The object's NetworkID and allocation id are handled by the system automatically, you do not need to write these values to constructionBitstream
Parameters
[out] | constructionBitstream | Destination bitstream to write your data to
[in] | destinationConnection | System that will receive this network message.

Implemented in RakNet::Replica3Composite< parent_type >.

virtual void RakNet::Replica3::SerializeConstructionExisting | ( | RakNet::BitStream * | constructionBitstream,
 |  | RakNet::Connection_RM3 * | destinationConnection
 | ) |  |
inlinevirtual

Same as SerializeConstruction(), but for an object that already exists on the remote system. Used if you return RM3CS_ALREADY_EXISTS_REMOTELY from QueryConstruction

Reimplemented in RakNet::Replica3Composite< parent_type >.

virtual void RakNet::Replica3::SerializeDestruction | ( | RakNet::BitStream * | destructionBitstream,
 |  | RakNet::Connection_RM3 * | destinationConnection
 | ) |  |
pure virtual

Write extra data to send with the object deletion event, if desired.

Replica3::SerializeDestruction() will be called to write any object destruction specific data you want to send with this event. destructionBitstream can be read in DeserializeDestruction()

Parameters
[out] | destructionBitstream | Bitstream for you to write to
[in] | destinationConnection | System that will receive this network message.

Implemented in RakNet::Replica3Composite< parent_type >.

bool RakNet::Replica3::WasReferenced ( void ) const
inline
Returns
If ReplicaManager3::Reference() was called on this object.
virtual void RakNet::Replica3::WriteAllocationID | ( | RakNet::Connection_RM3 * | destinationConnection,
 |  | RakNet::BitStream * | allocationIdBitstream
 | ) |  | const
 pure virtual

Write a unique identifer that can be read on a remote system to create an object of this same class.

The value written to allocationIdBitstream will be passed to Connection_RM3::AllocReplica().
Sample implementation:
{allocationIdBitstream->Write(RakNet::RakString("Soldier");}

Parameters
[out] allocationIdBitstream Bitstream for the user to write to, to identify this class

Implemented in RakNet::Replica3Composite< parent_type >.

Member Data Documentation

RakNetGUID RakNet::Replica3::creatingSystemGUID

GUID of the system that first called Reference() on this object. Transmitted automatically when the object is constructed

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/ReplicaManager3.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Router2

Classes
Router2
Plugins

Part of the NAT punchthrough solution, allowing you to connect to systems by routing through a shared connection. More...

Classes

class RakNet::Router2
Class interface for the Router2 system. More...

Detailed Description

Part of the NAT punchthrough solution, allowing you to connect to systems by routing through a shared connection.

Router2 routes datagrams between two systems that are not directly connected by using the bandwidth of a third system, to which the other two systems were connected It is of benefit when a fully connected mesh topology is desired, but could not be completely established due to routers and/or firewalls As the system address of a remote system will be the system address of the intermediary, it is necessary to use the RakNetGUID object to refer to systems, including with other plugins

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::Router2 Class Reference

  • Router2
Public Member Functions | List of all members
RakNet::Router2 Class Reference
Router2

Class interface for the Router2 system. More...

#include <Router2.h>

Inheritance diagram for RakNet::Router2:
RakNet::PluginInterface2

Public Member Functions

void | SetSocketFamily (unsigned short _socketFamily)
void | EstablishRouting (RakNetGUID endpointGuid)
Query all connected systems to connect through them to a third system. System will return ID_ROUTER_2_FORWARDING_NO_PATH if unable to connect. Else you will get ID_ROUTER_2_FORWARDING_ESTABLISHED.
void | SetMaximumForwardingRequests (int max)
void | SetDebugInterface (Router2DebugInterface *_debugInterface)
For testing and debugging.
Router2DebugInterface * | GetDebugInterface (void) const
Get the pointer passed to SetDebugInterface()
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Detailed Description

Class interface for the Router2 system.

Member Function Documentation

void RakNet::Router2::EstablishRouting ( RakNetGUID endpointGuid )

Query all connected systems to connect through them to a third system. System will return ID_ROUTER_2_FORWARDING_NO_PATH if unable to connect. Else you will get ID_ROUTER_2_FORWARDING_ESTABLISHED.

On ID_ROUTER_2_FORWARDING_ESTABLISHED, EstablishRouting as follows:

RakNet::BitStream bs(packet->data, packet->length, false); bs.IgnoreBytes(sizeof(MessageID)); RakNetGUID endpointGuid; bs.Read(endpointGuid); unsigned short sourceToDestPort; bs.Read(sourceToDestPort); char ipAddressString[32]; packet->systemAddress.ToString(false, ipAddressString); rakPeerInterface->EstablishRouting(ipAddressString, sourceToDestPort, 0,0);

Note
The SystemAddress for a connection should not be used - always use RakNetGuid as the address can change at any time. When the address changes, you will get ID_ROUTER_2_REROUTED
virtual void RakNet::Router2::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
virtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual void RakNet::Router2::OnFailedConnectionAttempt | ( | Packet * | packet,
 |  | PI2_FailedConnectionAttemptReason | failedConnectionAttemptReason
 | ) |  |
virtual

Called when a connection attempt fails

Parameters
[in] | packet | Packet to be returned to the user
[in] | failedConnectionReason | Why the connection failed

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::Router2::OnReceive ( Packet * packet )
virtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

void RakNet::Router2::SetMaximumForwardingRequests ( int max )

Set the maximum number of bidirectional connections this system will support Defaults to 0

void RakNet::Router2::SetSocketFamily ( unsigned short _socketFamily )

Sets the socket family to use, either IPV4 or IPV6

Parameters
[in] socketFamily For IPV4, use AF_INET (default). For IPV6, use AF_INET6. To autoselect, use AF_UNSPEC.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/Router2.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RPC

Classes | Enumerations
RPC
Plugins

Remote procedure calls, without external dependencies. More...

Classes

class RakNet::RPC4
The RPC4 plugin is just an association between a C function pointer and a string. More...

Enumerations

enum RakNet::RPCErrorCodes {
RakNet::RPC_ERROR_FUNCTION_NOT_REGISTERED, RakNet::RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RakNet::RPC_ERROR_OBJECT_DOES_NOT_EXIST, RakNet::RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE,
RakNet::RPC_ERROR_FUNCTION_NOT_REGISTERED, RakNet::RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RakNet::RPC_ERROR_CALLING_CPP_AS_C, RakNet::RPC_ERROR_CALLING_C_AS_CPP
}
Error codes returned by a remote system as to why an RPC function call cannot execute. More...

Detailed Description

Remote procedure calls, without external dependencies.

This should not be used at the same time as RPC3. This is a less functional version of RPC3, and is here for users that do not want the Boost dependency of RPC3.

Enumeration Type Documentation

enum RakNet::RPCErrorCodes

Error codes returned by a remote system as to why an RPC function call cannot execute.

Error code follows packet ID ID_RPC_REMOTE_ERROR, that is packet->data[1]
Name of the function will be appended starting at packet->data[2]

Enumerator:
RPC_ERROR_FUNCTION_NOT_REGISTERED

Named function was not registered with RegisterFunction(). Check your spelling.

RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE

RPC3::SetNetworkIDManager() was not called, and it must be called to call a C++ object member.

RPC_ERROR_OBJECT_DOES_NOT_EXIST

Cannot execute C++ object member call because the object specified by SetRecipientObject() does not exist on this system.

RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE

Internal error, index optimization for function lookup does not exist.

RPC_ERROR_FUNCTION_NOT_REGISTERED

Named function was not registered with RegisterFunction(). Check your spelling.

RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED

Named function was registered, but later unregistered with UnregisterFunction() and can no longer be called.

RPC_ERROR_CALLING_CPP_AS_C

SetRecipientObject() was not called before Call(), but the registered pointer is a class member If you intended to call a class member function, call SetRecipientObject() with a valid object first.

RPC_ERROR_CALLING_C_AS_CPP

SetRecipientObject() was called before Call(), but RegisterFunction() was called with isObjectMember=false If you intended to call a C function, call SetRecipientObject(UNASSIGNED_NETWORK_ID) first.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::RPC4 Class Reference

  • RPC4
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
RakNet::RPC4 Class Reference
RPC

The RPC4 plugin is just an association between a C function pointer and a string. More...

#include <RPC4Plugin.h>

Inheritance diagram for RakNet::RPC4:
RakNet::PluginInterface2

Public Member Functions

bool | RegisterFunction (const char *uniqueID, void(*functionPointer)(RakNet::BitStream *userData, Packet *packet))
Register a function pointer to be callable from a remote system.
void | RegisterSlot (const char *sharedIdentifier, void(*functionPointer)(RakNet::BitStream *userData, Packet *packet), int callPriority)
bool | RegisterBlockingFunction (const char *uniqueID, void(*functionPointer)(RakNet::BitStream *userData, RakNet::BitStream *returnData, Packet *packet))
Same as RegisterFunction, but is called with CallBlocking() instead of Call() and returns a value to the caller.
void | RegisterLocalCallback (const char *uniqueID, MessageID messageId)
bool | UnregisterFunction (const char *uniqueID)
Unregister a function pointer previously registered with RegisterFunction()
bool | UnregisterBlockingFunction (const char *uniqueID)
Same as UnregisterFunction, except for a blocking function.
bool | UnregisterLocalCallback (const char *uniqueID, MessageID messageId)
bool | UnregisterSlot (const char *sharedIdentifier)
void | CallLoopback (const char *uniqueID, RakNet::BitStream *bitStream)
void | Call (const char *uniqueID, RakNet::BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel, const AddressOrGUID systemIdentifier, bool broadcast)
bool | CallBlocking (const char *uniqueID, RakNet::BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel, const AddressOrGUID systemIdentifier, RakNet::BitStream *returnData)
Same as call, but don't return until the remote system replies. Broadcasting parameter does not exist, this can only call one remote system.
void | Signal (const char *sharedIdentifier, RakNet::BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel, const AddressOrGUID systemIdentifier, bool broadcast, bool invokeLocal)
void | InterruptSignal (void)
If called while processing a slot, no further slots for the currently executing signal will be executed.
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Protected Member Functions

virtual void | OnAttach (void)
Called when the interface is attached.
virtual PluginReceiveResult | OnReceive (Packet *packet)

Protected Attributes

unsigned int nextSlotRegistrationCount
Used so slots are called in the order they are registered.

Detailed Description

The RPC4 plugin is just an association between a C function pointer and a string.

It is for users that want to use RPC, but do not want to use boost. You do not have the automatic serialization or other features of RPC3, and C++ member calls are not supported.

Note
You cannot use RPC4 at the same time as RPC3Plugin

Member Function Documentation

void RakNet::RPC4::Call | ( | const char * | uniqueID,
 |  | RakNet::BitStream * | bitStream,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | const AddressOrGUID | systemIdentifier,
 |  | bool | broadcast
 | ) |  |
Deprecated:
, use Signal() Send to the specified remote instance of RakPeer.
Parameters
[in] | uniqueID | Identifier originally passed to RegisterFunction() on the remote system(s)
[in] | bitStream | bitStream encoded data to send to the function callback
[in] | priority | See RakPeerInterface::Send()
[in] | reliability | See RakPeerInterface::Send()
[in] | orderingChannel | See RakPeerInterface::Send()
[in] | systemIdentifier | See RakPeerInterface::Send()
[in] | broadcast | See RakPeerInterface::Send()
bool RakNet::RPC4::CallBlocking | ( | const char * | uniqueID,
 |  | RakNet::BitStream * | bitStream,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | const AddressOrGUID | systemIdentifier,
 |  | RakNet::BitStream * | returnData
 | ) |  |

Same as call, but don't return until the remote system replies. Broadcasting parameter does not exist, this can only call one remote system.

Note
This function does not return until the remote system responds, disconnects, or was never connected to begin with
Parameters
[in] | Identifier | originally passed to RegisterBlockingFunction() on the remote system(s)
[in] | bitStream | bitStream encoded data to send to the function callback
[in] | priority | See RakPeerInterface::Send()
[in] | reliability | See RakPeerInterface::Send()
[in] | orderingChannel | See RakPeerInterface::Send()
[in] | systemIdentifier | See RakPeerInterface::Send()
[out] | returnData | Written to by the function registered with RegisterBlockingFunction.
Returns
true if successfully called. False on disconnect, function not registered, or not connected to begin with
void RakNet::RPC4::CallLoopback | ( | const char * | uniqueID,
 |  | RakNet::BitStream * | bitStream
 | ) |  |
Deprecated:
Use RegisterSlot() and Signal() with your own RakNetGUID as the send target Send to the attached instance of RakPeer. See RakPeerInterface::SendLoopback()
Parameters
[in] | Identifier | originally passed to RegisterFunction() on the local system
[in] | bitStream | bitStream encoded data to send to the function callback
virtual PluginReceiveResult RakNet::RPC4::OnReceive ( Packet * packet )
protectedvirtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

bool RakNet::RPC4::RegisterFunction | ( | const char * | uniqueID,
 |  | void(*)(RakNet::BitStream *userData, Packet *packet) | functionPointer
 | ) |  |

Register a function pointer to be callable from a remote system.

Deprecated:
Use RegisterSlot

The hash of the function name will be stored as an association with the function pointer When a call is made to call this function from the Call() or CallLoopback() function, the function pointer will be invoked with the passed bitStream to Call() and the actual Packet that RakNet got.

See Also
RegisterPacketCallback()
Parameters
[in] | uniqueID | Identifier to be associated with functionPointer. If this identifier is already in use, the call will return false.
[in] | functionPointer | C function pointer to be called
Returns
True if the hash of uniqueID is not in use, false otherwise.
void RakNet::RPC4::RegisterLocalCallback | ( | const char * | uniqueID,
 |  | MessageID | messageId
 | ) |  |
Deprecated:
Use RegisterSlot and invoke on self only when the packet you want arrives When a RakNet Packet with the specified identifier is returned, execute CallLoopback() on a function previously registered with RegisterFunction() For example, you could call "OnClosedConnection" whenever you get ID_DISCONNECTION_NOTIFICATION or ID_CONNECTION_LOST
Parameters
[in] | uniqueID | Identifier passed to RegisterFunction()
[in] | messageId | What RakNet packet ID to call on, for example ID_DISCONNECTION_NOTIFICATION or ID_CONNECTION_LOST
void RakNet::RPC4::RegisterSlot | ( | const char * | sharedIdentifier,
 |  | void(*)(RakNet::BitStream *userData, Packet *packet) | functionPointer,
 |  | int | callPriority
 | ) |  |

Register a slot, which is a function pointer to one or more implementations that supports this function signature When a signal occurs, all slots with the same identifier are called.

Parameters
[in] | sharedIdentifier | A string to identify the slot. Recommended to be the same as the name of the function.
[in] | functionPtr | Pointer to the function. For C, just pass the name of the function. For C++, use ARPC_REGISTER_CPP_FUNCTION
[in] | callPriority | Slots are called by order of the highest callPriority first. For slots with the same priority, they are called in the order they are registered
void RakNet::RPC4::Signal | ( | const char * | sharedIdentifier,
 |  | RakNet::BitStream * | bitStream,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | const AddressOrGUID | systemIdentifier,
 |  | bool | broadcast,
 |  | bool | invokeLocal
 | ) |  |

Calls zero or more functions identified by sharedIdentifier registered with RegisterSlot()

Parameters
[in] | sharedIdentifier | parameter of the same name passed to RegisterSlot() on the remote system
[in] | bitStream | bitStream encoded data to send to the function callback
[in] | priority | See RakPeerInterface::Send()
[in] | reliability | See RakPeerInterface::Send()
[in] | orderingChannel | See RakPeerInterface::Send()
[in] | systemIdentifier | See RakPeerInterface::Send()
[in] | broadcast | See RakPeerInterface::Send()
[in] | invokeLocal | If true, also sends to self.
bool RakNet::RPC4::UnregisterFunction ( const char * uniqueID )

Unregister a function pointer previously registered with RegisterFunction()

Parameters
[in] Identifier originally passed to RegisterFunction()
Returns
True if the hash of uniqueID was in use, and hence removed. false otherwise.
bool RakNet::RPC4::UnregisterLocalCallback | ( | const char * | uniqueID,
 |  | MessageID | messageId
 | ) |  |

Remove the association created with RegisterPacketCallback()

Parameters
[in] | uniqueID | Identifier passed as uniqueID to RegisterLocalCallback()
[in] | messageId | Identifier passed as messageId to RegisterLocalCallback()
Returns
True if the combination of uniqueID and messageId was in use, and hence removed
bool RakNet::RPC4::UnregisterSlot ( const char * sharedIdentifier )

Remove the association created with RegisterSlot()

Parameters
[in] sharedIdentifier Identifier passed as sharedIdentifier to RegisterSlot()
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/RPC4Plugin.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RPC3

Classes | Enumerations
RPC3
Plugins

Remote procedure calls, powered by the 3rd party library Boost. More...

Classes

class RakNet::RPC3
The RPC3 plugin allows you to call remote functions as if they were local functions, using the standard function call syntax. More...

Enumerations

enum RakNet::RPCErrorCodes {
RakNet::RPC_ERROR_FUNCTION_NOT_REGISTERED, RakNet::RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RakNet::RPC_ERROR_OBJECT_DOES_NOT_EXIST, RakNet::RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE,
RakNet::RPC_ERROR_FUNCTION_NOT_REGISTERED, RakNet::RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RakNet::RPC_ERROR_CALLING_CPP_AS_C, RakNet::RPC_ERROR_CALLING_C_AS_CPP
}
Error codes returned by a remote system as to why an RPC function call cannot execute. More...

Detailed Description

Remote procedure calls, powered by the 3rd party library Boost.

Enumeration Type Documentation

enum RakNet::RPCErrorCodes

Error codes returned by a remote system as to why an RPC function call cannot execute.

Error code follows packet ID ID_RPC_REMOTE_ERROR, that is packet->data[1]
Name of the function will be appended starting at packet->data[2]

Enumerator:
RPC_ERROR_FUNCTION_NOT_REGISTERED

Named function was not registered with RegisterFunction(). Check your spelling.

RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE

RPC3::SetNetworkIDManager() was not called, and it must be called to call a C++ object member.

RPC_ERROR_OBJECT_DOES_NOT_EXIST

Cannot execute C++ object member call because the object specified by SetRecipientObject() does not exist on this system.

RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE

Internal error, index optimization for function lookup does not exist.

RPC_ERROR_FUNCTION_NOT_REGISTERED

Named function was not registered with RegisterFunction(). Check your spelling.

RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED

Named function was registered, but later unregistered with UnregisterFunction() and can no longer be called.

RPC_ERROR_CALLING_CPP_AS_C

SetRecipientObject() was not called before Call(), but the registered pointer is a class member If you intended to call a class member function, call SetRecipientObject() with a valid object first.

RPC_ERROR_CALLING_C_AS_CPP

SetRecipientObject() was called before Call(), but RegisterFunction() was called with isObjectMember=false If you intended to call a C function, call SetRecipientObject(UNASSIGNED_NETWORK_ID) first.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: TeamBalancer

Classes | Typedefs
TeamBalancer
Plugins

Set and network team selection (supports peer to peer or client/server) More...

Classes

class RakNet::TeamBalancer
Set and network team selection (supports peer to peer or client/server) More...

Typedefs

typedef unsigned char RakNet::TeamId

Detailed Description

Set and network team selection (supports peer to peer or client/server)

Automatically handles transmission and resolution of team selection, including team switching and balancing

Deprecated:
Use TeamManager intead

Typedef Documentation

typedef unsigned char RakNet::TeamId

0...254 for your team number identifiers. 255 is reserved as undefined.

Deprecated:
Use TeamManager intead
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::TeamBalancer Class Reference

  • TeamBalancer
Public Types | Public Member Functions | Protected Member Functions | List of all members
RakNet::TeamBalancer Class Reference
TeamBalancer

Set and network team selection (supports peer to peer or client/server) More...

#include <TeamBalancer.h>

Inheritance diagram for RakNet::TeamBalancer:
RakNet::PluginInterface2

Public Types

enum DefaultAssigmentAlgorithm { SMALLEST_TEAM, FILL_IN_ORDER }

Public Member Functions

void | SetTeamSizeLimit (TeamId team, unsigned short limit)
Set the limit to the number of players on the specified team.
void | SetDefaultAssignmentAlgorithm (DefaultAssigmentAlgorithm daa)
Determine how players' teams will be set when they call RequestAnyTeam()
void | SetForceEvenTeams (bool force)
By default, teams can be unbalanced up to the team size limit defined by SetTeamSizeLimits()
void | SetLockTeams (bool lock)
If set, calls to RequestSpecificTeam() and RequestAnyTeam() will return the team you are currently on.
void | RequestSpecificTeam (NetworkID memberId, TeamId desiredTeam)
void | CancelRequestSpecificTeam (NetworkID memberId)
void | RequestAnyTeam (NetworkID memberId)
TeamId | GetMyTeam (NetworkID memberId) const
void | DeleteMember (NetworkID memberId)
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Protected Member Functions

virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
void | OnAttach (void)
Called when the interface is attached.

Detailed Description

Set and network team selection (supports peer to peer or client/server)

Automatically handles transmission and resolution of team selection, including team switching and balancing.
Usage: TODO

Deprecated:
Use TeamManager intead

Member Enumeration Documentation

enum RakNet::TeamBalancer::DefaultAssigmentAlgorithm
Enumerator:
SMALLEST_TEAM

Among all the teams, join the team with the smallest number of players.

FILL_IN_ORDER

Join the team with the lowest index that has open slots.

Member Function Documentation

void RakNet::TeamBalancer::CancelRequestSpecificTeam ( NetworkID memberId )

If ID_TEAM_BALANCER_REQUESTED_TEAM_CHANGE_PENDING is returned after a call to RequestSpecificTeam(), the request will stay in memory on the host and execute when available, or until the teams become locked. You can cancel the request by calling CancelRequestSpecificTeam(), in which case you will stay on your existing team.

Note
Due to latency, even after calling CancelRequestSpecificTeam() you may still get ID_TEAM_BALANCER_SET_TEAM if the packet was already in transmission.
Parameters
[in] memberId If there is more than one player per computer, this number identifies that player. Use any consistent value, such as UNASSIGNED_NETWORK_ID if there is only one player.
void RakNet::TeamBalancer::DeleteMember ( NetworkID memberId )

If you called RequestSpecificTeam() or RequestAnyTeam() with a value for memberId that Has since been deleted, call DeleteMember(). to notify this plugin of that event. Not necessary with only one team member per system

Parameters
[in] memberId If there is more than one player per computer, this number identifies that player. Use any consistent value, such as UNASSIGNED_NETWORK_ID if there is only one player.
TeamId RakNet::TeamBalancer::GetMyTeam ( NetworkID memberId ) const

Returns your team. As your team changes, you are notified through the ID_TEAM_BALANCER_TEAM_ASSIGNED packet in byte 1. Returns UNASSIGNED_TEAM_ID initially

Precondition
For this to return anything other than UNASSIGNED_TEAM_ID, connect to a properly initialized host and RequestSpecificTeam() or RequestAnyTeam() first
Parameters
[in] memberId If there is more than one player per computer, this number identifies that player. Use any consistent value, such as UNASSIGNED_NETWORK_ID if there is only one player.
Returns
UNASSIGNED_TEAM_ID for no team. Otherwise, the index should range from 0 to one less than the size of the list passed to SetTeamSizeLimits() on the host
virtual void RakNet::TeamBalancer::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
protectedvirtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::TeamBalancer::OnReceive ( Packet * packet )
protectedvirtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

void RakNet::TeamBalancer::RequestAnyTeam ( NetworkID memberId )

Allow host to pick your team, based on whatever algorithm it uses for default team assignments. This only has an effect if you are not currently on a team (GetMyTeam() returns UNASSIGNED_TEAM_ID)

Precondition
Call SetTeamSizeLimits() on the host and call SetHostGuid() on this system
Parameters
[in] memberId If there is more than one player per computer, this number identifies that player. Use any consistent value, such as UNASSIGNED_NETWORK_ID if there is only one player.
void RakNet::TeamBalancer::RequestSpecificTeam | ( | NetworkID | memberId,
 |  | TeamId | desiredTeam
 | ) |  |

Set your requested team. UNASSIGNED_TEAM_ID means no team. After enough time for network communication, ID_TEAM_BALANCER_SET_TEAM will be returned with your current team, or If team switch is not possible, ID_TEAM_BALANCER_REQUESTED_TEAM_CHANGE_PENDING or ID_TEAM_BALANCER_TEAMS_LOCKED will be returned. In the case of ID_TEAM_BALANCER_REQUESTED_TEAM_CHANGE_PENDING the request will stay in memory. ID_TEAM_BALANCER_SET_TEAM will be returned when someone on the desired team leaves or wants to switch to your team. If SetLockTeams(true) is called while you have a request pending, you will get ID_TEAM_BALANCER_TEAMS_LOCKED

Precondition
Call SetTeamSizeLimits() on the host and call SetHostGuid() on this system. If the host is not running the TeamBalancer plugin or did not have SetTeamSizeLimits() called, then you will not get any response.
Parameters
[in] | memberId | If there is more than one player per computer, this number identifies that player. Use any consistent value, such as UNASSIGNED_NETWORK_ID if there is only one player.
[in] | desiredTeam | An index representing your team number. The index should range from 0 to one less than the size of the list passed to SetTeamSizeLimits() on the host. You can also pass UNASSIGNED_TEAM_ID to not be on any team (such as if spectating)
void RakNet::TeamBalancer::SetDefaultAssignmentAlgorithm ( DefaultAssigmentAlgorithm daa )

Determine how players' teams will be set when they call RequestAnyTeam()

Based on the specified enumeration, a player will join a team automatically Defaults to SMALLEST_TEAM This function is only used by the host

Parameters
[in] daa Enumeration describing the algorithm to use
void RakNet::TeamBalancer::SetForceEvenTeams ( bool force )

By default, teams can be unbalanced up to the team size limit defined by SetTeamSizeLimits()

If SetForceEvenTeams(true) is called on the host, then teams cannot be unbalanced by more than 1 player If teams are uneven at the time that SetForceEvenTeams(true) is called, players at randomly will be switched, and will be notified of ID_TEAM_BALANCER_TEAM_ASSIGNED If players disconnect from the host such that teams would not be even, and teams are not locked, then a player from the largest team is randomly moved to even the teams. Defaults to false

Note
SetLockTeams(true) takes priority over SetForceEvenTeams(), so if teams are currently locked, this function will have no effect until teams become unlocked.
Parameters
[in] force True to force even teams. False to allow teams to not be evenly matched
void RakNet::TeamBalancer::SetLockTeams ( bool lock )

If set, calls to RequestSpecificTeam() and RequestAnyTeam() will return the team you are currently on.

However, if those functions are called and you do not have a team, then you will be assigned to a default team according to SetDefaultAssignmentAlgorithm() and possibly SetForceEvenTeams(true) If lock is false, and SetForceEvenTeams() was called with force as true, and teams are currently uneven, they will be made even, and those players randomly moved will get ID_TEAM_BALANCER_TEAM_ASSIGNED Defaults to false

Parameters
[in] lock True to lock teams, false to unlock
void RakNet::TeamBalancer::SetTeamSizeLimit | ( | TeamId | team,
 |  | unsigned short | limit
 | ) |  |

Set the limit to the number of players on the specified team.

SetTeamSizeLimit() must be called on the host, so the host can enforce the maximum number of players on each team. SetTeamSizeLimit() can be called on all systems if desired - for example, in a P2P environment you may wish to call it on all systems in advanced in case you become host.

Parameters
[in] | team | Which team to set the limit for
[in] | limit | The maximum number of people on this team
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/TeamBalancer.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: TeamManager

Classes | Typedefs | Enumerations
TeamManager
Plugins

Automates networking and list management for teams. More...

Classes

struct | RakNet::TeamSelection
Parameter to TM_World::ReferenceTeamMember() More...
class | RakNet::TM_TeamMember
A member of one or more teams. More...
class | RakNet::TM_Team
A team, containing a list of TM_TeamMember instances. More...
class | RakNet::TM_World
Stores a list of teams which may be enforcing a balanced number of members. More...
class | RakNet::TeamManager
Automates networking and list management for teams. More...

Typedefs

typedef unsigned char | RakNet::NoTeamId
A subcategory of not being on a team. For example, 0 may mean no team for a player, while 1 may mean no team for a spectator. Defined by the user.
typedef uint16_t | RakNet::TeamMemberLimit

Enumerations

enum RakNet::JoinTeamType { RakNet::JOIN_ANY_AVAILABLE_TEAM, RakNet::JOIN_SPECIFIC_TEAM, RakNet::JOIN_NO_TEAM }

Detailed Description

Automates networking and list management for teams.

When used with ReplicaManager3 and FullyConnectedMesh2, provides a complete solution to managing a distributed list of teams and team member objects with support for host migration.

Typedef Documentation

typedef uint16_t RakNet::TeamMemberLimit

Maximum number of members on one team. Use 65535 for unlimited.

Enumeration Type Documentation

enum RakNet::JoinTeamType
Enumerator:
JOIN_ANY_AVAILABLE_TEAM

Attempt to join the first available team.

JOIN_SPECIFIC_TEAM

Attempt to join a specific team, previously added with TM_World::ReferenceTeam()

JOIN_NO_TEAM

No team. Always succeeds.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::TeamSelection Struct Reference

  • TeamSelection
Static Public Member Functions | List of all members
RakNet::TeamSelection Struct Reference
TeamManager

Parameter to TM_World::ReferenceTeamMember() More...

#include <TeamManager.h>

Static Public Member Functions

static TeamSelection | AnyAvailable (void)
Join any team that has available slots and is tagged with ALLOW_JOIN_ANY_AVAILABLE_TEAM.
static TeamSelection | SpecificTeam (TM_Team *specificTeamToJoin)
Join a specific team if it has available slots, and is tagged with JOIN_SPECIFIC_TEAMS.
static TeamSelection | NoTeam (NoTeamId noTeamSubcategory)
Do not join a team, or leave all current teams.

Detailed Description

Parameter to TM_World::ReferenceTeamMember()

Use TeamSelection::AnyAvailable(), TeamSelection::SpecificTeam(), or TeamSelection::NoTeam()

Member Function Documentation

static TeamSelection RakNet::TeamSelection::AnyAvailable ( void )
static

Join any team that has available slots and is tagged with ALLOW_JOIN_ANY_AVAILABLE_TEAM.

ID_TEAM_BALANCER_TEAM_ASSIGNED, ID_TEAM_BALANCER_REQUESTED_TEAM_FULL, or ID_TEAM_BALANCER_REQUESTED_TEAM_LOCKED will be returned to all systems.

static TeamSelection RakNet::TeamSelection::NoTeam ( NoTeamId noTeamSubcategory )
static

Do not join a team, or leave all current teams.

This always succeeds. ID_TEAM_BALANCER_TEAM_ASSIGNED will be returned to all systems.

Parameters
[in] noTeamSubcategory Even when not on a team, you can internally identify a subcategory of not being on a team, such as AI or spectator.
static TeamSelection RakNet::TeamSelection::SpecificTeam ( TM_Team * specificTeamToJoin )
static

Join a specific team if it has available slots, and is tagged with JOIN_SPECIFIC_TEAMS.

ID_TEAM_BALANCER_TEAM_ASSIGNED, ID_TEAM_BALANCER_REQUESTED_TEAM_FULL, or ID_TEAM_BALANCER_REQUESTED_TEAM_LOCKED will be returned to all systems.

Parameters
[in] specificTeamToJoin Which team to attempt to join.
The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/TeamManager.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::TM_TeamMember Class Reference

  • TM_TeamMember
Public Member Functions | List of all members
RakNet::TM_TeamMember Class Reference
TeamManager

A member of one or more teams. More...

#include <TeamManager.h>

Public Member Functions

bool | RequestTeam (TeamSelection teamSelection)
Request to join any team, a specific team, or to leave all teams.
bool | RequestTeamSwitch (TM_Team *teamToJoin, TM_Team *teamToLeave)
Similar to RequestTeam with TeamSelection::SpecificTeam(), but leave a team simultaneously when the desired team is joinable.
TeamSelection | GetRequestedTeam (void) const
Returns the first requested team in the list of requested teams, if you have a requested team at all.
void | GetRequestedSpecificTeams (DataStructures::List< TM_Team * > &requestedTeams) const
Returns pending calls to RequestTeam() when using TeamSelection::JOIN_SPECIFIC_TEAM.
bool | HasRequestedTeam (TM_Team *team) const
Returns if the specified team is in the list of pending requested teams.
unsigned int | GetRequestedTeamIndex (TM_Team *team) const
Returns the index of team in the requested teams list.
unsigned int | GetRequestedTeamCount (void) const
bool | CancelTeamRequest (TM_Team *specificTeamToCancel)
Cancels a request to join a specific team.
bool | LeaveTeam (TM_Team *team, NoTeamId _noTeamSubcategory)
Leave a team.
bool | LeaveAllTeams (NoTeamId noTeamSubcategory)
Leave all teams Leaves all teams you are on, and sets noTeamSubcategory.
TM_Team * | GetCurrentTeam (void) const
unsigned int | GetCurrentTeamCount (void) const
TM_Team * | GetCurrentTeamByIndex (unsigned int index)
void | GetCurrentTeams (DataStructures::List< TM_Team * > &_teams) const
void | GetLastTeams (DataStructures::List< TM_Team * > &_teams) const
bool | IsOnTeam (TM_Team *team) const
NetworkID | GetNetworkID (void) const
TM_World * | GetTM_World (void) const
void | SerializeConstruction (BitStream *constructionBitstream)
Serializes the current state of this object.
bool | DeserializeConstruction (TeamManager *teamManager, BitStream *constructionBitstream)
Deserializes the current state of this object.
void | SetOwner (void *o)
void * | GetOwner (void) const
NoTeamId | GetNoTeamId (void) const
unsigned int | GetWorldIndex (void) const
Return world->GetTeamMemberIndex(this)

Detailed Description

A member of one or more teams.

Contains data and operations on data to manage which team your game's team members are on. Best used as a composite member of your "User" or "Player" class(es). When using with ReplicaManager3, call TM_TeamMember::ReferenceTeamMember() in Replica3::DeserializeConstruction() and TM_TeamMember::DeserializeConstruction() in Replica3::PostDeserializeConstruction() There is otherwise no need to manually serialize the class, as operations are networked internally.

Member Function Documentation

bool RakNet::TM_TeamMember::CancelTeamRequest ( TM_Team * specificTeamToCancel )

Cancels a request to join a specific team.

Useful if you got ID_TEAM_BALANCER_REQUESTED_TEAM_FULL or ID_TEAM_BALANCER_REQUESTED_TEAM_LOCKED and changed your mind about joining the team.

Note
This is not guaranteed to work due to latency. To clarify, If the host switches your team at the same time you call CancelRequestTeam() you may still get ID_TEAM_BALANCER_TEAM_ASSIGNED for the team you tried to cancel.
Parameters
[in] specificTeamToCancel Which team to no longer join. Use 0 for all.
Returns
false On invalid or unnecessary operation. Otherwise returns true
bool RakNet::TM_TeamMember::DeserializeConstruction | ( | TeamManager * | teamManager,
 |  | BitStream * | constructionBitstream
 | ) |  |

Deserializes the current state of this object.

See SerializeConstruction for more details()

Note
DeserializeConstruction also calls ReferenceTeamMember on the passed teamManager instance, there is no need to do so yourself
Parameters
[in] | teamManager | TeamManager instance
[in] | constructionBitstream | This object serialized to a BitStream
TM_Team* RakNet::TM_TeamMember::GetCurrentTeam ( void ) const
Returns
Get the first team we are on, or 0 if we are not on a team.
TM_Team* RakNet::TM_TeamMember::GetCurrentTeamByIndex ( unsigned int index )
Returns
Returns one of the teams in the current team list, up to GetCurrentTeamCount()
unsigned int RakNet::TM_TeamMember::GetCurrentTeamCount ( void ) const
Returns
How many teams we are on
void RakNet::TM_TeamMember::GetCurrentTeams ( DataStructures::List< TM_Team * > & _teams ) const
Parameters
[out] Get all teams we are on, as a list
void RakNet::TM_TeamMember::GetLastTeams ( DataStructures::List< TM_Team * > & _teams ) const

For each team member, when you get ID_TEAM_BALANCER_TEAM_ASSIGNED for that member, the team list is saved. Use this function to get that list, for example to determine which teams we just left or joined

Parameters
[out] _teams The previous list of teams we were on
NetworkID RakNet::TM_TeamMember::GetNetworkID ( void ) const
Returns
The teamMemberID parameter passed to TM_World::ReferenceTeamMember()
NoTeamId RakNet::TM_TeamMember::GetNoTeamId ( void ) const
Returns
If not on a team, returns the current NoTeamId value
void* RakNet::TM_TeamMember::GetOwner ( void ) const
Returns
Whatever was passed to SetOwner()
void RakNet::TM_TeamMember::GetRequestedSpecificTeams ( DataStructures::List< TM_Team * > & requestedTeams ) const

Returns pending calls to RequestTeam() when using TeamSelection::JOIN_SPECIFIC_TEAM.

Parameters
[out] All pending requested teams
TeamSelection RakNet::TM_TeamMember::GetRequestedTeam ( void ) const

Returns the first requested team in the list of requested teams, if you have a requested team at all.

Returns
TeamSelection::SpecificTeam(), TeamSelection::NoTeam(), or TeamSelection::AnyAvailable()
unsigned int RakNet::TM_TeamMember::GetRequestedTeamCount ( void ) const
Returns
The number of teams that would be returned by a call to GetRequestedSpecificTeams()
unsigned int RakNet::TM_TeamMember::GetRequestedTeamIndex ( TM_Team * team ) const

Returns the index of team in the requested teams list.

Parameters
[in] The team we are checking
Returns
-1 if we did not requested to join this team. Otherwise the index.
TM_World* RakNet::TM_TeamMember::GetTM_World ( void ) const
Returns
The TM_World instance that was used when calling TM_World::ReferenceTeamMember()
bool RakNet::TM_TeamMember::HasRequestedTeam ( TM_Team * team ) const

Returns if the specified team is in the list of pending requested teams.

Parameters
[in] The team we are checking
Returns
Did we request to join this specific team?
bool RakNet::TM_TeamMember::IsOnTeam ( TM_Team * team ) const
Parameters
[in] The team we are checking
Returns
Are we on this team?
bool RakNet::TM_TeamMember::LeaveAllTeams ( NoTeamId noTeamSubcategory )

Leave all teams Leaves all teams you are on, and sets noTeamSubcategory.

Note
This is the same as and just calls RequestTeam(TeamSelection::NoTeam(noTeamSubcategory));
Returns
false On invalid or unnecessary operation. Otherwise returns true
bool RakNet::TM_TeamMember::LeaveTeam | ( | TM_Team * | team,
 |  | NoTeamId | _noTeamSubcategory
 | ) |  |

Leave a team.

Leaves a team that you are on. Always succeeds provided you are on that team Generates ID_TEAM_BALANCER_TEAM_ASSIGNED on all systems on success. If you leave the last team you are on, noTeamSubcategory is set as well.

Parameters
[in] | team | Which team to leave
[in] | _noTeamSubcategory | If the team member has been removed from all teams, which subcategory of NoTeamId to set them to
Returns
false On invalid or unnecessary operation. Otherwise returns true
bool RakNet::TM_TeamMember::RequestTeam ( TeamSelection teamSelection )

Request to join any team, a specific team, or to leave all teams.

Function will return false on invalid operations, such as joining a team you are already on. Will also fail with TeamSelection::JOIN_ANY_AVAILABLE_TEAM if you are currently on a team. On success, every system will get ID_TEAM_BALANCER_TEAM_ASSIGNED. Use TeamManager::DecomposeTeamAssigned() to get details of which team member the message refers to. On failure, all systems will get ID_TEAM_BALANCER_REQUESTED_TEAM_FULL or ID_TEAM_BALANCER_REQUESTED_TEAM_LOCKED. Use TeamManager::DecomposeTeamFull() and TeamManager::DecomposeTeamLocked() to get details of which team member the message refers to.

Note
Joining a specific team with this function may result in being on more than one team at once, even if you call the function while locally only on one team. If your game depends on only being on one team at a team, use RequestTeamSwitch() instead with the parameter teamToLeave set to 0
Parameters
[in] TeamSelection::AnyAvailable(),TeamSelection::SpecificTeam(),or TeamSelection::NoTeam()
Returns
false On invalid or unnecessary operation. Otherwise returns true
bool RakNet::TM_TeamMember::RequestTeamSwitch | ( | TM_Team * | teamToJoin,
 |  | TM_Team * | teamToLeave
 | ) |  |

Similar to RequestTeam with TeamSelection::SpecificTeam(), but leave a team simultaneously when the desired team is joinable.

Parameters
[in] | teamToJoin | Which team to join
[in] | teamToLeave | If 0, means leave all current teams. Otherwise, leave the specified team.
Returns
false On invalid or unnecessary operation. Otherwise returns true
void RakNet::TM_TeamMember::SerializeConstruction ( BitStream * constructionBitstream )

Serializes the current state of this object.

To replicate a TM_TeamMember on another system, first instantiate the object using your own code, or a system such as ReplicaManager3. Next, call SerializeConstruction() from whichever system owns the team member Last, call DeserializeConstruction() on the newly created TM_TeamMember

Note
You must instantiate and deserialize all TM_Team instances that the team member refers to before calling DesrializeConstruction(). ReplicaManager3::PostSerializeConstruction() and ReplicaManager3::PostDeserializeConstruction() will ensure this.
Parameters
[out] constructionBitstream This object serialized to a BitStream
void RakNet::TM_TeamMember::SetOwner ( void * o )
Parameters
[in] o Stores a void* for your own use. If using composition, this is useful to store a pointer to the containing object.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/TeamManager.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::TM_Team Class Reference

  • TM_Team
Public Member Functions | List of all members
RakNet::TM_Team Class Reference
TeamManager

A team, containing a list of TM_TeamMember instances. More...

#include <TeamManager.h>

Public Member Functions

bool | SetMemberLimit (TeamMemberLimit _teamMemberLimit, NoTeamId noTeamSubcategory)
Set the maximum number of members that can join this team. Defaults to 65535 Setting the limit lower than the existing number of members kicks members out, and assigns noTeamSubcategory to them if they have no other team to go to Setting the limit higher allows members to join in. If a member has a pending request to join this team, they join automatically and ID_TEAM_BALANCER_TEAM_ASSIGNED will be returned for those members.
TeamMemberLimit | GetMemberLimit (void) const
TeamMemberLimit | GetMemberLimitSetting (void) const
bool | SetJoinPermissions (JoinPermissions _joinPermissions)
Who can join this team under what conditions, while the team is not full To not allow new joins, pass 0 To allow all new joins under any circumstances, bitwise-OR all permission defines. For an invite-only team, use ALLOW_JOIN_SPECIFIC_TEAM only and only allow the requester to call TM_TeamMember::RequestTeam() upon invitiation through your game code. Defaults to allow all.
JoinPermissions | GetJoinPermissions (void) const
void | LeaveTeam (TM_TeamMember *teamMember, NoTeamId noTeamSubcategory)
Removes a member from a team he or she is on.
bool | GetBalancingApplies (void) const
void | GetTeamMembers (DataStructures::List< TM_TeamMember * > &_teamMembers) const
unsigned int | GetTeamMembersCount (void) const
TM_TeamMember * | GetTeamMemberByIndex (unsigned int index) const
NetworkID | GetNetworkID (void) const
TM_World * | GetTM_World (void) const
void | SerializeConstruction (BitStream *constructionBitstream)
Used by the host to serialize the initial state of this object to a new system.
bool | DeserializeConstruction (TeamManager *teamManager, BitStream *constructionBitstream)
Used by non-host systems to read the bitStream written by SerializeConstruction()
void | SetOwner (void *o)
void * | GetOwner (void) const
unsigned int | GetWorldIndex (void) const
Return world->GetTeamIndex(this)

Detailed Description

A team, containing a list of TM_TeamMember instances.

Contains lists of TM_TeamMember instances Best used as a composite member of your "Team" or "PlayerList" class(es). When using with ReplicaManager3, call TM_Team::ReferenceTeam() in Replica3::DeserializeConstruction() and TM_Team::DeserializeConstruction() in Replica3::PostDeserializeConstruction() There is otherwise no need to manually serialize the class, as operations are networked internally.

Member Function Documentation

bool RakNet::TM_Team::DeserializeConstruction | ( | TeamManager * | teamManager,
 |  | BitStream * | constructionBitstream
 | ) |  |

Used by non-host systems to read the bitStream written by SerializeConstruction()

On non-host systems, after creating existing objects, call DeserializeConstruction() to read and setup that object Creating the actual Team and TeamMember objects should be handled by your game code, or a system such as ReplicaManager3

bool RakNet::TM_Team::GetBalancingApplies ( void ) const
Returns
What was passed as the applyBalancing parameter TM_World::ReferenceTeam() when this team was added.
JoinPermissions RakNet::TM_Team::GetJoinPermissions ( void ) const
Returns
Whatever was passed to SetJoinPermissions(), or the default.
TeamMemberLimit RakNet::TM_Team::GetMemberLimit ( void ) const
Returns
If team balancing is on, the most members that can be on this team that would not either unbalance it or exceed the value passed to SetMemberLimit(). If team balancing is off, the same as GetMemberLimitSetting()
TeamMemberLimit RakNet::TM_Team::GetMemberLimitSetting ( void ) const
Returns
What was passed to SetMemberLimit() or the default
NetworkID RakNet::TM_Team::GetNetworkID ( void ) const
Returns
The teamID parameter passed to TM_World::ReferenceTeam()
void* RakNet::TM_Team::GetOwner ( void ) const
Returns
Whatever was passed to SetOwner()
TM_TeamMember* RakNet::TM_Team::GetTeamMemberByIndex ( unsigned int index ) const
Returns
A team member on this team. Members are stored in the order they are added
Parameters
[in] index A value between 0 and GetTeamMembersCount()
void RakNet::TM_Team::GetTeamMembers ( DataStructures::List< TM_TeamMember * > & _teamMembers ) const
Parameters
[out] All team members of this team
unsigned int RakNet::TM_Team::GetTeamMembersCount ( void ) const
Returns
The number of team members on this team
TM_World* RakNet::TM_Team::GetTM_World ( void ) const
Returns
The TM_World instance that was used when calling TM_World::ReferenceTeamMember()
void RakNet::TM_Team::LeaveTeam | ( | TM_TeamMember * | teamMember,
 |  | NoTeamId | noTeamSubcategory
 | ) |  |

Removes a member from a team he or she is on.

Identical to teamMember->LeaveTeam(this, noTeamSubcategory); See TeamMember::LeaveTeam() for details.

Parameters
[in] | teamMember | Which team member to remove
[in] | noTeamSubcategory | If the team member has been removed from all teams, which subcategory of NoTeamId to set them to
void RakNet::TM_Team::SerializeConstruction ( BitStream * constructionBitstream )

Used by the host to serialize the initial state of this object to a new system.

On the host, when sending existing objects to a new system, call SerializeConstruction() on each of those objects to serialize creation state. Creating the actual Team and TeamMember objects should be handled by your game code, or a system such as ReplicaManager3

bool RakNet::TM_Team::SetJoinPermissions ( JoinPermissions _joinPermissions )

Who can join this team under what conditions, while the team is not full To not allow new joins, pass 0 To allow all new joins under any circumstances, bitwise-OR all permission defines. For an invite-only team, use ALLOW_JOIN_SPECIFIC_TEAM only and only allow the requester to call TM_TeamMember::RequestTeam() upon invitiation through your game code. Defaults to allow all.

Parameters
[in] _joinPermissions Bitwise combination of ALLOW_JOIN_ANY_AVAILABLE_TEAM, ALLOW_JOIN_SPECIFIC_TEAM, ALLOW_JOIN_REBALANCING
Returns
false On invalid or unnecessary operation. Otherwise returns true
bool RakNet::TM_Team::SetMemberLimit | ( | TeamMemberLimit | _teamMemberLimit,
 |  | NoTeamId | noTeamSubcategory
 | ) |  |

Set the maximum number of members that can join this team. Defaults to 65535 Setting the limit lower than the existing number of members kicks members out, and assigns noTeamSubcategory to them if they have no other team to go to Setting the limit higher allows members to join in. If a member has a pending request to join this team, they join automatically and ID_TEAM_BALANCER_TEAM_ASSIGNED will be returned for those members.

Parameters
[in] | _teamMemberLimit | The new limit
[in] | noTeamSubcategory | Which noTeamSubcategory to assign to members that now have no team.
Returns
false On invalid or unnecessary operation. Otherwise returns true
void RakNet::TM_Team::SetOwner ( void * o )
Parameters
[in] o Stores a void* for your own use. If using composition, this is useful to store a pointer to the containing object.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/TeamManager.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::TM_World Class Reference

  • TM_World
Public Member Functions | List of all members
RakNet::TM_World Class Reference
TeamManager

Stores a list of teams which may be enforcing a balanced number of members. More...

#include <TeamManager.h>

Public Member Functions

TeamManager * | GetTeamManager (void) const
void | AddParticipant (RakNetGUID rakNetGUID)
Add a new system to send team and team member updates to.
void | RemoveParticipant (RakNetGUID rakNetGUID)
Remove a system that was previously added with AddParticipant()
void | SetAutoManageConnections (bool autoAdd)
If true, all new connections are added to this world using AddParticipant()
void | GetParticipantList (DataStructures::List< RakNetGUID > &participantList)
void | ReferenceTeam (TM_Team *team, NetworkID networkId, bool applyBalancing)
Register a TM_Team object with this system.
void | DereferenceTeam (TM_Team *team, NoTeamId noTeamSubcategory)
Unregisters the associated TM_Team object with this system. Call when a TM_Team instance is no longer needed.
unsigned int | GetTeamCount (void) const
TM_Team * | GetTeamByIndex (unsigned int index) const
TM_Team * | GetTeamByNetworkID (NetworkID teamId)
unsigned int | GetTeamIndex (const TM_Team *team) const
Inverse of GetTeamByIndex()
void | ReferenceTeamMember (TM_TeamMember *teamMember, NetworkID networkId)
Register a TM_TeamMember object with this system.
void | DereferenceTeamMember (TM_TeamMember *teamMember)
Unregisters the associated TM_TeamMember object with this system. Call when a TM_TeamMember instance is no longer needed.
unsigned int | GetTeamMemberCount (void) const
TM_TeamMember * | GetTeamMemberByIndex (unsigned int index) const
NetworkID | GetTeamMemberIDByIndex (unsigned int index) const
TM_TeamMember * | GetTeamMemberByNetworkID (NetworkID teamMemberId)
unsigned int | GetTeamMemberIndex (const TM_TeamMember *teamMember) const
Inverse of GetTeamMemberByIndex()
bool | SetBalanceTeams (bool balanceTeams, NoTeamId noTeamSubcategory)
Force or stop forcing teams to be balanced.
bool | GetBalanceTeams (void) const
void | SetHost (RakNetGUID _hostGuid)
Set the host that will perform balancing calculations and send notifications.
RakNetGUID | GetHost (void) const
WorldId | GetWorldId (void) const
void | Clear (void)
Clear all memory and reset everything.

Detailed Description

Stores a list of teams which may be enforcing a balanced number of members.

Each TM_World instance is independent of other TM_World world instances. This enables you to host multiple games on a single computer. Not currently supported to have the same TM_Team or TM_TeamMember in more than one world at a time, but easily added on request.

Member Function Documentation

void RakNet::TM_World::AddParticipant ( RakNetGUID rakNetGUID )

Add a new system to send team and team member updates to.

Parameters
[in] rakNetGUID GUID of the system you are adding. See Packet::rakNetGUID or RakPeerInterface::GetGUIDFromSystemAddress()
void RakNet::TM_World::Clear ( void )

Clear all memory and reset everything.

It is up to the user to deallocate pointers passed to ReferenceTeamMember() or ReferenceTeam(), if so desired.

void RakNet::TM_World::DereferenceTeam | ( | TM_Team * | team,
 |  | NoTeamId | noTeamSubcategory
 | ) |  |

Unregisters the associated TM_Team object with this system. Call when a TM_Team instance is no longer needed.

Parameters
[in] | team | Which team instance to unregister
[in] | noTeamSubcategory | All players on this team are kicked off. If these players then have no team, they are set to this no team category.
void RakNet::TM_World::DereferenceTeamMember ( TM_TeamMember * teamMember )

Unregisters the associated TM_TeamMember object with this system. Call when a TM_TeamMember instance is no longer needed.

Note
This is called by the destructor of TM_TeamMember automatically, so you do not normally need to call this function
bool RakNet::TM_World::GetBalanceTeams ( void ) const
Returns
balanceTeams parameter of SetBalanceTeams(), or the default
RakNetGUID RakNet::TM_World::GetHost ( void ) const
Returns
Returns the current host, or UNASSIGNED_RAKNET_GUID if unknown
void RakNet::TM_World::GetParticipantList ( DataStructures::List< RakNetGUID > & participantList )

Get the participants added with AddParticipant()

Parameters
[out] participantList Participants added with AddParticipant();
TM_Team* RakNet::TM_World::GetTeamByIndex ( unsigned int index ) const
Parameters
[in] index A value between 0 and GetTeamCount()
Returns
Returns whatever was passed to team in the function ReferenceTeam() in the order it was called.
TM_Team* RakNet::TM_World::GetTeamByNetworkID ( NetworkID teamId )
Parameters
[in] teamId Value passed to ReferenceTeam()
Returns
Returns whatever was passed to team in the function ReferenceTeam() with this NetworkID.
unsigned int RakNet::TM_World::GetTeamCount ( void ) const
Returns
Number of teams uniquely added with ReferenceTeam()
unsigned int RakNet::TM_World::GetTeamIndex ( const TM_Team * team ) const

Inverse of GetTeamByIndex()

Parameters
[in] team Which taem
Returns
The index of the specified team, or -1 if not found
TeamManager* RakNet::TM_World::GetTeamManager ( void ) const
Returns
Returns the plugin that created this TM_World instance
TM_TeamMember* RakNet::TM_World::GetTeamMemberByIndex ( unsigned int index ) const
Parameters
[in] index A value between 0 and GetTeamMemberCount()
Returns
Returns whatever was passed to team in the function ReferenceTeamMember() in the order it was called.
TM_TeamMember* RakNet::TM_World::GetTeamMemberByNetworkID ( NetworkID teamMemberId )
Parameters
[in] teamId Value passed to ReferenceTeamMember()
Returns
Returns Returns whatever was passed to team in the function ReferenceTeamMember() with this NetworkID
unsigned int RakNet::TM_World::GetTeamMemberCount ( void ) const
Returns
Number of team members uniquely added with ReferenceTeamMember()
NetworkID RakNet::TM_World::GetTeamMemberIDByIndex ( unsigned int index ) const
Parameters
[in] index A value between 0 and GetTeamMemberCount()
Returns
Returns whatever was passed to teamMemberID in the function ReferenceTeamMember() in the order it was called.
unsigned int RakNet::TM_World::GetTeamMemberIndex ( const TM_TeamMember * teamMember ) const

Inverse of GetTeamMemberByIndex()

Parameters
[in] team Which team member
Returns
The index of the specified team member, or -1 if not found
WorldId RakNet::TM_World::GetWorldId ( void ) const
Returns
The worldId passed to TeamManagr::AddWorld()
void RakNet::TM_World::ReferenceTeam | ( | TM_Team * | team,
 |  | NetworkID | networkId,
 |  | bool | applyBalancing
 | ) |  |

Register a TM_Team object with this system.

Your game should contain instances of TM_Team, for example by using composition with your game's Team or PlayerList class Tell TeamManager about these instances using ReferenceTeam().

Note
The destrutor of TM_Team calls DereferenceTeam() automatically.
Parameters
[in] | team | The instance you are registering
[in] | networkId | Identifies this instance. This value is independent of values used by NetworkIDManager. You can use the same value as the object that contains this instance.
[in] | applyBalancing | Whether or not to include this team for balancing when calling SetBalanceTeams().
void RakNet::TM_World::ReferenceTeamMember | ( | TM_TeamMember * | teamMember,
 |  | NetworkID | networkId
 | ) |  |

Register a TM_TeamMember object with this system.

Your game should contain instances of TM_TeamMember, for example by using composition with your game's User or Player classes Tell TeamManager about these instances using ReferenceTeamMember().

Note
The destrutor of TM_TeamMember calls DereferenceTeamMember() automatically.
Parameters
[in] | teamMember | The instance you are registering
[in] | networkId | Identifies this instance. This value is independent of values used by NetworkIDManager. You can use the same value as the object that contains this instance
void RakNet::TM_World::RemoveParticipant ( RakNetGUID rakNetGUID )

Remove a system that was previously added with AddParticipant()

Systems that disconnect are removed automatically

Parameters
[in] rakNetGUID GUID of the system you are removing. See Packet::rakNetGUID or RakPeerInterface::GetGUIDFromSystemAddress()
void RakNet::TM_World::SetAutoManageConnections ( bool autoAdd )

If true, all new connections are added to this world using AddParticipant()

Defaults to true

Parameters
[in] autoAdd Setting to set
bool RakNet::TM_World::SetBalanceTeams | ( | bool | balanceTeams,
 |  | NoTeamId | noTeamSubcategory
 | ) |  |

Force or stop forcing teams to be balanced.

For each team added with ReferenceTeam() and applyBalancing set to true, players on unbalanced teams will be redistributed While active, players can only join balanced teams if doing so would not cause that team to become unbalanced. If a player on the desired team also wants to switch, then both players will switch simultaneously. Otherwise, ID_TEAM_BALANCER_REQUESTED_TEAM_FULL will be returned to the requester and switching will occur when possible. If balanceTeams is true and later set to false, players waiting on ID_TEAM_BALANCER_REQUESTED_TEAM_FULL will be able to join the desired team immediately provided it is not full.

Parameters
[in] | balanceTeams | Whether to activate or deactivate team balancing.
[in] | noTeamSubcategory | If a player is kicked off a team and is no longer on any team, his or her noTeamSubcategory is set to this value
void RakNet::TM_World::SetHost ( RakNetGUID _hostGuid )

Set the host that will perform balancing calculations and send notifications.

Operations that can cause conflicts due to latency, such as joining teams, are operated on by the host. The result is sent to all systems added with AddParticipant() For a client/server game, call SetHost() with the server's RakNetGUID value on all systems (including the server itself). If you call TeamManager::SetTopology(TM_CLIENT_SERVER), the server will also relay messages between participants. For a peer to peer game, call SetHost() on the same peer when host migration occurs. Use TeamManager::SetTopology(TM_PEER_TO_PEER) in this case.

Note
If using FullyConnectedMesh2, SetHost() is called automatically when ID_FCM2_NEW_HOST is returned.
Parameters
[in] _hostGuid The host, which is the system that will serialize and resolve team disputes and calculate team balancing.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/TeamManager.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::TeamManager Class Reference

  • TeamManager
Public Member Functions | Protected Member Functions | List of all members
RakNet::TeamManager Class Reference
TeamManager

Automates networking and list management for teams. More...

#include <TeamManager.h>

Inheritance diagram for RakNet::TeamManager:
RakNet::PluginInterface2

Public Member Functions

TM_World * | AddWorld (WorldId worldId)
Allocate a world to hold a list of teams and players for that team. Use the returned TM_World object for actual team functionality.
void | RemoveWorld (WorldId worldId)
Deallocate a world created with AddWorld()
unsigned int | GetWorldCount (void) const
TM_World * | GetWorldAtIndex (unsigned int index) const
TM_World * | GetWorldWithId (WorldId worldId) const
void | SetAutoManageConnections (bool autoAdd)
When auto managing connections, call TM_World::AddParticipant() on all worlds for all new connections automatically Defaults to true.
void | SetTopology (TMTopology _topology)
If _topology is set to TM_CLIENT_SERVER, the host will relay messages to participants.
void | DecomposeTeamFull (Packet *packet, TM_World **world, TM_TeamMember **teamMember, TM_Team **team, uint16_t &currentMembers, uint16_t &memberLimitIncludingBalancing, bool &balancingIsActive, JoinPermissions &joinPermissions)
When you get ID_TEAM_BALANCER_REQUESTED_TEAM_FULL, pass the packet to this function to read out parameters.
void | DecomposeTeamLocked (Packet *packet, TM_World **world, TM_TeamMember **teamMember, TM_Team **team, uint16_t &currentMembers, uint16_t &memberLimitIncludingBalancing, bool &balancingIsActive, JoinPermissions &joinPermissions)
When you get ID_TEAM_BALANCER_REQUESTED_TEAM_LOCKED, pass the packet to this function to read out parameters.
void | Clear (void)
Clear all memory and reset everything.
void | DecodeTeamAssigned (Packet *packet, TM_World **world, TM_TeamMember **teamMember)
Reads out the world and teamMember from ID_TEAM_BALANCER_TEAM_ASSIGNED.
void | DecodeTeamCancelled (Packet *packet, TM_World **world, TM_TeamMember **teamMember, TM_Team **teamCancelled)
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Protected Member Functions

virtual void | Update (void)
Update is called every time a packet is checked for .
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
void | DecodeTeamAssigned (RakNet::BitStream *bsIn, TM_World **world, TM_TeamMember **teamMember, NoTeamId &noTeamSubcategory, JoinTeamType &joinTeamType, DataStructures::List< TM_Team * > &newTeam, DataStructures::List< TM_Team * > &teamsLeft, DataStructures::List< TM_Team * > &teamsJoined)
When you get ID_TEAM_BALANCER_TEAM_ASSIGNED, pass the packet to this function to read out parameters.

Detailed Description

Automates networking and list management for teams.

TeamManager provides support for teams. A team is a list of team members. Teams contain properties including the number of team members per team, whether or not tagged teams must have equal numbers of members, and if a team is locked or not to certain entry conditions Team members contain properties including which teams they are on and which teams they want to join if a team is not immediately joinable Advanced functionality includes the ability for a team member to be on multiple teams simultaneously, the ability to swap teams with other members, and the ability to resize the number of members supported per team The architecture is designed for easy integration with ReplicaManager3

Usage:

  1. Define your game classes to represent teams and team members. Your game classes should hold game-specific information such as team name and color.
  2. Have those game classes contain a corresponding TM_Team or TM_TeamMember instance. Operations on teams will be performed by those instances. Use SetOwner() to refer to the parent object when using composition.
  3. Call TeamManager::SetTopology() for client/server or peer to peer.
  4. Call AddWorld() to instantiate a TM_World object which will contain references to your TM_TeamMember and TM_Team instances.
  5. When you instantiate a TM_TeamMember or TM_Team object, call ReferenceTeam() and ReferenceTeamMember() for each corresponding object
  6. When sending world state to a new connection, for example in ReplicaManager3::SerializeConstruction(), call TM_SerializeConstruction() on the corresponding TM_TeamMember and TM_Team objects. TM_Team instances on the new connection must be created before TM_TeamMember instances.
  7. Call TM_DeserializeConstruction() on your new corresponding TM_TeamMember and TM_Team instances.
  8. Execute team operations. ID_TEAM_BALANCER_REQUESTED_TEAM_FULL, ID_TEAM_BALANCER_REQUESTED_TEAM_LOCKED, ID_TEAM_BALANCER_TEAM_REQUESTED_CANCELLED, and ID_TEAM_BALANCER_TEAM_ASSIGNED are returned to all systems when the corresponding event occurs for a team member.
  9. As the peer to peer session host changes, call SetHost() (Not necessary if using FullyConnectedMesh2). If using client/server, you must set the host
    Note
    This replaces TeamBalancer. You cannot use TeamBalancer and TeamManager at the same time.

Member Function Documentation

TM_World* RakNet::TeamManager::AddWorld ( WorldId worldId )

Allocate a world to hold a list of teams and players for that team. Use the returned TM_World object for actual team functionality.

Note
The world is tracked by TeamManager and deallocated by calling Clear()
Parameters
[in] worldId Arbitrary user-defined id of the world to create. Each world instance must have a unique id.
void RakNet::TeamManager::Clear ( void )

Clear all memory and reset everything.

Deallocates TM_World instances. It is up to the user to deallocate pointers passed to ReferenceTeamMember() or ReferenceTeam(), if so desired.

void RakNet::TeamManager::DecodeTeamAssigned | ( | Packet * | packet,
 |  | TM_World ** | world,
 |  | TM_TeamMember ** | teamMember
 | ) |  |

Reads out the world and teamMember from ID_TEAM_BALANCER_TEAM_ASSIGNED.

Note
You can get the current and prior team list from the teamMember itself
Parameters
[in] | A | packet where packet->data[0]==ID_TEAM_BALANCER_TEAM_ASSIGNED
[out] | world | Set to the world this teamMember is on. 0 on bad lookup.
[out] | teamMember | Set to the teamMember affected. 0 on bad lookup.
void RakNet::TeamManager::DecodeTeamAssigned | ( | RakNet::BitStream * | bsIn,
 |  | TM_World ** | world,
 |  | TM_TeamMember ** | teamMember,
 |  | NoTeamId & | noTeamSubcategory,
 |  | JoinTeamType & | joinTeamType,
 |  | DataStructures::List< TM_Team * > & | newTeam,
 |  | DataStructures::List< TM_Team * > & | teamsLeft,
 |  | DataStructures::List< TM_Team * > & | teamsJoined
 | ) |  |
protected

When you get ID_TEAM_BALANCER_TEAM_ASSIGNED, pass the packet to this function to read out parameters.

Parameters
[in] A packet where packet->data[0]==ID_TEAM_BALANCER_TEAM_ASSIGNED
Returns
true on success, false on read error
void RakNet::TeamManager::DecodeTeamCancelled | ( | Packet * | packet,
 |  | TM_World ** | world,
 |  | TM_TeamMember ** | teamMember,
 |  | TM_Team ** | teamCancelled
 | ) |  |
Note
You can get the requested team list from the teamMember itself
Parameters
[in] | A | packet where packet->data[0]==ID_TEAM_BALANCER_TEAM_REQUESTED_CANCELLED
[out] | world | Set to the world this teamMember is on. 0 on bad lookup.
[out] | teamMember | Set to the teamMember affected. 0 on bad lookup.
[out] | teamCancelled | Set to the team that was cancelled. 0 for all teams.
void RakNet::TeamManager::DecomposeTeamFull | ( | Packet * | packet,
 |  | TM_World ** | world,
 |  | TM_TeamMember ** | teamMember,
 |  | TM_Team ** | team,
 |  | uint16_t & | currentMembers,
 |  | uint16_t & | memberLimitIncludingBalancing,
 |  | bool & | balancingIsActive,
 |  | JoinPermissions & | joinPermissions
 | ) |  |

When you get ID_TEAM_BALANCER_REQUESTED_TEAM_FULL, pass the packet to this function to read out parameters.

Parameters
[in] A packet where packet->data[0]==ID_TEAM_BALANCER_REQUESTED_TEAM_FULL
Returns
true on success, false on read error
void RakNet::TeamManager::DecomposeTeamLocked | ( | Packet * | packet,
 |  | TM_World ** | world,
 |  | TM_TeamMember ** | teamMember,
 |  | TM_Team ** | team,
 |  | uint16_t & | currentMembers,
 |  | uint16_t & | memberLimitIncludingBalancing,
 |  | bool & | balancingIsActive,
 |  | JoinPermissions & | joinPermissions
 | ) |  |

When you get ID_TEAM_BALANCER_REQUESTED_TEAM_LOCKED, pass the packet to this function to read out parameters.

Parameters
[in] A packet where packet->data[0]==ID_TEAM_BALANCER_REQUESTED_TEAM_LOCKED
Returns
true on success, false on read error
TM_World* RakNet::TeamManager::GetWorldAtIndex ( unsigned int index ) const
Parameters
[in] index A value beteween 0 and GetWorldCount()-1 inclusive.
Returns
Returns a world created with AddWorld()
unsigned int RakNet::TeamManager::GetWorldCount ( void ) const
Returns
Returns the number of worlds created with AddWorld()
TM_World* RakNet::TeamManager::GetWorldWithId ( WorldId worldId ) const
Parameters
[in] worldId worldId value passed to AddWorld()
Returns
Returns a world created with AddWorld(), or 0 if no such worldId
virtual void RakNet::TeamManager::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
protectedvirtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual void RakNet::TeamManager::OnNewConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | bool | isIncoming
 | ) |  |
protectedvirtual

Called when we got a new connection

Parameters
[in] | systemAddress | Address of the new connection
[in] | rakNetGuid | The guid of the specified system
[in] | isIncoming | If true, this is ID_NEW_INCOMING_CONNECTION, or the equivalent

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::TeamManager::OnReceive ( Packet * packet )
protectedvirtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

void RakNet::TeamManager::RemoveWorld ( WorldId worldId )

Deallocate a world created with AddWorld()

Parameters
[in] worldId The world to deallocate
void RakNet::TeamManager::SetAutoManageConnections ( bool autoAdd )

When auto managing connections, call TM_World::AddParticipant() on all worlds for all new connections automatically Defaults to true.

Note
You probably want this set to false if using multiple worlds
Parameters
[in] autoAdd Automatically call TM_World::AddParticipant() all worlds each new connection. Defaults to true.
void RakNet::TeamManager::SetTopology ( TMTopology _topology )

If _topology is set to TM_CLIENT_SERVER, the host will relay messages to participants.

If topology is set to TM_PEER_TO_PEER, the host assumes the original message source was connected to all other participants and does not relay messages.

Note
If TM_PEER_TO_PEER, this plugin will listen for ID_FCM2_NEW_HOST and call SetHost() on all worlds automatically
Defaults to TM_PEER_TO_PEER
Parameters
[in] _topology Topology to use
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/TeamManager.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: UDPProxy

Classes
UDPProxy
Plugins

Forwards UDP datagrams from one system to another. Protocol independent. More...

Classes

struct | RakNet::UDPProxyClientResultHandler
class | RakNet::UDPProxyClient
Communicates with UDPProxyCoordinator, in order to find a UDPProxyServer to forward our datagrams. More...
struct | RakNet::UDPProxyServerResultHandler
class | RakNet::UDPProxyServer
UDPProxyServer to control our instance of UDPForwarder. More...

Detailed Description

Forwards UDP datagrams from one system to another. Protocol independent.

Used when NatPunchthroughClient fails

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::UDPProxyClientResultHandler Struct Reference

  • UDPProxyClientResultHandler
Public Member Functions | List of all members
RakNet::UDPProxyClientResultHandler Struct Referenceabstract
UDPProxy

#include <UDPProxyClient.h>

Public Member Functions

virtual void | OnForwardingSuccess (const char *proxyIPAddress, unsigned short proxyPort, SystemAddress proxyCoordinator, SystemAddress sourceAddress, SystemAddress targetAddress, RakNetGUID targetGuid, RakNet::UDPProxyClient *proxyClientPlugin)=0
virtual void | OnForwardingNotification (const char *proxyIPAddress, unsigned short proxyPort, SystemAddress proxyCoordinator, SystemAddress sourceAddress, SystemAddress targetAddress, RakNetGUID targetGuid, RakNet::UDPProxyClient *proxyClientPlugin)=0
virtual void | OnNoServersOnline (SystemAddress proxyCoordinator, SystemAddress sourceAddress, SystemAddress targetAddress, RakNetGUID targetGuid, RakNet::UDPProxyClient *proxyClientPlugin)=0
virtual void | OnRecipientNotConnected (SystemAddress proxyCoordinator, SystemAddress sourceAddress, SystemAddress targetAddress, RakNetGUID targetGuid, RakNet::UDPProxyClient *proxyClientPlugin)=0
virtual void | OnAllServersBusy (SystemAddress proxyCoordinator, SystemAddress sourceAddress, SystemAddress targetAddress, RakNetGUID targetGuid, RakNet::UDPProxyClient *proxyClientPlugin)=0
virtual void | OnForwardingInProgress (const char *proxyIPAddress, unsigned short proxyPort, SystemAddress proxyCoordinator, SystemAddress sourceAddress, SystemAddress targetAddress, RakNetGUID targetGuid, RakNet::UDPProxyClient *proxyClientPlugin)=0

Detailed Description

Callback to handle results of calling UDPProxyClient::RequestForwarding()

Member Function Documentation

virtual void RakNet::UDPProxyClientResultHandler::OnAllServersBusy | ( | SystemAddress | proxyCoordinator,
 |  | SystemAddress | sourceAddress,
 |  | SystemAddress | targetAddress,
 |  | RakNetGUID | targetGuid,
 |  | RakNet::UDPProxyClient * | proxyClientPlugin
 | ) |  |
pure virtual

Called when our forwarding request failed, because all UDPProxyServers that are connected to UDPProxyCoordinator are at their capacity Either add more servers, or increase capacity via UDPForwarder::SetMaxForwardEntries()

Parameters
[out] | proxyCoordinator | proxyCoordinator parameter originally passed to UDPProxyClient::RequestForwarding
[out] | sourceAddress | sourceAddress parameter passed to UDPProxyClient::RequestForwarding. If it was UNASSIGNED_SYSTEM_ADDRESS, it is now our external IP address.
[out] | targetAddress | targetAddress parameter originally passed to UDPProxyClient::RequestForwarding
[out] | targetGuid | targetGuid parameter originally passed to UDPProxyClient::RequestForwarding
[out] | proxyClient | The plugin that is calling this callback
virtual void RakNet::UDPProxyClientResultHandler::OnForwardingInProgress | ( | const char * | proxyIPAddress,
 |  | unsigned short | proxyPort,
 |  | SystemAddress | proxyCoordinator,
 |  | SystemAddress | sourceAddress,
 |  | SystemAddress | targetAddress,
 |  | RakNetGUID | targetGuid,
 |  | RakNet::UDPProxyClient * | proxyClientPlugin
 | ) |  |
pure virtual

Called when our forwarding request is already in progress on the proxyCoordinator. This can be ignored, but indicates an unneeded second request

Parameters
[out] | proxyIPAddress | IP Address of the proxy server, which is forwarding messages to targetAddress
[out] | proxyPort | Remote port to use on the proxy server, which is forwarding messages to targetAddress
[out] | proxyCoordinator | proxyCoordinator parameter originally passed to UDPProxyClient::RequestForwarding
[out] | sourceAddress | sourceAddress parameter passed to UDPProxyClient::RequestForwarding. If it was UNASSIGNED_SYSTEM_ADDRESS, it is now our external IP address.
[out] | targetAddress | targetAddress parameter originally passed to UDPProxyClient::RequestForwarding
[out] | targetGuid | targetGuid parameter originally passed to UDPProxyClient::RequestForwarding
[out] | proxyClient | The plugin that is calling this callback
virtual void RakNet::UDPProxyClientResultHandler::OnForwardingNotification | ( | const char * | proxyIPAddress,
 |  | unsigned short | proxyPort,
 |  | SystemAddress | proxyCoordinator,
 |  | SystemAddress | sourceAddress,
 |  | SystemAddress | targetAddress,
 |  | RakNetGUID | targetGuid,
 |  | RakNet::UDPProxyClient * | proxyClientPlugin
 | ) |  |
pure virtual

Called when another system has setup forwarding, with our system as the target address. Plugin automatically sends a datagram to proxyIPAddress before this callback, to open our router if necessary.

Parameters
[out] | proxyIPAddress | IP Address of the proxy server, which will forward messages to targetAddress
[out] | proxyPort | Remote port to use on the proxy server, which will forward messages to targetAddress
[out] | proxyCoordinator | proxyCoordinator parameter originally passed to UDPProxyClient::RequestForwarding
[out] | sourceAddress | sourceAddress parameter passed to UDPProxyClient::RequestForwarding. This is originating source IP address of the remote system that will be sending to us.
[out] | targetAddress | targetAddress parameter originally passed to UDPProxyClient::RequestForwarding. This is our external IP address.
[out] | targetGuid | targetGuid parameter originally passed to UDPProxyClient::RequestForwarding
[out] | proxyClient | The plugin that is calling this callback
virtual void RakNet::UDPProxyClientResultHandler::OnForwardingSuccess | ( | const char * | proxyIPAddress,
 |  | unsigned short | proxyPort,
 |  | SystemAddress | proxyCoordinator,
 |  | SystemAddress | sourceAddress,
 |  | SystemAddress | targetAddress,
 |  | RakNetGUID | targetGuid,
 |  | RakNet::UDPProxyClient * | proxyClientPlugin
 | ) |  |
pure virtual

Called when our forwarding request was completed. We can now connect to targetAddress by using proxyAddress instead

Parameters
[out] | proxyIPAddress | IP Address of the proxy server, which will forward messages to targetAddress
[out] | proxyPort | Remote port to use on the proxy server, which will forward messages to targetAddress
[out] | proxyCoordinator | proxyCoordinator parameter originally passed to UDPProxyClient::RequestForwarding
[out] | sourceAddress | sourceAddress parameter passed to UDPProxyClient::RequestForwarding. If it was UNASSIGNED_SYSTEM_ADDRESS, it is now our external IP address.
[out] | targetAddress | targetAddress parameter originally passed to UDPProxyClient::RequestForwarding
[out] | targetGuid | targetGuid parameter originally passed to UDPProxyClient::RequestForwarding
[out] | proxyClient | The plugin that is calling this callback
virtual void RakNet::UDPProxyClientResultHandler::OnNoServersOnline | ( | SystemAddress | proxyCoordinator,
 |  | SystemAddress | sourceAddress,
 |  | SystemAddress | targetAddress,
 |  | RakNetGUID | targetGuid,
 |  | RakNet::UDPProxyClient * | proxyClientPlugin
 | ) |  |
pure virtual

Called when our forwarding request failed, because no UDPProxyServers are connected to UDPProxyCoordinator

Parameters
[out] | proxyCoordinator | proxyCoordinator parameter originally passed to UDPProxyClient::RequestForwarding
[out] | sourceAddress | sourceAddress parameter passed to UDPProxyClient::RequestForwarding. If it was UNASSIGNED_SYSTEM_ADDRESS, it is now our external IP address.
[out] | targetAddress | targetAddress parameter originally passed to UDPProxyClient::RequestForwarding
[out] | targetGuid | targetGuid parameter originally passed to UDPProxyClient::RequestForwarding
[out] | proxyClient | The plugin that is calling this callback
virtual void RakNet::UDPProxyClientResultHandler::OnRecipientNotConnected | ( | SystemAddress | proxyCoordinator,
 |  | SystemAddress | sourceAddress,
 |  | SystemAddress | targetAddress,
 |  | RakNetGUID | targetGuid,
 |  | RakNet::UDPProxyClient * | proxyClientPlugin
 | ) |  |
pure virtual

Called when our forwarding request failed, because no UDPProxyServers are connected to UDPProxyCoordinator

Parameters
[out] | proxyCoordinator | proxyCoordinator parameter originally passed to UDPProxyClient::RequestForwarding
[out] | sourceAddress | sourceAddress parameter passed to UDPProxyClient::RequestForwarding. If it was UNASSIGNED_SYSTEM_ADDRESS, it is now our external IP address.
[out] | targetAddress | targetAddress parameter originally passed to UDPProxyClient::RequestForwarding
[out] | targetGuid | targetGuid parameter originally passed to UDPProxyClient::RequestForwarding
[out] | proxyClient | The plugin that is calling this callback
The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/UDPProxyClient.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::UDPProxyClient Class Reference

  • UDPProxyClient
Public Member Functions | List of all members
RakNet::UDPProxyClient Class Reference
UDPProxy

Communicates with UDPProxyCoordinator, in order to find a UDPProxyServer to forward our datagrams. More...

#include <UDPProxyClient.h>

Inheritance diagram for RakNet::UDPProxyClient:
RakNet::PluginInterface2

Public Member Functions

void | SetResultHandler (UDPProxyClientResultHandler *rh)
bool | RequestForwarding (SystemAddress proxyCoordinator, SystemAddress sourceAddress, SystemAddress targetAddressAsSeenFromCoordinator, RakNet::TimeMS timeoutOnNoDataMS, RakNet::BitStream *serverSelectionBitstream=0)
bool | RequestForwarding (SystemAddress proxyCoordinator, SystemAddress sourceAddress, RakNetGUID targetGuid, RakNet::TimeMS timeoutOnNoDataMS, RakNet::BitStream *serverSelectionBitstream=0)
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Detailed Description

Communicates with UDPProxyCoordinator, in order to find a UDPProxyServer to forward our datagrams.

When NAT Punchthrough fails, it is possible to use a non-NAT system to forward messages from us to the recipient, and vice-versa.
The class to forward messages is UDPForwarder, and it is triggered over the network via the UDPProxyServer plugin.
The UDPProxyClient connects to UDPProxyCoordinator to get a list of servers running UDPProxyServer, and the coordinator will relay our forwarding request

See Also
NatPunchthroughServer
NatPunchthroughClient

Member Function Documentation

virtual PluginReceiveResult RakNet::UDPProxyClient::OnReceive ( Packet * packet )
virtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

bool RakNet::UDPProxyClient::RequestForwarding | ( | SystemAddress | proxyCoordinator,
 |  | SystemAddress | sourceAddress,
 |  | SystemAddress | targetAddressAsSeenFromCoordinator,
 |  | RakNet::TimeMS | timeoutOnNoDataMS,
 |  | RakNet::BitStream * | serverSelectionBitstream = 0
 | ) |  |

Sends a request to proxyCoordinator to find a server and have that server setup UDPForwarder::StartForwarding() on our address to targetAddressAsSeenFromCoordinator The forwarded datagrams can be from any UDP source, not just RakNet

Precondition
Must be connected to proxyCoordinator
Systems running UDPProxyServer must be connected to proxyCoordinator and logged in via UDPProxyCoordinator::LoginServer() or UDPProxyServer::LoginToCoordinator()
Note
May still fail, if all proxy servers have no open connections.
RakNet's protocol will ensure a message is sent at least every 5 seconds, so if routing RakNet messages, it is a reasonable value for timeoutOnNoDataMS, plus an extra few seconds for latency.
Parameters
[in] | proxyCoordinator | System we are connected to that is running the UDPProxyCoordinator plugin
[in] | sourceAddress | External IP address of the system we want to forward messages from. This does not have to be our own system. To specify our own system, you can pass UNASSIGNED_SYSTEM_ADDRESS which the coordinator will treat as our external IP address.
[in] | targetAddressAsSeenFromCoordinator | External IP address of the system we want to forward messages to. If this system is connected to UDPProxyCoordinator at this address using RakNet, that system will ping the server and thus open the router for incoming communication. In any other case, you are responsible for doing your own network communication to have that system ping the server. See also targetGuid in the other version of RequestForwarding(), to avoid the need to know the IP address to the coordinator of the destination.
[in] | timeoutOnNoData | If no data is sent by the forwarded systems, how long before removing the forward entry from UDPForwarder? UDP_FORWARDER_MAXIMUM_TIMEOUT is the maximum value. Recommended 10 seconds.
[in] | serverSelectionBitstream | If you want to send data to UDPProxyCoordinator::GetBestServer(), write it here
Returns
true if the request was sent, false if we are not connected to proxyCoordinator
bool RakNet::UDPProxyClient::RequestForwarding | ( | SystemAddress | proxyCoordinator,
 |  | SystemAddress | sourceAddress,
 |  | RakNetGUID | targetGuid,
 |  | RakNet::TimeMS | timeoutOnNoDataMS,
 |  | RakNet::BitStream * | serverSelectionBitstream = 0
 | ) |  |

Same as above, but specify the target with a GUID, in case you don't know what its address is to the coordinator If requesting forwarding to a RakNet enabled system, then it is easier to use targetGuid instead of targetAddressAsSeenFromCoordinator

void RakNet::UDPProxyClient::SetResultHandler ( UDPProxyClientResultHandler * rh )

Receives the results of calling RequestForwarding() Set before calling RequestForwarding or you won't know what happened

Parameters
[in] resultHandler
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/UDPProxyClient.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::UDPProxyServerResultHandler Struct Reference

  • UDPProxyServerResultHandler
Public Member Functions | List of all members
RakNet::UDPProxyServerResultHandler Struct Referenceabstract
UDPProxy

#include <UDPProxyServer.h>

Public Member Functions

virtual void | OnLoginSuccess (RakNet::RakString usedPassword, RakNet::UDPProxyServer *proxyServerPlugin)=0
virtual void | OnAlreadyLoggedIn (RakNet::RakString usedPassword, RakNet::UDPProxyServer *proxyServerPlugin)=0
virtual void | OnNoPasswordSet (RakNet::RakString usedPassword, RakNet::UDPProxyServer *proxyServerPlugin)=0
virtual void | OnWrongPassword (RakNet::RakString usedPassword, RakNet::UDPProxyServer *proxyServerPlugin)=0

Detailed Description

Callback to handle results of calling UDPProxyServer::LoginToCoordinator()

Member Function Documentation

virtual void RakNet::UDPProxyServerResultHandler::OnAlreadyLoggedIn | ( | RakNet::RakString | usedPassword,
 |  | RakNet::UDPProxyServer * | proxyServerPlugin
 | ) |  |
pure virtual

We are already logged in. This login failed, but the system is operational as if it succeeded

Parameters
[out] | usedPassword | The password we passed to UDPProxyServer::LoginToCoordinator()
[out] | proxyServer | The plugin calling this callback
virtual void RakNet::UDPProxyServerResultHandler::OnLoginSuccess | ( | RakNet::RakString | usedPassword,
 |  | RakNet::UDPProxyServer * | proxyServerPlugin
 | ) |  |
pure virtual

Called when our login succeeds

Parameters
[out] | usedPassword | The password we passed to UDPProxyServer::LoginToCoordinator()
[out] | proxyServer | The plugin calling this callback
virtual void RakNet::UDPProxyServerResultHandler::OnNoPasswordSet | ( | RakNet::RakString | usedPassword,
 |  | RakNet::UDPProxyServer * | proxyServerPlugin
 | ) |  |
pure virtual

The coordinator operator forgot to call UDPProxyCoordinator::SetRemoteLoginPassword()

Parameters
[out] | usedPassword | The password we passed to UDPProxyServer::LoginToCoordinator()
[out] | proxyServer | The plugin calling this callback
virtual void RakNet::UDPProxyServerResultHandler::OnWrongPassword | ( | RakNet::RakString | usedPassword,
 |  | RakNet::UDPProxyServer * | proxyServerPlugin
 | ) |  |
pure virtual

The coordinator operator set a different password in UDPProxyCoordinator::SetRemoteLoginPassword() than what we passed

Parameters
[out] | usedPassword | The password we passed to UDPProxyServer::LoginToCoordinator()
[out] | proxyServer | The plugin calling this callback
The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/UDPProxyServer.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::UDPProxyServer Class Reference

  • UDPProxyServer
Public Member Functions | Public Attributes | List of all members
RakNet::UDPProxyServer Class Reference
UDPProxy

UDPProxyServer to control our instance of UDPForwarder. More...

#include <UDPProxyServer.h>

Inheritance diagram for RakNet::UDPProxyServer:
RakNet::PluginInterface2

Public Member Functions

void | SetSocketFamily (unsigned short _socketFamily)
void | SetResultHandler (UDPProxyServerResultHandler *rh)
bool | LoginToCoordinator (RakNet::RakString password, SystemAddress coordinatorAddress)
void | SetServerPublicIP (RakString ip)
The server IP reported to the client is the IP address from the server to the coordinator. If the server and coordinator are on the same LAN, you need to call SetServerPublicIP() to tell the client what address to connect to.
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Public Attributes

UDPForwarder udpForwarder

Detailed Description

UDPProxyServer to control our instance of UDPForwarder.

When NAT Punchthrough fails, it is possible to use a non-NAT system to forward messages from us to the recipient, and vice-versa.
The class to forward messages is UDPForwarder, and it is triggered over the network via the UDPProxyServer plugin.
The UDPProxyServer connects to UDPProxyServer to get a list of servers running UDPProxyServer, and the coordinator will relay our forwarding request.

Member Function Documentation

bool RakNet::UDPProxyServer::LoginToCoordinator | ( | RakNet::RakString | password,
 |  | SystemAddress | coordinatorAddress
 | ) |  |

Before the coordinator will register the UDPProxyServer, you must login

Precondition
Must be connected to the coordinator
Coordinator must have set a password with UDPProxyCoordinator::SetRemoteLoginPassword()
Returns
false if already logged in, or logging in. Returns true otherwise
virtual void RakNet::UDPProxyServer::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
virtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::UDPProxyServer::OnReceive ( Packet * packet )
virtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

void RakNet::UDPProxyServer::SetResultHandler ( UDPProxyServerResultHandler * rh )

Receives the results of calling LoginToCoordinator() Set before calling LoginToCoordinator or you won't know what happened

Parameters
[in] resultHandler
void RakNet::UDPProxyServer::SetServerPublicIP ( RakString ip )

The server IP reported to the client is the IP address from the server to the coordinator. If the server and coordinator are on the same LAN, you need to call SetServerPublicIP() to tell the client what address to connect to.

Parameters
[in] ip IP address to report in UDPProxyClientResultHandler::OnForwardingSuccess() and UDPProxyClientResultHandler::OnForwardingNotification() as proxyIPAddress
void RakNet::UDPProxyServer::SetSocketFamily ( unsigned short _socketFamily )

Sets the socket family to use, either IPV4 or IPV6

Parameters
[in] socketFamily For IPV4, use AF_INET (default). For IPV6, use AF_INET6. To autoselect, use AF_UNSPEC.

Member Data Documentation

UDPForwarder RakNet::UDPProxyServer::udpForwarder

Operative class that performs the forwarding Exposed so you can call UDPForwarder::SetMaxForwardEntries() if you want to change away from the default UDPForwarder::Startup(), UDPForwarder::Shutdown(), and UDPForwarder::Update() are called automatically by the plugin

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/UDPProxyServer.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Lobby2Plugin

Modules | Classes
Lobby2Plugin
Plugins

SQL based lobby system, with support for users, friends, clans, emails, ranking, and a message board. More...

Modules

Lobby2Commands
Commands that can be sent to Lobby2Server from Lobby2Client.
Lobby2Notifications
Callbacks that the Lobby2System will send to you.
Lobby2Server
Runs the server modules that asynchronously processes Lobby2Message.
Lobby2Client
Sends commands to Lobby2Server.

Classes

struct | RakNet::Lobby2Callbacks
struct | RakNet::Lobby2Printf
class | RakNet::Lobby2Plugin
Both Lobby2Server and Lobby2Client derive from this class. More...

Detailed Description

SQL based lobby system, with support for users, friends, clans, emails, ranking, and a message board.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Lobby2Commands

Classes | Enumerations
Lobby2Commands
Lobby2Plugin

Commands that can be sent to Lobby2Server from Lobby2Client. More...

Classes

struct | RakNet::Lobby2Message
A Lobby2Message encapsulates a networked function call from the client. More...
struct | RakNet::Platform_Startup
Platform specific startup. Unused on the PC. More...
struct | RakNet::Platform_Shutdown
Platform specific startup. Unused on the PC. More...
struct | RakNet::System_CreateDatabase
Create all tables and stored procedures on a system that does not already have them. More...
struct | RakNet::System_DestroyDatabase
Destroy all tables and stored procedures created with System_CreateDatabase. More...
struct | RakNet::System_CreateTitle
Each title essentially corresponds to a game. For example, the same lobby system may be used for both asteroids and Pac-man. When logging in, and for some functions, it is necessary to specify which title you are logging in under. This way users playing asteroids do not interact with users playing pac-man, where such interations are game specific (such as ranking). More...
struct | RakNet::System_DestroyTitle
Destroy a previously added title. More...
struct | RakNet::System_GetTitleRequiredAge
Get the required age set with System_CreateTitle. More...
struct | RakNet::System_GetTitleBinaryData
Get the binary data set with System_CreateTitle. More...
struct | RakNet::System_RegisterProfanity
Adds the input strings to a table of profanity. non-unique or empty strings can be ignored. This table will be used internally to ensure that handles and clan names do not contain profanity. Multiple calls add to the table. This table will be used for functions that take a user-defined string that is highly visible, such as clan and user names. It does not need to be checked for emails or message boards. More...
struct | RakNet::System_BanUser
Bans a specific user (will be most likely called by a moderator). Adds the user's primary key to a ban table, along with the name of the moderator, the reason for the ban. Banning is used to prevent the banned user from logging on for some specified duration. A date column should be present and automatically filled in. When bans are expired, the ban can be deleted from the database. However, a separate table should log bans, so that even expired bans can be looked up in case. More...
struct | RakNet::System_UnbanUser
Unban a user banned with System_BanUser. More...
struct | RakNet::CDKey_Add
Adds CDKeys to the database. Duplicate CDKeys for a particular title are ignored. CDKeys can be identical for different titles. More...
struct | RakNet::CDKey_GetStatus
Returns if a CD key was previously added with AddCDKey. More...
struct | RakNet::CDKey_Use
Associates a cd key with a user, such that the cd key cannot be used again. If Client_Login() is called with check cd key as true, then this table will be checked to make sure UserCDKey() was previously called with this user and a valid key. If this user is already associated with a CD Key, add the new key, and use the most recent key. All CD Key usage should be logged in a separate table, including the date used and result. More...
struct | RakNet::CDKey_FlagStolen
Flags one or more CD keys as stolen. Stolen CD keys will prevent Client_Login() if check cd key is true. They will also prevent these cd keys from being used with CDKey_Use. If this key is already in use by certain users for this particular title, then log this similarly to how CDKey_Use does so. More...
struct | RakNet::Client_Login
Logon with a previously registered account. More...
struct | RakNet::Client_Logoff
Logoff, after logging in. More...
struct | RakNet::Client_RegisterAccount
This creates a new account in the database, which can be used in a subsequent call to Login. Most parameters are optional. handle is not optional, and must be unique using case-insensitive compare. emailAddress should be validated to have a sensible format, including an @ sign and a period with a 3 letter extension. allowLoginWithoutEmailAddressValidation is used in Client_Login to potentially disallow logon attempts with unverified email addresses. More...
struct | RakNet::System_SetEmailAddressValidated
For the client with the given handle, mark a column emailAddressValidated as true or false as appropriate. This is potentially used in Client_Login. More...
struct | RakNet::Client_ValidateHandle
Looks up in the database if this handle is already in use, subject to the usual constraints of handles. This will be used by the user to quickly check for available handles. More...
struct | RakNet::System_DeleteAccount
Flags as deleted an account registered with RegisterAccount. Accounts are not actually deleted, only tagged as deleted. More...
struct | RakNet::System_PruneAccounts
Unused accounts are deleted. This is cascading, such that emails and other tables that reference this key are also deleted. unused accounts are defined as: More...
struct | RakNet::Client_GetEmailAddress
Returns the email address associated with a specific handle, invalid handle. This is used for password recovery. More...
struct | RakNet::Client_GetPasswordRecoveryQuestionByHandle
Returns the passwordRecoveryQuestion associated with handle, invalid handle. More...
struct | RakNet::Client_GetPasswordByPasswordRecoveryAnswer
Returns the password associated with a handle, if the passwordRecoveryAnswer is correct. More...
struct | RakNet::Client_ChangeHandle
Changes the handle for a user. More...
struct | RakNet::Client_UpdateAccount
Will update any or all of the inputs that were previously passed to Client_RegisterAccount, except handle. More...
struct | RakNet::Client_GetAccountDetails
Get the parameters set with Client_RegisterAccount. More...
struct | RakNet::Client_StartIgnore
Adds the specified user to an ignore list for my user. Recommended to store the primary key of the remote user, both for speed and so if the other use changes their handle it still works. The ignore list is checked for friend invites, emails, and elsewhere where indicated. Ignoring is uni-directional, so if A ignores B, A will block messages from B where appropriate, but B will not immediately block messages from A. More...
struct | RakNet::Client_StopIgnore
Removes an entry in the database such that myHandle will no longer ignore theirHandle. More...
struct | RakNet::Client_GetIgnoreList
Returns all users I have ignored. More...
struct | RakNet::Client_PerTitleBinaryStorage
For each combination of user and title, structures can be stored. More...
struct | RakNet::Friends_SendInvite
Stores in the database an add friend invite from my handle to their handle. The combination of my handle and their handle must be unique, so you cannot send more than one add friend invite to a single user. Sends an email to their handle the subject, body, and binary data. Note: if myHandle is ignored by theirHandle, then the function fails. See Client_StartIgnore. More...
struct | RakNet::Friends_AcceptInvite
Stores in the database that this user is now my friend. This is bidirectional, which is to say if someone accepts an add friend invite, they are my friend, and I am their friend. Recommended to store by primary key for speed and in case the friend's handle changes. Store in the emails table from my handle to their handle the subject, body, and binary data. Note: if myHandle is ignored by theirHandle, then the function fails. See AddToIgnoreList. More...
struct | RakNet::Friends_RejectInvite
Removes from the database the pending add friend invite. Operation completes even if ignored. Unless ignored, store in the emails table from my handle to their handle the subject, body, binary data, and procedure type flag. More...
struct | RakNet::Friends_GetInvites
Returns all invites for this user. More...
struct | RakNet::Friends_GetFriends
Gets all friends to this user. More...
struct | RakNet::Friends_Remove
Ends a friendship between two users. Remove from the database the friend entry between my handle and their handle. As with accept add friend invite, this is bidirectional. Either user can terminate the friendship. Store in the emails table from my handle to their handle the subject, body, and binary data, and procedure type flag. More...
struct | RakNet::BookmarkedUsers_Add
Remembers a user, with a type integer and description for you to use, if desired. More...
struct | RakNet::BookmarkedUsers_Remove
Remove a user added with BookmarkedUsers_Add. More...
struct | RakNet::BookmarkedUsers_Get
Returns all users added to BookmarkedUsers_Add. More...
struct | RakNet::Emails_Send
Adds to an emails table from myHandle (store primary key) to recipient handles (store primary key) the specified subject, body, and binary data. Emails are persistent, therefore emails should be stored in a separate table and referenced by the user. Deleting the user does not delete previously send email. Emails should have an automatic timestamp to store when they were created. Email should be flagged as sent=true (boolean), markedRead=true (boolean), deletedBySender=false (boolean), deletedByReciever=false (boolean). More...
struct | RakNet::Emails_Get
Returns emails as noted. Emails which were marked deleted are not returned. More...
struct | RakNet::Emails_Delete
Deletes an email with a specified ID. This ID is returned in GetEmail and should uniquely identify an email (it's fine to use the primary key). Note: Emails are not actually deleted from the database in this function. This just sets the deletedBySender or deletedByReciever flags. Emails are actually stored in a log recording past emails and sender and receiver primary key. They are not truly destroyed until done so with System_PruneAccounts. More...
struct | RakNet::Emails_SetStatus
Sets the status flag for an email. This is a property defined by and used by the user. More...
struct | RakNet::Ranking_SubmitMatch
Will record in the database the results of a match. This will store in the database the the match which is defined by the the match notes, match id, winner and loser participant primary keys, winner and loser participant scores, and binary data. More...
struct | RakNet::Ranking_GetMatches
Gets matches recorded with Ranking_SubmitMatch ordered from most recent to least recent. Each returned match has all columns submitted to Ranking_SubmitMatch, except binary data, which can be retrieved with Ranking_GetMatchBinaryData. Additionally, each returned match returns the primary key of each match, to be passed to Ranking_GetMatchBinaryData. More...
struct | RakNet::Ranking_GetMatchBinaryData
Because of the large amount of binary data potentially returned, this function is used to retrieve binary data for a particular match. More...
struct | RakNet::Ranking_GetTotalScore
When a match is submitted with Ranking_SubmitMatch, the total running score and number of matches played for each player for each game title and game mode combination should be recorded. Because matches can be pruned wth PruneMatches(), the total score sum and number of scores submitted should be stored, rather than summed up from prior submitted matches. More...
struct | RakNet::Ranking_WipeScoresForPlayer
Resets the sum of all submitted scores to 0, the number of scores submitted to 0. More...
struct | RakNet::Ranking_WipeMatches
Deletes all matches submitted with submit match. Also deletes all scores for all players associated with this titleName and gameType (e.g. same thing that WipeScoresForPlayer does, but for all players). More...
struct | RakNet::Ranking_PruneMatches
Will delete all matches submitted with SubmitMatch over PruneTime days old. Will also prune matches if the total storage space of all matches exceeds PruneSizeMB megabytes in the database. More...
struct | RakNet::Ranking_UpdateRating
Add or update a rating for a user, in a particular game and game mode. More...
struct | RakNet::Ranking_WipeRatings
Deletes all ratings for all players for this combination of titleName and gameType. More...
struct | RakNet::Ranking_GetRating
Get rating for a player. More...
struct | RakNet::Clans_Create
userHandle updates the clanDescription and clanBinaryData of a clan with the specified clanHandle. userHandle must be the clan leader. More...
struct | RakNet::Clans_SetProperties
userHandle updates the clanDescription and clanBinaryData of a clan with the specified clanHandle. userHandle must be the clan leader. More...
struct | RakNet::Clans_GetProperties
Returns clanDescription and clanBinaryData for the given clan. More...
struct | RakNet::Clans_SetMyMemberProperties
Each member of each clan has the the properties clanMemberDescription and clanMemberBinaryData which default to empty. These properties can be set here, and retrieved via GetClanMemberProperties. More...
struct | RakNet::Clans_GrantLeader
myPrimaryKey becomes a subleader. newLeaderHandle becomes the leader. An email is sent with Emails_Send() to all members with the specified subject and body More...
struct | RakNet::Clans_SetSubleaderStatus
Promotes a clan member to a subleader, or demotes a subleader to a regular member. On promotion, email is sent to all members from myPrimary key with the specified subject and body. On demotion, email is sent to all leaders from myPrimary key with the specified subject and body. More...
struct | RakNet::Clans_SetMemberRank
Lets the clan leader set the rank property for a clan member. More...
struct | RakNet::Clans_GetMemberProperties
Returns properties for a clan member of a given clan. More...
struct | RakNet::Clans_ChangeHandle
Renames the clan. Note that this may be called asynchronously, in which case the stored procedure should account for this occuring at the same time as another function that uses the old clan handle. More...
struct | RakNet::Clans_Leave
Remove user identified by myPrimaryKey from clan identified by clanHandle. More...
struct | RakNet::Clans_Get
Returns all clans that userHandle is a member of. Clans and clan members should be sorted by name, using ascending or descending sort as specified. More...
struct | RakNet::Clans_SendJoinInvitation
if myPrimaryKey is a leader or subleader of clanHandle, and invitedUserHandle is a valid user not already invited to this clan, add this user to the invite table. The invite table contains the clan, who send the invite, and who the invite was sent to, and when it was sent. Invites expire after expiration time in seconds. Also, use Emails_Send() to send an email from myPrimaryKey to invitedUserHandle with the specified subject and body. More...
struct | RakNet::Clans_WithdrawJoinInvitation
if myPrimaryKey is a leader or subleader of clanHandle, and invitedUserHandle is a valid user with an invite to this clan, remove this invite. Also, use Emails_Send() to send an email from myPrimaryKey to invitedUserHandle with the specified subject and body. More...
struct | RakNet::Clans_AcceptJoinInvitation
If myPrimaryKey has an invitation to the specified clan, add him to the clan. Fail on specified output parameters. Use Emails_Send() to send an email from myPrimaryKey to all clan members with the specified subject and body. More...
struct | RakNet::Clans_RejectJoinInvitation
If we have an open clan invitation, reject it (just delete it from the database). More...
struct | RakNet::Clans_DownloadInvitationList
Returns all invites sent by Clans_SendJoinInvitation that were not yet acted upon (withdrawn, accepted, rejected). More...
struct | RakNet::Clans_SendJoinRequest
Function has two forms: More...
struct | RakNet::Clans_WithdrawJoinRequest
Withdraws a previously sent clan join request via SendClanJoinRequest. Use Emails_Send() to send an email from myPrimaryKey to the clan leader and all subleaders with the specified subject and body. More...
struct | RakNet::Clans_AcceptJoinRequest
A clan leader or subleader accepts a join request from requestingUserHandle to this clan. requestingUserHandle joins the clan as a regular member. Use Emails_Send() to send an email from requestingUserHandle to all clan members with the specified subject and body. More...
struct | RakNet::Clans_DownloadRequestList
Returns all open requests this user has sent to clans, that have not yet acted upon (withdrawn, accepted, rejected, expired). More...
struct | RakNet::Clans_KickAndBlacklistUser
Kicks a user from the clan and/or blacklists a user so they cannot join. Only a clan leader or subleader can perform this operation. The operation can only be performed on members of lower status (leader can perform on subleader or regular member or nonmember, subleader on regular members or nonmember). If a member is banned, they are added to the banned table which contains the member's primary key, which user banned them, and the reason. Email is sent from myPrimaryKey to all leaders if a clan member is banned. Emails is furthermore sent to all clan members if successfully kicked. More...
struct | RakNet::Clans_UnblacklistUser
Removes a user from the blacklist for this clan. More...
struct | RakNet::Clans_GetBlacklist
Returns a list of all members blacklisted from this clan. Each element in the list contains the handle of the user that did the ban, who was banned, when the user was banned, and the reason passed to ClanKickAndBlacklistUser. More...
struct | RakNet::Clans_GetMembers
Returns all clan members for this clan. Each entry returned contains handle, description, binary data, status (leader, regular member, subleader). More...
struct | RakNet::Clans_GetList
Returns all clans names. More...
struct | RakNet::Clans_CreateBoard
Creates a new clan board for clan members to post in using AddPostToClanBoard. Clan boards are unique, and are destroyed when the clan is destroyed, or if DestroyClanBoard is called. More...
struct | RakNet::Clans_DestroyBoard
Success, invalid parameter syntax, myPrimaryKey is not the leader or subleader of clanHandle, unknown myPrimaryKey, unknown clanHandle, unknown clanBoardName. More...
struct | RakNet::Clans_CreateNewTopic
Each clan has a clan board that only clan members can post to. This adds a topic to the clan board. Posts should reference the primary key of the poster, so that even if the poster chagnes his or her handle, the post author is updated properly. Each post automatically stores the timestamp when it was created. Banned users may not add new posts to the clan board. More...
struct | RakNet::Clans_ReplyToTopic
Replies to a topic created with Clans_CreateTopic(). If postId references a post within a topic, just add the reply to the last post. Banned users may not add new posts to the clan board. More...
struct | RakNet::Clans_RemovePost
The clan leader or subleaders may remove posts or topics from a clan board. More...
struct | RakNet::Clans_GetBoards
Gets clan boards created for clanHandle. Boards are returned if we are a clan member, or if allowPublicReads in Clans_CreateBoard() was passed as false. However, if we are banned from this clan, no boards are returned. More...
struct | RakNet::Clans_GetTopics
Gets topics (posts that are not replies to other posts, created with Clans_CreateTopic()) for the specified clanHandle and clanBoardName. If we are not a clan member and the clan was created with allowPublicReads==false, then the user is not allowed to read topics. More...
struct | RakNet::Clans_GetPosts
Gets all posts for a particular topic. If postId is not a topic but is instead a post in a topic, treat it as if the topic postId was passed. If we are not a clan member and the clan was created with allowPublicReads==false, then the user is not allowed to read topics. More...

Enumerations

enum RakNet::Lobby2MessageID

Detailed Description

Commands that can be sent to Lobby2Server from Lobby2Client.

Enumeration Type Documentation

enum RakNet::Lobby2MessageID

All enumerations for Lobby2Message. Each Lobby2Message has one enumeration

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::Lobby2Message Struct Reference

  • Lobby2Message
Public Member Functions | Public Attributes | List of all members
RakNet::Lobby2Message Struct Referenceabstract
Lobby2Commands

A Lobby2Message encapsulates a networked function call from the client. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Lobby2Message:
RakNet::BookmarkedUsers_Add RakNet::BookmarkedUsers_Get RakNet::BookmarkedUsers_Remove RakNet::CDKey_Add RakNet::CDKey_FlagStolen RakNet::CDKey_GetStatus RakNet::CDKey_Use RakNet::Clans_AcceptJoinInvitation RakNet::Clans_AcceptJoinRequest RakNet::Clans_ChangeHandle RakNet::Clans_Create RakNet::Clans_CreateBoard RakNet::Clans_CreateNewTopic RakNet::Clans_DestroyBoard RakNet::Clans_DownloadInvitationList RakNet::Clans_DownloadRequestList RakNet::Clans_Get RakNet::Clans_GetBlacklist RakNet::Clans_GetBoards RakNet::Clans_GetList RakNet::Clans_GetMemberProperties RakNet::Clans_GetMembers RakNet::Clans_GetPosts RakNet::Clans_GetProperties RakNet::Clans_GetTopics RakNet::Clans_GrantLeader RakNet::Clans_KickAndBlacklistUser RakNet::Clans_Leave RakNet::Clans_RejectJoinInvitation RakNet::Clans_RejectJoinRequest RakNet::Clans_RemovePost RakNet::Clans_ReplyToTopic RakNet::Clans_SendJoinInvitation RakNet::Clans_SendJoinRequest RakNet::Clans_SetMemberRank RakNet::Clans_SetMyMemberProperties RakNet::Clans_SetProperties RakNet::Clans_SetSubleaderStatus RakNet::Clans_UnblacklistUser RakNet::Clans_WithdrawJoinInvitation RakNet::Clans_WithdrawJoinRequest RakNet::Client_ChangeHandle RakNet::Client_GetAccountDetails RakNet::Client_GetEmailAddress RakNet::Client_GetIgnoreList RakNet::Client_GetPasswordByPasswordRecoveryAnswer RakNet::Client_GetPasswordRecoveryQuestionByHandle RakNet::Client_GetPresence RakNet::Client_Login RakNet::Client_Logoff RakNet::Client_PerTitleBinaryStorage RakNet::Client_RegisterAccount RakNet::Client_SetPresence RakNet::Client_StartIgnore RakNet::Client_StopIgnore RakNet::Client_UpdateAccount RakNet::Client_ValidateHandle RakNet::Emails_Delete RakNet::Emails_Get RakNet::Emails_Send RakNet::Emails_SetStatus RakNet::Friends_AcceptInvite RakNet::Friends_GetFriends RakNet::Friends_GetInvites RakNet::Friends_RejectInvite RakNet::Friends_Remove RakNet::Friends_SendInvite RakNet::Platform_Shutdown RakNet::Platform_Startup RakNet::Ranking_GetMatchBinaryData RakNet::Ranking_GetMatches RakNet::Ranking_GetRating RakNet::Ranking_GetTotalScore RakNet::Ranking_PruneMatches RakNet::Ranking_SubmitMatch RakNet::Ranking_UpdateRating RakNet::Ranking_WipeMatches RakNet::Ranking_WipeRatings RakNet::Ranking_WipeScoresForPlayer RakNet::System_BanUser RakNet::System_CreateDatabase RakNet::System_CreateTitle RakNet::System_DeleteAccount RakNet::System_DestroyDatabase RakNet::System_DestroyTitle RakNet::System_GetTitleBinaryData RakNet::System_GetTitleRequiredAge RakNet::System_PruneAccounts RakNet::System_RegisterProfanity RakNet::System_SetEmailAddressValidated RakNet::System_UnbanUser

Public Member Functions

virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | RequiresAdmin (void) const =0
virtual bool | RequiresRankingPermission (void) const =0
virtual bool | CancelOnDisconnect (void) const =0
virtual bool | RequiresLogin (void) const =0
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Public Attributes

RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

A Lobby2Message encapsulates a networked function call from the client.

The client should fill in the input parameters, call Lobby2Client::SendMsg(), and wait for the reply in the callback passed to Lobby2Client::SetCallbackInterface() The input parameters are always serialized back from the server. See resultCode for the result of the operation. L2RC_SUCCESS means success. Anything else means failure. Any message may return between L2RC_NOT_LOGGED_IN and L2RC_EMAIL_ADDRESS_IS_INVALID, which indices formatting errors in the input. All other return codes have the name of the message in the enumeration. The system can be extended by deriving from Lobby2Message, adding your own input and output parameters, and deriving from Lobby2MessageFactory register your own class factory with RakNet::Lobby2Plugin::SetMessageFactory()

Member Function Documentation

virtual void RakNet::Lobby2Message::CallCallback ( Lobby2Callbacks * cb )
pure virtual

This message has been processed by the server and has arrived back on the client. Call the client informing the user of this event.

virtual bool RakNet::Lobby2Message::CancelOnDisconnect ( void ) const
pure virtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implemented in RakNet::Clans_GetPosts, RakNet::Clans_GetTopics, RakNet::Clans_GetBoards, RakNet::Clans_RemovePost, RakNet::Clans_ReplyToTopic, RakNet::Clans_CreateNewTopic, RakNet::Clans_DestroyBoard, RakNet::Clans_CreateBoard, RakNet::Clans_GetList, RakNet::Clans_GetMembers, RakNet::Clans_GetBlacklist, RakNet::Clans_UnblacklistUser, RakNet::Clans_KickAndBlacklistUser, RakNet::Clans_DownloadRequestList, RakNet::Clans_RejectJoinRequest, RakNet::Clans_AcceptJoinRequest, RakNet::Clans_WithdrawJoinRequest, RakNet::Clans_SendJoinRequest, RakNet::Clans_DownloadInvitationList, RakNet::Clans_RejectJoinInvitation, RakNet::Clans_AcceptJoinInvitation, RakNet::Clans_WithdrawJoinInvitation, RakNet::Clans_SendJoinInvitation, RakNet::Clans_Get, RakNet::Clans_Leave, RakNet::Clans_ChangeHandle, RakNet::Clans_GetMemberProperties, RakNet::Clans_SetMemberRank, RakNet::Clans_SetSubleaderStatus, RakNet::Clans_GrantLeader, RakNet::Clans_SetMyMemberProperties, RakNet::Clans_GetProperties, RakNet::Clans_SetProperties, RakNet::Clans_Create, RakNet::Ranking_GetRating, RakNet::Ranking_WipeRatings, RakNet::Ranking_UpdateRating, RakNet::Ranking_PruneMatches, RakNet::Ranking_WipeMatches, RakNet::Ranking_WipeScoresForPlayer, RakNet::Ranking_GetTotalScore, RakNet::Ranking_GetMatchBinaryData, RakNet::Ranking_GetMatches, RakNet::Ranking_SubmitMatch, RakNet::Emails_SetStatus, RakNet::Emails_Delete, RakNet::Emails_Get, RakNet::Emails_Send, RakNet::BookmarkedUsers_Get, RakNet::BookmarkedUsers_Remove, RakNet::BookmarkedUsers_Add, RakNet::Friends_Remove, RakNet::Friends_GetFriends, RakNet::Friends_GetInvites, RakNet::Friends_RejectInvite, RakNet::Friends_AcceptInvite, RakNet::Friends_SendInvite, RakNet::Client_GetPresence, RakNet::Client_SetPresence, RakNet::Client_PerTitleBinaryStorage, RakNet::Client_GetIgnoreList, RakNet::Client_StopIgnore, RakNet::Client_StartIgnore, RakNet::Client_GetAccountDetails, RakNet::Client_UpdateAccount, RakNet::Client_ChangeHandle, RakNet::Client_GetPasswordByPasswordRecoveryAnswer, RakNet::Client_GetPasswordRecoveryQuestionByHandle, RakNet::Client_GetEmailAddress, RakNet::System_PruneAccounts, RakNet::System_DeleteAccount, RakNet::Client_ValidateHandle, RakNet::System_SetEmailAddressValidated, RakNet::Client_RegisterAccount, RakNet::Client_Logoff, RakNet::Client_Login, RakNet::CDKey_FlagStolen, RakNet::CDKey_Use, RakNet::CDKey_GetStatus, RakNet::CDKey_Add, RakNet::System_UnbanUser, RakNet::System_BanUser, RakNet::System_RegisterProfanity, RakNet::System_GetTitleBinaryData, RakNet::System_GetTitleRequiredAge, RakNet::System_DestroyTitle, RakNet::System_CreateTitle, RakNet::System_DestroyDatabase, RakNet::System_CreateDatabase, RakNet::Platform_Shutdown, and RakNet::Platform_Startup.

virtual bool RakNet::Lobby2Message::ClientImpl ( RakNet::Lobby2Plugin * client )
virtual

Override to do any Lobby2Client functionality when the message is returned from the server (usually nothing).

Returns
True to call CallCallback immediately. False to defer for some reason (always true on the PC)

Reimplemented in RakNet::Client_GetIgnoreList, RakNet::Client_StopIgnore, and RakNet::Client_StartIgnore.

virtual bool RakNet::Lobby2Message::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented in RakNet::Clans_GetPosts, RakNet::Clans_GetTopics, RakNet::Clans_GetBoards, RakNet::Clans_ReplyToTopic, RakNet::Clans_CreateNewTopic, RakNet::Clans_DestroyBoard, RakNet::Clans_CreateBoard, RakNet::Clans_GetMembers, RakNet::Clans_GetBlacklist, RakNet::Clans_UnblacklistUser, RakNet::Clans_KickAndBlacklistUser, RakNet::Clans_RejectJoinRequest, RakNet::Clans_AcceptJoinRequest, RakNet::Clans_WithdrawJoinRequest, RakNet::Clans_SendJoinRequest, RakNet::Clans_RejectJoinInvitation, RakNet::Clans_AcceptJoinInvitation, RakNet::Clans_WithdrawJoinInvitation, RakNet::Clans_SendJoinInvitation, RakNet::Clans_Leave, RakNet::Clans_ChangeHandle, RakNet::Clans_GetMemberProperties, RakNet::Clans_SetMemberRank, RakNet::Clans_SetSubleaderStatus, RakNet::Clans_GrantLeader, RakNet::Clans_SetMyMemberProperties, RakNet::Clans_GetProperties, RakNet::Clans_SetProperties, RakNet::Clans_Create, RakNet::Ranking_GetRating, RakNet::Ranking_WipeRatings, RakNet::Ranking_UpdateRating, RakNet::Ranking_WipeMatches, RakNet::Ranking_WipeScoresForPlayer, RakNet::Ranking_GetTotalScore, RakNet::Ranking_GetMatches, RakNet::Ranking_SubmitMatch, RakNet::Emails_SetStatus, RakNet::Emails_Send, RakNet::BookmarkedUsers_Remove, RakNet::BookmarkedUsers_Add, RakNet::Friends_Remove, RakNet::Friends_RejectInvite, RakNet::Friends_AcceptInvite, RakNet::Friends_SendInvite, RakNet::Client_PerTitleBinaryStorage, RakNet::Client_StopIgnore, RakNet::Client_StartIgnore, RakNet::Client_UpdateAccount, RakNet::Client_ChangeHandle, RakNet::Client_GetPasswordByPasswordRecoveryAnswer, RakNet::Client_GetPasswordRecoveryQuestionByHandle, RakNet::Client_GetEmailAddress, RakNet::System_PruneAccounts, RakNet::System_DeleteAccount, RakNet::Client_ValidateHandle, RakNet::System_SetEmailAddressValidated, RakNet::Client_RegisterAccount, RakNet::Client_Login, RakNet::CDKey_FlagStolen, RakNet::CDKey_Use, RakNet::CDKey_GetStatus, RakNet::CDKey_Add, RakNet::System_UnbanUser, RakNet::System_BanUser, RakNet::System_RegisterProfanity, RakNet::System_GetTitleBinaryData, RakNet::System_GetTitleRequiredAge, RakNet::System_DestroyTitle, RakNet::System_CreateTitle, RakNet::System_DestroyDatabase, RakNet::System_CreateDatabase, RakNet::Platform_Shutdown, and RakNet::Platform_Startup.

virtual bool RakNet::Lobby2Message::RequiresAdmin ( void ) const
pure virtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implemented in RakNet::Clans_GetPosts, RakNet::Clans_GetTopics, RakNet::Clans_GetBoards, RakNet::Clans_RemovePost, RakNet::Clans_ReplyToTopic, RakNet::Clans_CreateNewTopic, RakNet::Clans_DestroyBoard, RakNet::Clans_CreateBoard, RakNet::Clans_GetList, RakNet::Clans_GetMembers, RakNet::Clans_GetBlacklist, RakNet::Clans_UnblacklistUser, RakNet::Clans_KickAndBlacklistUser, RakNet::Clans_DownloadRequestList, RakNet::Clans_RejectJoinRequest, RakNet::Clans_AcceptJoinRequest, RakNet::Clans_WithdrawJoinRequest, RakNet::Clans_SendJoinRequest, RakNet::Clans_DownloadInvitationList, RakNet::Clans_RejectJoinInvitation, RakNet::Clans_AcceptJoinInvitation, RakNet::Clans_WithdrawJoinInvitation, RakNet::Clans_SendJoinInvitation, RakNet::Clans_Get, RakNet::Clans_Leave, RakNet::Clans_ChangeHandle, RakNet::Clans_GetMemberProperties, RakNet::Clans_SetMemberRank, RakNet::Clans_SetSubleaderStatus, RakNet::Clans_GrantLeader, RakNet::Clans_SetMyMemberProperties, RakNet::Clans_GetProperties, RakNet::Clans_SetProperties, RakNet::Clans_Create, RakNet::Ranking_GetRating, RakNet::Ranking_WipeRatings, RakNet::Ranking_UpdateRating, RakNet::Ranking_PruneMatches, RakNet::Ranking_WipeMatches, RakNet::Ranking_WipeScoresForPlayer, RakNet::Ranking_GetTotalScore, RakNet::Ranking_GetMatchBinaryData, RakNet::Ranking_GetMatches, RakNet::Ranking_SubmitMatch, RakNet::Emails_SetStatus, RakNet::Emails_Delete, RakNet::Emails_Get, RakNet::Emails_Send, RakNet::BookmarkedUsers_Get, RakNet::BookmarkedUsers_Remove, RakNet::BookmarkedUsers_Add, RakNet::Friends_Remove, RakNet::Friends_GetFriends, RakNet::Friends_GetInvites, RakNet::Friends_RejectInvite, RakNet::Friends_AcceptInvite, RakNet::Friends_SendInvite, RakNet::Client_GetPresence, RakNet::Client_SetPresence, RakNet::Client_PerTitleBinaryStorage, RakNet::Client_GetIgnoreList, RakNet::Client_StopIgnore, RakNet::Client_StartIgnore, RakNet::Client_GetAccountDetails, RakNet::Client_UpdateAccount, RakNet::Client_ChangeHandle, RakNet::Client_GetPasswordByPasswordRecoveryAnswer, RakNet::Client_GetPasswordRecoveryQuestionByHandle, RakNet::Client_GetEmailAddress, RakNet::System_PruneAccounts, RakNet::System_DeleteAccount, RakNet::Client_ValidateHandle, RakNet::System_SetEmailAddressValidated, RakNet::Client_RegisterAccount, RakNet::Client_Logoff, RakNet::Client_Login, RakNet::CDKey_FlagStolen, RakNet::CDKey_Use, RakNet::CDKey_GetStatus, RakNet::CDKey_Add, RakNet::System_UnbanUser, RakNet::System_BanUser, RakNet::System_RegisterProfanity, RakNet::System_GetTitleBinaryData, RakNet::System_GetTitleRequiredAge, RakNet::System_DestroyTitle, RakNet::System_CreateTitle, RakNet::System_DestroyDatabase, RakNet::System_CreateDatabase, RakNet::Platform_Shutdown, and RakNet::Platform_Startup.

virtual bool RakNet::Lobby2Message::RequiresLogin ( void ) const
pure virtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implemented in RakNet::Clans_GetPosts, RakNet::Clans_GetTopics, RakNet::Clans_GetBoards, RakNet::Clans_RemovePost, RakNet::Clans_ReplyToTopic, RakNet::Clans_CreateNewTopic, RakNet::Clans_DestroyBoard, RakNet::Clans_CreateBoard, RakNet::Clans_GetList, RakNet::Clans_GetMembers, RakNet::Clans_GetBlacklist, RakNet::Clans_UnblacklistUser, RakNet::Clans_KickAndBlacklistUser, RakNet::Clans_DownloadRequestList, RakNet::Clans_RejectJoinRequest, RakNet::Clans_AcceptJoinRequest, RakNet::Clans_WithdrawJoinRequest, RakNet::Clans_SendJoinRequest, RakNet::Clans_DownloadInvitationList, RakNet::Clans_RejectJoinInvitation, RakNet::Clans_AcceptJoinInvitation, RakNet::Clans_WithdrawJoinInvitation, RakNet::Clans_SendJoinInvitation, RakNet::Clans_Get, RakNet::Clans_Leave, RakNet::Clans_ChangeHandle, RakNet::Clans_GetMemberProperties, RakNet::Clans_SetMemberRank, RakNet::Clans_SetSubleaderStatus, RakNet::Clans_GrantLeader, RakNet::Clans_SetMyMemberProperties, RakNet::Clans_GetProperties, RakNet::Clans_SetProperties, RakNet::Clans_Create, RakNet::Ranking_GetRating, RakNet::Ranking_WipeRatings, RakNet::Ranking_UpdateRating, RakNet::Ranking_PruneMatches, RakNet::Ranking_WipeMatches, RakNet::Ranking_WipeScoresForPlayer, RakNet::Ranking_GetTotalScore, RakNet::Ranking_GetMatchBinaryData, RakNet::Ranking_GetMatches, RakNet::Ranking_SubmitMatch, RakNet::Emails_SetStatus, RakNet::Emails_Delete, RakNet::Emails_Get, RakNet::Emails_Send, RakNet::BookmarkedUsers_Get, RakNet::BookmarkedUsers_Remove, RakNet::BookmarkedUsers_Add, RakNet::Friends_Remove, RakNet::Friends_GetFriends, RakNet::Friends_GetInvites, RakNet::Friends_RejectInvite, RakNet::Friends_AcceptInvite, RakNet::Friends_SendInvite, RakNet::Client_GetPresence, RakNet::Client_SetPresence, RakNet::Client_PerTitleBinaryStorage, RakNet::Client_GetIgnoreList, RakNet::Client_StopIgnore, RakNet::Client_StartIgnore, RakNet::Client_GetAccountDetails, RakNet::Client_UpdateAccount, RakNet::Client_ChangeHandle, RakNet::Client_GetPasswordByPasswordRecoveryAnswer, RakNet::Client_GetPasswordRecoveryQuestionByHandle, RakNet::Client_GetEmailAddress, RakNet::System_PruneAccounts, RakNet::System_DeleteAccount, RakNet::Client_ValidateHandle, RakNet::System_SetEmailAddressValidated, RakNet::Client_RegisterAccount, RakNet::Client_Logoff, RakNet::Client_Login, RakNet::CDKey_FlagStolen, RakNet::CDKey_Use, RakNet::CDKey_GetStatus, RakNet::CDKey_Add, RakNet::System_UnbanUser, RakNet::System_BanUser, RakNet::System_RegisterProfanity, RakNet::System_GetTitleBinaryData, RakNet::System_GetTitleRequiredAge, RakNet::System_DestroyTitle, RakNet::System_CreateTitle, RakNet::System_DestroyDatabase, RakNet::System_CreateDatabase, RakNet::Platform_Shutdown, and RakNet::Platform_Startup.

virtual bool RakNet::Lobby2Message::RequiresRankingPermission ( void ) const
pure virtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implemented in RakNet::Clans_GetPosts, RakNet::Clans_GetTopics, RakNet::Clans_GetBoards, RakNet::Clans_RemovePost, RakNet::Clans_ReplyToTopic, RakNet::Clans_CreateNewTopic, RakNet::Clans_DestroyBoard, RakNet::Clans_CreateBoard, RakNet::Clans_GetList, RakNet::Clans_GetMembers, RakNet::Clans_GetBlacklist, RakNet::Clans_UnblacklistUser, RakNet::Clans_KickAndBlacklistUser, RakNet::Clans_DownloadRequestList, RakNet::Clans_RejectJoinRequest, RakNet::Clans_AcceptJoinRequest, RakNet::Clans_WithdrawJoinRequest, RakNet::Clans_SendJoinRequest, RakNet::Clans_DownloadInvitationList, RakNet::Clans_RejectJoinInvitation, RakNet::Clans_AcceptJoinInvitation, RakNet::Clans_WithdrawJoinInvitation, RakNet::Clans_SendJoinInvitation, RakNet::Clans_Get, RakNet::Clans_Leave, RakNet::Clans_ChangeHandle, RakNet::Clans_GetMemberProperties, RakNet::Clans_SetMemberRank, RakNet::Clans_SetSubleaderStatus, RakNet::Clans_GrantLeader, RakNet::Clans_SetMyMemberProperties, RakNet::Clans_GetProperties, RakNet::Clans_SetProperties, RakNet::Clans_Create, RakNet::Ranking_GetRating, RakNet::Ranking_WipeRatings, RakNet::Ranking_UpdateRating, RakNet::Ranking_PruneMatches, RakNet::Ranking_WipeMatches, RakNet::Ranking_WipeScoresForPlayer, RakNet::Ranking_GetTotalScore, RakNet::Ranking_GetMatchBinaryData, RakNet::Ranking_GetMatches, RakNet::Ranking_SubmitMatch, RakNet::Emails_SetStatus, RakNet::Emails_Delete, RakNet::Emails_Get, RakNet::Emails_Send, RakNet::BookmarkedUsers_Get, RakNet::BookmarkedUsers_Remove, RakNet::BookmarkedUsers_Add, RakNet::Friends_Remove, RakNet::Friends_GetFriends, RakNet::Friends_GetInvites, RakNet::Friends_RejectInvite, RakNet::Friends_AcceptInvite, RakNet::Friends_SendInvite, RakNet::Client_GetPresence, RakNet::Client_SetPresence, RakNet::Client_PerTitleBinaryStorage, RakNet::Client_GetIgnoreList, RakNet::Client_StopIgnore, RakNet::Client_StartIgnore, RakNet::Client_GetAccountDetails, RakNet::Client_UpdateAccount, RakNet::Client_ChangeHandle, RakNet::Client_GetPasswordByPasswordRecoveryAnswer, RakNet::Client_GetPasswordRecoveryQuestionByHandle, RakNet::Client_GetEmailAddress, RakNet::System_PruneAccounts, RakNet::System_DeleteAccount, RakNet::Client_ValidateHandle, RakNet::System_SetEmailAddressValidated, RakNet::Client_RegisterAccount, RakNet::Client_Logoff, RakNet::Client_Login, RakNet::CDKey_FlagStolen, RakNet::CDKey_Use, RakNet::CDKey_GetStatus, RakNet::CDKey_Add, RakNet::System_UnbanUser, RakNet::System_BanUser, RakNet::System_RegisterProfanity, RakNet::System_GetTitleBinaryData, RakNet::System_GetTitleRequiredAge, RakNet::System_DestroyTitle, RakNet::System_CreateTitle, RakNet::System_DestroyDatabase, RakNet::System_CreateDatabase, RakNet::Platform_Shutdown, and RakNet::Platform_Startup.

virtual bool RakNet::Lobby2Message::ServerDBImpl | ( | Lobby2ServerCommand * | command,
 |  | void * | databaseInterface
 | ) |  |
virtual

Do any Lobby2Server functionality when the message is processed in a database thread on the server. It is safe to do slow database calls in this function. If it returns true, the message has been handled, and the result is sent to the client If it returns false, that means ignore the message

virtual bool RakNet::Lobby2Message::ServerPreDBMemoryImpl | ( | Lobby2Server * | server,
 |  | RakString | userHandle
 | ) |  |
virtual

Do any Lobby2Server functionality when the message first arrives on the server, and after it has returned true from PrevalidateInput() If it returns true, the message has been handled, and the result is sent to the client If it returns false, the message continues to ServerDBImpl

Reimplemented in RakNet::Platform_Shutdown, and RakNet::Platform_Startup.

bool RakNet::Lobby2Message::ValidateHandle ( RakNet::RakString * handle )

The only non-printable character is space Cannot start with space Cannot end with space Cannot have two spaces in a row

Member Data Documentation

uint32_t RakNet::Lobby2Message::callbackId

Just a number, representing which instance of Lobby2Callbacks should process the result of this operation -1 means all

uint64_t RakNet::Lobby2Message::requestId

Just a number, uniquely identifying each allocation of Lobby2Message. Use it if you need to lookup queries on the callback reply

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Platform_Startup Struct Reference

  • Platform_Startup
Public Member Functions | List of all members
RakNet::Platform_Startup Struct Reference
Lobby2Commands

Platform specific startup. Unused on the PC. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Platform_Startup:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual bool | PrevalidateInput (void)
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Platform specific startup. Unused on the PC.

Member Function Documentation

virtual bool RakNet::Platform_Startup::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Platform_Startup::PrevalidateInput ( void )
inlinevirtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Platform_Startup::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Platform_Startup::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Platform_Startup::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Platform_Startup::ServerPreDBMemoryImpl | ( | Lobby2Server * | server,
 |  | RakString | userHandle
 | ) |  |
inlinevirtual

Do any Lobby2Server functionality when the message first arrives on the server, and after it has returned true from PrevalidateInput() If it returns true, the message has been handled, and the result is sent to the client If it returns false, the message continues to ServerDBImpl

Reimplemented from RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Platform_Shutdown Struct Reference

  • Platform_Shutdown
Public Member Functions | List of all members
RakNet::Platform_Shutdown Struct Reference
Lobby2Commands

Platform specific startup. Unused on the PC. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Platform_Shutdown:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual bool | PrevalidateInput (void)
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Platform specific startup. Unused on the PC.

Member Function Documentation

virtual bool RakNet::Platform_Shutdown::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Platform_Shutdown::PrevalidateInput ( void )
inlinevirtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Platform_Shutdown::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Platform_Shutdown::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Platform_Shutdown::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Platform_Shutdown::ServerPreDBMemoryImpl | ( | Lobby2Server * | server,
 |  | RakString | userHandle
 | ) |  |
inlinevirtual

Do any Lobby2Server functionality when the message first arrives on the server, and after it has returned true from PrevalidateInput() If it returns true, the message has been handled, and the result is sent to the client If it returns false, the message continues to ServerDBImpl

Reimplemented from RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::System_CreateDatabase Struct Reference

  • System_CreateDatabase
Public Member Functions | List of all members
RakNet::System_CreateDatabase Struct Reference
Lobby2Commands

Create all tables and stored procedures on a system that does not already have them. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::System_CreateDatabase:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Create all tables and stored procedures on a system that does not already have them.

Member Function Documentation

virtual bool RakNet::System_CreateDatabase::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_CreateDatabase::PrevalidateInput ( void )
inlinevirtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::System_CreateDatabase::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_CreateDatabase::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_CreateDatabase::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::System_DestroyDatabase Struct Reference

  • System_DestroyDatabase
Public Member Functions | List of all members
RakNet::System_DestroyDatabase Struct Reference
Lobby2Commands

Destroy all tables and stored procedures created with System_CreateDatabase. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::System_DestroyDatabase:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Destroy all tables and stored procedures created with System_CreateDatabase.

Member Function Documentation

virtual bool RakNet::System_DestroyDatabase::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_DestroyDatabase::PrevalidateInput ( void )
inlinevirtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::System_DestroyDatabase::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_DestroyDatabase::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_DestroyDatabase::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::System_CreateTitle Struct Reference

  • System_CreateTitle
Public Member Functions | List of all members
RakNet::System_CreateTitle Struct Reference
Lobby2Commands

Each title essentially corresponds to a game. For example, the same lobby system may be used for both asteroids and Pac-man. When logging in, and for some functions, it is necessary to specify which title you are logging in under. This way users playing asteroids do not interact with users playing pac-man, where such interations are game specific (such as ranking). More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::System_CreateTitle:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Each title essentially corresponds to a game. For example, the same lobby system may be used for both asteroids and Pac-man. When logging in, and for some functions, it is necessary to specify which title you are logging in under. This way users playing asteroids do not interact with users playing pac-man, where such interations are game specific (such as ranking).

Member Function Documentation

virtual bool RakNet::System_CreateTitle::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_CreateTitle::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::System_CreateTitle::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_CreateTitle::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_CreateTitle::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::System_DestroyTitle Struct Reference

  • System_DestroyTitle
Public Member Functions | List of all members
RakNet::System_DestroyTitle Struct Reference
Lobby2Commands

Destroy a previously added title. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::System_DestroyTitle:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Destroy a previously added title.

Member Function Documentation

virtual bool RakNet::System_DestroyTitle::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_DestroyTitle::PrevalidateInput ( void )
inlinevirtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::System_DestroyTitle::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_DestroyTitle::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_DestroyTitle::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::System_GetTitleRequiredAge Struct Reference

  • System_GetTitleRequiredAge
Public Member Functions | List of all members
RakNet::System_GetTitleRequiredAge Struct Reference
Lobby2Commands

Get the required age set with System_CreateTitle. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::System_GetTitleRequiredAge:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Get the required age set with System_CreateTitle.

Member Function Documentation

virtual bool RakNet::System_GetTitleRequiredAge::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_GetTitleRequiredAge::PrevalidateInput ( void )
inlinevirtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::System_GetTitleRequiredAge::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_GetTitleRequiredAge::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_GetTitleRequiredAge::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::System_GetTitleBinaryData Struct Reference

  • System_GetTitleBinaryData
Public Member Functions | List of all members
RakNet::System_GetTitleBinaryData Struct Reference
Lobby2Commands

Get the binary data set with System_CreateTitle. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::System_GetTitleBinaryData:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Get the binary data set with System_CreateTitle.

Member Function Documentation

virtual bool RakNet::System_GetTitleBinaryData::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_GetTitleBinaryData::PrevalidateInput ( void )
inlinevirtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::System_GetTitleBinaryData::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_GetTitleBinaryData::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_GetTitleBinaryData::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::System_RegisterProfanity Struct Reference

  • System_RegisterProfanity
Public Member Functions | List of all members
RakNet::System_RegisterProfanity Struct Reference
Lobby2Commands

Adds the input strings to a table of profanity. non-unique or empty strings can be ignored. This table will be used internally to ensure that handles and clan names do not contain profanity. Multiple calls add to the table. This table will be used for functions that take a user-defined string that is highly visible, such as clan and user names. It does not need to be checked for emails or message boards. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::System_RegisterProfanity:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Adds the input strings to a table of profanity. non-unique or empty strings can be ignored. This table will be used internally to ensure that handles and clan names do not contain profanity. Multiple calls add to the table. This table will be used for functions that take a user-defined string that is highly visible, such as clan and user names. It does not need to be checked for emails or message boards.

Member Function Documentation

virtual bool RakNet::System_RegisterProfanity::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_RegisterProfanity::PrevalidateInput ( void )
inlinevirtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::System_RegisterProfanity::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_RegisterProfanity::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_RegisterProfanity::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::System_BanUser Struct Reference

  • System_BanUser
Public Member Functions | List of all members
RakNet::System_BanUser Struct Reference
Lobby2Commands

Bans a specific user (will be most likely called by a moderator). Adds the user's primary key to a ban table, along with the name of the moderator, the reason for the ban. Banning is used to prevent the banned user from logging on for some specified duration. A date column should be present and automatically filled in. When bans are expired, the ban can be deleted from the database. However, a separate table should log bans, so that even expired bans can be looked up in case. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::System_BanUser:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Bans a specific user (will be most likely called by a moderator). Adds the user's primary key to a ban table, along with the name of the moderator, the reason for the ban. Banning is used to prevent the banned user from logging on for some specified duration. A date column should be present and automatically filled in. When bans are expired, the ban can be deleted from the database. However, a separate table should log bans, so that even expired bans can be looked up in case.

Member Function Documentation

virtual bool RakNet::System_BanUser::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_BanUser::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::System_BanUser::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_BanUser::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_BanUser::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::System_UnbanUser Struct Reference

  • System_UnbanUser
Public Member Functions | List of all members
RakNet::System_UnbanUser Struct Reference
Lobby2Commands

Unban a user banned with System_BanUser. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::System_UnbanUser:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Unban a user banned with System_BanUser.

Member Function Documentation

virtual bool RakNet::System_UnbanUser::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_UnbanUser::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::System_UnbanUser::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_UnbanUser::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_UnbanUser::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::CDKey_Add Struct Reference

  • CDKey_Add
Public Member Functions | List of all members
RakNet::CDKey_Add Struct Reference
Lobby2Commands

Adds CDKeys to the database. Duplicate CDKeys for a particular title are ignored. CDKeys can be identical for different titles. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::CDKey_Add:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Adds CDKeys to the database. Duplicate CDKeys for a particular title are ignored. CDKeys can be identical for different titles.

Member Function Documentation

virtual bool RakNet::CDKey_Add::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::CDKey_Add::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::CDKey_Add::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::CDKey_Add::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::CDKey_Add::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::CDKey_GetStatus Struct Reference

  • CDKey_GetStatus
Public Member Functions | List of all members
RakNet::CDKey_GetStatus Struct Reference
Lobby2Commands

Returns if a CD key was previously added with AddCDKey. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::CDKey_GetStatus:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Returns if a CD key was previously added with AddCDKey.

Member Function Documentation

virtual bool RakNet::CDKey_GetStatus::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::CDKey_GetStatus::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::CDKey_GetStatus::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::CDKey_GetStatus::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::CDKey_GetStatus::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::CDKey_Use Struct Reference

  • CDKey_Use
Public Member Functions | List of all members
RakNet::CDKey_Use Struct Reference
Lobby2Commands

Associates a cd key with a user, such that the cd key cannot be used again. If Client_Login() is called with check cd key as true, then this table will be checked to make sure UserCDKey() was previously called with this user and a valid key. If this user is already associated with a CD Key, add the new key, and use the most recent key. All CD Key usage should be logged in a separate table, including the date used and result. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::CDKey_Use:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Associates a cd key with a user, such that the cd key cannot be used again. If Client_Login() is called with check cd key as true, then this table will be checked to make sure UserCDKey() was previously called with this user and a valid key. If this user is already associated with a CD Key, add the new key, and use the most recent key. All CD Key usage should be logged in a separate table, including the date used and result.

Member Function Documentation

virtual bool RakNet::CDKey_Use::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::CDKey_Use::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::CDKey_Use::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::CDKey_Use::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::CDKey_Use::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::CDKey_FlagStolen Struct Reference

  • CDKey_FlagStolen
Public Member Functions | List of all members
RakNet::CDKey_FlagStolen Struct Reference
Lobby2Commands

Flags one or more CD keys as stolen. Stolen CD keys will prevent Client_Login() if check cd key is true. They will also prevent these cd keys from being used with CDKey_Use. If this key is already in use by certain users for this particular title, then log this similarly to how CDKey_Use does so. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::CDKey_FlagStolen:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Flags one or more CD keys as stolen. Stolen CD keys will prevent Client_Login() if check cd key is true. They will also prevent these cd keys from being used with CDKey_Use. If this key is already in use by certain users for this particular title, then log this similarly to how CDKey_Use does so.

Member Function Documentation

virtual bool RakNet::CDKey_FlagStolen::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::CDKey_FlagStolen::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::CDKey_FlagStolen::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::CDKey_FlagStolen::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::CDKey_FlagStolen::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Client_Login Struct Reference

  • Client_Login
Public Member Functions | List of all members
RakNet::Client_Login Struct Reference
Lobby2Commands

Logon with a previously registered account. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Client_Login:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Logon with a previously registered account.

Once a client creates an account with Client_RegisterAccount, the client is able to logon. The login process will check

  1. The CDKey associated with this user (See CDKey_Use) if checkCDKey is true
  2. The userPassword passed to this function
  3. The titleName and titleSecretKey, to ensure this title was previously created with System_CreateTitle
  4. If allowLoginWithoutEmailAddressValidation==false for this user (See Client_RegisterAccount) and System_SetEmailAddressValidated was not called for that email address, fail.
  5. If this user was banned with a ban still in effect via System_BanUser

If all checks pass, store in a logging table that the user has logged in at this time. No status flag needs be set, this will be done in C++.

Member Function Documentation

virtual bool RakNet::Client_Login::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_Login::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Client_Login::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_Login::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_Login::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Client_Logoff Struct Reference

  • Client_Logoff
Public Member Functions | List of all members
RakNet::Client_Logoff Struct Reference
Lobby2Commands

Logoff, after logging in. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Client_Logoff:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Logoff, after logging in.

Member Function Documentation

virtual bool RakNet::Client_Logoff::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_Logoff::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_Logoff::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_Logoff::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Client_RegisterAccount Struct Reference

  • Client_RegisterAccount
Public Member Functions | List of all members
RakNet::Client_RegisterAccount Struct Reference
Lobby2Commands

This creates a new account in the database, which can be used in a subsequent call to Login. Most parameters are optional. handle is not optional, and must be unique using case-insensitive compare. emailAddress should be validated to have a sensible format, including an @ sign and a period with a 3 letter extension. allowLoginWithoutEmailAddressValidation is used in Client_Login to potentially disallow logon attempts with unverified email addresses. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Client_RegisterAccount:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

This creates a new account in the database, which can be used in a subsequent call to Login. Most parameters are optional. handle is not optional, and must be unique using case-insensitive compare. emailAddress should be validated to have a sensible format, including an @ sign and a period with a 3 letter extension. allowLoginWithoutEmailAddressValidation is used in Client_Login to potentially disallow logon attempts with unverified email addresses.

Member Function Documentation

virtual bool RakNet::Client_RegisterAccount::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_RegisterAccount::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Client_RegisterAccount::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_RegisterAccount::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_RegisterAccount::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::System_SetEmailAddressValidated Struct Reference

  • System_SetEmailAddressValidated
Public Member Functions | List of all members
RakNet::System_SetEmailAddressValidated Struct Reference
Lobby2Commands

For the client with the given handle, mark a column emailAddressValidated as true or false as appropriate. This is potentially used in Client_Login. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::System_SetEmailAddressValidated:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

For the client with the given handle, mark a column emailAddressValidated as true or false as appropriate. This is potentially used in Client_Login.

Member Function Documentation

virtual bool RakNet::System_SetEmailAddressValidated::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_SetEmailAddressValidated::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::System_SetEmailAddressValidated::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_SetEmailAddressValidated::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_SetEmailAddressValidated::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Client_ValidateHandle Struct Reference

  • Client_ValidateHandle
Public Member Functions | List of all members
RakNet::Client_ValidateHandle Struct Reference
Lobby2Commands

Looks up in the database if this handle is already in use, subject to the usual constraints of handles. This will be used by the user to quickly check for available handles. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Client_ValidateHandle:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Looks up in the database if this handle is already in use, subject to the usual constraints of handles. This will be used by the user to quickly check for available handles.

Member Function Documentation

virtual bool RakNet::Client_ValidateHandle::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_ValidateHandle::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Client_ValidateHandle::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_ValidateHandle::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_ValidateHandle::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::System_DeleteAccount Struct Reference

  • System_DeleteAccount
Public Member Functions | List of all members
RakNet::System_DeleteAccount Struct Reference
Lobby2Commands

Flags as deleted an account registered with RegisterAccount. Accounts are not actually deleted, only tagged as deleted. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::System_DeleteAccount:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Flags as deleted an account registered with RegisterAccount. Accounts are not actually deleted, only tagged as deleted.

Member Function Documentation

virtual bool RakNet::System_DeleteAccount::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_DeleteAccount::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::System_DeleteAccount::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_DeleteAccount::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_DeleteAccount::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::System_PruneAccounts Struct Reference

  • System_PruneAccounts
Public Member Functions | List of all members
RakNet::System_PruneAccounts Struct Reference
Lobby2Commands

Unused accounts are deleted. This is cascading, such that emails and other tables that reference this key are also deleted. unused accounts are defined as: More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::System_PruneAccounts:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Unused accounts are deleted. This is cascading, such that emails and other tables that reference this key are also deleted. unused accounts are defined as:

  1. Deleted accounts over deletedPruneTime seconds old
  2. Accounts which have not been logged into for over loggedInPruneTime seconds <>

Member Function Documentation

virtual bool RakNet::System_PruneAccounts::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_PruneAccounts::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::System_PruneAccounts::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_PruneAccounts::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::System_PruneAccounts::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Client_GetEmailAddress Struct Reference

  • Client_GetEmailAddress
Public Member Functions | List of all members
RakNet::Client_GetEmailAddress Struct Reference
Lobby2Commands

Returns the email address associated with a specific handle, invalid handle. This is used for password recovery. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Client_GetEmailAddress:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Returns the email address associated with a specific handle, invalid handle. This is used for password recovery.

Member Function Documentation

virtual bool RakNet::Client_GetEmailAddress::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_GetEmailAddress::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Client_GetEmailAddress::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_GetEmailAddress::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_GetEmailAddress::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Client_GetPasswordRecoveryQuestionByHandle Struct Reference

  • Client_GetPasswordRecoveryQuestionByHandle
Public Member Functions | List of all members
RakNet::Client_GetPasswordRecoveryQuestionByHandle Struct Reference
Lobby2Commands

Returns the passwordRecoveryQuestion associated with handle, invalid handle. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Client_GetPasswordRecoveryQuestionByHandle:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Returns the passwordRecoveryQuestion associated with handle, invalid handle.

Member Function Documentation

virtual bool RakNet::Client_GetPasswordRecoveryQuestionByHandle::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_GetPasswordRecoveryQuestionByHandle::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Client_GetPasswordRecoveryQuestionByHandle::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_GetPasswordRecoveryQuestionByHandle::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_GetPasswordRecoveryQuestionByHandle::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Client_GetPasswordByPasswordRecoveryAnswer Struct Reference

  • Client_GetPasswordByPasswordRecoveryAnswer
Public Member Functions | List of all members
RakNet::Client_GetPasswordByPasswordRecoveryAnswer Struct Reference
Lobby2Commands

Returns the password associated with a handle, if the passwordRecoveryAnswer is correct. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Client_GetPasswordByPasswordRecoveryAnswer:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Returns the password associated with a handle, if the passwordRecoveryAnswer is correct.

Member Function Documentation

virtual bool RakNet::Client_GetPasswordByPasswordRecoveryAnswer::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_GetPasswordByPasswordRecoveryAnswer::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Client_GetPasswordByPasswordRecoveryAnswer::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_GetPasswordByPasswordRecoveryAnswer::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_GetPasswordByPasswordRecoveryAnswer::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Client_ChangeHandle Struct Reference

  • Client_ChangeHandle
Public Member Functions | List of all members
RakNet::Client_ChangeHandle Struct Reference
Lobby2Commands

Changes the handle for a user. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Client_ChangeHandle:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Changes the handle for a user.

Member Function Documentation

virtual bool RakNet::Client_ChangeHandle::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_ChangeHandle::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Client_ChangeHandle::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_ChangeHandle::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_ChangeHandle::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Client_UpdateAccount Struct Reference

  • Client_UpdateAccount
Public Member Functions | List of all members
RakNet::Client_UpdateAccount Struct Reference
Lobby2Commands

Will update any or all of the inputs that were previously passed to Client_RegisterAccount, except handle. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Client_UpdateAccount:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Will update any or all of the inputs that were previously passed to Client_RegisterAccount, except handle.

For input parameters, see Client_RegisterAccount() createAccountParameters

Member Function Documentation

virtual bool RakNet::Client_UpdateAccount::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_UpdateAccount::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Client_UpdateAccount::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_UpdateAccount::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_UpdateAccount::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Client_GetAccountDetails Struct Reference

  • Client_GetAccountDetails
Public Member Functions | List of all members
RakNet::Client_GetAccountDetails Struct Reference
Lobby2Commands

Get the parameters set with Client_RegisterAccount. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Client_GetAccountDetails:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | PrevalidateInput (void)
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Get the parameters set with Client_RegisterAccount.

Member Function Documentation

virtual bool RakNet::Client_GetAccountDetails::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_GetAccountDetails::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_GetAccountDetails::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_GetAccountDetails::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Client_StartIgnore Struct Reference

  • Client_StartIgnore
Public Member Functions | List of all members
RakNet::Client_StartIgnore Struct Reference
Lobby2Commands

Adds the specified user to an ignore list for my user. Recommended to store the primary key of the remote user, both for speed and so if the other use changes their handle it still works. The ignore list is checked for friend invites, emails, and elsewhere where indicated. Ignoring is uni-directional, so if A ignores B, A will block messages from B where appropriate, but B will not immediately block messages from A. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Client_StartIgnore:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Adds the specified user to an ignore list for my user. Recommended to store the primary key of the remote user, both for speed and so if the other use changes their handle it still works. The ignore list is checked for friend invites, emails, and elsewhere where indicated. Ignoring is uni-directional, so if A ignores B, A will block messages from B where appropriate, but B will not immediately block messages from A.

Member Function Documentation

virtual bool RakNet::Client_StartIgnore::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_StartIgnore::ClientImpl ( RakNet::Lobby2Plugin * client )
virtual

Override to do any Lobby2Client functionality when the message is returned from the server (usually nothing).

Returns
True to call CallCallback immediately. False to defer for some reason (always true on the PC)

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Client_StartIgnore::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Client_StartIgnore::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_StartIgnore::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_StartIgnore::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Client_StopIgnore Struct Reference

  • Client_StopIgnore
Public Member Functions | List of all members
RakNet::Client_StopIgnore Struct Reference
Lobby2Commands

Removes an entry in the database such that myHandle will no longer ignore theirHandle. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Client_StopIgnore:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Removes an entry in the database such that myHandle will no longer ignore theirHandle.

Member Function Documentation

virtual bool RakNet::Client_StopIgnore::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_StopIgnore::ClientImpl ( RakNet::Lobby2Plugin * client )
virtual

Override to do any Lobby2Client functionality when the message is returned from the server (usually nothing).

Returns
True to call CallCallback immediately. False to defer for some reason (always true on the PC)

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Client_StopIgnore::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Client_StopIgnore::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_StopIgnore::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_StopIgnore::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Client_GetIgnoreList Struct Reference

  • Client_GetIgnoreList
Public Member Functions | List of all members
RakNet::Client_GetIgnoreList Struct Reference
Lobby2Commands

Returns all users I have ignored. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Client_GetIgnoreList:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | PrevalidateInput (void)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Returns all users I have ignored.

Member Function Documentation

virtual bool RakNet::Client_GetIgnoreList::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_GetIgnoreList::ClientImpl ( RakNet::Lobby2Plugin * client )
virtual

Override to do any Lobby2Client functionality when the message is returned from the server (usually nothing).

Returns
True to call CallCallback immediately. False to defer for some reason (always true on the PC)

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Client_GetIgnoreList::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_GetIgnoreList::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_GetIgnoreList::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Client_PerTitleBinaryStorage Struct Reference

  • Client_PerTitleBinaryStorage
Public Types | Public Member Functions | Public Attributes | List of all members
RakNet::Client_PerTitleBinaryStorage Struct Reference
Lobby2Commands

For each combination of user and title, structures can be stored. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Client_PerTitleBinaryStorage:
RakNet::Lobby2Message

Public Types

enum PTIS_Operation

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Public Attributes

RakNet::RakString titleName
[in] Name of a created title
unsigned int | slotIndex
[in] Slot index can be any value, and just lets you store more than one 64 bit integer
RakNetSmartPtr< BinaryDataBlock > | binaryData
- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

For each combination of user and title, structures can be stored.

Member Enumeration Documentation

enum RakNet::Client_PerTitleBinaryStorage::PTIS_Operation

[in] What to do. Write will overwrite the existing value with binaryData Read will return the existing value in binaryData

Member Function Documentation

virtual bool RakNet::Client_PerTitleBinaryStorage::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_PerTitleBinaryStorage::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Client_PerTitleBinaryStorage::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_PerTitleBinaryStorage::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_PerTitleBinaryStorage::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

Member Data Documentation

RakNetSmartPtr<BinaryDataBlock> RakNet::Client_PerTitleBinaryStorage::binaryData

[in/out] Binary data. On Write, will be written to the row. On Read, will be filled in with the value of the row. Unused for delete Max length of binaryData is 256K

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Friends_SendInvite Struct Reference

  • Friends_SendInvite
Public Member Functions | List of all members
RakNet::Friends_SendInvite Struct Reference
Lobby2Commands

Stores in the database an add friend invite from my handle to their handle. The combination of my handle and their handle must be unique, so you cannot send more than one add friend invite to a single user. Sends an email to their handle the subject, body, and binary data. Note: if myHandle is ignored by theirHandle, then the function fails. See Client_StartIgnore. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Friends_SendInvite:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Stores in the database an add friend invite from my handle to their handle. The combination of my handle and their handle must be unique, so you cannot send more than one add friend invite to a single user. Sends an email to their handle the subject, body, and binary data. Note: if myHandle is ignored by theirHandle, then the function fails. See Client_StartIgnore.

Member Function Documentation

virtual bool RakNet::Friends_SendInvite::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Friends_SendInvite::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Friends_SendInvite::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Friends_SendInvite::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Friends_SendInvite::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Friends_AcceptInvite Struct Reference

  • Friends_AcceptInvite
Public Member Functions | List of all members
RakNet::Friends_AcceptInvite Struct Reference
Lobby2Commands

Stores in the database that this user is now my friend. This is bidirectional, which is to say if someone accepts an add friend invite, they are my friend, and I am their friend. Recommended to store by primary key for speed and in case the friend's handle changes. Store in the emails table from my handle to their handle the subject, body, and binary data. Note: if myHandle is ignored by theirHandle, then the function fails. See AddToIgnoreList. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Friends_AcceptInvite:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Stores in the database that this user is now my friend. This is bidirectional, which is to say if someone accepts an add friend invite, they are my friend, and I am their friend. Recommended to store by primary key for speed and in case the friend's handle changes. Store in the emails table from my handle to their handle the subject, body, and binary data. Note: if myHandle is ignored by theirHandle, then the function fails. See AddToIgnoreList.

Member Function Documentation

virtual bool RakNet::Friends_AcceptInvite::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Friends_AcceptInvite::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Friends_AcceptInvite::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Friends_AcceptInvite::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Friends_AcceptInvite::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Friends_RejectInvite Struct Reference

  • Friends_RejectInvite
Public Member Functions | List of all members
RakNet::Friends_RejectInvite Struct Reference
Lobby2Commands

Removes from the database the pending add friend invite. Operation completes even if ignored. Unless ignored, store in the emails table from my handle to their handle the subject, body, binary data, and procedure type flag. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Friends_RejectInvite:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Removes from the database the pending add friend invite. Operation completes even if ignored. Unless ignored, store in the emails table from my handle to their handle the subject, body, binary data, and procedure type flag.

Member Function Documentation

virtual bool RakNet::Friends_RejectInvite::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Friends_RejectInvite::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Friends_RejectInvite::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Friends_RejectInvite::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Friends_RejectInvite::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Friends_GetInvites Struct Reference

  • Friends_GetInvites
Public Member Functions | Public Attributes | List of all members
RakNet::Friends_GetInvites Struct Reference
Lobby2Commands

Returns all invites for this user. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Friends_GetInvites:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | PrevalidateInput (void)
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Public Attributes

DataStructures::List< FriendInfo > | invitesSent
Up to caller to deallocate binaryData if needed.
- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Returns all invites for this user.

Member Function Documentation

virtual bool RakNet::Friends_GetInvites::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Friends_GetInvites::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Friends_GetInvites::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Friends_GetInvites::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Friends_GetFriends Struct Reference

  • Friends_GetFriends
Public Member Functions | List of all members
RakNet::Friends_GetFriends Struct Reference
Lobby2Commands

Gets all friends to this user. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Friends_GetFriends:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | PrevalidateInput (void)
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Gets all friends to this user.

Member Function Documentation

virtual bool RakNet::Friends_GetFriends::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Friends_GetFriends::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Friends_GetFriends::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Friends_GetFriends::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Friends_Remove Struct Reference

  • Friends_Remove
Public Member Functions | List of all members
RakNet::Friends_Remove Struct Reference
Lobby2Commands

Ends a friendship between two users. Remove from the database the friend entry between my handle and their handle. As with accept add friend invite, this is bidirectional. Either user can terminate the friendship. Store in the emails table from my handle to their handle the subject, body, and binary data, and procedure type flag. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Friends_Remove:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Ends a friendship between two users. Remove from the database the friend entry between my handle and their handle. As with accept add friend invite, this is bidirectional. Either user can terminate the friendship. Store in the emails table from my handle to their handle the subject, body, and binary data, and procedure type flag.

Member Function Documentation

virtual bool RakNet::Friends_Remove::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Friends_Remove::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Friends_Remove::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Friends_Remove::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Friends_Remove::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::BookmarkedUsers_Add Struct Reference

  • BookmarkedUsers_Add
Public Member Functions | List of all members
RakNet::BookmarkedUsers_Add Struct Reference
Lobby2Commands

Remembers a user, with a type integer and description for you to use, if desired. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::BookmarkedUsers_Add:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Remembers a user, with a type integer and description for you to use, if desired.

Can be used for recent users or other types of lists The combination of targetHandle and type uniquely identifies a bookmarked user. If you want more than one list of bookmarked usrs, use a different value for type

Member Function Documentation

virtual bool RakNet::BookmarkedUsers_Add::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::BookmarkedUsers_Add::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::BookmarkedUsers_Add::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::BookmarkedUsers_Add::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::BookmarkedUsers_Add::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::BookmarkedUsers_Remove Struct Reference

  • BookmarkedUsers_Remove
Public Member Functions | List of all members
RakNet::BookmarkedUsers_Remove Struct Reference
Lobby2Commands

Remove a user added with BookmarkedUsers_Add. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::BookmarkedUsers_Remove:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Remove a user added with BookmarkedUsers_Add.

Member Function Documentation

virtual bool RakNet::BookmarkedUsers_Remove::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::BookmarkedUsers_Remove::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::BookmarkedUsers_Remove::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::BookmarkedUsers_Remove::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::BookmarkedUsers_Remove::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::BookmarkedUsers_Get Struct Reference

  • BookmarkedUsers_Get
Public Member Functions | Public Attributes | List of all members
RakNet::BookmarkedUsers_Get Struct Reference
Lobby2Commands

Returns all users added to BookmarkedUsers_Add. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::BookmarkedUsers_Get:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | PrevalidateInput (void)
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Public Attributes

DataStructures::List
< BookmarkedUser > 		bookmarkedUsers
- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Returns all users added to BookmarkedUsers_Add.

Member Function Documentation

virtual bool RakNet::BookmarkedUsers_Get::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::BookmarkedUsers_Get::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::BookmarkedUsers_Get::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::BookmarkedUsers_Get::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

Member Data Documentation

DataStructures::List<BookmarkedUser> RakNet::BookmarkedUsers_Get::bookmarkedUsers
Parameters
[out] recentlyMetUsers Handles of recently met users, by BookmarkedUsers_Add, subject to expirationTimeSeconds
The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Emails_Send Struct Reference

  • Emails_Send
Public Member Functions | List of all members
RakNet::Emails_Send Struct Reference
Lobby2Commands

Adds to an emails table from myHandle (store primary key) to recipient handles (store primary key) the specified subject, body, and binary data. Emails are persistent, therefore emails should be stored in a separate table and referenced by the user. Deleting the user does not delete previously send email. Emails should have an automatic timestamp to store when they were created. Email should be flagged as sent=true (boolean), markedRead=true (boolean), deletedBySender=false (boolean), deletedByReciever=false (boolean). More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Emails_Send:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Adds to an emails table from myHandle (store primary key) to recipient handles (store primary key) the specified subject, body, and binary data. Emails are persistent, therefore emails should be stored in a separate table and referenced by the user. Deleting the user does not delete previously send email. Emails should have an automatic timestamp to store when they were created. Email should be flagged as sent=true (boolean), markedRead=true (boolean), deletedBySender=false (boolean), deletedByReciever=false (boolean).

Member Function Documentation

virtual bool RakNet::Emails_Send::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Emails_Send::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Emails_Send::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Emails_Send::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Emails_Send::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Emails_Get Struct Reference

  • Emails_Get
Public Member Functions | Public Attributes | List of all members
RakNet::Emails_Get Struct Reference
Lobby2Commands

Returns emails as noted. Emails which were marked deleted are not returned. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Emails_Get:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | PrevalidateInput (void)
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Public Attributes

DataStructures::List< EmailResult > | emailResults
- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Returns emails as noted. Emails which were marked deleted are not returned.

Member Function Documentation

virtual bool RakNet::Emails_Get::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Emails_Get::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Emails_Get::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Emails_Get::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

Member Data Documentation

DataStructures::List<EmailResult> RakNet::Emails_Get::emailResults
Parameters
[out] emailResults Up to caller to deallocate binary data
The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Emails_Delete Struct Reference

  • Emails_Delete
Public Member Functions | List of all members
RakNet::Emails_Delete Struct Reference
Lobby2Commands

Deletes an email with a specified ID. This ID is returned in GetEmail and should uniquely identify an email (it's fine to use the primary key). Note: Emails are not actually deleted from the database in this function. This just sets the deletedBySender or deletedByReciever flags. Emails are actually stored in a log recording past emails and sender and receiver primary key. They are not truly destroyed until done so with System_PruneAccounts. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Emails_Delete:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | PrevalidateInput (void)
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Deletes an email with a specified ID. This ID is returned in GetEmail and should uniquely identify an email (it's fine to use the primary key). Note: Emails are not actually deleted from the database in this function. This just sets the deletedBySender or deletedByReciever flags. Emails are actually stored in a log recording past emails and sender and receiver primary key. They are not truly destroyed until done so with System_PruneAccounts.

Member Function Documentation

virtual bool RakNet::Emails_Delete::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Emails_Delete::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Emails_Delete::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Emails_Delete::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Emails_SetStatus Struct Reference

  • Emails_SetStatus
Public Member Functions | List of all members
RakNet::Emails_SetStatus Struct Reference
Lobby2Commands

Sets the status flag for an email. This is a property defined by and used by the user. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Emails_SetStatus:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Sets the status flag for an email. This is a property defined by and used by the user.

Member Function Documentation

virtual bool RakNet::Emails_SetStatus::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Emails_SetStatus::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Emails_SetStatus::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Emails_SetStatus::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Emails_SetStatus::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Ranking_SubmitMatch Struct Reference

  • Ranking_SubmitMatch
Public Member Functions | List of all members
RakNet::Ranking_SubmitMatch Struct Reference
Lobby2Commands

Will record in the database the results of a match. This will store in the database the the match which is defined by the the match notes, match id, winner and loser participant primary keys, winner and loser participant scores, and binary data. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Ranking_SubmitMatch:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Will record in the database the results of a match. This will store in the database the the match which is defined by the the match notes, match id, winner and loser participant primary keys, winner and loser participant scores, and binary data.

Member Function Documentation

virtual bool RakNet::Ranking_SubmitMatch::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_SubmitMatch::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Ranking_SubmitMatch::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_SubmitMatch::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_SubmitMatch::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Ranking_GetMatches Struct Reference

  • Ranking_GetMatches
Public Member Functions | Public Attributes | List of all members
RakNet::Ranking_GetMatches Struct Reference
Lobby2Commands

Gets matches recorded with Ranking_SubmitMatch ordered from most recent to least recent. Each returned match has all columns submitted to Ranking_SubmitMatch, except binary data, which can be retrieved with Ranking_GetMatchBinaryData. Additionally, each returned match returns the primary key of each match, to be passed to Ranking_GetMatchBinaryData. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Ranking_GetMatches:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Public Attributes

DataStructures::List
< SubmittedMatch > 		submittedMatches
- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Gets matches recorded with Ranking_SubmitMatch ordered from most recent to least recent. Each returned match has all columns submitted to Ranking_SubmitMatch, except binary data, which can be retrieved with Ranking_GetMatchBinaryData. Additionally, each returned match returns the primary key of each match, to be passed to Ranking_GetMatchBinaryData.

Member Function Documentation

virtual bool RakNet::Ranking_GetMatches::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_GetMatches::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Ranking_GetMatches::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_GetMatches::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_GetMatches::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

Member Data Documentation

DataStructures::List<SubmittedMatch> RakNet::Ranking_GetMatches::submittedMatches
Parameters
[out] submittedMatches (excluding binary data, up to caller to deallocate)
The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Ranking_GetMatchBinaryData Struct Reference

  • Ranking_GetMatchBinaryData
Public Member Functions | List of all members
RakNet::Ranking_GetMatchBinaryData Struct Reference
Lobby2Commands

Because of the large amount of binary data potentially returned, this function is used to retrieve binary data for a particular match. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Ranking_GetMatchBinaryData:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | PrevalidateInput (void)
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Because of the large amount of binary data potentially returned, this function is used to retrieve binary data for a particular match.

Member Function Documentation

virtual bool RakNet::Ranking_GetMatchBinaryData::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_GetMatchBinaryData::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_GetMatchBinaryData::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_GetMatchBinaryData::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Ranking_GetTotalScore Struct Reference

  • Ranking_GetTotalScore
Public Member Functions | List of all members
RakNet::Ranking_GetTotalScore Struct Reference
Lobby2Commands

When a match is submitted with Ranking_SubmitMatch, the total running score and number of matches played for each player for each game title and game mode combination should be recorded. Because matches can be pruned wth PruneMatches(), the total score sum and number of scores submitted should be stored, rather than summed up from prior submitted matches. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Ranking_GetTotalScore:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

When a match is submitted with Ranking_SubmitMatch, the total running score and number of matches played for each player for each game title and game mode combination should be recorded. Because matches can be pruned wth PruneMatches(), the total score sum and number of scores submitted should be stored, rather than summed up from prior submitted matches.

Member Function Documentation

virtual bool RakNet::Ranking_GetTotalScore::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_GetTotalScore::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Ranking_GetTotalScore::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_GetTotalScore::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_GetTotalScore::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Ranking_WipeScoresForPlayer Struct Reference

  • Ranking_WipeScoresForPlayer
Public Member Functions | List of all members
RakNet::Ranking_WipeScoresForPlayer Struct Reference
Lobby2Commands

Resets the sum of all submitted scores to 0, the number of scores submitted to 0. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Ranking_WipeScoresForPlayer:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Resets the sum of all submitted scores to 0, the number of scores submitted to 0.

Member Function Documentation

virtual bool RakNet::Ranking_WipeScoresForPlayer::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_WipeScoresForPlayer::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Ranking_WipeScoresForPlayer::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_WipeScoresForPlayer::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_WipeScoresForPlayer::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Ranking_WipeMatches Struct Reference

  • Ranking_WipeMatches
Public Member Functions | List of all members
RakNet::Ranking_WipeMatches Struct Reference
Lobby2Commands

Deletes all matches submitted with submit match. Also deletes all scores for all players associated with this titleName and gameType (e.g. same thing that WipeScoresForPlayer does, but for all players). More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Ranking_WipeMatches:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Deletes all matches submitted with submit match. Also deletes all scores for all players associated with this titleName and gameType (e.g. same thing that WipeScoresForPlayer does, but for all players).

Member Function Documentation

virtual bool RakNet::Ranking_WipeMatches::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_WipeMatches::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Ranking_WipeMatches::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_WipeMatches::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_WipeMatches::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Ranking_PruneMatches Struct Reference

  • Ranking_PruneMatches
Public Member Functions | List of all members
RakNet::Ranking_PruneMatches Struct Reference
Lobby2Commands

Will delete all matches submitted with SubmitMatch over PruneTime days old. Will also prune matches if the total storage space of all matches exceeds PruneSizeMB megabytes in the database. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Ranking_PruneMatches:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | PrevalidateInput (void)
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Will delete all matches submitted with SubmitMatch over PruneTime days old. Will also prune matches if the total storage space of all matches exceeds PruneSizeMB megabytes in the database.

Member Function Documentation

virtual bool RakNet::Ranking_PruneMatches::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_PruneMatches::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_PruneMatches::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_PruneMatches::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Ranking_UpdateRating Struct Reference

  • Ranking_UpdateRating
Public Member Functions | List of all members
RakNet::Ranking_UpdateRating Struct Reference
Lobby2Commands

Add or update a rating for a user, in a particular game and game mode. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Ranking_UpdateRating:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Add or update a rating for a user, in a particular game and game mode.

Member Function Documentation

virtual bool RakNet::Ranking_UpdateRating::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_UpdateRating::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Ranking_UpdateRating::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_UpdateRating::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_UpdateRating::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Ranking_WipeRatings Struct Reference

  • Ranking_WipeRatings
Public Member Functions | List of all members
RakNet::Ranking_WipeRatings Struct Reference
Lobby2Commands

Deletes all ratings for all players for this combination of titleName and gameType. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Ranking_WipeRatings:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Deletes all ratings for all players for this combination of titleName and gameType.

Member Function Documentation

virtual bool RakNet::Ranking_WipeRatings::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_WipeRatings::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Ranking_WipeRatings::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_WipeRatings::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_WipeRatings::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Ranking_GetRating Struct Reference

  • Ranking_GetRating
Public Member Functions | Public Attributes | List of all members
RakNet::Ranking_GetRating Struct Reference
Lobby2Commands

Get rating for a player. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Ranking_GetRating:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Public Attributes

float | currentRating
- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Get rating for a player.

Member Function Documentation

virtual bool RakNet::Ranking_GetRating::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_GetRating::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Ranking_GetRating::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_GetRating::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Ranking_GetRating::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

Member Data Documentation

float RakNet::Ranking_GetRating::currentRating
Parameters
[out] currentRating Defaults to 100 if no matches submitted yet
The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_Create Struct Reference

  • Clans_Create
Public Member Functions | List of all members
RakNet::Clans_Create Struct Reference
Lobby2Commands

userHandle updates the clanDescription and clanBinaryData of a clan with the specified clanHandle. userHandle must be the clan leader. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_Create:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

userHandle updates the clanDescription and clanBinaryData of a clan with the specified clanHandle. userHandle must be the clan leader.

Member Function Documentation

virtual bool RakNet::Clans_Create::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_Create::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_Create::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_Create::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_Create::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_SetProperties Struct Reference

  • Clans_SetProperties
Public Member Functions | List of all members
RakNet::Clans_SetProperties Struct Reference
Lobby2Commands

userHandle updates the clanDescription and clanBinaryData of a clan with the specified clanHandle. userHandle must be the clan leader. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_SetProperties:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

userHandle updates the clanDescription and clanBinaryData of a clan with the specified clanHandle. userHandle must be the clan leader.

Member Function Documentation

virtual bool RakNet::Clans_SetProperties::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_SetProperties::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_SetProperties::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_SetProperties::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_SetProperties::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_GetProperties Struct Reference

  • Clans_GetProperties
Public Member Functions | List of all members
RakNet::Clans_GetProperties Struct Reference
Lobby2Commands

Returns clanDescription and clanBinaryData for the given clan. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_GetProperties:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Returns clanDescription and clanBinaryData for the given clan.

Member Function Documentation

virtual bool RakNet::Clans_GetProperties::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetProperties::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetProperties::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetProperties::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetProperties::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_SetMyMemberProperties Struct Reference

  • Clans_SetMyMemberProperties
Public Member Functions | List of all members
RakNet::Clans_SetMyMemberProperties Struct Reference
Lobby2Commands

Each member of each clan has the the properties clanMemberDescription and clanMemberBinaryData which default to empty. These properties can be set here, and retrieved via GetClanMemberProperties. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_SetMyMemberProperties:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Each member of each clan has the the properties clanMemberDescription and clanMemberBinaryData which default to empty. These properties can be set here, and retrieved via GetClanMemberProperties.

Member Function Documentation

virtual bool RakNet::Clans_SetMyMemberProperties::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_SetMyMemberProperties::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_SetMyMemberProperties::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_SetMyMemberProperties::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_SetMyMemberProperties::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_GrantLeader Struct Reference

  • Clans_GrantLeader
Public Member Functions | List of all members
RakNet::Clans_GrantLeader Struct Reference
Lobby2Commands

myPrimaryKey becomes a subleader. newLeaderHandle becomes the leader. An email is sent with Emails_Send() to all members with the specified subject and body More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_GrantLeader:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

myPrimaryKey becomes a subleader. newLeaderHandle becomes the leader. An email is sent with Emails_Send() to all members with the specified subject and body

Member Function Documentation

virtual bool RakNet::Clans_GrantLeader::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GrantLeader::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_GrantLeader::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GrantLeader::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GrantLeader::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_SetSubleaderStatus Struct Reference

  • Clans_SetSubleaderStatus
Public Member Functions | List of all members
RakNet::Clans_SetSubleaderStatus Struct Reference
Lobby2Commands

Promotes a clan member to a subleader, or demotes a subleader to a regular member. On promotion, email is sent to all members from myPrimary key with the specified subject and body. On demotion, email is sent to all leaders from myPrimary key with the specified subject and body. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_SetSubleaderStatus:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Promotes a clan member to a subleader, or demotes a subleader to a regular member. On promotion, email is sent to all members from myPrimary key with the specified subject and body. On demotion, email is sent to all leaders from myPrimary key with the specified subject and body.

Member Function Documentation

virtual bool RakNet::Clans_SetSubleaderStatus::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_SetSubleaderStatus::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_SetSubleaderStatus::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_SetSubleaderStatus::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_SetSubleaderStatus::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_SetMemberRank Struct Reference

  • Clans_SetMemberRank
Public Member Functions | List of all members
RakNet::Clans_SetMemberRank Struct Reference
Lobby2Commands

Lets the clan leader set the rank property for a clan member. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_SetMemberRank:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Lets the clan leader set the rank property for a clan member.

Member Function Documentation

virtual bool RakNet::Clans_SetMemberRank::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_SetMemberRank::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_SetMemberRank::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_SetMemberRank::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_SetMemberRank::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_GetMemberProperties Struct Reference

  • Clans_GetMemberProperties
Public Member Functions | List of all members
RakNet::Clans_GetMemberProperties Struct Reference
Lobby2Commands

Returns properties for a clan member of a given clan. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_GetMemberProperties:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Returns properties for a clan member of a given clan.

Member Function Documentation

virtual bool RakNet::Clans_GetMemberProperties::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetMemberProperties::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetMemberProperties::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetMemberProperties::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetMemberProperties::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_ChangeHandle Struct Reference

  • Clans_ChangeHandle
Public Member Functions | List of all members
RakNet::Clans_ChangeHandle Struct Reference
Lobby2Commands

Renames the clan. Note that this may be called asynchronously, in which case the stored procedure should account for this occuring at the same time as another function that uses the old clan handle. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_ChangeHandle:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Renames the clan. Note that this may be called asynchronously, in which case the stored procedure should account for this occuring at the same time as another function that uses the old clan handle.

Member Function Documentation

virtual bool RakNet::Clans_ChangeHandle::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_ChangeHandle::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_ChangeHandle::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_ChangeHandle::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_ChangeHandle::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_Leave Struct Reference

  • Clans_Leave
Public Member Functions | List of all members
RakNet::Clans_Leave Struct Reference
Lobby2Commands

Remove user identified by myPrimaryKey from clan identified by clanHandle. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_Leave:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Remove user identified by myPrimaryKey from clan identified by clanHandle.

If this user is the leader of the clan, and dissolveIfClanLeader is true, then also destroy the clan and remove all members from the clan, as well as all data associated with the clan (clan boards, join requests, etc). If the clan is automatically destroyed in this way, use Emails_Send() to each clan member with clanDissolvedSubject and clanDissolvedBody. The sender of the email should be the clan leader. If the clan is not destroyed, then leadership passes to the oldest subleader. If no subleaders exist, leadership passes to the oldest member. If no other members exist, the clan is destroyed.

Member Function Documentation

virtual bool RakNet::Clans_Leave::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_Leave::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_Leave::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_Leave::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_Leave::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_Get Struct Reference

  • Clans_Get
Public Member Functions | List of all members
RakNet::Clans_Get Struct Reference
Lobby2Commands

Returns all clans that userHandle is a member of. Clans and clan members should be sorted by name, using ascending or descending sort as specified. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_Get:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | PrevalidateInput (void)
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Returns all clans that userHandle is a member of. Clans and clan members should be sorted by name, using ascending or descending sort as specified.

Member Function Documentation

virtual bool RakNet::Clans_Get::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_Get::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_Get::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_Get::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_SendJoinInvitation Struct Reference

  • Clans_SendJoinInvitation
Public Member Functions | List of all members
RakNet::Clans_SendJoinInvitation Struct Reference
Lobby2Commands

if myPrimaryKey is a leader or subleader of clanHandle, and invitedUserHandle is a valid user not already invited to this clan, add this user to the invite table. The invite table contains the clan, who send the invite, and who the invite was sent to, and when it was sent. Invites expire after expiration time in seconds. Also, use Emails_Send() to send an email from myPrimaryKey to invitedUserHandle with the specified subject and body. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_SendJoinInvitation:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

if myPrimaryKey is a leader or subleader of clanHandle, and invitedUserHandle is a valid user not already invited to this clan, add this user to the invite table. The invite table contains the clan, who send the invite, and who the invite was sent to, and when it was sent. Invites expire after expiration time in seconds. Also, use Emails_Send() to send an email from myPrimaryKey to invitedUserHandle with the specified subject and body.

Member Function Documentation

virtual bool RakNet::Clans_SendJoinInvitation::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_SendJoinInvitation::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_SendJoinInvitation::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_SendJoinInvitation::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_SendJoinInvitation::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_WithdrawJoinInvitation Struct Reference

  • Clans_WithdrawJoinInvitation
Public Member Functions | List of all members
RakNet::Clans_WithdrawJoinInvitation Struct Reference
Lobby2Commands

if myPrimaryKey is a leader or subleader of clanHandle, and invitedUserHandle is a valid user with an invite to this clan, remove this invite. Also, use Emails_Send() to send an email from myPrimaryKey to invitedUserHandle with the specified subject and body. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_WithdrawJoinInvitation:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

if myPrimaryKey is a leader or subleader of clanHandle, and invitedUserHandle is a valid user with an invite to this clan, remove this invite. Also, use Emails_Send() to send an email from myPrimaryKey to invitedUserHandle with the specified subject and body.

Member Function Documentation

virtual bool RakNet::Clans_WithdrawJoinInvitation::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_WithdrawJoinInvitation::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_WithdrawJoinInvitation::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_WithdrawJoinInvitation::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_WithdrawJoinInvitation::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_AcceptJoinInvitation Struct Reference

  • Clans_AcceptJoinInvitation
Public Member Functions | List of all members
RakNet::Clans_AcceptJoinInvitation Struct Reference
Lobby2Commands

If myPrimaryKey has an invitation to the specified clan, add him to the clan. Fail on specified output parameters. Use Emails_Send() to send an email from myPrimaryKey to all clan members with the specified subject and body. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_AcceptJoinInvitation:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

If myPrimaryKey has an invitation to the specified clan, add him to the clan. Fail on specified output parameters. Use Emails_Send() to send an email from myPrimaryKey to all clan members with the specified subject and body.

Member Function Documentation

virtual bool RakNet::Clans_AcceptJoinInvitation::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_AcceptJoinInvitation::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_AcceptJoinInvitation::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_AcceptJoinInvitation::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_AcceptJoinInvitation::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_RejectJoinInvitation Struct Reference

  • Clans_RejectJoinInvitation
Public Member Functions | List of all members
RakNet::Clans_RejectJoinInvitation Struct Reference
Lobby2Commands

If we have an open clan invitation, reject it (just delete it from the database). More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_RejectJoinInvitation:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

If we have an open clan invitation, reject it (just delete it from the database).

Member Function Documentation

virtual bool RakNet::Clans_RejectJoinInvitation::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_RejectJoinInvitation::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_RejectJoinInvitation::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_RejectJoinInvitation::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_RejectJoinInvitation::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_DownloadInvitationList Struct Reference

  • Clans_DownloadInvitationList
Public Member Functions | List of all members
RakNet::Clans_DownloadInvitationList Struct Reference
Lobby2Commands

Returns all invites sent by Clans_SendJoinInvitation that were not yet acted upon (withdrawn, accepted, rejected). More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_DownloadInvitationList:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | PrevalidateInput (void)
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Returns all invites sent by Clans_SendJoinInvitation that were not yet acted upon (withdrawn, accepted, rejected).

Member Function Documentation

virtual bool RakNet::Clans_DownloadInvitationList::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_DownloadInvitationList::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_DownloadInvitationList::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_DownloadInvitationList::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_SendJoinRequest Struct Reference

  • Clans_SendJoinRequest
Public Member Functions | List of all members
RakNet::Clans_SendJoinRequest Struct Reference
Lobby2Commands

Function has two forms: More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_SendJoinRequest:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Function has two forms:

If requiresInvitationsToJoin==true when CreateClan() was called, will join the specified clan immediately. Sends subject and body to all other members in the clan. If requiresInvitationsToJoin==false when CreateClan() was called, send a join request to the specified clan, if we don't have one already. Join request expires after expiration time in seconds. Also, use Emails_Send() to send an email from myPrimaryKey to the clan leader and all subleaders with the specified subject and body.

Member Function Documentation

virtual bool RakNet::Clans_SendJoinRequest::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_SendJoinRequest::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_SendJoinRequest::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_SendJoinRequest::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_SendJoinRequest::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_WithdrawJoinRequest Struct Reference

  • Clans_WithdrawJoinRequest
Public Member Functions | List of all members
RakNet::Clans_WithdrawJoinRequest Struct Reference
Lobby2Commands

Withdraws a previously sent clan join request via SendClanJoinRequest. Use Emails_Send() to send an email from myPrimaryKey to the clan leader and all subleaders with the specified subject and body. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_WithdrawJoinRequest:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Withdraws a previously sent clan join request via SendClanJoinRequest. Use Emails_Send() to send an email from myPrimaryKey to the clan leader and all subleaders with the specified subject and body.

Member Function Documentation

virtual bool RakNet::Clans_WithdrawJoinRequest::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_WithdrawJoinRequest::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_WithdrawJoinRequest::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_WithdrawJoinRequest::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_WithdrawJoinRequest::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_AcceptJoinRequest Struct Reference

  • Clans_AcceptJoinRequest
Public Member Functions | List of all members
RakNet::Clans_AcceptJoinRequest Struct Reference
Lobby2Commands

A clan leader or subleader accepts a join request from requestingUserHandle to this clan. requestingUserHandle joins the clan as a regular member. Use Emails_Send() to send an email from requestingUserHandle to all clan members with the specified subject and body. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_AcceptJoinRequest:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

A clan leader or subleader accepts a join request from requestingUserHandle to this clan. requestingUserHandle joins the clan as a regular member. Use Emails_Send() to send an email from requestingUserHandle to all clan members with the specified subject and body.

Member Function Documentation

virtual bool RakNet::Clans_AcceptJoinRequest::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_AcceptJoinRequest::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_AcceptJoinRequest::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_AcceptJoinRequest::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_AcceptJoinRequest::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_DownloadRequestList Struct Reference

  • Clans_DownloadRequestList
Public Member Functions | List of all members
RakNet::Clans_DownloadRequestList Struct Reference
Lobby2Commands

Returns all open requests this user has sent to clans, that have not yet acted upon (withdrawn, accepted, rejected, expired). More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_DownloadRequestList:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | PrevalidateInput (void)
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Returns all open requests this user has sent to clans, that have not yet acted upon (withdrawn, accepted, rejected, expired).

Member Function Documentation

virtual bool RakNet::Clans_DownloadRequestList::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_DownloadRequestList::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_DownloadRequestList::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_DownloadRequestList::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_KickAndBlacklistUser Struct Reference

  • Clans_KickAndBlacklistUser
Public Member Functions | List of all members
RakNet::Clans_KickAndBlacklistUser Struct Reference
Lobby2Commands

Kicks a user from the clan and/or blacklists a user so they cannot join. Only a clan leader or subleader can perform this operation. The operation can only be performed on members of lower status (leader can perform on subleader or regular member or nonmember, subleader on regular members or nonmember). If a member is banned, they are added to the banned table which contains the member's primary key, which user banned them, and the reason. Email is sent from myPrimaryKey to all leaders if a clan member is banned. Emails is furthermore sent to all clan members if successfully kicked. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_KickAndBlacklistUser:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Kicks a user from the clan and/or blacklists a user so they cannot join. Only a clan leader or subleader can perform this operation. The operation can only be performed on members of lower status (leader can perform on subleader or regular member or nonmember, subleader on regular members or nonmember). If a member is banned, they are added to the banned table which contains the member's primary key, which user banned them, and the reason. Email is sent from myPrimaryKey to all leaders if a clan member is banned. Emails is furthermore sent to all clan members if successfully kicked.

Member Function Documentation

virtual bool RakNet::Clans_KickAndBlacklistUser::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_KickAndBlacklistUser::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_KickAndBlacklistUser::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_KickAndBlacklistUser::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_KickAndBlacklistUser::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_UnblacklistUser Struct Reference

  • Clans_UnblacklistUser
Public Member Functions | List of all members
RakNet::Clans_UnblacklistUser Struct Reference
Lobby2Commands

Removes a user from the blacklist for this clan. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_UnblacklistUser:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Removes a user from the blacklist for this clan.

Member Function Documentation

virtual bool RakNet::Clans_UnblacklistUser::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_UnblacklistUser::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_UnblacklistUser::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_UnblacklistUser::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_UnblacklistUser::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_GetBlacklist Struct Reference

  • Clans_GetBlacklist
Public Member Functions | List of all members
RakNet::Clans_GetBlacklist Struct Reference
Lobby2Commands

Returns a list of all members blacklisted from this clan. Each element in the list contains the handle of the user that did the ban, who was banned, when the user was banned, and the reason passed to ClanKickAndBlacklistUser. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_GetBlacklist:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Returns a list of all members blacklisted from this clan. Each element in the list contains the handle of the user that did the ban, who was banned, when the user was banned, and the reason passed to ClanKickAndBlacklistUser.

Member Function Documentation

virtual bool RakNet::Clans_GetBlacklist::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetBlacklist::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetBlacklist::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetBlacklist::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetBlacklist::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_GetMembers Struct Reference

  • Clans_GetMembers
Public Member Functions | List of all members
RakNet::Clans_GetMembers Struct Reference
Lobby2Commands

Returns all clan members for this clan. Each entry returned contains handle, description, binary data, status (leader, regular member, subleader). More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_GetMembers:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Returns all clan members for this clan. Each entry returned contains handle, description, binary data, status (leader, regular member, subleader).

Member Function Documentation

virtual bool RakNet::Clans_GetMembers::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetMembers::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetMembers::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetMembers::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetMembers::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_GetList Struct Reference

  • Clans_GetList
Public Member Functions | List of all members
RakNet::Clans_GetList Struct Reference
Lobby2Commands

Returns all clans names. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_GetList:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | PrevalidateInput (void)
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Returns all clans names.

Member Function Documentation

virtual bool RakNet::Clans_GetList::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetList::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetList::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetList::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_CreateBoard Struct Reference

  • Clans_CreateBoard
Public Member Functions | List of all members
RakNet::Clans_CreateBoard Struct Reference
Lobby2Commands

Creates a new clan board for clan members to post in using AddPostToClanBoard. Clan boards are unique, and are destroyed when the clan is destroyed, or if DestroyClanBoard is called. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_CreateBoard:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Creates a new clan board for clan members to post in using AddPostToClanBoard. Clan boards are unique, and are destroyed when the clan is destroyed, or if DestroyClanBoard is called.

Member Function Documentation

virtual bool RakNet::Clans_CreateBoard::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_CreateBoard::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_CreateBoard::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_CreateBoard::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_CreateBoard::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_DestroyBoard Struct Reference

  • Clans_DestroyBoard
Public Member Functions | List of all members
RakNet::Clans_DestroyBoard Struct Reference
Lobby2Commands

Success, invalid parameter syntax, myPrimaryKey is not the leader or subleader of clanHandle, unknown myPrimaryKey, unknown clanHandle, unknown clanBoardName. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_DestroyBoard:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Success, invalid parameter syntax, myPrimaryKey is not the leader or subleader of clanHandle, unknown myPrimaryKey, unknown clanHandle, unknown clanBoardName.

Member Function Documentation

virtual bool RakNet::Clans_DestroyBoard::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_DestroyBoard::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_DestroyBoard::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_DestroyBoard::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_DestroyBoard::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_CreateNewTopic Struct Reference

  • Clans_CreateNewTopic
Public Member Functions | List of all members
RakNet::Clans_CreateNewTopic Struct Reference
Lobby2Commands

Each clan has a clan board that only clan members can post to. This adds a topic to the clan board. Posts should reference the primary key of the poster, so that even if the poster chagnes his or her handle, the post author is updated properly. Each post automatically stores the timestamp when it was created. Banned users may not add new posts to the clan board. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_CreateNewTopic:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Each clan has a clan board that only clan members can post to. This adds a topic to the clan board. Posts should reference the primary key of the poster, so that even if the poster chagnes his or her handle, the post author is updated properly. Each post automatically stores the timestamp when it was created. Banned users may not add new posts to the clan board.

Member Function Documentation

virtual bool RakNet::Clans_CreateNewTopic::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_CreateNewTopic::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_CreateNewTopic::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_CreateNewTopic::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_CreateNewTopic::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_ReplyToTopic Struct Reference

  • Clans_ReplyToTopic
Public Member Functions | List of all members
RakNet::Clans_ReplyToTopic Struct Reference
Lobby2Commands

Replies to a topic created with Clans_CreateTopic(). If postId references a post within a topic, just add the reply to the last post. Banned users may not add new posts to the clan board. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_ReplyToTopic:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Replies to a topic created with Clans_CreateTopic(). If postId references a post within a topic, just add the reply to the last post. Banned users may not add new posts to the clan board.

Member Function Documentation

virtual bool RakNet::Clans_ReplyToTopic::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_ReplyToTopic::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_ReplyToTopic::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_ReplyToTopic::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_ReplyToTopic::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_RemovePost Struct Reference

  • Clans_RemovePost
Public Member Functions | List of all members
RakNet::Clans_RemovePost Struct Reference
Lobby2Commands

The clan leader or subleaders may remove posts or topics from a clan board. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_RemovePost:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | PrevalidateInput (void)
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

The clan leader or subleaders may remove posts or topics from a clan board.

Member Function Documentation

virtual bool RakNet::Clans_RemovePost::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_RemovePost::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_RemovePost::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_RemovePost::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_GetBoards Struct Reference

  • Clans_GetBoards
Public Member Functions | List of all members
RakNet::Clans_GetBoards Struct Reference
Lobby2Commands

Gets clan boards created for clanHandle. Boards are returned if we are a clan member, or if allowPublicReads in Clans_CreateBoard() was passed as false. However, if we are banned from this clan, no boards are returned. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_GetBoards:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Gets clan boards created for clanHandle. Boards are returned if we are a clan member, or if allowPublicReads in Clans_CreateBoard() was passed as false. However, if we are banned from this clan, no boards are returned.

Member Function Documentation

virtual bool RakNet::Clans_GetBoards::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetBoards::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetBoards::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetBoards::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetBoards::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_GetTopics Struct Reference

  • Clans_GetTopics
Public Member Functions | List of all members
RakNet::Clans_GetTopics Struct Reference
Lobby2Commands

Gets topics (posts that are not replies to other posts, created with Clans_CreateTopic()) for the specified clanHandle and clanBoardName. If we are not a clan member and the clan was created with allowPublicReads==false, then the user is not allowed to read topics. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_GetTopics:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Gets topics (posts that are not replies to other posts, created with Clans_CreateTopic()) for the specified clanHandle and clanBoardName. If we are not a clan member and the clan was created with allowPublicReads==false, then the user is not allowed to read topics.

Member Function Documentation

virtual bool RakNet::Clans_GetTopics::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetTopics::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetTopics::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetTopics::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetTopics::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_GetPosts Struct Reference

  • Clans_GetPosts
Public Member Functions | List of all members
RakNet::Clans_GetPosts Struct Reference
Lobby2Commands

Gets all posts for a particular topic. If postId is not a topic but is instead a post in a topic, treat it as if the topic postId was passed. If we are not a clan member and the clan was created with allowPublicReads==false, then the user is not allowed to read topics. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_GetPosts:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Gets all posts for a particular topic. If postId is not a topic but is instead a post in a topic, treat it as if the topic postId was passed. If we are not a clan member and the clan was created with allowPublicReads==false, then the user is not allowed to read topics.

Member Function Documentation

virtual bool RakNet::Clans_GetPosts::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetPosts::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetPosts::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetPosts::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_GetPosts::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Lobby2Notifications

Lobby2Notifications
Lobby2Plugin

Callbacks that the Lobby2System will send to you. More...

Detailed Description

Callbacks that the Lobby2System will send to you.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Lobby2Server

Classes
Lobby2Server
Lobby2Plugin

Runs the server modules that asynchronously processes Lobby2Message. More...

Classes

class | RakNet::Lobby2Server
The base class for the lobby server, without database specific functionality. More...
struct | RakNet::Lobby2Server::ConfigurationProperties
Server configuration properties, to customize how the server runs specific commands. More...

Detailed Description

Runs the server modules that asynchronously processes Lobby2Message.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::Lobby2Server Class Reference

  • Lobby2Server
Classes | Public Member Functions | Protected Member Functions | List of all members
RakNet::Lobby2Server Class Referenceabstract
Lobby2Server

The base class for the lobby server, without database specific functionality. More...

#include <Lobby2Server.h>

Inheritance diagram for RakNet::Lobby2Server:
RakNet::Lobby2Plugin RakNet::PluginInterface2 RakNet::Lobby2Server_PGSQL

Classes

struct ConfigurationProperties
Server configuration properties, to customize how the server runs specific commands. More...

Public Member Functions

virtual bool | ConnectToDB (const char *conninfo, int numWorkerThreads)=0
Connect to the database numWorkerThreads times using the connection string.
void | SendMsg (Lobby2Message *msg, const DataStructures::List< SystemAddress > &recipients)
Lobby2Message encapsulates a user command, containing both input and output data.
void | ExecuteCommand (Lobby2ServerCommand *command)
Add a command, which contains a message and other data such as who send the message.
void | AddAdminAddress (SystemAddress addr)
If Lobby2Message::RequiresAdmin() returns true, the message can only be processed from a remote system if the sender's system address is first added()
bool | HasAdminAddress (const DataStructures::List< SystemAddress > &addresses)
If AddAdminAddress() was previously called with addr then this returns true.
void | RemoveAdminAddress (SystemAddress addr)
Removes a system address previously added with AddAdminAddress()
void | ClearAdminAddresses (void)
Removes all system addresses previously added with AddAdminAddress()
void | AddRankingAddress (SystemAddress addr)
If Lobby2Message::RequiresRankingPermission() returns true, then the system that sent the command must be registered with AddRankingAddress()
bool | HasRankingAddress (const DataStructures::List< SystemAddress > &addresses)
void | RemoveRankingAddress (SystemAddress addr)
void | ClearRankingAddresses (void)
Clears all addresses added with AddRankingAddress()
void | SetRoomsPlugin (RoomsPlugin *rp)
To use RoomsPlugin and Lobby2Server together, register RoomsPlugin with this funcrtion.
void | SetRoomsPluginAddress (SystemAddress address)
This is similar to SetRoomsPlugin(), except the plugin is on another system.
void | SetConfigurationProperties (ConfigurationProperties c)
Set the desired configuration properties. This is read during runtime from threads.
const ConfigurationProperties * | GetConfigurationProperties (void) const
Get the previously set configuration properties.
void | SetPresence (const RakNet::Lobby2Presence &presence, RakNet::RakString userHandle)
void | GetPresence (RakNet::Lobby2Presence &presence, RakNet::RakString userHandle)
- Public Member Functions inherited from RakNet::Lobby2Plugin
void | SetOrderingChannel (char oc)
Ordering channel to send messages on.
void | SetSendPriority (PacketPriority pp)
Send priority to send messages on.
void | SetMessageFactory (Lobby2MessageFactory *f)
Creates messages from message IDs.
Lobby2MessageFactory * | GetMessageFactory (void) const
Returns whatever was passed to SetMessageFactory()
virtual void | SetCallbackInterface (Lobby2Callbacks *cb)
Set the callback to receive the results of operations via SendMsg()
virtual void | AddCallbackInterface (Lobby2Callbacks *cb)
You can have more than one callback to get called from the results of operations via SendMsg()
virtual void | RemoveCallbackInterface (Lobby2Callbacks *cb)
Removes a callback added with AddCallbackInterface();.
virtual void | ClearCallbackInterfaces ()
Removes all callbacks added with AddCallbackInterface();.
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Protected Member Functions

void | Update (void)
Update is called every time a packet is checked for .
PluginReceiveResult | OnReceive (Packet *packet)
void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)

Detailed Description

The base class for the lobby server, without database specific functionality.

This is a plugin which will take incoming messages via Lobby2Client_PC::SendMsg(), process them, and send back the same messages with output and a result code Unlike the first implementation of the lobby server, this is a thin plugin that mostly just sends messages to threads and sends back the results.

Member Function Documentation

void RakNet::Lobby2Server::AddAdminAddress ( SystemAddress addr )

If Lobby2Message::RequiresAdmin() returns true, the message can only be processed from a remote system if the sender's system address is first added()

This is useful if you want to administrate the server remotely

void RakNet::Lobby2Server::AddRankingAddress ( SystemAddress addr )

If Lobby2Message::RequiresRankingPermission() returns true, then the system that sent the command must be registered with AddRankingAddress()

Parameters
[in] addr Address to allow
virtual bool RakNet::Lobby2Server::ConnectToDB | ( | const char * | conninfo,
 |  | int | numWorkerThreads
 | ) |  |
pure virtual

Connect to the database numWorkerThreads times using the connection string.

Parameters
[in] conninfo See the postgre docs
Returns
True on success, false on failure.

Implemented in RakNet::Lobby2Server_PGSQL.

void RakNet::Lobby2Server::ExecuteCommand ( Lobby2ServerCommand * command )

Add a command, which contains a message and other data such as who send the message.

The command will be processed according to its implemented virtual functions. Most likely it will be processed in a thread to run database commands

void RakNet::Lobby2Server::GetPresence | ( | RakNet::Lobby2Presence & | presence,
 |  | RakNet::RakString | userHandle
 | ) |  |

Get the presence of a logged in user, by handle

Parameters
[out] | presence | Presence info of requested user
[in] | userHandle | Handle of the user
bool RakNet::Lobby2Server::HasRankingAddress ( const DataStructures::List< SystemAddress > & addresses )

Returns if an address was previously added with AddRankingAddress()

Parameters
[in] addr Address to check
void RakNet::Lobby2Server::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
protectedvirtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

PluginReceiveResult RakNet::Lobby2Server::OnReceive ( Packet * packet )
protectedvirtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

void RakNet::Lobby2Server::RemoveRankingAddress ( SystemAddress addr )

Removes an addressed added with AddRankingAddress()

Parameters
[in] addr Address to check
void RakNet::Lobby2Server::SendMsg | ( | Lobby2Message * | msg,
 |  | const DataStructures::List< SystemAddress > & | recipients
 | ) |  |

Lobby2Message encapsulates a user command, containing both input and output data.

This will serialize and transmit that command

void RakNet::Lobby2Server::SetPresence | ( | const RakNet::Lobby2Presence & | presence,
 |  | RakNet::RakString | userHandle
 | ) |  |

Set the presence of a logged in user

Parameters
[in] presence Presence info of this user
void RakNet::Lobby2Server::SetRoomsPlugin ( RoomsPlugin * rp )

To use RoomsPlugin and Lobby2Server together, register RoomsPlugin with this funcrtion.

The rooms plugin does not automatically handle users logging in and logging off, or renaming users. You can have Lobby2Server manage this for you by calling SetRoomsPlugin() with a pointer to the rooms plugin, if it is on the local system. This will call RoomsPlugin::LoginRoomsParticipant() and RoomsPlugin::LogoffRoomsParticipant() as the messages L2MID_Client_Login and L2MID_Client_Logoff arrive This will use the pointer to RoomsPlugin directly. Setting this will disable SetRoomsPluginAddress()

Note
This is an empty function. You must #define __INTEGRATE_LOBBY2_WITH_ROOMS_PLUGIN and link with RoomsPlugin.h to use it()
void RakNet::Lobby2Server::SetRoomsPluginAddress ( SystemAddress address )

This is similar to SetRoomsPlugin(), except the plugin is on another system.

This will set the system address of that system to send the login and logoff commands to. For this function to work, you must first call RoomsPlugin::AddLoginServerAddress() so that RoomsPlugin will accept the incoming login and logoff messages.

Note
This is an empty function. You must #define __INTEGRATE_LOBBY2_WITH_ROOMS_PLUGIN and link with RoomsPlugin.h to use it()
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Server.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Lobby2Server::ConfigurationProperties Struct Reference

  • Lobby2Server
  • ConfigurationProperties
Public Attributes | List of all members
RakNet::Lobby2Server::ConfigurationProperties Struct Reference
Lobby2Server

Server configuration properties, to customize how the server runs specific commands. More...

#include <Lobby2Server.h>

Public Attributes

bool | requiresEmailAddressValidationToLogin
If true, Client_Login will fail with Client_Login_EMAIL_ADDRESS_NOT_VALIDATED unless the email address registered with Client_RegisterAccount is verified with the command System_SetEmailAddressValidated.
bool | requiresTitleToLogin
If true Client_Login::titleName and Client_Login::titleSecretKey must be previously registered with System_CreateTitle or Client_Login will fail with L2RC_Client_Login_BAD_TITLE_OR_TITLE_SECRET_KEY.
bool | accountRegistrationRequiresCDKey
If true, Client_RegisterAccount::cdKey must be previously registered with CDKey_Add or Client_RegisterAccount will fail with L2RC_Client_RegisterAccount_REQUIRES_CD_KEY or a related error message.
unsigned int | accountRegistrationRequiredAgeYears
The minimum age needed to register accounts. If Client_RegisterAccount::createAccountParameters::ageInDays is less than this, then the account registration will fail with L2RC_Client_RegisterAccount_REQUIRED_AGE_NOT_MET.

Detailed Description

Server configuration properties, to customize how the server runs specific commands.

Member Data Documentation

unsigned int RakNet::Lobby2Server::ConfigurationProperties::accountRegistrationRequiredAgeYears

The minimum age needed to register accounts. If Client_RegisterAccount::createAccountParameters::ageInDays is less than this, then the account registration will fail with L2RC_Client_RegisterAccount_REQUIRED_AGE_NOT_MET.

Per-title age requirements can be handled client-side with System_CreateTitle::requiredAge and System_GetTitleRequiredAge

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Server.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Lobby2Client

Classes
Lobby2Client
Lobby2Plugin

Sends commands to Lobby2Server. More...

Classes

class RakNet::Lobby2Client
Class used to send commands to Lobby2Server. More...

Detailed Description

Sends commands to Lobby2Server.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::Lobby2Client Class Reference

  • Lobby2Client
Public Member Functions | Protected Member Functions | List of all members
RakNet::Lobby2Client Class Reference
Lobby2Client

Class used to send commands to Lobby2Server. More...

#include <Lobby2Client.h>

Inheritance diagram for RakNet::Lobby2Client:
RakNet::Lobby2Plugin RakNet::PluginInterface2

Public Member Functions

void | SetServerAddress (SystemAddress addr)
Set the address of the server. When you call SendMsg() the packet will be sent to this address.
virtual void | SendMsg (Lobby2Message *msg)
Send a command to the server.
virtual void | SendMsgAndDealloc (Lobby2Message *msg)
Same as SendMsg() Also calls Dealloc on the message factory.
- Public Member Functions inherited from RakNet::Lobby2Plugin
void | SetOrderingChannel (char oc)
Ordering channel to send messages on.
void | SetSendPriority (PacketPriority pp)
Send priority to send messages on.
void | SetMessageFactory (Lobby2MessageFactory *f)
Creates messages from message IDs.
Lobby2MessageFactory * | GetMessageFactory (void) const
Returns whatever was passed to SetMessageFactory()
virtual void | SetCallbackInterface (Lobby2Callbacks *cb)
Set the callback to receive the results of operations via SendMsg()
virtual void | AddCallbackInterface (Lobby2Callbacks *cb)
You can have more than one callback to get called from the results of operations via SendMsg()
virtual void | RemoveCallbackInterface (Lobby2Callbacks *cb)
Removes a callback added with AddCallbackInterface();.
virtual void | ClearCallbackInterfaces ()
Removes all callbacks added with AddCallbackInterface();.
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Protected Member Functions

PluginReceiveResult | OnReceive (Packet *packet)
void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)

Detailed Description

Class used to send commands to Lobby2Server.

The lobby system works by sending implementations of Lobby2Message from Lobby2Client to Lobby2Server, and getting the results via Lobby2Client::SetCallbackInterface()
The client itself is a thin shell that does little more than call Serialize on the messages.
To use:

  1. Call Lobby2Client::SetServerAddress() after connecting to the system running Lobby2Server.
  2. Instantiate an instance of RakNet::Lobby2MessageFactory and register it with RakNet::Lobby2Plugin::SetMessageFactory() (the base class of Lobby2Client)
  3. Call messageFactory.Alloc(command); where command is one of the Lobby2MessageID enumerations.
  4. Instantiate a (probably derived) instance of Lobby2Callbacks and register it with Lobby2Client::SetCallbackInterface()
  5. Cast the returned structure, fill in the input parameters, and call Lobby2Client::SendMsg() to send this command to the server.
  6. Wait for the result of the operation to be sent to your callback. The message will contain the original input parameters, possibly output parameters, and Lobby2Message::resultCode will be filled in.

Member Function Documentation

void RakNet::Lobby2Client::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
protectedvirtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

PluginReceiveResult RakNet::Lobby2Client::OnReceive ( Packet * packet )
protectedvirtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

virtual void RakNet::Lobby2Client::SendMsg ( Lobby2Message * msg )
virtual

Send a command to the server.

Parameters
[in] | msg | The message that represents the command
[in] | callbackId | Which callback, registered with SetCallbackInterface() or AddCallbackInterface(), should process the result. -1 for all
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Client.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Lobby2Callbacks Struct Reference

  • Lobby2Callbacks
List of all members
RakNet::Lobby2Callbacks Struct Reference
Lobby2Plugin

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Lobby2Callbacks:
RakNet::Lobby2Printf

Detailed Description

Every Lobby2Message processed with Lobby2Client::SendMsg() while connected will call the callback registered with Lobby2Client::SetCallbackInterface().

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Lobby2Printf Struct Reference

  • Lobby2Printf
List of all members
RakNet::Lobby2Printf Struct Reference
Lobby2Plugin

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Lobby2Printf:
RakNet::Lobby2Callbacks

Detailed Description

Just print out the name of the message by default. This class is used in the sample.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Lobby2Plugin Class Reference

  • Lobby2Plugin
Public Member Functions | List of all members
RakNet::Lobby2Plugin Class Reference
Lobby2Plugin

Both Lobby2Server and Lobby2Client derive from this class. More...

#include <Lobby2Plugin.h>

Inheritance diagram for RakNet::Lobby2Plugin:
RakNet::PluginInterface2 RakNet::Lobby2Client RakNet::Lobby2Server RakNet::Lobby2Server_PGSQL

Public Member Functions

void | SetOrderingChannel (char oc)
Ordering channel to send messages on.
void | SetSendPriority (PacketPriority pp)
Send priority to send messages on.
void | SetMessageFactory (Lobby2MessageFactory *f)
Creates messages from message IDs.
Lobby2MessageFactory * | GetMessageFactory (void) const
Returns whatever was passed to SetMessageFactory()
virtual void | SetCallbackInterface (Lobby2Callbacks *cb)
Set the callback to receive the results of operations via SendMsg()
virtual void | AddCallbackInterface (Lobby2Callbacks *cb)
You can have more than one callback to get called from the results of operations via SendMsg()
virtual void | RemoveCallbackInterface (Lobby2Callbacks *cb)
Removes a callback added with AddCallbackInterface();.
virtual void | ClearCallbackInterfaces ()
Removes all callbacks added with AddCallbackInterface();.
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Detailed Description

Both Lobby2Server and Lobby2Client derive from this class.

Member Function Documentation

void RakNet::Lobby2Plugin::SetMessageFactory ( Lobby2MessageFactory * f )

Creates messages from message IDs.

Server should get a factory that creates messages with database functionality.
Client can use the base class

Parameters
[in] f Class factory instance, which should remain valid for the scope of the plugin
void RakNet::Lobby2Plugin::SetOrderingChannel ( char oc )

Ordering channel to send messages on.

Parameters
[in] oc The ordering channel
void RakNet::Lobby2Plugin::SetSendPriority ( PacketPriority pp )

Send priority to send messages on.

Parameters
[in] pp The packet priority
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Plugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RoomsPlugin

Modules | Classes
RoomsPlugin
Plugins

Networked implementation of a rooms system, where members join and leave rooms. More...

Modules

RoomsCommands
Commands that can be sent to RoomsPlugin.
RoomsNotifications
Notifications that RoomsPlugin sends to you.

Classes

struct | RakNet::RoomsPluginNotification
Base class for notification callbacks. More...
class | RakNet::RoomsPlugin
Used to create rooms for players where they can matchmake. More...

Detailed Description

Networked implementation of a rooms system, where members join and leave rooms.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RoomsCommands

Classes
RoomsCommands
RoomsPlugin

Commands that can be sent to RoomsPlugin. More...

Classes

struct | RakNet::RoomsPluginFunc
Base class for rooms functionality. More...
struct | RakNet::CreateRoom_Func
Create a room. Each user can be in at most one room, so will fail if the user is already in a room. More...
struct | RakNet::EnterRoom_Func
Joins a room if possible. If not, creates a room. More...
struct | RakNet::JoinByFilter_Func
Joins a room given the filter parameters and desired room member mode. More...
struct | RakNet::LeaveRoom_Func
Leaves a room. You can leave at any time, even if the room is locked. More...
struct | RakNet::GetInvitesToParticipant_Func
struct | RakNet::SendInvite_Func
Sends an invitation to someone. More...
struct | RakNet::AcceptInvite_Func
Accept an invitation from a user to a room. More...
struct | RakNet::StartSpectating_Func
Begin spectating. Spectators are considered room members that are not playing the game, only watching. More...
struct | RakNet::StopSpectating_Func
Stop spectating. This will rejoin the room as a player, using a reserved slot if we were invited, and a public slot if not or if there are no reserved slots. More...
struct | RakNet::GrantModerator_Func
Give moderator to another player. Moderators cannot be spectators. More...
struct | RakNet::ChangeSlotCounts_Func
Change the allowed slot counts for the room. Setting fewer slot counts than the number of players does not kick out players, though it may prevent changing spectator status. More...
struct | RakNet::SetCustomRoomProperties_Func
Sets a table of user-defined room properties. More...
struct | RakNet::GetRoomProperties_Func
Given a named room, return the properties of that room, including member list. More...
struct | RakNet::ChangeRoomName_Func
Change the name of the room. More...
struct | RakNet::SetHiddenFromSearches_Func
Set or unset the room hidden from searches. If a room is hidden from searches, it can only be joined through invitations. More...
struct | RakNet::SetDestroyOnModeratorLeave_Func
Sets or unsets to destroy the room when the moderator leaves the room. More...
struct | RakNet::SetReadyStatus_Func
Sets or unsets the user as flagged 'ready'. More...
struct | RakNet::GetReadyStatus_Func
Gets the ready states for every user in the room, excluding spectators. More...
struct | RakNet::SetRoomLockState_Func
Lock or unlock the room. More...
struct | RakNet::GetRoomLockState_Func
Gets the lock state of the room. More...
struct | RakNet::AreAllMembersReady_Func
If all members have been set to ready using SetReadyStatus_Func, this operation will set allReady to true. More...
struct | RakNet::KickMember_Func
Kick a member out of the room. This will also automatically ban that member from rejoining as long as the moderator does not change, or the member is unbanned. More...
struct | RakNet::UnbanMember_Func
Allow a member previously kicked out of the room to rejoin. More...
struct | RakNet::GetBanReason_Func
For a given room, get the reason parameter of KickMember_Func when we were kicked out. More...
struct | RakNet::AddUserToQuickJoin_Func
Enter quick join mode. More...
struct | RakNet::RemoveUserFromQuickJoin_Func
Leave quick join mode. More...
struct | RakNet::IsInQuickJoin_Func
Returns if you are waiting in quick join mode. More...
struct | RakNet::SearchByFilter_Func
Return all rooms that pass the roomQuery filter. More...
struct | RakNet::ChangeHandle_Func
Change your handle. More...
struct | RakNet::Chat_Func
Send a chat message. More...
struct | RakNet::Bitstream_Func
Send an arbitrary binary message. More...

Detailed Description

Commands that can be sent to RoomsPlugin.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::RoomsPluginFunc Struct Reference

  • RoomsPluginFunc
Public Attributes | List of all members
RakNet::RoomsPluginFunc Struct Referenceabstract
RoomsCommands

Base class for rooms functionality. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::RoomsPluginFunc:
RakNet::AcceptInvite_Func RakNet::AddUserToQuickJoin_Func RakNet::AreAllMembersReady_Func RakNet::Bitstream_Func RakNet::ChangeHandle_Func RakNet::ChangeRoomName_Func RakNet::ChangeSlotCounts_Func RakNet::Chat_Func RakNet::CreateRoom_Func RakNet::EnterRoom_Func RakNet::GetBanReason_Func RakNet::GetInvitesToParticipant_Func RakNet::GetReadyStatus_Func RakNet::GetRoomLockState_Func RakNet::GetRoomProperties_Func RakNet::GrantModerator_Func RakNet::IsInQuickJoin_Func RakNet::JoinByFilter_Func RakNet::KickMember_Func RakNet::LeaveRoom_Func RakNet::RemoveUserFromQuickJoin_Func RakNet::SearchByFilter_Func RakNet::SendInvite_Func RakNet::SetCustomRoomProperties_Func RakNet::SetDestroyOnModeratorLeave_Func RakNet::SetHiddenFromSearches_Func RakNet::SetReadyStatus_Func RakNet::SetRoomLockState_Func RakNet::StartSpectating_Func RakNet::StopSpectating_Func RakNet::UnbanMember_Func

Public Attributes

RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Base class for rooms functionality.

Operations performed on rooms are not in the RoomsPlugin - instead, each structure encapsulates one operation

Member Data Documentation

RoomsErrorCode RakNet::RoomsPluginFunc::resultCode
Parameters
[out] resultCode Result of this operation
RakNet::RakString RakNet::RoomsPluginFunc::userName
Parameters
[in] userName Who is performing this operation. Input parameter
The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::CreateRoom_Func Struct Reference

  • CreateRoom_Func
List of all members
RakNet::CreateRoom_Func Struct Reference
RoomsCommands

Create a room. Each user can be in at most one room, so will fail if the user is already in a room. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::CreateRoom_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Create a room. Each user can be in at most one room, so will fail if the user is already in a room.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::EnterRoom_Func Struct Reference

  • EnterRoom_Func
List of all members
RakNet::EnterRoom_Func Struct Reference
RoomsCommands

Joins a room if possible. If not, creates a room. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::EnterRoom_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Joins a room if possible. If not, creates a room.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::JoinByFilter_Func Struct Reference

  • JoinByFilter_Func
List of all members
RakNet::JoinByFilter_Func Struct Reference
RoomsCommands

Joins a room given the filter parameters and desired room member mode. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::JoinByFilter_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Joins a room given the filter parameters and desired room member mode.

Room joins may fail if the room is locked, or does not have slots of the particular type Room joins may succeed where they would otherwise fail if the user has an invitation to the room

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::LeaveRoom_Func Struct Reference

  • LeaveRoom_Func
List of all members
RakNet::LeaveRoom_Func Struct Reference
RoomsCommands

Leaves a room. You can leave at any time, even if the room is locked. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::LeaveRoom_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Leaves a room. You can leave at any time, even if the room is locked.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::GetInvitesToParticipant_Func Struct Reference

  • GetInvitesToParticipant_Func
List of all members
RakNet::GetInvitesToParticipant_Func Struct Reference
RoomsCommands

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::GetInvitesToParticipant_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Gets all invitations to you to various rooms.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::SendInvite_Func Struct Reference

  • SendInvite_Func
List of all members
RakNet::SendInvite_Func Struct Reference
RoomsCommands

Sends an invitation to someone. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::SendInvite_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Sends an invitation to someone.

Each user may have at most one invitation to the same room, although they have have invitations to multiple rooms.
This may fail depending on the room settings - the moderator may not allow other users to send invitations.
Invitations may be cleared when the moderator changes, depending on the room settings

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::AcceptInvite_Func Struct Reference

  • AcceptInvite_Func
List of all members
RakNet::AcceptInvite_Func Struct Reference
RoomsCommands

Accept an invitation from a user to a room. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::AcceptInvite_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Accept an invitation from a user to a room.

Invitations are the only way to join reserved slots. If all reserved slots are full, will join a public slot if possible.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::StartSpectating_Func Struct Reference

  • StartSpectating_Func
List of all members
RakNet::StartSpectating_Func Struct Reference
RoomsCommands

Begin spectating. Spectators are considered room members that are not playing the game, only watching. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::StartSpectating_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Begin spectating. Spectators are considered room members that are not playing the game, only watching.

Spectators do not count towards room ready states. The moderator can lock the room, preventing users from spectating, or not allow spectators at all

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::StopSpectating_Func Struct Reference

  • StopSpectating_Func
List of all members
RakNet::StopSpectating_Func Struct Reference
RoomsCommands

Stop spectating. This will rejoin the room as a player, using a reserved slot if we were invited, and a public slot if not or if there are no reserved slots. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::StopSpectating_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Stop spectating. This will rejoin the room as a player, using a reserved slot if we were invited, and a public slot if not or if there are no reserved slots.

This may fail if the moderator locked the room, or if no slots are available.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::GrantModerator_Func Struct Reference

  • GrantModerator_Func
List of all members
RakNet::GrantModerator_Func Struct Reference
RoomsCommands

Give moderator to another player. Moderators cannot be spectators. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::GrantModerator_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Give moderator to another player. Moderators cannot be spectators.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::ChangeSlotCounts_Func Struct Reference

  • ChangeSlotCounts_Func
List of all members
RakNet::ChangeSlotCounts_Func Struct Reference
RoomsCommands

Change the allowed slot counts for the room. Setting fewer slot counts than the number of players does not kick out players, though it may prevent changing spectator status. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::ChangeSlotCounts_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Change the allowed slot counts for the room. Setting fewer slot counts than the number of players does not kick out players, though it may prevent changing spectator status.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::SetCustomRoomProperties_Func Struct Reference

  • SetCustomRoomProperties_Func
List of all members
RakNet::SetCustomRoomProperties_Func Struct Reference
RoomsCommands

Sets a table of user-defined room properties. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::SetCustomRoomProperties_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Sets a table of user-defined room properties.

Fill out the table with the column name, type, and value.
These properties are read when searching for rooms, and can be used as query filters to only join rooms with specified properties
See RoomTypes.h for default room properties.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::GetRoomProperties_Func Struct Reference

  • GetRoomProperties_Func
List of all members
RakNet::GetRoomProperties_Func Struct Reference
RoomsCommands

Given a named room, return the properties of that room, including member list. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::GetRoomProperties_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Given a named room, return the properties of that room, including member list.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::ChangeRoomName_Func Struct Reference

  • ChangeRoomName_Func
List of all members
RakNet::ChangeRoomName_Func Struct Reference
RoomsCommands

Change the name of the room. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::ChangeRoomName_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Change the name of the room.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::SetHiddenFromSearches_Func Struct Reference

  • SetHiddenFromSearches_Func
List of all members
RakNet::SetHiddenFromSearches_Func Struct Reference
RoomsCommands

Set or unset the room hidden from searches. If a room is hidden from searches, it can only be joined through invitations. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::SetHiddenFromSearches_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Set or unset the room hidden from searches. If a room is hidden from searches, it can only be joined through invitations.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::SetDestroyOnModeratorLeave_Func Struct Reference

  • SetDestroyOnModeratorLeave_Func
List of all members
RakNet::SetDestroyOnModeratorLeave_Func Struct Reference
RoomsCommands

Sets or unsets to destroy the room when the moderator leaves the room. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::SetDestroyOnModeratorLeave_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Sets or unsets to destroy the room when the moderator leaves the room.

If false, the next moderator will be the oldest member that is not a spectator.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::SetReadyStatus_Func Struct Reference

  • SetReadyStatus_Func
List of all members
RakNet::SetReadyStatus_Func Struct Reference
RoomsCommands

Sets or unsets the user as flagged 'ready'. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::SetReadyStatus_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Sets or unsets the user as flagged 'ready'.

Ready means ready to play the game. This flag can be set or unset by each room member.BR> When all players are ready, the can will presumably start (although you can use this flag however you want).

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::GetReadyStatus_Func Struct Reference

  • GetReadyStatus_Func
List of all members
RakNet::GetReadyStatus_Func Struct Reference
RoomsCommands

Gets the ready states for every user in the room, excluding spectators. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::GetReadyStatus_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Gets the ready states for every user in the room, excluding spectators.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::SetRoomLockState_Func Struct Reference

  • SetRoomLockState_Func
List of all members
RakNet::SetRoomLockState_Func Struct Reference
RoomsCommands

Lock or unlock the room. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::SetRoomLockState_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Lock or unlock the room.

If the room is locked, no further players can join regardless of the available room slots. This includes invited players.
Rooms default to unlocked

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::GetRoomLockState_Func Struct Reference

  • GetRoomLockState_Func
List of all members
RakNet::GetRoomLockState_Func Struct Reference
RoomsCommands

Gets the lock state of the room. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::GetRoomLockState_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Gets the lock state of the room.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::AreAllMembersReady_Func Struct Reference

  • AreAllMembersReady_Func
List of all members
RakNet::AreAllMembersReady_Func Struct Reference
RoomsCommands

If all members have been set to ready using SetReadyStatus_Func, this operation will set allReady to true. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::AreAllMembersReady_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

If all members have been set to ready using SetReadyStatus_Func, this operation will set allReady to true.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::KickMember_Func Struct Reference

  • KickMember_Func
List of all members
RakNet::KickMember_Func Struct Reference
RoomsCommands

Kick a member out of the room. This will also automatically ban that member from rejoining as long as the moderator does not change, or the member is unbanned. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::KickMember_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Kick a member out of the room. This will also automatically ban that member from rejoining as long as the moderator does not change, or the member is unbanned.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::UnbanMember_Func Struct Reference

  • UnbanMember_Func
List of all members
RakNet::UnbanMember_Func Struct Reference
RoomsCommands

Allow a member previously kicked out of the room to rejoin. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::UnbanMember_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Allow a member previously kicked out of the room to rejoin.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::GetBanReason_Func Struct Reference

  • GetBanReason_Func
List of all members
RakNet::GetBanReason_Func Struct Reference
RoomsCommands

For a given room, get the reason parameter of KickMember_Func when we were kicked out. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::GetBanReason_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

For a given room, get the reason parameter of KickMember_Func when we were kicked out.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::AddUserToQuickJoin_Func Struct Reference

  • AddUserToQuickJoin_Func
List of all members
RakNet::AddUserToQuickJoin_Func Struct Reference
RoomsCommands

Enter quick join mode. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::AddUserToQuickJoin_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Enter quick join mode.

Quick join mode will wait until the specified timeout to try to automatically join a room each second.
A room will only be joined if enough quick join members can join at once to fill all playable slots in the room.
Older rooms are given priority to quick join.
If no rooms are available to join, but enough quick join members are present to create a room instead, this will be done. The room custom properties will be any equality comparisons with networkedQuickJoinUser.query

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::RemoveUserFromQuickJoin_Func Struct Reference

  • RemoveUserFromQuickJoin_Func
List of all members
RakNet::RemoveUserFromQuickJoin_Func Struct Reference
RoomsCommands

Leave quick join mode. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::RemoveUserFromQuickJoin_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Leave quick join mode.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::IsInQuickJoin_Func Struct Reference

  • IsInQuickJoin_Func
List of all members
RakNet::IsInQuickJoin_Func Struct Reference
RoomsCommands

Returns if you are waiting in quick join mode. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::IsInQuickJoin_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Returns if you are waiting in quick join mode.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::SearchByFilter_Func Struct Reference

  • SearchByFilter_Func
List of all members
RakNet::SearchByFilter_Func Struct Reference
RoomsCommands

Return all rooms that pass the roomQuery filter. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::SearchByFilter_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Return all rooms that pass the roomQuery filter.

Use onlyJoinable to further filter by rooms that you can join (not locked, not banned, public or invited slots)

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::ChangeHandle_Func Struct Reference

  • ChangeHandle_Func
List of all members
RakNet::ChangeHandle_Func Struct Reference
RoomsCommands

Change your handle. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::ChangeHandle_Func:
RakNet::RoomsPluginFunc

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode resultCode

Detailed Description

Change your handle.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Chat_Func Struct Reference

  • Chat_Func
Public Attributes | List of all members
RakNet::Chat_Func Struct Reference
RoomsCommands

Send a chat message. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::Chat_Func:
RakNet::RoomsPluginFunc

Public Attributes

bool | chatDirectedToRoom
- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode | resultCode

Detailed Description

Send a chat message.

Member Data Documentation

bool RakNet::Chat_Func::chatDirectedToRoom

If true, only sends the chat message if the user is in the same room. If false, privateMessageRecipient must also be filled out

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Bitstream_Func Struct Reference

  • Bitstream_Func
Public Attributes | List of all members
RakNet::Bitstream_Func Struct Reference
RoomsCommands

Send an arbitrary binary message. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::Bitstream_Func:
RakNet::RoomsPluginFunc

Public Attributes

bool | directedToRoom
- Public Attributes inherited from RakNet::RoomsPluginFunc
RakNet::RakString userName
RoomsErrorCode | resultCode

Detailed Description

Send an arbitrary binary message.

Member Data Documentation

bool RakNet::Bitstream_Func::directedToRoom

If true, only sends the bitstream if the user is in the same room. If false, privateMessageRecipient must also be filled out

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RoomsNotifications

Classes
RoomsNotifications
RoomsPlugin

Notifications that RoomsPlugin sends to you. More...

Classes

struct | RakNet::QuickJoinExpired_Notification
The quick join duration has expired without joining or creating any rooms. More...
struct | RakNet::QuickJoinEnteredRoom_Notification
Quick join succeeded, and you are now in a room. More...
struct | RakNet::RoomMemberStartedSpectating_Notification
Another room member has started spectating. More...
struct | RakNet::RoomMemberStoppedSpectating_Notification
Another room member has stopped spectating. More...
struct | RakNet::ModeratorChanged_Notification
The room has a new moderator (possibly you) More...
struct | RakNet::SlotCountsSet_Notification
The slot counts in the room has changed. More...
struct | RakNet::CustomRoomPropertiesSet_Notification
The custom properties for the room has changed. More...
struct | RakNet::RoomNameSet_Notification
The name of the room has been changed. More...
struct | RakNet::HiddenFromSearchesSet_Notification
The room is now hidden, or no longer hidden, from searches. More...
struct | RakNet::RoomMemberReadyStatusSet_Notification
Another room member has changed their ready status. More...
struct | RakNet::RoomLockStateSet_Notification
The room is now, or is no longer, locked. More...
struct | RakNet::RoomMemberKicked_Notification
A room member has been kicked out of the room (possibly you) More...
struct | RakNet::RoomMemberHandleSet_Notification
A room member has changed their handle. More...
struct | RakNet::RoomMemberLeftRoom_Notification
struct | RakNet::RoomMemberJoinedRoom_Notification
A room member has joined the room. More...
struct | RakNet::RoomInvitationSent_Notification
You have received an invitation to a room. More...
struct | RakNet::RoomInvitationWithdrawn_Notification
A previous room invitation is no longer valid (possibly due to moderator change, or the room no longer exists) More...
struct | RakNet::RoomDestroyedOnModeratorLeft_Notification
The moderator has left the room, and everyone left is a spectator, or the room was set to be destroyed when the moderator leftYou are no longer in the room. More...
struct | RakNet::Chat_Notification
You got a chat message from another user. More...
struct | RakNet::Bitstream_Notification
You got a generic bitstream message from another user. More...

Detailed Description

Notifications that RoomsPlugin sends to you.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::QuickJoinExpired_Notification Struct Reference

  • QuickJoinExpired_Notification
List of all members
RakNet::QuickJoinExpired_Notification Struct Reference
RoomsNotifications

The quick join duration has expired without joining or creating any rooms. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::QuickJoinExpired_Notification:
RakNet::RoomsPluginNotification

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginNotification
RakNet::RakString recipient
Always filled out so you know which user this callback applies to.

Detailed Description

The quick join duration has expired without joining or creating any rooms.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::QuickJoinEnteredRoom_Notification Struct Reference

  • QuickJoinEnteredRoom_Notification
List of all members
RakNet::QuickJoinEnteredRoom_Notification Struct Reference
RoomsNotifications

Quick join succeeded, and you are now in a room. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::QuickJoinEnteredRoom_Notification:
RakNet::RoomsPluginNotification

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginNotification
RakNet::RakString recipient
Always filled out so you know which user this callback applies to.

Detailed Description

Quick join succeeded, and you are now in a room.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::RoomMemberStartedSpectating_Notification Struct Reference

  • RoomMemberStartedSpectating_Notification
List of all members
RakNet::RoomMemberStartedSpectating_Notification Struct Reference
RoomsNotifications

Another room member has started spectating. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::RoomMemberStartedSpectating_Notification:
RakNet::RoomsPluginNotification

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginNotification
RakNet::RakString recipient
Always filled out so you know which user this callback applies to.

Detailed Description

Another room member has started spectating.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::RoomMemberStoppedSpectating_Notification Struct Reference

  • RoomMemberStoppedSpectating_Notification
List of all members
RakNet::RoomMemberStoppedSpectating_Notification Struct Reference
RoomsNotifications

Another room member has stopped spectating. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::RoomMemberStoppedSpectating_Notification:
RakNet::RoomsPluginNotification

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginNotification
RakNet::RakString recipient
Always filled out so you know which user this callback applies to.

Detailed Description

Another room member has stopped spectating.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::ModeratorChanged_Notification Struct Reference

  • ModeratorChanged_Notification
List of all members
RakNet::ModeratorChanged_Notification Struct Reference
RoomsNotifications

The room has a new moderator (possibly you) More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::ModeratorChanged_Notification:
RakNet::RoomsPluginNotification

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginNotification
RakNet::RakString recipient
Always filled out so you know which user this callback applies to.

Detailed Description

The room has a new moderator (possibly you)

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::SlotCountsSet_Notification Struct Reference

  • SlotCountsSet_Notification
List of all members
RakNet::SlotCountsSet_Notification Struct Reference
RoomsNotifications

The slot counts in the room has changed. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::SlotCountsSet_Notification:
RakNet::RoomsPluginNotification

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginNotification
RakNet::RakString recipient
Always filled out so you know which user this callback applies to.

Detailed Description

The slot counts in the room has changed.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::CustomRoomPropertiesSet_Notification Struct Reference

  • CustomRoomPropertiesSet_Notification
List of all members
RakNet::CustomRoomPropertiesSet_Notification Struct Reference
RoomsNotifications

The custom properties for the room has changed. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::CustomRoomPropertiesSet_Notification:
RakNet::RoomsPluginNotification

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginNotification
RakNet::RakString recipient
Always filled out so you know which user this callback applies to.

Detailed Description

The custom properties for the room has changed.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::RoomNameSet_Notification Struct Reference

  • RoomNameSet_Notification
List of all members
RakNet::RoomNameSet_Notification Struct Reference
RoomsNotifications

The name of the room has been changed. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::RoomNameSet_Notification:
RakNet::RoomsPluginNotification

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginNotification
RakNet::RakString recipient
Always filled out so you know which user this callback applies to.

Detailed Description

The name of the room has been changed.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::HiddenFromSearchesSet_Notification Struct Reference

  • HiddenFromSearchesSet_Notification
List of all members
RakNet::HiddenFromSearchesSet_Notification Struct Reference
RoomsNotifications

The room is now hidden, or no longer hidden, from searches. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::HiddenFromSearchesSet_Notification:
RakNet::RoomsPluginNotification

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginNotification
RakNet::RakString recipient
Always filled out so you know which user this callback applies to.

Detailed Description

The room is now hidden, or no longer hidden, from searches.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::RoomMemberReadyStatusSet_Notification Struct Reference

  • RoomMemberReadyStatusSet_Notification
List of all members
RakNet::RoomMemberReadyStatusSet_Notification Struct Reference
RoomsNotifications

Another room member has changed their ready status. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::RoomMemberReadyStatusSet_Notification:
RakNet::RoomsPluginNotification

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginNotification
RakNet::RakString recipient
Always filled out so you know which user this callback applies to.

Detailed Description

Another room member has changed their ready status.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::RoomLockStateSet_Notification Struct Reference

  • RoomLockStateSet_Notification
List of all members
RakNet::RoomLockStateSet_Notification Struct Reference
RoomsNotifications

The room is now, or is no longer, locked. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::RoomLockStateSet_Notification:
RakNet::RoomsPluginNotification

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginNotification
RakNet::RakString recipient
Always filled out so you know which user this callback applies to.

Detailed Description

The room is now, or is no longer, locked.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::RoomMemberKicked_Notification Struct Reference

  • RoomMemberKicked_Notification
List of all members
RakNet::RoomMemberKicked_Notification Struct Reference
RoomsNotifications

A room member has been kicked out of the room (possibly you) More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::RoomMemberKicked_Notification:
RakNet::RoomsPluginNotification

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginNotification
RakNet::RakString recipient
Always filled out so you know which user this callback applies to.

Detailed Description

A room member has been kicked out of the room (possibly you)

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::RoomMemberHandleSet_Notification Struct Reference

  • RoomMemberHandleSet_Notification
List of all members
RakNet::RoomMemberHandleSet_Notification Struct Reference
RoomsNotifications

A room member has changed their handle. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::RoomMemberHandleSet_Notification:
RakNet::RoomsPluginNotification

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginNotification
RakNet::RakString recipient
Always filled out so you know which user this callback applies to.

Detailed Description

A room member has changed their handle.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::RoomMemberLeftRoom_Notification Struct Reference

  • RoomMemberLeftRoom_Notification
List of all members
RakNet::RoomMemberLeftRoom_Notification Struct Reference
RoomsNotifications

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::RoomMemberLeftRoom_Notification:
RakNet::RoomsPluginNotification

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginNotification
RakNet::RakString recipient
Always filled out so you know which user this callback applies to.

Detailed Description

A room member has left the room

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::RoomMemberJoinedRoom_Notification Struct Reference

  • RoomMemberJoinedRoom_Notification
List of all members
RakNet::RoomMemberJoinedRoom_Notification Struct Reference
RoomsNotifications

A room member has joined the room. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::RoomMemberJoinedRoom_Notification:
RakNet::RoomsPluginNotification

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginNotification
RakNet::RakString recipient
Always filled out so you know which user this callback applies to.

Detailed Description

A room member has joined the room.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::RoomInvitationSent_Notification Struct Reference

  • RoomInvitationSent_Notification
List of all members
RakNet::RoomInvitationSent_Notification Struct Reference
RoomsNotifications

You have received an invitation to a room. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::RoomInvitationSent_Notification:
RakNet::RoomsPluginNotification

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginNotification
RakNet::RakString recipient
Always filled out so you know which user this callback applies to.

Detailed Description

You have received an invitation to a room.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::RoomInvitationWithdrawn_Notification Struct Reference

  • RoomInvitationWithdrawn_Notification
List of all members
RakNet::RoomInvitationWithdrawn_Notification Struct Reference
RoomsNotifications

A previous room invitation is no longer valid (possibly due to moderator change, or the room no longer exists) More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::RoomInvitationWithdrawn_Notification:
RakNet::RoomsPluginNotification

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginNotification
RakNet::RakString recipient
Always filled out so you know which user this callback applies to.

Detailed Description

A previous room invitation is no longer valid (possibly due to moderator change, or the room no longer exists)

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::RoomDestroyedOnModeratorLeft_Notification Struct Reference

  • RoomDestroyedOnModeratorLeft_Notification
List of all members
RakNet::RoomDestroyedOnModeratorLeft_Notification Struct Reference
RoomsNotifications

The moderator has left the room, and everyone left is a spectator, or the room was set to be destroyed when the moderator leftYou are no longer in the room. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::RoomDestroyedOnModeratorLeft_Notification:
RakNet::RoomsPluginNotification

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginNotification
RakNet::RakString recipient
Always filled out so you know which user this callback applies to.

Detailed Description

The moderator has left the room, and everyone left is a spectator, or the room was set to be destroyed when the moderator left

You are no longer in the room.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Chat_Notification Struct Reference

  • Chat_Notification
List of all members
RakNet::Chat_Notification Struct Reference
RoomsNotifications

You got a chat message from another user. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::Chat_Notification:
RakNet::RoomsPluginNotification

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginNotification
RakNet::RakString recipient
Always filled out so you know which user this callback applies to.

Detailed Description

You got a chat message from another user.

If you want to support ignoring chat messages from specific users, use Lobby2Client_PC::IsInIgnoreList

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Bitstream_Notification Struct Reference

  • Bitstream_Notification
List of all members
RakNet::Bitstream_Notification Struct Reference
RoomsNotifications

You got a generic bitstream message from another user. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::Bitstream_Notification:
RakNet::RoomsPluginNotification

Additional Inherited Members

- Public Attributes inherited from RakNet::RoomsPluginNotification
RakNet::RakString recipient
Always filled out so you know which user this callback applies to.

Detailed Description

You got a generic bitstream message from another user.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::RoomsPluginNotification Struct Reference

  • RoomsPluginNotification
Public Attributes | List of all members
RakNet::RoomsPluginNotification Struct Referenceabstract
RoomsPlugin

Base class for notification callbacks. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::RoomsPluginNotification:
RakNet::Bitstream_Notification RakNet::Chat_Notification RakNet::CustomRoomPropertiesSet_Notification RakNet::HiddenFromSearchesSet_Notification RakNet::ModeratorChanged_Notification RakNet::QuickJoinEnteredRoom_Notification RakNet::QuickJoinExpired_Notification RakNet::RoomDestroyedOnModeratorLeft_Notification RakNet::RoomInvitationSent_Notification RakNet::RoomInvitationWithdrawn_Notification RakNet::RoomLockStateSet_Notification RakNet::RoomMemberHandleSet_Notification RakNet::RoomMemberJoinedRoom_Notification RakNet::RoomMemberKicked_Notification RakNet::RoomMemberLeftRoom_Notification RakNet::RoomMemberReadyStatusSet_Notification RakNet::RoomMemberStartedSpectating_Notification RakNet::RoomMemberStoppedSpectating_Notification RakNet::RoomNameSet_Notification RakNet::SlotCountsSet_Notification

Public Attributes

RakNet::RakString recipient
Always filled out so you know which user this callback applies to.

Detailed Description

Base class for notification callbacks.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::RoomsPlugin Class Reference

  • RoomsPlugin
Public Member Functions | Static Public Member Functions | Public Attributes | List of all members
RakNet::RoomsPlugin Class Reference
RoomsPlugin

Used to create rooms for players where they can matchmake. More...

#include <RoomsPlugin.h>

Inheritance diagram for RakNet::RoomsPlugin:
RakNet::PluginInterface2

Public Member Functions

void | SetOrderingChannel (char oc)
Ordering channel to send messages on.
void | SetSendPriority (PacketPriority pp)
Send priority to send messages on.
void | SetRoomsCallback (RoomsCallback *_roomsCallback)
Set the callback to get notification and ExecuteFunc() results.
void | AddRoomsCallback (RoomsCallback *_roomsCallback)
Add a callback to get notification and ExecuteFunc() results.
void | RemoveRoomsCallback (RoomsCallback *_roomsCallback)
Remove a callback to get notification and ExecuteFunc() results.
void | ExecuteFunc (RoomsPluginFunc *func)
Execute a function, using the system address passed to SetServerAddress();.
void | ExecuteFunc (RoomsPluginFunc *func, SystemAddress remoteAddress)
Execute a function, with a specific address.
void | SetServerAddress (SystemAddress systemAddress)
Sets the remote server address that is running RoomsPlugin. Send calls will go to this function.
bool | LoginRoomsParticipant (RakNet::RakString userName, SystemAddress roomsParticipantAddress, RakNetGUID guid, SystemAddress loginServerAddress)
Add a participant to the system.
bool | LogoffRoomsParticipant (RakNet::RakString userName, SystemAddress loginServerAddress)
Removes a participant from the system.
void | ClearRoomMembers ()
Clear all users.
void | ChangeHandle (RakNet::RakString oldHandle, RakNet::RakString newHandle)
Change the handle a user.
void | AddLoginServerAddress (SystemAddress systemAddress)
Add a SystemAddress to a list that will be checked when LoginRoomsParticipant() and LogoffRoomsParticipant() is called.
void | RemoveLoginServerAddress (SystemAddress systemAddress)
Remove a SystemAddress from a list that will be checked when LoginRoomsParticipant() and LogoffRoomsParticipant() is called.
void | ClearLoginServerAdddresses (void)
Remove all addresses added with AddLoginServerAddress()
void | SetProfanityFilter (ProfanityFilter *pf)
Sets the profanity filter for the system to use (optional)
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Static Public Member Functions

static void | SerializeLogin (RakNet::RakString userName, SystemAddress userAddress, RakNetGUID guid, RakNet::BitStream *bs)
Used for Lobby2. Serializes the same data that the plugin itself uses to login.
static void | SerializeLogoff (RakNet::RakString userName, RakNet::BitStream *bs)
Used for Lobby2. Serializes the same data that the plugin itself uses to logoff.
static void | SerializeChangeHandle (RakNet::RakString oldHandle, RakNet::RakString newHandle, RakNet::BitStream *bs)
Used for Lobby2. Serializes the same data that the plugin itself uses to change handles.

Public Attributes

AllGamesRoomsContainer roomsContainer
Only used on the server. Locally perform any desired functions, such as logging off players.

Detailed Description

Used to create rooms for players where they can matchmake.

A room is similar to the rooms you see in other lobby systems, where groups of players can join together in order to start a game match
Each player can be in at most one room.
Each player name must be unique.
Each room has one moderator, which can perform operations on the room such as kicking out members.
This plugin networks the AllGamesRoomsContainer class, which performs the actual functionality.

To use as a client:

  1. Connect to the server and attach the plugin as normal.
  2. Call SetServerAddress to tell the system where the server is.
  3. Call RoomsPlugin::SetRoomsCallback() with a pointer to a callback structure
  4. Fill in the input parameters of the desired structure(s)
  5. Call RoomsPlugin::ExecuteFunc with a pointer to the structure.
  6. Process the callback, which will contain the original input parameters, plus the new output parameters. All structures contain resultCode, which indicates if the operation was successful (REC_SUCCESS) or not (Anything else)

To use as a server:

  1. Start RakNet as usual, accepting connections and attaching the plugin
  2. Call RoomsPlugin::SetProfanityFilter() with the ProfanityFilter class, if desired
  3. Call RoomsPlugin::AddTitle() for each title (game) you want to support
  4. If you want other systems to be able to call RoomsPlugin::LoginRoomsParticipant(), call RoomsPlugin::AddLoginServerAddress() with the addresses of those systems
  5. As users go online, call RoomsPlugin::LoginRoomsParticipant(). Login and Logoff is up to you to implement (or rely on other systems, such as Lobby2)
  6. As users go offline, call RoomsPlugin::LogoffRoomsParticipant();
See Also
AllGamesRoomsContainer
TeamManager TeamManager performs some of the same functions as RoomsPlugin in a more flexible way

Member Function Documentation

void RakNet::RoomsPlugin::AddLoginServerAddress ( SystemAddress systemAddress )

Add a SystemAddress to a list that will be checked when LoginRoomsParticipant() and LogoffRoomsParticipant() is called.

Parameters
[in] systemAddress The address to add
void RakNet::RoomsPlugin::AddRoomsCallback ( RoomsCallback * _roomsCallback )

Add a callback to get notification and ExecuteFunc() results.

Parameters
[in] _roomsCallback Class instance to get callbacks on. Should remain a valid pointer for the duration of the plugin execution.
void RakNet::RoomsPlugin::ChangeHandle | ( | RakNet::RakString | oldHandle,
 |  | RakNet::RakString | newHandle
 | ) |  |

Change the handle a user.

Parameters
[in] | oldHandle | The handle previously known by the system
[in] | newHandle | The new handle to use
void RakNet::RoomsPlugin::ExecuteFunc ( RoomsPluginFunc * func )

Execute a function, using the system address passed to SetServerAddress();.

Parameters
[in] func Pointer to a base class of RoomsPluginFunc to execute
void RakNet::RoomsPlugin::ExecuteFunc | ( | RoomsPluginFunc * | func,
 |  | SystemAddress | remoteAddress
 | ) |  |

Execute a function, with a specific address.

Parameters
[in] | func | Pointer to a base class of RoomsPluginFunc to execute
[in] | remoteAddress | Address to send the command to. The remote system should also be running RoomsPlugin
bool RakNet::RoomsPlugin::LoginRoomsParticipant | ( | RakNet::RakString | userName,
 |  | SystemAddress | roomsParticipantAddress,
 |  | RakNetGUID | guid,
 |  | SystemAddress | loginServerAddress
 | ) |  |

Add a participant to the system.

Only participants can perform operations

Parameters
[in] | userName | A unique string identifying the user
[in] | roomsParticipantAddress | The address of the user
[in] | guid | The guid of the user
[in] | loginServerAddress | The server adding this user. Use RakNet::UNASSIGNED_SYSTEM_ADDRESS for not applicable. Otherwise, the address must previously have been added using AddLoginServerAddress() or the function will fail.
bool RakNet::RoomsPlugin::LogoffRoomsParticipant | ( | RakNet::RakString | userName,
 |  | SystemAddress | loginServerAddress
 | ) |  |

Removes a participant from the system.

Parameters
[in] | userName | A unique string identifying the user
[in] | loginServerAddress | The server removing. Use RakNet::UNASSIGNED_SYSTEM_ADDRESS for not applicable. Otherwise, the address must previously have been added using AddLoginServerAddress() or the function will fail.
virtual void RakNet::RoomsPlugin::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
virtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::RoomsPlugin::OnReceive ( Packet * packet )
virtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

void RakNet::RoomsPlugin::RemoveLoginServerAddress ( SystemAddress systemAddress )

Remove a SystemAddress from a list that will be checked when LoginRoomsParticipant() and LogoffRoomsParticipant() is called.

Parameters
[in] systemAddress The address to remove
void RakNet::RoomsPlugin::RemoveRoomsCallback ( RoomsCallback * _roomsCallback )

Remove a callback to get notification and ExecuteFunc() results.

Parameters
[in] _roomsCallback Class instance to no longer get callbacks on.
void RakNet::RoomsPlugin::SetOrderingChannel ( char oc )

Ordering channel to send messages on.

Parameters
[in] oc The ordering channel
void RakNet::RoomsPlugin::SetProfanityFilter ( ProfanityFilter * pf )

Sets the profanity filter for the system to use (optional)

If set, room names and player handles will be checked for profanity. Room invitations and other messages are not checked.

Parameters
[in] pf An instance of a profanity filter
void RakNet::RoomsPlugin::SetRoomsCallback ( RoomsCallback * _roomsCallback )

Set the callback to get notification and ExecuteFunc() results.

Parameters
[in] _roomsCallback Class instance to get callbacks on. Should remain a valid pointer for the duration of the plugin execution.
void RakNet::RoomsPlugin::SetSendPriority ( PacketPriority pp )

Send priority to send messages on.

Parameters
[in] pp The packet priority
void RakNet::RoomsPlugin::SetServerAddress ( SystemAddress systemAddress )

Sets the remote server address that is running RoomsPlugin. Send calls will go to this function.

Parameters
[in] systemAddress The remote system, which should be connected while calling client functions

Member Data Documentation

AllGamesRoomsContainer RakNet::RoomsPlugin::roomsContainer

Only used on the server. Locally perform any desired functions, such as logging off players.

Note
Use AllGamesRoomsContainer::AddTitle() to add titles
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::RPC3 Class Reference

  • RPC3
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
RakNet::RPC3 Class Reference
RPC3

The RPC3 plugin allows you to call remote functions as if they were local functions, using the standard function call syntax. More...

#include <RPC3.h>

Inheritance diagram for RakNet::RPC3:
RakNet::PluginInterface2

Public Member Functions

void | SetNetworkIDManager (NetworkIDManager *idMan)
template<typename Function >
bool | RegisterFunction (const char *uniqueIdentifier, Function functionPtr)
template<typename Function >
void | RegisterSlot (const char *sharedIdentifier, Function functionPtr, NetworkID objectInstanceId, int callPriority)
bool | UnregisterFunction (const char *uniqueIdentifier)
bool | IsFunctionRegistered (const char *uniqueIdentifier)
void | SetTimestamp (RakNet::Time timeStamp)
void | SetSendParams (PacketPriority priority, PacketReliability reliability, char orderingChannel)
void | SetRecipientAddress (const SystemAddress &systemAddress, bool broadcast)
void | SetRecipientObject (NetworkID networkID)
RakNet::Time | GetLastSenderTimestamp (void) const
SystemAddress | GetLastSenderAddress (void) const
void | InterruptSignal (void)
If called while processing a slot, no further slots for the currently executing signal will be executed.
RakPeerInterface * | GetRakPeer (void) const
Returns the instance of RakPeer this plugin was attached to.
const char * | GetCurrentExecution (void) const
bool | Call (const char *uniqueIdentifier)
bool | CallExplicit (const char *uniqueIdentifier, const CallExplicitParameters *const callExplicitParameters)
bool | Signal (const char *sharedIdentifier)
bool | SignalExplicit (const char *sharedIdentifier, const SignalExplicitParameters *const signalExplicitParameters)
Same as Signal(), but you are forced to specify the remote system parameters.
void | InvokeSignal (DataStructures::HashIndex functionIndex, RakNet::BitStream *serializedParameters, bool temporarilySetUSA)
Call a given signal with a bitstream representing the parameter list.
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Protected Member Functions

void | OnAttach (void)
Called when the interface is attached.
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)

Protected Attributes

unsigned int nextSlotRegistrationCount
Used so slots are called in the order they are registered.

Detailed Description

The RPC3 plugin allows you to call remote functions as if they were local functions, using the standard function call syntax.

No serialization or deserialization is needed.
As of this writing, the system is not threadsafe.
Features:
Pointers to classes that derive from NetworkID are automatically looked up using NetworkIDManager Types are written to BitStream, meaning built-in serialization operations are performed, including endian swapping Types can customize autoserialization by providing an implementation of operator << and operator >> to and from BitStream

Note
You cannot use RPC4 at the same time as RPC3

Member Function Documentation

bool RakNet::RPC3::Call ( const char * uniqueIdentifier )
inline

Calls a remote function, using as send parameters whatever was last passed to SetTimestamp(), SetSendParams(), SetRecipientAddress(), and SetRecipientObject() If you call a C++ class member function, don't forget to first call SetRecipientObject(). You can use CallExplicit() instead of Call() to force yourself not to forget.

Parameters passed to Call are processed as follows:

  1. If the parameter is not a pointer
  2. - And you overloaded RakNet::BitStream& operator<<(RakNet::BitStream& out, MyClass& in) then that will be used to do the serialization
  3. - Otherwise, it will use bitStream.Write(myClass); BitStream already defines specializations for NetworkIDObject, SystemAddress, other BitStreams
  4. If the parameter is a pointer
  5. - And the pointer can be converted to NetworkIDObject, then it will write bitStream.Write(myClass->GetNetworkID()); To make it also dereference the pointer, use RakNet::_RPC3::Deref(myClass)
  6. - And the pointer can not be converted to NetworkID, but it is a pointer to RakNet::RPC3, then it is skipped
  7. Otherwise, the pointer is dereferenced and written as in step 2 and 3.
Note
If you need endian swapping (Mac talking to PC for example), you pretty much need to define operator << and operator >> for all classes you want to serialize. Otherwise the member variables will not be endian swapped.
If the call fails on the remote system, you will get back ID_RPC_REMOTE_ERROR. packet->data[1] will contain one of the values of RPCErrorCodes. packet->data[2] and on will contain the name of the function.
Parameters
[in] uniqueIdentifier parameter of the same name passed to RegisterFunction() on the remote system
bool RakNet::RPC3::CallExplicit | ( | const char * | uniqueIdentifier,
 |  | const CallExplicitParameters *const | callExplicitParameters
 | ) |  |
inline

Calls a remote function, using whatever was last passed to SetTimestamp(), SetSendParams(), SetRecipientAddress(), and SetRecipientObject() Passed parameter(s), if any, are serialized using operator << with RakNet::BitStream. If you provide an overload it will be used, otherwise the seriailzation is equivalent to memcpy except for native RakNet types (NetworkIDObject, SystemAddress, etc.) If the type is a pointer to a type deriving from NetworkIDObject, then only the NetworkID is sent, and the object looked up on the remote system. Otherwise, the pointer is dereferenced and the contents serialized as usual.

Note
The this pointer, for this instance of RPC3, is pushed as the last parameter on the stack. See RPC3Sample.cpp for an example of this
If the call fails on the remote system, you will get back ID_RPC_REMOTE_ERROR. packet->data[1] will contain one of the values of RPCErrorCodes. packet->data[2] and on will contain the name of the function.
Parameters
[in] | uniqueIdentifier | parameter of the same name passed to RegisterFunction() on the remote system
[in] | timeStamp | See SetTimestamp()
[in] | priority | See SetSendParams()
[in] | reliability | See SetSendParams()
[in] | orderingChannel | See SetSendParams()
[in] | systemAddress | See SetRecipientAddress()
[in] | broadcast | See SetRecipientAddress()
[in] | networkID | See SetRecipientObject()
const char* RakNet::RPC3::GetCurrentExecution ( void ) const

Returns the currently running RPC call identifier, set from RegisterFunction::uniqueIdentifier Returns an empty string "" if none

Returns
which RPC call is currently running
SystemAddress RakNet::RPC3::GetLastSenderAddress ( void ) const

Returns the system address of the last system to send us a received function call Equivalent to the old system RPCParameters::sender

Returns
Last system to send an RPC call using this system
RakNet::Time RakNet::RPC3::GetLastSenderTimestamp ( void ) const

If the last received function call has a timestamp included, it is stored and can be retrieved with this function.

Returns
0 if the last call did not have a timestamp, else non-zero
bool RakNet::RPC3::IsFunctionRegistered ( const char * uniqueIdentifier )

Returns if a function identifier was previously registered on this system with RegisterFunction(), and not unregistered with UnregisterFunction()

Parameters
[in] uniqueIdentifier String identifying the function.
Returns
True if the function was registered, false otherwise
virtual void RakNet::RPC3::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
protectedvirtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::RPC3::OnReceive ( Packet * packet )
protectedvirtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

template<typename Function >
bool RakNet::RPC3::RegisterFunction | ( | const char * | uniqueIdentifier,
 |  | Function | functionPtr
 | ) |  |
inline

Register a function pointer as callable using RPC()

Parameters
[in] | uniqueIdentifier | String identifying the function. Recommended that this is the name of the function
[in] | functionPtr | Pointer to the function. For C, just pass the name of the function. For C++, use ARPC_REGISTER_CPP_FUNCTION
Returns
True on success, false on uniqueIdentifier already used
template<typename Function >
void RakNet::RPC3::RegisterSlot | ( | const char * | sharedIdentifier,
 |  | Function | functionPtr,
 |  | NetworkID | objectInstanceId,
 |  | int | callPriority
 | ) |  |
inline

Register a slot, which is a function pointer to one or more instances of a class that supports this function signature When a signal occurs, all slots with the same identifier are called.

Parameters
[in] | sharedIdentifier | A string to identify the slot. Recommended to be the same as the name of the function.
[in] | functionPtr | Pointer to the function. For C, just pass the name of the function. For C++, use ARPC_REGISTER_CPP_FUNCTION
[in] | objectInstance | If 0, then this slot is just a regular C function. Otherwise, this is a member of the given class instance.
[in] | callPriority | Slots are called by order of the highest callPriority first. For slots with the same priority, they are called in the order they are registered
void RakNet::RPC3::SetNetworkIDManager ( NetworkIDManager * idMan )

Sets the network ID manager to use for object lookup Required to call C++ object member functions via SetRecipientObject()

Parameters
[in] idMan Pointer to the network ID manager to use
void RakNet::RPC3::SetRecipientAddress | ( | const SystemAddress & | systemAddress,
 |  | bool | broadcast
 | ) |  |

Set system to send to for all following calls to Call() Defaults to RakNet::UNASSIGNED_SYSTEM_ADDRESS, broadcast=true

Parameters
[in] | systemAddress | See RakPeer::Send()
[in] | broadcast | See RakPeer::Send()
void RakNet::RPC3::SetRecipientObject ( NetworkID networkID )

Set the NetworkID to pass for all following calls to Call() Defaults to UNASSIGNED_NETWORK_ID (none) If set, the remote function will be considered a C++ function, e.g. an object member function If set to UNASSIGNED_NETWORK_ID (none), the remote function will be considered a C function If this is set incorrectly, you will get back either RPC_ERROR_CALLING_C_AS_CPP or RPC_ERROR_CALLING_CPP_AS_C

See Also
NetworkIDManager
Parameters
[in] networkID Returned from NetworkIDObject::GetNetworkID()
void RakNet::RPC3::SetSendParams | ( | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel
 | ) |  |

Set parameters to pass to RakPeer::Send() for all following calls to Call() Deafults to HIGH_PRIORITY, RELIABLE_ORDERED, ordering channel 0

Parameters
[in] | priority | See RakPeer::Send()
[in] | reliability | See RakPeer::Send()
[in] | orderingChannel | See RakPeer::Send()
void RakNet::RPC3::SetTimestamp ( RakNet::Time timeStamp )

Send or stop sending a timestamp with all following calls to Call() Use GetLastSenderTimestamp() to read the timestamp.

Parameters
[in] timeStamp Non-zero to pass this timestamp using the ID_TIMESTAMP system. 0 to clear passing a timestamp.
bool RakNet::RPC3::Signal ( const char * sharedIdentifier )
inline

Calls zero or more functions identified by sharedIdentifier. Uses as send parameters whatever was last passed to SetTimestamp(), SetSendParams(), and SetRecipientAddress() You can use CallExplicit() instead of Call() to force yourself not to forget to set parameters

See the Call() function for a description of parameters

Parameters
[in] sharedIdentifier parameter of the same name passed to RegisterSlot() on the remote system
bool RakNet::RPC3::UnregisterFunction ( const char * uniqueIdentifier )

Unregisters a function pointer to be callable given an identifier for the pointer

Parameters
[in] uniqueIdentifier String identifying the function.
Returns
True on success, false on function was not previously or is not currently registered.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/RPC3/RPC3.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: SQLite3Plugin

Classes | Macros | Functions
SQLite3Plugin
Plugins

Code to transmit SQLite3 commands across the network. More...

Classes

class | RakNet::SQLite3PluginResultInterface
Handles results of calls to SQLite3Plugin::_sqlite3_exec() Results from calling SQLite3Plugin::_sqlite3_exec() are handled in this callback. You should implement the callback, and let the plugin know about it via SQLite3Plugin::AddResultHandler() Be sure to call SQLite3Plugin::RemoveResultHandler() or SQLite3Plugin::ClearResultHandlers() if you delete the callback. More...
class | RakNet::SQLite3PluginResultInterface_Printf
class | RakNet::SQLite3ClientPlugin
struct | SQLite3Row
struct | SQLite3Table
class | RakNet::SQLite3ServerPlugin
Exec SQLLite commands over the network. More...

Macros

#define SQLite3_STATEMENT_EXECUTE_THREADED
Control if SQLite3 statements execute in a thread.

Functions

virtual void | RakNet::SQLite3PluginResultInterface::_sqlite3_exec (RakNet::RakString inputStatement, unsigned int queryId, RakNet::RakString dbIdentifier, const SQLite3Table &table, RakNet::RakString errorMsg)=0
virtual void | RakNet::SQLite3PluginResultInterface::OnUnknownDBIdentifier (RakNet::RakString inputStatement, unsigned int queryId, RakNet::RakString dbIdentifier)=0

Detailed Description

Code to transmit SQLite3 commands across the network.

Macro Definition Documentation

#define SQLite3_STATEMENT_EXECUTE_THREADED

Control if SQLite3 statements execute in a thread.

sqlite3_exec is blocking and will therefore block other operations in the same program
If defined, sqlite3_exec executes in a thread so that doesn't happen
If the only thing this system is doing is running SQLite, then you'll get marginally better performance by commenting it out.

Function Documentation

virtual void RakNet::SQLite3PluginResultInterface::_sqlite3_exec | ( | RakNet::RakString | inputStatement,
 |  | unsigned int | queryId,
 |  | RakNet::RakString | dbIdentifier,
 |  | const SQLite3Table & | table,
 |  | RakNet::RakString | errorMsg
 | ) |  |
pure virtual

Query executed, possibly returning data or an error message

Parameters
[out] | inputStatement | Passed to SQLite3Plugin::_sqlite3_exec
[out] | queryId | Returned from SQLite3Plugin::_sqlite3_exec
[out] | dbIdentifier | Passed to SQLite3Plugin::_sqlite3_exec
[out] | table | Result of call to _sqlite3_exec, should that statement return a result
[out] | errorMsg | If _sqlite3_exec failed, then the error message is here, and table will be empty
virtual void RakNet::SQLite3PluginResultInterface::OnUnknownDBIdentifier | ( | RakNet::RakString | inputStatement,
 |  | unsigned int | queryId,
 |  | RakNet::RakString | dbIdentifier
 | ) |  |
pure virtual

dbIdentifier is unknown on the remote system

Parameters
[out] | inputStatement | Passed to SQLite3Plugin::_sqlite3_exec
[out] | queryId | Returned from SQLite3Plugin::_sqlite3_exec
[out] | dbIdentifier | Passed to SQLite3Plugin::_sqlite3_exec
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::SQLite3PluginResultInterface Class Reference

  • SQLite3PluginResultInterface
Public Member Functions | List of all members
RakNet::SQLite3PluginResultInterface Class Referenceabstract
SQLite3Plugin

Handles results of calls to SQLite3Plugin::_sqlite3_exec() Results from calling SQLite3Plugin::_sqlite3_exec() are handled in this callback. You should implement the callback, and let the plugin know about it via SQLite3Plugin::AddResultHandler() Be sure to call SQLite3Plugin::RemoveResultHandler() or SQLite3Plugin::ClearResultHandlers() if you delete the callback. More...

#include <SQLite3ClientPlugin.h>

Inheritance diagram for RakNet::SQLite3PluginResultInterface:
RakNet::SQLite3PluginResultInterface_Printf

Public Member Functions

virtual void | _sqlite3_exec (RakNet::RakString inputStatement, unsigned int queryId, RakNet::RakString dbIdentifier, const SQLite3Table &table, RakNet::RakString errorMsg)=0
virtual void | OnUnknownDBIdentifier (RakNet::RakString inputStatement, unsigned int queryId, RakNet::RakString dbIdentifier)=0

Detailed Description

Handles results of calls to SQLite3Plugin::_sqlite3_exec() Results from calling SQLite3Plugin::_sqlite3_exec() are handled in this callback. You should implement the callback, and let the plugin know about it via SQLite3Plugin::AddResultHandler() Be sure to call SQLite3Plugin::RemoveResultHandler() or SQLite3Plugin::ClearResultHandlers() if you delete the callback.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/SQLite3Plugin/SQLite3ClientPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::SQLite3PluginResultInterface_Printf Class Reference

  • SQLite3PluginResultInterface_Printf
List of all members
RakNet::SQLite3PluginResultInterface_Printf Class Reference
SQLite3Plugin

#include <SQLite3ClientPlugin.h>

Inheritance diagram for RakNet::SQLite3PluginResultInterface_Printf:
RakNet::SQLite3PluginResultInterface

Detailed Description

Sample callback implementation that just prints to the screen the results

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/SQLite3Plugin/SQLite3ClientPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::SQLite3ClientPlugin Class Reference

  • SQLite3ClientPlugin
Public Member Functions | List of all members
RakNet::SQLite3ClientPlugin Class Reference
SQLite3Plugin

#include <SQLite3ClientPlugin.h>

Inheritance diagram for RakNet::SQLite3ClientPlugin:
RakNet::PluginInterface2

Public Member Functions

void | AddResultHandler (SQLite3PluginResultInterface *res)
unsigned int | _sqlite3_exec (RakNet::RakString dbIdentifier, RakNet::RakString inputStatement, PacketPriority priority, PacketReliability reliability, char orderingChannel, const SystemAddress &systemAddress)
virtual PluginReceiveResult | OnReceive (Packet *packet)
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Detailed Description

SQLite version 3 supports remote calls via networked file handles, but not over the regular internet This plugin will serialize calls to and results from sqlite3_exec That's all it does - any remote system can execute SQL queries. Intended as a starting platform to derive from for more advanced functionality (security over who can query, etc). Compatible as a plugin with both RakPeerInterface and PacketizedTCP

Member Function Documentation

unsigned int RakNet::SQLite3ClientPlugin::_sqlite3_exec | ( | RakNet::RakString | dbIdentifier,
 |  | RakNet::RakString | inputStatement,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | const SystemAddress & | systemAddress
 | ) |  |

Execute a statement on the remote system

Note
Don't forget to escape your input strings. RakString::SQLEscape() is available for this.
Parameters
[in] | dbIdentifier | Which database to use, added with AddDBHandle()
[in] | inputStatement | SQL statement to execute
[in] | priority | See RakPeerInterface::Send()
[in] | reliability | See RakPeerInterface::Send()
[in] | orderingChannel | See RakPeerInterface::Send()
[in] | systemAddress | See RakPeerInterface::Send()
Returns
Query ID. Will be returned in _sqlite3_exec
void RakNet::SQLite3ClientPlugin::AddResultHandler ( SQLite3PluginResultInterface * res )

Add an interface to get callbacks for results Up to user to make sure the pointer is valid through the lifetime of use

virtual PluginReceiveResult RakNet::SQLite3ClientPlugin::OnReceive ( Packet * packet )
virtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/SQLite3Plugin/SQLite3ClientPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: SQLite3Row Struct Reference

List of all members
SQLite3Row Struct Reference
SQLite3Plugin

#include <SQLite3PluginCommon.h>

Detailed Description

Contains a result row, which is just an array of strings

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/SQLite3Plugin/SQLite3PluginCommon.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: SQLite3Table Struct Reference

List of all members
SQLite3Table Struct Reference
SQLite3Plugin

#include <SQLite3PluginCommon.h>

Detailed Description

Contains a result table, which is an array of column name strings, followed by an array of SQLite3Row

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/SQLite3Plugin/SQLite3PluginCommon.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::SQLite3ServerPlugin Class Reference

  • SQLite3ServerPlugin
Public Member Functions | List of all members
RakNet::SQLite3ServerPlugin Class Reference
SQLite3Plugin

Exec SQLLite commands over the network. More...

#include <SQLite3ServerPlugin.h>

Inheritance diagram for RakNet::SQLite3ServerPlugin:
RakNet::PluginInterface2

Public Member Functions

virtual bool | AddDBHandle (RakNet::RakString dbIdentifier, sqlite3 *dbHandle, bool dbAutoCreated=false)
void | RemoveDBHandle (RakNet::RakString dbIdentifier, bool alsoCloseConnection=false)
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | Update (void)
Update is called every time a packet is checked for .
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Detailed Description

Exec SQLLite commands over the network.

SQLite version 3 supports remote calls via networked file handles, but not over the regular internet
This plugin will serialize calls to and results from sqlite3_exec
That's all it does - any remote system can execute SQL queries.
Intended as a starting platform to derive from for more advanced functionality (security over who can query, etc).
Compatible as a plugin with both RakPeerInterface and PacketizedTCP

Member Function Documentation

virtual bool RakNet::SQLite3ServerPlugin::AddDBHandle | ( | RakNet::RakString | dbIdentifier,
 |  | sqlite3 * | dbHandle,
 |  | bool | dbAutoCreated = false
 | ) |  |
virtual

Associate identifier with dbHandle, so when we get calls to operate on identifier, we use dbhandle If SQLite3_STATEMENT_EXECUTE_THREADED is defined, will start the execution thread the first time a dbHandle is added.

Returns
true on success, false on dbIdentifier empty, or already in use
virtual PluginReceiveResult RakNet::SQLite3ServerPlugin::OnReceive ( Packet * packet )
virtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

void RakNet::SQLite3ServerPlugin::RemoveDBHandle | ( | RakNet::RakString | dbIdentifier,
 |  | bool | alsoCloseConnection = false
 | ) |  |

Stop using a dbHandle, lookup either by identifier or by pointer. If SQLite3_STATEMENT_EXECUTE_THREADED is defined, do not call this while processing commands, since the commands run in a thread and might be using the dbHandle Call before closing the handle or else SQLite3Plugin won't know that it was closed, and will continue using it

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/SQLite3Plugin/SQLite3ServerPlugin.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::StatisticsHistoryPlugin Class Reference

  • StatisticsHistoryPlugin
Protected Member Functions | List of all members
RakNet::StatisticsHistoryPlugin Class Reference
Plugins

Input numerical values over time. Get sum, average, highest, lowest, standard deviation on recent or all-time values. More...

#include <StatisticsHistory.h>

Inheritance diagram for RakNet::StatisticsHistoryPlugin:
RakNet::PluginInterface2

Protected Member Functions

virtual void | Update (void)
Update is called every time a packet is checked for .
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)

Additional Inherited Members

- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Detailed Description

Input numerical values over time. Get sum, average, highest, lowest, standard deviation on recent or all-time values.

Member Function Documentation

virtual void RakNet::StatisticsHistoryPlugin::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
protectedvirtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual void RakNet::StatisticsHistoryPlugin::OnNewConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | bool | isIncoming
 | ) |  |
protectedvirtual

Called when we got a new connection

Parameters
[in] | systemAddress | Address of the new connection
[in] | rakNetGuid | The guid of the specified system
[in] | isIncoming | If true, this is ID_NEW_INCOMING_CONNECTION, or the equivalent

Reimplemented from RakNet::PluginInterface2.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/StatisticsHistory.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::TwoWayAuthentication Class Reference

  • TwoWayAuthentication
Public Member Functions | List of all members
RakNet::TwoWayAuthentication Class Reference
Plugins

Implements two way authentication. More...

#include <TwoWayAuthentication.h>

Inheritance diagram for RakNet::TwoWayAuthentication:
RakNet::PluginInterface2

Public Member Functions

bool | AddPassword (RakNet::RakString identifier, RakNet::RakString password)
Adds a password to the list of passwords the system will accept.
bool | Challenge (RakNet::RakString identifier, AddressOrGUID remoteSystem)
Challenge another system for the specified identifier.
void | Clear (void)
Free all memory.
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Detailed Description

Implements two way authentication.

Given two systems, each of whom known a common password / identifier pair, verify the password without transmitting it This can be used to determine what permissions are should be allowed to the other system If the other system should not send any data until authentication passes, you can use the MessageFilter plugin for this. Call MessageFilter::SetAllowMessageID() including ID_TWO_WAY_AUTHENTICATION_NEGOTIATION when doing so. Also attach MessageFilter first in the list of plugins

Note
If other systems challenges us, and fails, you will get ID_TWO_WAY_AUTHENTICATION_INCOMING_CHALLENGE_FAILED.

Member Function Documentation

bool RakNet::TwoWayAuthentication::AddPassword | ( | RakNet::RakString | identifier,
 |  | RakNet::RakString | password
 | ) |  |

Adds a password to the list of passwords the system will accept.

Each password, which is secret and not transmitted, is identified by identifier. identifier is transmitted in plaintext with the request. It is only needed because the system supports multiple password. It is used to only hash against once password on the remote system, rather than having to hash against every known password.

Parameters
[in] | identifier | A unique identifier representing this password. This is transmitted in plaintext and should be considered insecure
[in] | password | The password to add
Returns
True on success, false on identifier==password, either identifier or password is blank, or identifier is already in use
bool RakNet::TwoWayAuthentication::Challenge | ( | RakNet::RakString | identifier,
 |  | AddressOrGUID | remoteSystem
 | ) |  |

Challenge another system for the specified identifier.

After calling Challenge, you will get back ID_TWO_WAY_AUTHENTICATION_SUCCESS, ID_TWO_WAY_AUTHENTICATION_OUTGOING_CHALLENGE_TIMEOUT, or ID_TWO_WAY_AUTHENTICATION_OUTGOING_CHALLENGE_FAILED ID_TWO_WAY_AUTHENTICATION_SUCCESS will be returned if and only if the other system has called AddPassword() with the same identifier pair as this system.

Parameters
[in] identifier A unique identifier representing this password. This is transmitted in plaintext and should be considered insecure
Returns
True on success, false on remote system not connected, or identifier not previously added with AddPassword()
virtual void RakNet::TwoWayAuthentication::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
virtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::TwoWayAuthentication::OnReceive ( Packet * packet )
virtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/TwoWayAuthentication.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::PluginInterface2 Class Reference

  • PluginInterface2
Public Member Functions | List of all members
RakNet::PluginInterface2 Class Reference
PluginInterface2

#include <PluginInterface2.h>

Inheritance diagram for RakNet::PluginInterface2:
RakNet::AutopatcherServer RakNet::CloudClient RakNet::CloudServer RakNet::ConnectionGraph2 RakNet::FileListTransfer RakNet::HTTPConnection2 RakNet::Lobby2Plugin RakNet::MessageFilter RakNet::NatPunchthroughClient RakNet::NatPunchthroughServer RakNet::NatTypeDetectionClient RakNet::NatTypeDetectionServer RakNet::PacketLogger RakNet::RakNetTransport2 RakNet::RakVoice RakNet::ReadyEvent RakNet::RelayPlugin RakNet::ReplicaManager3 RakNet::RoomsPlugin RakNet::Router2 RakNet::RPC3 RakNet::RPC4 RakNet::SQLite3ClientPlugin RakNet::SQLite3ServerPlugin RakNet::StatisticsHistoryPlugin RakNet::TeamBalancer RakNet::TeamManager RakNet::TwoWayAuthentication RakNet::UDPProxyClient RakNet::UDPProxyCoordinator RakNet::UDPProxyServer

Public Member Functions

virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Detailed Description

RakNet's plugin system. Each plugin processes the following events: -Connection attempts -The result of connection attempts -Each incoming message -Updates over time, when RakPeer::Receive() is called

Member Function Documentation

virtual void RakNet::PluginInterface2::OnAck | ( | unsigned int | messageNumber,
 |  | SystemAddress | remoteSystemAddress,
 |  | RakNet::TimeMS | time
 | ) |  |
inlinevirtual

Called when we get an ack for a message we reliably sent

Precondition
To be called, UsesReliabilityLayer() must return true
Parameters
[in] | messageNumber | The numerical identifier for which message this is
[in] | remoteSystemAddress | The player we sent or got this packet from
[in] | time | The current time as returned by RakNet::GetTimeMS()

Reimplemented in RakNet::PacketLogger.

virtual void RakNet::PluginInterface2::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
inlinevirtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented in RakNet::RoomsPlugin, RakNet::RPC3, RakNet::TeamManager, RakNet::ReplicaManager3, RakNet::StatisticsHistoryPlugin, RakNet::AutopatcherServer, RakNet::ReadyEvent, RakNet::RakVoice, RakNet::NatPunchthroughClient, RakNet::MessageFilter, RakNet::Lobby2Server, RakNet::TeamBalancer, RakNet::CloudServer, RakNet::FileListTransfer, RakNet::RelayPlugin, RakNet::UDPProxyServer, RakNet::HTTPConnection2, RakNet::ConnectionGraph2, RakNet::Router2, RakNet::NatPunchthroughServer, RakNet::RakNetTransport2, RakNet::TwoWayAuthentication, RakNet::NatTypeDetectionServer, RakNet::Lobby2Client, RakNet::NatTypeDetectionClient, and RakNet::UDPProxyCoordinator.

virtual void RakNet::PluginInterface2::OnDirectSocketReceive | ( | const char * | data,
 |  | const BitSize_t | bitsUsed,
 |  | SystemAddress | remoteSystemAddress
 | ) |  |
inlinevirtual

Called on a receive from the socket, per datagram, that does not go through the reliability layer

Precondition
To be called, UsesReliabilityLayer() must return true
Parameters
[in] | data | The data being sent
[in] | bitsUsed | How many bits long data is
[in] | remoteSystemAddress | Which system this message is being sent to

Reimplemented in RakNet::PacketLogger.

virtual void RakNet::PluginInterface2::OnDirectSocketSend | ( | const char * | data,
 |  | const BitSize_t | bitsUsed,
 |  | SystemAddress | remoteSystemAddress
 | ) |  |
inlinevirtual

Called on a send to the socket, per datagram, that does not go through the reliability layer

Precondition
To be called, UsesReliabilityLayer() must return true
Parameters
[in] | data | The data being sent
[in] | bitsUsed | How many bits long data is
[in] | remoteSystemAddress | Which system this message is being sent to

Reimplemented in RakNet::PacketLogger.

virtual void RakNet::PluginInterface2::OnFailedConnectionAttempt | ( | Packet * | packet,
 |  | PI2_FailedConnectionAttemptReason | failedConnectionAttemptReason
 | ) |  |
inlinevirtual

Called when a connection attempt fails

Parameters
[in] | packet | Packet to be returned to the user
[in] | failedConnectionReason | Why the connection failed

Reimplemented in RakNet::HTTPConnection2, and RakNet::Router2.

virtual void RakNet::PluginInterface2::OnInternalPacket | ( | InternalPacket * | internalPacket,
 |  | unsigned | frameNumber,
 |  | SystemAddress | remoteSystemAddress,
 |  | RakNet::TimeMS | time,
 |  | int | isSend
 | ) |  |
inlinevirtual

Called on a send or receive of a message within the reliability layer

Precondition
To be called, UsesReliabilityLayer() must return true
Parameters
[in] | internalPacket | The user message, along with all send data.
[in] | frameNumber | The number of frames sent or received so far for this player depending on isSend . Indicates the frame of this user message.
[in] | remoteSystemAddress | The player we sent or got this packet from
[in] | time | The current time as returned by RakNet::GetTimeMS()
[in] | isSend | Is this callback representing a send event or receive event?

Reimplemented in RakNet::PacketLogger.

virtual void RakNet::PluginInterface2::OnNewConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | bool | isIncoming
 | ) |  |
inlinevirtual

Called when we got a new connection

Parameters
[in] | systemAddress | Address of the new connection
[in] | rakNetGuid | The guid of the specified system
[in] | isIncoming | If true, this is ID_NEW_INCOMING_CONNECTION, or the equivalent

Reimplemented in RakNet::TeamManager, RakNet::ReplicaManager3, RakNet::StatisticsHistoryPlugin, RakNet::NatPunchthroughClient, RakNet::MessageFilter, RakNet::HTTPConnection2, RakNet::ConnectionGraph2, RakNet::NatPunchthroughServer, and RakNet::RakNetTransport2.

virtual void RakNet::PluginInterface2::OnPushBackPacket | ( | const char * | data,
 |  | const BitSize_t | bitsUsed,
 |  | SystemAddress | remoteSystemAddress
 | ) |  |
inlinevirtual

System called RakPeerInterface::PushBackPacket

Parameters
[in] | data | The data being sent
[in] | bitsUsed | How many bits long data is
[in] | remoteSystemAddress | The player we sent or got this packet from

Reimplemented in RakNet::PacketLogger.

virtual PluginReceiveResult RakNet::PluginInterface2::OnReceive ( Packet * packet )
inlinevirtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented in RakNet::RoomsPlugin, RakNet::RPC3, RakNet::TeamManager, RakNet::ReplicaManager3, RakNet::RPC4, RakNet::AutopatcherServer, RakNet::ReadyEvent, RakNet::RakVoice, RakNet::NatPunchthroughClient, RakNet::MessageFilter, RakNet::Lobby2Server, RakNet::TeamBalancer, RakNet::UDPProxyClient, RakNet::CloudClient, RakNet::CloudServer, RakNet::FileListTransfer, RakNet::SQLite3ClientPlugin, RakNet::RelayPlugin, RakNet::ConnectionGraph2, RakNet::UDPProxyServer, RakNet::HTTPConnection2, RakNet::Router2, RakNet::NatPunchthroughServer, RakNet::RakNetTransport2, RakNet::TwoWayAuthentication, RakNet::NatTypeDetectionServer, RakNet::Lobby2Client, RakNet::SQLite3ServerPlugin, RakNet::NatTypeDetectionClient, and RakNet::UDPProxyCoordinator.

virtual void RakNet::PluginInterface2::OnReliabilityLayerNotification | ( | const char * | errorMessage,
 |  | const BitSize_t | bitsUsed,
 |  | SystemAddress | remoteSystemAddress,
 |  | bool | isError
 | ) |  |
inlinevirtual

Called when the reliability layer rejects a send or receive

Precondition
To be called, UsesReliabilityLayer() must return true
Parameters
[in] | bitsUsed | How many bits long data is
[in] | remoteSystemAddress | Which system this message is being sent to

Reimplemented in RakNet::PacketLogger.

virtual bool RakNet::PluginInterface2::UsesReliabilityLayer ( void ) const
inlinevirtual

Queried when attached to RakPeer Return true to call OnDirectSocketSend(), OnDirectSocketReceive(), OnReliabilityLayerNotification(), OnInternalPacket(), and OnAck() If true, then you cannot call RakPeer::AttachPlugin() or RakPeer::DetachPlugin() for this plugin, while RakPeer is active

Reimplemented in RakNet::PacketLogger.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/PluginInterface2.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all documented namespaces with brief descriptions:
o N DataStructures |
\ N RakNet | Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: DataStructures Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Functions
DataStructures Namespace Reference

Classes

class | BinarySearchTree
A binary search tree and an AVL balanced binary search tree. More...
class | AVLBalancedBinarySearchTree
An AVLBalancedBinarySearchTree is a binary tree that is always balanced. More...
struct | Page
class | BPlusTree
class | Hash
Using a string as a identifier for a node, store an allocated pointer to that node. More...
class | CircularLinkedList
(Circular) Linked List ADT (Doubly Linked Pointer to Node Style) - More...
class | List
Array based implementation of a list. More...
class | Map
class | MemoryPool
class | MLKeyRef
class | Multilist
The multilist, representing an abstract data type that generally holds lists. More...
class | OrderedList
class | Queue
A queue implemented as an array with a read and write index. More...
class | QueueLinkedList
A queue implemented using a linked list. Rarely used. More...
class | Table
Holds a set of columns, a set of rows, and rows times columns cells. More...
class | SingleProducerConsumer
A single producer consumer implementation without critical sections. More...

Functions

template<class key_type >
int | defaultMapKeyComparison (const key_type &a, const key_type &b)
template<class templateType >
void | DeletePtr_RakNet (templateType &ptr, const char *file, unsigned int line)
template<class templateType >
void | DeletePtr (templateType &ptr)

Detailed Description

The namespace DataStructures was only added to avoid compiler errors for commonly named data structures As these data structures are stand-alone, you can use them outside of RakNet for your own projects if you wish.

Function Documentation

template<class key_type >
int DataStructures::defaultMapKeyComparison | ( | const key_type & | a,
 |  | const key_type & | b
 | ) |  |

The default comparison has to be first so it can be called as a default parameter. It then is followed by MapNode, followed by NodeComparisonFunc

template<class templateType >
void DataStructures::DeletePtr ( templateType & ptr )

Can be used with Multilist::ForEach Assuming the Multilist holds pointers, will delete those pointers

template<class templateType >
void DataStructures::DeletePtr_RakNet | ( | templateType & | ptr,
 |  | const char * | file,
 |  | unsigned int | line
 | ) |  |

Can be used with Multilist::ForEach Assuming the Multilist holds pointers, will delete those pointers

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • c
  • d
  • g
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all documented namespace members with links to the namespaces they belong to:

- _ -

  • __L2_MSG_DB_HEADER() : RakNet

- a -

  • ACTUAL_BYTES_RECEIVED : RakNet
  • ACTUAL_BYTES_SENT : RakNet

- c -

  • CanConnect() : RakNet
  • ConnectionState : RakNet

- d -

  • defaultMapKeyComparison() : DataStructures
  • DeletePtr() : DataStructures
  • DeletePtr_RakNet() : DataStructures

- g -

  • GetTime() : RakNet
  • GetTimeMS() : RakNet
  • GetTimeUS() : RakNet
  • GreaterThan() : RakNet

- i -

  • IS_CONNECTED : RakNet
  • IS_CONNECTING : RakNet
  • IS_DISCONNECTED : RakNet
  • IS_DISCONNECTING : RakNet
  • IS_NOT_CONNECTED : RakNet
  • IS_PENDING : RakNet
  • IS_SILENTLY_DISCONNECTING : RakNet

- j -

  • JOIN_ANY_AVAILABLE_TEAM : RakNet
  • JOIN_NO_TEAM : RakNet
  • JOIN_SPECIFIC_TEAM : RakNet
  • JoinTeamType : RakNet

- l -

  • LCR_CLOSED_BY_USER : RakNet
  • LCR_CONNECTION_LOST : RakNet
  • LCR_DISCONNECTION_NOTIFICATION : RakNet
  • LessThan() : RakNet
  • Lobby2MessageID : RakNet

- m -

  • MessageID : RakNet
  • MessageNumberType : RakNet

- n -

  • NAT_TYPE_ADDRESS_RESTRICTED : RakNet
  • NAT_TYPE_DETECTION_IN_PROGRESS : RakNet
  • NAT_TYPE_FULL_CONE : RakNet
  • NAT_TYPE_NONE : RakNet
  • NAT_TYPE_PORT_RESTRICTED : RakNet
  • NAT_TYPE_SUPPORTS_UPNP : RakNet
  • NAT_TYPE_SYMMETRIC : RakNet
  • NAT_TYPE_UNKNOWN : RakNet
  • NATTypeDetectionResult : RakNet
  • NATTypeDetectionResultToString() : RakNet
  • NATTypeDetectionResultToStringFriendly() : RakNet
  • NoTeamId : RakNet

- o -

  • OrderingIndexType : RakNet

- p -

  • PI2_FailedConnectionAttemptReason : RakNet
  • PI2_LostConnectionReason : RakNet
  • PKM_ACCEPT_ANY_PUBLIC_KEY : RakNet
  • PKM_INSECURE_CONNECTION : RakNet
  • PKM_USE_KNOWN_PUBLIC_KEY : RakNet
  • PKM_USE_TWO_WAY_AUTHENTICATION : RakNet
  • PluginReceiveResult : RakNet
  • PublicKeyMode : RakNet

- r -

  • R3P2PM_MULTI_OWNER_CURRENTLY_AUTHORITATIVE : RakNet
  • R3P2PM_MULTI_OWNER_NOT_CURRENTLY_AUTHORITATIVE : RakNet
  • R3P2PM_SINGLE_OWNER : RakNet
  • R3P2PM_STATIC_OBJECT_CURRENTLY_AUTHORITATIVE : RakNet
  • R3P2PM_STATIC_OBJECT_NOT_CURRENTLY_AUTHORITATIVE : RakNet
  • RackspaceEventType : RakNet
  • ReadyEventSystemStatus : RakNet
  • RegisteredCommandComp() : RakNet
  • Replica3P2PMode : RakNet
  • RES_ALL_READY : RakNet
  • RES_NOT_WAITING : RakNet
  • RES_READY : RakNet
  • RES_UNKNOWN_EVENT : RakNet
  • RES_WAITING : RakNet
  • RM3ConstructionState : RakNet
  • RM3CS_ALREADY_EXISTS_REMOTELY : RakNet
  • RM3CS_ALREADY_EXISTS_REMOTELY_DO_NOT_CONSTRUCT : RakNet
  • RM3CS_MAX : RakNet
  • RM3CS_NEVER_CONSTRUCT : RakNet
  • RM3CS_NO_ACTION : RakNet
  • RM3CS_SEND_CONSTRUCTION : RakNet
  • RM3DestructionState : RakNet
  • RM3DS_DO_NOT_QUERY_DESTRUCTION : RakNet
  • RM3DS_MAX : RakNet
  • RM3DS_NO_ACTION : RakNet
  • RM3DS_SEND_DESTRUCTION : RakNet
  • RM3QSR_CALL_SERIALIZE : RakNet
  • RM3QSR_DO_NOT_CALL_SERIALIZE : RakNet
  • RM3QSR_MAX : RakNet
  • RM3QSR_NEVER_CALL_SERIALIZE : RakNet
  • RM3QuerySerializationResult : RakNet
  • RM3SerializationResult : RakNet
  • RM3SR_BROADCAST_IDENTICALLY : RakNet
  • RM3SR_BROADCAST_IDENTICALLY_FORCE_SERIALIZATION : RakNet
  • RM3SR_DO_NOT_SERIALIZE : RakNet
  • RM3SR_MAX : RakNet
  • RM3SR_NEVER_SERIALIZE_FOR_THIS_CONNECTION : RakNet
  • RM3SR_SERIALIZED_ALWAYS : RakNet
  • RM3SR_SERIALIZED_ALWAYS_IDENTICALLY : RakNet
  • RM3SR_SERIALIZED_UNIQUELY : RakNet
  • RNSPerSecondMetrics : RakNet
  • RPC_ERROR_CALLING_C_AS_CPP : RakNet
  • RPC_ERROR_CALLING_CPP_AS_C : RakNet
  • RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE : RakNet
  • RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED : RakNet
  • RPC_ERROR_FUNCTION_NOT_REGISTERED : RakNet
  • RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE : RakNet
  • RPC_ERROR_OBJECT_DOES_NOT_EXIST : RakNet
  • RPCErrorCodes : RakNet
  • RR_CONTINUE_PROCESSING : RakNet
  • RR_STOP_PROCESSING : RakNet
  • RR_STOP_PROCESSING_AND_DEALLOCATE : RakNet

- s -

  • StatisticsToString() : RakNet

- t -

  • TeamId : RakNet
  • TeamMemberLimit : RakNet

- u -

  • UNASSIGNED_NETWORK_ID : RakNet
  • UNASSIGNED_PLAYER_INDEX : RakNet
  • UNASSIGNED_SYSTEM_ADDRESS : RakNet
  • UniqueIDType : RakNet
  • USER_MESSAGE_BYTES_PUSHED : RakNet
  • USER_MESSAGE_BYTES_RECEIVED_IGNORED : RakNet
  • USER_MESSAGE_BYTES_RECEIVED_PROCESSED : RakNet
  • USER_MESSAGE_BYTES_RESENT : RakNet
  • USER_MESSAGE_BYTES_SENT : RakNet

- w -

  • WorldId : RakNet
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • __L2_MSG_DB_HEADER() : RakNet
  • CanConnect() : RakNet
  • defaultMapKeyComparison() : DataStructures
  • DeletePtr() : DataStructures
  • DeletePtr_RakNet() : DataStructures
  • GetTime() : RakNet
  • GetTimeMS() : RakNet
  • GetTimeUS() : RakNet
  • GreaterThan() : RakNet
  • LessThan() : RakNet
  • NATTypeDetectionResultToString() : RakNet
  • NATTypeDetectionResultToStringFriendly() : RakNet
  • RegisteredCommandComp() : RakNet
  • StatisticsToString() : RakNet
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • UNASSIGNED_NETWORK_ID : RakNet
  • UNASSIGNED_PLAYER_INDEX : RakNet
  • UNASSIGNED_SYSTEM_ADDRESS : RakNet
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • MessageID : RakNet
  • MessageNumberType : RakNet
  • NoTeamId : RakNet
  • OrderingIndexType : RakNet
  • TeamId : RakNet
  • TeamMemberLimit : RakNet
  • UniqueIDType : RakNet
  • WorldId : RakNet
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • ConnectionState : RakNet
  • JoinTeamType : RakNet
  • Lobby2MessageID : RakNet
  • NATTypeDetectionResult : RakNet
  • PI2_FailedConnectionAttemptReason : RakNet
  • PI2_LostConnectionReason : RakNet
  • PluginReceiveResult : RakNet
  • PublicKeyMode : RakNet
  • RackspaceEventType : RakNet
  • ReadyEventSystemStatus : RakNet
  • Replica3P2PMode : RakNet
  • RM3ConstructionState : RakNet
  • RM3DestructionState : RakNet
  • RM3QuerySerializationResult : RakNet
  • RM3SerializationResult : RakNet
  • RNSPerSecondMetrics : RakNet
  • RPCErrorCodes : RakNet
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • i
  • j
  • l
  • n
  • p
  • r
  • u

- a -

  • ACTUAL_BYTES_RECEIVED : RakNet
  • ACTUAL_BYTES_SENT : RakNet

- i -

  • IS_CONNECTED : RakNet
  • IS_CONNECTING : RakNet
  • IS_DISCONNECTED : RakNet
  • IS_DISCONNECTING : RakNet
  • IS_NOT_CONNECTED : RakNet
  • IS_PENDING : RakNet
  • IS_SILENTLY_DISCONNECTING : RakNet

- j -

  • JOIN_ANY_AVAILABLE_TEAM : RakNet
  • JOIN_NO_TEAM : RakNet
  • JOIN_SPECIFIC_TEAM : RakNet

- l -

  • LCR_CLOSED_BY_USER : RakNet
  • LCR_CONNECTION_LOST : RakNet
  • LCR_DISCONNECTION_NOTIFICATION : RakNet

- n -

  • NAT_TYPE_ADDRESS_RESTRICTED : RakNet
  • NAT_TYPE_DETECTION_IN_PROGRESS : RakNet
  • NAT_TYPE_FULL_CONE : RakNet
  • NAT_TYPE_NONE : RakNet
  • NAT_TYPE_PORT_RESTRICTED : RakNet
  • NAT_TYPE_SUPPORTS_UPNP : RakNet
  • NAT_TYPE_SYMMETRIC : RakNet
  • NAT_TYPE_UNKNOWN : RakNet

- p -

  • PKM_ACCEPT_ANY_PUBLIC_KEY : RakNet
  • PKM_INSECURE_CONNECTION : RakNet
  • PKM_USE_KNOWN_PUBLIC_KEY : RakNet
  • PKM_USE_TWO_WAY_AUTHENTICATION : RakNet

- r -

  • R3P2PM_MULTI_OWNER_CURRENTLY_AUTHORITATIVE : RakNet
  • R3P2PM_MULTI_OWNER_NOT_CURRENTLY_AUTHORITATIVE : RakNet
  • R3P2PM_SINGLE_OWNER : RakNet
  • R3P2PM_STATIC_OBJECT_CURRENTLY_AUTHORITATIVE : RakNet
  • R3P2PM_STATIC_OBJECT_NOT_CURRENTLY_AUTHORITATIVE : RakNet
  • RES_ALL_READY : RakNet
  • RES_NOT_WAITING : RakNet
  • RES_READY : RakNet
  • RES_UNKNOWN_EVENT : RakNet
  • RES_WAITING : RakNet
  • RM3CS_ALREADY_EXISTS_REMOTELY : RakNet
  • RM3CS_ALREADY_EXISTS_REMOTELY_DO_NOT_CONSTRUCT : RakNet
  • RM3CS_MAX : RakNet
  • RM3CS_NEVER_CONSTRUCT : RakNet
  • RM3CS_NO_ACTION : RakNet
  • RM3CS_SEND_CONSTRUCTION : RakNet
  • RM3DS_DO_NOT_QUERY_DESTRUCTION : RakNet
  • RM3DS_MAX : RakNet
  • RM3DS_NO_ACTION : RakNet
  • RM3DS_SEND_DESTRUCTION : RakNet
  • RM3QSR_CALL_SERIALIZE : RakNet
  • RM3QSR_DO_NOT_CALL_SERIALIZE : RakNet
  • RM3QSR_MAX : RakNet
  • RM3QSR_NEVER_CALL_SERIALIZE : RakNet
  • RM3SR_BROADCAST_IDENTICALLY : RakNet
  • RM3SR_BROADCAST_IDENTICALLY_FORCE_SERIALIZATION : RakNet
  • RM3SR_DO_NOT_SERIALIZE : RakNet
  • RM3SR_MAX : RakNet
  • RM3SR_NEVER_SERIALIZE_FOR_THIS_CONNECTION : RakNet
  • RM3SR_SERIALIZED_ALWAYS : RakNet
  • RM3SR_SERIALIZED_ALWAYS_IDENTICALLY : RakNet
  • RM3SR_SERIALIZED_UNIQUELY : RakNet
  • RPC_ERROR_CALLING_C_AS_CPP : RakNet
  • RPC_ERROR_CALLING_CPP_AS_C : RakNet
  • RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE : RakNet
  • RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED : RakNet
  • RPC_ERROR_FUNCTION_NOT_REGISTERED : RakNet
  • RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE : RakNet
  • RPC_ERROR_OBJECT_DOES_NOT_EXIST : RakNet
  • RR_CONTINUE_PROCESSING : RakNet
  • RR_STOP_PROCESSING : RakNet
  • RR_STOP_PROCESSING_AND_DEALLOCATE : RakNet

- u -

  • USER_MESSAGE_BYTES_PUSHED : RakNet
  • USER_MESSAGE_BYTES_RECEIVED_IGNORED : RakNet
  • USER_MESSAGE_BYTES_RECEIVED_PROCESSED : RakNet
  • USER_MESSAGE_BYTES_RESENT : RakNet
  • USER_MESSAGE_BYTES_SENT : RakNet
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 123]
o N DataStructures |
| o C BinarySearchTree | A binary search tree and an AVL balanced binary search tree
| o C AVLBalancedBinarySearchTree | An AVLBalancedBinarySearchTree is a binary tree that is always balanced
| o C Page |
| o C BPlusTree |
| o C Hash | Using a string as a identifier for a node, store an allocated pointer to that node
| o C CircularLinkedList | (Circular) Linked List ADT (Doubly Linked Pointer to Node Style) -
| o C List | Array based implementation of a list
| o C Map |
| o C MemoryPool |
| o C MLKeyRef |
| o C Multilist | The multilist, representing an abstract data type that generally holds lists
| o C OrderedList |
| o C Queue | A queue implemented as an array with a read and write index
| o C QueueLinkedList | A queue implemented using a linked list. Rarely used
| o C Table | Holds a set of columns, a set of rows, and rows times columns cells
| | o C Cell | Holds the actual data in the table
| | o C ColumnDescriptor |
| | \ C Row | Stores the list of cells for this row, and a special flag used for internal sorting
| \ C SingleProducerConsumer | A single producer consumer implementation without critical sections
o N RakNet | Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc
| o C AutopatcherRepositoryInterface | An interface used by AutopatcherServer to get the data necessary to run an autopatcher. This is up to you to implement for custom repository solutions
| o C BitStream |
| o C CloudClient | Performs Post() and Get() operations on CloudMemoryServer
| o C CloudClientCallback |
| o C CloudAllocator |
| o C CloudKey |
| o C CloudQuery |
| o C CloudServerQueryFilter | Zero or more instances of CloudServerQueryFilter can be attached to CloudServer to restrict client queries All attached instances of CloudServerQueryFilter on each corresponding operation, from all directly connected clients If any attached instance returns false for a given operation, that operation is silently rejected
| o C CloudServer | Stores client data, and allows cross-server communication to retrieve this data
| o C CommandParserInterface | The interface used by command parsers
| o C ConnectionGraph2 | A one hop connection graph
| o C ConsoleServer | The main entry point for the server portion of your remote console application support
| o C DataCompressor | Does compression on a block of data. Not very good compression, but it's small and fast so is something you can compute at runtime
| o C HuffmanEncodingTree | This generates special cases of the huffman encoding tree using 8 bit keys with the additional condition that unused combinations of 8 bits are treated as a frequency of 1
| o C HuffmanEncodingTreeFactory | Creates instances of the class HuffmanEncodingTree
| o C EmailSender | Rudimentary class to send email from code
| o C FileListNode | Represents once instance of a file
| o C FileListProgress | Callback interface set with FileList::SetCallback() in case you want progress notifications when FileList::AddFilesFromDirectory() is called
| o C FLP_Printf | Implementation of FileListProgress to use RAKNET_DEBUG_PRINTF
| o C FileListTransfer | A plugin to provide a simple way to compress and incrementally send the files in the FileList structure
| o C FileListTransferCBInterface | Used by FileListTransfer plugin as a callback for when we get a file
| o C HTTPConnection | Use HTTPConnection to communicate with a web server
| | \ C BadResponse | Encapsulates a raw HTTP response and response code
| o C HTTPConnection2 | Use HTTPConnection2 to communicate with a web server
| o C InternalPacketRefCountedData | Used in InternalPacket when pointing to sharedDataBlock, rather than allocating itself
| o C InternalPacket |
| o C LogCommandParser | Adds the ability to send logging output to a remote console
| | \ C SystemAddressAndChannel | One of these structures is created per player
| o C MessageFilter | Assigns systems to FilterSets. Each FilterSet limits what kinds of messages are allowed
| o C NatPunchthroughClient | Client code for NATPunchthrough
| o C NatPunchthroughServer | Server code for NATPunchthrough
| o C NatTypeDetectionClient | Client code for NatTypeDetection
| o C NatTypeDetectionServer | Server code for NatTypeDetection
| o C NetworkIDManager |
| o C NetworkIDObject | Unique shared ids for each object instance
| o C PacketConsoleLogger | Packetlogger that logs to a remote command console
| o C PacketFileLogger | Packetlogger that outputs to a file
| o C PacketLogger | Writes incoming and outgoing messages to the screen. This will write all incoming and outgoing messages to the console window, or to a file if you override it and give it this functionality
| o C PacketOutputWindowLogger | Packetlogger that outputs to the output window in the debugger. Windows only
| o C PluginInterface2 |
| o C Rackspace2EventCallback | Callback interface to receive the results of operations
| o C RackspaceEventCallback_Default | Callback interface to receive the results of operations, with a default result
| o C Rackspace | Code that uses the TCPInterface class to communicate with the Rackspace API servers
| o C RakNetCommandParser | This allows a console client to call most of the functions in RakPeer
| o C RakNetStatistics | Network Statisics Usage
| o C RakNetTransport2 | Use RakNetTransport if you need a secure connection between the client and the console server
| o C PublicKey | Passed to RakPeerInterface::Connect()
| o C SocketDescriptor | Describes the local socket to use for RakPeer::Startup
| o C SystemAddress | Network address for a system
| o C RakNetGUID |
| o C Packet | This represents a user message from another system
| o C RakPeer | Main interface for network communications
| o C RakPeerInterface | The main interface for network communications
| o C RakString | String class
| o C RakWString | String class for Unicode
| o C ReadyEvent | Peer to peer synchronized ready and unready events
| o C RelayPlugin | A simple class to relay messages from one system to another, identifying remote systems by a string
| o C ReliabilityLayer | Datagram reliable, ordered, unordered and sequenced sends. Flow control. Message splitting, reassembly, and coalescence
| o C ReplicaManager3 | System to help automate game object construction, destruction, and serialization
| o C LastSerializationResult |
| o C SerializeParameters |
| o C Connection_RM3 | Each remote system is represented by Connection_RM3. Used to allocate Replica3 and track which instances have been allocated
| o C Replica3 | Base class for your replicated objects for the ReplicaManager3 system
| o C Replica3Composite | Use Replica3 through composition instead of inheritance by containing an instance of this templated class Calls to parent class for all functions Parent class must still define and functions though!
| o C Router2 | Class interface for the Router2 system
| o C RPC4GlobalRegistration | Instantiate this class globally if you want to register a function with RPC4 at the global space
| o C RPC4 | The RPC4 plugin is just an association between a C function pointer and a string
| o C SimpleMutex | An easy to use mutex
| o C StatisticsHistory | Input numerical values over time. Get sum, average, highest, lowest, standard deviation on recent or all-time values
| o C StatisticsHistoryPlugin | Input numerical values over time. Get sum, average, highest, lowest, standard deviation on recent or all-time values
| o C StringCompressor | Writes and reads strings to and from bitstreams
| o C StringTable | Writes a string index, instead of the whole string
| o C RemoteClient | Stores information about a remote client
| o C TeamBalancer | Set and network team selection (supports peer to peer or client/server)
| o C TeamSelection | Parameter to TM_World::ReferenceTeamMember()
| o C TM_TeamMember | A member of one or more teams
| o C TM_Team | A team, containing a list of TM_TeamMember instances
| o C TM_World | Stores a list of teams which may be enforcing a balanced number of members
| o C TeamManager | Automates networking and list management for teams
| o C TelnetTransport | Use TelnetTransport to easily allow windows telnet to connect to your ConsoleServer
| o C ThreadsafePacketLogger | Same as PacketLogger, but writes output in the user thread
| o C TransportInterface | Defines an interface that is used to send and receive null-terminated strings
| o C TwoWayAuthentication | Implements two way authentication
| o C UDPForwarder | Forwards UDP datagrams. Independent of RakNet's protocol
| o C UDPProxyClientResultHandler |
| o C UDPProxyClient | Communicates with UDPProxyCoordinator, in order to find a UDPProxyServer to forward our datagrams
| o C UDPProxyCoordinator | Middleman between UDPProxyServer and UDPProxyClient, maintaining a list of UDPProxyServer, and managing state for clients to find an available forwarding server
| o C UDPProxyServerResultHandler |
| o C UDPProxyServer | UDPProxyServer to control our instance of UDPForwarder
| o C VariableDeltaSerializer | Class to compare memory values of variables in a current state to a prior state Results of the comparisons will be written to a bitStream, such that only changed variables get written Can be used with ReplicaManager3 to Serialize a Replica3 per-variable, rather than comparing the entire object against itself Usage: BR>
| o C VariableListDeltaTracker |
| o C RakVoice | Voice compression and transmission interface
| o C AutopatcherServerLoadNotifier_Printf | Sample implementation of AutopatcherServerLoadNotifier using printf
| o C AutopatcherServer | The server plugin for the autopatcher. Must be running for the client to get patches
| | \ C ResultTypeAndBitstream |
| o C AutopatcherPostgreRepository |
| o C Lobby2Client | Class used to send commands to Lobby2Server
| o C Lobby2Message | A Lobby2Message encapsulates a networked function call from the client
| o C Lobby2Callbacks |
| o C Lobby2Printf |
| o C IndexedIntegerValue | Used to unify different platforms for room search and search properties. Only applies if specifically used
| o C IndexedBinaryValue | Used to unify different platforms for room search and search properties. Only applies if specifically used
| o C Platform_Startup | Platform specific startup. Unused on the PC
| o C Platform_Shutdown | Platform specific startup. Unused on the PC
| o C System_CreateDatabase | Create all tables and stored procedures on a system that does not already have them
| o C System_DestroyDatabase | Destroy all tables and stored procedures created with System_CreateDatabase
| o C System_CreateTitle | Each title essentially corresponds to a game. For example, the same lobby system may be used for both asteroids and Pac-man. When logging in, and for some functions, it is necessary to specify which title you are logging in under. This way users playing asteroids do not interact with users playing pac-man, where such interations are game specific (such as ranking)
| o C System_DestroyTitle | Destroy a previously added title
| o C System_GetTitleRequiredAge | Get the required age set with System_CreateTitle
| o C System_GetTitleBinaryData | Get the binary data set with System_CreateTitle
| o C System_RegisterProfanity | Adds the input strings to a table of profanity. non-unique or empty strings can be ignored. This table will be used internally to ensure that handles and clan names do not contain profanity. Multiple calls add to the table. This table will be used for functions that take a user-defined string that is highly visible, such as clan and user names. It does not need to be checked for emails or message boards
| o C System_BanUser | Bans a specific user (will be most likely called by a moderator). Adds the user's primary key to a ban table, along with the name of the moderator, the reason for the ban. Banning is used to prevent the banned user from logging on for some specified duration. A date column should be present and automatically filled in. When bans are expired, the ban can be deleted from the database. However, a separate table should log bans, so that even expired bans can be looked up in case
| o C System_UnbanUser | Unban a user banned with System_BanUser
| o C CDKey_Add | Adds CDKeys to the database. Duplicate CDKeys for a particular title are ignored. CDKeys can be identical for different titles
| o C CDKey_GetStatus | Returns if a CD key was previously added with AddCDKey
| o C CDKey_Use | Associates a cd key with a user, such that the cd key cannot be used again. If Client_Login() is called with check cd key as true, then this table will be checked to make sure UserCDKey() was previously called with this user and a valid key. If this user is already associated with a CD Key, add the new key, and use the most recent key. All CD Key usage should be logged in a separate table, including the date used and result
| o C CDKey_FlagStolen | Flags one or more CD keys as stolen. Stolen CD keys will prevent Client_Login() if check cd key is true. They will also prevent these cd keys from being used with CDKey_Use. If this key is already in use by certain users for this particular title, then log this similarly to how CDKey_Use does so
| o C Client_Login | Logon with a previously registered account
| o C Client_Logoff | Logoff, after logging in
| o C Client_RegisterAccount | This creates a new account in the database, which can be used in a subsequent call to Login. Most parameters are optional. handle is not optional, and must be unique using case-insensitive compare. emailAddress should be validated to have a sensible format, including an @ sign and a period with a 3 letter extension. allowLoginWithoutEmailAddressValidation is used in Client_Login to potentially disallow logon attempts with unverified email addresses
| o C System_SetEmailAddressValidated | For the client with the given handle, mark a column emailAddressValidated as true or false as appropriate. This is potentially used in Client_Login
| o C Client_ValidateHandle | Looks up in the database if this handle is already in use, subject to the usual constraints of handles. This will be used by the user to quickly check for available handles
| o C System_DeleteAccount | Flags as deleted an account registered with RegisterAccount. Accounts are not actually deleted, only tagged as deleted
| o C System_PruneAccounts | Unused accounts are deleted. This is cascading, such that emails and other tables that reference this key are also deleted. unused accounts are defined as:
| o C Client_GetEmailAddress | Returns the email address associated with a specific handle, invalid handle. This is used for password recovery
| o C Client_GetPasswordRecoveryQuestionByHandle | Returns the passwordRecoveryQuestion associated with handle, invalid handle
| o C Client_GetPasswordByPasswordRecoveryAnswer | Returns the password associated with a handle, if the passwordRecoveryAnswer is correct
| o C Client_ChangeHandle | Changes the handle for a user
| o C Client_UpdateAccount | Will update any or all of the inputs that were previously passed to Client_RegisterAccount, except handle
| o C Client_GetAccountDetails | Get the parameters set with Client_RegisterAccount
| o C Client_StartIgnore | Adds the specified user to an ignore list for my user. Recommended to store the primary key of the remote user, both for speed and so if the other use changes their handle it still works. The ignore list is checked for friend invites, emails, and elsewhere where indicated. Ignoring is uni-directional, so if A ignores B, A will block messages from B where appropriate, but B will not immediately block messages from A
| o C Client_StopIgnore | Removes an entry in the database such that myHandle will no longer ignore theirHandle
| o C Client_GetIgnoreList | Returns all users I have ignored
| o C Client_PerTitleBinaryStorage | For each combination of user and title, structures can be stored
| o C Client_SetPresence | Sets in-memory information about your login state, such as which game you are playing, or if you are playing a game Online friends will be notified when you presence changes For the XBOX, just use XUserSetProperty and XUserSetContext directly, as there is no analogue to this function
| o C Client_GetPresence | Gets in-memory information about a user's login state, such as which game they are playing, or if they are playing a game This can also be a quick way to query if a user is logged in or not. If they are not logged in, presence will be set to Lobby2Presence::NOT_ONLINE
| o C Friends_SendInvite | Stores in the database an add friend invite from my handle to their handle. The combination of my handle and their handle must be unique, so you cannot send more than one add friend invite to a single user. Sends an email to their handle the subject, body, and binary data. Note: if myHandle is ignored by theirHandle, then the function fails. See Client_StartIgnore
| o C Friends_AcceptInvite | Stores in the database that this user is now my friend. This is bidirectional, which is to say if someone accepts an add friend invite, they are my friend, and I am their friend. Recommended to store by primary key for speed and in case the friend's handle changes. Store in the emails table from my handle to their handle the subject, body, and binary data. Note: if myHandle is ignored by theirHandle, then the function fails. See AddToIgnoreList
| o C Friends_RejectInvite | Removes from the database the pending add friend invite. Operation completes even if ignored. Unless ignored, store in the emails table from my handle to their handle the subject, body, binary data, and procedure type flag
| o C Friends_GetInvites | Returns all invites for this user
| o C Friends_GetFriends | Gets all friends to this user
| o C Friends_Remove | Ends a friendship between two users. Remove from the database the friend entry between my handle and their handle. As with accept add friend invite, this is bidirectional. Either user can terminate the friendship. Store in the emails table from my handle to their handle the subject, body, and binary data, and procedure type flag
| o C BookmarkedUsers_Add | Remembers a user, with a type integer and description for you to use, if desired
| o C BookmarkedUsers_Remove | Remove a user added with BookmarkedUsers_Add
| o C BookmarkedUsers_Get | Returns all users added to BookmarkedUsers_Add
| o C Emails_Send | Adds to an emails table from myHandle (store primary key) to recipient handles (store primary key) the specified subject, body, and binary data. Emails are persistent, therefore emails should be stored in a separate table and referenced by the user. Deleting the user does not delete previously send email. Emails should have an automatic timestamp to store when they were created. Email should be flagged as sent=true (boolean), markedRead=true (boolean), deletedBySender=false (boolean), deletedByReciever=false (boolean)
| o C Emails_Get | Returns emails as noted. Emails which were marked deleted are not returned
| o C Emails_Delete | Deletes an email with a specified ID. This ID is returned in GetEmail and should uniquely identify an email (it's fine to use the primary key). Note: Emails are not actually deleted from the database in this function. This just sets the deletedBySender or deletedByReciever flags. Emails are actually stored in a log recording past emails and sender and receiver primary key. They are not truly destroyed until done so with System_PruneAccounts
| o C Emails_SetStatus | Sets the status flag for an email. This is a property defined by and used by the user
| o C Ranking_SubmitMatch | Will record in the database the results of a match. This will store in the database the the match which is defined by the the match notes, match id, winner and loser participant primary keys, winner and loser participant scores, and binary data
| o C Ranking_GetMatches | Gets matches recorded with Ranking_SubmitMatch ordered from most recent to least recent. Each returned match has all columns submitted to Ranking_SubmitMatch, except binary data, which can be retrieved with Ranking_GetMatchBinaryData. Additionally, each returned match returns the primary key of each match, to be passed to Ranking_GetMatchBinaryData
| o C Ranking_GetMatchBinaryData | Because of the large amount of binary data potentially returned, this function is used to retrieve binary data for a particular match
| o C Ranking_GetTotalScore | When a match is submitted with Ranking_SubmitMatch, the total running score and number of matches played for each player for each game title and game mode combination should be recorded. Because matches can be pruned wth PruneMatches(), the total score sum and number of scores submitted should be stored, rather than summed up from prior submitted matches
| o C Ranking_WipeScoresForPlayer | Resets the sum of all submitted scores to 0, the number of scores submitted to 0
| o C Ranking_WipeMatches | Deletes all matches submitted with submit match. Also deletes all scores for all players associated with this titleName and gameType (e.g. same thing that WipeScoresForPlayer does, but for all players)
| o C Ranking_PruneMatches | Will delete all matches submitted with SubmitMatch over PruneTime days old. Will also prune matches if the total storage space of all matches exceeds PruneSizeMB megabytes in the database
| o C Ranking_UpdateRating | Add or update a rating for a user, in a particular game and game mode
| o C Ranking_WipeRatings | Deletes all ratings for all players for this combination of titleName and gameType
| o C Ranking_GetRating | Get rating for a player
| o C Clans_Create | UserHandle updates the clanDescription and clanBinaryData of a clan with the specified clanHandle. userHandle must be the clan leader
| o C Clans_SetProperties | UserHandle updates the clanDescription and clanBinaryData of a clan with the specified clanHandle. userHandle must be the clan leader
| o C Clans_GetProperties | Returns clanDescription and clanBinaryData for the given clan
| o C Clans_SetMyMemberProperties | Each member of each clan has the the properties clanMemberDescription and clanMemberBinaryData which default to empty. These properties can be set here, and retrieved via GetClanMemberProperties
| o C Clans_GrantLeader | MyPrimaryKey becomes a subleader. newLeaderHandle becomes the leader. An email is sent with Emails_Send() to all members with the specified subject and body
| o C Clans_SetSubleaderStatus | Promotes a clan member to a subleader, or demotes a subleader to a regular member. On promotion, email is sent to all members from myPrimary key with the specified subject and body. On demotion, email is sent to all leaders from myPrimary key with the specified subject and body
| o C Clans_SetMemberRank | Lets the clan leader set the rank property for a clan member
| o C Clans_GetMemberProperties | Returns properties for a clan member of a given clan
| o C Clans_ChangeHandle | Renames the clan. Note that this may be called asynchronously, in which case the stored procedure should account for this occuring at the same time as another function that uses the old clan handle
| o C Clans_Leave | Remove user identified by myPrimaryKey from clan identified by clanHandle
| o C Clans_Get | Returns all clans that userHandle is a member of. Clans and clan members should be sorted by name, using ascending or descending sort as specified
| o C Clans_SendJoinInvitation | If myPrimaryKey is a leader or subleader of clanHandle, and invitedUserHandle is a valid user not already invited to this clan, add this user to the invite table. The invite table contains the clan, who send the invite, and who the invite was sent to, and when it was sent. Invites expire after expiration time in seconds. Also, use Emails_Send() to send an email from myPrimaryKey to invitedUserHandle with the specified subject and body
| o C Clans_WithdrawJoinInvitation | If myPrimaryKey is a leader or subleader of clanHandle, and invitedUserHandle is a valid user with an invite to this clan, remove this invite. Also, use Emails_Send() to send an email from myPrimaryKey to invitedUserHandle with the specified subject and body
| o C Clans_AcceptJoinInvitation | If myPrimaryKey has an invitation to the specified clan, add him to the clan. Fail on specified output parameters. Use Emails_Send() to send an email from myPrimaryKey to all clan members with the specified subject and body
| o C Clans_RejectJoinInvitation | If we have an open clan invitation, reject it (just delete it from the database)
| o C Clans_DownloadInvitationList | Returns all invites sent by Clans_SendJoinInvitation that were not yet acted upon (withdrawn, accepted, rejected)
| o C Clans_SendJoinRequest | Function has two forms:
| o C Clans_WithdrawJoinRequest | Withdraws a previously sent clan join request via SendClanJoinRequest. Use Emails_Send() to send an email from myPrimaryKey to the clan leader and all subleaders with the specified subject and body
| o C Clans_AcceptJoinRequest | A clan leader or subleader accepts a join request from requestingUserHandle to this clan. requestingUserHandle joins the clan as a regular member. Use Emails_Send() to send an email from requestingUserHandle to all clan members with the specified subject and body
| o C Clans_RejectJoinRequest | Rejects a clan join request from requestingUserHandle. Send an email from myPrimaryKey to requestingUserHandle with the specified subject and body
| o C Clans_DownloadRequestList | Returns all open requests this user has sent to clans, that have not yet acted upon (withdrawn, accepted, rejected, expired)
| o C Clans_KickAndBlacklistUser | Kicks a user from the clan and/or blacklists a user so they cannot join. Only a clan leader or subleader can perform this operation. The operation can only be performed on members of lower status (leader can perform on subleader or regular member or nonmember, subleader on regular members or nonmember). If a member is banned, they are added to the banned table which contains the member's primary key, which user banned them, and the reason. Email is sent from myPrimaryKey to all leaders if a clan member is banned. Emails is furthermore sent to all clan members if successfully kicked
| o C Clans_UnblacklistUser | Removes a user from the blacklist for this clan
| o C Clans_GetBlacklist | Returns a list of all members blacklisted from this clan. Each element in the list contains the handle of the user that did the ban, who was banned, when the user was banned, and the reason passed to ClanKickAndBlacklistUser
| o C Clans_GetMembers | Returns all clan members for this clan. Each entry returned contains handle, description, binary data, status (leader, regular member, subleader)
| o C Clans_GetList | Returns all clans names
| o C Clans_CreateBoard | Creates a new clan board for clan members to post in using AddPostToClanBoard. Clan boards are unique, and are destroyed when the clan is destroyed, or if DestroyClanBoard is called
| o C Clans_DestroyBoard | Success, invalid parameter syntax, myPrimaryKey is not the leader or subleader of clanHandle, unknown myPrimaryKey, unknown clanHandle, unknown clanBoardName
| o C Clans_CreateNewTopic | Each clan has a clan board that only clan members can post to. This adds a topic to the clan board. Posts should reference the primary key of the poster, so that even if the poster chagnes his or her handle, the post author is updated properly. Each post automatically stores the timestamp when it was created. Banned users may not add new posts to the clan board
| o C Clans_ReplyToTopic | Replies to a topic created with Clans_CreateTopic(). If postId references a post within a topic, just add the reply to the last post. Banned users may not add new posts to the clan board
| o C Clans_RemovePost | The clan leader or subleaders may remove posts or topics from a clan board
| o C Clans_GetBoards | Gets clan boards created for clanHandle. Boards are returned if we are a clan member, or if allowPublicReads in Clans_CreateBoard() was passed as false. However, if we are banned from this clan, no boards are returned
| o C Clans_GetTopics | Gets topics (posts that are not replies to other posts, created with Clans_CreateTopic()) for the specified clanHandle and clanBoardName. If we are not a clan member and the clan was created with allowPublicReads==false, then the user is not allowed to read topics
| o C Clans_GetPosts | Gets all posts for a particular topic. If postId is not a topic but is instead a post in a topic, treat it as if the topic postId was passed. If we are not a clan member and the clan was created with allowPublicReads==false, then the user is not allowed to read topics
| o C Lobby2Plugin | Both Lobby2Server and Lobby2Client derive from this class
| o C Lobby2Presence |
| o C Lobby2ServerCommand |
| o C Lobby2Server | The base class for the lobby server, without database specific functionality
| | \ C ConfigurationProperties | Server configuration properties, to customize how the server runs specific commands
| o C Lobby2Server_PGSQL | PostgreSQL specific functionality to the lobby server
| o C RoomsPluginFunc | Base class for rooms functionality
| o C CreateRoom_Func | Create a room. Each user can be in at most one room, so will fail if the user is already in a room
| o C EnterRoom_Func | Joins a room if possible. If not, creates a room
| o C JoinByFilter_Func | Joins a room given the filter parameters and desired room member mode
| o C LeaveRoom_Func | Leaves a room. You can leave at any time, even if the room is locked
| o C GetInvitesToParticipant_Func |
| o C SendInvite_Func | Sends an invitation to someone
| o C AcceptInvite_Func | Accept an invitation from a user to a room
| o C StartSpectating_Func | Begin spectating. Spectators are considered room members that are not playing the game, only watching
| o C StopSpectating_Func | Stop spectating. This will rejoin the room as a player, using a reserved slot if we were invited, and a public slot if not or if there are no reserved slots
| o C GrantModerator_Func | Give moderator to another player. Moderators cannot be spectators
| o C ChangeSlotCounts_Func | Change the allowed slot counts for the room. Setting fewer slot counts than the number of players does not kick out players, though it may prevent changing spectator status
| o C SetCustomRoomProperties_Func | Sets a table of user-defined room properties
| o C GetRoomProperties_Func | Given a named room, return the properties of that room, including member list
| o C ChangeRoomName_Func | Change the name of the room
| o C SetHiddenFromSearches_Func | Set or unset the room hidden from searches. If a room is hidden from searches, it can only be joined through invitations
| o C SetDestroyOnModeratorLeave_Func | Sets or unsets to destroy the room when the moderator leaves the room
| o C SetReadyStatus_Func | Sets or unsets the user as flagged 'ready'
| o C GetReadyStatus_Func | Gets the ready states for every user in the room, excluding spectators
| o C SetRoomLockState_Func | Lock or unlock the room
| o C GetRoomLockState_Func | Gets the lock state of the room
| o C AreAllMembersReady_Func | If all members have been set to ready using SetReadyStatus_Func, this operation will set allReady to true
| o C KickMember_Func | Kick a member out of the room. This will also automatically ban that member from rejoining as long as the moderator does not change, or the member is unbanned
| o C UnbanMember_Func | Allow a member previously kicked out of the room to rejoin
| o C GetBanReason_Func | For a given room, get the reason parameter of KickMember_Func when we were kicked out
| o C AddUserToQuickJoin_Func | Enter quick join mode
| o C RemoveUserFromQuickJoin_Func | Leave quick join mode
| o C IsInQuickJoin_Func | Returns if you are waiting in quick join mode
| o C SearchByFilter_Func | Return all rooms that pass the roomQuery filter
| o C ChangeHandle_Func | Change your handle
| o C Chat_Func | Send a chat message
| o C Bitstream_Func | Send an arbitrary binary message
| o C RoomsPluginNotification | Base class for notification callbacks
| o C QuickJoinExpired_Notification | The quick join duration has expired without joining or creating any rooms
| o C QuickJoinEnteredRoom_Notification | Quick join succeeded, and you are now in a room
| o C RoomMemberStartedSpectating_Notification | Another room member has started spectating
| o C RoomMemberStoppedSpectating_Notification | Another room member has stopped spectating
| o C ModeratorChanged_Notification | The room has a new moderator (possibly you)
| o C SlotCountsSet_Notification | The slot counts in the room has changed
| o C CustomRoomPropertiesSet_Notification | The custom properties for the room has changed
| o C RoomNameSet_Notification | The name of the room has been changed
| o C HiddenFromSearchesSet_Notification | The room is now hidden, or no longer hidden, from searches
| o C RoomMemberReadyStatusSet_Notification | Another room member has changed their ready status
| o C RoomLockStateSet_Notification | The room is now, or is no longer, locked
| o C RoomMemberKicked_Notification | A room member has been kicked out of the room (possibly you)
| o C RoomMemberHandleSet_Notification | A room member has changed their handle
| o C RoomMemberLeftRoom_Notification |
| o C RoomMemberJoinedRoom_Notification | A room member has joined the room
| o C RoomInvitationSent_Notification | You have received an invitation to a room
| o C RoomInvitationWithdrawn_Notification | A previous room invitation is no longer valid (possibly due to moderator change, or the room no longer exists)
| o C RoomDestroyedOnModeratorLeft_Notification | The moderator has left the room, and everyone left is a spectator, or the room was set to be destroyed when the moderator leftYou are no longer in the room
| o C Chat_Notification | You got a chat message from another user
| o C Bitstream_Notification | You got a generic bitstream message from another user
| o C RoomsPlugin | Used to create rooms for players where they can matchmake
| o C AutopatcherMySQLRepository |
| o C RPC3 | The RPC3 plugin allows you to call remote functions as if they were local functions, using the standard function call syntax
| o C SQLite3PluginResultInterface | Handles results of calls to SQLite3Plugin::_sqlite3_exec() Results from calling SQLite3Plugin::_sqlite3_exec() are handled in this callback. You should implement the callback, and let the plugin know about it via SQLite3Plugin::AddResultHandler() Be sure to call SQLite3Plugin::RemoveResultHandler() or SQLite3Plugin::ClearResultHandlers() if you delete the callback
| o C SQLite3PluginResultInterface_Printf |
| o C SQLite3ClientPlugin |
| \ C SQLite3ServerPlugin | Exec SQLLite commands over the network
o C CheckSum | Generates and validates checksums
o C MemoryCompressor | Compress one or more blocks of data
o C RefCountedObj | World's simplest class :)
o C SQLite3Row |
o C SQLite3Table |
o C StrAndBool | The string plus a bool telling us if this string was copied or not
\ C ThreadPool |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: DataStructures::BinarySearchTree< BinarySearchTreeType > Class Template Reference

  • DataStructures
  • BinarySearchTree
List of all members
DataStructures::BinarySearchTree< BinarySearchTreeType > Class Template Reference

A binary search tree and an AVL balanced binary search tree. More...

#include <DS_BinarySearchTree.h>

Inheritance diagram for DataStructures::BinarySearchTree< BinarySearchTreeType >:
DataStructures::AVLBalancedBinarySearchTree< BinarySearchTreeType >

Detailed Description

template<class BinarySearchTreeType>
class DataStructures::BinarySearchTree< BinarySearchTreeType >

A binary search tree and an AVL balanced binary search tree.

Initilize with the following structure

BinarySearchTree<TYPE>

OR

AVLBalancedBinarySearchTree<TYPE>

Use the AVL balanced tree if you want the tree to be balanced after every deletion and addition. This avoids the potential worst case scenario where ordered input to a binary search tree gives linear search time results. It's not needed if input will be evenly distributed, in which case the search time is O (log n). The search time for the AVL balanced binary tree is O (log n) irregardless of input.

Has the following member functions unsigned int Height(<index>) - Returns the height of the tree at the optional specified starting index. Default is the root add(element) - adds an element to the BinarySearchTree bool del(element) - deletes the node containing element if the element is in the tree as defined by a comparison with the == operator. Returns true on success, false if the element is not found bool IsInelement) - returns true if element is in the tree as defined by a comparison with the == operator. Otherwise returns false DisplayInorder(array) - Fills an array with an inorder search of the elements in the tree. USER IS REPONSIBLE FOR ALLOCATING THE ARRAY!. DisplayPreorder(array) - Fills an array with an preorder search of the elements in the tree. USER IS REPONSIBLE FOR ALLOCATING THE ARRAY!. DisplayPostorder(array) - Fills an array with an postorder search of the elements in the tree. USER IS REPONSIBLE FOR ALLOCATING THE ARRAY!. DisplayBreadthFirstSearch(array) - Fills an array with a breadth first search of the elements in the tree. USER IS REPONSIBLE FOR ALLOCATING THE ARRAY!. clear - Destroys the tree. Same as calling the destructor unsigned int Height() - Returns the height of the tree unsigned int size() - returns the size of the BinarySearchTree GetPointerToNode(element) - returns a pointer to the comparision element in the tree, allowing for direct modification when necessary with complex data types. Be warned, it is possible to corrupt the tree if the element used for comparisons is modified. Returns NULL if the item is not found

EXAMPLE

BinarySearchTree<int> A;
A.Add(10);
A.Add(15);
A.Add(5);
int* array = RakNet::OP_NEW<int >(A.Size(), _FILE_AND_LINE_ );
A.DisplayInorder(array);
array[0]; // returns 5
array[1]; // returns 10
array[2]; // returns 15

compress - reallocates memory to fit the number of elements. Best used when the number of elements decreases

clear - empties the BinarySearchTree and returns storage The assignment and copy constructors are defined

Note
The template type must have the copy constructor and assignment operator defined and must work with >, <, and == All elements in the tree MUST be distinct The assignment operator is defined between BinarySearchTree and AVLBalancedBinarySearchTree as long as they are of the same template type. However, passing a BinarySearchTree to an AVLBalancedBinarySearchTree will lose its structure unless it happened to be AVL balanced to begin with Requires queue_linked_list.cpp for the breadth first search used in the copy constructor, overloaded assignment operator, and display_breadth_first_search.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/DS_BinarySearchTree.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: DataStructures::AVLBalancedBinarySearchTree< BinarySearchTreeType > Class Template Reference

  • DataStructures
  • AVLBalancedBinarySearchTree
List of all members
DataStructures::AVLBalancedBinarySearchTree< BinarySearchTreeType > Class Template Reference

An AVLBalancedBinarySearchTree is a binary tree that is always balanced. More...

#include <DS_BinarySearchTree.h>

Inheritance diagram for DataStructures::AVLBalancedBinarySearchTree< BinarySearchTreeType >:
DataStructures::BinarySearchTree< BinarySearchTreeType >

Detailed Description

template<class BinarySearchTreeType>
class DataStructures::AVLBalancedBinarySearchTree< BinarySearchTreeType >

An AVLBalancedBinarySearchTree is a binary tree that is always balanced.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/DS_BinarySearchTree.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: DataStructures::Page< KeyType, DataType, order > Struct Template Reference

  • DataStructures
  • Page
List of all members
DataStructures::Page< KeyType, DataType, order > Struct Template Reference

#include <DS_BPlusTree.h>

Detailed Description

template<class KeyType, class DataType, int order>
struct DataStructures::Page< KeyType, DataType, order >

Used in the BPlusTree. Used for both leaf and index nodes. Don't use a constructor or destructor, due to the memory pool I am using

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/DS_BPlusTree.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: DataStructures::BPlusTree< KeyType, DataType, order > Class Template Reference

  • DataStructures
  • BPlusTree
List of all members
DataStructures::BPlusTree< KeyType, DataType, order > Class Template Reference

#include <DS_BPlusTree.h>

Detailed Description

template<class KeyType, class DataType, int order>
class DataStructures::BPlusTree< KeyType, DataType, order >

A BPlus tree Written with efficiency and speed in mind.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/DS_BPlusTree.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: DataStructures::Hash< key_type, data_type, HASH_SIZE, hashFunction > Class Template Reference

  • DataStructures
  • Hash
Public Member Functions | List of all members
DataStructures::Hash< key_type, data_type, HASH_SIZE, hashFunction > Class Template Reference

Using a string as a identifier for a node, store an allocated pointer to that node. More...

#include <DS_Hash.h>

Public Member Functions

Hash ()
Default constructor.
void Clear (const char *file, unsigned int line)
Clear the list.

Detailed Description

template<class key_type, class data_type, unsigned int HASH_SIZE, unsigned long(*)(const key_type &) hashFunction>
class DataStructures::Hash< key_type, data_type, HASH_SIZE, hashFunction >

Using a string as a identifier for a node, store an allocated pointer to that node.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/DS_Hash.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: DataStructures::CircularLinkedList< CircularLinkedListType > Class Template Reference

  • DataStructures
  • CircularLinkedList
List of all members
DataStructures::CircularLinkedList< CircularLinkedListType > Class Template Reference

(Circular) Linked List ADT (Doubly Linked Pointer to Node Style) - More...

#include <DS_LinkedList.h>

Detailed Description

template<class CircularLinkedListType>
class DataStructures::CircularLinkedList< CircularLinkedListType >

(Circular) Linked List ADT (Doubly Linked Pointer to Node Style) -

By Kevin Jenkins (http://www.rakkar.org) Initilize with the following command LinkedList<TYPE> OR CircularLinkedList<Type>

Has the following member functions

  • size: returns number of elements in the linked list
  • insert(item): inserts item at the current position in the LinkedList.
  • add(item): inserts item after the current position in the LinkedList. Does not increment the position
  • replace(item): replaces the element at the current position item.
  • peek: returns the element at the current position
  • pop: returns the element at the current position and deletes it
  • del: deletes the current element. Does nothing for an empty list.
  • clear: empties the LinkedList and returns storage
  • bool IsInitem): Does a linear search for item. Does not set the position to it, only returns true on item found, false otherwise
  • bool find(item): Does a linear search for item and sets the current position to point to it if and only if the item is found. Returns true on item found, false otherwise
  • sort: Sorts the elements of the list with a mergesort and sets the current pointer to the first element
  • concatenate(list L): This appends L to the current list
  • ++(prefix): moves the pointer one element up in the list and returns the appropriate copy of the element in the list
  • –(prefix): moves the pointer one element back in the list and returns the appropriate copy of the element in the list
  • beginning - moves the pointer to the start of the list. For circular linked lists this is first 'position' created. You should call this after the sort function to read the first value.
  • end - moves the pointer to the end of the list. For circular linked lists this is one less than the first 'position' created The assignment and copy constructor operators are defined
Note
  1. LinkedList and CircularLinkedList are exactly the same except LinkedList won't let you wrap around the root and lets you jump to two positions relative to the root/
  2. Postfix ++ and – can be used but simply call the prefix versions.

EXAMPLE:

LinkedList<int> A; // Creates a Linked List of integers called A
CircularLinkedList<int> B; // Creates a Circular Linked List of
// integers called B
A.Insert(20); // Adds 20 to A. A: 20 - current is 20
A.Insert(5); // Adds 5 to A. A: 5 20 - current is 5
A.Insert(1); // Adds 1 to A. A: 1 5 20 - current is 1
A.IsIn1); // returns true
A.IsIn200); // returns false
A.Find(5); // returns true and sets current to 5
A.Peek(); // returns 5
A.Find(1); // returns true and sets current to 1
(++A).Peek(); // Returns 5
A.Peek(); // Returns 5
A.Replace(10); // Replaces 5 with 10.
A.Peek(); // Returns 10
A.Beginning(); // Current points to the beginning of the list at 1
(++A).Peek(); // Returns 5
A.Peek(); // Returns 10
A.Del(); // Deletes 10. Current points to the next element, which is 20
A.Peek(); // Returns 20
A.Beginning(); // Current points to the beginning of the list at 1
(++A).Peek(); // Returns 5
A.Peek(); // Returns 20
A.Clear(_FILE_AND_LINE_); // Deletes all nodes in A
A.Insert(5); // A: 5 - current is 5
A.Insert(6); // A: 6 5 - current is 6
A.Insert(7); // A: 7 6 5 - current is 7
A.Clear(_FILE_AND_LINE_);
B.Clear(_FILE_AND_LINE_);
B.Add(10);
B.Add(20);
B.Add(30);
B.Add(5);
B.Add(2);
B.Add(25);
// Sorts the numbers in the list and sets the current pointer to the
// first element
B.sort();
// Postfix ++ just calls the prefix version and has no functional
// difference.
B.Peek(); // Returns 2
B++;
B.Peek(); // Returns 5
B++;
B.Peek(); // Returns 10
B++;
B.Peek(); // Returns 20
B++;
B.Peek(); // Returns 25
B++;
B.Peek(); // Returns 30
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/DS_LinkedList.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: DataStructures::List< list_type > Class Template Reference

  • DataStructures
  • List
Public Member Functions | List of all members
DataStructures::List< list_type > Class Template Reference

Array based implementation of a list. More...

#include <DS_List.h>

Public Member Functions

List ()
Default constructor.
List (const List &original_copy)
Copy constructor.
List & | operator= (const List &original_copy)
Assign one list to another.
list_type & | operator[] (const unsigned int position) const
Access an element by its index in the array.
list_type & | Get (const unsigned int position) const
Access an element by its index in the array.
void | Push (const list_type &input, const char *file, unsigned int line)
Push an element at the end of the stack.
list_type & | Pop (void)
Pop an element from the end of the stack.
void | Insert (const list_type &input, const unsigned int position, const char *file, unsigned int line)
Insert an element at position position in the list.
void | Insert (const list_type &input, const char *file, unsigned int line)
Insert at the end of the list.
void | Replace (const list_type &input, const list_type filler, const unsigned int position, const char *file, unsigned int line)
Replace the value at position by input.
void | Replace (const list_type &input)
Replace the last element of the list by input.
void | RemoveAtIndex (const unsigned int position)
Delete the element at position position.
void | RemoveAtIndexFast (const unsigned int position)
Delete the element at position position.
void | RemoveFromEnd (const unsigned num=1)
Delete the element at the end of the list.
unsigned int | GetIndexOf (const list_type &input) const
Returns the index of the specified item or MAX_UNSIGNED_LONG if not found.
unsigned int | Size (void) const
void | Clear (bool doNotDeallocateSmallBlocks, const char *file, unsigned int line)
Clear the list.
void | Preallocate (unsigned countNeeded, const char *file, unsigned int line)
Preallocate the list, so it needs fewer reallocations at runtime.
void | Compress (const char *file, unsigned int line)
Frees overallocated members, to use the minimum memory necessary.

Detailed Description

template<class list_type>
class DataStructures::List< list_type >

Array based implementation of a list.

Note
ONLY USE THIS FOR SHALLOW COPIES. I don't bother with operator= to improve performance.

Constructor & Destructor Documentation

template<class list_type >
DataStructures::List< list_type >::List ( const List< list_type > & original_copy )

Copy constructor.

Parameters
[in] original_copy The list to duplicate

Member Function Documentation

template<class list_type >
void DataStructures::List< list_type >::Compress | ( | const char * | file,
 |  | unsigned int | line
 | ) |  |

Frees overallocated members, to use the minimum memory necessary.

Attention
This is a slow operation
template<class list_type >
list_type & DataStructures::List< list_type >::Get ( const unsigned int position ) const
inline

Access an element by its index in the array.

Parameters
[in] position The index into the array.
Returns
The element at position position.
template<class list_type>
unsigned int DataStructures::List< list_type >::GetIndexOf ( const list_type & input ) const

Returns the index of the specified item or MAX_UNSIGNED_LONG if not found.

Parameters
[in] input The element to check for
Returns
The index or position of input in the list.
Return values
MAX_UNSIGNED_LONG | The object is not in the list
[Integer] | The index of the element in the list
template<class list_type>
void DataStructures::List< list_type >::Insert | ( | const list_type & | input,
 |  | const unsigned int | position,
 |  | const char * | file,
 |  | unsigned int | line
 | ) |  |

Insert an element at position position in the list.

Parameters
[in] | input | The new element.
[in] | position | The position of the new element.
template<class list_type>
void DataStructures::List< list_type >::Insert | ( | const list_type & | input,
 |  | const char * | file,
 |  | unsigned int | line
 | ) |  |

Insert at the end of the list.

Parameters
[in] input The new element.
template<class list_type >
list_type & DataStructures::List< list_type >::operator[] ( const unsigned int position ) const
inline

Access an element by its index in the array.

Parameters
[in] position The index into the array.
Returns
The element at position position.
template<class list_type >
list_type & DataStructures::List< list_type >::Pop ( void )
inline

Pop an element from the end of the stack.

Precondition
Size()>0
Returns
The element at the end.
template<class list_type>
void DataStructures::List< list_type >::Push | ( | const list_type & | input,
 |  | const char * | file,
 |  | unsigned int | line
 | ) |  |

Push an element at the end of the stack.

Parameters
[in] input The new element.
template<class list_type >
void DataStructures::List< list_type >::RemoveAtIndex ( const unsigned int position )

Delete the element at position position.

Parameters
[in] position The index of the element to delete
template<class list_type >
void DataStructures::List< list_type >::RemoveAtIndexFast ( const unsigned int position )

Delete the element at position position.

Note
- swaps middle with end of list, only use if list order does not matter
Parameters
[in] position The index of the element to delete
template<class list_type>
void DataStructures::List< list_type >::Replace | ( | const list_type & | input,
 |  | const list_type | filler,
 |  | const unsigned int | position,
 |  | const char * | file,
 |  | unsigned int | line
 | ) |  |
inline

Replace the value at position by input.

If the size of the list is less than position, it increase the capacity of the list and fill slot with filler.

Parameters
[in] | input | The element to replace at position position.
[in] | filler | The element use to fill new allocated capacity.
[in] | position | The position of input in the list.
template<class list_type>
void DataStructures::List< list_type >::Replace ( const list_type & input )
inline

Replace the last element of the list by input.

Parameters
[in] input The element used to replace the last element.
template<class list_type >
unsigned int DataStructures::List< list_type >::Size ( void ) const
inline
Returns
The number of elements in the list
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/DS_List.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: DataStructures::Map< key_type, data_type, key_comparison_func > Class Template Reference

  • DataStructures
  • Map
List of all members
DataStructures::Map< key_type, data_type, key_comparison_func > Class Template Reference

#include <DS_Map.h>

Detailed Description

template<class key_type, class data_type, int(*)(const key_type &, const key_type &) key_comparison_func = defaultMapKeyComparison<key_type>>
class DataStructures::Map< key_type, data_type, key_comparison_func >

Note
IMPORTANT! If you use defaultMapKeyComparison then call IMPLEMENT_DEFAULT_COMPARISON or you will get an unresolved external linker error.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/DS_Map.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: DataStructures::MemoryPool< MemoryBlockType > Class Template Reference

  • DataStructures
  • MemoryPool
List of all members
DataStructures::MemoryPool< MemoryBlockType > Class Template Reference

#include <DS_MemoryPool.h>

Detailed Description

template<class MemoryBlockType>
class DataStructures::MemoryPool< MemoryBlockType >

Very fast memory pool for allocating and deallocating structures that don't have constructors or destructors. Contains a list of pages, each of which has an array of the user structures

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/DS_MemoryPool.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: DataStructures::MLKeyRef< templateType > Class Template Reference

  • DataStructures
  • MLKeyRef
List of all members
DataStructures::MLKeyRef< templateType > Class Template Reference

#include <DS_Multilist.h>

Detailed Description

template<class templateType>
class DataStructures::MLKeyRef< templateType >

The following is invalid. bool operator<( const MyClass *myClass, const int &inputKey ) {return myClass->value < inputKey;} At least one type has to be a reference to a class MLKeyRef is a helper class to turn a native type into a class, so you can compare that native type against a pointer to a different class Used for he Multilist, when _DataType != _KeyType

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/DS_Multilist.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > Class Template Reference

  • DataStructures
  • Multilist
Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > Class Template Reference

The multilist, representing an abstract data type that generally holds lists. More...

#include <DS_Multilist.h>

Public Member Functions

void | Push (const _DataType &d, const char *file=__FILE__, unsigned int line=__LINE__)
_DataType & | Pop (const char *file=__FILE__, unsigned int line=__LINE__)
Gets or removes and gets an element from the list, according to the same rules as Push(). Ordered list is LIFO for the purposes of Pop and Peek.
void | PushOpposite (const _DataType &d, const char *file=__FILE__, unsigned int line=__LINE__)
Same as Push(), except FIFO and LIFO are reversed. Ordered list still inserts in order.
_DataType & | PopOpposite (const char *file=__FILE__, unsigned int line=__LINE__)
Same as Pop() and Peek(), except FIFO and LIFO are reversed.
void | InsertAtIndex (const _DataType &d, _IndexType index, const char *file=__FILE__, unsigned int line=__LINE__)
Stack,Queue: Inserts at index indicated, elements are shifted. Ordered list: Inserts, position is ignored.
void | RemoveAtIndex (_IndexType position, const char *file=__FILE__, unsigned int line=__LINE__)
Unordered list, removes at index indicated, swaps last element with that element. Otherwise, array is shifted left to overwrite removed element.
bool | RemoveAtKey (_KeyType key, bool assertIfDoesNotExist, const char *file=__FILE__, unsigned int line=__LINE__)
Find the index of key, and remove at that index.
_IndexType | GetIndexOf (_KeyType key) const
Finds the index of key. Return -1 if the key is not found.
_IndexType | GetInsertionIndex (_KeyType key) const
Returns where in the list we should insert the item, to preserve list order. Returns -1 if the item is already in the list.
_DataType | GetPtr (_KeyType key) const
Finds the index of key. Return 0 if the key is not found. Useful if _DataType is always non-zero pointers.
void | ForEach (void(*func)(_DataType &item, const char *file, unsigned int line), const char *file, unsigned int line)
Iterate over the list, calling the function pointer on each element.
bool | IsEmpty (void) const
Returns if the list is empty.
_IndexType | GetSize (void) const
Returns the number of elements used in the list.
void | Clear (bool deallocateSmallBlocks=true, const char *file=__FILE__, unsigned int line=__LINE__)
Empties the list. The list is not deallocated if it is small, unless deallocateSmallBlocks is true.
void | ClearPointers (bool deallocateSmallBlocks=true, const char *file=__FILE__, unsigned int line=__LINE__)
Empties the list, first calling RakNet::OP_Delete on all items.
void | ClearPointer (_KeyType key, const char *file=__FILE__, unsigned int line=__LINE__)
Empty one item from the list, first calling RakNet::OP_Delete on that item.
void | ReverseList (void)
Reverses the elements in the list, and flips the sort order returned by GetSortOrder() if IsSorted() returns true at the time the function is called.
void | Reallocate (_IndexType size, const char *file=__FILE__, unsigned int line=__LINE__)
Reallocates the list to a larger size. If size is smaller than the value returned by GetSize(), the call does nothing.
void | Sort (bool force)
Sorts the list unless it is an ordered list, in which it does nothing as the list is assumed to already be sorted.
void | TagSorted (void)
Sets the list to be remembered as sorted.
void | SetSortOrder (bool ascending)
Defaults to ascending.
bool | GetSortOrder (void) const
Returns true if ascending.
bool | IsSorted (void) const
Returns true if the list is currently believed to be in a sorted state.
MultilistType | GetMultilistType (void) const
Returns what type of list this is.
void | SetMultilistType (MultilistType newType)
Changes what type of list this is.

Static Public Member Functions

static void FindIntersection (Multilist &source1, Multilist &source2, Multilist &intersection, Multilist &uniqueToSource1, Multilist &uniqueToSource2)
Returns the intersection of two lists. Intersection is items common to both lists.

Protected Attributes

_DataType * | data
An array of user values.
_IndexType | dataSize
Number of elements in the list.
_IndexType | allocationSize
Size of array.
_IndexType | queueHead
Array index for the head of the queue.
_IndexType | queueTail
Array index for the tail of the queue.
_IndexType | preallocationSize

Detailed Description

template<const MultilistType _MultilistType, class _DataType, class _KeyType = _DataType, class _IndexType = DefaultIndexType>
class DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >

The multilist, representing an abstract data type that generally holds lists.

Parameters
[in] _MultilistType What type of list this is,
See Also
MultilistType
Parameters
[in] | _DataType | What type of data this list holds.
[in] | _KeyType | If a function takes a key to sort on, what type of key this is. The comparison operator between _DataType and _KeyType must be defined
[in] | _IndexType | What variable type to use for indices

Member Function Documentation

template<const MultilistType _MultilistType, class _DataType , class _KeyType , class _IndexType >
void DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >::ClearPointers | ( | bool | deallocateSmallBlocks = true,
 |  | const char * | file = __FILE__,
 |  | unsigned int | line = __LINE__
 | ) |  |

Empties the list, first calling RakNet::OP_Delete on all items.

The list is not deallocated if it is small, unless deallocateSmallBlocks is true

template<const MultilistType _MultilistType, class _DataType , class _KeyType , class _IndexType >
bool DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >::IsSorted ( void ) const

Returns true if the list is currently believed to be in a sorted state.

Doesn't actually check for sortedness, just if Sort() was recently called, or MultilistType is ML_ORDERED_LIST

template<const MultilistType _MultilistType, class _DataType, class _KeyType , class _IndexType >
void DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >::Push | ( | const _DataType & | d,
 |  | const char * | file = __FILE__,
 |  | unsigned int | line = __LINE__
 | ) |  |

Unordered list, stack is LIFO QUEUE is FIFO Ordered list is inserted in order

template<const MultilistType _MultilistType, class _DataType , class _KeyType , class _IndexType>
void DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >::RemoveAtIndex | ( | _IndexType | position,
 |  | const char * | file = __FILE__,
 |  | unsigned int | line = __LINE__
 | ) |  |

Unordered list, removes at index indicated, swaps last element with that element. Otherwise, array is shifted left to overwrite removed element.

Index[0] returns the same as Pop() for a queue. Same as PopOpposite() for the list and ordered list

template<const MultilistType _MultilistType, class _DataType , class _KeyType , class _IndexType >
void DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >::SetMultilistType ( MultilistType newType )

Changes what type of list this is.

Precondition
Template must be defined with ML_VARIABLE_DURING_RUNTIME for this to do anything
Parameters
[in] mlType Any value of the enum MultilistType, except ML_VARIABLE_DURING_RUNTIME
template<const MultilistType _MultilistType, class _DataType , class _KeyType , class _IndexType >
void DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >::SetSortOrder ( bool ascending )

Defaults to ascending.

Used by Sort(), and by ML_ORDERED_LIST

template<const MultilistType _MultilistType, class _DataType , class _KeyType , class _IndexType >
void DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >::Sort ( bool force )

Sorts the list unless it is an ordered list, in which it does nothing as the list is assumed to already be sorted.

However, if force is true, it will also resort the ordered list, useful if the comparison operator between _KeyType and _DataType would now return different results Once the list is sorted, further operations to lookup by key will be log2(n) until the list is modified

template<const MultilistType _MultilistType, class _DataType , class _KeyType , class _IndexType >
void DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >::TagSorted ( void )

Sets the list to be remembered as sorted.

Optimization if the source is sorted already

Member Data Documentation

template<const MultilistType _MultilistType, class _DataType, class _KeyType = _DataType, class _IndexType = DefaultIndexType>
_IndexType DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >::preallocationSize
protected

How many bytes the user chose to preallocate Won't automatically deallocate below this

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/DS_Multilist.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: DataStructures::OrderedList< key_type, data_type, default_comparison_function > Class Template Reference

  • DataStructures
  • OrderedList
Public Member Functions | List of all members
DataStructures::OrderedList< key_type, data_type, default_comparison_function > Class Template Reference

#include <DS_OrderedList.h>

Public Member Functions

bool HasData (const key_type &key, int(*cf)(const key_type &, const data_type &)=default_comparison_function) const

Detailed Description

template<class key_type, class data_type, int(*)(const key_type &, const data_type &) default_comparison_function = defaultOrderedListComparison<key_type, data_type>>
class DataStructures::OrderedList< key_type, data_type, default_comparison_function >

Note
IMPORTANT! If you use defaultOrderedListComparison then call IMPLEMENT_DEFAULT_COMPARISON or you will get an unresolved external linker error.

Member Function Documentation

template<class key_type, class data_type, int(*)(const key_type &, const data_type &) default_comparison_function>
bool DataStructures::OrderedList< key_type, data_type, default_comparison_function >::HasData | ( | const key_type & | key,
 |  | int(*)(const key_type &, const data_type &) | cf = default_comparison_function
 | ) |  | const

comparisonFunction must take a key_type and a data_type and return <0, ==0, or >0 If the data type has comparison operators already defined then you can just use defaultComparison

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/DS_OrderedList.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: DataStructures::Queue< queue_type > Class Template Reference

  • DataStructures
  • Queue
List of all members
DataStructures::Queue< queue_type > Class Template Reference

A queue implemented as an array with a read and write index. More...

#include <DS_Queue.h>

Detailed Description

template<class queue_type>
class DataStructures::Queue< queue_type >

A queue implemented as an array with a read and write index.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/DS_Queue.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: DataStructures::QueueLinkedList< QueueType > Class Template Reference

  • DataStructures
  • QueueLinkedList
List of all members
DataStructures::QueueLinkedList< QueueType > Class Template Reference

A queue implemented using a linked list. Rarely used. More...

#include <DS_QueueLinkedList.h>

Detailed Description

template<class QueueType>
class DataStructures::QueueLinkedList< QueueType >

A queue implemented using a linked list. Rarely used.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/DS_QueueLinkedList.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: DataStructures::Table Class Reference

  • DataStructures
  • Table
Classes | Public Types | Public Member Functions | List of all members
DataStructures::Table Class Reference

Holds a set of columns, a set of rows, and rows times columns cells. More...

#include <DS_Table.h>

Classes

struct | Cell
Holds the actual data in the table. More...
struct | ColumnDescriptor
struct | Row
Stores the list of cells for this row, and a special flag used for internal sorting. More...

Public Types

enum SortQueryType
Increasing or decreasing sort order.

Public Member Functions

unsigned | AddColumn (const char columnName[_TABLE_MAX_COLUMN_NAME_LENGTH], ColumnType columnType)
Adds a column to the table.
void | RemoveColumn (unsigned columnIndex)
Removes a column by index.
unsigned | ColumnIndex (char columnName[_TABLE_MAX_COLUMN_NAME_LENGTH]) const
Gets the index of a column by name.
char * | ColumnName (unsigned index) const
Gives the string name of the column at a certain index.
ColumnType | GetColumnType (unsigned index) const
Returns the type of a column, referenced by index.
unsigned | GetColumnCount (void) const
unsigned | GetRowCount (void) const
Table::Row * | AddRow (unsigned rowId)
Adds a row to the table.
bool | RemoveRow (unsigned rowId)
Removes a row specified by rowId.
void | RemoveRows (Table *tableContainingRowIDs)
Removes all the rows with IDs that the specified table also has.
bool | UpdateCell (unsigned rowId, unsigned columnIndex, int value)
Updates a particular cell in the table.
void | GetCellValueByIndex (unsigned rowIndex, unsigned columnIndex, int *output)
Note this is much less efficient to call than GetRow, then working with the cells directly. Numeric, string, binary.
Row * | GetRowByID (unsigned rowId) const
Gets a row. More efficient to do this and access Row::cells than to repeatedly call GetCell. You can also update cells in rows from this function.
Row * | GetRowByIndex (unsigned rowIndex, unsigned *key) const
Gets a row at a specific index. rowIndex should be less than GetRowCount()
void | QueryTable (unsigned *columnIndicesSubset, unsigned numColumnSubset, FilterQuery *inclusionFilters, unsigned numInclusionFilters, unsigned *rowIds, unsigned numRowIDs, Table *result)
Queries the table, optionally returning only a subset of columns and rows.
void | SortTable (Table::SortQuery *sortQueries, unsigned numSortQueries, Table::Row **out)
Sorts the table by rows.
void | Clear (void)
Frees all memory in the table.
void | PrintColumnHeaders (char *out, int outLength, char columnDelineator) const
Prints out the names of all the columns.
void | PrintRow (char *out, int outLength, char columnDelineator, bool printDelineatorForBinary, Table::Row *inputRow) const
Writes a text representation of the row to out.
const DataStructures::List
< ColumnDescriptor > & 		GetColumns (void) const
Direct access to make things easier.
const
DataStructures::BPlusTree
< unsigned, Row
*, _TABLE_BPLUS_TREE_ORDER > & 		GetRows (void) const
Direct access to make things easier.
DataStructures::Page< unsigned,
Row *, _TABLE_BPLUS_TREE_ORDER > * 		GetListHead (void)
Get the head of a linked list containing all the row data.
unsigned | GetAvailableRowId (void) const
Get the first free row id. This could be made more efficient.

Detailed Description

Holds a set of columns, a set of rows, and rows times columns cells.

The table data structure is useful if you want to store a set of structures and perform queries on those structures.
This is a relatively simple and fast implementation of the types of tables commonly used in databases.
See TableSerializer to serialize data members of the table.
See LightweightDatabaseClient and LightweightDatabaseServer to transmit the table over the network.

Member Function Documentation

unsigned DataStructures::Table::AddColumn | ( | const char | columnName[_TABLE_MAX_COLUMN_NAME_LENGTH],
 |  | ColumnType | columnType
 | ) |  |

Adds a column to the table.

Parameters
[in] | columnName | The name of the column
[in] | columnType | What type of data this column will hold
Returns
The index of the new column
Table::Row* DataStructures::Table::AddRow ( unsigned rowId )

Adds a row to the table.

New rows are added with empty values for all cells. However, if you specify initialCelLValues you can specify initial values It's up to you to ensure that the values in the specific cells match the type of data used by that row rowId can be considered the primary key for the row. It is much faster to lookup a row by its rowId than by searching keys. rowId must be unique Rows are stored in sorted order in the table, using rowId as the sort key

Parameters
[in] | rowId | The UNIQUE primary key for the row. This can never be changed.
[in] | initialCellValues | Initial values to give the row (optional)
Returns
The newly added row
unsigned DataStructures::Table::ColumnIndex ( char columnName[_TABLE_MAX_COLUMN_NAME_LENGTH] ) const

Gets the index of a column by name.

Column indices are stored in the order they are added.

Parameters
[in] columnName The name of the column
Returns
The index of the column, or (unsigned)-1 if no such column
char* DataStructures::Table::ColumnName ( unsigned index ) const

Gives the string name of the column at a certain index.

Parameters
[in] index The index of the column
Returns
The name of the column, or 0 if an invalid index
unsigned DataStructures::Table::GetColumnCount ( void ) const

Returns the number of columns

Returns
The number of columns in the table
ColumnType DataStructures::Table::GetColumnType ( unsigned index ) const

Returns the type of a column, referenced by index.

Parameters
[in] index The index of the column
Returns
The type of the column
Row* DataStructures::Table::GetRowByID ( unsigned rowId ) const

Gets a row. More efficient to do this and access Row::cells than to repeatedly call GetCell. You can also update cells in rows from this function.

Parameters
[in] rowId The ID of the row
Returns
The desired row, or 0 if no such row.
Row* DataStructures::Table::GetRowByIndex | ( | unsigned | rowIndex,
 |  | unsigned * | key
 | ) |  | const

Gets a row at a specific index. rowIndex should be less than GetRowCount()

Parameters
[in] | rowIndex | The index of the row
[out] | key | The ID of the row returned
Returns
The desired row, or 0 if no such row.
unsigned DataStructures::Table::GetRowCount ( void ) const

Returns the number of rows

Returns
The number of rows in the table
void DataStructures::Table::PrintColumnHeaders | ( | char * | out,
 |  | int | outLength,
 |  | char | columnDelineator
 | ) |  | const

Prints out the names of all the columns.

Parameters
[out] | out | A pointer to an array of bytes which will hold the output.
[in] | outLength | The size of the out array
[in] | columnDelineator | What character to print to delineate columns
void DataStructures::Table::PrintRow | ( | char * | out,
 |  | int | outLength,
 |  | char | columnDelineator,
 |  | bool | printDelineatorForBinary,
 |  | Table::Row * | inputRow
 | ) |  | const

Writes a text representation of the row to out.

Parameters
[out] | out | A pointer to an array of bytes which will hold the output.
[in] | outLength | The size of the out array
[in] | columnDelineator | What character to print to delineate columns
[in] | printDelineatorForBinary | Binary output is not printed. True to still print the delineator.
[in] | inputRow | The row to print
void DataStructures::Table::QueryTable | ( | unsigned * | columnIndicesSubset,
 |  | unsigned | numColumnSubset,
 |  | FilterQuery * | inclusionFilters,
 |  | unsigned | numInclusionFilters,
 |  | unsigned * | rowIds,
 |  | unsigned | numRowIDs,
 |  | Table * | result
 | ) |  |

Queries the table, optionally returning only a subset of columns and rows.

Parameters
[in] | columnSubset | An array of column indices. Only columns in this array are returned. Pass 0 for all columns
[in] | numColumnSubset | The number of elements in columnSubset
[in] | inclusionFilters | An array of FilterQuery. All filters must pass for the row to be returned.
[in] | numInclusionFilters | The number of elements in inclusionFilters
[in] | rowIds | An arrow of row IDs. Only these rows with these IDs are returned. Pass 0 for all rows.
[in] | numRowIDs | The number of elements in rowIds
[out] | result | The result of the query. If no rows are returned, the table will only have columns.
void DataStructures::Table::RemoveColumn ( unsigned columnIndex )

Removes a column by index.

Parameters
[in] columnIndex The index of the column to remove
bool DataStructures::Table::RemoveRow ( unsigned rowId )

Removes a row specified by rowId.

Parameters
[in] rowId The ID of the row
Returns
true if the row was deleted. False if not.
void DataStructures::Table::RemoveRows ( Table * tableContainingRowIDs )

Removes all the rows with IDs that the specified table also has.

Parameters
[in] tableContainingRowIDs The IDs of the rows
void DataStructures::Table::SortTable | ( | Table::SortQuery * | sortQueries,
 |  | unsigned | numSortQueries,
 |  | Table::Row ** | out
 | ) |  |

Sorts the table by rows.

You can sort the table in ascending or descending order on one or more columns Columns have precedence in the order they appear in the sortQueries array If a row cell on column n has the same value as a a different row on column n, then the row will be compared on column n+1

Parameters
[in] | sortQueries | A list of SortQuery structures, defining the sorts to perform on the table
[in] | numColumnSubset | The number of elements in numSortQueries
[out] | out | The address of an array of Rows, which will receive the sorted output. The array must be long enough to contain all returned rows, up to GetRowCount()
bool DataStructures::Table::UpdateCell | ( | unsigned | rowId,
 |  | unsigned | columnIndex,
 |  | int | value
 | ) |  |

Updates a particular cell in the table.

Note
If you are going to update many cells of a particular row, it is more efficient to call GetRow and perform the operations on the row directly.
Row pointers do not change, so you can also write directly to the rows for more efficiency.
Parameters
[in] | rowId | The ID of the row
[in] | columnIndex | The column of the cell
[in] | value | The data to set
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/DS_Table.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: DataStructures::Table::Cell Struct Reference

  • DataStructures
  • Table
  • Cell
Public Member Functions | List of all members
DataStructures::Table::Cell Struct Reference

Holds the actual data in the table. More...

#include <DS_Table.h>

Public Member Functions

void | Set (int input)
Numeric.
void | Set (const char *input)
String.
void | Set (const char *input, int inputLength)
Binary.
void | SetPtr (void *p)
Pointer.
void | Get (int *output)
Numeric.
void | Get (char *output)
String.
void | Get (char *output, int *outputLength)
Binary.

Detailed Description

Holds the actual data in the table.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/DS_Table.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: DataStructures::Table::ColumnDescriptor Struct Reference

  • DataStructures
  • Table
  • ColumnDescriptor
List of all members
DataStructures::Table::ColumnDescriptor Struct Reference

#include <DS_Table.h>

Detailed Description

Stores the name and type of the column

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/DS_Table.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: DataStructures::Table::Row Struct Reference

  • DataStructures
  • Table
  • Row
Public Member Functions | List of all members
DataStructures::Table::Row Struct Reference

Stores the list of cells for this row, and a special flag used for internal sorting. More...

#include <DS_Table.h>

Public Member Functions

void | UpdateCell (unsigned columnIndex, double value)
Numeric.
void | UpdateCell (unsigned columnIndex, const char *str)
String.
void | UpdateCell (unsigned columnIndex, int byteLength, const char *data)
Binary.

Detailed Description

Stores the list of cells for this row, and a special flag used for internal sorting.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/DS_Table.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: DataStructures::SingleProducerConsumer< SingleProducerConsumerType > Class Template Reference

  • DataStructures
  • SingleProducerConsumer
Public Member Functions | List of all members
DataStructures::SingleProducerConsumer< SingleProducerConsumerType > Class Template Reference

A single producer consumer implementation without critical sections. More...

#include <SingleProducerConsumer.h>

Public Member Functions

SingleProducerConsumerType * | WriteLock (void)
void | CancelWriteLock (SingleProducerConsumerType *cancelToLocation)
void | WriteUnlock (void)
Call when you are done writing to a block of memory returned by WriteLock()
SingleProducerConsumerType * | ReadLock (void)
void | CancelReadLock (SingleProducerConsumerType *cancelToLocation)
param[in] Which ReadLock() to cancel.
void | ReadUnlock (void)
void | Clear (void)
Clear is not thread-safe and none of the lock or unlock functions should be called while it is running.
int | Size (void) const
bool | CheckReadUnlockOrder (const SingleProducerConsumerType *data) const
bool | ReadIsLocked (void) const

Detailed Description

template<class SingleProducerConsumerType>
class DataStructures::SingleProducerConsumer< SingleProducerConsumerType >

A single producer consumer implementation without critical sections.

Member Function Documentation

template<class SingleProducerConsumerType>
void DataStructures::SingleProducerConsumer< SingleProducerConsumerType >::CancelWriteLock ( SingleProducerConsumerType * cancelToLocation )

Call if you don't want to write to a block of data from WriteLock() after all. Cancelling locks cancels all locks back up to the data passed. So if you lock twice and cancel using the first lock, the second lock is ignored

Parameters
[in] cancelToLocation Which WriteLock() to cancel.
template<class SingleProducerConsumerType>
bool DataStructures::SingleProducerConsumer< SingleProducerConsumerType >::CheckReadUnlockOrder ( const SingleProducerConsumerType * data ) const

Make sure that the pointer we done reading for the call to ReadUnlock is the right pointer. param[in] A previous pointer returned by ReadLock()

template<class SingleProducerConsumerType >
bool DataStructures::SingleProducerConsumer< SingleProducerConsumerType >::ReadIsLocked ( void ) const

Returns if ReadUnlock was called before ReadLock

Returns
If the read is locked
template<class SingleProducerConsumerType >
SingleProducerConsumerType * DataStructures::SingleProducerConsumer< SingleProducerConsumerType >::ReadLock ( void )

ReadLock must be immediately followed by ReadUnlock. These two functions must be called in the same thread.

Return values
0 | No data is availble to read
Non-zero | The data previously written to, in another thread, by WriteLock followed by WriteUnlock.
template<class SingleProducerConsumerType >
void DataStructures::SingleProducerConsumer< SingleProducerConsumerType >::ReadUnlock ( void )

Signals that we are done reading the the data from the least recent call of ReadLock. At this point that pointer is no longer valid, and should no longer be read.

template<class SingleProducerConsumerType >
int DataStructures::SingleProducerConsumer< SingleProducerConsumerType >::Size ( void ) const

This function will estimate how many elements are waiting to be read. It's threadsafe enough that the value returned is stable, but not threadsafe enough to give accurate results.

Returns
An ESTIMATE of how many data elements are waiting to be read
template<class SingleProducerConsumerType >
SingleProducerConsumerType * DataStructures::SingleProducerConsumer< SingleProducerConsumerType >::WriteLock ( void )

WriteLock must be immediately followed by WriteUnlock. These two functions must be called in the same thread.

Returns
A pointer to a block of data you can write to.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/SingleProducerConsumer.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::AutopatcherRepositoryInterface Class Reference

  • AutopatcherRepositoryInterface
Public Member Functions | List of all members
RakNet::AutopatcherRepositoryInterface Class Referenceabstract

An interface used by AutopatcherServer to get the data necessary to run an autopatcher. This is up to you to implement for custom repository solutions. More...

#include <AutopatcherRepositoryInterface.h>

Inheritance diagram for RakNet::AutopatcherRepositoryInterface:
RakNet::AutopatcherMySQLRepository RakNet::AutopatcherPostgreRepository

Public Member Functions

virtual bool | GetChangelistSinceDate (const char *applicationName, FileList *addedOrModifiedFilesWithHashData, FileList *deletedFiles, double sinceDate)=0
virtual int | GetPatches (const char *applicationName, FileList *input, bool allowDownloadOfOriginalUnmodifiedFiles, FileList *patchList)=0
virtual bool | GetMostRecentChangelistWithPatches (RakNet::RakString &applicationName, FileList *patchedFiles, FileList *updatedFiles, FileList *addedOrModifiedFileHashes, FileList *deletedFiles, double *priorRowPatchTime, double *mostRecentRowPatchTime)=0
virtual const char * | GetLastError (void) const =0
virtual const int | GetIncrementalReadChunkSize (void) const =0
- Public Member Functions inherited from RakNet::IncrementalReadInterface
virtual unsigned int | GetFilePart (const char *filename, unsigned int startReadBytes, unsigned int numBytesToRead, void *preallocatedDestination, FileListNodeContext context)

Detailed Description

An interface used by AutopatcherServer to get the data necessary to run an autopatcher. This is up to you to implement for custom repository solutions.

Member Function Documentation

virtual bool RakNet::AutopatcherRepositoryInterface::GetChangelistSinceDate | ( | const char * | applicationName,
 |  | FileList * | addedOrModifiedFilesWithHashData,
 |  | FileList * | deletedFiles,
 |  | double | sinceDate
 | ) |  |
pure virtual

Get list of files added and deleted since a certain date. This is used by AutopatcherServer and not usually explicitly called.

Parameters
[in] | applicationName | A null terminated string identifying the application
[out] | addedFiles | A list of the current versions of filenames with hashes as their data that were created after sinceData
[out] | deletedFiles | A list of the current versions of filenames that were deleted after sinceData
[in] | An | input date, in whatever format your repository uses
[out] | currentDate | The current server date, in whatever format your repository uses
Returns
True on success, false on failure.

Implemented in RakNet::AutopatcherPostgreRepository, and RakNet::AutopatcherMySQLRepository.

virtual const int RakNet::AutopatcherRepositoryInterface::GetIncrementalReadChunkSize ( void ) const
pure virtual
Returns
Passed to FileListTransfer::Send() as the _chunkSize parameter.

Implemented in RakNet::AutopatcherPostgreRepository, and RakNet::AutopatcherMySQLRepository.

virtual const char* RakNet::AutopatcherRepositoryInterface::GetLastError ( void ) const
pure virtual
Returns
Whatever this function returns is sent from the AutopatcherServer to the AutopatcherClient when one of the above functions returns false.

Implemented in RakNet::AutopatcherPostgreRepository, and RakNet::AutopatcherMySQLRepository.

virtual bool RakNet::AutopatcherRepositoryInterface::GetMostRecentChangelistWithPatches | ( | RakNet::RakString & | applicationName,
 |  | FileList * | patchedFiles,
 |  | FileList * | updatedFiles,
 |  | FileList * | addedOrModifiedFileHashes,
 |  | FileList * | deletedFiles,
 |  | double * | priorRowPatchTime,
 |  | double * | mostRecentRowPatchTime
 | ) |  |
pure virtual

For the most recent update, return files that were patched, added, or deleted. For files that were patched, return both the patch in patchedFiles and the current version in updatedFiles

Parameters
[in,out] | applicationName | Name of the application to get patches for. If empty, uses the most recently updated application, and the string will be updated to reflect this name.
[out] | patchedFiles | A list of patched files with op PC_HASH_2_WITH_PATCH. It has 2 hashes, the priorHash and the currentHash. The currentHash is checked on the client after patching for patch success. The priorHash is checked in AutopatcherServer::OnGetPatch() to see if the client is able to hash with the version they currently have
[out] | patchedFiles | A list of new files. It contains the actual data in addition to the filename
[out] | addedOrModifiedFileHashes | A list of file hashes that were either modified or new. This is returned to the client when replying to ID_AUTOPATCHER_CREATION_LIST, which tells the client what files have changed on the server since a certain date
[out] | deletedFiles | A list of the current versions of filenames that were deleted in the most recent patch
[out] | whenPatched | time in seconds since epoch when patched. Use time() function to get this in C
Returns
true on success, false on failure

Implemented in RakNet::AutopatcherPostgreRepository, and RakNet::AutopatcherMySQLRepository.

virtual int RakNet::AutopatcherRepositoryInterface::GetPatches | ( | const char * | applicationName,
 |  | FileList * | input,
 |  | bool | allowDownloadOfOriginalUnmodifiedFiles,
 |  | FileList * | patchList
 | ) |  |
pure virtual

Get patches (or files) for every file in input, assuming that input has a hash for each of those files.

Parameters
[in] | applicationName | A null terminated string identifying the application
[in] | input | A list of files with SHA1_LENGTH byte hashes to get from the database.
[out] | patchList | You should return list of files with either the filedata or the patch. This is a subset of input. The context data for each file will be either PC_WRITE_FILE (to just write the file) or PC_HASH_WITH_PATCH (to patch). If PC_HASH_WITH_PATCH, then the file contains a SHA1_LENGTH byte patch followed by the hash. The datalength is patchlength + SHA1_LENGTH
[out] | currentDate | The current server date, in whatever format your repository uses
Returns
1 on success, 0 on database failure, -1 on tried to download original unmodified file

Implemented in RakNet::AutopatcherPostgreRepository, and RakNet::AutopatcherMySQLRepository.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/AutopatcherRepositoryInterface.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::BitStream Class Reference

  • BitStream
Public Member Functions | Static Public Member Functions | List of all members
RakNet::BitStream Class Reference

#include <BitStream.h>

Public Member Functions

BitStream ()
Default Constructor.
BitStream (const unsigned int initialBytesToAllocate)
Create the bitstream, with some number of bytes to immediately allocate.
BitStream (unsigned char *_data, const unsigned int lengthInBytes, bool _copyData)
Initialize the BitStream, immediately setting the data it contains to a predefined pointer.
void | Reset (void)
Resets the bitstream for reuse.
template<class templateType >
bool | Serialize (bool writeToBitstream, templateType &inOutTemplateVar)
Bidirectional serialize/deserialize any integral type to/from a bitstream.
template<class templateType >
bool | SerializeDelta (bool writeToBitstream, templateType &inOutCurrentValue, const templateType &lastValue)
Bidirectional serialize/deserialize any integral type to/from a bitstream.
template<class templateType >
bool | SerializeDelta (bool writeToBitstream, templateType &inOutCurrentValue)
Bidirectional version of SerializeDelta when you don't know what the last value is, or there is no last value.
template<class templateType >
bool | SerializeCompressed (bool writeToBitstream, templateType &inOutTemplateVar)
Bidirectional serialize/deserialize any integral type to/from a bitstream.
template<class templateType >
bool | SerializeCompressedDelta (bool writeToBitstream, templateType &inOutCurrentValue, const templateType &lastValue)
Bidirectional serialize/deserialize any integral type to/from a bitstream.
template<class templateType >
bool | SerializeCompressedDelta (bool writeToBitstream, templateType &inOutTemplateVar)
Save as SerializeCompressedDelta(templateType &currentValue, const templateType &lastValue) when we have an unknown second parameter.
bool | Serialize (bool writeToBitstream, char *inOutByteArray, const unsigned int numberOfBytes)
Bidirectional serialize/deserialize an array or casted stream or raw data. This does NOT do endian swapping.
bool | SerializeFloat16 (bool writeToBitstream, float &inOutFloat, float floatMin, float floatMax)
Serialize a float into 2 bytes, spanning the range between floatMin and floatMax.
template<class serializationType , class sourceType >
bool | SerializeCasted (bool writeToBitstream, sourceType &value)
template<class templateType >
bool | SerializeBitsFromIntegerRange (bool writeToBitstream, templateType &value, const templateType minimum, const templateType maximum, bool allowOutsideRange=false)
template<class templateType >
bool | SerializeBitsFromIntegerRange (bool writeToBitstream, templateType &value, const templateType minimum, const templateType maximum, const int requiredBits, bool allowOutsideRange=false)
template<class templateType >
bool | SerializeNormVector (bool writeToBitstream, templateType &x, templateType &y, templateType &z)
Bidirectional serialize/deserialize a normalized 3D vector, using (at most) 4 bytes + 3 bits instead of 12-24 bytes.
template<class templateType >
bool | SerializeVector (bool writeToBitstream, templateType &x, templateType &y, templateType &z)
Bidirectional serialize/deserialize a vector, using 10 bytes instead of 12.
template<class templateType >
bool | SerializeNormQuat (bool writeToBitstream, templateType &w, templateType &x, templateType &y, templateType &z)
Bidirectional serialize/deserialize a normalized quaternion in 6 bytes + 4 bits instead of 16 bytes. Slightly lossy.
template<class templateType >
bool | SerializeOrthMatrix (bool writeToBitstream, templateType &m00, templateType &m01, templateType &m02, templateType &m10, templateType &m11, templateType &m12, templateType &m20, templateType &m21, templateType &m22)
Bidirectional serialize/deserialize an orthogonal matrix by creating a quaternion, and writing 3 components of the quaternion in 2 bytes each.
bool | SerializeBits (bool writeToBitstream, unsigned char *inOutByteArray, const BitSize_t numberOfBitsToSerialize, const bool rightAlignedBits=true)
Bidirectional serialize/deserialize numberToSerialize bits to/from the input.
template<class templateType >
void | Write (const templateType &inTemplateVar)
Write any integral type to a bitstream.
template<class templateType >
void | WritePtr (templateType *inTemplateVar)
Write the dereferenced pointer to any integral type to a bitstream.
template<class templateType >
void | WriteDelta (const templateType &currentValue, const templateType &lastValue)
Write any integral type to a bitstream.
template<class templateType >
void | WriteDelta (const templateType &currentValue)
WriteDelta when you don't know what the last value is, or there is no last value.
template<class templateType >
void | WriteCompressed (const templateType &inTemplateVar)
Write any integral type to a bitstream.
template<class templateType >
void | WriteCompressedDelta (const templateType &currentValue, const templateType &lastValue)
Write any integral type to a bitstream.
template<class templateType >
void | WriteCompressedDelta (const templateType &currentValue)
Save as WriteCompressedDelta(const templateType &currentValue, const templateType &lastValue) when we have an unknown second parameter.
template<class templateType >
bool | Read (templateType &outTemplateVar)
Read any integral type from a bitstream.
template<class templateType >
bool | ReadDelta (templateType &outTemplateVar)
Read any integral type from a bitstream.
template<class templateType >
bool | ReadCompressed (templateType &outTemplateVar)
Read any integral type from a bitstream.
template<class templateType >
bool | ReadCompressedDelta (templateType &outTemplateVar)
Read any integral type from a bitstream.
bool | Read (BitStream *bitStream, BitSize_t numberOfBits)
Read one bitstream to another.
void | Write (const char *inputByteArray, const unsigned int numberOfBytes)
Write an array or casted stream or raw data. This does NOT do endian swapping.
void | Write (BitStream *bitStream, BitSize_t numberOfBits)
Write one bitstream to another.
void | WriteFloat16 (float x, float floatMin, float floatMax)
Write a float into 2 bytes, spanning the range between floatMin and floatMax.
template<class serializationType , class sourceType >
void | WriteCasted (const sourceType &value)
template<class templateType >
void | WriteBitsFromIntegerRange (const templateType value, const templateType minimum, const templateType maximum, bool allowOutsideRange=false)
template<class templateType >
void | WriteBitsFromIntegerRange (const templateType value, const templateType minimum, const templateType maximum, const int requiredBits, bool allowOutsideRange=false)
template<class templateType >
void | WriteNormVector (templateType x, templateType y, templateType z)
Write a normalized 3D vector, using (at most) 4 bytes + 3 bits instead of 12-24 bytes.
template<class templateType >
void | WriteVector (templateType x, templateType y, templateType z)
Write a vector, using 10 bytes instead of 12.
template<class templateType >
void | WriteNormQuat (templateType w, templateType x, templateType y, templateType z)
Write a normalized quaternion in 6 bytes + 4 bits instead of 16 bytes. Slightly lossy.
template<class templateType >
void | WriteOrthMatrix (templateType m00, templateType m01, templateType m02, templateType m10, templateType m11, templateType m12, templateType m20, templateType m21, templateType m22)
Write an orthogonal matrix by creating a quaternion, and writing 3 components of the quaternion in 2 bytes each.
bool | Read (char *output, const unsigned int numberOfBytes)
Read an array or casted stream of byte.
bool | ReadFloat16 (float &outFloat, float floatMin, float floatMax)
Read a float into 2 bytes, spanning the range between floatMin and floatMax.
template<class serializationType , class sourceType >
bool | ReadCasted (sourceType &value)
template<class templateType >
bool | ReadBitsFromIntegerRange (templateType &value, const templateType minimum, const templateType maximum, bool allowOutsideRange=false)
template<class templateType >
bool | ReadBitsFromIntegerRange (templateType &value, const templateType minimum, const templateType maximum, const int requiredBits, bool allowOutsideRange=false)
template<class templateType >
bool | ReadNormVector (templateType &x, templateType &y, templateType &z)
Read a normalized 3D vector, using (at most) 4 bytes + 3 bits instead of 12-24 bytes.
template<class templateType >
bool | ReadVector (templateType &x, templateType &y, templateType &z)
Read 3 floats or doubles, using 10 bytes, where those float or doubles comprise a vector.
template<class templateType >
bool | ReadNormQuat (templateType &w, templateType &x, templateType &y, templateType &z)
Read a normalized quaternion in 6 bytes + 4 bits instead of 16 bytes.
template<class templateType >
bool | ReadOrthMatrix (templateType &m00, templateType &m01, templateType &m02, templateType &m10, templateType &m11, templateType &m12, templateType &m20, templateType &m21, templateType &m22)
Read an orthogonal matrix from a quaternion, reading 3 components of the quaternion in 2 bytes each and extrapolatig the 4th.
void | ResetReadPointer (void)
Sets the read pointer back to the beginning of your data.
void | ResetWritePointer (void)
Sets the write pointer back to the beginning of your data.
void | AssertStreamEmpty (void)
This is good to call when you are done with the stream to make sure you didn't leave any data left over void.
void | PrintBits (char *out) const
RAKNET_DEBUG_PRINTF the bits in the stream. Great for debugging.
void | IgnoreBits (const BitSize_t numberOfBits)
Ignore data we don't intend to read.
void | IgnoreBytes (const unsigned int numberOfBytes)
Ignore data we don't intend to read.
void | SetWriteOffset (const BitSize_t offset)
Move the write pointer to a position on the array.
BitSize_t | GetNumberOfBitsUsed (void) const
Returns the length in bits of the stream.
BitSize_t | GetNumberOfBytesUsed (void) const
Returns the length in bytes of the stream.
BitSize_t | GetReadOffset (void) const
Returns the number of bits into the stream that we have read.
void | SetReadOffset (const BitSize_t newReadOffset)
Sets the read bit index.
BitSize_t | GetNumberOfUnreadBits (void) const
Returns the number of bits left in the stream that haven't been read.
BitSize_t | CopyData (unsigned char **_data) const
Makes a copy of the internal data for you _data will point to the stream. Partial bytes are left aligned.
unsigned char * | GetData (void) const
void | WriteBits (const unsigned char *inByteArray, BitSize_t numberOfBitsToWrite, const bool rightAlignedBits=true)
Write numberToWrite bits from the input source.
void | WriteAlignedBytes (const unsigned char *inByteArray, const unsigned int numberOfBytesToWrite)
Align the bitstream to the byte boundary and then write the specified number of bits.
void | WriteAlignedBytesSafe (const char *inByteArray, const unsigned int inputLength, const unsigned int maxBytesToWrite)
Aligns the bitstream, writes inputLength, and writes input. Won't write beyond maxBytesToWrite.
bool | ReadAlignedBytes (unsigned char *inOutByteArray, const unsigned int numberOfBytesToRead)
Read bits, starting at the next aligned bits.
bool | ReadAlignedBytesSafe (char *inOutByteArray, int &inputLength, const int maxBytesToRead)
Reads what was written by WriteAlignedBytesSafe.
bool | ReadAlignedBytesSafeAlloc (char **outByteArray, int &inputLength, const unsigned int maxBytesToRead)
Same as ReadAlignedBytesSafe() but allocates the memory for you using new, rather than assuming it is safe to write to.
void | AlignWriteToByteBoundary (void)
Align the next write and/or read to a byte boundary.
void | AlignReadToByteBoundary (void)
Align the next write and/or read to a byte boundary.
bool | ReadBits (unsigned char *inOutByteArray, BitSize_t numberOfBitsToRead, const bool alignBitsToRight=true)
Read numberOfBitsToRead bits to the output source.
void | Write0 (void)
Write a 0.
void | Write1 (void)
Write a 1.
bool | ReadBit (void)
Reads 1 bit and returns true if that bit is 1 and false if it is 0.
void | AssertCopyData (void)
If we used the constructor version with copy data off, this *makes sure it is set to on and the data pointed to is copied.
void | SetNumberOfBitsAllocated (const BitSize_t lengthInBits)
Use this if you pass a pointer copy to the constructor *(_copyData==false) and want to overallocate to prevent reallocation.
void | AddBitsAndReallocate (const BitSize_t numberOfBitsToWrite)
Reallocates (if necessary) in preparation of writing numberOfBitsToWrite.
bool | Read (char *varString)
Read strings, non reference.
void | PadWithZeroToByteLength (unsigned int bytes)
Write zeros until the bitstream is filled up to bytes.
template<>
void | Write (const bool &inTemplateVar)
Write a bool to a bitstream.
template<>
void | Write (const SystemAddress &inTemplateVar)
Write a systemAddress to a bitstream.
template<>
void | Write (const RakString &inTemplateVar)
Write a string to a bitstream.
template<>
void | WriteDelta (const bool &currentValue, const bool &lastValue)
Write a bool delta. Same thing as just calling Write.
template<>
void | WriteCompressed (const float &inTemplateVar)
For values between -1 and 1.
template<>
void | WriteCompressed (const double &inTemplateVar)
For values between -1 and 1.
template<>
void | WriteCompressed (const RakString &inTemplateVar)
Compress the string.
template<>
void | WriteCompressedDelta (const bool &currentValue, const bool &lastValue)
Write a bool delta. Same thing as just calling Write.
template<>
void | WriteCompressedDelta (const bool &currentValue)
Save as WriteCompressedDelta(bool currentValue, const templateType &lastValue) when we have an unknown second bool.
template<>
bool | Read (bool &outTemplateVar)
Read a bool from a bitstream.
template<>
bool | Read (SystemAddress &outTemplateVar)
Read a systemAddress from a bitstream.
template<>
bool | ReadDelta (bool &outTemplateVar)
Read a bool from a bitstream.
template<>
bool | ReadCompressed (float &outTemplateVar)
For values between -1 and 1.
template<>
bool | ReadCompressed (double &outTemplateVar)
For values between -1 and 1.
template<>
bool | ReadCompressed (RakString &outTemplateVar)
For strings.
template<>
bool | ReadCompressedDelta (bool &outTemplateVar)
Read a bool from a bitstream.

Static Public Member Functions

static int | NumberOfLeadingZeroes (uint8_t x)
static bool | DoEndianSwap (void)
-— Member function template specialization declarations -—

Detailed Description

This class allows you to write and read native types as a string of bits. BitStream is used extensively throughout RakNet and is designed to be used by users as well.

See Also
BitStreamSample.txt

Constructor & Destructor Documentation

RakNet::BitStream::BitStream ( const unsigned int initialBytesToAllocate )

Create the bitstream, with some number of bytes to immediately allocate.

There is no benefit to calling this, unless you know exactly how many bytes you need and it is greater than BITSTREAM_STACK_ALLOCATION_SIZE. In that case all it does is save you one or more realloc calls.

Parameters
[in] initialBytesToAllocate the number of bytes to pre-allocate.
RakNet::BitStream::BitStream | ( | unsigned char * | _data,
 |  | const unsigned int | lengthInBytes,
 |  | bool | _copyData
 | ) |  |

Initialize the BitStream, immediately setting the data it contains to a predefined pointer.

Set _copyData to true if you want to make an internal copy of the data you are passing. Set it to false to just save a pointer to the data. You shouldn't call Write functions with _copyData as false, as this will write to unallocated memory 99% of the time you will use this function to cast Packet::data to a bitstream for reading, in which case you should write something as follows:

RakNet::BitStream bs(packet->data, packet->length, false);
Parameters
[in] | _data | An array of bytes.
[in] | lengthInBytes | Size of the _data.
[in] | _copyData | true or false to make a copy of _data or not.

Member Function Documentation

void RakNet::BitStream::AlignReadToByteBoundary ( void )
inline

Align the next write and/or read to a byte boundary.

This can be used to 'waste' bits to byte align for efficiency reasons It can also be used to force coalesced bitstreams to start on byte boundaries so so WriteAlignedBits and ReadAlignedBits both calculate the same offset when aligning.

void RakNet::BitStream::AlignWriteToByteBoundary ( void )
inline

Align the next write and/or read to a byte boundary.

This can be used to 'waste' bits to byte align for efficiency reasons It can also be used to force coalesced bitstreams to start on byte boundaries so so WriteAlignedBits and ReadAlignedBits both calculate the same offset when aligning.

BitSize_t RakNet::BitStream::CopyData ( unsigned char ** _data ) const

Makes a copy of the internal data for you _data will point to the stream. Partial bytes are left aligned.

Parameters
[out] _data The allocated copy of GetData()
Returns
The length in bits of the stream.
unsigned char* RakNet::BitStream::GetData ( void ) const
inline

Gets the data that BitStream is writing to / reading from. Partial bytes are left aligned.

Returns
A pointer to the internal state
void RakNet::BitStream::IgnoreBits ( const BitSize_t numberOfBits )

Ignore data we don't intend to read.

Parameters
[in] numberOfBits The number of bits to ignore
void RakNet::BitStream::IgnoreBytes ( const unsigned int numberOfBytes )

Ignore data we don't intend to read.

Parameters
[in] numberOfBits The number of bytes to ignore
static int RakNet::BitStream::NumberOfLeadingZeroes ( uint8_t x )
static

Get the number of leading zeros for a number

Parameters
[in] x Number to test
template<class templateType >
bool RakNet::BitStream::Read ( templateType & outTemplateVar )
inline

Read any integral type from a bitstream.

Read any integral type from a bitstream. Define __BITSTREAM_NATIVE_END if you need endian swapping.

Define __BITSTREAM_NATIVE_END if you need endian swapping.

Parameters
[in] outTemplateVar The value to read
Returns
true on success, false on failure.
Parameters
[in] outTemplateVar The value to read
bool RakNet::BitStream::Read | ( | BitStream * | bitStream,
 |  | BitSize_t | numberOfBits
 | ) |  |

Read one bitstream to another.

Parameters
[in] | numberOfBits | bits to read
bitStream | the bitstream to read into from
Returns
true on success, false on failure.
bool RakNet::BitStream::Read | ( | char * | output,
 |  | const unsigned int | numberOfBytes
 | ) |  |

Read an array or casted stream of byte.

The array is raw data. There is no automatic endian conversion with this function

Parameters
[in] | output | The result byte array. It should be larger than numberOfBytes.
[in] | numberOfBytes | The number of byte to read
Returns
true on success false if there is some missing bytes.
template<>
bool RakNet::BitStream::Read ( bool & outTemplateVar )
inline

Read a bool from a bitstream.

Parameters
[in] outTemplateVar The value to read
template<>
bool RakNet::BitStream::Read ( SystemAddress & outTemplateVar )
inline

Read a systemAddress from a bitstream.

Parameters
[in] outTemplateVar The value to read
bool RakNet::BitStream::ReadAlignedBytes | ( | unsigned char * | inOutByteArray,
 |  | const unsigned int | numberOfBytesToRead
 | ) |  |

Read bits, starting at the next aligned bits.

Note that the modulus 8 starting offset of the sequence must be the same as was used with WriteBits. This will be a problem with packet coalescence unless you byte align the coalesced packets.

Parameters
[in] | inOutByteArray | The byte array larger than numberOfBytesToRead
[in] | numberOfBytesToRead | The number of byte to read from the internal state
Returns
true if there is enough byte.
bool RakNet::BitStream::ReadAlignedBytesSafe | ( | char * | inOutByteArray,
 |  | int & | inputLength,
 |  | const int | maxBytesToRead
 | ) |  |

Reads what was written by WriteAlignedBytesSafe.

Parameters
[in] | inOutByteArray | The data
[in] | maxBytesToRead | Maximum number of bytes to read
Returns
true on success, false on failure.
bool RakNet::BitStream::ReadAlignedBytesSafeAlloc | ( | char ** | outByteArray,
 |  | int & | inputLength,
 |  | const unsigned int | maxBytesToRead
 | ) |  |

Same as ReadAlignedBytesSafe() but allocates the memory for you using new, rather than assuming it is safe to write to.

Parameters
[in] outByteArray outByteArray will be deleted if it is not a pointer to 0
Returns
true on success, false on failure.
bool RakNet::BitStream::ReadBits | ( | unsigned char * | inOutByteArray,
 |  | BitSize_t | numberOfBitsToRead,
 |  | const bool | alignBitsToRight = true
 | ) |  |

Read numberOfBitsToRead bits to the output source.

alignBitsToRight should be set to true to convert internal bitstream data to userdata. It should be false if you used WriteBits with rightAlignedBits false

Parameters
[in] | inOutByteArray | The resulting bits array
[in] | numberOfBitsToRead | The number of bits to read
[in] | alignBitsToRight | if true bits will be right aligned.
Returns
true if there is enough bits to read
template<class templateType >
bool RakNet::BitStream::ReadBitsFromIntegerRange | ( | templateType & | value,
 |  | const templateType | minimum,
 |  | const templateType | maximum,
 |  | bool | allowOutsideRange = false
 | ) |  |

Given the minimum and maximum values for an integer type, figure out the minimum number of bits to represent the range Then read only those bits

Note
A static is used so that the required number of bits for (maximum-minimum) is only calculated once. This does require that minimum and are fixed values for a given line of code for the life of the program
Parameters
[in] | value | Integer value to read, which should be between minimum and maximum
[in] | minimum | Minimum value of value
[in] | maximum | Maximum value of value
[in] | allowOutsideRange | If true, all sends will take an extra bit, however value can deviate from outside minimum and maximum. If false, will assert if the value deviates. This should match the corresponding value passed to Write().
template<class templateType >
bool RakNet::BitStream::ReadBitsFromIntegerRange | ( | templateType & | value,
 |  | const templateType | minimum,
 |  | const templateType | maximum,
 |  | const int | requiredBits,
 |  | bool | allowOutsideRange = false
 | ) |  |
Parameters
[in] requiredBits Primarily for internal use, called from above function() after calculating number of bits needed to represent maximum-minimum
template<class serializationType , class sourceType >
bool RakNet::BitStream::ReadCasted ( sourceType & value )

Read one type serialized to another (smaller) type, to save bandwidth serializationType should be uint8_t, uint16_t, uint24_t, or uint32_t Example: int num; ReadCasted<uint8_t>(num); would read 1 bytefrom the stream, and put the value in an integer

Parameters
[in] value The value to write
template<class templateType >
bool RakNet::BitStream::ReadCompressed ( templateType & outTemplateVar )
inline

Read any integral type from a bitstream.

Undefine __BITSTREAM_NATIVE_END if you need endian swapping. For floating point, this is lossy, using 2 bytes for a float and 4 for a double. The range must be between -1 and +1. For non-floating point, this is lossless, but only has benefit if you use less than half the bits of the type If you are not using __BITSTREAM_NATIVE_END the opposite is true for types larger than 1 byte

Parameters
[in] outTemplateVar The value to read
Returns
true on success, false on failure.

Undefine __BITSTREAM_NATIVE_END if you need endian swapping. For floating point, this is lossy, using 2 bytes for a float and 4 for a double. The range must be between -1 and +1. For non-floating point, this is lossless, but only has benefit if you use less than half the bits of the type If you are not using __BITSTREAM_NATIVE_END the opposite is true for types larger than 1 byte

Parameters
[in] outTemplateVar The value to read
template<class templateType >
bool RakNet::BitStream::ReadCompressedDelta ( templateType & outTemplateVar )
inline

Read any integral type from a bitstream.

If the written value differed from the value compared against in the write function, var will be updated. Otherwise it will retain the current value. the current value will be updated. For floating point, this is lossy, using 2 bytes for a float and 4 for a double. The range must be between -1 and +1. For non-floating point, this is lossless, but only has benefit if you use less than half the bits of the type If you are not using __BITSTREAM_NATIVE_END the opposite is true for types larger than 1 byte ReadCompressedDelta is only valid from a previous call to WriteDelta

Parameters
[in] outTemplateVar The value to read
Returns
true on success, false on failure.

If the written value differed from the value compared against in the write function, var will be updated. Otherwise it will retain the current value. the current value will be updated. For floating point, this is lossy, using 2 bytes for a float and 4 for a double. The range must be between -1 and +1. For non-floating point, this is lossless, but only has benefit if you use less than half the bits of the type If you are not using __BITSTREAM_NATIVE_END the opposite is true for types larger than 1 byte ReadCompressedDelta is only valid from a previous call to WriteDelta

Parameters
[in] outTemplateVar The value to read
template<>
bool RakNet::BitStream::ReadCompressedDelta ( bool & outTemplateVar )
inline

Read a bool from a bitstream.

Parameters
[in] outTemplateVar The value to read
template<class templateType >
bool RakNet::BitStream::ReadDelta ( templateType & outTemplateVar )
inline

Read any integral type from a bitstream.

If the written value differed from the value compared against in the write function, var will be updated. Otherwise it will retain the current value. ReadDelta is only valid from a previous call to WriteDelta

Parameters
[in] outTemplateVar The value to read
Returns
true on success, false on failure.

If the written value differed from the value compared against in the write function, var will be updated. Otherwise it will retain the current value. ReadDelta is only valid from a previous call to WriteDelta

Parameters
[in] outTemplateVar The value to read
template<>
bool RakNet::BitStream::ReadDelta ( bool & outTemplateVar )
inline

Read a bool from a bitstream.

Parameters
[in] outTemplateVar The value to read
bool RakNet::BitStream::ReadFloat16 | ( | float & | outFloat,
 |  | float | floatMin,
 |  | float | floatMax
 | ) |  |

Read a float into 2 bytes, spanning the range between floatMin and floatMax.

Parameters
[in] | outFloat | The float to read
[in] | floatMin | Predetermined minimum value of f
[in] | floatMax | Predetermined maximum value of f
template<class templateType >
bool RakNet::BitStream::ReadNormQuat | ( | templateType & | w,
 |  | templateType & | x,
 |  | templateType & | y,
 |  | templateType & | z
 | ) |  |

Read a normalized quaternion in 6 bytes + 4 bits instead of 16 bytes.

Parameters
[in] | w | w
[in] | x | x
[in] | y | y
[in] | z | z
Returns
true on success, false on failure.
template<class templateType >
bool RakNet::BitStream::ReadNormVector | ( | templateType & | x,
 |  | templateType & | y,
 |  | templateType & | z
 | ) |  |

Read a normalized 3D vector, using (at most) 4 bytes + 3 bits instead of 12-24 bytes.

Will further compress y or z axis aligned vectors. Accurate to 1/32767.5.

Parameters
[in] | x | x
[in] | y | y
[in] | z | z
Returns
true on success, false on failure.
template<class templateType >
bool RakNet::BitStream::ReadOrthMatrix | ( | templateType & | m00,
 |  | templateType & | m01,
 |  | templateType & | m02,
 |  | templateType & | m10,
 |  | templateType & | m11,
 |  | templateType & | m12,
 |  | templateType & | m20,
 |  | templateType & | m21,
 |  | templateType & | m22
 | ) |  |

Read an orthogonal matrix from a quaternion, reading 3 components of the quaternion in 2 bytes each and extrapolatig the 4th.

Use 6 bytes instead of 36 Lossy, although the result is renormalized

Returns
true on success, false on failure.
template<class templateType >
bool RakNet::BitStream::ReadVector | ( | templateType & | x,
 |  | templateType & | y,
 |  | templateType & | z
 | ) |  |

Read 3 floats or doubles, using 10 bytes, where those float or doubles comprise a vector.

Loses accuracy to about 3/10ths and only saves 2 bytes, so only use if accuracy is not important.

Parameters
[in] | x | x
[in] | y | y
[in] | z | z
Returns
true on success, false on failure.
template<class templateType >
bool RakNet::BitStream::Serialize | ( | bool | writeToBitstream,
 |  | templateType & | inOutTemplateVar
 | ) |  |
inline

Bidirectional serialize/deserialize any integral type to/from a bitstream.

Undefine __BITSTREAM_NATIVE_END if you need endian swapping.

Parameters
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | inOutTemplateVar | The value to write
Returns
true if writeToBitstream is true. true if writeToBitstream is false and the read was successful. false if writeToBitstream is false and the read was not successful.
bool RakNet::BitStream::Serialize | ( | bool | writeToBitstream,
 |  | char * | inOutByteArray,
 |  | const unsigned int | numberOfBytes
 | ) |  |
inline

Bidirectional serialize/deserialize an array or casted stream or raw data. This does NOT do endian swapping.

Parameters
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | inOutByteArray | a byte buffer
[in] | numberOfBytes | the size of input in bytes
Returns
true if writeToBitstream is true. true if writeToBitstream is false and the read was successful. false if writeToBitstream is false and the read was not successful.
bool RakNet::BitStream::SerializeBits | ( | bool | writeToBitstream,
 |  | unsigned char * | inOutByteArray,
 |  | const BitSize_t | numberOfBitsToSerialize,
 |  | const bool | rightAlignedBits = true
 | ) |  |
inline

Bidirectional serialize/deserialize numberToSerialize bits to/from the input.

Right aligned data means in the case of a partial byte, the bits are aligned from the right (bit 0) rather than the left (as in the normal internal representation) You would set this to true when writing user data, and false when copying bitstream data, such as writing one bitstream to another

Parameters
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | inOutByteArray | The data
[in] | numberOfBitsToSerialize | The number of bits to write
[in] | rightAlignedBits | if true data will be right aligned
Returns
true if writeToBitstream is true. true if writeToBitstream is false and the read was successful. false if writeToBitstream is false and the read was not successful.
template<class templateType >
bool RakNet::BitStream::SerializeBitsFromIntegerRange | ( | bool | writeToBitstream,
 |  | templateType & | value,
 |  | const templateType | minimum,
 |  | const templateType | maximum,
 |  | bool | allowOutsideRange = false
 | ) |  |

Given the minimum and maximum values for an integer type, figure out the minimum number of bits to represent the range Then serialize only those bits

Note
A static is used so that the required number of bits for (maximum-minimum) is only calculated once. This does require that minimum and are fixed values for a given line of code for the life of the program
Parameters
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | value | Integer value to write, which should be between minimum and maximum
[in] | minimum | Minimum value of value
[in] | maximum | Maximum value of value
[in] | allowOutsideRange | If true, all sends will take an extra bit, however value can deviate from outside minimum and maximum. If false, will assert if the value deviates
template<class templateType >
bool RakNet::BitStream::SerializeBitsFromIntegerRange | ( | bool | writeToBitstream,
 |  | templateType & | value,
 |  | const templateType | minimum,
 |  | const templateType | maximum,
 |  | const int | requiredBits,
 |  | bool | allowOutsideRange = false
 | ) |  |
Parameters
[in] requiredBits Primarily for internal use, called from above function() after calculating number of bits needed to represent maximum-minimum
template<class serializationType , class sourceType >
bool RakNet::BitStream::SerializeCasted | ( | bool | writeToBitstream,
 |  | sourceType & | value
 | ) |  |

Serialize one type casted to another (smaller) type, to save bandwidth serializationType should be uint8_t, uint16_t, uint24_t, or uint32_t Example: int num=53; SerializeCasted<uint8_t>(true, num); would use 1 byte to write what would otherwise be an integer (4 or 8 bytes)

Parameters
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | value | The value to serialize
template<class templateType >
bool RakNet::BitStream::SerializeCompressed | ( | bool | writeToBitstream,
 |  | templateType & | inOutTemplateVar
 | ) |  |
inline

Bidirectional serialize/deserialize any integral type to/from a bitstream.

Undefine __BITSTREAM_NATIVE_END if you need endian swapping. If you are not using __BITSTREAM_NATIVE_END the opposite is true for types larger than 1 byte For floating point, this is lossy, using 2 bytes for a float and 4 for a double. The range must be between -1 and +1. For non-floating point, this is lossless, but only has benefit if you use less than half the bits of the type

Parameters
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | inOutTemplateVar | The value to write
Returns
true if writeToBitstream is true. true if writeToBitstream is false and the read was successful. false if writeToBitstream is false and the read was not successful.
template<class templateType >
bool RakNet::BitStream::SerializeCompressedDelta | ( | bool | writeToBitstream,
 |  | templateType & | inOutCurrentValue,
 |  | const templateType & | lastValue
 | ) |  |
inline

Bidirectional serialize/deserialize any integral type to/from a bitstream.

If the current value is different from the last value the current value will be written. Otherwise, a single bit will be written For floating point, this is lossy, using 2 bytes for a float and 4 for a double. The range must be between -1 and +1. For non-floating point, this is lossless, but only has benefit if you use less than half the bits of the type If you are not using __BITSTREAM_NATIVE_END the opposite is true for types larger than 1 byte

Parameters
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | inOutCurrentValue | The current value to write
[in] | lastValue | The last value to compare against. Only used if writeToBitstream is true.
Returns
true if writeToBitstream is true. true if writeToBitstream is false and the read was successful. false if writeToBitstream is false and the read was not successful.
template<class templateType >
bool RakNet::BitStream::SerializeCompressedDelta | ( | bool | writeToBitstream,
 |  | templateType & | inOutTemplateVar
 | ) |  |
inline

Save as SerializeCompressedDelta(templateType &currentValue, const templateType &lastValue) when we have an unknown second parameter.

Returns
true on data read. False on insufficient data in bitstream
template<class templateType >
bool RakNet::BitStream::SerializeDelta | ( | bool | writeToBitstream,
 |  | templateType & | inOutCurrentValue,
 |  | const templateType & | lastValue
 | ) |  |
inline

Bidirectional serialize/deserialize any integral type to/from a bitstream.

If the current value is different from the last value the current value will be written. Otherwise, a single bit will be written

Parameters
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | inOutCurrentValue | The current value to write
[in] | lastValue | The last value to compare against. Only used if writeToBitstream is true.
Returns
true if writeToBitstream is true. true if writeToBitstream is false and the read was successful. false if writeToBitstream is false and the read was not successful.
template<class templateType >
bool RakNet::BitStream::SerializeDelta | ( | bool | writeToBitstream,
 |  | templateType & | inOutCurrentValue
 | ) |  |
inline

Bidirectional version of SerializeDelta when you don't know what the last value is, or there is no last value.

Parameters
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | inOutCurrentValue | The current value to write
Returns
true if writeToBitstream is true. true if writeToBitstream is false and the read was successful. false if writeToBitstream is false and the read was not successful.
bool RakNet::BitStream::SerializeFloat16 | ( | bool | writeToBitstream,
 |  | float & | inOutFloat,
 |  | float | floatMin,
 |  | float | floatMax
 | ) |  |

Serialize a float into 2 bytes, spanning the range between floatMin and floatMax.

Parameters
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | inOutFloat | The float to write
[in] | floatMin | Predetermined minimum value of f
[in] | floatMax | Predetermined maximum value of f
template<class templateType >
bool RakNet::BitStream::SerializeNormQuat | ( | bool | writeToBitstream,
 |  | templateType & | w,
 |  | templateType & | x,
 |  | templateType & | y,
 |  | templateType & | z
 | ) |  |
inline

Bidirectional serialize/deserialize a normalized quaternion in 6 bytes + 4 bits instead of 16 bytes. Slightly lossy.

Parameters
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | w | w
[in] | x | x
[in] | y | y
[in] | z | z
Returns
true if writeToBitstream is true. true if writeToBitstream is false and the read was successful. false if writeToBitstream is false and the read was not successful.
template<class templateType >
bool RakNet::BitStream::SerializeNormVector | ( | bool | writeToBitstream,
 |  | templateType & | x,
 |  | templateType & | y,
 |  | templateType & | z
 | ) |  |
inline

Bidirectional serialize/deserialize a normalized 3D vector, using (at most) 4 bytes + 3 bits instead of 12-24 bytes.

Will further compress y or z axis aligned vectors. Accurate to 1/32767.5.

Parameters
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | x | x
[in] | y | y
[in] | z | z
Returns
true if writeToBitstream is true. true if writeToBitstream is false and the read was successful. false if writeToBitstream is false and the read was not successful.
template<class templateType >
bool RakNet::BitStream::SerializeOrthMatrix | ( | bool | writeToBitstream,
 |  | templateType & | m00,
 |  | templateType & | m01,
 |  | templateType & | m02,
 |  | templateType & | m10,
 |  | templateType & | m11,
 |  | templateType & | m12,
 |  | templateType & | m20,
 |  | templateType & | m21,
 |  | templateType & | m22
 | ) |  |
inline

Bidirectional serialize/deserialize an orthogonal matrix by creating a quaternion, and writing 3 components of the quaternion in 2 bytes each.

Use 6 bytes instead of 36 Lossy, although the result is renormalized

Returns
true on success, false on failure.
template<class templateType >
bool RakNet::BitStream::SerializeVector | ( | bool | writeToBitstream,
 |  | templateType & | x,
 |  | templateType & | y,
 |  | templateType & | z
 | ) |  |
inline

Bidirectional serialize/deserialize a vector, using 10 bytes instead of 12.

Loses accuracy to about 3/10ths and only saves 2 bytes, so only use if accuracy is not important.

Parameters
[in] | writeToBitstream | true to write from your data to this bitstream. False to read from this bitstream and write to your data
[in] | x | x
[in] | y | y
[in] | z | z
Returns
true if writeToBitstream is true. true if writeToBitstream is false and the read was successful. false if writeToBitstream is false and the read was not successful.
void RakNet::BitStream::SetWriteOffset ( const BitSize_t offset )

Move the write pointer to a position on the array.

Parameters
[in] offset the offset from the start of the array.
Attention

Dangerous if you don't know what you are doing! For efficiency reasons you can only write mid-stream if your data is byte aligned.

template<class templateType >
void RakNet::BitStream::Write ( const templateType & inTemplateVar )
inline

Write any integral type to a bitstream.

Undefine __BITSTREAM_NATIVE_END if you need endian swapping.

Parameters
[in] inTemplateVar The value to write
void RakNet::BitStream::Write | ( | const char * | inputByteArray,
 |  | const unsigned int | numberOfBytes
 | ) |  |

Write an array or casted stream or raw data. This does NOT do endian swapping.

Parameters
[in] | inputByteArray | a byte buffer
[in] | numberOfBytes | the size of input in bytes
void RakNet::BitStream::Write | ( | BitStream * | bitStream,
 |  | BitSize_t | numberOfBits
 | ) |  |

Write one bitstream to another.

Parameters
[in] | numberOfBits | bits to write
bitStream | the bitstream to copy from
template<>
void RakNet::BitStream::Write ( const bool & inTemplateVar )
inline

Write a bool to a bitstream.

Parameters
[in] inTemplateVar The value to write
template<>
void RakNet::BitStream::Write ( const SystemAddress & inTemplateVar )
inline

Write a systemAddress to a bitstream.

Parameters
[in] inTemplateVar The value to write
template<>
void RakNet::BitStream::Write ( const RakString & inTemplateVar )
inline

Write a string to a bitstream.

Parameters
[in] var The value to write
void RakNet::BitStream::WriteAlignedBytes | ( | const unsigned char * | inByteArray,
 |  | const unsigned int | numberOfBytesToWrite
 | ) |  |

Align the bitstream to the byte boundary and then write the specified number of bits.

This is faster than WriteBits but wastes the bits to do the alignment and requires you to call ReadAlignedBits at the corresponding read position.

Parameters
[in] | inByteArray | The data
[in] | numberOfBytesToWrite | The size of input.
void RakNet::BitStream::WriteAlignedBytesSafe | ( | const char * | inByteArray,
 |  | const unsigned int | inputLength,
 |  | const unsigned int | maxBytesToWrite
 | ) |  |

Aligns the bitstream, writes inputLength, and writes input. Won't write beyond maxBytesToWrite.

Parameters
[in] | inByteArray | The data
[in] | inputLength | The size of input.
[in] | maxBytesToWrite | Max bytes to write
void RakNet::BitStream::WriteBits | ( | const unsigned char * | inByteArray,
 |  | BitSize_t | numberOfBitsToWrite,
 |  | const bool | rightAlignedBits = true
 | ) |  |

Write numberToWrite bits from the input source.

Right aligned data means in the case of a partial byte, the bits are aligned from the right (bit 0) rather than the left (as in the normal internal representation) You would set this to true when writing user data, and false when copying bitstream data, such as writing one bitstream to another.

Parameters
[in] | inByteArray | The data
[in] | numberOfBitsToWrite | The number of bits to write
[in] | rightAlignedBits | if true data will be right aligned
template<class templateType >
void RakNet::BitStream::WriteBitsFromIntegerRange | ( | const templateType | value,
 |  | const templateType | minimum,
 |  | const templateType | maximum,
 |  | bool | allowOutsideRange = false
 | ) |  |

Given the minimum and maximum values for an integer type, figure out the minimum number of bits to represent the range Then write only those bits

Note
A static is used so that the required number of bits for (maximum-minimum) is only calculated once. This does require that minimum and are fixed values for a given line of code for the life of the program
Parameters
[in] | value | Integer value to write, which should be between minimum and maximum
[in] | minimum | Minimum value of value
[in] | maximum | Maximum value of value
[in] | allowOutsideRange | If true, all sends will take an extra bit, however value can deviate from outside minimum and maximum. If false, will assert if the value deviates. This should match the corresponding value passed to Read().
template<class templateType >
void RakNet::BitStream::WriteBitsFromIntegerRange | ( | const templateType | value,
 |  | const templateType | minimum,
 |  | const templateType | maximum,
 |  | const int | requiredBits,
 |  | bool | allowOutsideRange = false
 | ) |  |
Parameters
[in] requiredBits Primarily for internal use, called from above function() after calculating number of bits needed to represent maximum-minimum
template<class destinationType , class sourceType >
void RakNet::BitStream::WriteCasted ( const sourceType & value )

Write one type serialized as another (smaller) type, to save bandwidth serializationType should be uint8_t, uint16_t, uint24_t, or uint32_t Example: int num=53; WriteCasted<uint8_t>(num); would use 1 byte to write what would otherwise be an integer (4 or 8 bytes)

Parameters
[in] value The value to write
template<class templateType >
void RakNet::BitStream::WriteCompressed ( const templateType & inTemplateVar )
inline

Write any integral type to a bitstream.

Undefine __BITSTREAM_NATIVE_END if you need endian swapping. If you are not using __BITSTREAM_NATIVE_END the opposite is true for types larger than 1 byte For floating point, this is lossy, using 2 bytes for a float and 4 for a double. The range must be between -1 and +1. For non-floating point, this is lossless, but only has benefit if you use less than half the bits of the type

Parameters
[in] inTemplateVar The value to write

Undefine __BITSTREAM_NATIVE_END if you need endian swapping. For floating point, this is lossy, using 2 bytes for a float and 4 for a double. The range must be between -1 and +1. For non-floating point, this is lossless, but only has benefit if you use less than half the bits of the type If you are not using __BITSTREAM_NATIVE_END the opposite is true for types larger than 1 byte

Parameters
[in] inTemplateVar The value to write
template<class templateType >
void RakNet::BitStream::WriteCompressedDelta | ( | const templateType & | currentValue,
 |  | const templateType & | lastValue
 | ) |  |
inline

Write any integral type to a bitstream.

If the current value is different from the last value the current value will be written. Otherwise, a single bit will be written For floating point, this is lossy, using 2 bytes for a float and 4 for a double. The range must be between -1 and +1. For non-floating point, this is lossless, but only has benefit if you use less than half the bits of the type If you are not using __BITSTREAM_NATIVE_END the opposite is true for types larger than 1 byte

Parameters
[in] | currentValue | The current value to write
[in] | lastValue | The last value to compare against
template<>
void RakNet::BitStream::WriteCompressedDelta | ( | const bool & | currentValue,
 |  | const bool & | lastValue
 | ) |  |
inline

Write a bool delta. Same thing as just calling Write.

Parameters
[in] | currentValue | The current value to write
[in] | lastValue | The last value to compare against
template<class templateType >
void RakNet::BitStream::WriteDelta | ( | const templateType & | currentValue,
 |  | const templateType & | lastValue
 | ) |  |
inline

Write any integral type to a bitstream.

If the current value is different from the last value the current value will be written. Otherwise, a single bit will be written

Parameters
[in] | currentValue | The current value to write
[in] | lastValue | The last value to compare against
template<class templateType >
void RakNet::BitStream::WriteDelta ( const templateType & currentValue )
inline

WriteDelta when you don't know what the last value is, or there is no last value.

Parameters
[in] currentValue The current value to write
template<>
void RakNet::BitStream::WriteDelta | ( | const bool & | currentValue,
 |  | const bool & | lastValue
 | ) |  |
inline

Write a bool delta. Same thing as just calling Write.

Parameters
[in] | currentValue | The current value to write
[in] | lastValue | The last value to compare against
void RakNet::BitStream::WriteFloat16 | ( | float | x,
 |  | float | floatMin,
 |  | float | floatMax
 | ) |  |

Write a float into 2 bytes, spanning the range between floatMin and floatMax.

Parameters
[in] | x | The float to write
[in] | floatMin | Predetermined minimum value of f
[in] | floatMax | Predetermined maximum value of f
template<class templateType >
void RakNet::BitStream::WriteNormQuat | ( | templateType | w,
 |  | templateType | x,
 |  | templateType | y,
 |  | templateType | z
 | ) |  |

Write a normalized quaternion in 6 bytes + 4 bits instead of 16 bytes. Slightly lossy.

Parameters
[in] | w | w
[in] | x | x
[in] | y | y
[in] | z | z
template<class templateType >
void RakNet::BitStream::WriteNormVector | ( | templateType | x,
 |  | templateType | y,
 |  | templateType | z
 | ) |  |

Write a normalized 3D vector, using (at most) 4 bytes + 3 bits instead of 12-24 bytes.

Will further compress y or z axis aligned vectors. Accurate to 1/32767.5.

Parameters
[in] | x | x
[in] | y | y
[in] | z | z
template<class templateType >
void RakNet::BitStream::WriteOrthMatrix | ( | templateType | m00,
 |  | templateType | m01,
 |  | templateType | m02,
 |  | templateType | m10,
 |  | templateType | m11,
 |  | templateType | m12,
 |  | templateType | m20,
 |  | templateType | m21,
 |  | templateType | m22
 | ) |  |

Write an orthogonal matrix by creating a quaternion, and writing 3 components of the quaternion in 2 bytes each.

Use 6 bytes instead of 36 Lossy, although the result is renormalized

template<class templateType >
void RakNet::BitStream::WritePtr ( templateType * inTemplateVar )
inline

Write the dereferenced pointer to any integral type to a bitstream.

Undefine __BITSTREAM_NATIVE_END if you need endian swapping.

Parameters
[in] inTemplateVar The value to write
template<class templateType >
void RakNet::BitStream::WriteVector | ( | templateType | x,
 |  | templateType | y,
 |  | templateType | z
 | ) |  |

Write a vector, using 10 bytes instead of 12.

Loses accuracy to about 3/10ths and only saves 2 bytes, so only use if accuracy is not important.

Parameters
[in] | x | x
[in] | y | y
[in] | z | z
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/BitStream.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::CommandParserInterface Class Reference

  • CommandParserInterface
Public Member Functions | List of all members
RakNet::CommandParserInterface Class Referenceabstract

The interface used by command parsers. More...

#include <CommandParserInterface.h>

Inheritance diagram for RakNet::CommandParserInterface:
RakNet::LogCommandParser RakNet::RakNetCommandParser

Public Member Functions

virtual const char * | GetName (void) const =0
virtual void | OnNewIncomingConnection (const SystemAddress &systemAddress, TransportInterface *transport)
A callback for when systemAddress has connected to us.
virtual void | OnConnectionLost (const SystemAddress &systemAddress, TransportInterface *transport)
A callback for when systemAddress has disconnected, either gracefully or forcefully.
virtual void | SendHelp (TransportInterface *transport, const SystemAddress &systemAddress)=0
A callback for when you are expected to send a brief description of your parser to systemAddress.
virtual bool | OnCommand (const char *command, unsigned numParameters, char **parameterList, TransportInterface *transport, const SystemAddress &systemAddress, const char *originalString)=0
Given command with parameters parameterList , do whatever processing you wish.
virtual void | OnTransportChange (TransportInterface *transport)
This is called every time transport interface is registered.
virtual void | RegisterCommand (unsigned char parameterCount, const char *command, const char *commandHelp)
virtual void | ReturnResult (bool res, const char *command, TransportInterface *transport, const SystemAddress &systemAddress)
Just writes a string to the remote system based on the result ( res ) of your operation.
virtual void | ReturnResult (const char *command, TransportInterface *transport, const SystemAddress &systemAddress)
Just writes a string to the remote system when you are calling a function that has no return value.

Detailed Description

The interface used by command parsers.

CommandParserInterface provides a set of functions and interfaces that plug into the ConsoleServer class. Each CommandParserInterface works at the same time as other interfaces in the system.

Member Function Documentation

virtual const char* RakNet::CommandParserInterface::GetName ( void ) const
pure virtual

You are responsible for overriding this function and returning a static string, which will identifier your parser. This should return a static string

Returns
The name that you return.

Implemented in RakNet::LogCommandParser, and RakNet::RakNetCommandParser.

virtual bool RakNet::CommandParserInterface::OnCommand | ( | const char * | command,
 |  | unsigned | numParameters,
 |  | char ** | parameterList,
 |  | TransportInterface * | transport,
 |  | const SystemAddress & | systemAddress,
 |  | const char * | originalString
 | ) |  |
pure virtual

Given command with parameters parameterList , do whatever processing you wish.

Parameters
[in] | command | The command to process
[in] | numParameters | How many parameters were passed along with the command
[in] | parameterList | The list of parameters. parameterList[0] is the first parameter and so on.
[in] | transport | The transport interface we can use to write to
[in] | systemAddress | The player that sent this command.
[in] | originalString | The string that was actually sent over the network, in case you want to do your own parsing

Implemented in RakNet::LogCommandParser, and RakNet::RakNetCommandParser.

virtual void RakNet::CommandParserInterface::OnConnectionLost | ( | const SystemAddress & | systemAddress,
 |  | TransportInterface * | transport
 | ) |  |
virtual

A callback for when systemAddress has disconnected, either gracefully or forcefully.

Parameters
[in] | systemAddress | The player that has disconnected.
[in] | transport | The transport interface that sent us this information.

Reimplemented in RakNet::LogCommandParser.

virtual void RakNet::CommandParserInterface::OnNewIncomingConnection | ( | const SystemAddress & | systemAddress,
 |  | TransportInterface * | transport
 | ) |  |
virtual

A callback for when systemAddress has connected to us.

Parameters
[in] | systemAddress | The player that has connected.
[in] | transport | The transport interface that sent us this information. Can be used to send messages to this or other players.

Reimplemented in RakNet::LogCommandParser.

virtual void RakNet::CommandParserInterface::OnTransportChange ( TransportInterface * transport )
virtual

This is called every time transport interface is registered.

If you want to save a copy of the TransportInterface pointer This is the place to do it

Parameters
[in] transport The new TransportInterface

Reimplemented in RakNet::LogCommandParser.

virtual void RakNet::CommandParserInterface::RegisterCommand | ( | unsigned char | parameterCount,
 |  | const char * | command,
 |  | const char * | commandHelp
 | ) |  |
virtual

Registers a command.

Parameters
[in] | parameterCount | How many parameters your command requires. If you want to accept a variable number of commands, pass CommandParserInterface::VARIABLE_NUMBER_OF_PARAMETERS
[in] | command | A pointer to a STATIC string that has your command. I keep a copy of the pointer here so don't deallocate the string.
[in] | commandHelp | A pointer to a STATIC string that has the help information for your command. I keep a copy of the pointer here so don't deallocate the string.
virtual void RakNet::CommandParserInterface::ReturnResult | ( | bool | res,
 |  | const char * | command,
 |  | TransportInterface * | transport,
 |  | const SystemAddress & | systemAddress
 | ) |  |
virtual

Just writes a string to the remote system based on the result ( res ) of your operation.

This is not necessary to call, but makes it easier to return results of function calls.

Parameters
[in] | res | The result to write
[in] | command | The command that this result came from
[in] | transport | The transport interface that will be written to
[in] | systemAddress | The player this result will be sent to
virtual void RakNet::CommandParserInterface::ReturnResult | ( | const char * | command,
 |  | TransportInterface * | transport,
 |  | const SystemAddress & | systemAddress
 | ) |  |
virtual

Just writes a string to the remote system when you are calling a function that has no return value.

This is not necessary to call, but makes it easier to return results of function calls.

Parameters
[in] | res | The result to write
[in] | command | The command that this result came from
[in] | transport | The transport interface that will be written to
[in] | systemAddress | The player this result will be sent to
virtual void RakNet::CommandParserInterface::SendHelp | ( | TransportInterface * | transport,
 |  | const SystemAddress & | systemAddress
 | ) |  |
pure virtual

A callback for when you are expected to send a brief description of your parser to systemAddress.

Parameters
[in] | transport | The transport interface we can use to write to
[in] | systemAddress | The player that requested help.

Implemented in RakNet::LogCommandParser, and RakNet::RakNetCommandParser.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/CommandParserInterface.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::ConnectionGraph2 Class Reference

  • ConnectionGraph2
Public Member Functions | Protected Member Functions | List of all members
RakNet::ConnectionGraph2 Class Reference

A one hop connection graph. More...

#include <ConnectionGraph2.h>

Inheritance diagram for RakNet::ConnectionGraph2:
RakNet::PluginInterface2

Public Member Functions

bool | GetConnectionListForRemoteSystem (RakNetGUID remoteSystemGuid, SystemAddress *saOut, RakNetGUID *guidOut, unsigned int *outLength)
Given a remote system identified by RakNetGUID, return the list of SystemAddresses and RakNetGUIDs they are connected to.
bool | ConnectionExists (RakNetGUID g1, RakNetGUID g2)
Returns if g1 is connected to g2.
uint16_t | GetPingBetweenSystems (RakNetGUID g1, RakNetGUID g2) const
Returns the average ping between two systems in the connection graph. Returns -1 if no connection exists between those systems.
RakNetGUID | GetLowestAveragePingSystem (void) const
void | SetAutoProcessNewConnections (bool b)
If called with false, then new connections are only added to the connection graph when you call ProcessNewConnection();.
bool | GetAutoProcessNewConnections (void) const
Returns value passed to SetAutoProcessNewConnections()
void | AddParticipant (const SystemAddress &systemAddress, RakNetGUID rakNetGUID)
If you call SetAutoProcessNewConnections(false);, then you will need to manually call ProcessNewConnection() on new connections.
void | GetParticipantList (DataStructures::OrderedList< RakNetGUID, RakNetGUID > &participantList)
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Protected Member Functions

virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual PluginReceiveResult | OnReceive (Packet *packet)

Detailed Description

A one hop connection graph.

Sends ID_REMOTE_CONNECTION_LOST, ID_REMOTE_DISCONNECTION_NOTIFICATION, ID_REMOTE_NEW_INCOMING_CONNECTION
All identifiers are followed by SystemAddress, then RakNetGUID Also stores the list for you, which you can access with GetConnectionListForRemoteSystem

Member Function Documentation

void RakNet::ConnectionGraph2::AddParticipant | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID
 | ) |  |

If you call SetAutoProcessNewConnections(false);, then you will need to manually call ProcessNewConnection() on new connections.

On ID_NEW_INCOMING_CONNECTION or ID_CONNECTION_REQUEST_ACCEPTED, adds that system to the graph Do not call ProcessNewConnection() manually otherwise

Parameters
[in] | The | packet->SystemAddress member
[in] | The | packet->guid member
bool RakNet::ConnectionGraph2::GetAutoProcessNewConnections ( void ) const

Returns value passed to SetAutoProcessNewConnections()

Returns
Value passed to SetAutoProcessNewConnections(), or the default of true if it was never called
bool RakNet::ConnectionGraph2::GetConnectionListForRemoteSystem | ( | RakNetGUID | remoteSystemGuid,
 |  | SystemAddress * | saOut,
 |  | RakNetGUID * | guidOut,
 |  | unsigned int * | outLength
 | ) |  |

Given a remote system identified by RakNetGUID, return the list of SystemAddresses and RakNetGUIDs they are connected to.

Parameters
[in] | remoteSystemGuid | Which system we are referring to. This only works for remote systems, not ourselves.
[out] | saOut | A preallocated array to hold the output list of SystemAddress. Can be 0 if you don't care.
[out] | guidOut | A preallocated array to hold the output list of RakNetGUID. Can be 0 if you don't care.
[in,out] | outLength | On input, the size of saOut and guidOut. On output, modified to reflect the number of elements actually written
Returns
True if remoteSystemGuid was found. Otherwise false, and saOut, guidOut remain unchanged. outLength will be set to 0.
RakNetGUID RakNet::ConnectionGraph2::GetLowestAveragePingSystem ( void ) const

Returns the system with the lowest average ping among all its connections. If you need one system in the peer to peer group to relay data, have the FullyConnectedMesh2 host call this function after host migration, and use that system

void RakNet::ConnectionGraph2::GetParticipantList ( DataStructures::OrderedList< RakNetGUID, RakNetGUID > & participantList )

Get the participants added with AddParticipant()

Parameters
[out] participantList Participants added with AddParticipant();
virtual void RakNet::ConnectionGraph2::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
protectedvirtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual void RakNet::ConnectionGraph2::OnNewConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | bool | isIncoming
 | ) |  |
protectedvirtual

Called when we got a new connection

Parameters
[in] | systemAddress | Address of the new connection
[in] | rakNetGuid | The guid of the specified system
[in] | isIncoming | If true, this is ID_NEW_INCOMING_CONNECTION, or the equivalent

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::ConnectionGraph2::OnReceive ( Packet * packet )
protectedvirtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

void RakNet::ConnectionGraph2::SetAutoProcessNewConnections ( bool b )

If called with false, then new connections are only added to the connection graph when you call ProcessNewConnection();.

This is useful if you want to perform validation before connecting a system to a mesh, or if you want a submesh (for example a server cloud)

Parameters
[in] b True to automatically call ProcessNewConnection() on any new connection, false to not do so. Defaults to true.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/ConnectionGraph2.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::ConsoleServer Class Reference

  • ConsoleServer
Public Member Functions | List of all members
RakNet::ConsoleServer Class Reference

The main entry point for the server portion of your remote console application support. More...

#include <ConsoleServer.h>

Public Member Functions

void | SetTransportProvider (TransportInterface *transportInterface, unsigned short port)
Call this with a derivation of TransportInterface so that the console server can send and receive commands.
void | AddCommandParser (CommandParserInterface *commandParserInterface)
Add an implementation of CommandParserInterface to the list of command parsers.
void | RemoveCommandParser (CommandParserInterface *commandParserInterface)
Remove an implementation of CommandParserInterface previously added with AddCommandParser().
void | Update (void)
Call update to read packet sent from your TransportInterface. You should do this fairly frequently.
void | SetPrompt (const char *_prompt)
Sets a prompt to show when waiting for user input.

Detailed Description

The main entry point for the server portion of your remote console application support.

ConsoleServer takes one TransportInterface and one or more CommandParserInterface (s) The TransportInterface will be used to send data between the server and the client. The connecting client must support the protocol used by your derivation of TransportInterface . TelnetTransport and RakNetTransport are two such derivations . When a command is sent by a remote console, it will be processed by your implementations of CommandParserInterface

Member Function Documentation

void RakNet::ConsoleServer::AddCommandParser ( CommandParserInterface * commandParserInterface )

Add an implementation of CommandParserInterface to the list of command parsers.

Parameters
[in] commandParserInterface The command parser referred to
void RakNet::ConsoleServer::RemoveCommandParser ( CommandParserInterface * commandParserInterface )

Remove an implementation of CommandParserInterface previously added with AddCommandParser().

Parameters
[in] commandParserInterface The command parser referred to
void RakNet::ConsoleServer::SetPrompt ( const char * _prompt )

Sets a prompt to show when waiting for user input.

Pass an empty string to clear the prompt Defaults to no prompt

Parameters
[in] _prompt Null-terminated string of the prompt to use. If you want a newline, be sure to use /r/n
void RakNet::ConsoleServer::SetTransportProvider | ( | TransportInterface * | transportInterface,
 |  | unsigned short | port
 | ) |  |

Call this with a derivation of TransportInterface so that the console server can send and receive commands.

Parameters
[in] | transportInterface | Your interface to use.
[in] | port | The port to host on. Telnet uses port 23 by default. RakNet can use whatever you want.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/ConsoleServer.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::DataCompressor Class Reference

  • DataCompressor
List of all members
RakNet::DataCompressor Class Reference

Does compression on a block of data. Not very good compression, but it's small and fast so is something you can compute at runtime. More...

#include <DataCompressor.h>

Detailed Description

Does compression on a block of data. Not very good compression, but it's small and fast so is something you can compute at runtime.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/DataCompressor.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::HuffmanEncodingTree Class Reference

  • HuffmanEncodingTree
Public Member Functions | List of all members
RakNet::HuffmanEncodingTree Class Reference

This generates special cases of the huffman encoding tree using 8 bit keys with the additional condition that unused combinations of 8 bits are treated as a frequency of 1. More...

#include <DS_HuffmanEncodingTree.h>

Public Member Functions

void | EncodeArray (unsigned char *input, size_t sizeInBytes, RakNet::BitStream *output)
Pass an array of bytes to array and a preallocated BitStream to receive the output.
void | GenerateFromFrequencyTable (unsigned int frequencyTable[256])
Given a frequency table of 256 elements, all with a frequency of 1 or more, generate the tree.
void | FreeMemory (void)
Free the memory used by the tree.

Detailed Description

This generates special cases of the huffman encoding tree using 8 bit keys with the additional condition that unused combinations of 8 bits are treated as a frequency of 1.

Member Function Documentation

void RakNet::HuffmanEncodingTree::EncodeArray | ( | unsigned char * | input,
 |  | size_t | sizeInBytes,
 |  | RakNet::BitStream * | output
 | ) |  |

Pass an array of bytes to array and a preallocated BitStream to receive the output.

Parameters
[in] | input | Array of bytes to encode
[in] | sizeInBytes | size of input
[out] | output | The bitstream to write to
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/DS_HuffmanEncodingTree.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::HuffmanEncodingTreeFactory Class Reference

  • HuffmanEncodingTreeFactory
Public Member Functions | List of all members
RakNet::HuffmanEncodingTreeFactory Class Reference

Creates instances of the class HuffmanEncodingTree. More...

#include <DS_HuffmanEncodingTreeFactory.h>

Public Member Functions

HuffmanEncodingTreeFactory ()
Default constructor.
void | Reset (void)
Reset the frequency table.
void | AddToFrequencyTable (unsigned char *array, int size)
Pass an array of bytes to this to add those elements to the frequency table.
void | GetFrequencyTable (unsigned int _frequency[256])
Copies the frequency table to the array passed. Retrieve the frequency table.
unsigned int * | GetFrequencyTable (void)
Returns the frequency table as a pointer.
HuffmanEncodingTree * | GenerateTree (void)
Generate a HuffmanEncodingTree.

Detailed Description

Creates instances of the class HuffmanEncodingTree.

This class takes a frequency table and given that frequence table, will generate an instance of HuffmanEncodingTree

Member Function Documentation

void RakNet::HuffmanEncodingTreeFactory::AddToFrequencyTable | ( | unsigned char * | array,
 |  | int | size
 | ) |  |

Pass an array of bytes to this to add those elements to the frequency table.

Parameters
[in] | array | the data to insert into the frequency table
[in] | size | the size of the data to insert
HuffmanEncodingTree* RakNet::HuffmanEncodingTreeFactory::GenerateTree ( void )

Generate a HuffmanEncodingTree.

You can also use GetFrequencyTable and GenerateFromFrequencyTable in the tree itself

Returns
The generated instance of HuffmanEncodingTree
void RakNet::HuffmanEncodingTreeFactory::GetFrequencyTable ( unsigned int _frequency[256] )

Copies the frequency table to the array passed. Retrieve the frequency table.

Parameters
[in] _frequency The frequency table used currently
unsigned int* RakNet::HuffmanEncodingTreeFactory::GetFrequencyTable ( void )

Returns the frequency table as a pointer.

Returns
the address of the frenquency table
void RakNet::HuffmanEncodingTreeFactory::Reset ( void )

Reset the frequency table.

You don't need to call this unless you want to reuse the class for a new tree

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/DS_HuffmanEncodingTreeFactory.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::EmailSender Class Reference

  • EmailSender
Public Member Functions | List of all members
RakNet::EmailSender Class Reference

Rudimentary class to send email from code. More...

#include <EmailSender.h>

Public Member Functions

const char * Send (const char *hostAddress, unsigned short hostPort, const char *sender, const char *recipient, const char *senderName, const char *recipientName, const char *subject, const char *body, FileList *attachedFiles, bool doPrintf, const char *password)
Sends an email.

Detailed Description

Rudimentary class to send email from code.

Member Function Documentation

const char* RakNet::EmailSender::Send | ( | const char * | hostAddress,
 |  | unsigned short | hostPort,
 |  | const char * | sender,
 |  | const char * | recipient,
 |  | const char * | senderName,
 |  | const char * | recipientName,
 |  | const char * | subject,
 |  | const char * | body,
 |  | FileList * | attachedFiles,
 |  | bool | doPrintf,
 |  | const char * | password
 | ) |  |

Sends an email.

Parameters
[in] | hostAddress | The address of the email server.
[in] | hostPort | The port of the email server (usually 25)
[in] | sender | The email address you are sending from.
[in] | recipient | The email address you are sending to.
[in] | senderName | The email address you claim to be sending from
[in] | recipientName | The email address you claim to be sending to
[in] | subject | Email subject
[in] | body | Email body
[in] | attachedFiles | List of files to attach to the email. (Can be 0 to send none).
[in] | doPrintf | true to output SMTP info to console(for debugging?)
[in] | password | Used if the server uses AUTHENTICATE PLAIN over TLS (such as gmail)
Returns
0 on success, otherwise a string indicating the error message
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/EmailSender.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::FileListNode Struct Reference

  • FileListNode
Public Attributes | List of all members
RakNet::FileListNode Struct Reference

Represents once instance of a file. More...

#include <FileList.h>

Public Attributes

RakNet::RakString filename
Name of the file.
RakNet::RakString fullPathToFile
Full path to the file, which may be different than filename.
char * | data
File data (may be null if not ready)
BitSize_t | dataLengthBytes
Length of data. May be greater than fileLength if prepended with a file hash.
unsigned | fileLengthBytes
Length of the file.
FileListNodeContext | context
User specific data for whatever, describing this file.
bool | isAReference
If true, data and dataLengthBytes should be empty. This is just storing the filename.

Detailed Description

Represents once instance of a file.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/FileList.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::FileListProgress Class Reference

  • FileListProgress
Public Member Functions | List of all members
RakNet::FileListProgress Class Reference

Callback interface set with FileList::SetCallback() in case you want progress notifications when FileList::AddFilesFromDirectory() is called. More...

#include <FileList.h>

Inheritance diagram for RakNet::FileListProgress:
RakNet::AutopatcherServer RakNet::FLP_Printf

Public Member Functions

virtual void | OnAddFilesFromDirectoryStarted (FileList *fileList, char *dir)
First callback called when FileList::AddFilesFromDirectory() starts.
virtual void | OnDirectory (FileList *fileList, char *dir, unsigned int directoriesRemaining)
Called for each directory, when that directory begins processing.
virtual void | OnFile (FileList *fileList, char *dir, char *fileName, unsigned int fileSize)
Called for each file, when that file begins processing.
virtual void | OnFilePush (const char *fileName, unsigned int fileLengthBytes, unsigned int offset, unsigned int bytesBeingSent, bool done, SystemAddress targetSystem, unsigned short setId)
This function is called when we are sending a file to a remote system.
virtual void | OnFilePushesComplete (SystemAddress systemAddress, unsigned short setId)
This function is called when all files have been read and are being transferred to a remote system.
virtual void | OnSendAborted (SystemAddress systemAddress)
This function is called when a send to a system was aborted (probably due to disconnection)

Detailed Description

Callback interface set with FileList::SetCallback() in case you want progress notifications when FileList::AddFilesFromDirectory() is called.

Member Function Documentation

virtual void RakNet::FileListProgress::OnFilePush | ( | const char * | fileName,
 |  | unsigned int | fileLengthBytes,
 |  | unsigned int | offset,
 |  | unsigned int | bytesBeingSent,
 |  | bool | done,
 |  | SystemAddress | targetSystem,
 |  | unsigned short | setId
 | ) |  |
inlinevirtual

This function is called when we are sending a file to a remote system.

Parameters
[in] | fileName | The name of the file being sent
[in] | fileLengthBytes | How long the file is
[in] | offset | The offset in bytes into the file that we are sending
[in] | bytesBeingSent | How many bytes we are sending this push
[in] | done | If this file is now done with this push
[in] | targetSystem | Who we are sending to
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/FileList.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::FLP_Printf Class Reference

  • FLP_Printf
Public Member Functions | List of all members
RakNet::FLP_Printf Class Reference

Implementation of FileListProgress to use RAKNET_DEBUG_PRINTF. More...

#include <FileList.h>

Inheritance diagram for RakNet::FLP_Printf:
RakNet::FileListProgress

Public Member Functions

virtual void | OnAddFilesFromDirectoryStarted (FileList *fileList, char *dir)
First callback called when FileList::AddFilesFromDirectory() starts.
virtual void | OnDirectory (FileList *fileList, char *dir, unsigned int directoriesRemaining)
Called for each directory, when that directory begins processing.
virtual void | OnFilePushesComplete (SystemAddress systemAddress, unsigned short setID)
This function is called when all files have been transferred to a particular remote system.
virtual void | OnSendAborted (SystemAddress systemAddress)
This function is called when a send to a system was aborted (probably due to disconnection)
- Public Member Functions inherited from RakNet::FileListProgress
virtual void | OnFile (FileList *fileList, char *dir, char *fileName, unsigned int fileSize)
Called for each file, when that file begins processing.
virtual void | OnFilePush (const char *fileName, unsigned int fileLengthBytes, unsigned int offset, unsigned int bytesBeingSent, bool done, SystemAddress targetSystem, unsigned short setId)
This function is called when we are sending a file to a remote system.

Detailed Description

Implementation of FileListProgress to use RAKNET_DEBUG_PRINTF.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/FileList.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::FileListTransferCBInterface Class Reference

  • FileListTransferCBInterface
Public Member Functions | List of all members
RakNet::FileListTransferCBInterface Class Referenceabstract

Used by FileListTransfer plugin as a callback for when we get a file. More...

#include <FileListTransferCBInterface.h>

Inherited by RakNet::AutopatcherClientCBInterface.

Public Member Functions

virtual bool | OnFile (OnFileStruct *onFileStruct)=0
Got a file.
virtual void | OnFileProgress (FileProgressStruct *fps)=0
Got part of a big file internally in RakNet.
virtual bool | Update (void)
Called while the handler is active by FileListTransfer.
virtual bool | OnDownloadComplete (DownloadCompleteStruct *dcs)
Called when the download is completed.
virtual void | OnDereference (void)
This function is called when this instance is about to be dereferenced by the FileListTransfer plugin.

Detailed Description

Used by FileListTransfer plugin as a callback for when we get a file.

You get the last file when fileIndex==numberOfFilesInThisSet

See Also
FileListTransfer

Member Function Documentation

virtual void RakNet::FileListTransferCBInterface::OnDereference ( void )
inlinevirtual

This function is called when this instance is about to be dereferenced by the FileListTransfer plugin.

Update will no longer be called. It will will be deleted automatically if true was passed to FileListTransfer::SetupReceive::deleteHandler Otherwise it is up to you to delete it yourself.

virtual bool RakNet::FileListTransferCBInterface::OnDownloadComplete ( DownloadCompleteStruct * dcs )
inlinevirtual

Called when the download is completed.

If you are finished with this class, return false. At that point OnDereference will be called and the class will no longer be maintained by the FileListTransfer plugin. Otherwise return true, and Update will continue to be called.

virtual bool RakNet::FileListTransferCBInterface::OnFile ( OnFileStruct * onFileStruct )
pure virtual

Got a file.

This structure is only valid for the duration of this function call.

Returns
Return true to have RakNet delete the memory allocated to hold this file for this function call.
virtual void RakNet::FileListTransferCBInterface::OnFileProgress ( FileProgressStruct * fps )
pure virtual

Got part of a big file internally in RakNet.

This is called in one of two circumstances: Either the transport layer is returning ID_PROGRESS_NOTIFICATION, or you got a block via IncrementalReadInterface If the transport layer is returning ID_PROGRESS_NOTIFICATION (see RakPeer::SetSplitMessageProgressInterval()) then FileProgressStruct::iriDataChunk will be 0. If this is a block via IncrementalReadInterface, then iriDataChunk will point to the block just downloaded. If not using IncrementalReadInterface, then you only care about partCount and partTotal to tell how far the download has progressed. YOu can use firstDataChunk to read the first part of the file if desired. The file is usable when you get the OnFile callback. If using IncrementalReadInterface and you let RakNet buffer the files in memory (default), then it is the same as above. The file is usable when you get the OnFile callback. If using IncrementalReadInterface and you do not let RakNet buffer the files in memory, then set allocateIrIDataChunkAutomatically to false. Write the file to disk whenever you get OnFileProgress and iriDataChunk is not 0, and ignore OnFile.

virtual bool RakNet::FileListTransferCBInterface::Update ( void )
inlinevirtual

Called while the handler is active by FileListTransfer.

Return false when you are done with the class. At that point OnDereference will be called and the class will no longer be maintained by the FileListTransfer plugin.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/FileListTransferCBInterface.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::HTTPConnection Class Reference

  • HTTPConnection
Classes | Public Types | Public Member Functions | List of all members
RakNet::HTTPConnection Class Reference

Use HTTPConnection to communicate with a web server. More...

#include <HTTPConnection.h>

Classes

struct BadResponse
Encapsulates a raw HTTP response and response code. More...

Public Types

enum ResponseCodes

Public Member Functions

HTTPConnection ()
Returns a HTTP object associated with this tcp connection.
void | Init (TCPInterface *_tcp, const char *host, unsigned short port=80)
void | Post (const char *path, const char *data, const char *_contentType="application/x-www-form-urlencoded")
void | Get (const char *path)
bool | HasRead (void) const
Is there a Read result ready?
RakNet::RakString | Read (void)
void | Update (void)
Call periodically to do time-based updates.
SystemAddress | GetServerAddress (void) const
Returns the address of the server we are connected to.
void | ProcessTCPPacket (Packet *packet)
bool | HasBadResponse (int *code, RakNet::RakString *data)
Queued events of failed exchanges with the HTTP server.
bool | IsBusy (void) const
Returns false if the connection is not doing anything else.

Detailed Description

Use HTTPConnection to communicate with a web server.

Start an instance of TCPInterface via the Start() command. Instantiate a new instance of HTTPConnection, and associate TCPInterface with the class in the constructor. Use Post() to send commands to the web server, and ProcessDataPacket() to update the connection with packets returned from TCPInterface that have the system address of the web server This class will handle connecting and reconnecting as necessary.

Note that only one Post() can be handled at a time.

Deprecated:
, use HTTPConnection2

Member Enumeration Documentation

enum RakNet::HTTPConnection::ResponseCodes

Results of HTTP requests. Standard response codes are < 999 ( define HTTP codes and our internal codes as needed )

Member Function Documentation

void RakNet::HTTPConnection::Get ( const char * path )

Get a file from a webserver

Parameters
path the path on the remote server you want to GET from. For example "index.html"
void RakNet::HTTPConnection::Init | ( | TCPInterface * | _tcp,
 |  | const char * | host,
 |  | unsigned short | port = 80
 | ) |  |
Precondition
tcp should already be started
void RakNet::HTTPConnection::Post | ( | const char * | path,
 |  | const char * | data,
 |  | const char * | _contentType = "application/x-www-form-urlencoded"
 | ) |  |

Submit data to the HTTP server HTTP only allows one request at a time per connection

Precondition
IsBusy()==false
Parameters
path | the path on the remote server you want to POST to. For example "index.html"
data | A NULL terminated string to submit to the server
contentType | "Content-Type:" passed to post.
void RakNet::HTTPConnection::ProcessTCPPacket ( Packet * packet )

Process an HTTP data packet returned from TCPInterface Returns true when we have gotten all the data from the HTTP server. If this returns true then it's safe to Post() another request Deallocate the packet as usual via TCPInterface

Parameters
packet NULL or a packet associated with our host and port
RakNet::RakString RakNet::HTTPConnection::Read ( void )

Get one result from the server

Precondition
HasResult must return true
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/HTTPConnection.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::HTTPConnection::BadResponse Struct Reference

  • HTTPConnection
  • BadResponse
List of all members
RakNet::HTTPConnection::BadResponse Struct Reference

Encapsulates a raw HTTP response and response code. More...

#include <HTTPConnection.h>

Detailed Description

Encapsulates a raw HTTP response and response code.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/HTTPConnection.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::HTTPConnection2 Class Reference

  • HTTPConnection2
Public Member Functions | List of all members
RakNet::HTTPConnection2 Class Reference

Use HTTPConnection2 to communicate with a web server. More...

#include <HTTPConnection2.h>

Inheritance diagram for RakNet::HTTPConnection2:
RakNet::PluginInterface2

Public Member Functions

bool | TransmitRequest (const char *stringToTransmit, const char *host, unsigned short port=80, bool useSSL=false, int ipVersion=4, SystemAddress useAddress=UNASSIGNED_SYSTEM_ADDRESS, void *userData=0)
Connect to, then transmit a request to a TCP based server.
bool | GetResponse (RakString &stringTransmitted, RakString &hostTransmitted, RakString &responseReceived, SystemAddress &hostReceived, int &contentOffset, void **userData)
Check for and return a response from a prior call to TransmitRequest() As TCP is stream based, you may get a webserver reply over several calls to TCPInterface::Receive() HTTPConnection2 will store Packet::data and return the response to you either when the connection to the webserver is lost, or enough data has been received() This will only potentially return true after a call to ProcessTCPPacket() or OnLostConnection()
bool | IsBusy (void) const
Return if any requests are pending.
bool | HasResponse (void) const
Return if any requests are waiting to be read by the user.
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Detailed Description

Use HTTPConnection2 to communicate with a web server.

Start an instance of TCPInterface via the Start() command. This class will handle connecting to transmit a request

Member Function Documentation

bool RakNet::HTTPConnection2::GetResponse | ( | RakString & | stringTransmitted,
 |  | RakString & | hostTransmitted,
 |  | RakString & | responseReceived,
 |  | SystemAddress & | hostReceived,
 |  | int & | contentOffset,
 |  | void ** | userData
 | ) |  |

Check for and return a response from a prior call to TransmitRequest() As TCP is stream based, you may get a webserver reply over several calls to TCPInterface::Receive() HTTPConnection2 will store Packet::data and return the response to you either when the connection to the webserver is lost, or enough data has been received() This will only potentially return true after a call to ProcessTCPPacket() or OnLostConnection()

Parameters
[out] | stringTransmitted | The original string transmitted
[out] | hostTransmitted | The parameter of the same name passed to TransmitRequest()
[out] | responseReceived | The response, if any
[out] | hostReceived | The SystemAddress from ProcessTCPPacket() or OnLostConnection()
[out] contentOffset The offset from the start of responseReceived to the data body. Equivalent to searching for

in responseReceived.
[out] | userData | Whatever you passed to TransmitRequest
Returns
true if there was a response. false if not.
virtual void RakNet::HTTPConnection2::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
virtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual void RakNet::HTTPConnection2::OnFailedConnectionAttempt | ( | Packet * | packet,
 |  | PI2_FailedConnectionAttemptReason | failedConnectionAttemptReason
 | ) |  |
virtual

Called when a connection attempt fails

Parameters
[in] | packet | Packet to be returned to the user
[in] | failedConnectionReason | Why the connection failed

Reimplemented from RakNet::PluginInterface2.

virtual void RakNet::HTTPConnection2::OnNewConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | bool | isIncoming
 | ) |  |
virtual

Called when we got a new connection

Parameters
[in] | systemAddress | Address of the new connection
[in] | rakNetGuid | The guid of the specified system
[in] | isIncoming | If true, this is ID_NEW_INCOMING_CONNECTION, or the equivalent

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::HTTPConnection2::OnReceive ( Packet * packet )
virtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

bool RakNet::HTTPConnection2::TransmitRequest | ( | const char * | stringToTransmit,
 |  | const char * | host,
 |  | unsigned short | port = 80,
 |  | bool | useSSL = false,
 |  | int | ipVersion = 4,
 |  | SystemAddress | useAddress = UNASSIGNED_SYSTEM_ADDRESS,
 |  | void * | userData = 0
 | ) |  |

Connect to, then transmit a request to a TCP based server.

Parameters
[in] | tcp | An instance of TCPInterface that previously had TCPInterface::Start() called
[in] | stringToTransmit | What string to transmit. See RakString::FormatForPOST(), RakString::FormatForGET(), RakString::FormatForDELETE()
[in] | host | The IP address to connect to
[in] | port | The port to connect to
[in] | useSSL | If to use SSL to connect. OPEN_SSL_CLIENT_SUPPORT must be defined to 1 in RakNetDefines.h or RakNetDefinesOverrides.h
[in] | ipVersion | 4 for IPV4, 6 for IPV6
[in] | useAddress | Assume we are connected to this address and send to it, rather than do a lookup
[in] | userData
Returns
false if host is not a valid IP address or domain name
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/HTTPConnection2.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::InternalPacketRefCountedData Struct Reference

  • InternalPacketRefCountedData
List of all members
RakNet::InternalPacketRefCountedData Struct Reference

Used in InternalPacket when pointing to sharedDataBlock, rather than allocating itself. More...

#include <InternalPacket.h>

Detailed Description

Used in InternalPacket when pointing to sharedDataBlock, rather than allocating itself.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/InternalPacket.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::InternalPacket Struct Reference

  • InternalPacket
Public Types | Public Attributes | List of all members
RakNet::InternalPacket Struct Reference

#include <InternalPacket.h>

Inherits RakNet::InternalPacketFixedSizeTransmissionHeader.

Public Types

enum AllocationScheme { NORMAL, REF_COUNTED, STACK }
How to alloc and delete the data member. More...

Public Attributes

MessageNumberType messageInternalOrder
Identifies the order in which this number was sent. Used locally.
bool | messageNumberAssigned
RakNet::TimeUS | creationTime
Was this packet number used this update to track windowing drops or increases? Each packet number is only used once per update.
RakNet::TimeUS | nextActionTime
The resendNext time to take action on this packet.
unsigned char * | data
Buffer is a pointer to the actual data, assuming this packet has data at all.
unsigned char | timesSent
How many attempts we made at sending this message.
PacketPriority priority
The priority level of this packet.
uint32_t | sendReceiptSerial
If the reliability type requires a receipt, then return this number with it.
- Public Attributes inherited from RakNet::InternalPacketFixedSizeTransmissionHeader
MessageNumberType | reliableMessageNumber
A unique numerical identifier given to this user message. Used to identify reliable messages on the network.
OrderingIndexType | orderingIndex
The ID used as identification for ordering messages. Also included in sequenced messages.
unsigned char | orderingChannel
What ordering channel this packet is on, if the reliability type uses ordering channels.
SplitPacketIdType | splitPacketId
The ID of the split packet, if we have split packets. This is the maximum number of split messages we can send simultaneously per connection.
SplitPacketIndexType | splitPacketIndex
If this is a split packet, the index into the array of subsplit packets.
SplitPacketIndexType | splitPacketCount
The size of the array of subsplit packets.
BitSize_t | dataBitLength
How many bits long the data is.
PacketReliability | reliability
What type of reliability algorithm to use with this packet.

Detailed Description

Holds a user message, and related information Don't use a constructor or destructor, due to the memory pool I am using

Member Enumeration Documentation

enum RakNet::InternalPacket::AllocationScheme

How to alloc and delete the data member.

Enumerator:
NORMAL

Data is allocated using rakMalloc. Just free it.

REF_COUNTED

data points to a larger block of data, where the larger block is reference counted. internalPacketRefCountedData is used in this case

STACK

If allocation scheme is STACK, data points to stackData and should not be deallocated This is only used when sending. Received packets are deallocated in RakPeer

Member Data Documentation

RakNet::TimeUS RakNet::InternalPacket::creationTime

Was this packet number used this update to track windowing drops or increases? Each packet number is only used once per update.

When this packet was created

bool RakNet::InternalPacket::messageNumberAssigned

Has this message number been assigned yet? We don't assign until the message is actually sent. This fixes a bug where pre-determining message numbers and then sending a message on a different channel creates a huge gap. This causes performance problems and causes those messages to timeout.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/InternalPacket.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::LogCommandParser Class Reference

  • LogCommandParser
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
RakNet::LogCommandParser Class Reference

Adds the ability to send logging output to a remote console. More...

#include <LogCommandParser.h>

Inheritance diagram for RakNet::LogCommandParser:
RakNet::CommandParserInterface

Classes

struct SystemAddressAndChannel
One of these structures is created per player. More...

Public Member Functions

bool | OnCommand (const char *command, unsigned numParameters, char **parameterList, TransportInterface *transport, const SystemAddress &systemAddress, const char *originalString)
const char * | GetName (void) const
void | SendHelp (TransportInterface *transport, const SystemAddress &systemAddress)
void | AddChannel (const char *channelName)
All logs must be associated with a channel. This is a filter so that remote clients only get logs for a system they care about.
void | WriteLog (const char *channelName, const char *format,...)
void | OnNewIncomingConnection (const SystemAddress &systemAddress, TransportInterface *transport)
void | OnConnectionLost (const SystemAddress &systemAddress, TransportInterface *transport)
void | OnTransportChange (TransportInterface *transport)
- Public Member Functions inherited from RakNet::CommandParserInterface
virtual void | RegisterCommand (unsigned char parameterCount, const char *command, const char *commandHelp)
virtual void | ReturnResult (bool res, const char *command, TransportInterface *transport, const SystemAddress &systemAddress)
Just writes a string to the remote system based on the result ( res ) of your operation.
virtual void | ReturnResult (const char *command, TransportInterface *transport, const SystemAddress &systemAddress)
Just writes a string to the remote system when you are calling a function that has no return value.

Protected Member Functions

void | PrintChannels (const SystemAddress &systemAddress, TransportInterface *transport) const
unsigned | Unsubscribe (const SystemAddress &systemAddress, const char *channelName)
unsigned | Subscribe (const SystemAddress &systemAddress, const char *channelName)
unsigned | GetChannelIndexFromName (const char *channelName)

Protected Attributes

DataStructures::List
< SystemAddressAndChannel > 		remoteUsers
The list of remote users. Added to when users subscribe, removed when they disconnect or unsubscribe.
const char * channelNames [32]
Names of the channels at each bit, or 0 for an unused channel.
TransportInterface * trans
This is so I can save the current transport provider, solely so I can use it without having the user pass it to Log.

Detailed Description

Adds the ability to send logging output to a remote console.

Member Function Documentation

void RakNet::LogCommandParser::AddChannel ( const char * channelName )

All logs must be associated with a channel. This is a filter so that remote clients only get logs for a system they care about.

Parameters
[in] channelName A persistent string naming the channel. Don't deallocate this string.
unsigned RakNet::LogCommandParser::GetChannelIndexFromName ( const char * channelName )
protected

Given the name of a channel, return the index into channelNames where it is located

Parameters
[in] channelName The name of the channel
const char* RakNet::LogCommandParser::GetName ( void ) const
virtual

You are responsible for overriding this function and returning a static string, which will identifier your parser. This should return a static string

Returns
The name that you return.

Implements RakNet::CommandParserInterface.

bool RakNet::LogCommandParser::OnCommand | ( | const char * | command,
 |  | unsigned | numParameters,
 |  | char ** | parameterList,
 |  | TransportInterface * | transport,
 |  | const SystemAddress & | systemAddress,
 |  | const char * | originalString
 | ) |  |
virtual

Given command with parameters parameterList , do whatever processing you wish.

Parameters
[in] | command | The command to process
[in] | numParameters | How many parameters were passed along with the command
[in] | parameterList | The list of parameters. parameterList[0] is the first parameter and so on.
[in] | transport | The transport interface we can use to write to
[in] | systemAddress | The player that sent this command.
[in] | originalString | The string that was actually sent over the network, in case you want to do your own parsing

Implements RakNet::CommandParserInterface.

void RakNet::LogCommandParser::OnConnectionLost | ( | const SystemAddress & | systemAddress,
 |  | TransportInterface * | transport
 | ) |  |
virtual

A callback for when systemAddress has disconnected, either gracefully or forcefully

Parameters
[in] | systemAddress | The player that has disconnected.
[in] | transport | The transport interface that sent us this information.

Reimplemented from RakNet::CommandParserInterface.

void RakNet::LogCommandParser::OnNewIncomingConnection | ( | const SystemAddress & | systemAddress,
 |  | TransportInterface * | transport
 | ) |  |
virtual

A callback for when systemAddress has connected to us.

Parameters
[in] | systemAddress | The player that has connected.
[in] | transport | The transport interface that sent us this information. Can be used to send messages to this or other players.

Reimplemented from RakNet::CommandParserInterface.

void RakNet::LogCommandParser::OnTransportChange ( TransportInterface * transport )
virtual

This is called every time transport interface is registered. If you want to save a copy of the TransportInterface pointer This is the place to do it

Parameters
[in] transport The new TransportInterface

Reimplemented from RakNet::CommandParserInterface.

void RakNet::LogCommandParser::PrintChannels | ( | const SystemAddress & | systemAddress,
 |  | TransportInterface * | transport
 | ) |  | const
 protected

Sends the currently active channels to the user

Parameters
[in] | systemAddress | The player to send to
[in] | transport | The transport interface to use to send the channels
void RakNet::LogCommandParser::SendHelp | ( | TransportInterface * | transport,
 |  | const SystemAddress & | systemAddress
 | ) |  |
virtual

A callback for when you are expected to send a brief description of your parser to systemAddress

Parameters
[in] | transport | The transport interface we can use to write to
[in] | systemAddress | The player that requested help.

Implements RakNet::CommandParserInterface.

unsigned RakNet::LogCommandParser::Subscribe | ( | const SystemAddress & | systemAddress,
 |  | const char * | channelName
 | ) |  |
protected

Subscribe a user to a channel (or to all channels)

Parameters
[in] | systemAddress | The player to subscribe to
[in] | channelName | If 0, then subscribe from all channels. Otherwise subscribe to the named channel
unsigned RakNet::LogCommandParser::Unsubscribe | ( | const SystemAddress & | systemAddress,
 |  | const char * | channelName
 | ) |  |
protected

Unsubscribe a user from a channel (or from all channels)

Parameters
[in] | systemAddress | The player to unsubscribe to
[in] | channelName | If 0, then unsubscribe from all channels. Otherwise unsubscribe from the named channel
void RakNet::LogCommandParser::WriteLog | ( | const char * | channelName,
 |  | const char * | format,
 |  |  | ...
 | ) |  |

Write a log to a channel. Logs are not buffered, so only remote consoles connected and subscribing at the time you write will get the output.

Parameters
[in] format Same as RAKNET_DEBUG_PRINTF()
[in] ... Same as RAKNET_DEBUG_PRINTF()
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/LogCommandParser.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::LogCommandParser::SystemAddressAndChannel Struct Reference

  • LogCommandParser
  • SystemAddressAndChannel
Public Attributes | List of all members
RakNet::LogCommandParser::SystemAddressAndChannel Struct Reference

One of these structures is created per player. More...

#include <LogCommandParser.h>

Public Attributes

SystemAddress systemAddress
The ID of the player.
unsigned channels
Bitwise representations of the channels subscribed to. If bit 0 is set, then we subscribe to channelNames[0] and so on.

Detailed Description

One of these structures is created per player.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/LogCommandParser.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::NetworkIDManager Class Reference

  • NetworkIDManager
Public Member Functions | List of all members
RakNet::NetworkIDManager Class Reference

#include <NetworkIDManager.h>

Public Member Functions

template<class returnType >
returnType GET_OBJECT_FROM_ID (NetworkID x)

Detailed Description

This class is simply used to generate a unique number for a group of instances of NetworkIDObject An instance of this class is required to use the ObjectID to pointer lookup system You should have one instance of this class per game instance. Call SetIsNetworkIDAuthority before using any functions of this class, or of NetworkIDObject

Member Function Documentation

template<class returnType >
returnType RakNet::NetworkIDManager::GET_OBJECT_FROM_ID ( NetworkID x )
inline

Returns the parent object, or this instance if you don't use a parent. Supports NetworkIDObject anywhere in the inheritance hierarchy

Precondition
You must first call SetNetworkIDManager before using this function
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/NetworkIDManager.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::NetworkIDObject Class Reference

  • NetworkIDObject
Public Member Functions | Protected Attributes | List of all members
RakNet::NetworkIDObject Class Reference

Unique shared ids for each object instance. More...

#include <NetworkIDObject.h>

Inheritance diagram for RakNet::NetworkIDObject:
RakNet::Replica3 RakNet::Replica3Composite< parent_type >

Public Member Functions

virtual void | SetNetworkIDManager (NetworkIDManager *manager)
virtual NetworkIDManager * | GetNetworkIDManager (void) const
Returns what was passed to SetNetworkIDManager.
virtual NetworkID | GetNetworkID (void)
virtual void | SetNetworkID (NetworkID id)
virtual void | SetParent (void *_parent)
virtual void * | GetParent (void) const

Protected Attributes

NetworkID | networkID
The network ID of this object.
void * | parent
The parent set by SetParent()

Detailed Description

Unique shared ids for each object instance.

A class you can derive from to make it easier to represent every networked object with an integer. This way you can refer to objects over the network. One system should return true for IsNetworkIDAuthority() and the rest should return false. When an object needs to be created, have the the one system create the object. Then have that system send a message to all other systems, and include the value returned from GetNetworkID() in that packet. All other systems should then create the same class of object, and call SetNetworkID() on that class with the NetworkID in the packet.

See Also
the manual for more information on this.

Member Function Documentation

virtual NetworkID RakNet::NetworkIDObject::GetNetworkID ( void )
virtual

Returns the NetworkID that you can use to refer to this object over the network.

Precondition
You must first call SetNetworkIDManager before using this function
Return values
UNASSIGNED_NETWORK_ID | UNASSIGNED_NETWORK_ID is returned IsNetworkIDAuthority() is false and SetNetworkID() was not previously called. This is also returned if you call this function in the constructor.
0-65534 | Any other value is a valid NetworkID. NetworkIDs start at 0 and go to 65534, wrapping at that point.
virtual void* RakNet::NetworkIDObject::GetParent ( void ) const
virtual

Return what was passed to SetParent

Returns
The value passed to SetParent, or 0 if it was never called.
virtual void RakNet::NetworkIDObject::SetNetworkID ( NetworkID id )
virtual

Sets the NetworkID for this instance. Usually this is called by the clients and determined from the servers. However, if you save multiplayer games you would likely use This on load as well.

virtual void RakNet::NetworkIDObject::SetNetworkIDManager ( NetworkIDManager * manager )
virtual

Sets the manager class from which to request unique network IDs Unlike previous versions, the NetworkIDObject relies on a manager class to provide IDs, rather than using statics, So you can have more than one set of IDs on the same system.

virtual void RakNet::NetworkIDObject::SetParent ( void * _parent )
virtual

Your class does not have to derive from NetworkIDObject, although that is the easiest way to implement this. If you want this to be a member object of another class, rather than inherit, then call SetParent() with a pointer to the parent class instance. GET_OBJECT_FROM_ID will then return the parent rather than this instance.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/NetworkIDObject.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RakNet::Rackspace2EventCallback Class Reference

  • Rackspace2EventCallback
List of all members
RakNet::Rackspace2EventCallback Class Referenceabstract

Callback interface to receive the results of operations. More...

#include <Rackspace.h>

Inheritance diagram for RakNet::Rackspace2EventCallback:
RakNet::RackspaceEventCallback_Default

Detailed Description

Callback interface to receive the results of operations.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/Rackspace.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::RackspaceEventCallback_Default Class Reference

  • RackspaceEventCallback_Default
List of all members
RakNet::RackspaceEventCallback_Default Class Reference

Callback interface to receive the results of operations, with a default result. More...

#include <Rackspace.h>

Inheritance diagram for RakNet::RackspaceEventCallback_Default:
RakNet::Rackspace2EventCallback

Detailed Description

Callback interface to receive the results of operations, with a default result.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/Rackspace.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Rackspace Class Reference

  • Rackspace
Public Member Functions | Static Public Member Functions | List of all members
RakNet::Rackspace Class Reference

Code that uses the TCPInterface class to communicate with the Rackspace API servers. More...

#include <Rackspace.h>

Public Member Functions

SystemAddress | Authenticate (TCPInterface *_tcpInterface, const char *_authenticationURL, const char *_rackspaceCloudUsername, const char *_apiAccessKey)
Authenticate with Rackspace servers, required before executing any commands.
void | ListServers (void)
Get a list of running servers.
void | ListServersWithDetails (void)
Get a list of running servers, with extended details on each server.
void | CreateServer (RakNet::RakString name, RakNet::RakString imageId, RakNet::RakString flavorId)
Create a server.
void | GetServerDetails (RakNet::RakString serverId)
Get details on a particular server.
void | UpdateServerNameOrPassword (RakNet::RakString serverId, RakNet::RakString newName, RakNet::RakString newPassword)
Changes the name or password for a server.
void | DeleteServer (RakNet::RakString serverId)
Deletes a server.
void | ListServerAddresses (RakNet::RakString serverId)
Lists the IP addresses available to a server.
void | ShareServerAddress (RakNet::RakString serverId, RakNet::RakString ipAddress)
Shares an IP address with a server.
void | DeleteServerAddress (RakNet::RakString serverId, RakNet::RakString ipAddress)
Stops sharing an IP address with a server.
void | RebootServer (RakNet::RakString serverId, RakNet::RakString rebootType)
Reboots a server.
void | RebuildServer (RakNet::RakString serverId, RakNet::RakString imageId)
Rebuilds a server with a different image (harddrive contents)
void | ResizeServer (RakNet::RakString serverId, RakNet::RakString flavorId)
Changes the hardware configuration of a server. This does not take effect until you call ConfirmResizedServer()
void | ConfirmResizedServer (RakNet::RakString serverId)
Confirm a resize for the specified server.
void | RevertResizedServer (RakNet::RakString serverId)
Reverts a resize for the specified server.
void | ListFlavors (void)
List all flavors (hardware configs, primarily memory)
void | GetFlavorDetails (RakNet::RakString flavorId)
Get extended details about a specific flavor.
void | ListImages (void)
List all images (software configs, including operating systems), which includes images you create yourself.
void | CreateImage (RakNet::RakString serverId, RakNet::RakString imageName)
Images a running server. This essentially copies the harddrive, and lets you start a server with the same harddrive contents later.
void | GetImageDetails (RakNet::RakString imageId)
Get extended details about a particular image.
void | DeleteImage (RakNet::RakString imageId)
Delete a custom image created with CreateImage()
void | ListSharedIPGroups (void)
List IP groups.
void | ListSharedIPGroupsWithDetails (void)
List IP groups with extended details.
void | AddEventCallback (Rackspace2EventCallback *callback)
Adds a callback to the list of callbacks to be called when any of the above functions finish executing The callbacks are called in the order they are added.
void | RemoveEventCallback (Rackspace2EventCallback *callback)
Removes a callback from the list of callbacks to be called when any of the above functions finish executing The callbacks are called in the order they are added.
void | ClearEventCallbacks (void)
Removes all callbacks.
void | OnReceive (Packet *packet)
Call this anytime TCPInterface returns a packet.
void | OnClosedConnection (SystemAddress systemAddress)
Call this when TCPInterface returns something other than UNASSIGNED_SYSTEM_ADDRESS from HasLostConnection()
void | AddOperation (RackspaceOperationType type, RakNet::RakString httpCommand, RakNet::RakString operation, RakNet::RakString xml)
Mostly for internal use, but you can use it to execute an operation with more complex xml if desired See the Rackspace.cpp on how to use it.

Static Public Member Functions

static const char * EventTypeToString (RackspaceEventType eventType)
String representation of each RackspaceEventType.

Detailed Description

Code that uses the TCPInterface class to communicate with the Rackspace API servers.

Precondition
Compile RakNet with OPEN_SSL_CLIENT_SUPPORT set to 1
Packets returned from TCPInterface::OnReceive() must be passed to Rackspace::OnReceive()
Packets returned from TCPInterface::HasLostConnection() must be passed to Rackspace::OnClosedConnection()

Member Function Documentation

SystemAddress RakNet::Rackspace::Authenticate | ( | TCPInterface * | _tcpInterface,
 |  | const char * | _authenticationURL,
 |  | const char * | _rackspaceCloudUsername,
 |  | const char * | _apiAccessKey
 | ) |  |

Authenticate with Rackspace servers, required before executing any commands.

All requests to authenticate and operate against Cloud Servers are performed using SSL over HTTP (HTTPS) on TCP port 443. Times out after 24 hours - if you get RET_Authenticate_Unauthorized in the RackspaceEventCallback callback, call again

See Also
RackspaceEventCallback::OnAuthenticationResult()
Parameters
[in] | _tcpInterface | An instance of TCPInterface, build with OPEN_SSL_CLIENT_SUPPORT 1 and already started
[in] | _authenticationURL | See http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf . US-based accounts authenticate through auth.api.rackspacecloud.com. UK-based accounts authenticate through lon.auth.api.rackspacecloud.com
[in] | _rackspaceCloudUsername | Username you registered with Rackspace on their website
[in] | _apiAccessKey | Obtain your API access key from the Rackspace Cloud Control Panel in the Your Account API Access section.
Returns
The address of the authentication server, or UNASSIGNED_SYSTEM_ADDRESS if the connection attempt failed
void RakNet::Rackspace::ConfirmResizedServer ( RakNet::RakString serverId )

Confirm a resize for the specified server.

See Also
http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf
RackspaceEventCallback::OnConfirmResizedServerResult()
ResizeServer()
Parameters
[in] serverId Which server to operate on. You can call ListServers() to get the list of active servers.
void RakNet::Rackspace::CreateImage | ( | RakNet::RakString | serverId,
 |  | RakNet::RakString | imageName
 | ) |  |

Images a running server. This essentially copies the harddrive, and lets you start a server with the same harddrive contents later.

See Also
http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf
RackspaceEventCallback::OnCreateImageResult()
ListImages()
Parameters
[in] | serverId | Which server to operate on. You can call ListServers() to get the list of active servers.
[in] | imageName | What to call this image
void RakNet::Rackspace::CreateServer | ( | RakNet::RakString | name,
 |  | RakNet::RakString | imageId,
 |  | RakNet::RakString | flavorId
 | ) |  |

Create a server.

Create a server with a given image (harddrive contents) and flavor (hardware configuration) Get the available images with ListImages() Get the available flavors with ListFlavors() It is possible to configure the server in more detail. See the XML schema at http://docs.rackspacecloud.com/servers/api/v1.0 You can execute such a custom command by calling AddOperation() manually. See the implementation of CreateServer for how to do so. The server takes a while to build. Call GetServerDetails() to get the current build status. Server id to pass to GetServerDetails() is returned in the field <server ... id="1234">

See Also
http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf
RackspaceEventCallback::OnCreateServerResult()
Parameters
[in] | name | Name of the server. Only alphanumeric characters, periods, and hyphens are valid. Server Name cannot start or end with a period or hyphen.
[in] | imageId | Which image (harddrive contents, including OS) to use
[in] | flavorId | Which flavor (hardware config) to use, primarily how much memory is available.
void RakNet::Rackspace::DeleteImage ( RakNet::RakString imageId )

Delete a custom image created with CreateImage()

See Also
http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf
RackspaceEventCallback::OnDeleteImageResult()
ListImages()
Parameters
[in] imageId Which image
void RakNet::Rackspace::DeleteServer ( RakNet::RakString serverId )

Deletes a server.

See Also
http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf
RackspaceEventCallback::OnDeleteServerResult()
Parameters
[in] serverId Which server to get details on. You can call ListServers() to get the list of active servers.
void RakNet::Rackspace::DeleteServerAddress | ( | RakNet::RakString | serverId,
 |  | RakNet::RakString | ipAddress
 | ) |  |

Stops sharing an IP address with a server.

See Also
http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf
RackspaceEventCallback::OnDeleteServerAddressResult()
Parameters
[in] | serverId | Which server to operate on. You can call ListServers() to get the list of active servers.
[in] | ipAddress | Which IP address. You can call ListServerAddresses() to get the list of addresses for the specified server
void RakNet::Rackspace::GetFlavorDetails ( RakNet::RakString flavorId )

Get extended details about a specific flavor.

See Also
http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf
RackspaceEventCallback::OnGetFlavorDetailsResult()
ListFlavors()
Parameters
[in] flavorId Which flavor (hardware config)
void RakNet::Rackspace::GetImageDetails ( RakNet::RakString imageId )

Get extended details about a particular image.

See Also
http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf
RackspaceEventCallback::OnGetImageDetailsResult()
ListImages()
Parameters
[in] imageId Which image
void RakNet::Rackspace::GetServerDetails ( RakNet::RakString serverId )

Get details on a particular server.

See Also
http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf
RackspaceEventCallback::OnGetServerDetailsResult()
Parameters
[in] serverId Which server to get details on. You can call ListServers() to get the list of active servers.
void RakNet::Rackspace::ListFlavors ( void )

List all flavors (hardware configs, primarily memory)

See Also
http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf
RackspaceEventCallback::OnListFlavorsResult()
void RakNet::Rackspace::ListImages ( void )

List all images (software configs, including operating systems), which includes images you create yourself.

See Also
http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf
RackspaceEventCallback::OnListImagesResult()
CreateImage()
void RakNet::Rackspace::ListServerAddresses ( RakNet::RakString serverId )

Lists the IP addresses available to a server.

See Also
http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf
RackspaceEventCallback::OnListServerAddressesResult()
Parameters
[in] serverId Which server to operate on. You can call ListServers() to get the list of active servers.
void RakNet::Rackspace::ListServers ( void )

Get a list of running servers.

See Also
http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf
RackspaceEventCallback::OnListServersResult()
void RakNet::Rackspace::ListServersWithDetails ( void )

Get a list of running servers, with extended details on each server.

See Also
GetServerDetails()
http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf
RackspaceEventCallback::OnListServersWithDetailsResult()
void RakNet::Rackspace::ListSharedIPGroups ( void )

List IP groups.

See Also
http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf
RackspaceEventCallback::OnListSharedIPGroupsResult()
void RakNet::Rackspace::ListSharedIPGroupsWithDetails ( void )

List IP groups with extended details.

See Also
http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf
RackspaceEventCallback::OnListSharedIPGroupsWithDetailsResult()
void RakNet::Rackspace::RebootServer | ( | RakNet::RakString | serverId,
 |  | RakNet::RakString | rebootType
 | ) |  |

Reboots a server.

See Also
http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf
RackspaceEventCallback::OnRebootServerResult()
Parameters
[in] | serverId | Which server to operate on. You can call ListServers() to get the list of active servers.
[in] | rebootType | Should be either "HARD" or "SOFT"
void RakNet::Rackspace::RebuildServer | ( | RakNet::RakString | serverId,
 |  | RakNet::RakString | imageId
 | ) |  |

Rebuilds a server with a different image (harddrive contents)

See Also
http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf
RackspaceEventCallback::OnRebuildServerResult()
Parameters
[in] | serverId | Which server to operate on. You can call ListServers() to get the list of active servers.
[in] | imageId | Which image (harddrive contents, including OS) to use
void RakNet::Rackspace::ResizeServer | ( | RakNet::RakString | serverId,
 |  | RakNet::RakString | flavorId
 | ) |  |

Changes the hardware configuration of a server. This does not take effect until you call ConfirmResizedServer()

See Also
http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf
RackspaceEventCallback::OnResizeServerResult()
RevertResizedServer()
Parameters
[in] | serverId | Which server to operate on. You can call ListServers() to get the list of active servers.
[in] | flavorId | Which flavor (hardware config) to use, primarily how much memory is available.
void RakNet::Rackspace::RevertResizedServer ( RakNet::RakString serverId )

Reverts a resize for the specified server.

See Also
http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf
RackspaceEventCallback::OnRevertResizedServerResult()
ResizeServer()
Parameters
[in] serverId Which server to operate on. You can call ListServers() to get the list of active servers.
void RakNet::Rackspace::ShareServerAddress | ( | RakNet::RakString | serverId,
 |  | RakNet::RakString | ipAddress
 | ) |  |

Shares an IP address with a server.

See Also
http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf
RackspaceEventCallback::OnShareServerAddressResult()
Parameters
[in] | serverId | Which server to operate on. You can call ListServers() to get the list of active servers.
[in] | ipAddress | Which IP address. You can call ListServerAddresses() to get the list of addresses for the specified server
void RakNet::Rackspace::UpdateServerNameOrPassword | ( | RakNet::RakString | serverId,
 |  | RakNet::RakString | newName,
 |  | RakNet::RakString | newPassword
 | ) |  |

Changes the name or password for a server.

See Also
http://docs.rackspacecloud.com/servers/api/v1.0/cs-devguide-20110112.pdf
RackspaceEventCallback::OnUpdateServerNameOrPasswordResult()
Parameters
[in] | serverId | Which server to get details on. You can call ListServers() to get the list of active servers.
[in] | newName | The new server name. Leave blank to leave unchanged. Only alphanumeric characters, periods, and hyphens are valid. Server Name cannot start or end with a period or hyphen.
[in] | newPassword | The new server password. Leave blank to leave unchanged.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/Rackspace.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::RakNetCommandParser Class Reference

  • RakNetCommandParser
Public Member Functions | Protected Attributes | List of all members
RakNet::RakNetCommandParser Class Reference

This allows a console client to call most of the functions in RakPeer. More...

#include <RakNetCommandParser.h>

Inheritance diagram for RakNet::RakNetCommandParser:
RakNet::CommandParserInterface

Public Member Functions

bool | OnCommand (const char *command, unsigned numParameters, char **parameterList, TransportInterface *transport, const SystemAddress &systemAddress, const char *originalString)
const char * | GetName (void) const
void | SendHelp (TransportInterface *transport, const SystemAddress &systemAddress)
void | SetRakPeerInterface (RakNet::RakPeerInterface *rakPeer)
- Public Member Functions inherited from RakNet::CommandParserInterface
virtual void | OnNewIncomingConnection (const SystemAddress &systemAddress, TransportInterface *transport)
A callback for when systemAddress has connected to us.
virtual void | OnConnectionLost (const SystemAddress &systemAddress, TransportInterface *transport)
A callback for when systemAddress has disconnected, either gracefully or forcefully.
virtual void | OnTransportChange (TransportInterface *transport)
This is called every time transport interface is registered.
virtual void | RegisterCommand (unsigned char parameterCount, const char *command, const char *commandHelp)
virtual void | ReturnResult (bool res, const char *command, TransportInterface *transport, const SystemAddress &systemAddress)
Just writes a string to the remote system based on the result ( res ) of your operation.
virtual void | ReturnResult (const char *command, TransportInterface *transport, const SystemAddress &systemAddress)
Just writes a string to the remote system when you are calling a function that has no return value.

Protected Attributes

RakPeerInterface * peer
Which instance of RakPeer we are working on. Set from SetRakPeerInterface()

Detailed Description

This allows a console client to call most of the functions in RakPeer.

Member Function Documentation

const char* RakNet::RakNetCommandParser::GetName ( void ) const
virtual

You are responsible for overriding this function and returning a static string, which will identifier your parser. This should return a static string

Returns
The name that you return.

Implements RakNet::CommandParserInterface.

bool RakNet::RakNetCommandParser::OnCommand | ( | const char * | command,
 |  | unsigned | numParameters,
 |  | char ** | parameterList,
 |  | TransportInterface * | transport,
 |  | const SystemAddress & | systemAddress,
 |  | const char * | originalString
 | ) |  |
virtual

Given command with parameters parameterList , do whatever processing you wish.

Parameters
[in] | command | The command to process
[in] | numParameters | How many parameters were passed along with the command
[in] | parameterList | The list of parameters. parameterList[0] is the first parameter and so on.
[in] | transport | The transport interface we can use to write to
[in] | systemAddress | The player that sent this command.
[in] | originalString | The string that was actually sent over the network, in case you want to do your own parsing

Implements RakNet::CommandParserInterface.

void RakNet::RakNetCommandParser::SendHelp | ( | TransportInterface * | transport,
 |  | const SystemAddress & | systemAddress
 | ) |  |
virtual

A callback for when you are expected to send a brief description of your parser to systemAddress

Parameters
[in] | transport | The transport interface we can use to write to
[in] | systemAddress | The player that requested help.

Implements RakNet::CommandParserInterface.

void RakNet::RakNetCommandParser::SetRakPeerInterface ( RakNet::RakPeerInterface * rakPeer )

Records the instance of RakPeer to perform the desired commands on

Parameters
[in] rakPeer The RakPeer instance, or a derived class (e.g. RakPeer or RakPeer)
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/RakNetCommandParser.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::RakNetStatistics Struct Reference

  • RakNetStatistics
Public Attributes | List of all members
RakNet::RakNetStatistics Struct Reference

Network Statisics Usage. More...

#include <RakNetStatistics.h>

Public Attributes

uint64_t | valueOverLastSecond [RNS_PER_SECOND_METRICS_COUNT]
For each type in RNSPerSecondMetrics, what is the value over the last 1 second?
uint64_t | runningTotal [RNS_PER_SECOND_METRICS_COUNT]
For each type in RNSPerSecondMetrics, what is the total value over the lifetime of the connection?
RakNet::TimeUS | connectionStartTime
bool | isLimitedByCongestionControl
uint64_t | BPSLimitByCongestionControl
If isLimitedByCongestionControl is true, what is the limit, in bytes per second?
bool | isLimitedByOutgoingBandwidthLimit
Is our current send rate throttled by a call to RakPeer::SetPerConnectionOutgoingBandwidthLimit()?
uint64_t | BPSLimitByOutgoingBandwidthLimit
If isLimitedByOutgoingBandwidthLimit is true, what is the limit, in bytes per second?
unsigned int | messageInSendBuffer [NUMBER_OF_PRIORITIES]
For each priority level, how many messages are waiting to be sent out?
double | bytesInSendBuffer [NUMBER_OF_PRIORITIES]
For each priority level, how many bytes are waiting to be sent out?
unsigned int | messagesInResendBuffer
uint64_t | bytesInResendBuffer
How many bytes are waiting in the resend buffer. See also messagesInResendBuffer.
float | packetlossLastSecond
Over the last second, what was our packetloss? This number will range from 0.0 (for none) to 1.0 (for 100%)
float | packetlossTotal
What is the average total packetloss over the lifetime of the connection?

Detailed Description

Network Statisics Usage.

Store Statistics information related to network usage

Member Data Documentation

RakNet::TimeUS RakNet::RakNetStatistics::connectionStartTime

When did the connection start?

See Also
RakNet::GetTimeUS()
bool RakNet::RakNetStatistics::isLimitedByCongestionControl

Is our current send rate throttled by congestion control? This value should be true if you send more data per second than your bandwidth capacity

unsigned int RakNet::RakNetStatistics::messagesInResendBuffer

How many messages are waiting in the resend buffer? This includes messages waiting for an ack, so should normally be a small value If the value is rising over time, you are exceeding the bandwidth capacity. See BPSLimitByCongestionControl

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/RakNetStatistics.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::PublicKey Struct Reference

  • PublicKey
Public Attributes | List of all members
RakNet::PublicKey Struct Reference

Passed to RakPeerInterface::Connect() More...

#include <RakNetTypes.h>

Public Attributes

PublicKeyMode publicKeyMode
How to interpret the public key, see above.
char * | remoteServerPublicKey
Pointer to a public key of length cat::EasyHandshake::PUBLIC_KEY_BYTES. See the Encryption sample.
char * | myPublicKey
(Optional) Pointer to a public key of length cat::EasyHandshake::PUBLIC_KEY_BYTES
char * | myPrivateKey
(Optional) Pointer to a private key of length cat::EasyHandshake::PRIVATE_KEY_BYTES

Detailed Description

Passed to RakPeerInterface::Connect()

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/RakNetTypes.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::SocketDescriptor Struct Reference

  • SocketDescriptor
Public Attributes | List of all members
RakNet::SocketDescriptor Struct Reference

Describes the local socket to use for RakPeer::Startup. More...

#include <RakNetTypes.h>

Public Attributes

unsigned short | port
The local port to bind to. Pass 0 to have the OS autoassign a port.
char | hostAddress [32]
The local network card address to bind to, such as "127.0.0.1". Pass an empty string to use INADDR_ANY.
short | socketFamily
unsigned int | extraSocketOptions
XBOX only: set IPPROTO_VDP if you want to use VDP. If enabled, this socket does not support broadcast to 255.255.255.255.

Detailed Description

Describes the local socket to use for RakPeer::Startup.

Member Data Documentation

short RakNet::SocketDescriptor::socketFamily

IP version: For IPV4, use AF_INET (default). For IPV6, use AF_INET6. To autoselect, use AF_UNSPEC. IPV6 is the newer internet protocol. Instead of addresses such as natpunch.jenkinssoftware.com, you may have an address such as fe80::7c:31f7:fec4:27de%14. Encoding takes 16 bytes instead of 4, so IPV6 is less efficient for bandwidth. On the positive side, NAT Punchthrough is not needed and should not be used with IPV6 because there are enough addresses that routers do not need to create address mappings. RakPeer::Startup() will fail if this IP version is not supported.

Precondition
RAKNET_SUPPORT_IPV6 must be set to 1 in RakNetDefines.h for AF_INET6
The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/RakNetTypes.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::SystemAddress Struct Reference

  • SystemAddress
Public Member Functions | Static Public Member Functions | Public Attributes | List of all members
RakNet::SystemAddress Struct Reference

Network address for a system. More...

#include <RakNetTypes.h>

Public Member Functions

SystemAddress ()
Constructors.
unsigned char | GetIPVersion (void) const
void | SetToLoopback (void)
Call SetToLoopback(), with whatever IP version is currently held. Defaults to IPV4.
void | SetToLoopback (unsigned char ipVersion)
bool | IsLoopback (void) const
bool | FromString (const char *str, char portDelineator='|', int ipVersion=0)
bool | FromStringExplicitPort (const char *str, unsigned short port, int ipVersion=0)
Same as FromString(), but you explicitly set a port at the same time.
void | CopyPort (const SystemAddress &right)
Copy the port from another SystemAddress structure.
bool | EqualsExcludingPort (const SystemAddress &right) const
Returns if two system addresses have the same IP (port is not checked)
unsigned short | GetPort (void) const
Returns the port in host order (this is what you normally use)
void | SetPortHostOrder (unsigned short s)
bool | SetBinaryAddress (const char *str, char portDelineator=':')
Old version, for crap platforms that don't support newer socket functions.
void | ToString_Old (bool writePort, char *dest, char portDelineator=':') const
Old version, for crap platforms that don't support newer socket functions.

Static Public Member Functions

static unsigned long ToInteger (const SystemAddress &sa)
Hash the system address.

Public Attributes

union sockaddr_in | addr4
SystemAddress, with RAKNET_SUPPORT_IPV6 defined, holds both an sockaddr_in6 and a sockaddr_in.
unsigned short | debugPort
This is not used internally, but holds a copy of the port held in the address union, so for debugging it's easier to check what port is being held.

Detailed Description

Network address for a system.

Corresponds to a network address
This is not necessarily a unique identifier. For example, if a system has both LAN and internet connections, the system may be identified by either one, depending on who is communicating
Therefore, you should not transmit the SystemAddress over the network and expect it to identify a system, or use it to connect to that system, except in the case where that system is not behind a NAT (such as with a dedciated server) Use RakNetGUID for a unique per-instance of RakPeer to identify systems

Member Function Documentation

bool RakNet::SystemAddress::FromString | ( | const char * | str,
 |  | char | portDelineator = '|',
 |  | int | ipVersion = 0
 | ) |  |

Set the system address from a printable IP string, for example "192.0.2.1" or "2001:db8:63b3:1::3490" You can write the port as well, using the portDelineator, for example "192.0.2.1|1234"

Parameters
[in] | str | A printable IP string, for example "192.0.2.1" or "2001:db8:63b3:1::3490". Pass 0 for str to set to UNASSIGNED_SYSTEM_ADDRESS
[in] | portDelineator | if str contains a port, delineate the port with this character. portDelineator should not be '.', ':', '', '-', '/', a number, or a-f
[in] | ipVersion | Only used if str is a pre-defined address in the wrong format, such as 127.0.0.1 but you want ip version 6, so you can pass 6 here to do the conversion
Note
The current port is unchanged if a port is not specified in str
Returns
True on success, false on ipVersion does not match type of passed string
unsigned char RakNet::SystemAddress::GetIPVersion ( void ) const

Return the IP version, either IPV4 or IPV6

Returns
Either 4 or 6
bool RakNet::SystemAddress::IsLoopback ( void ) const
Returns
If was set to 127.0.0.1 or ::1
void RakNet::SystemAddress::SetPortHostOrder ( unsigned short s )

Sets the port. The port value should be in host order (this is what you normally use) Renamed from SetPort because of winspool.h http://edn.embarcadero.com/article/21494

void RakNet::SystemAddress::SetToLoopback ( unsigned char ipVersion )

Call SetToLoopback() with a specific IP version

Parameters
[in] ipVersion Either 4 for IPV4 or 6 for IPV6
The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/RakNetTypes.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::RakNetGUID Struct Reference

  • RakNetGUID
List of all members
RakNet::RakNetGUID Struct Reference

#include <RakNetTypes.h>

Detailed Description

Uniquely identifies an instance of RakPeer. Use RakPeer::GetGuidFromSystemAddress() and RakPeer::GetSystemAddressFromGuid() to go between SystemAddress and RakNetGUID Use RakPeer::GetGuidFromSystemAddress(UNASSIGNED_SYSTEM_ADDRESS) to get your own GUID

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/RakNetTypes.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Packet Struct Reference

  • Packet
Public Attributes | List of all members
RakNet::Packet Struct Reference

This represents a user message from another system. More...

#include <RakNetTypes.h>

Public Attributes

SystemAddress systemAddress
The system that send this packet.
RakNetGUID guid
unsigned int | length
The length of the data in bytes.
BitSize_t | bitSize
The length of the data in bits.
unsigned char * | data
The data from the sender.

Detailed Description

This represents a user message from another system.

Member Data Documentation

RakNetGUID RakNet::Packet::guid

A unique identifier for the system that sent this packet, regardless of IP address (internal / external / remote system) Only valid once a connection has been established (ID_CONNECTION_REQUEST_ACCEPTED, or ID_NEW_INCOMING_CONNECTION) Until that time, will be UNASSIGNED_RAKNET_GUID

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/RakNetTypes.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::RakPeer Class Reference

  • RakPeer
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
RakNet::RakPeer Class Reference

Main interface for network communications. More...

#include <RakPeer.h>

Inheritance diagram for RakNet::RakPeer:
RakNet::RakPeerInterface

Public Member Functions

RakPeer ()
Constructor.
virtual | ~RakPeer ()
Destructor.
StartupResult | Startup (unsigned int maxConnections, SocketDescriptor *socketDescriptors, unsigned socketDescriptorCount, int threadPriority=-99999)
Starts the network threads and opens the listen port.
bool | InitializeSecurity (const char *publicKey, const char *privateKey, bool bRequireClientKey=false)
void | DisableSecurity (void)
void | AddToSecurityExceptionList (const char *ip)
This is useful if you have a fixed-address internal server behind a LAN.
void | RemoveFromSecurityExceptionList (const char *ip)
Remove a specific connection previously added via AddToSecurityExceptionList.
bool | IsInSecurityExceptionList (const char *ip)
Checks to see if a given IP is in the security exception list.
void | SetMaximumIncomingConnections (unsigned short numberAllowed)
Sets the maximum number of incoming connections allowed.
unsigned int | GetMaximumIncomingConnections (void) const
Returns the value passed to SetMaximumIncomingConnections().
unsigned short | NumberOfConnections (void) const
Returns how many open connections exist at this time.
void | SetIncomingPassword (const char *passwordData, int passwordDataLength)
Sets the password for the incoming connections.
void | GetIncomingPassword (char *passwordData, int *passwordDataLength)
Gets the password passed to SetIncomingPassword.
ConnectionAttemptResult | Connect (const char *host, unsigned short remotePort, const char *passwordData, int passwordDataLength, PublicKey *publicKey=0, unsigned connectionSocketIndex=0, unsigned sendConnectionAttemptCount=6, unsigned timeBetweenSendConnectionAttemptsMS=1000, RakNet::TimeMS timeoutTime=0)
Connect to the specified host (ip or domain name) and server port.
virtual ConnectionAttemptResult | ConnectWithSocket (const char *host, unsigned short remotePort, const char *passwordData, int passwordDataLength, RakNetSocket2 *socket, PublicKey *publicKey=0, unsigned sendConnectionAttemptCount=6, unsigned timeBetweenSendConnectionAttemptsMS=1000, RakNet::TimeMS timeoutTime=0)
Connect to the specified host (ip or domain name) and server port.
void | Shutdown (unsigned int blockDuration, unsigned char orderingChannel=0, PacketPriority disconnectionNotificationPriority=LOW_PRIORITY)
Stops the network threads and closes all connections.
bool | IsActive (void) const
Returns true if the network thread is running.
bool | GetConnectionList (SystemAddress *remoteSystems, unsigned short *numberOfSystems) const
Fills the array remoteSystems with the SystemAddress of all the systems we are connected to.
virtual uint32_t | GetNextSendReceipt (void)
virtual uint32_t | IncrementNextSendReceipt (void)
uint32_t | Send (const char *data, const int length, PacketPriority priority, PacketReliability reliability, char orderingChannel, const AddressOrGUID systemIdentifier, bool broadcast, uint32_t forceReceiptNumber=0)
Sends a block of data to the specified system that you are connected to.
void | SendLoopback (const char *data, const int length)
"Send" to yourself rather than a remote system.
uint32_t | Send (const RakNet::BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel, const AddressOrGUID systemIdentifier, bool broadcast, uint32_t forceReceiptNumber=0)
Sends a block of data to the specified system that you are connected to.
uint32_t | SendList (const char **data, const int *lengths, const int numParameters, PacketPriority priority, PacketReliability reliability, char orderingChannel, const AddressOrGUID systemIdentifier, bool broadcast, uint32_t forceReceiptNumber=0)
Sends multiple blocks of data, concatenating them automatically.
Packet * | Receive (void)
Gets a message from the incoming message queue.
void | DeallocatePacket (Packet *packet)
Call this to deallocate a message returned by Receive() when you are done handling it.
unsigned int | GetMaximumNumberOfPeers (void) const
Return the total number of connections we are allowed.
void | CloseConnection (const AddressOrGUID target, bool sendDisconnectionNotification, unsigned char orderingChannel=0, PacketPriority disconnectionNotificationPriority=LOW_PRIORITY)
Close the connection to another host (if we initiated the connection it will disconnect, if they did it will kick them out).
void | CancelConnectionAttempt (const SystemAddress target)
Cancel a pending connection attempt.
ConnectionState | GetConnectionState (const AddressOrGUID systemIdentifier)
int | GetIndexFromSystemAddress (const SystemAddress systemAddress) const
Given systemAddress, returns its index into remoteSystemList.
SystemAddress | GetSystemAddressFromIndex (unsigned int index)
Given index into remoteSystemList, will return a SystemAddress. This function is only useful for looping through all systems.
RakNetGUID | GetGUIDFromIndex (unsigned int index)
Same as GetSystemAddressFromIndex but returns RakNetGUID.
void | GetSystemList (DataStructures::List< SystemAddress > &addresses, DataStructures::List< RakNetGUID > &guids) const
Same as calling GetSystemAddressFromIndex and GetGUIDFromIndex for all systems, but more efficient Indices match each other, so addresses[0] and guids[0] refer to the same system.
void | AddToBanList (const char *IP, RakNet::TimeMS milliseconds=0)
Bans an IP from connecting.
void | RemoveFromBanList (const char *IP)
Allows a previously banned IP to connect. param[in] Dotted IP address. You can use * as a wildcard. An IP such as 128.0.0.* will ban all IP addresses starting with 128.0.0.
void | ClearBanList (void)
Allows all previously banned IPs to connect.
bool | IsBanned (const char *IP)
Returns true or false indicating if a particular IP is banned.
void | SetLimitIPConnectionFrequency (bool b)
Enable or disable allowing frequent connections from the same IP adderss.
void | Ping (const SystemAddress target)
bool | Ping (const char *host, unsigned short remotePort, bool onlyReplyOnAcceptingConnections, unsigned connectionSocketIndex=0)
Send a ping to the specified unconnected system.
int | GetAveragePing (const AddressOrGUID systemIdentifier)
Returns the average of all ping times read for the specific system or -1 if none read yet.
int | GetLastPing (const AddressOrGUID systemIdentifier) const
Returns the last ping time read for the specific system or -1 if none read yet.
int | GetLowestPing (const AddressOrGUID systemIdentifier) const
Returns the lowest ping time read or -1 if none read yet.
void | SetOccasionalPing (bool doPing)
RakNet::Time | GetClockDifferential (const AddressOrGUID systemIdentifier)
void | SetOfflinePingResponse (const char *data, const unsigned int length)
Sets the data to send along with a LAN server discovery or offline ping reply.
void | GetOfflinePingResponse (char **data, unsigned int *length)
Returns pointers to a copy of the data passed to SetOfflinePingResponse.
SystemAddress | GetInternalID (const SystemAddress systemAddress=UNASSIGNED_SYSTEM_ADDRESS, const int index=0) const
Returns the unique address identifier that represents you or another system on the the network.
void | SetInternalID (SystemAddress systemAddress, int index=0)
Sets your internal IP address, for platforms that do not support reading it, or to override a value.
SystemAddress | GetExternalID (const SystemAddress target) const
Returns the unique address identifier that represents the target on the the network and is based on the target's external IP / port.
const RakNetGUID | GetMyGUID (void) const
Return my own GUID.
SystemAddress | GetMyBoundAddress (const int socketIndex=0)
Return the address bound to a socket at the specified index.
const RakNetGUID & | GetGuidFromSystemAddress (const SystemAddress input) const
Given a connected system address, this method gives the unique GUID representing that instance of RakPeer. This will be the same on all systems connected to that instance of RakPeer, even if the external system addresses are different. Complexity is O(log2(n)). If input is UNASSIGNED_SYSTEM_ADDRESS, will return your own GUID.
SystemAddress | GetSystemAddressFromGuid (const RakNetGUID input) const
Gives the system address of a connected system, given its GUID. The GUID will be the same on all systems connected to that instance of RakPeer, even if the external system addresses are different. Currently O(log(n)), but this may be improved in the future If input is UNASSIGNED_RAKNET_GUID, UNASSIGNED_SYSTEM_ADDRESS is returned.
bool | GetClientPublicKeyFromSystemAddress (const SystemAddress input, char *client_public_key) const
void | SetTimeoutTime (RakNet::TimeMS timeMS, const SystemAddress target)
Set the time, in MS, to use before considering ourselves disconnected after not being able to deliver a reliable message.
RakNet::TimeMS | GetTimeoutTime (const SystemAddress target)
Returns the Timeout time for the given system.
int | GetMTUSize (const SystemAddress target) const
Returns the current MTU size.
unsigned | GetNumberOfAddresses (void)
Returns the number of IP addresses this system has internally.
const char * | GetLocalIP (unsigned int index)
bool | IsLocalIP (const char *ip)
void | AllowConnectionResponseIPMigration (bool allow)
Allow or disallow connection responses from any IP.
bool | AdvertiseSystem (const char *host, unsigned short remotePort, const char *data, int dataLength, unsigned connectionSocketIndex=0)
Sends a one byte message ID_ADVERTISE_SYSTEM to the remote unconnected system. This will send our external IP outside the LAN along with some user data to the remote system.
void | SetSplitMessageProgressInterval (int interval)
Controls how often to return ID_DOWNLOAD_PROGRESS for large message downloads.
int | GetSplitMessageProgressInterval (void) const
Returns what was passed to SetSplitMessageProgressInterval().
void | SetUnreliableTimeout (RakNet::TimeMS timeoutMS)
Set how long to wait before giving up on sending an unreliable message. Useful if the network is clogged up. Set to 0 or less to never timeout. Defaults to 0.
void | SendTTL (const char *host, unsigned short remotePort, int ttl, unsigned connectionSocketIndex=0)
Send a message to a host, with the IP socket option TTL set to 3.
void | AttachPlugin (PluginInterface2 *plugin)
Attaches a Plugin interface to an instance of the base class (RakPeer or PacketizedTCP) to run code automatically on message receipt in the Receive call. If the plugin returns false from PluginInterface::UsesReliabilityLayer(), which is the case for all plugins except PacketLogger, you can call AttachPlugin() and DetachPlugin() for this plugin while RakPeer is active.
void | DetachPlugin (PluginInterface2 *messageHandler)
Detaches a Plugin interface from the instance of the base class (RakPeer or PacketizedTCP) it is attached to.
void | PushBackPacket (Packet *packet, bool pushAtHead)
Puts a message back in the receive queue in case you don't want to deal with it immediately.
Packet * | AllocatePacket (unsigned dataSize)
Returns a packet for you to write to if you want to create a Packet for some reason. You can add it to the receive buffer with PushBackPacket.
virtual RakNetSocket2 * | GetSocket (const SystemAddress target)
Get the socket used with a particular active connection. The smart pointer reference counts the RakNetSocket object, so the socket will remain active as long as the smart pointer does, even if RakNet were to shutdown or close the connection.
virtual void | GetSockets (DataStructures::List< RakNetSocket2 * > &sockets)
Gets all sockets in use.
virtual void | SetUserUpdateThread (void(*_userUpdateThreadPtr)(RakPeerInterface *, void *), void *_userUpdateThreadData)
virtual void | SetIncomingDatagramEventHandler (bool(*_incomingDatagramEventHandler)(RNS2RecvStruct *))
virtual void | ApplyNetworkSimulator (float packetloss, unsigned short minExtraPing, unsigned short extraPingVariance)
virtual void | SetPerConnectionOutgoingBandwidthLimit (unsigned maxBitsPerSecond)
virtual bool | IsNetworkSimulatorActive (void)
RakNetStatistics * | GetStatistics (const SystemAddress systemAddress, RakNetStatistics *rns=0)
Returns a structure containing a large set of network statistics for the specified system. You can map this data to a string using the C style StatisticsToString() function.
bool | GetStatistics (const unsigned int index, RakNetStatistics *rns)
Returns the network statistics of the system at the given index in the remoteSystemList.
virtual void | GetStatisticsList (DataStructures::List< SystemAddress > &addresses, DataStructures::List< RakNetGUID > &guids, DataStructures::List< RakNetStatistics > &statistics)
Returns the list of systems, and statistics for each of those systems Each system has one entry in each of the lists, in the same order.
virtual unsigned int | GetReceiveBufferSize (void)
how many messages are waiting when you call Receive()
- Public Member Functions inherited from RakNet::RakPeerInterface
virtual | ~RakPeerInterface ()
Destructor.

Protected Member Functions

RemoteSystemStruct * | GetRemoteSystemFromSystemAddress (const SystemAddress systemAddress, bool calledFromNetworkThread, bool onlyActive) const
void | ParseConnectionRequestPacket (RakPeer::RemoteSystemStruct *remoteSystem, const SystemAddress &systemAddress, const char *data, int byteSize)
Parse out a connection request packet.
void | NotifyAndFlagForShutdown (const SystemAddress systemAddress, bool performImmediate, unsigned char orderingChannel, PacketPriority disconnectionNotificationPriority)
Send a reliable disconnect packet to this player and disconnect them when it is delivered.
unsigned int | GetNumberOfRemoteInitiatedConnections (void) const
Returns how many remote systems initiated a connection to us.
RemoteSystemStruct * | AssignSystemAddressToRemoteSystemList (const SystemAddress systemAddress, RemoteSystemStruct::ConnectMode connectionMode, RakNetSocket2 *incomingRakNetSocket, bool *thisIPConnectedRecently, SystemAddress bindingAddress, int incomingMTU, RakNetGUID guid, bool useSecurity)
Get a free remote system from the list and assign our systemAddress to it.
void | ShiftIncomingTimestamp (unsigned char *data, const SystemAddress &systemAddress) const
Adjust the timestamp of the incoming packet to be relative to this system.
RakNet::Time | GetBestClockDifferential (const SystemAddress systemAddress) const

Protected Attributes

volatile bool | endThreads
Set this to true to terminate the Peer thread execution.
volatile bool | isMainLoopThreadActive
true if the peer thread is active.
*unsigned int | maximumNumberOfPeers
Store the maximum number of peers allowed to connect.
unsigned int | maximumIncomingConnections
Store the maximum number of peers able to connect, including reserved connection slots for pings, etc.
char | incomingPassword [256]
Local Player ID.
RemoteSystemStruct * | remoteSystemList
RemoteSystemStruct ** | activeSystemList
bool | updateCycleIsRunning
RunUpdateCycle is not thread safe but we don't need to mutex calls. Just skip calls if it is running already.
unsigned int | bytesSentPerSecond
The list of people we have tried to connect to recently.
bool | allowConnectionResponseIPMigration
How long it has been since things were updated by a call to receiveUpdate thread uses this to determine how long to sleep for.
SimpleMutex sendReceiptSerialMutex

Additional Inherited Members

- Static Public Member Functions inherited from RakNet::RakPeerInterface
static uint64_t Get64BitUniqueRandomNumber (void)
Get a random number (to generate a GUID)

Detailed Description

Main interface for network communications.

It implements most of RakNet's functionality and is the primary interface for RakNet.

Inherits RakPeerInterface.

See the individual functions for what the class can do.

Member Function Documentation

void RakNet::RakPeer::AddToBanList | ( | const char * | IP,
 |  | RakNet::TimeMS | milliseconds = 0
 | ) |  |
virtual

Bans an IP from connecting.

Banned IPs persist between connections but are not saved on shutdown nor loaded on startup.

Parameters
[in] | IP | Dotted IP address. You can use * for a wildcard address, such as 128.0.0. * will ban all IP addresses starting with 128.0.0.
[in] | milliseconds | Gives time in milli seconds for a temporary ban of the IP address. Use 0 for a permanent ban.

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::AddToSecurityExceptionList ( const char * ip )
virtual

This is useful if you have a fixed-address internal server behind a LAN.

Secure connections are determined by the recipient of an incoming connection. This has no effect if called on the system attempting to connect.

Note
If secure connections are on, do not use secure connections for a specific IP address.
Parameters
[in] ip IP address to add. * wildcards are supported.

Implements RakNet::RakPeerInterface.

bool RakNet::RakPeer::AdvertiseSystem | ( | const char * | host,
 |  | unsigned short | remotePort,
 |  | const char * | data,
 |  | int | dataLength,
 |  | unsigned | connectionSocketIndex = 0
 | ) |  |
virtual

Sends a one byte message ID_ADVERTISE_SYSTEM to the remote unconnected system. This will send our external IP outside the LAN along with some user data to the remote system.

Precondition
The sender and recipient must already be started via a successful call to Initialize
Parameters
[in] | host | Either a dotted IP address or a domain name
[in] | remotePort | Which port to connect to on the remote machine.
[in] | data | Optional data to append to the packet.
[in] | dataLength | Length of data in bytes. Use 0 if no data.
[in] | connectionSocketIndex | Index into the array of socket descriptors passed to socketDescriptors in RakPeer::Startup() to send on.
Returns
False if IsActive()==false or the host is unresolvable. True otherwise.

Implements RakNet::RakPeerInterface.

Packet* RakNet::RakPeer::AllocatePacket ( unsigned dataSize )
virtual

Returns a packet for you to write to if you want to create a Packet for some reason. You can add it to the receive buffer with PushBackPacket.

Parameters
[in] dataSize How many bytes to allocate for the buffer
Returns
A packet.

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::AllowConnectionResponseIPMigration ( bool allow )
virtual

Allow or disallow connection responses from any IP.

Normally this should be false, but may be necessary when connecting to servers with multiple IP addresses.

Parameters
[in] allow - True to allow this behavior, false to not allow. Defaults to false. Value persists between connections.

Implements RakNet::RakPeerInterface.

virtual void RakNet::RakPeer::ApplyNetworkSimulator | ( | float | packetloss,
 |  | unsigned short | minExtraPing,
 |  | unsigned short | extraPingVariance
 | ) |  |
virtual

Adds simulated ping and packet loss to the outgoing data flow. To simulate bi-directional ping and packet loss, you should call this on both the sender and the recipient, with half the total ping and packetloss value on each. You can exclude network simulator code with the _RELEASE #define to decrease code size

Deprecated:
Use http://www.jenkinssoftware.com/forum/index.php?topic=1671.0 instead.
Note
Doesn't work past version 3.6201
Parameters
[in] | packetloss | Chance to lose a packet. Ranges from 0 to 1.
[in] | minExtraPing | The minimum time to delay sends.
[in] | extraPingVariance | The additional random time to delay sends.

Implements RakNet::RakPeerInterface.

RemoteSystemStruct* RakNet::RakPeer::AssignSystemAddressToRemoteSystemList | ( | const SystemAddress | systemAddress,
 |  | RemoteSystemStruct::ConnectMode | connectionMode,
 |  | RakNetSocket2 * | incomingRakNetSocket,
 |  | bool * | thisIPConnectedRecently,
 |  | SystemAddress | bindingAddress,
 |  | int | incomingMTU,
 |  | RakNetGUID | guid,
 |  | bool | useSecurity
 | ) |  |
protected

Get a free remote system from the list and assign our systemAddress to it.

Note
Should only be called from the update thread - not the user thread.
Parameters
[in] | systemAddress | systemAddress to be assigned
[in] | connectionMode | connection mode of the RemoteSystem.
[in] | rakNetSocket
[in] | thisIPConnectedRecently | Is this IP connected recently? set to False;
[in] | bindingAddress | Address to be binded with the remote system
[in] | incomingMTU | MTU for the remote system
void RakNet::RakPeer::AttachPlugin ( PluginInterface2 * plugin )
virtual

Attaches a Plugin interface to an instance of the base class (RakPeer or PacketizedTCP) to run code automatically on message receipt in the Receive call. If the plugin returns false from PluginInterface::UsesReliabilityLayer(), which is the case for all plugins except PacketLogger, you can call AttachPlugin() and DetachPlugin() for this plugin while RakPeer is active.

Parameters
[in] messageHandler Pointer to the plugin to attach.

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::CancelConnectionAttempt ( const SystemAddress target )
virtual

Cancel a pending connection attempt.

If we are already connected, the connection stays open

Parameters
[in] target Target system to cancel.

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::CloseConnection | ( | const AddressOrGUID | target,
 |  | bool | sendDisconnectionNotification,
 |  | unsigned char | orderingChannel = 0,
 |  | PacketPriority | disconnectionNotificationPriority = LOW_PRIORITY
 | ) |  |
virtual

Close the connection to another host (if we initiated the connection it will disconnect, if they did it will kick them out).

This method closes the connection irrespective of who initiated the connection.

Parameters
[in] | target | Which system to close the connection to.
[in] | sendDisconnectionNotification | True to send ID_DISCONNECTION_NOTIFICATION to the recipient. False to close it silently.
[in] | channel | Which ordering channel to send the disconnection notification on, if any
[in] | disconnectionNotificationPriority | Priority to send ID_DISCONNECTION_NOTIFICATION on.

Implements RakNet::RakPeerInterface.

ConnectionAttemptResult RakNet::RakPeer::Connect | ( | const char * | host,
 |  | unsigned short | remotePort,
 |  | const char * | passwordData,
 |  | int | passwordDataLength,
 |  | PublicKey * | publicKey = 0,
 |  | unsigned | connectionSocketIndex = 0,
 |  | unsigned | sendConnectionAttemptCount = 6,
 |  | unsigned | timeBetweenSendConnectionAttemptsMS = 1000,
 |  | RakNet::TimeMS | timeoutTime = 0
 | ) |  |
virtual

Connect to the specified host (ip or domain name) and server port.

Calling Connect and not calling SetMaximumIncomingConnections acts as a dedicated client. Calling both acts as a true peer.

This is a non-blocking connection.

The connection is successful when GetConnectionState() returns IS_CONNECTED or Receive() gets a message with the type identifier ID_CONNECTION_REQUEST_ACCEPTED. If the connection is not successful, such as a rejected connection or no response then neither of these things will happen.

Precondition
Requires that you first call Startup().
Parameters
[in] | host | Either a dotted IP address or a domain name.
[in] | remotePort | Port to connect to on the remote machine.
[in] | passwordData | A data block that must match the data block on the server passed to SetIncomingPassword(). This can be a string or can be a stream of data. Use 0 for no password.
[in] | passwordDataLength | The length in bytes of passwordData.
[in] | publicKey | The public key the server is using. If 0, the server is not using security. If non-zero, the publicKeyMode member determines how to connect
[in] | connectionSocketIndex | Index into the array of socket descriptors passed to socketDescriptors in RakPeer::Startup() to determine the one to send on.
[in] | sendConnectionAttemptCount | Number of datagrams to send to the other system to try to connect.
[in] | timeBetweenSendConnectionAttemptsMS | Time to elapse before a datagram is sent to the other system to try to connect. After sendConnectionAttemptCount number of attempts, ID_CONNECTION_ATTEMPT_FAILED is returned. Under low bandwidth conditions with multiple simultaneous outgoing connections, this value should be raised to 1000 or higher, or else the MTU detection can overrun the available bandwidth.
[in] | timeoutTime | Time to elapse before dropping the connection if a reliable message could not be sent. 0 to use the default value from SetTimeoutTime(UNASSIGNED_SYSTEM_ADDRESS);
Returns
CONNECTION_ATTEMPT_STARTED on successful initiation. Otherwise, an appropriate enumeration indicating failure.
Note
CONNECTION_ATTEMPT_STARTED does not mean you are already connected!
It is possible to immediately get back ID_CONNECTION_ATTEMPT_FAILED if you exceed the maxConnections parameter passed to Startup(). This could happen if you call CloseConnection() with sendDisconnectionNotificaiton true, then immediately call Connect() before the connection has closed.

Implements RakNet::RakPeerInterface.

virtual ConnectionAttemptResult RakNet::RakPeer::ConnectWithSocket | ( | const char * | host,
 |  | unsigned short | remotePort,
 |  | const char * | passwordData,
 |  | int | passwordDataLength,
 |  | RakNetSocket2 * | socket,
 |  | PublicKey * | publicKey = 0,
 |  | unsigned | sendConnectionAttemptCount = 6,
 |  | unsigned | timeBetweenSendConnectionAttemptsMS = 1000,
 |  | RakNet::TimeMS | timeoutTime = 0
 | ) |  |
virtual

Connect to the specified host (ip or domain name) and server port.

Parameters
[in] | host | Either a dotted IP address or a domain name.
[in] | remotePort | Which port to connect to on the remote machine.
[in] | passwordData | A data block that must match the data block on the server passed to SetIncomingPassword(). This can be a string or can be a stream of data. Use 0 for no password.
[in] | passwordDataLength | The length in bytes of passwordData.
[in] | socket | A bound socket returned by another instance of RakPeerInterface.
[in] | sendConnectionAttemptCount | Number of datagrams to send to the other system to try to connect.
[in] | timeBetweenSendConnectionAttemptsMS | Time to elapse before a datagram is sent to the other system to try to connect. After sendConnectionAttemptCount number of attempts, ID_CONNECTION_ATTEMPT_FAILED is returned.. Under low bandwidth conditions with multiple simultaneous outgoing connections, this value should be raised to 1000 or higher, or else the MTU detection can overrun the available bandwidth.
[in] | timeoutTime | Time to elapse before dropping the connection if a reliable message could not be sent. 0 to use the default from SetTimeoutTime(UNASSIGNED_SYSTEM_ADDRESS);
Returns
CONNECTION_ATTEMPT_STARTED on successful initiation. Otherwise, an appropriate enumeration indicating failure.
Note
CONNECTION_ATTEMPT_STARTED does not mean you are already connected!

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::DeallocatePacket ( Packet * packet )
virtual

Call this to deallocate a message returned by Receive() when you are done handling it.

Parameters
[in] packet Message to deallocate.

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::DetachPlugin ( PluginInterface2 * messageHandler )
virtual

Detaches a Plugin interface from the instance of the base class (RakPeer or PacketizedTCP) it is attached to.

This method disables the plugin code from running automatically on base class's updates or message receipt. If the plugin returns false from PluginInterface::UsesReliabilityLayer(), which is the case for all plugins except PacketLogger, you can call AttachPlugin() and DetachPlugin() for this plugin while RakPeer is active.

Parameters
[in] messageHandler Pointer to a plugin to detach.

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::DisableSecurity ( void )
virtual

Disables security for incoming connections.

Note
Must be called while offline

Implements RakNet::RakPeerInterface.

int RakNet::RakPeer::GetAveragePing ( const AddressOrGUID systemIdentifier )
virtual

Returns the average of all ping times read for the specific system or -1 if none read yet.

Parameters
[in] systemAddress Which system we are referring to
Returns
The ping time for this system, or -1

Implements RakNet::RakPeerInterface.

RakNet::Time RakNet::RakPeer::GetBestClockDifferential ( const SystemAddress systemAddress ) const
protected

Get the most accurate clock differential for a certain player.

Parameters
[in] systemAddress The player with whose clock the time difference is calculated.
Returns
The clock differential for a certain player.
bool RakNet::RakPeer::GetClientPublicKeyFromSystemAddress | ( | const SystemAddress | input,
 |  | char * | client_public_key
 | ) |  | const
 virtual

Given the SystemAddress of a connected system, get the public key they provided as an identity Returns false if system address was not found or client public key is not known

Parameters
[in] | input | The RakNetGUID of the system
[in] | client_public_key | The connected client's public key is copied to this address. Buffer must be cat::EasyHandshake::PUBLIC_KEY_BYTES bytes in length.

Implements RakNet::RakPeerInterface.

RakNet::Time RakNet::RakPeer::GetClockDifferential ( const AddressOrGUID systemIdentifier )
virtual

Return the clock difference between your system and the specified system Subtract GetClockDifferential() from a time returned by the remote system to get that time relative to your own system Returns 0 if the system is unknown

Parameters
[in] systemIdentifier Which system we are referring to

Implements RakNet::RakPeerInterface.

bool RakNet::RakPeer::GetConnectionList | ( | SystemAddress * | remoteSystems,
 |  | unsigned short * | numberOfSystems
 | ) |  | const
 virtual

Fills the array remoteSystems with the SystemAddress of all the systems we are connected to.

Parameters
[out] | remoteSystems | An array of SystemAddress structures, to be filled with the SystemAddresss of the systems we are connected to. Pass 0 to remoteSystems to get the number of systems we are connected to.
[in,out] | numberOfSystems | As input, the size of remoteSystems array. As output, the number of elements put into the array.

Implements RakNet::RakPeerInterface.

ConnectionState RakNet::RakPeer::GetConnectionState ( const AddressOrGUID systemIdentifier )
virtual

Returns if a system is connected, disconnected, connecting in progress, or various other states

Parameters
[in] systemIdentifier The system we are referring to
Note
This locks a mutex, do not call too frequently during connection attempts or the attempt will take longer and possibly even timeout
Returns
What state the remote system is in

Implements RakNet::RakPeerInterface.

SystemAddress RakNet::RakPeer::GetExternalID ( const SystemAddress target ) const
virtual

Returns the unique address identifier that represents the target on the the network and is based on the target's external IP / port.

Parameters
[in] target The SystemAddress of the remote system. Usually the same for all systems, unless you have two or more network cards.

Implements RakNet::RakPeerInterface.

RakNetGUID RakNet::RakPeer::GetGUIDFromIndex ( unsigned int index )
virtual

Same as GetSystemAddressFromIndex but returns RakNetGUID.

Parameters
[in] index Index should range between 0 and the maximum number of players allowed - 1.
Returns
The RakNetGUID

Implements RakNet::RakPeerInterface.

const RakNetGUID& RakNet::RakPeer::GetGuidFromSystemAddress ( const SystemAddress input ) const
virtual

Given a connected system address, this method gives the unique GUID representing that instance of RakPeer. This will be the same on all systems connected to that instance of RakPeer, even if the external system addresses are different. Complexity is O(log2(n)). If input is UNASSIGNED_SYSTEM_ADDRESS, will return your own GUID.

Precondition
Call Startup() first, or the function will return UNASSIGNED_RAKNET_GUID
Parameters
[in] input The system address of the target system we are connected to.

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::GetIncomingPassword | ( | char * | passwordData,
 |  | int * | passwordDataLength
 | ) |  |
virtual

Gets the password passed to SetIncomingPassword.

Parameters
[out] | passwordData | Should point to a block large enough to hold the password data you passed to SetIncomingPassword()
[in,out] | passwordDataLength | Maximum size of the passwordData array. Modified to hold the number of bytes actually written.

Implements RakNet::RakPeerInterface.

int RakNet::RakPeer::GetIndexFromSystemAddress ( const SystemAddress systemAddress ) const
virtual

Given systemAddress, returns its index into remoteSystemList.

Values range from 0 to the maximum number of players allowed - 1. This includes systems which were formerly connected, but are now not connected.

Parameters
[in] systemAddress The SystemAddress we are referring to
Returns
The index of this SystemAddress or -1 on system not found.

Implements RakNet::RakPeerInterface.

SystemAddress RakNet::RakPeer::GetInternalID | ( | const SystemAddress | systemAddress = UNASSIGNED_SYSTEM_ADDRESS,
 |  | const int | index = 0
 | ) |  | const
 virtual

Returns the unique address identifier that represents you or another system on the the network.

Note
Not supported by the XBOX
Parameters
[in] | systemAddress | Use UNASSIGNED_SYSTEM_ADDRESS to get your behind-LAN address. Use a connected system to get their behind-LAN address. This does not return the port.
[in] | index | When you have multiple internal IDs, which index to return? Currently limited to MAXIMUM_NUMBER_OF_INTERNAL_IDS (so the maximum value of this variable is MAXIMUM_NUMBER_OF_INTERNAL_IDS-1)
Returns
Identifier of your system internally, which may not be how other systems see if you if you are behind a NAT or proxy.

Implements RakNet::RakPeerInterface.

int RakNet::RakPeer::GetLastPing ( const AddressOrGUID systemIdentifier ) const
virtual

Returns the last ping time read for the specific system or -1 if none read yet.

Parameters
[in] systemAddress Which system we are referring to
Returns
The last ping time for this system, or -1.

Implements RakNet::RakPeerInterface.

const char* RakNet::RakPeer::GetLocalIP ( unsigned int index )
virtual

Returns an IP address at index 0 to GetNumberOfAddresses-1 in ipList array.

Parameters
[in] index index into the list of IP addresses
Returns
The local IP address at this index

Implements RakNet::RakPeerInterface.

int RakNet::RakPeer::GetLowestPing ( const AddressOrGUID systemIdentifier ) const
virtual

Returns the lowest ping time read or -1 if none read yet.

Parameters
[in] systemIdentifier Which system we are referring to
Returns
The lowest ping time for this system, or -1.

Implements RakNet::RakPeerInterface.

unsigned int RakNet::RakPeer::GetMaximumIncomingConnections ( void ) const
virtual

Returns the value passed to SetMaximumIncomingConnections().

Returns
Maximum number of incoming connections, which is always <= maxConnections

Implements RakNet::RakPeerInterface.

unsigned int RakNet::RakPeer::GetMaximumNumberOfPeers ( void ) const
virtual

Return the total number of connections we are allowed.

Returns
Total number of connections allowed.

Implements RakNet::RakPeerInterface.

int RakNet::RakPeer::GetMTUSize ( const SystemAddress target ) const
virtual

Returns the current MTU size.

Parameters
[in] target Which system to get MTU for. UNASSIGNED_SYSTEM_ADDRESS to get the default
Returns
The current MTU size of the target system.

Implements RakNet::RakPeerInterface.

virtual uint32_t RakNet::RakPeer::GetNextSendReceipt ( void )
virtual

Returns the next uint32_t that Send() will return

Note
If using RakPeer from multiple threads, this may not be accurate for your thread. Use IncrementNextSendReceipt() in that case.
Returns
The next uint32_t that Send() or SendList will return

Implements RakNet::RakPeerInterface.

unsigned RakNet::RakPeer::GetNumberOfAddresses ( void )
virtual

Returns the number of IP addresses this system has internally.

Get the actual addresses from GetLocalIP()

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::GetOfflinePingResponse | ( | char ** | data,
 |  | unsigned int * | length
 | ) |  |
virtual

Returns pointers to a copy of the data passed to SetOfflinePingResponse.

Parameters
[out] | data | A pointer to a copy of the data passed to SetOfflinePingResponse()
[out] | length | A pointer filled in with the length parameter passed to SetOfflinePingResponse()
See Also
SetOfflinePingResponse

Implements RakNet::RakPeerInterface.

RemoteSystemStruct* RakNet::RakPeer::GetRemoteSystemFromSystemAddress | ( | const SystemAddress | systemAddress,
 |  | bool | calledFromNetworkThread,
 |  | bool | onlyActive
 | ) |  | const
 protected

Get the reliability layer associated with a systemAddress.

Parameters
[in] systemAddress The player identifier
Returns
0 if none
virtual RakNetSocket2* RakNet::RakPeer::GetSocket ( const SystemAddress target )
virtual

Get the socket used with a particular active connection. The smart pointer reference counts the RakNetSocket object, so the socket will remain active as long as the smart pointer does, even if RakNet were to shutdown or close the connection.

Note
This sends a query to the thread and blocks on the return value for up to one second. In practice it should only take a millisecond or so.
Parameters
[in] target Which system.
Returns
A smart pointer object containing the socket information about the target. Be sure to check IsNull() which is returned if the update thread is unresponsive, shutting down, or if this system is not connected.

Implements RakNet::RakPeerInterface.

virtual void RakNet::RakPeer::GetSockets ( DataStructures::List< RakNetSocket2 * > & sockets )
virtual

Gets all sockets in use.

Note
This sends a query to the thread and blocks on the return value for up to one second. In practice it should only take a millisecond or so.
Parameters
[out] sockets List of RakNetSocket structures in use.

Implements RakNet::RakPeerInterface.

int RakNet::RakPeer::GetSplitMessageProgressInterval ( void ) const
virtual

Returns what was passed to SetSplitMessageProgressInterval().

Returns
Number of messages to be recieved before a download progress notification is returned. Default to 0.

Implements RakNet::RakPeerInterface.

RakNetStatistics* RakNet::RakPeer::GetStatistics | ( | const SystemAddress | systemAddress,
 |  | RakNetStatistics * | rns = 0
 | ) |  |
virtual

Returns a structure containing a large set of network statistics for the specified system. You can map this data to a string using the C style StatisticsToString() function.

Parameters
[in] | systemAddress | Which connected system to get statistics for.
[in] | rns | If you supply this structure,the network statistics will be written to it. Otherwise the method uses a static struct to write the data, which is not threadsafe.
Returns
0 if the specified system can't be found. Otherwise a pointer to the struct containing the specified system's network statistics.
See Also
RakNetStatistics.h

Implements RakNet::RakPeerInterface.

bool RakNet::RakPeer::GetStatistics | ( | const unsigned int | index,
 |  | RakNetStatistics * | rns
 | ) |  |
virtual

Returns the network statistics of the system at the given index in the remoteSystemList.

Returns
True if the index is less than the maximum number of peers allowed and the system is active. False otherwise.

Implements RakNet::RakPeerInterface.

virtual void RakNet::RakPeer::GetStatisticsList | ( | DataStructures::List< SystemAddress > & | addresses,
 |  | DataStructures::List< RakNetGUID > & | guids,
 |  | DataStructures::List< RakNetStatistics > & | statistics
 | ) |  |
virtual

Returns the list of systems, and statistics for each of those systems Each system has one entry in each of the lists, in the same order.

Parameters
[out] | addresses | SystemAddress for each connected system
[out] | guids | RakNetGUID for each connected system
[out] | statistics | Calculated RakNetStatistics for each connected system

Implements RakNet::RakPeerInterface.

SystemAddress RakNet::RakPeer::GetSystemAddressFromGuid ( const RakNetGUID input ) const
virtual

Gives the system address of a connected system, given its GUID. The GUID will be the same on all systems connected to that instance of RakPeer, even if the external system addresses are different. Currently O(log(n)), but this may be improved in the future If input is UNASSIGNED_RAKNET_GUID, UNASSIGNED_SYSTEM_ADDRESS is returned.

Parameters
[in] input The RakNetGUID of the target system.

Implements RakNet::RakPeerInterface.

SystemAddress RakNet::RakPeer::GetSystemAddressFromIndex ( unsigned int index )
virtual

Given index into remoteSystemList, will return a SystemAddress. This function is only useful for looping through all systems.

Parameters
[in] index Index should range between 0 and the maximum number of players allowed - 1.
Returns
The SystemAddress structure corresponding to index in remoteSystemList.

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::GetSystemList | ( | DataStructures::List< SystemAddress > & | addresses,
 |  | DataStructures::List< RakNetGUID > & | guids
 | ) |  | const
 virtual

Same as calling GetSystemAddressFromIndex and GetGUIDFromIndex for all systems, but more efficient Indices match each other, so addresses[0] and guids[0] refer to the same system.

Parameters
[out] | addresses | All system addresses. Size of the list is the number of connections. Size of the addresses list will match the size of the guids list.
[out] | guids | All guids. Size of the list is the number of connections. Size of the list will match the size of the addresses list.

Implements RakNet::RakPeerInterface.

RakNet::TimeMS RakNet::RakPeer::GetTimeoutTime ( const SystemAddress target )
virtual

Returns the Timeout time for the given system.

Parameters
[in] target Target system to get the TimeoutTime for. Pass UNASSIGNED_SYSTEM_ADDRESS to get the default value.
Returns
Timeout time for a given system.

Implements RakNet::RakPeerInterface.

virtual uint32_t RakNet::RakPeer::IncrementNextSendReceipt ( void )
virtual

Returns the next uint32_t that Send() will return, and increments the value by one

Note
If using RakPeer from multiple threads, pass this to forceReceipt in the send function
Returns
The next uint32_t that Send() or SendList will return

Implements RakNet::RakPeerInterface.

bool RakNet::RakPeer::InitializeSecurity | ( | const char * | publicKey,
 |  | const char * | privateKey,
 |  | bool | bRequireClientKey = false
 | ) |  |
virtual

If you accept connections, you must call this or else security will not be enabled for incoming connections. This feature requires more round trips, bandwidth, and CPU time for the connection handshake x64 builds require under 25% of the CPU time of other builds See the Encryption sample for example usage

Precondition
Must be called while offline
LIBCAT_SECURITY must be defined to 1 in NativeFeatureIncludes.h for this function to have any effect
Parameters
[in] | publicKey | A pointer to the public key for accepting new connections
[in] | privateKey | A pointer to the private key for accepting new connections
[in] bRequireClientKey,: Should be set to false for most servers. Allows the server to accept a public key from connecting clients as a proof of identity but eats twice as much CPU time as a normal connection

Implements RakNet::RakPeerInterface.

bool RakNet::RakPeer::IsActive ( void ) const
virtual

Returns true if the network thread is running.

Returns
True if the network thread is running, False otherwise

Implements RakNet::RakPeerInterface.

bool RakNet::RakPeer::IsBanned ( const char * IP )
virtual

Returns true or false indicating if a particular IP is banned.

Parameters
[in] IP Dotted IP address.
Returns
True if IP matches any IPs in the ban list, accounting for any wildcards. False otherwise.

Implements RakNet::RakPeerInterface.

bool RakNet::RakPeer::IsInSecurityExceptionList ( const char * ip )
virtual

Checks to see if a given IP is in the security exception list.

Parameters
[in] IP address to check.
Returns
True if the IP address is found in security exception list, else returns false.

Implements RakNet::RakPeerInterface.

bool RakNet::RakPeer::IsLocalIP ( const char * ip )
virtual

Is this a local IP? Checks if this ip is in the ipList array.

Parameters
[in] An IP address to check, excluding the port.
Returns
True if this is one of the IP addresses returned by GetLocalIP

Implements RakNet::RakPeerInterface.

virtual bool RakNet::RakPeer::IsNetworkSimulatorActive ( void )
virtual

Returns if you previously called ApplyNetworkSimulator

Returns
If you previously called ApplyNetworkSimulator

Implements RakNet::RakPeerInterface.

unsigned short RakNet::RakPeer::NumberOfConnections ( void ) const
virtual

Returns how many open connections exist at this time.

Returns
Number of open connections.

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::Ping ( const SystemAddress target )
virtual

Send a ping to the specified connected system.

Precondition
The sender and recipient must already be started via a successful call to Startup()
Parameters
[in] target Which system to ping

Implements RakNet::RakPeerInterface.

bool RakNet::RakPeer::Ping | ( | const char * | host,
 |  | unsigned short | remotePort,
 |  | bool | onlyReplyOnAcceptingConnections,
 |  | unsigned | connectionSocketIndex = 0
 | ) |  |
virtual

Send a ping to the specified unconnected system.

The remote system, if it is Initialized, will respond with ID_PONG followed by sizeof(RakNet::TimeMS) containing the system time the ping was sent. Default is 4 bytes - See __GET_TIME_64BIT in RakNetTypes.h System should reply with ID_PONG if it is active

Parameters
[in] | host | Either a dotted IP address or a domain name. Can be 255.255.255.255 for LAN broadcast.
[in] | remotePort | Which port to connect to on the remote machine.
[in] | onlyReplyOnAcceptingConnections | Only request a reply if the remote system is accepting connections
[in] | connectionSocketIndex | Index into the array of socket descriptors passed to socketDescriptors in RakPeer::Startup() to send on.
Returns
true on success, false on failure (unknown hostname)

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::PushBackPacket | ( | Packet * | packet,
 |  | bool | pushAtHead
 | ) |  |
virtual

Puts a message back in the receive queue in case you don't want to deal with it immediately.

Parameters
[in] | packet | The pointer to the packet you want to push back.
[in] | pushAtHead | True to push the packet at the start of the queue so that the next receive call returns it. False to push it at the end of the queue.
Note
Setting pushAtHead to false end makes the packets out of order.

Implements RakNet::RakPeerInterface.

Packet* RakNet::RakPeer::Receive ( void )
virtual

Gets a message from the incoming message queue.

Use DeallocatePacket() to deallocate the message after you are done with it. User-thread functions, such as RPC calls and the plugin function PluginInterface::Update occur here.

Returns
0 if no packets are waiting to be handled, otherwise a pointer to a packet.
Note
COMMON MISTAKE: Be sure to call this in a loop, once per game tick, until it returns 0. If you only process one packet per game tick they will buffer up.
See Also
RakNetTypes.h contains struct Packet.

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::RemoveFromSecurityExceptionList ( const char * ip )
virtual

Remove a specific connection previously added via AddToSecurityExceptionList.

Parameters
[in] ip IP address to remove. Pass 0 to remove all IP addresses. * wildcards are supported.

Implements RakNet::RakPeerInterface.

uint32_t RakNet::RakPeer::Send | ( | const char * | data,
 |  | const int | length,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | const AddressOrGUID | systemIdentifier,
 |  | bool | broadcast,
 |  | uint32_t | forceReceiptNumber = 0
 | ) |  |
virtual

Sends a block of data to the specified system that you are connected to.

Note
This function only works while connected.
The first byte should be a message identifier starting at ID_USER_PACKET_ENUM.
Parameters
[in] | data | Block of data to send.
[in] | length | Size in bytes of the data to send.
[in] | priority | Priority level to send on. See PacketPriority.h
[in] | reliability | How reliably to send this data. See PacketPriority.h
[in] | orderingChannel | When using ordered or sequenced messages, the channel to order these on. Messages are only ordered relative to other messages on the same stream.
[in] | systemIdentifier | Who to send this packet to, or in the case of broadcasting who not to send it to. Pass either a SystemAddress structure or a RakNetGUID structure. Use UNASSIGNED_SYSTEM_ADDRESS or to specify none
[in] | broadcast | True to send this packet to all connected systems. If true, then systemAddress specifies who not to send the packet to.
[in] | forceReceipt | If 0, will automatically determine the receipt number to return. If non-zero, will return what you give it.
Returns
0 on bad input. Otherwise a number that identifies this message. If reliability is a type that returns a receipt, on a later call to Receive() you will get ID_SND_RECEIPT_ACKED or ID_SND_RECEIPT_LOSS with bytes 1-4 inclusive containing this number

Implements RakNet::RakPeerInterface.

uint32_t RakNet::RakPeer::Send | ( | const RakNet::BitStream * | bitStream,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | const AddressOrGUID | systemIdentifier,
 |  | bool | broadcast,
 |  | uint32_t | forceReceiptNumber = 0
 | ) |  |
virtual

Sends a block of data to the specified system that you are connected to.

Same as the above version, but takes a BitStream as input.

Parameters
[in] | bitStream | Bitstream to send
[in] | priority | Priority level to send on. See PacketPriority.h
[in] | reliability | How reliably to send this data. See PacketPriority.h
[in] | orderingChannel | Channel to order the messages on, when using ordered or sequenced messages. Messages are only ordered relative to other messages on the same stream.
[in] | systemIdentifier | System Address or RakNetGUID to send this packet to, or in the case of broadcasting, the address not to send it to. Use UNASSIGNED_SYSTEM_ADDRESS to specify none.
[in] | broadcast | True to send this packet to all connected systems. If true, then systemAddress specifies who not to send the packet to.
[in] | forceReceipt | If 0, will automatically determine the receipt number to return. If non-zero, will return what you give it.
Returns
0 on bad input. Otherwise a number that identifies this message. If reliability is a type that returns a receipt, on a later call to Receive() you will get ID_SND_RECEIPT_ACKED or ID_SND_RECEIPT_LOSS with bytes 1-4 inclusive containing this number
Note
COMMON MISTAKE: When writing the first byte, bitStream->Write((unsigned char) ID_MY_TYPE) be sure it is casted to a byte, and you are not writing a 4 byte enumeration.

Implements RakNet::RakPeerInterface.

uint32_t RakNet::RakPeer::SendList | ( | const char ** | data,
 |  | const int * | lengths,
 |  | const int | numParameters,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | const AddressOrGUID | systemIdentifier,
 |  | bool | broadcast,
 |  | uint32_t | forceReceiptNumber = 0
 | ) |  |
virtual

Sends multiple blocks of data, concatenating them automatically.

This is equivalent to: RakNet::BitStream bs; bs.WriteAlignedBytes(block1, blockLength1); bs.WriteAlignedBytes(block2, blockLength2); bs.WriteAlignedBytes(block3, blockLength3); Send(&bs, ...)

This function only works when connected.

Parameters
[in] | data | An array of pointers to blocks of data
[in] | lengths | An array of integers indicating the length of each block of data
[in] | numParameters | Length of the arrays data and lengths
[in] | priority | Priority level to send on. See PacketPriority.h
[in] | reliability | How reliably to send this data. See PacketPriority.h
[in] | orderingChannel | Channel to order the messages on, when using ordered or sequenced messages. Messages are only ordered relative to other messages on the same stream.
[in] | systemIdentifier | System Address or RakNetGUID to send this packet to, or in the case of broadcasting, the address not to send it to. Use UNASSIGNED_SYSTEM_ADDRESS to specify none.
[in] | broadcast | True to send this packet to all connected systems. If true, then systemAddress specifies who not to send the packet to.
[in] | forceReceipt | If 0, will automatically determine the receipt number to return. If non-zero, will return what you give it.
Returns
0 on bad input. Otherwise a number that identifies this message. If reliability is a type that returns a receipt, on a later call to Receive() you will get ID_SND_RECEIPT_ACKED or ID_SND_RECEIPT_LOSS with bytes 1-4 inclusive containing this number

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::SendLoopback | ( | const char * | data,
 |  | const int | length
 | ) |  |
virtual

"Send" to yourself rather than a remote system.

The message will be processed through the plugins and returned to the game as usual. This function works anytime

Note
The first byte should be a message identifier starting at ID_USER_PACKET_ENUM
Parameters
[in] | data | Block of data to send.
[in] | length | Size in bytes of the data to send.

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::SendTTL | ( | const char * | host,
 |  | unsigned short | remotePort,
 |  | int | ttl,
 |  | unsigned | connectionSocketIndex = 0
 | ) |  |
virtual

Send a message to a host, with the IP socket option TTL set to 3.

This message will not reach the host, but will open the router.

Parameters
[in] | host | The address of the remote host in dotted notation.
[in] | remotePort | The port number to send to.
[in] | ttl | Max hops of datagram, set to 3
[in] | connectionSocketIndex | userConnectionSocketIndex.
Remarks
Used for NAT-Punchthrough

Implements RakNet::RakPeerInterface.

virtual void RakNet::RakPeer::SetIncomingDatagramEventHandler ( bool(*)(RNS2RecvStruct *) _incomingDatagramEventHandler )
virtual

Set a C callback to be called whenever a datagram arrives Return true from the callback to have RakPeer handle the datagram. Return false and RakPeer will ignore the datagram. This can be used to filter incoming datagrams by system, or to share a recvfrom socket with RakPeer RNS2RecvStruct will only remain valid for the duration of the call

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::SetIncomingPassword | ( | const char * | passwordData,
 |  | int | passwordDataLength
 | ) |  |
virtual

Sets the password for the incoming connections.

The password must match in the call to Connect (defaults to none). Pass 0 to passwordData to specify no password. This is a way to set a low level password for all incoming connections. To selectively reject connections, implement your own scheme using CloseConnection() to remove unwanted connections.

Parameters
[in] | passwordData | A data block that incoming connections must match. This can be just a password, or can be a stream of data. Specify 0 for no password data
[in] | passwordDataLength | The length in bytes of passwordData

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::SetInternalID | ( | SystemAddress | systemAddress,
 |  | int | index = 0
 | ) |  |
virtual

Sets your internal IP address, for platforms that do not support reading it, or to override a value.

Parameters
[in] | systemAddress. | The address to set. Use SystemAddress::FromString() if you want to use a dotted string
[in] | index | When you have multiple internal IDs, which index to set?

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::SetLimitIPConnectionFrequency ( bool b )
virtual

Enable or disable allowing frequent connections from the same IP adderss.

This is a security measure which is disabled by default, but can be set to true to prevent attackers from using up all connection slots.

Parameters
[in] b True to limit connections from the same ip to at most 1 per 100 milliseconds.

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::SetMaximumIncomingConnections ( unsigned short numberAllowed )
virtual

Sets the maximum number of incoming connections allowed.

If the number of incoming connections is less than the number of players currently connected, no more players will be allowed to connect. If this is greater than the maximum number of peers allowed, it will be reduced to the maximum number of peers allowed.

Defaults to 0, meaning by default, nobody can connect to you

Parameters
[in] numberAllowed Maximum number of incoming connections allowed.

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::SetOccasionalPing ( bool doPing )
virtual

Ping the remote systems every so often, or not. Can be called anytime. By default this is true. Recommended to leave on, because congestion control uses it to determine how often to resend lost packets. It would be true by default to prevent timestamp drift, since in the event of a clock spike, the timestamp deltas would no longer be accurate

Parameters
[in] doPing True to start occasional pings. False to stop them.

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::SetOfflinePingResponse | ( | const char * | data,
 |  | const unsigned int | length
 | ) |  |
virtual

Sets the data to send along with a LAN server discovery or offline ping reply.

Parameters
[in] | data | Block of data to send, or 0 for none
[in] | length | Length of the data in bytes, or 0 for none
Note
length should be under 400 bytes, as a security measure against flood attacks
See Also
Ping.cpp

Implements RakNet::RakPeerInterface.

virtual void RakNet::RakPeer::SetPerConnectionOutgoingBandwidthLimit ( unsigned maxBitsPerSecond )
virtual

Limits how much outgoing bandwidth can be sent per-connection. This limit does not apply to the sum of all connections! Exceeding the limit queues up outgoing traffic

Parameters
[in] maxBitsPerSecond Maximum bits per second to send. Use 0 for unlimited (default). Once set, it takes effect immedately and persists until called again.

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::SetSplitMessageProgressInterval ( int interval )
virtual

Controls how often to return ID_DOWNLOAD_PROGRESS for large message downloads.

ID_DOWNLOAD_PROGRESS is returned to indicate a new partial message chunk, roughly the MTU size, has arrived. As it can be slow or cumbersome to get this notification for every chunk, you can set the interval at which it is returned. Defaults to 0 (never return this notification).

Parameters
[in] interval How many messages to use as an interval before a download progress notification is returned.

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::SetTimeoutTime | ( | RakNet::TimeMS | timeMS,
 |  | const SystemAddress | target
 | ) |  |
virtual

Set the time, in MS, to use before considering ourselves disconnected after not being able to deliver a reliable message.

Set the time, in MS, to use before considering ourselves disconnected after not being able to deliver a reliable message. Default time is 10,000 or 10 seconds in release and 30,000 or 30 seconds in debug. Do not set different values for different computers that are connected to each other, or you won't be able to reconnect after ID_CONNECTION_LOST

Parameters
[in] | timeMS | Time, in MS
[in] | target | SystemAddress structure of the target system. Pass UNASSIGNED_SYSTEM_ADDRESS for all systems.

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::SetUnreliableTimeout ( RakNet::TimeMS timeoutMS )
virtual

Set how long to wait before giving up on sending an unreliable message. Useful if the network is clogged up. Set to 0 or less to never timeout. Defaults to 0.

Parameters
[in] timeoutMS How many ms to wait before simply not sending an unreliable message.

Implements RakNet::RakPeerInterface.

virtual void RakNet::RakPeer::SetUserUpdateThread | ( | void(*)(RakPeerInterface *, void *) | _userUpdateThreadPtr,
 |  | void * | _userUpdateThreadData
 | ) |  |
virtual

If you need code to run in the same thread as RakNet's update thread, this function can be used for that

Parameters
[in] | _userUpdateThreadPtr | C callback function
[in] | _userUpdateThreadData | Passed to C callback function

Implements RakNet::RakPeerInterface.

void RakNet::RakPeer::ShiftIncomingTimestamp | ( | unsigned char * | data,
 |  | const SystemAddress & | systemAddress
 | ) |  | const
 protected

Adjust the timestamp of the incoming packet to be relative to this system.

Parameters
[in] | data | Data in the incoming packet.
[in] | systemAddress | Sender of the incoming packet.
void RakNet::RakPeer::Shutdown | ( | unsigned int | blockDuration,
 |  | unsigned char | orderingChannel = 0,
 |  | PacketPriority | disconnectionNotificationPriority = LOW_PRIORITY
 | ) |  |
virtual

Stops the network threads and closes all connections.

Parameters
[in] | blockDuration | Wait time(milli seconds) for all remaining messages to go out, including ID_DISCONNECTION_NOTIFICATION. If 0, it doesn't wait at all.
[in] | orderingChannel | Channel on which ID_DISCONNECTION_NOTIFICATION will be sent, if blockDuration > 0.
[in] | disconnectionNotificationPriority | Priority of sending ID_DISCONNECTION_NOTIFICATION. If set to 0, the disconnection notification won't be sent.

Implements RakNet::RakPeerInterface.

StartupResult RakNet::RakPeer::Startup | ( | unsigned int | maxConnections,
 |  | SocketDescriptor * | socketDescriptors,
 |  | unsigned | socketDescriptorCount,
 |  | int | threadPriority = -99999
 | ) |  |
virtual

Starts the network threads and opens the listen port.

You must call this before calling Connect().

Precondition
On the PS3, call Startup() after Client_Login()
Note
Multiple calls while already active are ignored. To call this function again with different settings, you must first call Shutdown().
Call SetMaximumIncomingConnections if you want to accept incoming connections.
Parameters
[in] | maxConnections | Maximum number of connections between this instance of RakPeer and another instance of RakPeer. Required so that the network can preallocate and for thread safety. A pure client would set this to 1. A pure server would set it to the number of allowed clients.A hybrid would set it to the sum of both types of connections.
[in] | localPort | The port to listen for connections on. On linux the system may be set up so thast ports under 1024 are restricted for everything but the root user. Use a higher port for maximum compatibility.
[in] | socketDescriptors | An array of SocketDescriptor structures to force RakNet to listen on a particular IP address or port (or both). Each SocketDescriptor will represent one unique socket. Do not pass redundant structures. To listen on a specific port, you can pass SocketDescriptor(myPort,0); such as for a server. For a client, it is usually OK to just pass SocketDescriptor(); However, on the XBOX be sure to use IPPROTO_VDP
[in] | socketDescriptorCount | The size of the socketDescriptors array. Pass 1 if you are not sure what to pass.
[in] | threadPriority | Passed to the thread creation routine. Use THREAD_PRIORITY_NORMAL for Windows. For Linux based systems, you MUST pass something reasonable based on the thread priorities for your application.
Returns
RAKNET_STARTED on success, otherwise appropriate failure enumeration.

Implements RakNet::RakPeerInterface.

Member Data Documentation

RemoteSystemStruct** RakNet::RakPeer::activeSystemList
protected

activeSystemList holds a list of pointers and is preallocated to be the same size as remoteSystemList. It is updated only by the network thread, but read by both threads When the isActive member of RemoteSystemStruct is set to true or false, that system is added to this list of pointers Threadsafe because RemoteSystemStruct is preallocated, and the list is only added to, not removed from

bool RakNet::RakPeer::allowConnectionResponseIPMigration
protected

How long it has been since things were updated by a call to receiveUpdate thread uses this to determine how long to sleep for.

True to allow connection accepted packets from anyone. False to only allow these packets from servers we requested a connection to.

unsigned int RakNet::RakPeer::bytesSentPerSecond
protected

The list of people we have tried to connect to recently.

Data that both the client and the server needs

unsigned int RakNet::RakPeer::maximumIncomingConnections
protected

Store the maximum number of peers able to connect, including reserved connection slots for pings, etc.

Store the maximum incoming connection allowed

* unsigned int RakNet::RakPeer::maximumNumberOfPeers
protected

Store the maximum number of peers allowed to connect.

Do we occasionally ping the other systems?

RemoteSystemStruct* RakNet::RakPeer::remoteSystemList
protected

This is an array of pointers to RemoteSystemStruct This allows us to preallocate the list when starting, so we don't have to allocate or delete at runtime. Another benefit is that is lets us add and remove active players simply by setting systemAddress and moving elements in the list by copying pointers variables without affecting running threads, even if they are in the reliability layer

SimpleMutex RakNet::RakPeer::sendReceiptSerialMutex
protected

This is used to return a number to the user when they call Send identifying the message This number will be returned back with ID_SND_RECEIPT_ACKED or ID_SND_RECEIPT_LOSS and is only returned with the reliability types that contain RECEIPT in the name

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/RakPeer.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::RakPeerInterface Class Reference

  • RakPeerInterface
Public Member Functions | Static Public Member Functions | List of all members
RakNet::RakPeerInterface Class Referenceabstract

The main interface for network communications. More...

#include <RakPeerInterface.h>

Inheritance diagram for RakNet::RakPeerInterface:
RakNet::RakPeer

Public Member Functions

virtual | ~RakPeerInterface ()
Destructor.
virtual StartupResult | Startup (unsigned int maxConnections, SocketDescriptor *socketDescriptors, unsigned socketDescriptorCount, int threadPriority=-99999)=0
Starts the network threads, opens the listen port.
virtual bool | InitializeSecurity (const char *publicKey, const char *privateKey, bool bRequireClientKey=false)=0
virtual void | DisableSecurity (void)=0
virtual void | AddToSecurityExceptionList (const char *ip)=0
virtual void | RemoveFromSecurityExceptionList (const char *ip)=0
virtual bool | IsInSecurityExceptionList (const char *ip)=0
virtual void | SetMaximumIncomingConnections (unsigned short numberAllowed)=0
virtual unsigned int | GetMaximumIncomingConnections (void) const =0
virtual unsigned short | NumberOfConnections (void) const =0
virtual void | SetIncomingPassword (const char *passwordData, int passwordDataLength)=0
virtual void | GetIncomingPassword (char *passwordData, int *passwordDataLength)=0
virtual ConnectionAttemptResult | Connect (const char *host, unsigned short remotePort, const char *passwordData, int passwordDataLength, PublicKey *publicKey=0, unsigned connectionSocketIndex=0, unsigned sendConnectionAttemptCount=12, unsigned timeBetweenSendConnectionAttemptsMS=500, RakNet::TimeMS timeoutTime=0)=0
Connect to the specified host (ip or domain name) and server port. Calling Connect and not calling SetMaximumIncomingConnections acts as a dedicated client. Calling both acts as a true peer. This is a non-blocking connection. You know the connection is successful when GetConnectionState() returns IS_CONNECTED or Receive() gets a message with the type identifier ID_CONNECTION_REQUEST_ACCEPTED. If the connection is not successful, such as a rejected connection or no response then neither of these things will happen.
virtual ConnectionAttemptResult | ConnectWithSocket (const char *host, unsigned short remotePort, const char *passwordData, int passwordDataLength, RakNetSocket2 *socket, PublicKey *publicKey=0, unsigned sendConnectionAttemptCount=12, unsigned timeBetweenSendConnectionAttemptsMS=500, RakNet::TimeMS timeoutTime=0)=0
Connect to the specified host (ip or domain name) and server port, using a shared socket from another instance of RakNet.
virtual void | Shutdown (unsigned int blockDuration, unsigned char orderingChannel=0, PacketPriority disconnectionNotificationPriority=LOW_PRIORITY)=0
Connect to the specified network ID (Platform specific console function)
virtual bool | IsActive (void) const =0
virtual bool | GetConnectionList (SystemAddress *remoteSystems, unsigned short *numberOfSystems) const =0
virtual uint32_t | GetNextSendReceipt (void)=0
virtual uint32_t | IncrementNextSendReceipt (void)=0
virtual uint32_t | Send (const char *data, const int length, PacketPriority priority, PacketReliability reliability, char orderingChannel, const AddressOrGUID systemIdentifier, bool broadcast, uint32_t forceReceiptNumber=0)=0
virtual void | SendLoopback (const char *data, const int length)=0
virtual uint32_t | Send (const RakNet::BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel, const AddressOrGUID systemIdentifier, bool broadcast, uint32_t forceReceiptNumber=0)=0
virtual uint32_t | SendList (const char **data, const int *lengths, const int numParameters, PacketPriority priority, PacketReliability reliability, char orderingChannel, const AddressOrGUID systemIdentifier, bool broadcast, uint32_t forceReceiptNumber=0)=0
virtual Packet * | Receive (void)=0
virtual void | DeallocatePacket (Packet *packet)=0
virtual unsigned int | GetMaximumNumberOfPeers (void) const =0
Return the total number of connections we are allowed.
virtual void | CloseConnection (const AddressOrGUID target, bool sendDisconnectionNotification, unsigned char orderingChannel=0, PacketPriority disconnectionNotificationPriority=LOW_PRIORITY)=0
virtual ConnectionState | GetConnectionState (const AddressOrGUID systemIdentifier)=0
virtual void | CancelConnectionAttempt (const SystemAddress target)=0
virtual int | GetIndexFromSystemAddress (const SystemAddress systemAddress) const =0
virtual SystemAddress | GetSystemAddressFromIndex (unsigned int index)=0
virtual RakNetGUID | GetGUIDFromIndex (unsigned int index)=0
virtual void | GetSystemList (DataStructures::List< SystemAddress > &addresses, DataStructures::List< RakNetGUID > &guids) const =0
virtual void | AddToBanList (const char *IP, RakNet::TimeMS milliseconds=0)=0
virtual void | RemoveFromBanList (const char *IP)=0
virtual void | ClearBanList (void)=0
Allows all previously banned IPs to connect.
virtual bool | IsBanned (const char *IP)=0
virtual void | SetLimitIPConnectionFrequency (bool b)=0
virtual void | Ping (const SystemAddress target)=0
virtual bool | Ping (const char *host, unsigned short remotePort, bool onlyReplyOnAcceptingConnections, unsigned connectionSocketIndex=0)=0
virtual int | GetAveragePing (const AddressOrGUID systemIdentifier)=0
virtual int | GetLastPing (const AddressOrGUID systemIdentifier) const =0
virtual int | GetLowestPing (const AddressOrGUID systemIdentifier) const =0
virtual void | SetOccasionalPing (bool doPing)=0
virtual RakNet::Time | GetClockDifferential (const AddressOrGUID systemIdentifier)=0
virtual void | SetOfflinePingResponse (const char *data, const unsigned int length)=0
virtual void | GetOfflinePingResponse (char **data, unsigned int *length)=0
virtual SystemAddress | GetInternalID (const SystemAddress systemAddress=UNASSIGNED_SYSTEM_ADDRESS, const int index=0) const =0
virtual void | SetInternalID (SystemAddress systemAddress, int index=0)=0
Sets your internal IP address, for platforms that do not support reading it, or to override a value.
virtual SystemAddress | GetExternalID (const SystemAddress target) const =0
virtual const RakNetGUID | GetMyGUID (void) const =0
Return my own GUID.
virtual SystemAddress | GetMyBoundAddress (const int socketIndex=0)=0
Return the address bound to a socket at the specified index.
virtual const RakNetGUID & | GetGuidFromSystemAddress (const SystemAddress input) const =0
virtual SystemAddress | GetSystemAddressFromGuid (const RakNetGUID input) const =0
virtual bool | GetClientPublicKeyFromSystemAddress (const SystemAddress input, char *client_public_key) const =0
virtual void | SetTimeoutTime (RakNet::TimeMS timeMS, const SystemAddress target)=0
virtual RakNet::TimeMS | GetTimeoutTime (const SystemAddress target)=0
virtual int | GetMTUSize (const SystemAddress target) const =0
virtual unsigned | GetNumberOfAddresses (void)=0
Returns the number of IP addresses this system has internally. Get the actual addresses from GetLocalIP()
virtual const char * | GetLocalIP (unsigned int index)=0
virtual bool | IsLocalIP (const char *ip)=0
virtual void | AllowConnectionResponseIPMigration (bool allow)=0
virtual bool | AdvertiseSystem (const char *host, unsigned short remotePort, const char *data, int dataLength, unsigned connectionSocketIndex=0)=0
virtual void | SetSplitMessageProgressInterval (int interval)=0
virtual int | GetSplitMessageProgressInterval (void) const =0
virtual void | SetUnreliableTimeout (RakNet::TimeMS timeoutMS)=0
virtual void | SendTTL (const char *host, unsigned short remotePort, int ttl, unsigned connectionSocketIndex=0)=0
virtual void | AttachPlugin (PluginInterface2 *plugin)=0
Attaches a Plugin interface to an instance of the base class (RakPeer or PacketizedTCP) to run code automatically on message receipt in the Receive call. If the plugin returns false from PluginInterface::UsesReliabilityLayer(), which is the case for all plugins except PacketLogger, you can call AttachPlugin() and DetachPlugin() for this plugin while RakPeer is active.
virtual void | DetachPlugin (PluginInterface2 *messageHandler)=0
Detaches a Plugin interface from the instance of the base class (RakPeer or PacketizedTCP) it is attached to.
virtual void | PushBackPacket (Packet *packet, bool pushAtHead)=0
virtual Packet * | AllocatePacket (unsigned dataSize)=0
virtual RakNetSocket2 * | GetSocket (const SystemAddress target)=0
virtual void | GetSockets (DataStructures::List< RakNetSocket2 * > &sockets)=0
virtual void | SetUserUpdateThread (void(*_userUpdateThreadPtr)(RakPeerInterface *, void *), void *_userUpdateThreadData)=0
virtual void | SetIncomingDatagramEventHandler (bool(*_incomingDatagramEventHandler)(RNS2RecvStruct *))=0
virtual void | ApplyNetworkSimulator (float packetloss, unsigned short minExtraPing, unsigned short extraPingVariance)=0
virtual void | SetPerConnectionOutgoingBandwidthLimit (unsigned maxBitsPerSecond)=0
virtual bool | IsNetworkSimulatorActive (void)=0
virtual RakNetStatistics * | GetStatistics (const SystemAddress systemAddress, RakNetStatistics *rns=0)=0
virtual bool | GetStatistics (const unsigned int index, RakNetStatistics *rns)=0
Returns the network statistics of the system at the given index in the remoteSystemList.
virtual void | GetStatisticsList (DataStructures::List< SystemAddress > &addresses, DataStructures::List< RakNetGUID > &guids, DataStructures::List< RakNetStatistics > &statistics)=0
Returns the list of systems, and statistics for each of those systems Each system has one entry in each of the lists, in the same order.
virtual unsigned int | GetReceiveBufferSize (void)=0
how many messages are waiting when you call Receive()

Static Public Member Functions

static uint64_t Get64BitUniqueRandomNumber (void)
Get a random number (to generate a GUID)

Detailed Description

The main interface for network communications.

The primary interface for RakNet, RakPeer contains all major functions for the library. See the individual functions for what the class can do.

Member Function Documentation

virtual void RakNet::RakPeerInterface::AddToBanList | ( | const char * | IP,
 |  | RakNet::TimeMS | milliseconds = 0
 | ) |  |
pure virtual

Bans an IP from connecting. Banned IPs persist between connections but are not saved on shutdown nor loaded on startup. param[in] IP Dotted IP address. Can use * as a wildcard, such as 128.0.0.* will ban all IP addresses starting with 128.0.0

Parameters
[in] milliseconds how many ms for a temporary ban. Use 0 for a permanent ban

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::AddToSecurityExceptionList ( const char * ip )
pure virtual

If secure connections are on, do not use secure connections for a specific IP address. This is useful if you have a fixed-address internal server behind a LAN.

Note
Secure connections are determined by the recipient of an incoming connection. This has no effect if called on the system attempting to connect.
Parameters
[in] ip IP address to add. * wildcards are supported.

Implemented in RakNet::RakPeer.

virtual bool RakNet::RakPeerInterface::AdvertiseSystem | ( | const char * | host,
 |  | unsigned short | remotePort,
 |  | const char * | data,
 |  | int | dataLength,
 |  | unsigned | connectionSocketIndex = 0
 | ) |  |
pure virtual

Sends a one byte message ID_ADVERTISE_SYSTEM to the remote unconnected system. This will tell the remote system our external IP outside the LAN along with some user data.

Precondition
The sender and recipient must already be started via a successful call to Initialize
Parameters
[in] | host | Either a dotted IP address or a domain name
[in] | remotePort | Which port to connect to on the remote machine.
[in] | data | Optional data to append to the packet.
[in] | dataLength | length of data in bytes. Use 0 if no data.
[in] | connectionSocketIndex | Index into the array of socket descriptors passed to socketDescriptors in RakPeer::Startup() to send on.
Returns
false if IsActive()==false or the host is unresolvable. True otherwise

Implemented in RakNet::RakPeer.

virtual Packet* RakNet::RakPeerInterface::AllocatePacket ( unsigned dataSize )
pure virtual
Returns
a packet for you to write to if you want to create a Packet for some reason. You can add it to the receive buffer with PushBackPacket
Parameters
[in] dataSize How many bytes to allocate for the buffer
Returns
A packet you can write to

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::AllowConnectionResponseIPMigration ( bool allow )
pure virtual

Allow or disallow connection responses from any IP. Normally this should be false, but may be necessary when connecting to servers with multiple IP addresses.

Parameters
[in] allow - True to allow this behavior, false to not allow. Defaults to false. Value persists between connections

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::ApplyNetworkSimulator | ( | float | packetloss,
 |  | unsigned short | minExtraPing,
 |  | unsigned short | extraPingVariance
 | ) |  |
pure virtual

Adds simulated ping and packet loss to the outgoing data flow. To simulate bi-directional ping and packet loss, you should call this on both the sender and the recipient, with half the total ping and packetloss value on each. You can exclude network simulator code with the _RELEASE #define to decrease code size

Deprecated:
Use http://www.jenkinssoftware.com/forum/index.php?topic=1671.0 instead.
Note
Doesn't work past version 3.6201
Parameters
[in] | packetloss | Chance to lose a packet. Ranges from 0 to 1.
[in] | minExtraPing | The minimum time to delay sends.
[in] | extraPingVariance | The additional random time to delay sends.

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::AttachPlugin ( PluginInterface2 * plugin )
pure virtual

Attaches a Plugin interface to an instance of the base class (RakPeer or PacketizedTCP) to run code automatically on message receipt in the Receive call. If the plugin returns false from PluginInterface::UsesReliabilityLayer(), which is the case for all plugins except PacketLogger, you can call AttachPlugin() and DetachPlugin() for this plugin while RakPeer is active.

Parameters
[in] messageHandler Pointer to the plugin to attach.

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::CancelConnectionAttempt ( const SystemAddress target )
pure virtual

Cancel a pending connection attempt If we are already connected, the connection stays open

Parameters
[in] target Which system to cancel

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::CloseConnection | ( | const AddressOrGUID | target,
 |  | bool | sendDisconnectionNotification,
 |  | unsigned char | orderingChannel = 0,
 |  | PacketPriority | disconnectionNotificationPriority = LOW_PRIORITY
 | ) |  |
pure virtual

Close the connection to another host (if we initiated the connection it will disconnect, if they did it will kick them out).

Parameters
[in] | target | Which system to close the connection to.
[in] | sendDisconnectionNotification | True to send ID_DISCONNECTION_NOTIFICATION to the recipient. False to close it silently.
[in] | channel | Which ordering channel to send the disconnection notification on, if any
[in] | disconnectionNotificationPriority | Priority to send ID_DISCONNECTION_NOTIFICATION on.

Implemented in RakNet::RakPeer.

virtual ConnectionAttemptResult RakNet::RakPeerInterface::Connect | ( | const char * | host,
 |  | unsigned short | remotePort,
 |  | const char * | passwordData,
 |  | int | passwordDataLength,
 |  | PublicKey * | publicKey = 0,
 |  | unsigned | connectionSocketIndex = 0,
 |  | unsigned | sendConnectionAttemptCount = 12,
 |  | unsigned | timeBetweenSendConnectionAttemptsMS = 500,
 |  | RakNet::TimeMS | timeoutTime = 0
 | ) |  |
pure virtual

Connect to the specified host (ip or domain name) and server port. Calling Connect and not calling SetMaximumIncomingConnections acts as a dedicated client. Calling both acts as a true peer. This is a non-blocking connection. You know the connection is successful when GetConnectionState() returns IS_CONNECTED or Receive() gets a message with the type identifier ID_CONNECTION_REQUEST_ACCEPTED. If the connection is not successful, such as a rejected connection or no response then neither of these things will happen.

Precondition
Requires that you first call Startup()
Parameters
[in] | host | Either a dotted IP address or a domain name
[in] | remotePort | Which port to connect to on the remote machine.
[in] | passwordData | A data block that must match the data block on the server passed to SetIncomingPassword. This can be a string or can be a stream of data. Use 0 for no password.
[in] | passwordDataLength | The length in bytes of passwordData
[in] | publicKey | The public key the server is using. If 0, the server is not using security. If non-zero, the publicKeyMode member determines how to connect
[in] | connectionSocketIndex | Index into the array of socket descriptors passed to socketDescriptors in RakPeer::Startup() to send on.
[in] | sendConnectionAttemptCount | How many datagrams to send to the other system to try to connect.
[in] | timeBetweenSendConnectionAttemptsMS | Time to elapse before a datagram is sent to the other system to try to connect. After sendConnectionAttemptCount number of attempts, ID_CONNECTION_ATTEMPT_FAILED is returned. Under low bandwidth conditions with multiple simultaneous outgoing connections, this value should be raised to 1000 or higher, or else the MTU detection can overrun the available bandwidth.
[in] | timeoutTime | How long to keep the connection alive before dropping it on unable to send a reliable message. 0 to use the default from SetTimeoutTime(UNASSIGNED_SYSTEM_ADDRESS);
Returns
CONNECTION_ATTEMPT_STARTED on successful initiation. Otherwise, an appropriate enumeration indicating failure.
Note
CONNECTION_ATTEMPT_STARTED does not mean you are already connected!
It is possible to immediately get back ID_CONNECTION_ATTEMPT_FAILED if you exceed the maxConnections parameter passed to Startup(). This could happen if you call CloseConnection() with sendDisconnectionNotificaiton true, then immediately call Connect() before the connection has closed.

Implemented in RakNet::RakPeer.

virtual ConnectionAttemptResult RakNet::RakPeerInterface::ConnectWithSocket | ( | const char * | host,
 |  | unsigned short | remotePort,
 |  | const char * | passwordData,
 |  | int | passwordDataLength,
 |  | RakNetSocket2 * | socket,
 |  | PublicKey * | publicKey = 0,
 |  | unsigned | sendConnectionAttemptCount = 12,
 |  | unsigned | timeBetweenSendConnectionAttemptsMS = 500,
 |  | RakNet::TimeMS | timeoutTime = 0
 | ) |  |
pure virtual

Connect to the specified host (ip or domain name) and server port, using a shared socket from another instance of RakNet.

Parameters
[in] | host | Either a dotted IP address or a domain name
[in] | remotePort | Which port to connect to on the remote machine.
[in] | passwordData | A data block that must match the data block on the server passed to SetIncomingPassword. This can be a string or can be a stream of data. Use 0 for no password.
[in] | passwordDataLength | The length in bytes of passwordData
[in] | socket | A bound socket returned by another instance of RakPeerInterface
[in] | sendConnectionAttemptCount | How many datagrams to send to the other system to try to connect.
[in] | timeBetweenSendConnectionAttemptsMS | Time to elapse before a datagram is sent to the other system to try to connect. After sendConnectionAttemptCount number of attempts, ID_CONNECTION_ATTEMPT_FAILED is returned. Under low bandwidth conditions with multiple simultaneous outgoing connections, this value should be raised to 1000 or higher, or else the MTU detection can overrun the available bandwidth.
[in] | timeoutTime | How long to keep the connection alive before dropping it on unable to send a reliable message. 0 to use the default from SetTimeoutTime(UNASSIGNED_SYSTEM_ADDRESS);
Returns
CONNECTION_ATTEMPT_STARTED on successful initiation. Otherwise, an appropriate enumeration indicating failure.
Note
CONNECTION_ATTEMPT_STARTED does not mean you are already connected!

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::DeallocatePacket ( Packet * packet )
pure virtual

Call this to deallocate a message returned by Receive() when you are done handling it.

Parameters
[in] packet The message to deallocate.

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::DetachPlugin ( PluginInterface2 * messageHandler )
pure virtual

Detaches a Plugin interface from the instance of the base class (RakPeer or PacketizedTCP) it is attached to.

This method disables the plugin code from running automatically on base class's updates or message receipt. If the plugin returns false from PluginInterface::UsesReliabilityLayer(), which is the case for all plugins except PacketLogger, you can call AttachPlugin() and DetachPlugin() for this plugin while RakPeer is active.

Parameters
[in] messageHandler Pointer to a plugin to detach.

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::DisableSecurity ( void )
pure virtual

Disables security for incoming connections.

Note
Must be called while offline

Implemented in RakNet::RakPeer.

virtual int RakNet::RakPeerInterface::GetAveragePing ( const AddressOrGUID systemIdentifier )
pure virtual

Returns the average of all ping times read for the specific system or -1 if none read yet

Parameters
[in] systemAddress Which system we are referring to
Returns
The ping time for this system, or -1

Implemented in RakNet::RakPeer.

virtual bool RakNet::RakPeerInterface::GetClientPublicKeyFromSystemAddress | ( | const SystemAddress | input,
 |  | char * | client_public_key
 | ) |  | const
 pure virtual

Given the SystemAddress of a connected system, get the public key they provided as an identity Returns false if system address was not found or client public key is not known

Parameters
[in] | input | The RakNetGUID of the system
[in] | client_public_key | The connected client's public key is copied to this address. Buffer must be cat::EasyHandshake::PUBLIC_KEY_BYTES bytes in length.

Implemented in RakNet::RakPeer.

virtual RakNet::Time RakNet::RakPeerInterface::GetClockDifferential ( const AddressOrGUID systemIdentifier )
pure virtual

Return the clock difference between your system and the specified system Subtract GetClockDifferential() from a time returned by the remote system to get that time relative to your own system Returns 0 if the system is unknown

Parameters
[in] systemIdentifier Which system we are referring to

Implemented in RakNet::RakPeer.

virtual bool RakNet::RakPeerInterface::GetConnectionList | ( | SystemAddress * | remoteSystems,
 |  | unsigned short * | numberOfSystems
 | ) |  | const
 pure virtual

Fills the array remoteSystems with the SystemAddress of all the systems we are connected to

Parameters
[out] | remoteSystems | An array of SystemAddress structures to be filled with the SystemAddresss of the systems we are connected to. Pass 0 to remoteSystems to only get the number of systems we are connected to
[in,out] | numberOfSystems | As input, the size of remoteSystems array. As output, the number of elements put into the array

Implemented in RakNet::RakPeer.

virtual ConnectionState RakNet::RakPeerInterface::GetConnectionState ( const AddressOrGUID systemIdentifier )
pure virtual

Returns if a system is connected, disconnected, connecting in progress, or various other states

Parameters
[in] systemIdentifier The system we are referring to
Note
This locks a mutex, do not call too frequently during connection attempts or the attempt will take longer and possibly even timeout
Returns
What state the remote system is in

Implemented in RakNet::RakPeer.

virtual SystemAddress RakNet::RakPeerInterface::GetExternalID ( const SystemAddress target ) const
pure virtual

Return the unique address identifier that represents you on the the network and is based on your externalIP / port (the IP / port the specified player uses to communicate with you)

Parameters
[in] target Which remote system you are referring to for your external ID. Usually the same for all systems, unless you have two or more network cards.

Implemented in RakNet::RakPeer.

virtual RakNetGUID RakNet::RakPeerInterface::GetGUIDFromIndex ( unsigned int index )
pure virtual

Same as GetSystemAddressFromIndex but returns RakNetGUID

Parameters
[in] index Index should range between 0 and the maximum number of players allowed - 1.
Returns
The RakNetGUID

Implemented in RakNet::RakPeer.

virtual const RakNetGUID& RakNet::RakPeerInterface::GetGuidFromSystemAddress ( const SystemAddress input ) const
pure virtual

Given a connected system, give us the unique GUID representing that instance of RakPeer. This will be the same on all systems connected to that instance of RakPeer, even if the external system addresses are different Currently O(log(n)), but this may be improved in the future. If you use this frequently, you may want to cache the value as it won't change. Returns UNASSIGNED_RAKNET_GUID if system address can't be found. If input is UNASSIGNED_SYSTEM_ADDRESS, will return your own GUID

Precondition
Call Startup() first, or the function will return UNASSIGNED_RAKNET_GUID
Parameters
[in] input The system address of the system we are connected to

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::GetIncomingPassword | ( | char * | passwordData,
 |  | int * | passwordDataLength
 | ) |  |
pure virtual

Gets the password passed to SetIncomingPassword

Parameters
[out] | passwordData | Should point to a block large enough to hold the password data you passed to SetIncomingPassword()
[in,out] | passwordDataLength | Maximum size of the array passwordData. Modified to hold the number of bytes actually written

Implemented in RakNet::RakPeer.

virtual int RakNet::RakPeerInterface::GetIndexFromSystemAddress ( const SystemAddress systemAddress ) const
pure virtual

Given a systemAddress, returns an index from 0 to the maximum number of players allowed - 1.

Parameters
[in] systemAddress The SystemAddress we are referring to
Returns
The index of this SystemAddress or -1 on system not found.

Implemented in RakNet::RakPeer.

virtual SystemAddress RakNet::RakPeerInterface::GetInternalID | ( | const SystemAddress | systemAddress = UNASSIGNED_SYSTEM_ADDRESS,
 |  | const int | index = 0
 | ) |  | const
 pure virtual

Return the unique address identifier that represents you or another system on the the network and is based on your local IP / port.

Note
Not supported by the XBOX
Parameters
[in] | systemAddress | Use UNASSIGNED_SYSTEM_ADDRESS to get your behind-LAN address. Use a connected system to get their behind-LAN address
[in] | index | When you have multiple internal IDs, which index to return? Currently limited to MAXIMUM_NUMBER_OF_INTERNAL_IDS (so the maximum value of this variable is MAXIMUM_NUMBER_OF_INTERNAL_IDS-1)
Returns
the identifier of your system internally, which may not be how other systems see if you if you are behind a NAT or proxy

Implemented in RakNet::RakPeer.

virtual int RakNet::RakPeerInterface::GetLastPing ( const AddressOrGUID systemIdentifier ) const
pure virtual

Returns the last ping time read for the specific system or -1 if none read yet

Parameters
[in] systemAddress Which system we are referring to
Returns
The last ping time for this system, or -1

Implemented in RakNet::RakPeer.

virtual const char* RakNet::RakPeerInterface::GetLocalIP ( unsigned int index )
pure virtual

Returns an IP address at index 0 to GetNumberOfAddresses-1

Parameters
[in] index index into the list of IP addresses
Returns
The local IP address at this index

Implemented in RakNet::RakPeer.

virtual int RakNet::RakPeerInterface::GetLowestPing ( const AddressOrGUID systemIdentifier ) const
pure virtual

Returns the lowest ping time read or -1 if none read yet

Parameters
[in] systemAddress Which system we are referring to
Returns
The lowest ping time for this system, or -1

Implemented in RakNet::RakPeer.

virtual unsigned int RakNet::RakPeerInterface::GetMaximumIncomingConnections ( void ) const
pure virtual

Returns the value passed to SetMaximumIncomingConnections()

Returns
the maximum number of incoming connections, which is always <= maxConnections

Implemented in RakNet::RakPeer.

virtual int RakNet::RakPeerInterface::GetMTUSize ( const SystemAddress target ) const
pure virtual

Returns the current MTU size

Parameters
[in] target Which system to get this for. UNASSIGNED_SYSTEM_ADDRESS to get the default
Returns
The current MTU size

Implemented in RakNet::RakPeer.

virtual uint32_t RakNet::RakPeerInterface::GetNextSendReceipt ( void )
pure virtual

Returns the next uint32_t that Send() will return

Note
If using RakPeer from multiple threads, this may not be accurate for your thread. Use IncrementNextSendReceipt() in that case.
Returns
The next uint32_t that Send() or SendList will return

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::GetOfflinePingResponse | ( | char ** | data,
 |  | unsigned int * | length
 | ) |  |
pure virtual

Returns pointers to a copy of the data passed to SetOfflinePingResponse

Parameters
[out] | data | A pointer to a copy of the data passed to SetOfflinePingResponse()
[out] | length | A pointer filled in with the length parameter passed to SetOfflinePingResponse()
See Also
SetOfflinePingResponse

Implemented in RakNet::RakPeer.

virtual RakNetSocket2* RakNet::RakPeerInterface::GetSocket ( const SystemAddress target )
pure virtual

Get the socket used with a particular active connection The smart pointer reference counts the RakNetSocket2 object, so the socket will remain active as long as the smart pointer does, even if RakNet were to shutdown or close the connection.

Note
This sends a query to the thread and blocks on the return value for up to one second. In practice it should only take a millisecond or so.
Parameters
[in] target Which system
Returns
A smart pointer object containing the socket information about the socket. Be sure to check IsNull() which is returned if the update thread is unresponsive, shutting down, or if this system is not connected

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::GetSockets ( DataStructures::List< RakNetSocket2 * > & sockets )
pure virtual

Get all sockets in use

Note
This sends a query to the thread and blocks on the return value for up to one second. In practice it should only take a millisecond or so.
Parameters
[out] sockets List of RakNetSocket2 structures in use. Sockets will not be closed until sockets goes out of scope

Implemented in RakNet::RakPeer.

virtual int RakNet::RakPeerInterface::GetSplitMessageProgressInterval ( void ) const
pure virtual

Returns what was passed to SetSplitMessageProgressInterval()

Returns
What was passed to SetSplitMessageProgressInterval(). Default to 0.

Implemented in RakNet::RakPeer.

virtual RakNetStatistics* RakNet::RakPeerInterface::GetStatistics | ( | const SystemAddress | systemAddress,
 |  | RakNetStatistics * | rns = 0
 | ) |  |
pure virtual

Returns a structure containing a large set of network statistics for the specified system. You can map this data to a string using the C style StatisticsToString() function

Parameters
[in] systemAddress,: Which connected system to get statistics for
[in] rns If you supply this structure, it will be written to it. Otherwise it will use a static struct, which is not threadsafe
Returns
0 on can't find the specified system. A pointer to a set of data otherwise.
See Also
RakNetStatistics.h

Implemented in RakNet::RakPeer.

virtual bool RakNet::RakPeerInterface::GetStatistics | ( | const unsigned int | index,
 |  | RakNetStatistics * | rns
 | ) |  |
pure virtual

Returns the network statistics of the system at the given index in the remoteSystemList.

Returns
True if the index is less than the maximum number of peers allowed and the system is active. False otherwise.

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::GetStatisticsList | ( | DataStructures::List< SystemAddress > & | addresses,
 |  | DataStructures::List< RakNetGUID > & | guids,
 |  | DataStructures::List< RakNetStatistics > & | statistics
 | ) |  |
pure virtual

Returns the list of systems, and statistics for each of those systems Each system has one entry in each of the lists, in the same order.

Parameters
[out] | addresses | SystemAddress for each connected system
[out] | guids | RakNetGUID for each connected system
[out] | statistics | Calculated RakNetStatistics for each connected system

Implemented in RakNet::RakPeer.

virtual SystemAddress RakNet::RakPeerInterface::GetSystemAddressFromGuid ( const RakNetGUID input ) const
pure virtual

Given the GUID of a connected system, give us the system address of that system. The GUID will be the same on all systems connected to that instance of RakPeer, even if the external system addresses are different Currently O(log(n)), but this may be improved in the future. If you use this frequently, you may want to cache the value as it won't change. If input is UNASSIGNED_RAKNET_GUID, will return UNASSIGNED_SYSTEM_ADDRESS

Parameters
[in] input The RakNetGUID of the system we are checking to see if we are connected to

Implemented in RakNet::RakPeer.

virtual SystemAddress RakNet::RakPeerInterface::GetSystemAddressFromIndex ( unsigned int index )
pure virtual

This function is only useful for looping through all systems Given an index, will return a SystemAddress.

Parameters
[in] index Index should range between 0 and the maximum number of players allowed - 1.
Returns
The SystemAddress

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::GetSystemList | ( | DataStructures::List< SystemAddress > & | addresses,
 |  | DataStructures::List< RakNetGUID > & | guids
 | ) |  | const
 pure virtual

Same as calling GetSystemAddressFromIndex and GetGUIDFromIndex for all systems, but more efficient Indices match each other, so addresses[0] and guids[0] refer to the same system

Parameters
[out] | addresses | All system addresses. Size of the list is the number of connections. Size of the list will match the size of the guids list.
[out] | guids | All guids. Size of the list is the number of connections. Size of the list will match the size of the addresses list.

Implemented in RakNet::RakPeer.

virtual RakNet::TimeMS RakNet::RakPeerInterface::GetTimeoutTime ( const SystemAddress target )
pure virtual
Parameters
[in] target Which system to do this for. Pass UNASSIGNED_SYSTEM_ADDRESS to get the default value
Returns
timeoutTime for a given system.

Implemented in RakNet::RakPeer.

virtual uint32_t RakNet::RakPeerInterface::IncrementNextSendReceipt ( void )
pure virtual

Returns the next uint32_t that Send() will return, and increments the value by one

Note
If using RakPeer from multiple threads, pass this to forceReceipt in the send function
Returns
The next uint32_t that Send() or SendList will return

Implemented in RakNet::RakPeer.

virtual bool RakNet::RakPeerInterface::InitializeSecurity | ( | const char * | publicKey,
 |  | const char * | privateKey,
 |  | bool | bRequireClientKey = false
 | ) |  |
pure virtual

If you accept connections, you must call this or else security will not be enabled for incoming connections. This feature requires more round trips, bandwidth, and CPU time for the connection handshake x64 builds require under 25% of the CPU time of other builds See the Encryption sample for example usage

Precondition
Must be called while offline
LIBCAT_SECURITY must be defined to 1 in NativeFeatureIncludes.h for this function to have any effect
Parameters
[in] | publicKey | A pointer to the public key for accepting new connections
[in] | privateKey | A pointer to the private key for accepting new connections
[in] bRequireClientKey,: Should be set to false for most servers. Allows the server to accept a public key from connecting clients as a proof of identity but eats twice as much CPU time as a normal connection

Implemented in RakNet::RakPeer.

virtual bool RakNet::RakPeerInterface::IsActive ( void ) const
pure virtual

Returns if the network thread is running

Returns
true if the network thread is running, false otherwise

Implemented in RakNet::RakPeer.

virtual bool RakNet::RakPeerInterface::IsBanned ( const char * IP )
pure virtual

Returns true or false indicating if a particular IP is banned.

Parameters
[in] IP - Dotted IP address.
Returns
true if IP matches any IPs in the ban list, accounting for any wildcards. False otherwise.

Implemented in RakNet::RakPeer.

virtual bool RakNet::RakPeerInterface::IsInSecurityExceptionList ( const char * ip )
pure virtual

Checks to see if a given IP is in the security exception list

Parameters
[in] IP address to check.

Implemented in RakNet::RakPeer.

virtual bool RakNet::RakPeerInterface::IsLocalIP ( const char * ip )
pure virtual

Is this a local IP?

Parameters
[in] An IP address to check, excluding the port
Returns
True if this is one of the IP addresses returned by GetLocalIP

Implemented in RakNet::RakPeer.

virtual bool RakNet::RakPeerInterface::IsNetworkSimulatorActive ( void )
pure virtual

Returns if you previously called ApplyNetworkSimulator

Returns
If you previously called ApplyNetworkSimulator

Implemented in RakNet::RakPeer.

virtual unsigned short RakNet::RakPeerInterface::NumberOfConnections ( void ) const
pure virtual

Returns how many open connections there are at this time

Returns
the number of open connections

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::Ping ( const SystemAddress target )
pure virtual

Send a ping to the specified connected system.

Precondition
The sender and recipient must already be started via a successful call to Startup()
Parameters
[in] target Which system to ping

Implemented in RakNet::RakPeer.

virtual bool RakNet::RakPeerInterface::Ping | ( | const char * | host,
 |  | unsigned short | remotePort,
 |  | bool | onlyReplyOnAcceptingConnections,
 |  | unsigned | connectionSocketIndex = 0
 | ) |  |
pure virtual

Send a ping to the specified unconnected system. The remote system, if it is Initialized, will respond with ID_PONG followed by sizeof(RakNet::TimeMS) containing the system time the ping was sent.(Default is 4 bytes - See __GET_TIME_64BIT in RakNetTypes.h System should reply with ID_PONG if it is active

Parameters
[in] | host | Either a dotted IP address or a domain name. Can be 255.255.255.255 for LAN broadcast.
[in] | remotePort | Which port to connect to on the remote machine.
[in] | onlyReplyOnAcceptingConnections | Only request a reply if the remote system is accepting connections
[in] | connectionSocketIndex | Index into the array of socket descriptors passed to socketDescriptors in RakPeer::Startup() to send on.
Returns
true on success, false on failure (unknown hostname)

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::PushBackPacket | ( | Packet * | packet,
 |  | bool | pushAtHead
 | ) |  |
pure virtual

Put a message back at the end of the receive queue in case you don't want to deal with it immediately

Parameters
[in] | packet | The packet you want to push back.
[in] | pushAtHead | True to push the packet so that the next receive call returns it. False to push it at the end of the queue (obviously pushing it at the end makes the packets out of order)

Implemented in RakNet::RakPeer.

virtual Packet* RakNet::RakPeerInterface::Receive ( void )
pure virtual

Gets a message from the incoming message queue. Use DeallocatePacket() to deallocate the message after you are done with it. User-thread functions, such as RPC calls and the plugin function PluginInterface::Update occur here.

Returns
0 if no packets are waiting to be handled, otherwise a pointer to a packet.
Note
COMMON MISTAKE: Be sure to call this in a loop, once per game tick, until it returns 0. If you only process one packet per game tick they will buffer up. sa RakNetTypes.h contains struct Packet

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::RemoveFromBanList ( const char * IP )
pure virtual

Allows a previously banned IP to connect. param[in] Dotted IP address. Can use * as a wildcard, such as 128.0.0.* will banAll IP addresses starting with 128.0.0

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::RemoveFromSecurityExceptionList ( const char * ip )
pure virtual

Remove a specific connection previously added via AddToSecurityExceptionList

Parameters
[in] ip IP address to remove. Pass 0 to remove all IP addresses. * wildcards are supported.

Implemented in RakNet::RakPeer.

virtual uint32_t RakNet::RakPeerInterface::Send | ( | const char * | data,
 |  | const int | length,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | const AddressOrGUID | systemIdentifier,
 |  | bool | broadcast,
 |  | uint32_t | forceReceiptNumber = 0
 | ) |  |
pure virtual

Sends a block of data to the specified system that you are connected to. This function only works while connected The first byte should be a message identifier starting at ID_USER_PACKET_ENUM

Parameters
[in] | data | The block of data to send
[in] | length | The size in bytes of the data to send
[in] | priority | What priority level to send on. See PacketPriority.h
[in] | reliability | How reliability to send this data. See PacketPriority.h
[in] | orderingChannel | When using ordered or sequenced messages, what channel to order these on. Messages are only ordered relative to other messages on the same stream
[in] | systemIdentifier | Who to send this packet to, or in the case of broadcasting who not to send it to. Pass either a SystemAddress structure or a RakNetGUID structure. Use UNASSIGNED_SYSTEM_ADDRESS or to specify none
[in] | broadcast | True to send this packet to all connected systems. If true, then systemAddress specifies who not to send the packet to.
[in] | forceReceipt | If 0, will automatically determine the receipt number to return. If non-zero, will return what you give it.
Returns
0 on bad input. Otherwise a number that identifies this message. If reliability is a type that returns a receipt, on a later call to Receive() you will get ID_SND_RECEIPT_ACKED or ID_SND_RECEIPT_LOSS with bytes 1-4 inclusive containing this number

Implemented in RakNet::RakPeer.

virtual uint32_t RakNet::RakPeerInterface::Send | ( | const RakNet::BitStream * | bitStream,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | const AddressOrGUID | systemIdentifier,
 |  | bool | broadcast,
 |  | uint32_t | forceReceiptNumber = 0
 | ) |  |
pure virtual

Sends a block of data to the specified system that you are connected to. Same as the above version, but takes a BitStream as input.

Parameters
[in] | bitStream | The bitstream to send
[in] | priority | What priority level to send on. See PacketPriority.h
[in] | reliability | How reliability to send this data. See PacketPriority.h
[in] | orderingChannel | When using ordered or sequenced messages, what channel to order these on. Messages are only ordered relative to other messages on the same stream
[in] | systemIdentifier | Who to send this packet to, or in the case of broadcasting who not to send it to. Pass either a SystemAddress structure or a RakNetGUID structure. Use UNASSIGNED_SYSTEM_ADDRESS or to specify none
[in] | broadcast | True to send this packet to all connected systems. If true, then systemAddress specifies who not to send the packet to.
[in] | forceReceipt | If 0, will automatically determine the receipt number to return. If non-zero, will return what you give it.
Returns
0 on bad input. Otherwise a number that identifies this message. If reliability is a type that returns a receipt, on a later call to Receive() you will get ID_SND_RECEIPT_ACKED or ID_SND_RECEIPT_LOSS with bytes 1-4 inclusive containing this number
Note
COMMON MISTAKE: When writing the first byte, bitStream->Write((unsigned char) ID_MY_TYPE) be sure it is casted to a byte, and you are not writing a 4 byte enumeration.

Implemented in RakNet::RakPeer.

virtual uint32_t RakNet::RakPeerInterface::SendList | ( | const char ** | data,
 |  | const int * | lengths,
 |  | const int | numParameters,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | char | orderingChannel,
 |  | const AddressOrGUID | systemIdentifier,
 |  | bool | broadcast,
 |  | uint32_t | forceReceiptNumber = 0
 | ) |  |
pure virtual

Sends multiple blocks of data, concatenating them automatically.

This is equivalent to: RakNet::BitStream bs; bs.WriteAlignedBytes(block1, blockLength1); bs.WriteAlignedBytes(block2, blockLength2); bs.WriteAlignedBytes(block3, blockLength3); Send(&bs, ...)

This function only works while connected

Parameters
[in] | data | An array of pointers to blocks of data
[in] | lengths | An array of integers indicating the length of each block of data
[in] | numParameters | Length of the arrays data and lengths
[in] | priority | What priority level to send on. See PacketPriority.h
[in] | reliability | How reliability to send this data. See PacketPriority.h
[in] | orderingChannel | When using ordered or sequenced messages, what channel to order these on. Messages are only ordered relative to other messages on the same stream
[in] | systemIdentifier | Who to send this packet to, or in the case of broadcasting who not to send it to. Pass either a SystemAddress structure or a RakNetGUID structure. Use UNASSIGNED_SYSTEM_ADDRESS or to specify none
[in] | broadcast | True to send this packet to all connected systems. If true, then systemAddress specifies who not to send the packet to.
[in] | forceReceipt | If 0, will automatically determine the receipt number to return. If non-zero, will return what you give it.
Returns
0 on bad input. Otherwise a number that identifies this message. If reliability is a type that returns a receipt, on a later call to Receive() you will get ID_SND_RECEIPT_ACKED or ID_SND_RECEIPT_LOSS with bytes 1-4 inclusive containing this number

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::SendLoopback | ( | const char * | data,
 |  | const int | length
 | ) |  |
pure virtual

"Send" to yourself rather than a remote system. The message will be processed through the plugins and returned to the game as usual This function works anytime The first byte should be a message identifier starting at ID_USER_PACKET_ENUM

Parameters
[in] | data | The block of data to send
[in] | length | The size in bytes of the data to send

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::SendTTL | ( | const char * | host,
 |  | unsigned short | remotePort,
 |  | int | ttl,
 |  | unsigned | connectionSocketIndex = 0
 | ) |  |
pure virtual

Send a message to host, with the IP socket option TTL set to 3 This message will not reach the host, but will open the router. Used for NAT-Punchthrough

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::SetIncomingDatagramEventHandler ( bool(*)(RNS2RecvStruct *) _incomingDatagramEventHandler )
pure virtual

Set a C callback to be called whenever a datagram arrives Return true from the callback to have RakPeer handle the datagram. Return false and RakPeer will ignore the datagram. This can be used to filter incoming datagrams by system, or to share a recvfrom socket with RakPeer RNS2RecvStruct will only remain valid for the duration of the call If the incoming datagram is not from your game at all, it is a RakNet packet. If the incoming datagram has an IP address that matches a known address from your game, then check the first byte of data. For RakNet connected systems, the first bit is always 1. So for your own game packets, make sure the first bit is always 0.

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::SetIncomingPassword | ( | const char * | passwordData,
 |  | int | passwordDataLength
 | ) |  |
pure virtual

Sets the password incoming connections must match in the call to Connect (defaults to none). Pass 0 to passwordData to specify no password This is a way to set a low level password for all incoming connections. To selectively reject connections, implement your own scheme using CloseConnection() to remove unwanted connections

Parameters
[in] | passwordData | A data block that incoming connections must match. This can be just a password, or can be a stream of data. Specify 0 for no password data
[in] | passwordDataLength | The length in bytes of passwordData

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::SetInternalID | ( | SystemAddress | systemAddress,
 |  | int | index = 0
 | ) |  |
pure virtual

Sets your internal IP address, for platforms that do not support reading it, or to override a value.

Parameters
[in] | systemAddress. | The address to set. Use SystemAddress::FromString() if you want to use a dotted string
[in] | index | When you have multiple internal IDs, which index to set?

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::SetLimitIPConnectionFrequency ( bool b )
pure virtual

Enable or disable allowing frequent connections from the same IP adderss This is a security measure which is disabled by default, but can be set to true to prevent attackers from using up all connection slots

Parameters
[in] b True to limit connections from the same ip to at most 1 per 100 milliseconds.

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::SetMaximumIncomingConnections ( unsigned short numberAllowed )
pure virtual

Sets how many incoming connections are allowed. If this is less than the number of players currently connected, no more players will be allowed to connect. If this is greater than the maximum number of peers allowed, it will be reduced to the maximum number of peers allowed. Defaults to 0, meaning by default, nobody can connect to you

Parameters
[in] numberAllowed Maximum number of incoming connections allowed.

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::SetOccasionalPing ( bool doPing )
pure virtual

Ping the remote systems every so often, or not. Can be called anytime. By default this is true. Recommended to leave on, because congestion control uses it to determine how often to resend lost packets. It would be true by default to prevent timestamp drift, since in the event of a clock spike, the timestamp deltas would no longer be accurate

Parameters
[in] doPing True to start occasional pings. False to stop them.

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::SetOfflinePingResponse | ( | const char * | data,
 |  | const unsigned int | length
 | ) |  |
pure virtual

Sets the data to send along with a LAN server discovery or offline ping reply. length should be under 400 bytes, as a security measure against flood attacks

Parameters
[in] | data | a block of data to store, or 0 for none
[in] | length | The length of data in bytes, or 0 for none
See Also
Ping.cpp

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::SetPerConnectionOutgoingBandwidthLimit ( unsigned maxBitsPerSecond )
pure virtual

Limits how much outgoing bandwidth can be sent per-connection. This limit does not apply to the sum of all connections! Exceeding the limit queues up outgoing traffic

Parameters
[in] maxBitsPerSecond Maximum bits per second to send. Use 0 for unlimited (default). Once set, it takes effect immedately and persists until called again.

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::SetSplitMessageProgressInterval ( int interval )
pure virtual

Controls how often to return ID_DOWNLOAD_PROGRESS for large message downloads. ID_DOWNLOAD_PROGRESS is returned to indicate a new partial message chunk, roughly the MTU size, has arrived As it can be slow or cumbersome to get this notification for every chunk, you can set the interval at which it is returned. Defaults to 0 (never return this notification)

Parameters
[in] interval How many messages to use as an interval

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::SetTimeoutTime | ( | RakNet::TimeMS | timeMS,
 |  | const SystemAddress | target
 | ) |  |
pure virtual

Set the time, in MS, to use before considering ourselves disconnected after not being able to deliver a reliable message. Default time is 10,000 or 10 seconds in release and 30,000 or 30 seconds in debug. Do not set different values for different computers that are connected to each other, or you won't be able to reconnect after ID_CONNECTION_LOST

Parameters
[in] | timeMS | Time, in MS
[in] | target | Which system to do this for. Pass UNASSIGNED_SYSTEM_ADDRESS for all systems.

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::SetUnreliableTimeout ( RakNet::TimeMS timeoutMS )
pure virtual

Set how long to wait before giving up on sending an unreliable message Useful if the network is clogged up. Set to 0 or less to never timeout. Defaults to 0.

Parameters
[in] timeoutMS How many ms to wait before simply not sending an unreliable message.

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::SetUserUpdateThread | ( | void(*)(RakPeerInterface *, void *) | _userUpdateThreadPtr,
 |  | void * | _userUpdateThreadData
 | ) |  |
pure virtual

If you need code to run in the same thread as RakNet's update thread, this function can be used for that

Parameters
[in] | _userUpdateThreadPtr | C callback function
[in] | _userUpdateThreadData | Passed to C callback function

Implemented in RakNet::RakPeer.

virtual void RakNet::RakPeerInterface::Shutdown | ( | unsigned int | blockDuration,
 |  | unsigned char | orderingChannel = 0,
 |  | PacketPriority | disconnectionNotificationPriority = LOW_PRIORITY
 | ) |  |
pure virtual

Connect to the specified network ID (Platform specific console function)

Does built-in NAt traversal

Parameters
[in] | passwordData | A data block that must match the data block on the server passed to SetIncomingPassword. This can be a string or can be a stream of data. Use 0 for no password.
[in] | passwordDataLength | The length in bytes of passwordData Stops the network threads and closes all connections.
[in] | blockDuration | How long, in milliseconds, you should wait for all remaining messages to go out, including ID_DISCONNECTION_NOTIFICATION. If 0, it doesn't wait at all.
[in] | orderingChannel | If blockDuration > 0, ID_DISCONNECTION_NOTIFICATION will be sent on this channel
[in] | disconnectionNotificationPriority | Priority to send ID_DISCONNECTION_NOTIFICATION on. If you set it to 0 then the disconnection notification won't be sent

Implemented in RakNet::RakPeer.

virtual StartupResult RakNet::RakPeerInterface::Startup | ( | unsigned int | maxConnections,
 |  | SocketDescriptor * | socketDescriptors,
 |  | unsigned | socketDescriptorCount,
 |  | int | threadPriority = -99999
 | ) |  |
pure virtual

Starts the network threads, opens the listen port.

You must call this before calling Connect().

Precondition
On the PS3, call Startup() after Client_Login()
On Android, add the necessary permission to your application's androidmanifest.xml: <uses-permission android:name="android.permission.INTERNET" /> Multiple calls while already active are ignored. To call this function again with different settings, you must first call Shutdown().
Note
Call SetMaximumIncomingConnections if you want to accept incoming connections
Parameters
[in] | maxConnections | The maximum number of connections between this instance of RakPeer and another instance of RakPeer. Required so the network can preallocate and for thread safety. A pure client would set this to 1. A pure server would set it to the number of allowed clients.- A hybrid would set it to the sum of both types of connections
[in] | localPort | The port to listen for connections on. On linux the system may be set up so thast ports under 1024 are restricted for everything but the root user. Use a higher port for maximum compatibility.
[in] | socketDescriptors | An array of SocketDescriptor structures to force RakNet to listen on a particular IP address or port (or both). Each SocketDescriptor will represent one unique socket. Do not pass redundant structures. To listen on a specific port, you can pass SocketDescriptor(myPort,0); such as for a server. For a client, it is usually OK to just pass SocketDescriptor(); However, on the XBOX be sure to use IPPROTO_VDP
[in] | socketDescriptorCount | The size of the socketDescriptors array. Pass 1 if you are not sure what to pass.
[in] | threadPriority | Passed to the thread creation routine. Use THREAD_PRIORITY_NORMAL for Windows. For Linux based systems, you MUST pass something reasonable based on the thread priorities for your application.
Returns
RAKNET_STARTED on success, otherwise appropriate failure enumeration.

Implemented in RakNet::RakPeer.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/RakPeerInterface.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::RakString Class Reference

  • RakString
Public Member Functions | Static Public Member Functions | List of all members
RakNet::RakString Class Reference

String class. More...

#include <RakString.h>

Public Member Functions

operator const char * () const
Implicit return of const char*.
const char * | C_String (void) const
Same as std::string::c_str.
RakString & | operator= (const RakString &rhs)
Assigment operators.
RakString & | operator+= (const RakString &rhs)
Concatenation.
unsigned char | operator[] (const unsigned int position) const
Character index. Do not use to change the string however.
size_t | Find (const char *stringToFind, size_t pos=0)
bool | operator== (const RakString &rhs) const
Equality.
bool | operator!= (const RakString &rhs) const
Inequality.
const char * | ToLower (void)
Change all characters to lowercase.
const char * | ToUpper (void)
Change all characters to uppercase.
void | Set (const char *format,...)
Set the value of the string.
RakString | Assign (const char *str, size_t pos, size_t n)
bool | IsEmpty (void) const
Returns if the string is empty. Also, C_String() would return "".
size_t | GetLength (void) const
Returns the length of the string.
void | Replace (unsigned index, unsigned count, unsigned char c)
Replace character(s) in starting at index, for count, with c.
void | SetChar (unsigned index, unsigned char c)
Replace character at index with c.
void | SetChar (unsigned index, RakNet::RakString s)
Replace character at index with string s.
void | Truncate (unsigned int length)
Make sure string is no longer than length.
void | Erase (unsigned int index, unsigned int count)
Erase characters out of the string at index for count.
void | TerminateAtFirstCharacter (char c)
Set the first instance of c with a NULL terminator.
void | TerminateAtLastCharacter (char c)
Set the last instance of c with a NULL terminator.
int | GetCharacterCount (char c)
Returns how many occurances there are of c in the string.
void | RemoveCharacter (char c)
Remove all instances of c.
int | StrCmp (const RakString &rhs) const
Compare strings (case sensitive)
int | StrNCmp (const RakString &rhs, size_t num) const
Compare strings (case sensitive), up to num characters.
int | StrICmp (const RakString &rhs) const
Compare strings (not case sensitive)
void | Clear (void)
Clear the string.
void | Printf (void)
Print the string to the screen.
void | FPrintf (FILE *fp)
Print the string to a file.
bool | IPAddressMatch (const char *IP)
Does the given IP address match the IP address encoded into this string, accounting for wildcards?
bool | ContainsNonprintableExceptSpaces (void) const
Does the string contain non-printable characters other than spaces?
bool | IsEmailAddress (void) const
Is this a valid email address?
RakNet::RakString & | URLEncode (void)
URL Encode the string. See http://www.codeguru.com/cpp/cpp/cpp_mfc/article.php/c4029/.
RakNet::RakString & | URLDecode (void)
URL decode the string.
void | SplitURI (RakNet::RakString &header, RakNet::RakString &domain, RakNet::RakString &path)
https://servers.api.rackspacecloud.com/v1.0 to https://, servers.api.rackspacecloud.com, /v1.0
RakNet::RakString & | SQLEscape (void)
Scan for quote, double quote, and backslash and prepend with backslash.
RakNet::RakString & | MakeFilePath (void)
Fix to be a file path, ending with /.
void | Serialize (BitStream *bs) const
void | SerializeCompressed (BitStream *bs, uint8_t languageId=0, bool writeLanguageId=false) const
bool | Deserialize (BitStream *bs)
bool | DeserializeCompressed (BitStream *bs, bool readLanguageId=false)

Static Public Member Functions

static RakNet::RakString | NonVariadic (const char *str)
static unsigned long | ToInteger (const char *str)
Hash the string into an unsigned int.
static int | ReadIntFromSubstring (const char *str, size_t pos, size_t n)
Read an integer out of a substring.
static RakNet::RakString | FormatForPOST (const char *uri, const char *contentType, const char *body, const char *extraHeaders="")
static RakNet::RakString | FormatForGET (const char *uri, const char *extraHeaders="")
static RakNet::RakString | FormatForDELETE (const char *uri, const char *extraHeaders="")
static void | FreeMemory (void)
static void | Serialize (const char *str, BitStream *bs)
Static version of the Serialize function.
static void | SerializeCompressed (const char *str, BitStream *bs, uint8_t languageId=0, bool writeLanguageId=false)
Static version of the SerializeCompressed function.
static bool | Deserialize (char *str, BitStream *bs)
Static version of the Deserialize() function.
static bool | DeserializeCompressed (char *str, BitStream *bs, bool readLanguageId=false)
Static version of the DeserializeCompressed() function.

Detailed Description

String class.

Has the following improvements over std::string -Reference counting: Suitable to store in lists -Variadic assignment operator -Doesn't cause linker errors

Member Function Documentation

RakString RakNet::RakString::Assign | ( | const char * | str,
 |  | size_t | pos,
 |  | size_t | n
 | ) |  |

Sets a copy of a substring of str as the new content. The substring is the portion of str that begins at the character position pos and takes up to n characters (it takes less than n if the end of str is reached before).

Parameters
[in] | str | The string to copy in
[in] | pos | The position on str to start the copy
[in] | n | How many chars to copy
Returns
Returns the string, note that the current string is set to that value as well
bool RakNet::RakString::Deserialize ( BitStream * bs )

Deserialize what was written by Serialize

Parameters
[in] bs Bitstream to serialize from
Returns
true if the deserialization was successful
bool RakNet::RakString::DeserializeCompressed | ( | BitStream * | bs,
 |  | bool | readLanguageId = false
 | ) |  |

Deserialize compressed string, written by SerializeCompressed

Parameters
[in] | bs | Bitstream to serialize from
[in] | readLanguageId | If true, looks for the variable langaugeId in the data stream. Must match what was passed to SerializeCompressed
Returns
true if the deserialization was successful
Precondition
StringCompressor::AddReference must have been called to instantiate the class (Happens automatically from RakPeer::Startup())
size_t RakNet::RakString::Find | ( | const char * | stringToFind,
 |  | size_t | pos = 0
 | ) |  |

String class find replacement Searches the string for the content specified in stringToFind and returns the position of the first occurrence in the string. Search only includes characters on or after position pos, ignoring any possible occurrences in previous locations.

Parameters
[in] | stringToFind | The string to find inside of this object's string
[in] | pos | The position in the string to start the search
Returns
Returns the position of the first occurrence in the string.
static RakNet::RakString RakNet::RakString::FormatForDELETE | ( | const char * | uri,
 |  | const char * | extraHeaders = ""
 | ) |  |
static

Format as a DELETE command that can be sent to a webserver

Parameters
[in] uri For example, masterserver2.raknet.com/testServer?__gameId=comprehensivePCGame&__rowId=1
Returns
Formatted string
static RakNet::RakString RakNet::RakString::FormatForGET | ( | const char * | uri,
 |  | const char * | extraHeaders = ""
 | ) |  |
static

Format as a GET command that can be sent to a webserver

Parameters
[in] uri For example, masterserver2.raknet.com/testServer?__gameId=comprehensivePCGame
Returns
Formatted string
static RakNet::RakString RakNet::RakString::FormatForPOST | ( | const char * | uri,
 |  | const char * | contentType,
 |  | const char * | body,
 |  | const char * | extraHeaders = ""
 | ) |  |
static

Format as a POST command that can be sent to a webserver

Parameters
[in] | uri | For example, masterserver2.raknet.com/testServer
[in] | contentType | For example, text/plain; charset=UTF-8
[in] | body | Body of the post
Returns
Formatted string
static void RakNet::RakString::FreeMemory ( void )
static

RakString uses a freeList of old no-longer used strings Call this function to clear this memory on shutdown

static RakNet::RakString RakNet::RakString::NonVariadic ( const char * str )
static

Create a RakString with a value, without doing printf style parsing Equivalent to assignment operator

static int RakNet::RakString::ReadIntFromSubstring | ( | const char * | str,
 |  | size_t | pos,
 |  | size_t | n
 | ) |  |
static

Read an integer out of a substring.

Parameters
[in] | str | The string
[in] | pos | The position on str where the integer starts
[in] | n | How many chars to copy
void RakNet::RakString::Serialize ( BitStream * bs ) const

Serialize to a bitstream, uncompressed (slightly faster)

Parameters
[out] bs Bitstream to serialize to
void RakNet::RakString::SerializeCompressed | ( | BitStream * | bs,
 |  | uint8_t | languageId = 0,
 |  | bool | writeLanguageId = false
 | ) |  | const

Serialize to a bitstream, compressed (better bandwidth usage)

Parameters
[out] | bs | Bitstream to serialize to
[in] | languageId | languageId to pass to the StringCompressor class
[in] | writeLanguageId | encode the languageId variable in the stream. If false, 0 is assumed, and DeserializeCompressed will not look for this variable in the stream (saves bandwidth)
Precondition
StringCompressor::AddReference must have been called to instantiate the class (Happens automatically from RakPeer::Startup())
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/RakString.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::RakWString Class Reference

  • RakWString
Public Member Functions | Static Public Member Functions | List of all members
RakNet::RakWString Class Reference

String class for Unicode. More...

#include <RakWString.h>

Public Member Functions

operator wchar_t * () const
Implicit return of wchar_t*.
const wchar_t * | C_String (void) const
Same as std::string::c_str.
RakWString & | operator= (const RakWString &right)
Assignment operators.
RakWString & | operator+= (const RakWString &right)
Concatenation.
bool | operator== (const RakWString &right) const
Equality.
bool | operator!= (const RakWString &right) const
Inequality.
void | Set (wchar_t *str)
Set the value of the string.
bool | IsEmpty (void) const
Returns if the string is empty. Also, C_String() would return "".
size_t | GetLength (void) const
Returns the length of the string.
int | StrCmp (const RakWString &right) const
Compare strings (case sensitive)
int | StrICmp (const RakWString &right) const
Compare strings (not case sensitive)
void | Clear (void)
Clear the string.
void | Printf (void)
Print the string to the screen.
void | FPrintf (FILE *fp)
Print the string to a file.
void | Serialize (BitStream *bs) const
bool | Deserialize (BitStream *bs)

Static Public Member Functions

static unsigned long | ToInteger (const RakWString &rs)
Has the string into an unsigned int.
static void | Serialize (const wchar_t *const str, BitStream *bs)
Static version of the Serialize function.
static bool | Deserialize (wchar_t *str, BitStream *bs)
Static version of the Deserialize() function.

Detailed Description

String class for Unicode.

Member Function Documentation

bool RakNet::RakWString::Deserialize ( BitStream * bs )

Deserialize what was written by Serialize

Parameters
[in] bs Bitstream to serialize from
Returns
true if the deserialization was successful
void RakNet::RakWString::Serialize ( BitStream * bs ) const

Serialize to a bitstream, uncompressed (slightly faster)

Parameters
[out] bs Bitstream to serialize to
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/RakWString.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::ReliabilityLayer Class Reference

  • ReliabilityLayer
Public Member Functions | List of all members
RakNet::ReliabilityLayer Class Reference

Datagram reliable, ordered, unordered and sequenced sends. Flow control. Message splitting, reassembly, and coalescence. More...

#include <ReliabilityLayer.h>

Public Member Functions

void | Reset (bool resetVariables, int MTUSize, bool _useSecurity)
Resets the layer for reuse.
void | SetTimeoutTime (RakNet::TimeMS time)
RakNet::TimeMS | GetTimeoutTime (void)
bool | HandleSocketReceiveFromConnectedPlayer (const char *buffer, unsigned int length, SystemAddress &systemAddress, DataStructures::List< PluginInterface2 * > &messageHandlerList, int MTUSize, RakNetSocket2 *s, RakNetRandom *rnr, CCTimeType timeRead, BitStream &updateBitStream)
BitSize_t | Receive (unsigned char **data)
bool | Send (char *data, BitSize_t numberOfBitsToSend, PacketPriority priority, PacketReliability reliability, unsigned char orderingChannel, bool makeDataCopy, int MTUSize, CCTimeType currentTime, uint32_t receipt)
void | Update (RakNetSocket2 *s, SystemAddress &systemAddress, int MTUSize, CCTimeType time, unsigned bitsPerSecondLimit, DataStructures::List< PluginInterface2 * > &messageHandlerList, RakNetRandom *rnr, BitStream &updateBitStream)
bool | IsDeadConnection (void) const
void | KillConnection (void)
Causes IsDeadConnection to return true.
RakNetStatistics * | GetStatistics (RakNetStatistics *rns)
bool | IsOutgoingDataWaiting (void)
Are we waiting for any data to be sent out or be processed by the player?
bool | IsNetworkSimulatorActive (void)
bool | AckTimeout (RakNet::Time curTime)
Has a lot of time passed since the last ack.

Detailed Description

Datagram reliable, ordered, unordered and sequenced sends. Flow control. Message splitting, reassembly, and coalescence.

Member Function Documentation

RakNetStatistics* RakNet::ReliabilityLayer::GetStatistics ( RakNetStatistics * rns )

Get Statistics

Returns
A pointer to a static struct, filled out with current statistical information.
RakNet::TimeMS RakNet::ReliabilityLayer::GetTimeoutTime ( void )

Returns the value passed to SetTimeoutTime. or the default if it was never called

Parameters
[out] the value passed to SetTimeoutTime
bool RakNet::ReliabilityLayer::HandleSocketReceiveFromConnectedPlayer | ( | const char * | buffer,
 |  | unsigned int | length,
 |  | SystemAddress & | systemAddress,
 |  | DataStructures::List< PluginInterface2 * > & | messageHandlerList,
 |  | int | MTUSize,
 |  | RakNetSocket2 * | s,
 |  | RakNetRandom * | rnr,
 |  | CCTimeType | timeRead,
 |  | BitStream & | updateBitStream
 | ) |  |

Packets are read directly from the socket layer and skip the reliability layer because unconnected players do not use the reliability layer This function takes packet data after a player has been confirmed as connected.

Parameters
[in] | buffer | The socket data
[in] | length | The length of the socket data
[in] | systemAddress | The player that this data is from
[in] | messageHandlerList | A list of registered plugins
[in] | MTUSize | maximum datagram size
Return values
true | Success
false | Modified packet
bool RakNet::ReliabilityLayer::IsDeadConnection ( void ) const

Were you ever unable to deliver a packet despite retries?

Returns
true means the connection has been lost. Otherwise not.
bool RakNet::ReliabilityLayer::IsNetworkSimulatorActive ( void )

Returns if you previously called ApplyNetworkSimulator

Returns
If you previously called ApplyNetworkSimulator
BitSize_t RakNet::ReliabilityLayer::Receive ( unsigned char ** data )

This allocates bytes and writes a user-level message to those bytes.

Parameters
[out] data The message
Returns
Returns number of BITS put into the buffer
bool RakNet::ReliabilityLayer::Send | ( | char * | data,
 |  | BitSize_t | numberOfBitsToSend,
 |  | PacketPriority | priority,
 |  | PacketReliability | reliability,
 |  | unsigned char | orderingChannel,
 |  | bool | makeDataCopy,
 |  | int | MTUSize,
 |  | CCTimeType | currentTime,
 |  | uint32_t | receipt
 | ) |  |

Puts data on the send queue

Parameters
[in] | data | The data to send
[in] | numberOfBitsToSend | The length of data in bits
[in] | priority | The priority level for the send
[in] | reliability | The reliability type for the send
[in] | orderingChannel | 0 to 31. Specifies what channel to use, for relational ordering and sequencing of packets.
[in] | makeDataCopy | If true data will be copied. Otherwise, only a pointer will be stored.
[in] | MTUSize | maximum datagram size
[in] | currentTime | Current time, as per RakNet::GetTimeMS()
[in] | receipt | This number will be returned back with ID_SND_RECEIPT_ACKED or ID_SND_RECEIPT_LOSS and is only returned with the reliability types that contain RECEIPT in the name
Returns
True or false for success or failure.
void RakNet::ReliabilityLayer::SetTimeoutTime ( RakNet::TimeMS time )

Set the time, in MS, to use before considering ourselves disconnected after not being able to deliver a reliable packet Default time is 10,000 or 10 seconds in release and 30,000 or 30 seconds in debug.

Parameters
[in] time Time, in MS
void RakNet::ReliabilityLayer::Update | ( | RakNetSocket2 * | s,
 |  | SystemAddress & | systemAddress,
 |  | int | MTUSize,
 |  | CCTimeType | time,
 |  | unsigned | bitsPerSecondLimit,
 |  | DataStructures::List< PluginInterface2 * > & | messageHandlerList,
 |  | RakNetRandom * | rnr,
 |  | BitStream & | updateBitStream
 | ) |  |

Call once per game cycle. Handles internal lists and actually does the send.

Parameters
[in] | s | the communication end point
[in] | systemAddress | The Unique Player Identifier who shouldhave sent some packets
[in] | MTUSize | maximum datagram size
[in] | time | current system time
[in] | maxBitsPerSecond | if non-zero, enforces that outgoing bandwidth does not exceed this amount
[in] | messageHandlerList | A list of registered plugins
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/ReliabilityLayer.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Replica3Composite< parent_type > Class Template Reference

  • Replica3Composite
Public Member Functions | List of all members
RakNet::Replica3Composite< parent_type > Class Template Reference

Use Replica3 through composition instead of inheritance by containing an instance of this templated class Calls to parent class for all functions Parent class must still define and functions though! More...

#include <ReplicaManager3.h>

Inheritance diagram for RakNet::Replica3Composite< parent_type >:
RakNet::Replica3 RakNet::NetworkIDObject

Public Member Functions

virtual void | WriteAllocationID (RakNet::Connection_RM3 *destinationConnection, RakNet::BitStream *allocationIdBitstream) const
Write a unique identifer that can be read on a remote system to create an object of this same class.
virtual
RakNet::RM3ConstructionState 		QueryConstruction (RakNet::Connection_RM3 *destinationConnection, RakNet::ReplicaManager3 *replicaManager3)
Ask if this object, which does not exist on destinationConnection should (now) be sent to that system.
virtual RakNet::RM3DestructionState | QueryDestruction (RakNet::Connection_RM3 *destinationConnection, RakNet::ReplicaManager3 *replicaManager3)
Ask if this object, which does exist on destinationConnection should be removed from the remote system.
virtual bool | QueryRemoteConstruction (RakNet::Connection_RM3 *sourceConnection)
We're about to call DeserializeConstruction() on this Replica3. If QueryRemoteConstruction() returns false, this object is deleted instead.
virtual bool | QueryRelayDestruction (RakNet::Connection_RM3 *sourceConnection) const
We got a message from a connection to destroy this replica Return true to automatically relay the destruction message to all our other connections For a client in client/server, it does not matter what this funtion returns For a server in client/server, this should normally return true For a peer in peer to peer, you can normally return false since the original destroying peer would have told all other peers about the destruction If a system gets a destruction command for an object that was already destroyed, the destruction message is ignored.
virtual void | SerializeConstruction (RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *destinationConnection)
Write data to be sent only when the object is constructed on a remote system.
virtual bool | DeserializeConstruction (RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *sourceConnection)
Read data written by Replica3::SerializeConstruction()
virtual void | SerializeConstructionExisting (RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *destinationConnection)
virtual void | DeserializeConstructionExisting (RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *sourceConnection)
virtual void | SerializeDestruction (RakNet::BitStream *destructionBitstream, RakNet::Connection_RM3 *destinationConnection)
Write extra data to send with the object deletion event, if desired.
virtual bool | DeserializeDestruction (RakNet::BitStream *destructionBitstream, RakNet::Connection_RM3 *sourceConnection)
Read data written by Replica3::SerializeDestruction()
virtual
RakNet::RM3ActionOnPopConnection 		QueryActionOnPopConnection (RakNet::Connection_RM3 *droppedConnection) const
The system is asking what to do with this replica when the connection is dropped.
virtual void | OnPoppedConnection (RakNet::Connection_RM3 *droppedConnection)
Notification called for each of our replicas when a connection is popped.
virtual void | DeallocReplica (RakNet::Connection_RM3 *sourceConnection)
Override with {delete this;}.
virtual
RakNet::RM3QuerySerializationResult 		QuerySerialization (RakNet::Connection_RM3 *destinationConnection)
Implement with QuerySerialization_ClientSerializable(), QuerySerialization_ServerSerializable(), or QuerySerialization_PeerToPeer()
virtual void | OnUserReplicaPreSerializeTick (void)
Called for each replica owned by the user, once per Serialization tick, before Serialize() is called. If you want to do some kind of operation on the Replica objects that you own, just before Serialization(), then overload this function.
virtual
RakNet::RM3SerializationResult 		Serialize (RakNet::SerializeParameters *serializeParameters)
Serialize our class to a bitstream.
virtual void | Deserialize (RakNet::DeserializeParameters *deserializeParameters)
Read what was written in Serialize()
virtual void | PostSerializeConstruction (RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *destinationConnection)
Called after SerializeConstruction completes for all objects in a given update tick.
Writes to PostDeserializeConstruction(), which is called after all objects are created for a given Construction tick(). Override to send data to PostDeserializeConstruction(), such as the NetworkID of other objects to resolve pointers to.
virtual void | PostDeserializeConstruction (RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *sourceConnection)
virtual void | PostSerializeConstructionExisting (RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *destinationConnection)
Same as PostSerializeConstruction(), but for objects that returned RM3CS_ALREADY_EXISTS_REMOTELY from QueryConstruction.
virtual void | PostDeserializeConstructionExisting (RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *sourceConnection)
Same as PostDeserializeConstruction(), but for objects that returned RM3CS_ALREADY_EXISTS_REMOTELY from QueryConstruction.
virtual void | PreDestruction (RakNet::Connection_RM3 *sourceConnection)
- Public Member Functions inherited from RakNet::Replica3
virtual | ~Replica3 ()
virtual void | OnSerializeTransmission (RakNet::BitStream *bitStream, RakNet::Connection_RM3 *destinationConnection, BitSize_t bitsPerChannel[RM3_NUM_OUTPUT_BITSTREAM_CHANNELS], RakNet::Time curTime)
Called when the class is actually transmitted via Serialize()
virtual RM3ConstructionState | QueryConstruction_ClientConstruction (RakNet::Connection_RM3 *destinationConnection, bool isThisTheServer)
Default call for QueryConstruction().
virtual bool | QueryRemoteConstruction_ClientConstruction (RakNet::Connection_RM3 *sourceConnection, bool isThisTheServer)
virtual RM3ConstructionState | QueryConstruction_ServerConstruction (RakNet::Connection_RM3 *destinationConnection, bool isThisTheServer)
Default call for QueryConstruction().
virtual bool | QueryRemoteConstruction_ServerConstruction (RakNet::Connection_RM3 *sourceConnection, bool isThisTheServer)
Default call for QueryRemoteConstruction(). Allow the server to create this object, but not the client.
virtual RM3ConstructionState | QueryConstruction_PeerToPeer (RakNet::Connection_RM3 *destinationConnection, Replica3P2PMode p2pMode=R3P2PM_SINGLE_OWNER)
Default call for QueryConstruction().
virtual bool | QueryRemoteConstruction_PeerToPeer (RakNet::Connection_RM3 *sourceConnection)
Default call for QueryRemoteConstruction().
virtual
RakNet::RM3QuerySerializationResult 		QuerySerialization_ClientSerializable (RakNet::Connection_RM3 *destinationConnection, bool isThisTheServer)
Default call for QuerySerialization().
virtual
RakNet::RM3QuerySerializationResult 		QuerySerialization_ServerSerializable (RakNet::Connection_RM3 *destinationConnection, bool isThisTheServer)
Default call for QuerySerialization().
virtual
RakNet::RM3QuerySerializationResult 		QuerySerialization_PeerToPeer (RakNet::Connection_RM3 *destinationConnection, Replica3P2PMode p2pMode=R3P2PM_SINGLE_OWNER)
Default call for QuerySerialization().
virtual RM3ActionOnPopConnection | QueryActionOnPopConnection_Client (RakNet::Connection_RM3 *droppedConnection) const
Default: If we are a client, and the connection is lost, delete the server's objects.
virtual RM3ActionOnPopConnection | QueryActionOnPopConnection_Server (RakNet::Connection_RM3 *droppedConnection) const
Default: If we are a server, and the connection is lost, delete the client's objects and broadcast the destruction.
virtual RM3ActionOnPopConnection | QueryActionOnPopConnection_PeerToPeer (RakNet::Connection_RM3 *droppedConnection) const
Default: If we are a peer, and the connection is lost, delete the peer's objects.
virtual void | BroadcastDestruction (void)
RakNetGUID | GetCreatingSystemGUID (void) const
bool | WasReferenced (void) const
- Public Member Functions inherited from RakNet::NetworkIDObject
virtual void | SetNetworkIDManager (NetworkIDManager *manager)
virtual NetworkIDManager * | GetNetworkIDManager (void) const
Returns what was passed to SetNetworkIDManager.
virtual NetworkID | GetNetworkID (void)
virtual void | SetNetworkID (NetworkID id)
virtual void | SetParent (void *_parent)
virtual void * | GetParent (void) const

Additional Inherited Members

- Public Attributes inherited from RakNet::Replica3
RakNetGUID creatingSystemGUID
RakNetGUID deletingSystemGUID
GUID of the system that caused the item to send a deletion command over the network.
- Protected Attributes inherited from RakNet::NetworkIDObject
NetworkID | networkID
The network ID of this object.
void * | parent
The parent set by SetParent()

Detailed Description

template<class parent_type>
class RakNet::Replica3Composite< parent_type >

Use Replica3 through composition instead of inheritance by containing an instance of this templated class Calls to parent class for all functions Parent class must still define and functions though!

Precondition
Parent class must call SetCompositeOwner() on this object

Member Function Documentation

template<class parent_type >
virtual void RakNet::Replica3Composite< parent_type >::DeallocReplica ( RakNet::Connection_RM3 * sourceConnection )
inlinevirtual

Override with {delete this;}.

  1. Got a remote message to delete this object which passed DeserializeDestruction(), OR
  2. ReplicaManager3::SetAutoManageConnections() was called autoDestroy true (which is the default setting), and a remote system that owns this object disconnected) OR <>
    Override with {delete this;} to actually delete the object (and any other processing you wish).
    If you don't want to delete the object, just do nothing, however, the system will not know this. You may wish to call Dereference() if the object should no longer be networked, but remain in memory. You are responsible for deleting it yoruself later.
    destructionBitstream may be 0 if the object was deleted locally

Implements RakNet::Replica3.

template<class parent_type >
virtual void RakNet::Replica3Composite< parent_type >::Deserialize ( RakNet::DeserializeParameters * deserializeParameters )
inlinevirtual

Read what was written in Serialize()

Reads the contents of the class from SerializationParamters::serializationBitstream.
Called whenever Serialize() is called with different data from the last send.

Parameters
[in] | serializationBitstream | Bitstream passed to Serialize()
[in] | timeStamp | 0 if unused, else contains the time the message originated on the remote system
[in] | sourceConnection | Which system sent to us

Implements RakNet::Replica3.

template<class parent_type >
virtual bool RakNet::Replica3Composite< parent_type >::DeserializeConstruction | ( | RakNet::BitStream * | constructionBitstream,
 |  | RakNet::Connection_RM3 * | sourceConnection
 | ) |  |
inlinevirtual

Read data written by Replica3::SerializeConstruction()

Reads whatever data was written to constructionBitstream in Replica3::SerializeConstruction()

Parameters
[out] | constructionBitstream | Bitstream written to in Replica3::SerializeConstruction()
[in] | sourceConnection | System that sent us this network message.
Returns
true to accept construction of the object. false to reject, in which case the object will be deleted via Replica3::DeallocReplica()

Implements RakNet::Replica3.

template<class parent_type >
virtual void RakNet::Replica3Composite< parent_type >::DeserializeConstructionExisting | ( | RakNet::BitStream * | constructionBitstream,
 |  | RakNet::Connection_RM3 * | sourceConnection
 | ) |  |
inlinevirtual

Same as DeserializeConstruction(), but for an object that already exists on the remote system. Used if you return RM3CS_ALREADY_EXISTS_REMOTELY from QueryConstruction

Reimplemented from RakNet::Replica3.

template<class parent_type >
virtual bool RakNet::Replica3Composite< parent_type >::DeserializeDestruction | ( | RakNet::BitStream * | destructionBitstream,
 |  | RakNet::Connection_RM3 * | sourceConnection
 | ) |  |
inlinevirtual

Read data written by Replica3::SerializeDestruction()

Return true to delete the object. BroadcastDestruction() will be called automatically, followed by ReplicaManager3::Dereference.
Return false to not delete it. If you delete it at a later point, you are responsible for calling BroadcastDestruction() yourself.

Implements RakNet::Replica3.

template<class parent_type >
virtual void RakNet::Replica3Composite< parent_type >::PostDeserializeConstruction | ( | RakNet::BitStream * | constructionBitstream,
 |  | RakNet::Connection_RM3 * | sourceConnection
 | ) |  |
inlinevirtual

Called after DeserializeConstruction completes for all objects in a given update tick.
This is used to resolve dependency chains, where two objects would refer to each other in DeserializeConstruction, yet one had not been constructed yet In PostDeserializeConstruction(), you know that all objects have already been created, so can resolve NetworkIDs to pointers safely. You can also use it to trigger some sort of event when you know the object has completed deserialization.

Parameters
[in] | constructionBitstream | BitStream written in PostSerializeConstruction()
[in] | sourceConnection | System that sent us this network message.

Reimplemented from RakNet::Replica3.

template<class parent_type >
virtual void RakNet::Replica3Composite< parent_type >::PreDestruction ( RakNet::Connection_RM3 * sourceConnection )
inlinevirtual

Called after DeserializeDestruction completes for the object successfully, but obviously before the object is deleted.
Override to trigger some sort of event when you know the object has completed destruction.

Parameters
[in] sourceConnection System that sent us this network message.

Reimplemented from RakNet::Replica3.

template<class parent_type >
virtual RakNet::RM3ActionOnPopConnection RakNet::Replica3Composite< parent_type >::QueryActionOnPopConnection ( RakNet::Connection_RM3 * droppedConnection ) const
inlinevirtual

The system is asking what to do with this replica when the connection is dropped.

Return QueryActionOnPopConnection_Client, QueryActionOnPopConnection_Server, or QueryActionOnPopConnection_PeerToPeer

Implements RakNet::Replica3.

template<class parent_type >
virtual RakNet::RM3ConstructionState RakNet::Replica3Composite< parent_type >::QueryConstruction | ( | RakNet::Connection_RM3 * | destinationConnection,
 |  | RakNet::ReplicaManager3 * | replicaManager3
 | ) |  |
inlinevirtual

Ask if this object, which does not exist on destinationConnection should (now) be sent to that system.

If ReplicaManager3::QueryConstructionMode() returns QUERY_CONNECTION_FOR_REPLICA_LIST or QUERY_REPLICA_FOR_CONSTRUCTION_AND_DESTRUCTION (default), then QueyrConstruction() is called once per tick from ReplicaManager3::Update() to determine if an object should exist on a given system.
Based on the return value, a network message may be sent to the other system to create the object.
If QueryConstructionMode() is overriden to return QUERY_CONNECTION_FOR_REPLICA_LIST, this function is unused.

Note
Defaults are provided: QueryConstruction_PeerToPeer(), QueryConstruction_ServerConstruction(), QueryConstruction_ClientConstruction(). Return one of these functions for a working default for the relevant topology.
Parameters
[in] | destinationConnection | Which system we will send to
[in] | replicaManager3 | Plugin instance for this Replica3
Returns
What action to take

Implements RakNet::Replica3.

template<class parent_type >
virtual RakNet::RM3DestructionState RakNet::Replica3Composite< parent_type >::QueryDestruction | ( | RakNet::Connection_RM3 * | destinationConnection,
 |  | RakNet::ReplicaManager3 * | replicaManager3
 | ) |  |
inlinevirtual

Ask if this object, which does exist on destinationConnection should be removed from the remote system.

If ReplicaManager3::QueryConstructionMode() returns QUERY_REPLICA_FOR_CONSTRUCTION_AND_DESTRUCTION (default), then QueryDestruction() is called once per tick from ReplicaManager3::Update() to determine if an object that exists on a remote system should be destroyed for a given system.
Based on the return value, a network message may be sent to the other system to destroy the object.
Note that you can also destroy objects with BroadcastDestruction(), so this function is not useful unless you plan to delete objects for only a particular connection.
If QueryConstructionMode() is overriden to return QUERY_CONNECTION_FOR_REPLICA_LIST, this function is unused.

Parameters
[in] | destinationConnection | Which system we will send to
[in] | replicaManager3 | Plugin instance for this Replica3
Returns
What action to take. Only RM3CS_SEND_DESTRUCTION does anything at this time.

Reimplemented from RakNet::Replica3.

template<class parent_type >
virtual bool RakNet::Replica3Composite< parent_type >::QueryRemoteConstruction ( RakNet::Connection_RM3 * sourceConnection )
inlinevirtual

We're about to call DeserializeConstruction() on this Replica3. If QueryRemoteConstruction() returns false, this object is deleted instead.

By default, QueryRemoteConstruction_ServerConstruction() does not allow clients to create objects. The client will get Replica3::DeserializeConstructionRequestRejected().
If you want the client to be able to potentially create objects for client/server, override accordingly.
Other variants of QueryRemoteConstruction_* just return true.

Note
Defaults are provided: QueryRemoteConstruction_PeerToPeer(), QueryRemoteConstruction_ServerConstruction(), QueryRemoteConstruction_ClientConstruction(). Return one of these functions for a working default for the relevant topology.
Parameters
[in] sourceConnection Which system sent us the object creation request message.
Returns
True to allow the object to pass onto DeserializeConstruction() (where it may also be rejected), false to immediately reject the remote construction request

Implements RakNet::Replica3.

template<class parent_type >
virtual RakNet::RM3QuerySerializationResult RakNet::Replica3Composite< parent_type >::QuerySerialization ( RakNet::Connection_RM3 * destinationConnection )
inlinevirtual

Implement with QuerySerialization_ClientSerializable(), QuerySerialization_ServerSerializable(), or QuerySerialization_PeerToPeer()

QuerySerialization() is a first pass query to check if a given object should serializable to a given system. The intent is that the user implements with one of the defaults for client, server, or peer to peer.
Without this function, a careless implementation would serialize an object anytime it changed to all systems. This would give you feedback loops as the sender gets the same message back from the recipient it just sent to.
If more than one system can serialize the same object then you will need to override to return true, and control the serialization result from Replica3::Serialize(). Be careful not to send back the same data to the system that just sent to you!

Returns
True to allow calling Replica3::Serialize() for this connection, false to not call.

Implements RakNet::Replica3.

template<class parent_type >
virtual RakNet::RM3SerializationResult RakNet::Replica3Composite< parent_type >::Serialize ( RakNet::SerializeParameters * serializeParameters )
inlinevirtual

Serialize our class to a bitstream.

User should implement this function to write the contents of this class to SerializationParamters::serializationBitstream.
If data only needs to be written once, you can write it to SerializeConstruction() instead for efficiency.
Transmitted over the network if it changed from the last time we called Serialize().
Called every time the time interval to ReplicaManager3::SetAutoSerializeInterval() elapses and ReplicaManager3::Update is subsequently called.

Parameters
in/out] serializeParameters Parameters controlling the serialization, including destination bitstream to write to
Returns
Whether to serialize, and if so, how to optimize the results

Implements RakNet::Replica3.

template<class parent_type >
virtual void RakNet::Replica3Composite< parent_type >::SerializeConstruction | ( | RakNet::BitStream * | constructionBitstream,
 |  | RakNet::Connection_RM3 * | destinationConnection
 | ) |  |
inlinevirtual

Write data to be sent only when the object is constructed on a remote system.

SerializeConstruction is used to write out data that you need to create this object in the context of your game, such as health, score, name. Use it for data you only need to send when the object is created.
After SerializeConstruction() is called, Serialize() will be called immediately thereafter. However, they are sent in different messages, so Serialize() may arrive a later frame than SerializeConstruction() For that reason, the object should be valid after a call to DeserializeConstruction() for at least a short time.

Note
The object's NetworkID and allocation id are handled by the system automatically, you do not need to write these values to constructionBitstream
Parameters
[out] | constructionBitstream | Destination bitstream to write your data to
[in] | destinationConnection | System that will receive this network message.

Implements RakNet::Replica3.

template<class parent_type >
virtual void RakNet::Replica3Composite< parent_type >::SerializeConstructionExisting | ( | RakNet::BitStream * | constructionBitstream,
 |  | RakNet::Connection_RM3 * | destinationConnection
 | ) |  |
inlinevirtual

Same as SerializeConstruction(), but for an object that already exists on the remote system. Used if you return RM3CS_ALREADY_EXISTS_REMOTELY from QueryConstruction

Reimplemented from RakNet::Replica3.

template<class parent_type >
virtual void RakNet::Replica3Composite< parent_type >::SerializeDestruction | ( | RakNet::BitStream * | destructionBitstream,
 |  | RakNet::Connection_RM3 * | destinationConnection
 | ) |  |
inlinevirtual

Write extra data to send with the object deletion event, if desired.

Replica3::SerializeDestruction() will be called to write any object destruction specific data you want to send with this event. destructionBitstream can be read in DeserializeDestruction()

Parameters
[out] | destructionBitstream | Bitstream for you to write to
[in] | destinationConnection | System that will receive this network message.

Implements RakNet::Replica3.

template<class parent_type >
virtual void RakNet::Replica3Composite< parent_type >::WriteAllocationID | ( | RakNet::Connection_RM3 * | destinationConnection,
 |  | RakNet::BitStream * | allocationIdBitstream
 | ) |  | const
 inlinevirtual

Write a unique identifer that can be read on a remote system to create an object of this same class.

The value written to allocationIdBitstream will be passed to Connection_RM3::AllocReplica().
Sample implementation:
{allocationIdBitstream->Write(RakNet::RakString("Soldier");}

Parameters
[out] allocationIdBitstream Bitstream for the user to write to, to identify this class

Implements RakNet::Replica3.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/ReplicaManager3.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::RPC4GlobalRegistration Class Reference

  • RPC4GlobalRegistration
Public Member Functions | List of all members
RakNet::RPC4GlobalRegistration Class Reference

Instantiate this class globally if you want to register a function with RPC4 at the global space. More...

#include <RPC4Plugin.h>

Public Member Functions

RPC4GlobalRegistration (const char *uniqueID, void(*functionPointer)(RakNet::BitStream *userData, Packet *packet))
Queue a call to RPC4::RegisterFunction() globally. Actual call occurs once RPC4 is attached to an instance of RakPeer or TCPInterface.
RPC4GlobalRegistration (const char *uniqueID, void(*functionPointer)(RakNet::BitStream *userData, Packet *packet), int callPriority)
Queue a call to RPC4::RegisterSlot() globally. Actual call occurs once RPC4 is attached to an instance of RakPeer or TCPInterface.
RPC4GlobalRegistration (const char *uniqueID, void(*functionPointer)(RakNet::BitStream *userData, RakNet::BitStream *returnData, Packet *packet))
Queue a call to RPC4::RegisterBlockingFunction() globally. Actual call occurs once RPC4 is attached to an instance of RakPeer or TCPInterface.
RPC4GlobalRegistration (const char *uniqueID, MessageID messageId)
Queue a call to RPC4::RegisterLocalCallback() globally. Actual call occurs once RPC4 is attached to an instance of RakPeer or TCPInterface.

Detailed Description

Instantiate this class globally if you want to register a function with RPC4 at the global space.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/RPC4Plugin.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::SimpleMutex Class Reference

  • SimpleMutex
List of all members
RakNet::SimpleMutex Class Reference

An easy to use mutex. More...

#include <SimpleMutex.h>

Detailed Description

An easy to use mutex.

I wrote this because the version that comes with Windows is too complicated and requires too much code to use.

Remarks
Previously I used this everywhere, and in fact for a year or two RakNet was totally threadsafe. While doing profiling, I saw that this function was incredibly slow compared to the blazing performance of everything else, so switched to single producer / consumer everywhere. Now the user thread of RakNet is not threadsafe, but it's 100X faster than before.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/SimpleMutex.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::StatisticsHistory Class Reference

  • StatisticsHistory
Public Types | List of all members
RakNet::StatisticsHistory Class Reference

Input numerical values over time. Get sum, average, highest, lowest, standard deviation on recent or all-time values. More...

#include <StatisticsHistory.h>

Public Types

enum SHDataCategory { DC_DISCRETE, DC_CONTINUOUS }

Detailed Description

Input numerical values over time. Get sum, average, highest, lowest, standard deviation on recent or all-time values.

Member Enumeration Documentation

enum RakNet::StatisticsHistory::SHDataCategory
Enumerator:
DC_DISCRETE

Insert values from one set into the other set, in time order Values at the same time end up in the final set twice Use when you have additional data points to add to a graph

DC_CONTINUOUS

Add values from one set to values from the other set, at corresponding times If value at time t does not exist in the other set, linearly extrapolate value for other set based on nearest two data points longTerm* values are unknown using this method Use to add two graphs together

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/StatisticsHistory.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::StringCompressor Class Reference

  • StringCompressor
Public Member Functions | Static Public Member Functions | List of all members
RakNet::StringCompressor Class Reference

Writes and reads strings to and from bitstreams. More...

#include <StringCompressor.h>

Public Member Functions

void | GenerateTreeFromStrings (unsigned char *input, unsigned inputLength, uint8_t languageId)
void | EncodeString (const char *input, int maxCharsToWrite, RakNet::BitStream *output, uint8_t languageId=0)
bool | DecodeString (char *output, int maxCharsToWrite, RakNet::BitStream *input, uint8_t languageId=0)

Static Public Member Functions

static StringCompressor * | Instance (void)
static void | AddReference (void)
Used so I can allocate and deallocate this singleton at runtime.
static void | RemoveReference (void)
Used so I can allocate and deallocate this singleton at runtime.

Detailed Description

Writes and reads strings to and from bitstreams.

Only works with ASCII strings. The default compression is for English. You can call GenerateTreeFromStrings to compress and decompress other languages efficiently as well.

Member Function Documentation

bool RakNet::StringCompressor::DecodeString | ( | char * | output,
 |  | int | maxCharsToWrite,
 |  | RakNet::BitStream * | input,
 |  | uint8_t | languageId = 0
 | ) |  |

Writes input to output, uncompressed. Takes care of the null terminator for you.

Parameters
[out] | output | A block of bytes to receive the output
[in] | maxCharsToWrite | Size, in bytes, of output . A NULL terminator will always be appended to the output string. If the maxCharsToWrite is not large enough, the string will be truncated.
[in] | input | The bitstream containing the compressed string
[in] | languageID | Which language to use
void RakNet::StringCompressor::EncodeString | ( | const char * | input,
 |  | int | maxCharsToWrite,
 |  | RakNet::BitStream * | output,
 |  | uint8_t | languageId = 0
 | ) |  |

Writes input to output, compressed. Takes care of the null terminator for you.

Parameters
[in] | input | Pointer to an ASCII string
[in] | maxCharsToWrite | The max number of bytes to write of input. Use 0 to mean no limit.
[out] | output | The bitstream to write the compressed string to
[in] | languageID | Which language to use
void RakNet::StringCompressor::GenerateTreeFromStrings | ( | unsigned char * | input,
 |  | unsigned | inputLength,
 |  | uint8_t | languageId
 | ) |  |

Given an array of strings, such as a chat log, generate the optimal encoding tree for it. This function is optional and if it is not called a default tree will be used instead.

Parameters
[in] | input | An array of bytes which should point to text.
[in] | inputLength | Length of input
[in] | languageID | An identifier for the language / string table to generate the tree for. English is automatically created with ID 0 in the constructor.
static StringCompressor* RakNet::StringCompressor::Instance ( void )
static

static function because only static functions can access static members The RakPeer constructor adds a reference to this class, so don't call this until an instance of RakPeer exists, or unless you call AddReference yourself.

Returns
the unique instance of the StringCompressor
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/StringCompressor.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::StringTable Class Reference

  • StringTable
Public Member Functions | Static Public Member Functions | Protected Member Functions | Static Protected Attributes | List of all members
RakNet::StringTable Class Reference

Writes a string index, instead of the whole string. More...

#include <StringTable.h>

Public Member Functions

void | AddString (const char *str, bool copyString)
void | EncodeString (const char *input, int maxCharsToWrite, RakNet::BitStream *output)
bool | DecodeString (char *output, int maxCharsToWrite, RakNet::BitStream *input)
StringTable ()
Private Constructor.

Static Public Member Functions

static StringTable * | Instance (void)
static void | AddReference (void)
Used so I can allocate and deallocate this singleton at runtime.
static void | RemoveReference (void)
Used so I can allocate and deallocate this singleton at runtime.

Protected Member Functions

void LogStringNotFound (const char *strName)

Static Protected Attributes

static StringTable * instance
Singleton instance.

Detailed Description

Writes a string index, instead of the whole string.

This is an even more efficient alternative to StringCompressor in that it writes a single byte from a lookup table and only does compression.
if the string does not already exist in the table.
All string tables must match on all systems - hence you must add all the strings in the same order on all systems.
Furthermore, this must be done before sending packets that use this class, since the strings are ordered for fast lookup. Adding after that time would mess up all the indices so don't do it.
Don't use this class to write strings which were not previously registered with AddString, since you just waste bandwidth then. Use StringCompressor instead.

Member Function Documentation

void RakNet::StringTable::AddString | ( | const char * | str,
 |  | bool | copyString
 | ) |  |

Add a string to the string table.

Parameters
[in] | str | The string to add to the string table
[in] | copyString | true to make a copy of the passed string (takes more memory), false to not do so (if your string is in static memory).
bool RakNet::StringTable::DecodeString | ( | char * | output,
 |  | int | maxCharsToWrite,
 |  | RakNet::BitStream * | input
 | ) |  |

Writes input to output, uncompressed. Takes care of the null terminator for you. Relies on the StringCompressor class, which is automatically reference counted in the constructor and destructor in RakPeer. You can call the reference counting functions yourself if you wish too.

Parameters
[out] | output | A block of bytes to receive the output
[in] | maxCharsToWrite | Size, in bytes, of output . A NULL terminator will always be appended to the output string. If the maxCharsToWrite is not large enough, the string will be truncated.
[in] | input | The bitstream containing the compressed string
void RakNet::StringTable::EncodeString | ( | const char * | input,
 |  | int | maxCharsToWrite,
 |  | RakNet::BitStream * | output
 | ) |  |

Writes input to output, compressed. Takes care of the null terminator for you. Relies on the StringCompressor class, which is automatically reference counted in the constructor and destructor in RakPeer. You can call the reference counting functions yourself if you wish too.

Parameters
[in] | input | Pointer to an ASCII string
[in] | maxCharsToWrite | The size of input
[out] | output | The bitstream to write the compressed string to
static StringTable* RakNet::StringTable::Instance ( void )
static

static function because only static functions can access static members The RakPeer constructor adds a reference to this class, so don't call this until an instance of RakPeer exists, or unless you call AddReference yourself.

Returns
the unique instance of the StringTable
void RakNet::StringTable::LogStringNotFound ( const char * strName )
protected

Called when you mess up and send a string using this class that was not registered with AddString

Parameters
[in] maxCharsToWrite Size, in bytes, of output . A NULL terminator will always be appended to the output string. If the maxCharsToWrite is not large enough, the string will be truncated.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/StringTable.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::RemoteClient Struct Reference

  • RemoteClient
List of all members
RakNet::RemoteClient Struct Reference

Stores information about a remote client. More...

#include <TCPInterface.h>

Detailed Description

Stores information about a remote client.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/TCPInterface.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::TelnetTransport Class Reference

  • TelnetTransport
Public Member Functions | List of all members
RakNet::TelnetTransport Class Reference

Use TelnetTransport to easily allow windows telnet to connect to your ConsoleServer. More...

#include <TelnetTransport.h>

Inheritance diagram for RakNet::TelnetTransport:
RakNet::TransportInterface

Public Member Functions

bool | Start (unsigned short port, bool serverMode)
void | Stop (void)
Stop the transport provider. You can clear memory and shutdown threads here.
void | Send (SystemAddress systemAddress, const char *data,...)
void | CloseConnection (SystemAddress systemAddress)
Packet * | Receive (void)
void | DeallocatePacket (Packet *packet)
SystemAddress | HasNewIncomingConnection (void)
SystemAddress | HasLostConnection (void)
CommandParserInterface * | GetCommandParser (void)

Detailed Description

Use TelnetTransport to easily allow windows telnet to connect to your ConsoleServer.

To run Windows telnet, go to your start menu, click run, and in the edit box type "telnet <IP>" where <IP> is the ip address.
of your ConsoleServer (most likely the same IP as your game).
This implementation always echos commands.

Member Function Documentation

void RakNet::TelnetTransport::CloseConnection ( SystemAddress systemAddress )
virtual

Disconnect systemAddress . The binary address and port defines the SystemAddress structure.

Parameters
[in] systemAddress The player/address to disconnect

Implements RakNet::TransportInterface.

void RakNet::TelnetTransport::DeallocatePacket ( Packet * packet )
virtual

Deallocate the Packet structure returned by Receive

Parameters
[in] The packet to deallocate

Implements RakNet::TransportInterface.

CommandParserInterface* RakNet::TelnetTransport::GetCommandParser ( void )
virtual

Your transport provider can itself have command parsers if the transport layer has user-modifiable features For example, your transport layer may have a password which you want remote users to be able to set or you may want to allow remote users to turn on or off command echo

Returns
0 if you do not need a command parser - otherwise the desired derivation of CommandParserInterface

Implements RakNet::TransportInterface.

SystemAddress RakNet::TelnetTransport::HasLostConnection ( void )
virtual

If a system loses the connection, you should queue that event and return the systemAddress/address of that player in this function.

Returns
The SystemAddress/address of the system

Implements RakNet::TransportInterface.

SystemAddress RakNet::TelnetTransport::HasNewIncomingConnection ( void )
virtual

If a new system connects to you, you should queue that event and return the systemAddress/address of that player in this function.

Returns
The SystemAddress/address of the system

Implements RakNet::TransportInterface.

Packet* RakNet::TelnetTransport::Receive ( void )
virtual

Return a string. The string should be allocated and written to Packet::data . The byte length should be written to Packet::length . The player/address should be written to Packet::systemAddress If your transport protocol adds special formatting to the data stream you should parse it out before returning it in the packet and thus only return a string in Packet::data

Returns
The packet structure containing the result of Receive, or 0 if no data is available

Implements RakNet::TransportInterface.

void RakNet::TelnetTransport::Send | ( | SystemAddress | systemAddress,
 |  | const char * | data,
 |  |  | ...
 | ) |  |
virtual

Send a null-terminated string to systemAddress If your transport method requires particular formatting of the outgoing data (e.g. you don't just send strings) you can do it here and parse it out in Receive().

Parameters
[in] | systemAddress | The player to send the string to
[in] | data | format specifier - same as RAKNET_DEBUG_PRINTF
[in] ... format specification arguments - same as RAKNET_DEBUG_PRINTF

Implements RakNet::TransportInterface.

bool RakNet::TelnetTransport::Start | ( | unsigned short | port,
 |  | bool | serverMode
 | ) |  |
virtual

Start the transport provider on the indicated port.

Parameters
[in] | port | The port to start the transport provider on
[in] | serverMode | If true, you should allow incoming connections (I don't actually use this anywhere)
Returns
Return true on success, false on failure.

Implements RakNet::TransportInterface.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/TelnetTransport.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::TransportInterface Class Reference

  • TransportInterface
Public Member Functions | List of all members
RakNet::TransportInterface Class Referenceabstract

Defines an interface that is used to send and receive null-terminated strings. More...

#include <TransportInterface.h>

Inheritance diagram for RakNet::TransportInterface:
RakNet::RakNetTransport2 RakNet::TelnetTransport

Public Member Functions

virtual bool | Start (unsigned short port, bool serverMode)=0
virtual void | Stop (void)=0
Stop the transport provider. You can clear memory and shutdown threads here.
virtual void | Send (SystemAddress systemAddress, const char *data,...)=0
virtual void | CloseConnection (SystemAddress systemAddress)=0
virtual Packet * | Receive (void)=0
virtual void | DeallocatePacket (Packet *packet)=0
virtual SystemAddress | HasNewIncomingConnection (void)=0
virtual SystemAddress | HasLostConnection (void)=0
virtual CommandParserInterface * | GetCommandParser (void)=0

Detailed Description

Defines an interface that is used to send and receive null-terminated strings.

In practice this is only used by the CommandParser system for for servers.

Member Function Documentation

virtual void RakNet::TransportInterface::CloseConnection ( SystemAddress systemAddress )
pure virtual

Disconnect systemAddress . The binary address and port defines the SystemAddress structure.

Parameters
[in] systemAddress The player/address to disconnect

Implemented in RakNet::RakNetTransport2, and RakNet::TelnetTransport.

virtual void RakNet::TransportInterface::DeallocatePacket ( Packet * packet )
pure virtual

Deallocate the Packet structure returned by Receive

Parameters
[in] The packet to deallocate

Implemented in RakNet::RakNetTransport2, and RakNet::TelnetTransport.

virtual CommandParserInterface* RakNet::TransportInterface::GetCommandParser ( void )
pure virtual

Your transport provider can itself have command parsers if the transport layer has user-modifiable features For example, your transport layer may have a password which you want remote users to be able to set or you may want to allow remote users to turn on or off command echo

Returns
0 if you do not need a command parser - otherwise the desired derivation of CommandParserInterface

Implemented in RakNet::RakNetTransport2, and RakNet::TelnetTransport.

virtual SystemAddress RakNet::TransportInterface::HasLostConnection ( void )
pure virtual

If a system loses the connection, you should queue that event and return the systemAddress/address of that player in this function.

Returns
The SystemAddress/address of the system

Implemented in RakNet::RakNetTransport2, and RakNet::TelnetTransport.

virtual SystemAddress RakNet::TransportInterface::HasNewIncomingConnection ( void )
pure virtual

If a new system connects to you, you should queue that event and return the systemAddress/address of that player in this function.

Returns
The SystemAddress/address of the system

Implemented in RakNet::RakNetTransport2, and RakNet::TelnetTransport.

virtual Packet* RakNet::TransportInterface::Receive ( void )
pure virtual

Return a string. The string should be allocated and written to Packet::data . The byte length should be written to Packet::length . The player/address should be written to Packet::systemAddress If your transport protocol adds special formatting to the data stream you should parse it out before returning it in the packet and thus only return a string in Packet::data

Returns
The packet structure containing the result of Receive, or 0 if no data is available

Implemented in RakNet::RakNetTransport2, and RakNet::TelnetTransport.

virtual void RakNet::TransportInterface::Send | ( | SystemAddress | systemAddress,
 |  | const char * | data,
 |  |  | ...
 | ) |  |
pure virtual

Send a null-terminated string to systemAddress If your transport method requires particular formatting of the outgoing data (e.g. you don't just send strings) you can do it here and parse it out in Receive().

Parameters
[in] | systemAddress | The player to send the string to
[in] | data | format specifier - same as RAKNET_DEBUG_PRINTF
[in] ... format specification arguments - same as RAKNET_DEBUG_PRINTF

Implemented in RakNet::RakNetTransport2, and RakNet::TelnetTransport.

virtual bool RakNet::TransportInterface::Start | ( | unsigned short | port,
 |  | bool | serverMode
 | ) |  |
pure virtual

Start the transport provider on the indicated port.

Parameters
[in] | port | The port to start the transport provider on
[in] | serverMode | If true, you should allow incoming connections (I don't actually use this anywhere)
Returns
Return true on success, false on failure.

Implemented in RakNet::RakNetTransport2, and RakNet::TelnetTransport.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/TransportInterface.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::VariableDeltaSerializer Class Reference

  • VariableDeltaSerializer
Public Member Functions | Protected Attributes | List of all members
RakNet::VariableDeltaSerializer Class Reference

Class to compare memory values of variables in a current state to a prior state Results of the comparisons will be written to a bitStream, such that only changed variables get written
Can be used with ReplicaManager3 to Serialize a Replica3 per-variable, rather than comparing the entire object against itself
Usage:
BR> More...

#include <VariableDeltaSerializer.h>

Public Member Functions

void | BeginUnreliableAckedSerialize (SerializationContext *context, RakNetGUID _guid, BitStream *_bitStream, uint32_t _sendReceipt)
Call before doing one or more SerializeVariable calls when the data will be sent UNRELIABLE_WITH_ACK_RECEIPT The last value of each variable will be saved per remote system. Additionally, a history of _sendReceipts is stored to determine what to resend on packetloss. When variables are lost, they will be flagged dirty and always resent to the system that lost it Disadvantages: Every variable for every remote system is copied internally, in addition to a history list of what variables changed for which _sendReceipt. Very memory and CPU intensive for multiple connections. Advantages: When data needs to be resent by RakNet, RakNet can only resend the value it currently has. This allows the application to control the resend, sending the most recent value of the variable. The end result is that bandwidth is used more efficiently because old data is never sent.
void | BeginUniqueSerialize (SerializationContext *context, RakNetGUID _guid, BitStream *_bitStream)
Call before doing one or more SerializeVariable calls for data that may be sent differently to every remote system (such as an invisibility flag that only teammates can see) The last value of each variable will be saved per remote system. Unlike BeginUnreliableAckedSerialize(), send receipts are not necessary Disadvantages: Every variable for every remote system is copied internally. Very memory and CPU intensive for multiple connections. Advantages: When data is sent differently depending on the recipient, this system can make things easier to use and is as efficient as it can be.
void | BeginIdenticalSerialize (SerializationContext *context, bool _isFirstSerializeToThisSystem, BitStream *_bitStream)
Call before doing one or more SerializeVariable calls for data that is sent with the same value to every remote system (such as health, position, etc.) This is the most common type of serialization, and also the most efficient Disadvantages: A copy of every variable still needs to be held, although only once Advantages: After the first serialization, the last serialized bitStream will be used for subsequent sends.
void | EndSerialize (SerializationContext *context)
Call after BeginUnreliableAckedSerialize(), BeginUniqueSerialize(), or BeginIdenticalSerialize(), then after calling SerializeVariable() one or more times.
void | BeginDeserialize (DeserializationContext *context, BitStream *_bitStream)
Call when you receive the BitStream written by SerializeVariable(), before calling DeserializeVariable()
void | EndDeserialize (DeserializationContext *context)
void | AddRemoteSystemVariableHistory (RakNetGUID guid)
void | RemoveRemoteSystemVariableHistory (RakNetGUID guid)
void | OnPreSerializeTick (void)
void | OnMessageReceipt (RakNetGUID guid, uint32_t receiptId, bool messageArrived)
template<class VarType >
void | SerializeVariable (SerializationContext *context, const VarType &variable)
template<class VarType >
bool | DeserializeVariable (DeserializationContext *context, VarType &variable)

Protected Attributes

DataStructures::List
< RemoteSystemVariableHistory * > 		remoteSystemVariableHistoryList

Detailed Description

Class to compare memory values of variables in a current state to a prior state Results of the comparisons will be written to a bitStream, such that only changed variables get written
Can be used with ReplicaManager3 to Serialize a Replica3 per-variable, rather than comparing the entire object against itself
Usage:
BR>

  1. Call BeginUnreliableAckedSerialize(), BeginUniqueSerialize(), or BeginIdenticalSerialize(). In the case of Replica3, this would be in the Serialize() call
  2. For each variable of the type in step 1, call Serialize(). The same variables must be serialized every tick()
  3. Call EndSerialize()
  4. Repeat step 1 for each of the other categories of how to send varaibles
    BR> On the receiver:
    BR>
  1. Call BeginDeserialize(). In the case of Replica3, this would be in the Deserialize() call
  2. Call DeserializeVariable() for each variable, in the same order as was Serialized()
  3. Call EndSerialize()
    See Also
    The ReplicaManager3 sample

Member Function Documentation

void RakNet::VariableDeltaSerializer::AddRemoteSystemVariableHistory ( RakNetGUID guid )

BeginUnreliableAckedSerialize() and BeginUniqueSerialize() require knowledge of when connections are added and dropped Call AddRemoteSystemVariableHistory() and RemoveRemoteSystemVariableHistory() to notify the system of these events

Parameters
[in] _guid Which system we are sending to
void RakNet::VariableDeltaSerializer::BeginDeserialize | ( | DeserializationContext * | context,
 |  | BitStream * | _bitStream
 | ) |  |

Call when you receive the BitStream written by SerializeVariable(), before calling DeserializeVariable()

Parameters
[in] | context | Holds the context of this group of deserialize calls. This can be a stack object just passed to the function.
[in] | _bitStream | Pass the bitStream originally passed to and written to by serialize calls
void RakNet::VariableDeltaSerializer::BeginIdenticalSerialize | ( | SerializationContext * | context,
 |  | bool | _isFirstSerializeToThisSystem,
 |  | BitStream * | _bitStream
 | ) |  |

Call before doing one or more SerializeVariable calls for data that is sent with the same value to every remote system (such as health, position, etc.) This is the most common type of serialization, and also the most efficient Disadvantages: A copy of every variable still needs to be held, although only once Advantages: After the first serialization, the last serialized bitStream will be used for subsequent sends.

Precondition
Call OnPreSerializeTick() before doing any calls to BeginIdenticalSerialize() for each of your objects, once per game tick
Parameters
[in] | context | Holds the context of this group of serialize calls. This can be a stack object just passed to the function.
[in] | _isFirstSerializeToThisSystem | Pass true if this is the first time ever serializing to this system (the initial download). This way all variables will be written, rather than checking against prior sent values.
[in] | _bitSteam | Which bitStream to write to
void RakNet::VariableDeltaSerializer::BeginUniqueSerialize | ( | SerializationContext * | context,
 |  | RakNetGUID | _guid,
 |  | BitStream * | _bitStream
 | ) |  |

Call before doing one or more SerializeVariable calls for data that may be sent differently to every remote system (such as an invisibility flag that only teammates can see) The last value of each variable will be saved per remote system. Unlike BeginUnreliableAckedSerialize(), send receipts are not necessary Disadvantages: Every variable for every remote system is copied internally. Very memory and CPU intensive for multiple connections. Advantages: When data is sent differently depending on the recipient, this system can make things easier to use and is as efficient as it can be.

Precondition
AddRemoteSystemVariableHistory() and RemoveRemoteSystemVariableHistory() must be called for new and lost connections
Parameters
[in] | context | Holds the context of this group of serialize calls. This can be a stack object just passed to the function.
[in] | _guid | Which system we are sending to
[in] | _bitSteam | Which bitStream to write to
void RakNet::VariableDeltaSerializer::BeginUnreliableAckedSerialize | ( | SerializationContext * | context,
 |  | RakNetGUID | _guid,
 |  | BitStream * | _bitStream,
 |  | uint32_t | _sendReceipt
 | ) |  |

Call before doing one or more SerializeVariable calls when the data will be sent UNRELIABLE_WITH_ACK_RECEIPT The last value of each variable will be saved per remote system. Additionally, a history of _sendReceipts is stored to determine what to resend on packetloss. When variables are lost, they will be flagged dirty and always resent to the system that lost it Disadvantages: Every variable for every remote system is copied internally, in addition to a history list of what variables changed for which _sendReceipt. Very memory and CPU intensive for multiple connections. Advantages: When data needs to be resent by RakNet, RakNet can only resend the value it currently has. This allows the application to control the resend, sending the most recent value of the variable. The end result is that bandwidth is used more efficiently because old data is never sent.

Precondition
Upon getting ID_SND_RECEIPT_LOSS or ID_SND_RECEIPT_ACKED call OnMessageReceipt()
AddRemoteSystemVariableHistory() and RemoveRemoteSystemVariableHistory() must be called for new and lost connections
Parameters
[in] | context | Holds the context of this group of serialize calls. This can be a stack object just passed to the function.
[in] | _guid | Which system we are sending to
[in] | _bitSteam | Which bitStream to write to
[in] | _sendReceipt | Returned from RakPeer::IncrementNextSendReceipt() and passed to the Send() or SendLists() function. Identifies this update for ID_SND_RECEIPT_LOSS and ID_SND_RECEIPT_ACKED
template<class VarType >
bool RakNet::VariableDeltaSerializer::DeserializeVariable | ( | DeserializationContext * | context,
 |  | VarType & | variable
 | ) |  |
inline

Call to deserialize into a variable

Precondition
You have called BeginDeserialize()
Note
Be sure to call EndDeserialize() after finishing all deserializations
Parameters
[in] | context | Same context pointer passed to BeginDeserialize()
[in] | variable | A variable to write to the bitStream passed to context
void RakNet::VariableDeltaSerializer::EndDeserialize ( DeserializationContext * context )
Parameters
[in] context Same context pointer passed to BeginDeserialize()
void RakNet::VariableDeltaSerializer::EndSerialize ( SerializationContext * context )

Call after BeginUnreliableAckedSerialize(), BeginUniqueSerialize(), or BeginIdenticalSerialize(), then after calling SerializeVariable() one or more times.

Parameters
[in] context Same context pointer passed to BeginUnreliableAckedSerialize(), BeginUniqueSerialize(), or BeginIdenticalSerialize()
void RakNet::VariableDeltaSerializer::OnMessageReceipt | ( | RakNetGUID | guid,
 |  | uint32_t | receiptId,
 |  | bool | messageArrived
 | ) |  |

Call when getting ID_SND_RECEIPT_LOSS or ID_SND_RECEIPT_ACKED for a particular system Example:

uint32_t msgNumber; memcpy(&msgNumber, packet->data+1, 4); DataStructures::List<Replica3*> replicaListOut; replicaManager.GetReplicasCreatedByMe(replicaListOut); unsigned int idx; for (idx=0; idx < replicaListOut.GetSize(); idx++) { ((SampleReplica*)replicaListOut[idx])->NotifyReplicaOfMessageDeliveryStatus(packet->guid,msgNumber, packet->data[0]==ID_SND_RECEIPT_ACKED); }

Parameters
[in] | guid | Which system we are sending to
[in] | receiptId | Encoded in bytes 1-4 inclusive of ID_SND_RECEIPT_LOSS and ID_SND_RECEIPT_ACKED
[in] | messageArrived | True for ID_SND_RECEIPT_ACKED, false otherwise
void RakNet::VariableDeltaSerializer::OnPreSerializeTick ( void )

BeginIdenticalSerialize() requires knowledge of when serialization has started for an object across multiple systems This way it can setup the flag to do new comparisons against the last sent values, rather than just resending the last sent bitStream For Replica3, overload and call this from Replica3::OnUserReplicaPreSerializeTick()

void RakNet::VariableDeltaSerializer::RemoveRemoteSystemVariableHistory ( RakNetGUID guid )

BeginUnreliableAckedSerialize() and BeginUniqueSerialize() require knowledge of when connections are added and dropped Call AddRemoteSystemVariableHistory() and RemoveRemoteSystemVariableHistory() to notify the system of these events

Parameters
[in] _guid Which system we are sending to
template<class VarType >
void RakNet::VariableDeltaSerializer::SerializeVariable | ( | SerializationContext * | context,
 |  | const VarType & | variable
 | ) |  |
inline

Call to Serialize a variable Will write to the bitSteam passed to context true, variableValue if the variable has changed or has never been written. Otherwise will write false.

Precondition
You have called BeginUnreliableAckedSerialize(), BeginUniqueSerialize(), or BeginIdenticalSerialize()
Will also require calling OnPreSerializeTick() if using BeginIdenticalSerialize()
Note
Be sure to call EndSerialize() after finishing all serializations
Parameters
[in] | context | Same context pointer passed to BeginUnreliableAckedSerialize(), BeginUniqueSerialize(), or BeginIdenticalSerialize()
[in] | variable | A variable to write to the bitStream passed to context

Member Data Documentation

DataStructures::List<RemoteSystemVariableHistory*> RakNet::VariableDeltaSerializer::remoteSystemVariableHistoryList
protected

A list of RemoteSystemVariableHistory indexed by guid, one per connection that we serialize to List is added to when SerializeConstruction is called, and removed from when SerializeDestruction is called, or when a given connection is dropped

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/VariableDeltaSerializer.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::VariableListDeltaTracker Class Reference

  • VariableListDeltaTracker
Public Member Functions | Static Public Member Functions | List of all members
RakNet::VariableListDeltaTracker Class Reference

#include <VariableListDeltaTracker.h>

Public Member Functions

template<class VarType >
bool | WriteVar (const VarType &varData)
template<class VarType >
bool | WriteVarToBitstream (const VarType &varData, RakNet::BitStream *bitStream)
Calls WriteVar. If the variable has changed, writes true, and writes the variable. Otherwise writes false.
template<class VarType >
bool | WriteVarToBitstream (const VarType &varData, RakNet::BitStream *bitStream, unsigned char *bArray, unsigned short writeOffset)
Calls WriteVarToBitstream(). Additionally, adds the boolean result of WriteVar() to boolean bit array.
void | FlagDirtyFromBitArray (unsigned char *bArray)

Static Public Member Functions

template<class VarType >
static bool ReadVarFromBitstream (VarType &varData, RakNet::BitStream *bitStream)
Paired with a call to WriteVarToBitstream(), will read a variable if it had changed. Otherwise the values remains the same.

Detailed Description

Class to write a series of variables, copy the contents to memory, and return if the newly written value is different than what was last written Can also encode the reads, writes, and results directly to/from a bitstream

Member Function Documentation

void RakNet::VariableListDeltaTracker::FlagDirtyFromBitArray ( unsigned char * bArray )

Variables flagged dirty will cause WriteVar() to return true, even if the variable had not otherwise changed This updates all the variables in the list, where in each index varsWritten is true, so will the variable at the corresponding index be flagged dirty

template<class VarType >
bool RakNet::VariableListDeltaTracker::WriteVar ( const VarType & varData )
inline

Records the passed value of the variable to memory, and returns true if the value is different from the write before that (or if it is the first write)

Precondition
Call StartWrite() before doing the first of a series of calls to WriteVar or other functions that call WriteVar
Note
Variables must be of the same type, written in the same order, each time
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/VariableListDeltaTracker.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::RakVoice Class Reference

  • RakVoice
Public Member Functions | List of all members
RakNet::RakVoice Class Reference

Voice compression and transmission interface. More...

#include <RakVoice.h>

Inheritance diagram for RakNet::RakVoice:
RakNet::PluginInterface2

Public Member Functions

void | Init (unsigned short speexSampleRate, unsigned bufferSizeBytes)
Starts RakVoice.
void | SetEncoderComplexity (int complexity)
Changes encoder complexity Specifying higher values might help when encoding non-speech sounds.
void | SetVAD (bool enable)
Enables or disables VAD (Voice Activity Detection) Enabling VAD can help reduce the amount of data transmitted, by automatically disabling outgoing data, when no voice is detected. Don't turn this off or the receive buffer fills up and you eventually get very long delays!!
void | SetNoiseFilter (bool enable)
Enables or disables the noise filter.
void | SetVBR (bool enable)
Enables or disables VBR VBR is variable bitrate. Uses less bandwidth but more CPU if on.
int | GetEncoderComplexity (void)
Returns the complexity of the encoder.
bool | IsVADActive (void)
Returns current state of VAD.
bool | IsNoiseFilterActive ()
Returns the current state of the noise filter.
bool | IsVBRActive ()
Returns the current state of VBR.
void | Deinit (void)
Shuts down RakVoice.
void | RequestVoiceChannel (RakNetGUID recipient)
Opens a channel to another connected system You will get ID_RAKVOICE_OPEN_CHANNEL_REPLY on success.
void | CloseVoiceChannel (RakNetGUID recipient)
Closes an existing voice channel. Other system will get ID_RAKVOICE_CLOSE_CHANNEL.
void | CloseAllChannels (void)
Closes all existing voice channels Other systems will get ID_RAKVOICE_CLOSE_CHANNEL.
bool | SendFrame (RakNetGUID recipient, void *inputBuffer)
Sends voice data to a system on an open channel.
bool | IsSendingVoiceDataTo (RakNetGUID recipient)
Returns if we are currently sending voice data, accounting for voice activity detection.
void | ReceiveFrame (void *outputBuffer)
Gets decoded voice data, from one or more remote senders.
int | GetSampleRate (void) const
int | GetBufferSizeBytes (void) const
bool | IsInitialized (void) const
RakPeerInterface * | GetRakPeerInterface (void) const
unsigned | GetBufferedBytesToSend (RakNetGUID guid) const
unsigned | GetBufferedBytesToReturn (RakNetGUID guid) const
void | SetLoopbackMode (bool enabled)
bool | IsLoopbackMode (void) const
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Detailed Description

Voice compression and transmission interface.

Member Function Documentation

void RakNet::RakVoice::CloseVoiceChannel ( RakNetGUID recipient )

Closes an existing voice channel. Other system will get ID_RAKVOICE_CLOSE_CHANNEL.

Parameters
[in] recipient Which system to close a channel with
unsigned RakNet::RakVoice::GetBufferedBytesToReturn ( RakNetGUID guid ) const

How many bytes are on the read buffer, waiting to be passed to a call to ReceiveFrame This should remain at a fairly small near-constant size as incoming data is read out at the same rate as outgoing data from the remote system

Parameters
[in] guid The system to query, or RakNet::UNASSIGNED_SYSTEM_ADDRESS for the sum of all channels.
Returns
Number of bytes on the read buffer.
unsigned RakNet::RakVoice::GetBufferedBytesToSend ( RakNetGUID guid ) const

How many bytes are on the write buffer, waiting to be passed to a call to RakPeer::Send (internally) This should remain at a fairly small near-constant size as outgoing data is sent to the Send function

Parameters
[in] guid The system to query, or RakNet::UNASSIGNED_SYSTEM_ADDRESS for the sum of all channels.
Returns
Number of bytes on the write buffer
int RakNet::RakVoice::GetBufferSizeBytes ( void ) const

Returns the buffer size in bytes, as passed to Init

Returns
buffer size in bytes
int RakNet::RakVoice::GetEncoderComplexity ( void )

Returns the complexity of the encoder.

Precondition
Only applies to encoder.
Returns
a value from 0 to 10.
RakPeerInterface* RakNet::RakVoice::GetRakPeerInterface ( void ) const

Returns the RakPeerInterface that the object is attached to.

Returns
the respective RakPeerInterface, or NULL not attached.
int RakNet::RakVoice::GetSampleRate ( void ) const

Returns the value sample rate, as passed to Init

Returns
the sample rate
void RakNet::RakVoice::Init | ( | unsigned short | speexSampleRate,
 |  | unsigned | bufferSizeBytes
 | ) |  |

Starts RakVoice.

Parameters
[in] | speexSampleRate | 8000, 16000, or 32000
[in] | bufferSizeBytes | How many bytes long inputBuffer and outputBuffer are in SendFrame and ReceiveFrame are. Should be your sample size * the number of samples to encode at once.
bool RakNet::RakVoice::IsInitialized ( void ) const

Returns true or false, indicating if the object has been initialized

Returns
true if initialized, false otherwise.
bool RakNet::RakVoice::IsLoopbackMode ( void ) const

Returns true or false, indicating if the loopback mode is enabled

Returns
true if enabled, false otherwise.
bool RakNet::RakVoice::IsNoiseFilterActive ( )

Returns the current state of the noise filter.

Precondition
Only applies to encoder.
Returns
true if the noise filter is active, false otherwise.
bool RakNet::RakVoice::IsSendingVoiceDataTo ( RakNetGUID recipient )

Returns if we are currently sending voice data, accounting for voice activity detection.

Parameters
[in] Which system to check
Returns
If we are sending voice data for the specified system
bool RakNet::RakVoice::IsVADActive ( void )

Returns current state of VAD.

Precondition
Only applies to encoder.
Returns
true if VAD is enable, false otherwise
bool RakNet::RakVoice::IsVBRActive ( )

Returns the current state of VBR.

Precondition
Only applies to encoder.
Returns
true if VBR is active, false otherwise.
virtual void RakNet::RakVoice::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
virtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::RakVoice::OnReceive ( Packet * packet )
virtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

void RakNet::RakVoice::ReceiveFrame ( void * outputBuffer )

Gets decoded voice data, from one or more remote senders.

Parameters
[out] outputBuffer The voice data. The size of outputBuffer should be what was specified as bufferSizeBytes in Init
void RakNet::RakVoice::RequestVoiceChannel ( RakNetGUID recipient )

Opens a channel to another connected system You will get ID_RAKVOICE_OPEN_CHANNEL_REPLY on success.

Parameters
[in] recipient Which system to open a channel to
bool RakNet::RakVoice::SendFrame | ( | RakNetGUID | recipient,
 |  | void * | inputBuffer
 | ) |  |

Sends voice data to a system on an open channel.

Precondition
recipient must refer to a system with an open channel via RequestVoiceChannel
Parameters
[in] | recipient | The system to send voice data to
[in] | inputBuffer | The voice data. The size of inputBuffer should be what was specified as bufferSizeBytes in Init
void RakNet::RakVoice::SetEncoderComplexity ( int complexity )

Changes encoder complexity Specifying higher values might help when encoding non-speech sounds.

Parameters
[in] complexity 0 to 10. The higher the value, the more CPU it needs. Recommended values are from 2 to 4.
void RakNet::RakVoice::SetLoopbackMode ( bool enabled )

Enables/disables loopback mode

Parameters
[in] true to enable, false to disable
void RakNet::RakVoice::SetNoiseFilter ( bool enable )

Enables or disables the noise filter.

Precondition
Only applies to encoder.
Parameters
[in] enable true to enable, false to disable.
void RakNet::RakVoice::SetVAD ( bool enable )

Enables or disables VAD (Voice Activity Detection) Enabling VAD can help reduce the amount of data transmitted, by automatically disabling outgoing data, when no voice is detected. Don't turn this off or the receive buffer fills up and you eventually get very long delays!!

Precondition
Only applies to encoder.
Parameters
[in] enable true to enable, false to disable. True by default
void RakNet::RakVoice::SetVBR ( bool enable )

Enables or disables VBR VBR is variable bitrate. Uses less bandwidth but more CPU if on.

Precondition
Only applies to encoder.
Parameters
[in] enable true to enable VBR, false to disable
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/RakVoice.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::AutopatcherServerLoadNotifier_Printf Class Reference

  • AutopatcherServerLoadNotifier_Printf
List of all members
RakNet::AutopatcherServerLoadNotifier_Printf Class Reference

Sample implementation of AutopatcherServerLoadNotifier using printf. More...

#include <AutopatcherServer.h>

Inherits RakNet::AutopatcherServerLoadNotifier.

Additional Inherited Members

- Public Types inherited from RakNet::AutopatcherServerLoadNotifier
enum | RequestType
The server only handles two types of requests - to get a change list since a certain date, or to get a patch.
- Public Member Functions inherited from RakNet::AutopatcherServerLoadNotifier
virtual void | OnQueueUpdate (SystemAddress remoteSystem, AutopatcherServerLoadNotifier::RequestType requestType, AutopatcherServerLoadNotifier::QueueOperation queueOperation, AutopatcherServerLoadNotifier::AutopatcherState *autopatcherState)
virtual void | OnGetPatchCompleted (SystemAddress remoteSystem, AutopatcherServerLoadNotifier::PatchResult patchResult, AutopatcherServerLoadNotifier::AutopatcherState *autopatcherState)

Detailed Description

Sample implementation of AutopatcherServerLoadNotifier using printf.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Autopatcher/AutopatcherServer.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::AutopatcherServer Class Reference

  • AutopatcherServer
Classes | Public Member Functions | Protected Member Functions | List of all members
RakNet::AutopatcherServer Class Reference

The server plugin for the autopatcher. Must be running for the client to get patches. More...

#include <AutopatcherServer.h>

Inheritance diagram for RakNet::AutopatcherServer:
RakNet::PluginInterface2 RakNet::FileListProgress

Classes

struct ResultTypeAndBitstream

Public Member Functions

void | StartThreads (int numThreads, int numSQLConnections, AutopatcherRepositoryInterface **sqlConnectionPtrArray)
void | CacheMostRecentPatch (const char *applicationName)
void | SetUploadSendParameters (PacketPriority _priority, char _orderingChannel)
void | SetFileListTransferPlugin (FileListTransfer *flt)
void | SetMaxConurrentUsers (unsigned int _maxConcurrentUsers)
unsigned int | GetMaxConurrentUsers (void) const
void | SetLoadManagementCallback (AutopatcherServerLoadNotifier *asumc)
void | SetAllowDownloadOfOriginalUnmodifiedFiles (bool allow)
void | Clear (void)
Clear buffered input and output.
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | Update (void)
Update is called every time a packet is checked for .
virtual PluginReceiveResult | OnReceive (Packet *packet)
virtual void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Protected Member Functions

virtual void | OnFilePushesComplete (SystemAddress systemAddress, unsigned short setID)
This function is called when all files have been read and are being transferred to a remote system.
virtual void | OnSendAborted (SystemAddress systemAddress)
This function is called when a send to a system was aborted (probably due to disconnection)

Additional Inherited Members

- Private Member Functions inherited from RakNet::FileListProgress
virtual void | OnAddFilesFromDirectoryStarted (FileList *fileList, char *dir)
First callback called when FileList::AddFilesFromDirectory() starts.
virtual void | OnDirectory (FileList *fileList, char *dir, unsigned int directoriesRemaining)
Called for each directory, when that directory begins processing.
virtual void | OnFile (FileList *fileList, char *dir, char *fileName, unsigned int fileSize)
Called for each file, when that file begins processing.
virtual void | OnFilePush (const char *fileName, unsigned int fileLengthBytes, unsigned int offset, unsigned int bytesBeingSent, bool done, SystemAddress targetSystem, unsigned short setId)
This function is called when we are sending a file to a remote system.
- Private Member Functions inherited from RakNet::IncrementalReadInterface
virtual unsigned int | GetFilePart (const char *filename, unsigned int startReadBytes, unsigned int numBytesToRead, void *preallocatedDestination, FileListNodeContext context)

Detailed Description

The server plugin for the autopatcher. Must be running for the client to get patches.

Member Function Documentation

void RakNet::AutopatcherServer::CacheMostRecentPatch ( const char * applicationName )

Load the most recent patch in memory and keep it there This can take a lot of memory, but greatly speeds up serving patches, since disk access is not incurred

Parameters
[in] applicationName 0 means all, otherwise the name of the application to cache
unsigned int RakNet::AutopatcherServer::GetMaxConurrentUsers ( void ) const
Returns
Returns what was passed to SetMaxConurrentUsers();
virtual void RakNet::AutopatcherServer::OnClosedConnection | ( | const SystemAddress & | systemAddress,
 |  | RakNetGUID | rakNetGUID,
 |  | PI2_LostConnectionReason | lostConnectionReason
 | ) |  |
virtual

Called when a connection is dropped because the user called RakPeer::CloseConnection() for a particular system

Parameters
[in] | systemAddress | The system whose connection was closed
[in] | rakNetGuid | The guid of the specified system
[in] | lostConnectionReason | How the connection was closed: manually, connection lost, or notification of disconnection

Reimplemented from RakNet::PluginInterface2.

virtual PluginReceiveResult RakNet::AutopatcherServer::OnReceive ( Packet * packet )
virtual

OnReceive is called for every packet.

Parameters
[in] packet the packet that is being returned to the user
Returns
True to allow the game and other plugins to get this message, false to absorb it

Reimplemented from RakNet::PluginInterface2.

void RakNet::AutopatcherServer::SetAllowDownloadOfOriginalUnmodifiedFiles ( bool allow )

Set whether or not the client can download files that were never modified, that they do not have Defaults to true Set to false to disallow downloading the entire game through the autopatcher. In this case, the user must have a copy of the game through other means (such as a CD install)

Parameters
[in] allow True to allow downloading original game files, false to disallow
void RakNet::AutopatcherServer::SetFileListTransferPlugin ( FileListTransfer * flt )

This plugin has a dependency on the FileListTransfer plugin, which it uses to actually send the files. So you need an instance of that plugin registered with RakPeerInterface, and a pointer to that interface should be passed here.

Parameters
[in] flt A pointer to a registered instance of FileListTransfer
void RakNet::AutopatcherServer::SetLoadManagementCallback ( AutopatcherServerLoadNotifier * asumc )

Set a callback to get notifications of when user requests are queued and processed This is primarily of use to load balance the server

Parameters
[in] asumc An externally allocated instance of AutopatcherServerLoadNotifier. Pass 0 to disable.
void RakNet::AutopatcherServer::SetMaxConurrentUsers ( unsigned int _maxConcurrentUsers )

This is the maximum number of users the patcher will service at one time (generally about equal to the number of downloads at once) If this limit is exceeded, the request packet will be put into a queue and serviced when slots are available Defaults to 0 (unlimited)

Parameters
[in] maxConcurrentUsers Pass 0 for unlimited, otherwise the max users to serve at once
void RakNet::AutopatcherServer::SetUploadSendParameters | ( | PacketPriority | _priority,
 |  | char | _orderingChannel
 | ) |  |

What parameters to use for the RakPeerInterface::Send() call when uploading files.

Parameters
[in] | _priority | See RakPeerInterface::Send()
[in] | _orderingChannel | See RakPeerInterface::Send()
void RakNet::AutopatcherServer::StartThreads | ( | int | numThreads,
 |  | int | numSQLConnections,
 |  | AutopatcherRepositoryInterface ** | sqlConnectionPtrArray
 | ) |  |

DO THIS FIRST Implement to start the worker threads. Before this is called, no queries will be performed When this is called, AllocAutopatcherRepositoryInterface will be called with repositoryAllocationParameters The system works in three phases.

  1. Get change list since a given date. This uses one of the worker threads.
  2. If either running a full scan, or files have changed since a given date, get the list of patches. This uses one of the worker threads and does an intensive comparison of the hashes the client has vs. the files in the database
  3. If the total amount of data to be sent exceeds DATABASE_READ_CHUNK_SIZE, defined in the cpp file, then the database will be read from incrementally during this download phase. This uses an sql connection object, which may or may not be also in use by one of the threads. If you have more sql connections than threads, this tends to prevent the same connection from being used to incrementally read files for a downloader, and to be used in a worker thread.
    Parameters
    [in] | numThreads | Number of processing threads, which handles the CPU intensive tasks of generating a patch list and comparing files
    [in] | numSQLConnections | Number of SQL connection objects passed to sqlConnectionPtrArray. Must be greater than or equal to numThreads
    [in] | sqlConnectionPtrArray | List of pointers to AutopatcherRepositoryInterface. C++ note: Don't just cast a derived class array, you need to take the pointer address of each item
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Autopatcher/AutopatcherServer.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::AutopatcherServer::ResultTypeAndBitstream Struct Reference

  • AutopatcherServer
  • ResultTypeAndBitstream
List of all members
RakNet::AutopatcherServer::ResultTypeAndBitstream Struct Reference

#include <AutopatcherServer.h>

Detailed Description

Deprecated:
The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Autopatcher/AutopatcherServer.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::AutopatcherPostgreRepository Class Reference

  • AutopatcherPostgreRepository
Public Member Functions | List of all members
RakNet::AutopatcherPostgreRepository Class Reference

#include <AutopatcherPostgreRepository.h>

Inheritance diagram for RakNet::AutopatcherPostgreRepository:
RakNet::AutopatcherRepositoryInterface

Public Member Functions

virtual bool | CreateAutopatcherTables (void)
bool | DestroyAutopatcherTables (void)
bool | AddApplication (const char *applicationName, const char *userName)
bool | RemoveApplication (const char *applicationName)
virtual bool | UpdateApplicationFiles (const char *applicationName, const char *applicationDirectory, const char *userName, FileListProgress *cb)
virtual bool | GetChangelistSinceDate (const char *applicationName, FileList *addedOrModifiedFilesWithHashData, FileList *deletedFiles, double sinceDate)
virtual int | GetPatches (const char *applicationName, FileList *input, bool allowDownloadOfOriginalUnmodifiedFiles, FileList *patchList)
virtual bool | GetMostRecentChangelistWithPatches (RakNet::RakString &applicationName, FileList *patchedFiles, FileList *addedFiles, FileList *addedOrModifiedFileHashes, FileList *deletedFiles, double *priorRowPatchTime, double *mostRecentRowPatchTime)
virtual const char * | GetLastError (void) const
If any of the above functions fail, the error string is stored internally. Call this to get it.
virtual unsigned int | GetFilePart (const char *filename, unsigned int startReadBytes, unsigned int numBytesToRead, void *preallocatedDestination, FileListNodeContext context)
virtual const int | GetIncrementalReadChunkSize (void) const
- Public Member Functions inherited from PostgreSQLInterface
bool | Connect (const char *conninfo)
void | AssignConnection (PGconn *_pgConn)
Use a connection allocated elsewehre.
PGconn * | GetPGConn (void) const
Get the instance of PGconn.
void | Disconnect (void)
Disconnect from the database.
virtual const char * | GetLastError (void) const
If any of the above functions fail, the error string is stored internally. Call this to get it.

Detailed Description

An implementation of the AutopatcherRepositoryInterface to use PostgreSQL to store the relevant data

Member Function Documentation

bool RakNet::AutopatcherPostgreRepository::AddApplication | ( | const char * | applicationName,
 |  | const char * | userName
 | ) |  |

Add an application for use by files. Call this second.

Parameters
[in] | applicationName | A null terminated string.
[in] | userName | Stored in the database, but otherwise unused. Useful to track who added this application.
Returns
True on success, false on failure.
virtual bool RakNet::AutopatcherPostgreRepository::CreateAutopatcherTables ( void )
virtual

Create the tables used by the autopatcher, for all applications. Call this first.

Returns
True on success, false on failure.
bool RakNet::AutopatcherPostgreRepository::DestroyAutopatcherTables ( void )

Destroy the tables used by the autopatcher. Don't call this unless you don't want to use the autopatcher anymore, or are testing.

Returns
True on success, false on failure.
virtual bool RakNet::AutopatcherPostgreRepository::GetChangelistSinceDate | ( | const char * | applicationName,
 |  | FileList * | addedOrModifiedFilesWithHashData,
 |  | FileList * | deletedFiles,
 |  | double | sinceDate
 | ) |  |
virtual

Get list of files added and deleted since a certain date. This is used by AutopatcherServer and not usually explicitly called.

Parameters
[in] | applicationName | A null terminated string previously passed to AddApplication
[out] | addedFiles | A list of the current versions of filenames with SHA1_LENGTH byte hashes as their data that were created after sinceData
[out] | deletedFiles | A list of the current versions of filenames that were deleted after sinceData
[in] | sinceDate
Returns
True on success, false on failure.

Implements RakNet::AutopatcherRepositoryInterface.

virtual unsigned int RakNet::AutopatcherPostgreRepository::GetFilePart | ( | const char * | filename,
 |  | unsigned int | startReadBytes,
 |  | unsigned int | numBytesToRead,
 |  | void * | preallocatedDestination,
 |  | FileListNodeContext | context
 | ) |  |
virtual

Read part of a file into destination Return the number of bytes written. Return 0 when file is done.

Parameters
[in] | filename | Filename to read
[in] | startReadBytes | What offset from the start of the file to read from
[in] | numBytesToRead | How many bytes to read. This is also how many bytes have been allocated to preallocatedDestination
[out] | preallocatedDestination | Write your data here
Returns
The number of bytes read, or 0 if none
virtual const int RakNet::AutopatcherPostgreRepository::GetIncrementalReadChunkSize ( void ) const
virtual
Returns
Passed to FileListTransfer::Send() as the _chunkSize parameter.

Implements RakNet::AutopatcherRepositoryInterface.

virtual bool RakNet::AutopatcherPostgreRepository::GetMostRecentChangelistWithPatches | ( | RakNet::RakString & | applicationName,
 |  | FileList * | patchedFiles,
 |  | FileList * | addedFiles,
 |  | FileList * | addedOrModifiedFileHashes,
 |  | FileList * | deletedFiles,
 |  | double * | priorRowPatchTime,
 |  | double * | mostRecentRowPatchTime
 | ) |  |
virtual

For the most recent update, return files that were patched, added, or deleted. For files that were patched, return both the patch in patchedFiles and the current version in updatedFiles

Parameters
[in,out] | applicationName | Name of the application to get patches for. If empty, uses the most recently updated application, and the string will be updated to reflect this name.
[out] | patchedFiles | A list of patched files with op PC_HASH_2_WITH_PATCH. It has 2 hashes, the priorHash and the currentHash. The currentHash is checked on the client after patching for patch success. The priorHash is checked in AutopatcherServer::OnGetPatch() to see if the client is able to hash with the version they currently have
[out] | patchedFiles | A list of new files. It contains the actual data in addition to the filename
[out] | addedOrModifiedFileHashes | A list of file hashes that were either modified or new. This is returned to the client when replying to ID_AUTOPATCHER_CREATION_LIST, which tells the client what files have changed on the server since a certain date
[out] | deletedFiles | A list of the current versions of filenames that were deleted in the most recent patch
[out] | whenPatched | time in seconds since epoch when patched. Use time() function to get this in C
Returns
true on success, false on failure

Implements RakNet::AutopatcherRepositoryInterface.

virtual int RakNet::AutopatcherPostgreRepository::GetPatches | ( | const char * | applicationName,
 |  | FileList * | input,
 |  | bool | allowDownloadOfOriginalUnmodifiedFiles,
 |  | FileList * | patchList
 | ) |  |
virtual

Get patches (or files) for every file in input, assuming that input has a hash for each of those files. This is used by AutopatcherServer and not usually explicitly called.

Parameters
[in] | applicationName | A null terminated string previously passed to AddApplication
[in] | input | A list of files with hashes to get from the database. If this hash exists, a patch to the current version is returned if this file is not the current version. Otherwise the current version is returned.
[in] | allowDownloadOfOriginalUnmodifiedFiles | If false, then if a file has never been modified and there is no hash for it in the input list, return false. This is to prevent clients from just downloading the game from the autopatcher.
[out] | patchList | A list of files with either the filedata or the patch. This is a subset of input. The context data for each file will be either PC_WRITE_FILE (to just write the file) or PC_HASH_WITH_PATCH (to patch). If PC_HASH_WITH_PATCH, then the file contains a SHA1_LENGTH byte patch followed by the hash. The datalength is patchlength + SHA1_LENGTH
Returns
1 on success, 0 on database failure, -1 on tried to download original unmodified file

Implements RakNet::AutopatcherRepositoryInterface.

bool RakNet::AutopatcherPostgreRepository::RemoveApplication ( const char * applicationName )

Remove an application and files used by that application.

Parameters
[in] applicationName A null terminated string previously passed to AddApplication
Returns
True on success, false on failure.
virtual bool RakNet::AutopatcherPostgreRepository::UpdateApplicationFiles | ( | const char * | applicationName,
 |  | const char * | applicationDirectory,
 |  | const char * | userName,
 |  | FileListProgress * | cb
 | ) |  |
virtual

Update all the files for an application to match what is at the specified directory. Call this third. Be careful not to call this with the wrong directory. This is implemented in a Begin and Rollback block so you won't a messed up database from get partial updates.

Note
It takes 10 bytes of memory to create a patch per byte on disk for a file. So you should not have any files larger than 1/10th your server memory.
Parameters
[in] | applicationName | A null terminated string previously passed to AddApplication
[in] | applicationDirectory | The base directory of your application. All files in this directory and subdirectories are added.
[in] | userName | Stored in the database, but otherwise unused. Useful to track who added this revision
[in] | cb | Callback to get progress updates. Pass 0 to not use.
Returns
True on success, false on failure.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Autopatcher/AutopatcherPostgreRepository/AutopatcherPostgreRepository.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::IndexedIntegerValue Struct Reference

  • IndexedIntegerValue
Public Attributes | List of all members
RakNet::IndexedIntegerValue Struct Reference

Used to unify different platforms for room search and search properties. Only applies if specifically used. More...

#include <Lobby2Message.h>

Public Attributes

unsigned int | index
Index of the value to set, required.
unsigned int | value
Value to set.
int | searchOperator
Used for room searches only, -1 means use default equals.

Detailed Description

Used to unify different platforms for room search and search properties. Only applies if specifically used.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::IndexedBinaryValue Struct Reference

  • IndexedBinaryValue
Public Attributes | List of all members
RakNet::IndexedBinaryValue Struct Reference

Used to unify different platforms for room search and search properties. Only applies if specifically used. More...

#include <Lobby2Message.h>

Public Attributes

unsigned int | index
Index of the value to set, required.
char * | value
Value is deallocated in the destructor, use rakMalloc_Ex to allocate!
unsigned short | valueByteLength
Length of value.
int | searchOperator
Used for room searches only, -1 means use default equals.
unsigned char | type
Used on 360 only. -1 means use default BINARY.

Detailed Description

Used to unify different platforms for room search and search properties. Only applies if specifically used.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Client_SetPresence Struct Reference

  • Client_SetPresence
Public Member Functions | Public Attributes | List of all members
RakNet::Client_SetPresence Struct Reference

Sets in-memory information about your login state, such as which game you are playing, or if you are playing a game Online friends will be notified when you presence changes For the XBOX, just use XUserSetProperty and XUserSetContext directly, as there is no analogue to this function. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Client_SetPresence:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | PrevalidateInput (void)
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Public Attributes

RakNet::Lobby2Presence presence
- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Sets in-memory information about your login state, such as which game you are playing, or if you are playing a game Online friends will be notified when you presence changes For the XBOX, just use XUserSetProperty and XUserSetContext directly, as there is no analogue to this function.

Member Function Documentation

virtual bool RakNet::Client_SetPresence::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_SetPresence::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_SetPresence::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_SetPresence::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

Member Data Documentation

RakNet::Lobby2Presence RakNet::Client_SetPresence::presence
Parameters
[in] Presence info to set.
The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Client_GetPresence Struct Reference

  • Client_GetPresence
Public Member Functions | Public Attributes | List of all members
RakNet::Client_GetPresence Struct Reference

Gets in-memory information about a user's login state, such as which game they are playing, or if they are playing a game This can also be a quick way to query if a user is logged in or not. If they are not logged in, presence will be set to Lobby2Presence::NOT_ONLINE. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Client_GetPresence:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | PrevalidateInput (void)
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Public Attributes

RakNet::RakString userHandle
RakNet::Lobby2Presence presence
- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Gets in-memory information about a user's login state, such as which game they are playing, or if they are playing a game This can also be a quick way to query if a user is logged in or not. If they are not logged in, presence will be set to Lobby2Presence::NOT_ONLINE.

Member Function Documentation

virtual bool RakNet::Client_GetPresence::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_GetPresence::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_GetPresence::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Client_GetPresence::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

Member Data Documentation

RakNet::Lobby2Presence RakNet::Client_GetPresence::presence
Parameters
[out] Presence info to set.
RakNet::RakString RakNet::Client_GetPresence::userHandle
Parameters
[in] Which user we are looking up ( can be ourselves )
The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: RakNet::Clans_RejectJoinRequest Struct Reference

  • Clans_RejectJoinRequest
Public Member Functions | List of all members
RakNet::Clans_RejectJoinRequest Struct Reference

Rejects a clan join request from requestingUserHandle. Send an email from myPrimaryKey to requestingUserHandle with the specified subject and body. More...

#include <Lobby2Message.h>

Inheritance diagram for RakNet::Clans_RejectJoinRequest:
RakNet::Lobby2Message

Public Member Functions

virtual bool | RequiresAdmin (void) const
virtual bool | RequiresRankingPermission (void) const
virtual bool | CancelOnDisconnect (void) const
virtual bool | RequiresLogin (void) const
virtual void | Serialize (bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream)
Overridable serialization of the contents of this message. Defaults to SerializeBase()
virtual bool | PrevalidateInput (void)
- Public Member Functions inherited from RakNet::Lobby2Message
virtual Lobby2MessageID | GetID (void) const =0
Every message has an ID identifying it across the network.
virtual bool | ClientImpl (RakNet::Lobby2Plugin *client)
virtual void | CallCallback (Lobby2Callbacks *cb)=0
virtual bool | ServerPreDBMemoryImpl (Lobby2Server *server, RakString userHandle)
virtual void | ServerPostDBMemoryImpl (Lobby2Server *server, RakString userHandle)
Do any Lobby2Server functionality after the message has been processed by the database, in the server thread.
virtual bool | ServerDBImpl (Lobby2ServerCommand *command, void *databaseInterface)
bool | ValidateHandle (RakNet::RakString *handle)
bool | ValidateBinary (RakNetSmartPtr< BinaryDataBlock >binaryDataBlock)
Binary data cannot be longer than L2_MAX_BINARY_DATA_LENGTH.
bool | ValidateRequiredText (RakNet::RakString *text)
Required text cannot be empty.
bool | ValidatePassword (RakNet::RakString *text)
Passwords must contain at least 5 characters.
bool | ValidateEmailAddress (RakNet::RakString *text)
Check email address format.
virtual const char * | GetName (void) const =0
Convert the enumeration representing this message to a string, and return it. Done automatically by macros.
virtual void | DebugMsg (RakNet::RakString &out) const =0
Write the result of this message to out(). Done automatically by macros.
virtual void | DebugPrintf (void) const
Print the result of DebugMsg.

Additional Inherited Members

- Public Attributes inherited from RakNet::Lobby2Message
RakNet::Lobby2ResultCode | resultCode
Result of the operation. L2RC_SUCCESS means the result completed. Anything else means an error.
uint32_t | callbackId
int | extendedResultCode
Used for consoles.
uint64_t | requestId

Detailed Description

Rejects a clan join request from requestingUserHandle. Send an email from myPrimaryKey to requestingUserHandle with the specified subject and body.

Member Function Documentation

virtual bool RakNet::Clans_RejectJoinRequest::CancelOnDisconnect ( void ) const
inlinevirtual

Should this message not be processed on the server if the requesting user disconnects before it completes? This should be true for functions that only return data. False for functions that affect other users, or change the database

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_RejectJoinRequest::PrevalidateInput ( void )
virtual

If data members can be validated for correctness in the server's main thread, override this function and do those checks here.

Returns
True for input OK. False if the input is bad and does not need to be further processed in the database threads.

Reimplemented from RakNet::Lobby2Message.

virtual bool RakNet::Clans_RejectJoinRequest::RequiresAdmin ( void ) const
inlinevirtual

Is this message something that should only be run by a system with admin privileges? Set admin privileges with Lobby2Server::AddAdminAddress()

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_RejectJoinRequest::RequiresLogin ( void ) const
inlinevirtual

Does this function require logging into the server before it can be executed? If true, the user id and user handle will be automatically inferred by the last login by looking up the sender's system address. If false, the message should include the username so the database query can lookup which user is performing this operation.

Implements RakNet::Lobby2Message.

virtual bool RakNet::Clans_RejectJoinRequest::RequiresRankingPermission ( void ) const
inlinevirtual

Is this message something that should only be run by a system with ranking upload priviledges? Set ranking privileges with Lobby2Server::AddRankingAddress()

Implements RakNet::Lobby2Message.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Message.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Lobby2Presence Struct Reference

  • Lobby2Presence
Public Types | Public Attributes | List of all members
RakNet::Lobby2Presence Struct Reference

#include <Lobby2Presence.h>

Public Types

enum Status {
UNDEFINED, NOT_ONLINE, AWAY, DO_NOT_DISTURB,
MINIMIZED, TYPING, VIEWING_PROFILE, EDITING_PROFILE,
IN_LOBBY, IN_ROOM, IN_GAME
}

Public Attributes

bool isVisible
Visibility flag. This is not enforced by the server, so if you want a user's presence to be not visible, just don't display it on the client.
RakString titleNameOrID
RakString statusString
Anything you want.

Detailed Description

Lobby2Presence is information about your online status. It is only held in memory, so is lost when you go offline. Set by calling Client_SetPresence and retrieve with Client_GetPresence

Member Enumeration Documentation

enum RakNet::Lobby2Presence::Status
Enumerator:
UNDEFINED

Set by the constructor, meaning it was never set. This is the default if a user is online, but SetPresence() was never called.

NOT_ONLINE

Returned by Client_GetPresence() if you query for a user that is not online, whether or not SetPresence was ever called().

AWAY

Set by the user (you)

DO_NOT_DISTURB

Set by the user (you)

MINIMIZED

Set by the user (you)

TYPING

Set by the user (you)

VIEWING_PROFILE

Set by the user (you)

EDITING_PROFILE

Set by the user (you)

IN_LOBBY

Set by the user (you)

IN_ROOM

Set by the user (you)

IN_GAME

Set by the user (you)

Member Data Documentation

RakString RakNet::Lobby2Presence::titleNameOrID

Although game name is also present in the titleNameOrID member of Client_Login, this is the visible name returned by presence queries That is because Client_Login::titleNameOrID member is optional, for example for lobbies that support multiple titles. Set by the user (you) or leave blank if desired.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Presence.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Lobby2ServerCommand Struct Reference

  • Lobby2ServerCommand
List of all members
RakNet::Lobby2ServerCommand Struct Reference

#include <Lobby2Server.h>

Detailed Description

Commands are either messages from remote systems, or can be run by the local system

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/Lobby2Server.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::Lobby2Server_PGSQL Class Reference

  • Lobby2Server_PGSQL
Public Member Functions | List of all members
RakNet::Lobby2Server_PGSQL Class Reference

PostgreSQL specific functionality to the lobby server. More...

#include <Lobby2Server_PGSQL.h>

Inheritance diagram for RakNet::Lobby2Server_PGSQL:
RakNet::Lobby2Server RakNet::Lobby2Plugin RakNet::PluginInterface2

Public Member Functions

virtual bool | ConnectToDB (const char *conninfo, int numWorkerThreads)
virtual void | AddInputFromThread (Lobby2Message *msg, unsigned int targetUserId, RakNet::RakString targetUserHandle)
Add input to the worker threads, from a thread already running.
virtual void | AddOutputFromThread (Lobby2Message *msg, unsigned int targetUserId, RakNet::RakString targetUserHandle)
Add output from the worker threads, from a thread already running. This is in addition to the current message, so is used for notifications.
- Public Member Functions inherited from RakNet::Lobby2Server
void | SendMsg (Lobby2Message *msg, const DataStructures::List< SystemAddress > &recipients)
Lobby2Message encapsulates a user command, containing both input and output data.
void | ExecuteCommand (Lobby2ServerCommand *command)
Add a command, which contains a message and other data such as who send the message.
void | AddAdminAddress (SystemAddress addr)
If Lobby2Message::RequiresAdmin() returns true, the message can only be processed from a remote system if the sender's system address is first added()
bool | HasAdminAddress (const DataStructures::List< SystemAddress > &addresses)
If AddAdminAddress() was previously called with addr then this returns true.
void | RemoveAdminAddress (SystemAddress addr)
Removes a system address previously added with AddAdminAddress()
void | ClearAdminAddresses (void)
Removes all system addresses previously added with AddAdminAddress()
void | AddRankingAddress (SystemAddress addr)
If Lobby2Message::RequiresRankingPermission() returns true, then the system that sent the command must be registered with AddRankingAddress()
bool | HasRankingAddress (const DataStructures::List< SystemAddress > &addresses)
void | RemoveRankingAddress (SystemAddress addr)
void | ClearRankingAddresses (void)
Clears all addresses added with AddRankingAddress()
void | SetRoomsPlugin (RoomsPlugin *rp)
To use RoomsPlugin and Lobby2Server together, register RoomsPlugin with this funcrtion.
void | SetRoomsPluginAddress (SystemAddress address)
This is similar to SetRoomsPlugin(), except the plugin is on another system.
void | SetConfigurationProperties (ConfigurationProperties c)
Set the desired configuration properties. This is read during runtime from threads.
const ConfigurationProperties * | GetConfigurationProperties (void) const
Get the previously set configuration properties.
void | SetPresence (const RakNet::Lobby2Presence &presence, RakNet::RakString userHandle)
void | GetPresence (RakNet::Lobby2Presence &presence, RakNet::RakString userHandle)
- Public Member Functions inherited from RakNet::Lobby2Plugin
void | SetOrderingChannel (char oc)
Ordering channel to send messages on.
void | SetSendPriority (PacketPriority pp)
Send priority to send messages on.
void | SetMessageFactory (Lobby2MessageFactory *f)
Creates messages from message IDs.
Lobby2MessageFactory * | GetMessageFactory (void) const
Returns whatever was passed to SetMessageFactory()
virtual void | SetCallbackInterface (Lobby2Callbacks *cb)
Set the callback to receive the results of operations via SendMsg()
virtual void | AddCallbackInterface (Lobby2Callbacks *cb)
You can have more than one callback to get called from the results of operations via SendMsg()
virtual void | RemoveCallbackInterface (Lobby2Callbacks *cb)
Removes a callback added with AddCallbackInterface();.
virtual void | ClearCallbackInterfaces ()
Removes all callbacks added with AddCallbackInterface();.
- Public Member Functions inherited from RakNet::PluginInterface2
virtual void | OnAttach (void)
Called when the interface is attached.
virtual void | OnDetach (void)
Called when the interface is detached.
virtual void | OnRakPeerStartup (void)
Called when RakPeer is initialized.
virtual void | OnRakPeerShutdown (void)
Called when RakPeer is shutdown.
virtual void | OnNewConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming)
virtual void | OnFailedConnectionAttempt (Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason)
virtual bool | UsesReliabilityLayer (void) const
virtual void | OnDirectSocketSend (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnDirectSocketReceive (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)
virtual void | OnReliabilityLayerNotification (const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError)
virtual void | OnInternalPacket (InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend)
virtual void | OnAck (unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time)
virtual void | OnPushBackPacket (const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress)

Additional Inherited Members

- Protected Member Functions inherited from RakNet::Lobby2Server
void | Update (void)
Update is called every time a packet is checked for .
PluginReceiveResult | OnReceive (Packet *packet)
void | OnClosedConnection (const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason)

Detailed Description

PostgreSQL specific functionality to the lobby server.

Member Function Documentation

virtual bool RakNet::Lobby2Server_PGSQL::ConnectToDB | ( | const char * | conninfo,
 |  | int | numWorkerThreads
 | ) |  |
virtual

ConnectTo to the database numWorkerThreads times using the connection string

Parameters
[in] conninfo See the postgre docs
Returns
True on success, false on failure.

Implements RakNet::Lobby2Server.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Lobby2/PGSQL/Lobby2Server_PGSQL.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::AutopatcherMySQLRepository Class Reference

  • AutopatcherMySQLRepository
Public Member Functions | List of all members
RakNet::AutopatcherMySQLRepository Class Reference

#include <AutopatcherMySQLRepository.h>

Inheritance diagram for RakNet::AutopatcherMySQLRepository:
RakNet::AutopatcherRepositoryInterface

Public Member Functions

bool | CreateAutopatcherTables (void)
bool | DestroyAutopatcherTables (void)
bool | AddApplication (const char *applicationName, const char *userName)
bool | RemoveApplication (const char *applicationName)
bool | UpdateApplicationFiles (const char *applicationName, const char *applicationDirectory, const char *userName, FileListProgress *cb)
virtual bool | GetChangelistSinceDate (const char *applicationName, FileList *addedOrModifiedFilesWithHashData, FileList *deletedFiles, double sinceDate)
virtual int | GetPatches (const char *applicationName, FileList *input, bool allowDownloadOfOriginalUnmodifiedFiles, FileList *patchList)
virtual bool | GetMostRecentChangelistWithPatches (RakNet::RakString &applicationName, FileList *patchedFiles, FileList *addedFiles, FileList *addedOrModifiedFileHashes, FileList *deletedFiles, double *priorRowPatchTime, double *mostRecentRowPatchTime)
virtual const char * | GetLastError (void) const
If any of the above functions fail, the error string is stored internally. Call this to get it.
virtual unsigned int | GetFilePart (const char *filename, unsigned int startReadBytes, unsigned int numBytesToRead, void *preallocatedDestination, FileListNodeContext context)
virtual const int | GetIncrementalReadChunkSize (void) const
- Public Member Functions inherited from MySQLInterface
bool | Connect (const char *host, const char *user, const char *passwd, const char *db, unsigned int port, const char *unix_socket, unsigned long clientflag)
Calls mysql_real_connect with the implicit mySqlConnection.
void | Disconnect (void)
Disconnect from the database.
bool | IsConnected (void) const
Returns if we are connected to the database.
virtual const char * | GetLastError (void) const
If any of the above functions fail, the error string is stored internally. Call this to get it.
char * | GetLocalTimestamp (void)
Returns the result of SELECT LOCALTIMESTAMP.

Detailed Description

An implementation of the AutopatcherRepositoryInterface to use MySQL to store the relevant data

Member Function Documentation

bool RakNet::AutopatcherMySQLRepository::AddApplication | ( | const char * | applicationName,
 |  | const char * | userName
 | ) |  |

Add an application for use by files. Call this second.

Parameters
[in] | applicationName | A null terminated string.
[in] | userName | Stored in the database, but otherwise unused. Useful to track who added this application.
Returns
True on success, false on failure.
bool RakNet::AutopatcherMySQLRepository::CreateAutopatcherTables ( void )

Create the tables used by the autopatcher, for all applications. Call this first.

Returns
True on success, false on failure.
bool RakNet::AutopatcherMySQLRepository::DestroyAutopatcherTables ( void )

Destroy the tables used by the autopatcher. Don't call this unless you don't want to use the autopatcher anymore, or are testing.

Returns
True on success, false on failure.
virtual bool RakNet::AutopatcherMySQLRepository::GetChangelistSinceDate | ( | const char * | applicationName,
 |  | FileList * | addedOrModifiedFilesWithHashData,
 |  | FileList * | deletedFiles,
 |  | double | sinceDate
 | ) |  |
virtual

Get list of files added and deleted since a certain date. This is used by AutopatcherServer and not usually explicitly called.

Parameters
[in] | applicationName | A null terminated string previously passed to AddApplication
[out] | addedFiles | A list of the current versions of filenames with SHA1_LENGTH byte hashes as their data that were created after sinceData
[out] | deletedFiles | A list of the current versions of filenames that were deleted after sinceData
[in] | An | input date, in the string format of a timestamp.
Returns
True on success, false on failure.

Implements RakNet::AutopatcherRepositoryInterface.

virtual unsigned int RakNet::AutopatcherMySQLRepository::GetFilePart | ( | const char * | filename,
 |  | unsigned int | startReadBytes,
 |  | unsigned int | numBytesToRead,
 |  | void * | preallocatedDestination,
 |  | FileListNodeContext | context
 | ) |  |
virtual

Read part of a file into destination Return the number of bytes written. Return 0 when file is done.

Parameters
[in] | filename | Filename to read
[in] | startReadBytes | What offset from the start of the file to read from
[in] | numBytesToRead | How many bytes to read. This is also how many bytes have been allocated to preallocatedDestination
[out] | preallocatedDestination | Write your data here
Returns
The number of bytes read, or 0 if none
virtual const int RakNet::AutopatcherMySQLRepository::GetIncrementalReadChunkSize ( void ) const
virtual
Returns
Passed to FileListTransfer::Send() as the _chunkSize parameter.

Implements RakNet::AutopatcherRepositoryInterface.

virtual bool RakNet::AutopatcherMySQLRepository::GetMostRecentChangelistWithPatches | ( | RakNet::RakString & | applicationName,
 |  | FileList * | patchedFiles,
 |  | FileList * | updatedFiles,
 |  | FileList * | addedOrModifiedFileHashes,
 |  | FileList * | deletedFiles,
 |  | double * | priorRowPatchTime,
 |  | double * | mostRecentRowPatchTime
 | ) |  |
virtual

For the most recent update, return files that were patched, added, or deleted. For files that were patched, return both the patch in patchedFiles and the current version in updatedFiles

Parameters
[in,out] | applicationName | Name of the application to get patches for. If empty, uses the most recently updated application, and the string will be updated to reflect this name.
[out] | patchedFiles | A list of patched files with op PC_HASH_2_WITH_PATCH. It has 2 hashes, the priorHash and the currentHash. The currentHash is checked on the client after patching for patch success. The priorHash is checked in AutopatcherServer::OnGetPatch() to see if the client is able to hash with the version they currently have
[out] | patchedFiles | A list of new files. It contains the actual data in addition to the filename
[out] | addedOrModifiedFileHashes | A list of file hashes that were either modified or new. This is returned to the client when replying to ID_AUTOPATCHER_CREATION_LIST, which tells the client what files have changed on the server since a certain date
[out] | deletedFiles | A list of the current versions of filenames that were deleted in the most recent patch
[out] | whenPatched | time in seconds since epoch when patched. Use time() function to get this in C
Returns
true on success, false on failure

Implements RakNet::AutopatcherRepositoryInterface.

virtual int RakNet::AutopatcherMySQLRepository::GetPatches | ( | const char * | applicationName,
 |  | FileList * | input,
 |  | bool | allowDownloadOfOriginalUnmodifiedFiles,
 |  | FileList * | patchList
 | ) |  |
virtual

Get patches (or files) for every file in input, assuming that input has a hash for each of those files. This is used by AutopatcherServer and not usually explicitly called.

Parameters
[in] | applicationName | A null terminated string previously passed to AddApplication
[in] | input | A list of files with hashes to get from the database. If this hash exists, a patch to the current version is returned if this file is not the current version. Otherwise the current version is returned.
[out] | patchList | A list of files with either the filedata or the patch. This is a subset of input. The context data for each file will be either PC_WRITE_FILE (to just write the file) or PC_HASH_WITH_PATCH (to patch). If PC_HASH_WITH_PATCH, then the file contains a SHA1_LENGTH byte patch followed by the hash. The datalength is patchlength + SHA1_LENGTH
Returns
1 on success, 0 on database failure, -1 on tried to download original unmodified file

Implements RakNet::AutopatcherRepositoryInterface.

bool RakNet::AutopatcherMySQLRepository::RemoveApplication ( const char * applicationName )

Remove an application and files used by that application.

Parameters
[in] applicationName A null terminated string previously passed to AddApplication
Returns
True on success, false on failure.
bool RakNet::AutopatcherMySQLRepository::UpdateApplicationFiles | ( | const char * | applicationName,
 |  | const char * | applicationDirectory,
 |  | const char * | userName,
 |  | FileListProgress * | cb
 | ) |  |

Update all the files for an application to match what is at the specified directory. Call this third. Be careful not to call this with the wrong directory. This is implemented in a Begin and Rollback block so you won't a messed up database from get partial updates.

Parameters
[in] | applicationName | A null terminated string previously passed to AddApplication
[in] | applicationDirectory | The base directory of your application. All files in this directory and subdirectories are added.
[in] | userName | Stored in the database, but otherwise unused. Useful to track who added this revision
[in] | cb | Callback to get progress updates. Pass 0 to not use.
Returns
True on success, false on failure.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Autopatcher/AutopatcherMySQLRepository/AutopatcherMySQLRepository.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: CheckSum Class Reference

Public Member Functions | List of all members
CheckSum Class Reference

Generates and validates checksums. More...

#include <CheckSum.h>

Public Member Functions

CheckSum ()
Default constructor.

Detailed Description

Generates and validates checksums.

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/CheckSum.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: MemoryCompressor Class Reference

Public Member Functions | List of all members
MemoryCompressor Class Reference

Compress one or more blocks of data. More...

#include <MemoryCompressor.h>

Inherits CompressorBase.

Public Member Functions

bool | Compress (char *input, const unsigned inputLength, bool finish)
void | Clear (void)
Resets the compressor and all data.
- Public Member Functions inherited from CompressorBase
char * | GetOutput (void) const
unsigned | GetTotalOutputSize (void) const
unsigned | GetTotalInputSize (void) const

Detailed Description

Compress one or more blocks of data.

Member Function Documentation

bool MemoryCompressor::Compress | ( | char * | input,
 |  | const unsigned | inputLength,
 |  | bool | finish
 | ) |  |

Compress a block of data. Pass true to finish if this is the last block in the series. If you don't know if it's the last block, you can call it again with 0 for inputLength

Note
Data passed to input isn't necessarily immediately compressed to output. You can force a write by passing true to finish. Multiple calls concatenate the written data.
Parameters
[in] | input | A pointer to a block of data
[in] | inputLength | The length of input
[in] | finish | Write the last of the data.
The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Autopatcher/MemoryCompressor.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: RefCountedObj Class Reference

List of all members
RefCountedObj Class Reference

World's simplest class :) More...

#include <RefCountedObj.h>

Detailed Description

World's simplest class :)

The documentation for this class was generated from the following file:
  • D:/temp/RakNet_PC/Source/RefCountedObj.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: StrAndBool Struct Reference

List of all members
StrAndBool Struct Reference

The string plus a bool telling us if this string was copied or not. More...

#include <StringTable.h>

Detailed Description

The string plus a bool telling us if this string was copied or not.

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/StringTable.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: ThreadPool< InputType, OutputType > Struct Template Reference

Public Member Functions | List of all members
ThreadPool< InputType, OutputType > Struct Template Reference

#include <ThreadPool.h>

Public Member Functions

bool | StartThreads (int numThreads, int stackSize, void *(*_perThreadInit)()=0, void(*_perThreadDeinit)(void *)=0)
void | StopThreads (void)
Stops all threads.
void | AddInput (OutputType(*workerThreadCallback)(InputType, bool *returnOutput, void *perThreadData), InputType inputData)
void | AddOutput (OutputType outputData)
bool | HasOutput (void)
bool | HasOutputFast (void)
bool | HasInput (void)
bool | HasInputFast (void)
OutputType | GetOutput (void)
void | Clear (void)
Clears internal buffers.
void | LockInput (void)
void | UnlockInput (void)
Unlock the input buffer after you are done with the functions InputSize, GetInputAtIndex, and RemoveInputAtIndex.
unsigned | InputSize (void)
Length of the input queue.
InputType | GetInputAtIndex (unsigned index)
Get the input at a specified index.
void | RemoveInputAtIndex (unsigned index)
Remove input from a specific index. This does NOT do memory deallocation - it only removes the item from the queue.
void | LockOutput (void)
void | UnlockOutput (void)
Unlock the output buffer after you are done with the functions OutputSize, GetOutputAtIndex, and RemoveOutputAtIndex.
unsigned | OutputSize (void)
Length of the output queue.
OutputType | GetOutputAtIndex (unsigned index)
Get the output at a specified index.
void | RemoveOutputAtIndex (unsigned index)
Remove output from a specific index. This does NOT do memory deallocation - it only removes the item from the queue.
void | ClearInput (void)
Removes all items from the input queue.
void | ClearOutput (void)
Removes all items from the output queue.
bool | IsWorking (void)
Are any of the threads working, or is input or output available?
int | NumThreadsWorking (void)
The number of currently active threads.
bool | WasStarted (void)
Did we call Start?

Detailed Description

template<class InputType, class OutputType>
struct ThreadPool< InputType, OutputType >

A simple class to create worker threads that processes a queue of functions with data. This class does not allocate or deallocate memory. It is up to the user to handle memory management. InputType and OutputType are stored directly in a queue. For large structures, if you plan to delete from the middle of the queue, you might wish to store pointers rather than the structures themselves so the array can shift efficiently.

Member Function Documentation

template<class InputType, class OutputType>
void ThreadPool< InputType, OutputType >::AddInput | ( | OutputType(*)(InputType, bool *returnOutput, void *perThreadData) | workerThreadCallback,
 |  | InputType | inputData
 | ) |  |

Adds a function to a queue with data to pass to that function. This function will be called from the thread Memory management is your responsibility! This class does not allocate or deallocate memory. The best way to deallocate inputData is in userCallback. If you call EndThreads such that callbacks were not called, you can iterate through the inputQueue and deallocate all pending input data there The best way to deallocate output is as it is returned to you from GetOutput. Similarly, if you end the threads such that not all output was returned, you can iterate through outputQueue and deallocate it there.

Parameters
[in] | workerThreadCallback | The function to call from the thread
[in] | inputData | The parameter to pass to userCallback
template<class InputType , class OutputType>
void ThreadPool< InputType, OutputType >::AddOutput ( OutputType outputData )

Adds to the output queue Use it if you want to inject output into the same queue that the system uses. Normally you would not use this. Consider it a convenience function.

Parameters
[in] outputData The output to inject
template<class InputType , class OutputType >
OutputType ThreadPool< InputType, OutputType >::GetOutput ( void )

Gets the output of a call to userCallback HasOutput must return true before you call this function. Otherwise it will assert.

Returns
The output of userCallback. If you have different output signatures, it is up to you to encode the data to indicate this
template<class InputType , class OutputType >
bool ThreadPool< InputType, OutputType >::HasInput ( void )

Returns true if input from GetInput is waiting.

Returns
true if input is waiting, false otherwise
template<class InputType , class OutputType >
bool ThreadPool< InputType, OutputType >::HasInputFast ( void )

Inaccurate but fast version of HasInput. If this returns true, you should still check HasInput for the real value.

Returns
true if input is probably waiting, false otherwise
template<class InputType , class OutputType >
bool ThreadPool< InputType, OutputType >::HasOutput ( void )

Returns true if output from GetOutput is waiting.

Returns
true if output is waiting, false otherwise
template<class InputType , class OutputType >
bool ThreadPool< InputType, OutputType >::HasOutputFast ( void )

Inaccurate but fast version of HasOutput. If this returns true, you should still check HasOutput for the real value.

Returns
true if output is probably waiting, false otherwise
template<class InputType , class OutputType >
void ThreadPool< InputType, OutputType >::LockInput ( void )

Lock the input buffer before calling the functions InputSize, InputAtIndex, and RemoveInputAtIndex It is only necessary to lock the input or output while the threads are running

template<class InputType , class OutputType >
void ThreadPool< InputType, OutputType >::LockOutput ( void )

Lock the output buffer before calling the functions OutputSize, OutputAtIndex, and RemoveOutputAtIndex It is only necessary to lock the input or output while the threads are running

template<class InputType , class OutputType >
bool ThreadPool< InputType, OutputType >::StartThreads | ( | int | numThreads,
 |  | int | stackSize,
 |  | void *(*)() | _perThreadInit = 0,
 |  | void(*)(void *) | _perThreadDeinit = 0
 | ) |  |

Start the specified number of threads.

Parameters
[in] | numThreads | The number of threads to start
[in] | stackSize | 0 for default (except on consoles).
[in] | _perThreadInit | User callback to return data stored per thread. Pass 0 if not needed.
[in] | _perThreadDeinit | User callback to destroy data stored per thread, created by _perThreadInit. Pass 0 if not needed.
Returns
True on success, false on failure.
The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/Source/ThreadPool.h
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Class Index

Class Index
A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V
A
Clans_SetProperties (RakNet) GetRoomProperties_Func (RakNet) Platform_Shutdown (RakNet) SendInvite_Func (RakNet)
Clans_SetSubleaderStatus (RakNet) GrantModerator_Func (RakNet) Platform_Startup (RakNet) SerializeParameters (RakNet)
AcceptInvite_Func (RakNet) Clans_UnblacklistUser (RakNet)
H
PluginInterface2 (RakNet) SetCustomRoomProperties_Func (RakNet)
AddUserToQuickJoin_Func (RakNet) Clans_WithdrawJoinInvitation (RakNet) PublicKey (RakNet) SetDestroyOnModeratorLeave_Func (RakNet)
AreAllMembersReady_Func (RakNet) Clans_WithdrawJoinRequest (RakNet) Hash (DataStructures)
Q
SetHiddenFromSearches_Func (RakNet)
AutopatcherMySQLRepository (RakNet) Client_ChangeHandle (RakNet) HiddenFromSearchesSet_Notification (RakNet) SetReadyStatus_Func (RakNet)
AutopatcherPostgreRepository (RakNet) Client_GetAccountDetails (RakNet) HTTPConnection (RakNet) Queue (DataStructures) SetRoomLockState_Func (RakNet)
AutopatcherRepositoryInterface (RakNet) Client_GetEmailAddress (RakNet) HTTPConnection2 (RakNet) QueueLinkedList (DataStructures) SimpleMutex (RakNet)
AutopatcherServer (RakNet) Client_GetIgnoreList (RakNet) HuffmanEncodingTree (RakNet) QuickJoinEnteredRoom_Notification (RakNet) SingleProducerConsumer (DataStructures)
AutopatcherServerLoadNotifier_Printf (RakNet) Client_GetPasswordByPasswordRecoveryAnswer (RakNet) HuffmanEncodingTreeFactory (RakNet) QuickJoinExpired_Notification (RakNet) SlotCountsSet_Notification (RakNet)
AutopatcherServerLoadNotifier::AutopatcherState (RakNet) Client_GetPasswordRecoveryQuestionByHandle (RakNet)
I
R
SocketDescriptor (RakNet)
AVLBalancedBinarySearchTree (DataStructures) Client_GetPresence (RakNet) SQLite3ClientPlugin (RakNet)
B
Client_Login (RakNet) IndexedBinaryValue (RakNet) Rackspace (RakNet) SQLite3PluginResultInterface (RakNet)
Client_Logoff (RakNet) IndexedIntegerValue (RakNet) Rackspace2EventCallback (RakNet) SQLite3PluginResultInterface_Printf (RakNet)
HTTPConnection::BadResponse (RakNet) Client_PerTitleBinaryStorage (RakNet) InternalPacket (RakNet) RackspaceEventCallback_Default (RakNet) SQLite3Row
BinarySearchTree (DataStructures) Client_RegisterAccount (RakNet) InternalPacketRefCountedData (RakNet) RakNetCommandParser (RakNet) SQLite3ServerPlugin (RakNet)
BitStream (RakNet) Client_SetPresence (RakNet) IsInQuickJoin_Func (RakNet) RakNetGUID (RakNet) SQLite3Table
Bitstream_Func (RakNet) Client_StartIgnore (RakNet)
J
RakNetStatistics (RakNet) StartSpectating_Func (RakNet)
Bitstream_Notification (RakNet) Client_StopIgnore (RakNet) RakNetTransport2 (RakNet) StatisticsHistory (RakNet)
BookmarkedUsers_Add (RakNet) Client_UpdateAccount (RakNet) JoinByFilter_Func (RakNet) RakPeer (RakNet) StatisticsHistoryPlugin (RakNet)
BookmarkedUsers_Get (RakNet) Client_ValidateHandle (RakNet)
K
RakPeerInterface (RakNet) StopSpectating_Func (RakNet)
BookmarkedUsers_Remove (RakNet) CloudAllocator (RakNet) RakString (RakNet) StrAndBool
BPlusTree (DataStructures) CloudClient (RakNet) KickMember_Func (RakNet) RakVoice (RakNet) StringCompressor (RakNet)
C
CloudClientCallback (RakNet)
L
RakWString (RakNet) StringTable (RakNet)
CloudKey (RakNet) Ranking_GetMatchBinaryData (RakNet) System_BanUser (RakNet)
CDKey_Add (RakNet) CloudQuery (RakNet) LastSerializationResult (RakNet) Ranking_GetMatches (RakNet) System_CreateDatabase (RakNet)
CDKey_FlagStolen (RakNet) CloudServer (RakNet) LeaveRoom_Func (RakNet) Ranking_GetRating (RakNet) System_CreateTitle (RakNet)
CDKey_GetStatus (RakNet) CloudServerQueryFilter (RakNet) List (DataStructures) Ranking_GetTotalScore (RakNet) System_DeleteAccount (RakNet)
CDKey_Use (RakNet) Table::ColumnDescriptor (DataStructures) Lobby2Callbacks (RakNet) Ranking_PruneMatches (RakNet) System_DestroyDatabase (RakNet)
Table::Cell (DataStructures) CommandParserInterface (RakNet) Lobby2Client (RakNet) Ranking_SubmitMatch (RakNet) System_DestroyTitle (RakNet)
ChangeHandle_Func (RakNet) Lobby2Server::ConfigurationProperties (RakNet) Lobby2Message (RakNet) Ranking_UpdateRating (RakNet) System_GetTitleBinaryData (RakNet)
ChangeRoomName_Func (RakNet) Connection_RM3 (RakNet) Lobby2Plugin (RakNet) Ranking_WipeMatches (RakNet) System_GetTitleRequiredAge (RakNet)
ChangeSlotCounts_Func (RakNet) ConnectionGraph2 (RakNet) Lobby2Presence (RakNet) Ranking_WipeRatings (RakNet) System_PruneAccounts (RakNet)
Chat_Func (RakNet) ConsoleServer (RakNet) Lobby2Printf (RakNet) Ranking_WipeScoresForPlayer (RakNet) System_RegisterProfanity (RakNet)
Chat_Notification (RakNet) CreateRoom_Func (RakNet) Lobby2Server (RakNet) ReadyEvent (RakNet) System_SetEmailAddressValidated (RakNet)
CheckSum CustomRoomPropertiesSet_Notification (RakNet) Lobby2Server_PGSQL (RakNet) RefCountedObj System_UnbanUser (RakNet)
CircularLinkedList (DataStructures)
D
Lobby2ServerCommand (RakNet) RelayPlugin (RakNet) SystemAddress (RakNet)
Clans_AcceptJoinInvitation (RakNet) LogCommandParser (RakNet) ReliabilityLayer (RakNet) LogCommandParser::SystemAddressAndChannel (RakNet)
Clans_AcceptJoinRequest (RakNet) DataCompressor (RakNet)
M
RemoteClient (RakNet)
T
Clans_ChangeHandle (RakNet)
E
RemoveUserFromQuickJoin_Func (RakNet)
Clans_Create (RakNet) Map (DataStructures) Replica3 (RakNet) Table (DataStructures)
Clans_CreateBoard (RakNet) Emails_Delete (RakNet) MemoryCompressor Replica3Composite (RakNet) TeamBalancer (RakNet)
Clans_CreateNewTopic (RakNet) Emails_Get (RakNet) MemoryPool (DataStructures) ReplicaManager3 (RakNet) TeamManager (RakNet)
Clans_DestroyBoard (RakNet) Emails_Send (RakNet) MessageFilter (RakNet) AutopatcherServer::ResultTypeAndBitstream (RakNet) TeamSelection (RakNet)
Clans_DownloadInvitationList (RakNet) Emails_SetStatus (RakNet) MLKeyRef (DataStructures) RoomDestroyedOnModeratorLeft_Notification (RakNet) TelnetTransport (RakNet)
Clans_DownloadRequestList (RakNet) EmailSender (RakNet) ModeratorChanged_Notification (RakNet) RoomInvitationSent_Notification (RakNet) ThreadPool
Clans_Get (RakNet) EnterRoom_Func (RakNet) Multilist (DataStructures) RoomInvitationWithdrawn_Notification (RakNet) ThreadsafePacketLogger (RakNet)
Clans_GetBlacklist (RakNet)
F
N
RoomLockStateSet_Notification (RakNet) TM_Team (RakNet)
Clans_GetBoards (RakNet) RoomMemberHandleSet_Notification (RakNet) TM_TeamMember (RakNet)
Clans_GetList (RakNet) FileListNode (RakNet) NatPunchthroughClient (RakNet) RoomMemberJoinedRoom_Notification (RakNet) TM_World (RakNet)
Clans_GetMemberProperties (RakNet) FileListProgress (RakNet) NatPunchthroughServer (RakNet) RoomMemberKicked_Notification (RakNet) TransportInterface (RakNet)
Clans_GetMembers (RakNet) FileListTransfer (RakNet) NatTypeDetectionClient (RakNet) RoomMemberLeftRoom_Notification (RakNet) TwoWayAuthentication (RakNet)
Clans_GetPosts (RakNet) FileListTransferCBInterface (RakNet) NatTypeDetectionServer (RakNet) RoomMemberReadyStatusSet_Notification (RakNet)
U
Clans_GetProperties (RakNet) FLP_Printf (RakNet) NetworkIDManager (RakNet) RoomMemberStartedSpectating_Notification (RakNet)
Clans_GetTopics (RakNet) Friends_AcceptInvite (RakNet) NetworkIDObject (RakNet) RoomMemberStoppedSpectating_Notification (RakNet) UDPForwarder (RakNet)
Clans_GrantLeader (RakNet) Friends_GetFriends (RakNet)
O
RoomNameSet_Notification (RakNet) UDPProxyClient (RakNet)
Clans_KickAndBlacklistUser (RakNet) Friends_GetInvites (RakNet) RoomsPlugin (RakNet) UDPProxyClientResultHandler (RakNet)
Clans_Leave (RakNet) Friends_RejectInvite (RakNet) OrderedList (DataStructures) RoomsPluginFunc (RakNet) UDPProxyCoordinator (RakNet)
Clans_RejectJoinInvitation (RakNet) Friends_Remove (RakNet)
P
RoomsPluginNotification (RakNet) UDPProxyServer (RakNet)
Clans_RejectJoinRequest (RakNet) Friends_SendInvite (RakNet) Router2 (RakNet) UDPProxyServerResultHandler (RakNet)
Clans_RemovePost (RakNet)
G
Packet (RakNet) Table::Row (DataStructures) UnbanMember_Func (RakNet)
Clans_ReplyToTopic (RakNet) PacketConsoleLogger (RakNet) RPC3 (RakNet)
V
Clans_SendJoinInvitation (RakNet) GetBanReason_Func (RakNet) PacketFileLogger (RakNet) RPC4 (RakNet)
Clans_SendJoinRequest (RakNet) GetInvitesToParticipant_Func (RakNet) PacketLogger (RakNet) RPC4GlobalRegistration (RakNet) VariableDeltaSerializer (RakNet)
Clans_SetMemberRank (RakNet) GetReadyStatus_Func (RakNet) PacketOutputWindowLogger (RakNet)
S
VariableListDeltaTracker (RakNet)
Clans_SetMyMemberProperties (RakNet) GetRoomLockState_Func (RakNet) Page (DataStructures)
SearchByFilter_Func (RakNet)
A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Hierarchy

Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 1234]
o C RakNet::AutopatcherRepositoryInterface | An interface used by AutopatcherServer to get the data necessary to run an autopatcher. This is up to you to implement for custom repository solutions
| o C RakNet::AutopatcherMySQLRepository |
| \ C RakNet::AutopatcherPostgreRepository |
o C RakNet::AutopatcherServerLoadNotifier_Printf | Sample implementation of AutopatcherServerLoadNotifier using printf
o C RakNet::AutopatcherServerLoadNotifier::AutopatcherState | Current queue state of the autopatcher
o C RakNet::HTTPConnection::BadResponse | Encapsulates a raw HTTP response and response code
o C DataStructures::BinarySearchTree< BinarySearchTreeType > | A binary search tree and an AVL balanced binary search tree
| \ C DataStructures::AVLBalancedBinarySearchTree< BinarySearchTreeType > | An AVLBalancedBinarySearchTree is a binary tree that is always balanced
o C RakNet::BitStream |
o C DataStructures::BPlusTree< KeyType, DataType, order > |
o C DataStructures::BPlusTree< unsigned, Row *, _TABLE_BPLUS_TREE_ORDER > |
o C DataStructures::Table::Cell | Holds the actual data in the table
o C CheckSum | Generates and validates checksums
o C DataStructures::CircularLinkedList< CircularLinkedListType > | (Circular) Linked List ADT (Doubly Linked Pointer to Node Style) -
o C DataStructures::CircularLinkedList< LinkedListType > |
o C DataStructures::CircularLinkedList< QueueType > |
o C RakNet::CloudAllocator |
| \ C RakNet::CloudServer | Stores client data, and allows cross-server communication to retrieve this data
o C RakNet::CloudClientCallback |
o C RakNet::CloudKey |
o C RakNet::CloudQuery |
o C RakNet::CloudServerQueryFilter | Zero or more instances of CloudServerQueryFilter can be attached to CloudServer to restrict client queries All attached instances of CloudServerQueryFilter on each corresponding operation, from all directly connected clients If any attached instance returns false for a given operation, that operation is silently rejected
o C DataStructures::Table::ColumnDescriptor |
o C RakNet::CommandParserInterface | The interface used by command parsers
| o C RakNet::LogCommandParser | Adds the ability to send logging output to a remote console
| \ C RakNet::RakNetCommandParser | This allows a console client to call most of the functions in RakPeer
o C RakNet::Lobby2Server::ConfigurationProperties | Server configuration properties, to customize how the server runs specific commands
o C RakNet::Connection_RM3 | Each remote system is represented by Connection_RM3. Used to allocate Replica3 and track which instances have been allocated
o C RakNet::ConsoleServer | The main entry point for the server portion of your remote console application support
o C RakNet::DataCompressor | Does compression on a block of data. Not very good compression, but it's small and fast so is something you can compute at runtime
o C RakNet::EmailSender | Rudimentary class to send email from code
o C RakNet::FileListNode | Represents once instance of a file
o C RakNet::FileListProgress | Callback interface set with FileList::SetCallback() in case you want progress notifications when FileList::AddFilesFromDirectory() is called
| o C RakNet::AutopatcherServer | The server plugin for the autopatcher. Must be running for the client to get patches
| \ C RakNet::FLP_Printf | Implementation of FileListProgress to use RAKNET_DEBUG_PRINTF
o C RakNet::FileListTransferCBInterface | Used by FileListTransfer plugin as a callback for when we get a file
o C DataStructures::Hash< key_type, data_type, HASH_SIZE, hashFunction > | Using a string as a identifier for a node, store an allocated pointer to that node
o C DataStructures::Hash< AddressOrGUID, FilteredSystem, 2048, AddressOrGUID::ToInteger > |
o C DataStructures::Hash< NetworkID, TM_Team *, 256, TM_Team::ToUint32 > |
o C DataStructures::Hash< NetworkID, TM_TeamMember *, 256, TM_TeamMember::ToUint32 > |
o C DataStructures::Hash< RakNet::RakString, LocalRPCFunction *, 256, RakNet::RakString::ToInteger > |
o C DataStructures::Hash< RakNet::RakString, LocalSlot *, 256, RakNet::RakString::ToInteger > |
o C DataStructures::Hash< RakNet::RakString, RakNet::RakString, 16, RakNet::RakString::ToInteger > |
o C DataStructures::Hash< RakNet::RakString, TimeAndValueQueue *, 32, RakNet::RakString::ToInteger > |
o C DataStructures::Hash< RakNet::RakString, void(*)(RakNet::BitStream *, Packet *), 64, RakNet::RakString::ToInteger > |
o C DataStructures::Hash< RakNet::RakString, void(*)(RakNet::BitStream *, RakNet::BitStream *, Packet *), 64, RakNet::RakString::ToInteger > |
o C DataStructures::Hash< RakNetGUID, RemoteCloudClient *, 2048, RakNetGUID::ToUint32 > |
o C DataStructures::Hash< RakNetGUID, StrAndGuidAndRoom *, 8096, RakNet::RakNetGUID::ToUint32 > |
o C DataStructures::Hash< RakString, StrAndGuidAndRoom *, 8096, RakNet::RakString::ToInteger > |
o C RakNet::HTTPConnection | Use HTTPConnection to communicate with a web server
o C RakNet::HuffmanEncodingTree | This generates special cases of the huffman encoding tree using 8 bit keys with the additional condition that unused combinations of 8 bits are treated as a frequency of 1
o C RakNet::HuffmanEncodingTreeFactory | Creates instances of the class HuffmanEncodingTree
o C RakNet::IndexedBinaryValue | Used to unify different platforms for room search and search properties. Only applies if specifically used
o C RakNet::IndexedIntegerValue | Used to unify different platforms for room search and search properties. Only applies if specifically used
o C RakNet::InternalPacket |
o C RakNet::InternalPacketRefCountedData | Used in InternalPacket when pointing to sharedDataBlock, rather than allocating itself
o C RakNet::LastSerializationResult |
o C DataStructures::List< list_type > | Array based implementation of a list
o C DataStructures::List< __TCPSOCKET__ > |
o C DataStructures::List< AddrAndGuid > |
o C DataStructures::List< BannedUser > |
o C DataStructures::List< BanStruct * > |
o C DataStructures::List< BookmarkedUser > |
o C DataStructures::List< bool > |
o C DataStructures::List< BufferedGetResponseFromServer * > |
o C DataStructures::List< Cell * > |
o C DataStructures::List< ChangedVariablesList * > |
o C DataStructures::List< ClanInfo > |
o C DataStructures::List< ClanJoinInvite > |
o C DataStructures::List< ClanJoinRequest > |
o C DataStructures::List< CloudData * > |
o C DataStructures::List< CloudDataList * > |
o C DataStructures::List< CloudKey > |
o C DataStructures::List< CloudQueryRow * > |
o C DataStructures::List< CloudServerQueryFilter * > |
o C DataStructures::List< ColumnDescriptor > |
o C DataStructures::List< CommandParserInterface * > |
o C DataStructures::List< Connection_RM3 * > |
o C DataStructures::List< ConnectionAttempt * > |
o C DataStructures::List< ConnectionRequestSystem > |
o C DataStructures::List< ConnnectRequest * > |
o C DataStructures::List< data_type > |
o C DataStructures::List< EmailResult > |
o C DataStructures::List< FileListNode > |
o C DataStructures::List< FileListProgress * > |
o C DataStructures::List< FileToPushRecipient * > |
o C DataStructures::List< FilterSet * > |
o C DataStructures::List< ForwardedConnection > |
o C DataStructures::List< ForwardEntry * > |
o C DataStructures::List< ForwardingRequest * > |
o C DataStructures::List< FriendInfo > |
o C DataStructures::List< GetRequest * > |
o C DataStructures::List< HeapNode > |
o C DataStructures::List< InternalPacket * > |
o C DataStructures::List< InvitedUser > |
o C DataStructures::List< KeySubscriberID * > |
o C DataStructures::List< LastSerializationResult * > |
o C DataStructures::List< Lobby2Callbacks * > |
o C DataStructures::List< LocalCallback * > |
o C DataStructures::List< LocalSlotObject > |
o C DataStructures::List< MapNode > |
o C DataStructures::List< MatchParticipant > |
o C DataStructures::List< MiniPunchRequest > |
o C DataStructures::List< MyTeamMembers > |
o C DataStructures::List< NATDetectionAttempt > |
o C DataStructures::List< node_type > |
o C DataStructures::List< OpenInvite > |
o C DataStructures::List< PingServerGroup * > |
o C DataStructures::List< PluginInterface2 * > |
o C DataStructures::List< PostgreSQLInterface * > |
o C DataStructures::List< QuickJoinUser * > |
o C DataStructures::List< Rackspace2EventCallback * > |
o C DataStructures::List< RackspaceOperation > |
o C DataStructures::List< RakNet::RakString > |
o C DataStructures::List< RakNetGUID > |
o C DataStructures::List< RakNetSocket2 * > |
o C DataStructures::List< RangeNode< DatagramSequenceNumberType > > |
o C DataStructures::List< RangeNode< range_type > > |
o C DataStructures::List< ReadyEventNode * > |
o C DataStructures::List< RegisteredCommand > |
o C DataStructures::List< RemoteServer * > |
o C DataStructures::List< RemoteSystem * > |
o C DataStructures::List< RemoteSystem > |
o C DataStructures::List< RemoteSystemVariableHistory * > |
o C DataStructures::List< Replica3 * > |
o C DataStructures::List< Request * > |
o C DataStructures::List< RequestedTeam > |
o C DataStructures::List< RM3World * > |
o C DataStructures::List< RoomDescriptor * > |
o C DataStructures::List< RoomMember * > |
o C DataStructures::List< RoomMember > |
o C DataStructures::List< RoomMemberDescriptor > |
o C DataStructures::List< RoomsCallback * > |
o C DataStructures::List< RoomsPluginParticipant * > |
o C DataStructures::List< RP_Group * > |
o C DataStructures::List< ServerWithPing > |
o C DataStructures::List< SharedString * > |
o C DataStructures::List< SplitPacketChannel * > |
o C DataStructures::List< SQLite3PluginResultInterface * > |
o C DataStructures::List< SQLite3Row * > |
o C DataStructures::List< StrAndBool > |
o C DataStructures::List< StrAndGuid > |
o C DataStructures::List< SubmittedMatch > |
o C DataStructures::List< SystemAddress > |
o C DataStructures::List< SystemAddressAndChannel > |
o C DataStructures::List< SystemAddressAndGuid > |
o C DataStructures::List< TeamMember > |
o C DataStructures::List< TelnetClient * > |
o C DataStructures::List< TM_Team * > |
o C DataStructures::List< TM_TeamMember * > |
o C DataStructures::List< TM_World * > |
o C DataStructures::List< TrackedObject * > |
o C DataStructures::List< Tree * > |
o C DataStructures::List< TwoWayAuthentication::NonceAndRemoteSystemRequest * > |
o C DataStructures::List< uint32_t > |
o C DataStructures::List< UnreliableWithAckReceiptNode > |
o C DataStructures::List< unsigned int > |
o C DataStructures::List< unsigned short > |
o C DataStructures::List< User * > |
o C DataStructures::List< VariableLastValueNode > |
o C DataStructures::List< VoiceChannel * > |
o C DataStructures::List< void * > |
o C RakNet::Lobby2Callbacks |
| \ C RakNet::Lobby2Printf |
o C RakNet::Lobby2Message | A Lobby2Message encapsulates a networked function call from the client
| o C RakNet::BookmarkedUsers_Add | Remembers a user, with a type integer and description for you to use, if desired
| o C RakNet::BookmarkedUsers_Get | Returns all users added to BookmarkedUsers_Add
| o C RakNet::BookmarkedUsers_Remove | Remove a user added with BookmarkedUsers_Add
| o C RakNet::CDKey_Add | Adds CDKeys to the database. Duplicate CDKeys for a particular title are ignored. CDKeys can be identical for different titles
| o C RakNet::CDKey_FlagStolen | Flags one or more CD keys as stolen. Stolen CD keys will prevent Client_Login() if check cd key is true. They will also prevent these cd keys from being used with CDKey_Use. If this key is already in use by certain users for this particular title, then log this similarly to how CDKey_Use does so
| o C RakNet::CDKey_GetStatus | Returns if a CD key was previously added with AddCDKey
| o C RakNet::CDKey_Use | Associates a cd key with a user, such that the cd key cannot be used again. If Client_Login() is called with check cd key as true, then this table will be checked to make sure UserCDKey() was previously called with this user and a valid key. If this user is already associated with a CD Key, add the new key, and use the most recent key. All CD Key usage should be logged in a separate table, including the date used and result
| o C RakNet::Clans_AcceptJoinInvitation | If myPrimaryKey has an invitation to the specified clan, add him to the clan. Fail on specified output parameters. Use Emails_Send() to send an email from myPrimaryKey to all clan members with the specified subject and body
| o C RakNet::Clans_AcceptJoinRequest | A clan leader or subleader accepts a join request from requestingUserHandle to this clan. requestingUserHandle joins the clan as a regular member. Use Emails_Send() to send an email from requestingUserHandle to all clan members with the specified subject and body
| o C RakNet::Clans_ChangeHandle | Renames the clan. Note that this may be called asynchronously, in which case the stored procedure should account for this occuring at the same time as another function that uses the old clan handle
| o C RakNet::Clans_Create | UserHandle updates the clanDescription and clanBinaryData of a clan with the specified clanHandle. userHandle must be the clan leader
| o C RakNet::Clans_CreateBoard | Creates a new clan board for clan members to post in using AddPostToClanBoard. Clan boards are unique, and are destroyed when the clan is destroyed, or if DestroyClanBoard is called
| o C RakNet::Clans_CreateNewTopic | Each clan has a clan board that only clan members can post to. This adds a topic to the clan board. Posts should reference the primary key of the poster, so that even if the poster chagnes his or her handle, the post author is updated properly. Each post automatically stores the timestamp when it was created. Banned users may not add new posts to the clan board
| o C RakNet::Clans_DestroyBoard | Success, invalid parameter syntax, myPrimaryKey is not the leader or subleader of clanHandle, unknown myPrimaryKey, unknown clanHandle, unknown clanBoardName
| o C RakNet::Clans_DownloadInvitationList | Returns all invites sent by Clans_SendJoinInvitation that were not yet acted upon (withdrawn, accepted, rejected)
| o C RakNet::Clans_DownloadRequestList | Returns all open requests this user has sent to clans, that have not yet acted upon (withdrawn, accepted, rejected, expired)
| o C RakNet::Clans_Get | Returns all clans that userHandle is a member of. Clans and clan members should be sorted by name, using ascending or descending sort as specified
| o C RakNet::Clans_GetBlacklist | Returns a list of all members blacklisted from this clan. Each element in the list contains the handle of the user that did the ban, who was banned, when the user was banned, and the reason passed to ClanKickAndBlacklistUser
| o C RakNet::Clans_GetBoards | Gets clan boards created for clanHandle. Boards are returned if we are a clan member, or if allowPublicReads in Clans_CreateBoard() was passed as false. However, if we are banned from this clan, no boards are returned
| o C RakNet::Clans_GetList | Returns all clans names
| o C RakNet::Clans_GetMemberProperties | Returns properties for a clan member of a given clan
| o C RakNet::Clans_GetMembers | Returns all clan members for this clan. Each entry returned contains handle, description, binary data, status (leader, regular member, subleader)
| o C RakNet::Clans_GetPosts | Gets all posts for a particular topic. If postId is not a topic but is instead a post in a topic, treat it as if the topic postId was passed. If we are not a clan member and the clan was created with allowPublicReads==false, then the user is not allowed to read topics
| o C RakNet::Clans_GetProperties | Returns clanDescription and clanBinaryData for the given clan
| o C RakNet::Clans_GetTopics | Gets topics (posts that are not replies to other posts, created with Clans_CreateTopic()) for the specified clanHandle and clanBoardName. If we are not a clan member and the clan was created with allowPublicReads==false, then the user is not allowed to read topics
| o C RakNet::Clans_GrantLeader | MyPrimaryKey becomes a subleader. newLeaderHandle becomes the leader. An email is sent with Emails_Send() to all members with the specified subject and body
| o C RakNet::Clans_KickAndBlacklistUser | Kicks a user from the clan and/or blacklists a user so they cannot join. Only a clan leader or subleader can perform this operation. The operation can only be performed on members of lower status (leader can perform on subleader or regular member or nonmember, subleader on regular members or nonmember). If a member is banned, they are added to the banned table which contains the member's primary key, which user banned them, and the reason. Email is sent from myPrimaryKey to all leaders if a clan member is banned. Emails is furthermore sent to all clan members if successfully kicked
| o C RakNet::Clans_Leave | Remove user identified by myPrimaryKey from clan identified by clanHandle
| o C RakNet::Clans_RejectJoinInvitation | If we have an open clan invitation, reject it (just delete it from the database)
| o C RakNet::Clans_RejectJoinRequest | Rejects a clan join request from requestingUserHandle. Send an email from myPrimaryKey to requestingUserHandle with the specified subject and body
| o C RakNet::Clans_RemovePost | The clan leader or subleaders may remove posts or topics from a clan board
| o C RakNet::Clans_ReplyToTopic | Replies to a topic created with Clans_CreateTopic(). If postId references a post within a topic, just add the reply to the last post. Banned users may not add new posts to the clan board
| o C RakNet::Clans_SendJoinInvitation | If myPrimaryKey is a leader or subleader of clanHandle, and invitedUserHandle is a valid user not already invited to this clan, add this user to the invite table. The invite table contains the clan, who send the invite, and who the invite was sent to, and when it was sent. Invites expire after expiration time in seconds. Also, use Emails_Send() to send an email from myPrimaryKey to invitedUserHandle with the specified subject and body
| o C RakNet::Clans_SendJoinRequest | Function has two forms:
| o C RakNet::Clans_SetMemberRank | Lets the clan leader set the rank property for a clan member
| o C RakNet::Clans_SetMyMemberProperties | Each member of each clan has the the properties clanMemberDescription and clanMemberBinaryData which default to empty. These properties can be set here, and retrieved via GetClanMemberProperties
| o C RakNet::Clans_SetProperties | UserHandle updates the clanDescription and clanBinaryData of a clan with the specified clanHandle. userHandle must be the clan leader
| o C RakNet::Clans_SetSubleaderStatus | Promotes a clan member to a subleader, or demotes a subleader to a regular member. On promotion, email is sent to all members from myPrimary key with the specified subject and body. On demotion, email is sent to all leaders from myPrimary key with the specified subject and body
| o C RakNet::Clans_UnblacklistUser | Removes a user from the blacklist for this clan
| o C RakNet::Clans_WithdrawJoinInvitation | If myPrimaryKey is a leader or subleader of clanHandle, and invitedUserHandle is a valid user with an invite to this clan, remove this invite. Also, use Emails_Send() to send an email from myPrimaryKey to invitedUserHandle with the specified subject and body
| o C RakNet::Clans_WithdrawJoinRequest | Withdraws a previously sent clan join request via SendClanJoinRequest. Use Emails_Send() to send an email from myPrimaryKey to the clan leader and all subleaders with the specified subject and body
| o C RakNet::Client_ChangeHandle | Changes the handle for a user
| o C RakNet::Client_GetAccountDetails | Get the parameters set with Client_RegisterAccount
| o C RakNet::Client_GetEmailAddress | Returns the email address associated with a specific handle, invalid handle. This is used for password recovery
| o C RakNet::Client_GetIgnoreList | Returns all users I have ignored
| o C RakNet::Client_GetPasswordByPasswordRecoveryAnswer | Returns the password associated with a handle, if the passwordRecoveryAnswer is correct
| o C RakNet::Client_GetPasswordRecoveryQuestionByHandle | Returns the passwordRecoveryQuestion associated with handle, invalid handle
| o C RakNet::Client_GetPresence | Gets in-memory information about a user's login state, such as which game they are playing, or if they are playing a game This can also be a quick way to query if a user is logged in or not. If they are not logged in, presence will be set to Lobby2Presence::NOT_ONLINE
| o C RakNet::Client_Login | Logon with a previously registered account
| o C RakNet::Client_Logoff | Logoff, after logging in
| o C RakNet::Client_PerTitleBinaryStorage | For each combination of user and title, structures can be stored
| o C RakNet::Client_RegisterAccount | This creates a new account in the database, which can be used in a subsequent call to Login. Most parameters are optional. handle is not optional, and must be unique using case-insensitive compare. emailAddress should be validated to have a sensible format, including an @ sign and a period with a 3 letter extension. allowLoginWithoutEmailAddressValidation is used in Client_Login to potentially disallow logon attempts with unverified email addresses
| o C RakNet::Client_SetPresence | Sets in-memory information about your login state, such as which game you are playing, or if you are playing a game Online friends will be notified when you presence changes For the XBOX, just use XUserSetProperty and XUserSetContext directly, as there is no analogue to this function
| o C RakNet::Client_StartIgnore | Adds the specified user to an ignore list for my user. Recommended to store the primary key of the remote user, both for speed and so if the other use changes their handle it still works. The ignore list is checked for friend invites, emails, and elsewhere where indicated. Ignoring is uni-directional, so if A ignores B, A will block messages from B where appropriate, but B will not immediately block messages from A
| o C RakNet::Client_StopIgnore | Removes an entry in the database such that myHandle will no longer ignore theirHandle
| o C RakNet::Client_UpdateAccount | Will update any or all of the inputs that were previously passed to Client_RegisterAccount, except handle
| o C RakNet::Client_ValidateHandle | Looks up in the database if this handle is already in use, subject to the usual constraints of handles. This will be used by the user to quickly check for available handles
| o C RakNet::Emails_Delete | Deletes an email with a specified ID. This ID is returned in GetEmail and should uniquely identify an email (it's fine to use the primary key). Note: Emails are not actually deleted from the database in this function. This just sets the deletedBySender or deletedByReciever flags. Emails are actually stored in a log recording past emails and sender and receiver primary key. They are not truly destroyed until done so with System_PruneAccounts
| o C RakNet::Emails_Get | Returns emails as noted. Emails which were marked deleted are not returned
| o C RakNet::Emails_Send | Adds to an emails table from myHandle (store primary key) to recipient handles (store primary key) the specified subject, body, and binary data. Emails are persistent, therefore emails should be stored in a separate table and referenced by the user. Deleting the user does not delete previously send email. Emails should have an automatic timestamp to store when they were created. Email should be flagged as sent=true (boolean), markedRead=true (boolean), deletedBySender=false (boolean), deletedByReciever=false (boolean)
| o C RakNet::Emails_SetStatus | Sets the status flag for an email. This is a property defined by and used by the user
| o C RakNet::Friends_AcceptInvite | Stores in the database that this user is now my friend. This is bidirectional, which is to say if someone accepts an add friend invite, they are my friend, and I am their friend. Recommended to store by primary key for speed and in case the friend's handle changes. Store in the emails table from my handle to their handle the subject, body, and binary data. Note: if myHandle is ignored by theirHandle, then the function fails. See AddToIgnoreList
| o C RakNet::Friends_GetFriends | Gets all friends to this user
| o C RakNet::Friends_GetInvites | Returns all invites for this user
| o C RakNet::Friends_RejectInvite | Removes from the database the pending add friend invite. Operation completes even if ignored. Unless ignored, store in the emails table from my handle to their handle the subject, body, binary data, and procedure type flag
| o C RakNet::Friends_Remove | Ends a friendship between two users. Remove from the database the friend entry between my handle and their handle. As with accept add friend invite, this is bidirectional. Either user can terminate the friendship. Store in the emails table from my handle to their handle the subject, body, and binary data, and procedure type flag
| o C RakNet::Friends_SendInvite | Stores in the database an add friend invite from my handle to their handle. The combination of my handle and their handle must be unique, so you cannot send more than one add friend invite to a single user. Sends an email to their handle the subject, body, and binary data. Note: if myHandle is ignored by theirHandle, then the function fails. See Client_StartIgnore
| o C RakNet::Platform_Shutdown | Platform specific startup. Unused on the PC
| o C RakNet::Platform_Startup | Platform specific startup. Unused on the PC
| o C RakNet::Ranking_GetMatchBinaryData | Because of the large amount of binary data potentially returned, this function is used to retrieve binary data for a particular match
| o C RakNet::Ranking_GetMatches | Gets matches recorded with Ranking_SubmitMatch ordered from most recent to least recent. Each returned match has all columns submitted to Ranking_SubmitMatch, except binary data, which can be retrieved with Ranking_GetMatchBinaryData. Additionally, each returned match returns the primary key of each match, to be passed to Ranking_GetMatchBinaryData
| o C RakNet::Ranking_GetRating | Get rating for a player
| o C RakNet::Ranking_GetTotalScore | When a match is submitted with Ranking_SubmitMatch, the total running score and number of matches played for each player for each game title and game mode combination should be recorded. Because matches can be pruned wth PruneMatches(), the total score sum and number of scores submitted should be stored, rather than summed up from prior submitted matches
| o C RakNet::Ranking_PruneMatches | Will delete all matches submitted with SubmitMatch over PruneTime days old. Will also prune matches if the total storage space of all matches exceeds PruneSizeMB megabytes in the database
| o C RakNet::Ranking_SubmitMatch | Will record in the database the results of a match. This will store in the database the the match which is defined by the the match notes, match id, winner and loser participant primary keys, winner and loser participant scores, and binary data
| o C RakNet::Ranking_UpdateRating | Add or update a rating for a user, in a particular game and game mode
| o C RakNet::Ranking_WipeMatches | Deletes all matches submitted with submit match. Also deletes all scores for all players associated with this titleName and gameType (e.g. same thing that WipeScoresForPlayer does, but for all players)
| o C RakNet::Ranking_WipeRatings | Deletes all ratings for all players for this combination of titleName and gameType
| o C RakNet::Ranking_WipeScoresForPlayer | Resets the sum of all submitted scores to 0, the number of scores submitted to 0
| o C RakNet::System_BanUser | Bans a specific user (will be most likely called by a moderator). Adds the user's primary key to a ban table, along with the name of the moderator, the reason for the ban. Banning is used to prevent the banned user from logging on for some specified duration. A date column should be present and automatically filled in. When bans are expired, the ban can be deleted from the database. However, a separate table should log bans, so that even expired bans can be looked up in case
| o C RakNet::System_CreateDatabase | Create all tables and stored procedures on a system that does not already have them
| o C RakNet::System_CreateTitle | Each title essentially corresponds to a game. For example, the same lobby system may be used for both asteroids and Pac-man. When logging in, and for some functions, it is necessary to specify which title you are logging in under. This way users playing asteroids do not interact with users playing pac-man, where such interations are game specific (such as ranking)
| o C RakNet::System_DeleteAccount | Flags as deleted an account registered with RegisterAccount. Accounts are not actually deleted, only tagged as deleted
| o C RakNet::System_DestroyDatabase | Destroy all tables and stored procedures created with System_CreateDatabase
| o C RakNet::System_DestroyTitle | Destroy a previously added title
| o C RakNet::System_GetTitleBinaryData | Get the binary data set with System_CreateTitle
| o C RakNet::System_GetTitleRequiredAge | Get the required age set with System_CreateTitle
| o C RakNet::System_PruneAccounts | Unused accounts are deleted. This is cascading, such that emails and other tables that reference this key are also deleted. unused accounts are defined as:
| o C RakNet::System_RegisterProfanity | Adds the input strings to a table of profanity. non-unique or empty strings can be ignored. This table will be used internally to ensure that handles and clan names do not contain profanity. Multiple calls add to the table. This table will be used for functions that take a user-defined string that is highly visible, such as clan and user names. It does not need to be checked for emails or message boards
| o C RakNet::System_SetEmailAddressValidated | For the client with the given handle, mark a column emailAddressValidated as true or false as appropriate. This is potentially used in Client_Login
| \ C RakNet::System_UnbanUser | Unban a user banned with System_BanUser
o C RakNet::Lobby2Presence |
o C RakNet::Lobby2ServerCommand |
o C DataStructures::Map< key_type, data_type, key_comparison_func > |
o C DataStructures::Map< channel_key_type, QueueAndWeight *, channel_key_comparison_func > |
o C DataStructures::Map< GameIdentifier, PerGameRoomsContainer * > |
o C DataStructures::Map< int, HuffmanEncodingTree * > |
o C DataStructures::Map< node_type, DataStructures::Map< node_type, weight_type > * > |
o C DataStructures::Map< SystemAddress, DataStructures::ByteQueue * > |
o C DataStructures::Map< unsigned short, FileListReceiver * > |
o C MemoryCompressor | Compress one or more blocks of data
o C DataStructures::MemoryPool< MemoryBlockType > |
o C DataStructures::MemoryPool< BufferedCommandStruct > |
o C DataStructures::MemoryPool< ChangedVariablesList > |
o C DataStructures::MemoryPool< InternalPacket > |
o C DataStructures::MemoryPool< InternalPacketRefCountedData > |
o C DataStructures::MemoryPool< MessageNumberNode > |
o C DataStructures::MemoryPool< Packet > |
o C DataStructures::MemoryPool< Page< KeyType, DataType, order > > |
o C DataStructures::MemoryPool< Page< unsigned, Row *, order > > |
o C DataStructures::MemoryPool< RemoteClient * > |
o C DataStructures::MemoryPool< RemoteSystemIndex > |
o C DataStructures::MemoryPool< SocketQueryOutput > |
o C DataStructures::MemoryPool< StartForwardingInputStruct > |
o C DataStructures::MemoryPool< StopForwardingStruct > |
o C DataStructures::MemoryPool< structureType > |
o C DataStructures::MemoryPool< SystemAddress > |
o C DataStructures::MemoryPool< unsigned char[128]> |
o C DataStructures::MemoryPool< unsigned char[2048]> |
o C DataStructures::MemoryPool< unsigned char[512]> |
o C DataStructures::MemoryPool< unsigned char[8192]> |
o C DataStructures::MLKeyRef< templateType > |
o C DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > | The multilist, representing an abstract data type that generally holds lists
o C DataStructures::Multilist< ML_ORDERED_LIST, NamedDBHandle, RakNet::RakString > |
o C DataStructures::Multilist< ML_ORDERED_LIST, uint64_t > |
o C DataStructures::Multilist< ML_UNORDERED_LIST, Lobby2Message *, uint64_t > |
o C RakNet::NetworkIDManager |
o C RakNet::NetworkIDObject | Unique shared ids for each object instance
| \ C RakNet::Replica3 | Base class for your replicated objects for the ReplicaManager3 system
| \ C RakNet::Replica3Composite< parent_type > | Use Replica3 through composition instead of inheritance by containing an instance of this templated class Calls to parent class for all functions Parent class must still define and functions though!
o C DataStructures::OrderedList< key_type, data_type, default_comparison_function > |
o C DataStructures::OrderedList< channel_key_type, MapNode,&Map::NodeComparisonFunc > |
o C DataStructures::OrderedList< char *, StrAndBool, StrAndBoolComp > |
o C DataStructures::OrderedList< CloudKey, CloudDataList *, CloudServer::KeyDataListComp > |
o C DataStructures::OrderedList< CloudKey, CloudKey, CloudKeyComp > |
o C DataStructures::OrderedList< CloudKey, KeySubscriberID *, CloudServer::KeySubscriberIDComp > |
o C DataStructures::OrderedList< const char *, RegisteredCommand, RegisteredCommandComp > |
o C DataStructures::OrderedList< DatagramSequenceNumberType, RangeNode< DatagramSequenceNumberType >, RangeNodeComp< DatagramSequenceNumberType > > |
o C DataStructures::OrderedList< GameIdentifier, MapNode,&Map::NodeComparisonFunc > |
o C DataStructures::OrderedList< int, FilterSet *, FilterSetComp > |
o C DataStructures::OrderedList< int, MapNode,&Map::NodeComparisonFunc > |
o C DataStructures::OrderedList< int, ReadyEventNode *, ReadyEvent::ReadyEventNodeComp > |
o C DataStructures::OrderedList< key_type, MapNode,&Map::NodeComparisonFunc > |
o C DataStructures::OrderedList< LocalSlotObject, LocalSlotObject, LocalSlotObjectComp > |
o C DataStructures::OrderedList< MessageID, LocalCallback *, RPC4::LocalCallbackComp > |
o C DataStructures::OrderedList< node_type, MapNode,&Map::NodeComparisonFunc > |
o C DataStructures::OrderedList< node_type, node_type > |
o C DataStructures::OrderedList< RakNet::RakString, RakNet::RakString > |
o C DataStructures::OrderedList< RakNet::RakString, RoomsPluginParticipant *, RoomsPluginParticipantCompByRakString > |
o C DataStructures::OrderedList< RakNetGUID, BufferedGetResponseFromServer *, CloudServer::BufferedGetResponseFromServerComp > |
o C DataStructures::OrderedList< RakNetGUID, CloudData *, CloudServer::KeyDataPtrComp > |
o C DataStructures::OrderedList< RakNetGUID, RakNetGUID > |
o C DataStructures::OrderedList< RakNetGUID, RemoteServer *, CloudServer::RemoteServerComp > |
o C DataStructures::OrderedList< RakNetGUID, RemoteSystem *, ConnectionGraph2::RemoteSystemComp > |
o C DataStructures::OrderedList< RakNetGUID, RemoteSystem, ReadyEvent::RemoteSystemCompByGuid > |
o C DataStructures::OrderedList< RakNetGUID, User *, NatPunchthroughServer::NatPunchthroughUserComp > |
o C DataStructures::OrderedList< RakNetGUID, VoiceChannel *, VoiceChannelComp > |
o C DataStructures::OrderedList< RakString, User *, Lobby2Server::UserCompByUsername > |
o C DataStructures::OrderedList< range_type, RangeNode< range_type >, RangeNodeComp< range_type > > |
o C DataStructures::OrderedList< Replica3 *, LastSerializationResult *, Connection_RM3::Replica3LSRComp > |
o C DataStructures::OrderedList< SenderAndTargetAddress, ForwardingRequest *, ForwardingRequestComp > |
o C DataStructures::OrderedList< SplitPacketIdType, SplitPacketChannel *, SplitPacketChannelComp > |
o C DataStructures::OrderedList< SystemAddress, MapNode,&Map::NodeComparisonFunc > |
o C DataStructures::OrderedList< SystemAddress, RoomMember, SystemAddressAndRoomMemberComp > |
o C DataStructures::OrderedList< SystemAddress, SystemAddress > |
o C DataStructures::OrderedList< SystemAddressAndGuid, SystemAddressAndGuid, ConnectionGraph2::SystemAddressAndGuidComp > |
o C DataStructures::OrderedList< uint32_t, ChangedVariablesList *, VariableDeltaSerializer::UpdatedVariablesListPtrComp > |
o C DataStructures::OrderedList< uint32_t, GetRequest *, CloudServer::GetRequestComp > |
o C DataStructures::OrderedList< uint64_t, RoomMember, SteamIDAndRoomMemberComp > |
o C DataStructures::OrderedList< uint64_t, TrackedObject *, TrackedObjectComp > |
o C DataStructures::OrderedList< unsigned short, MapNode,&Map::NodeComparisonFunc > |
o C RakNet::Packet | This represents a user message from another system
o C DataStructures::Page< KeyType, DataType, order > |
o C DataStructures::Page< unsigned, Row *, order > |
o C RakNet::PluginInterface2 |
| o C RakNet::AutopatcherServer | The server plugin for the autopatcher. Must be running for the client to get patches
| o C RakNet::CloudClient | Performs Post() and Get() operations on CloudMemoryServer
| o C RakNet::CloudServer | Stores client data, and allows cross-server communication to retrieve this data
| o C RakNet::ConnectionGraph2 | A one hop connection graph
| o C RakNet::FileListTransfer | A plugin to provide a simple way to compress and incrementally send the files in the FileList structure
| o C RakNet::HTTPConnection2 | Use HTTPConnection2 to communicate with a web server
| o C RakNet::Lobby2Plugin | Both Lobby2Server and Lobby2Client derive from this class
| | o C RakNet::Lobby2Client | Class used to send commands to Lobby2Server
| | \ C RakNet::Lobby2Server | The base class for the lobby server, without database specific functionality
| | \ C RakNet::Lobby2Server_PGSQL | PostgreSQL specific functionality to the lobby server
| o C RakNet::MessageFilter | Assigns systems to FilterSets. Each FilterSet limits what kinds of messages are allowed
| o C RakNet::NatPunchthroughClient | Client code for NATPunchthrough
| o C RakNet::NatPunchthroughServer | Server code for NATPunchthrough
| o C RakNet::NatTypeDetectionClient | Client code for NatTypeDetection
| o C RakNet::NatTypeDetectionServer | Server code for NatTypeDetection
| o C RakNet::PacketLogger | Writes incoming and outgoing messages to the screen. This will write all incoming and outgoing messages to the console window, or to a file if you override it and give it this functionality
| | o C RakNet::PacketConsoleLogger | Packetlogger that logs to a remote command console
| | o C RakNet::PacketFileLogger | Packetlogger that outputs to a file
| | o C RakNet::PacketOutputWindowLogger | Packetlogger that outputs to the output window in the debugger. Windows only
| | \ C RakNet::ThreadsafePacketLogger | Same as PacketLogger, but writes output in the user thread
| o C RakNet::RakNetTransport2 | Use RakNetTransport if you need a secure connection between the client and the console server
| o C RakNet::RakVoice | Voice compression and transmission interface
| o C RakNet::ReadyEvent | Peer to peer synchronized ready and unready events
| o C RakNet::RelayPlugin | A simple class to relay messages from one system to another, identifying remote systems by a string
| o C RakNet::ReplicaManager3 | System to help automate game object construction, destruction, and serialization
| o C RakNet::RoomsPlugin | Used to create rooms for players where they can matchmake
| o C RakNet::Router2 | Class interface for the Router2 system
| o C RakNet::RPC3 | The RPC3 plugin allows you to call remote functions as if they were local functions, using the standard function call syntax
| o C RakNet::RPC4 | The RPC4 plugin is just an association between a C function pointer and a string
| o C RakNet::SQLite3ClientPlugin |
| o C RakNet::SQLite3ServerPlugin | Exec SQLLite commands over the network
| o C RakNet::StatisticsHistoryPlugin | Input numerical values over time. Get sum, average, highest, lowest, standard deviation on recent or all-time values
| o C RakNet::TeamBalancer | Set and network team selection (supports peer to peer or client/server)
| o C RakNet::TeamManager | Automates networking and list management for teams
| o C RakNet::TwoWayAuthentication | Implements two way authentication
| o C RakNet::UDPProxyClient | Communicates with UDPProxyCoordinator, in order to find a UDPProxyServer to forward our datagrams
| o C RakNet::UDPProxyCoordinator | Middleman between UDPProxyServer and UDPProxyClient, maintaining a list of UDPProxyServer, and managing state for clients to find an available forwarding server
| \ C RakNet::UDPProxyServer | UDPProxyServer to control our instance of UDPForwarder
o C RakNet::PublicKey | Passed to RakPeerInterface::Connect()
o C DataStructures::Queue< queue_type > | A queue implemented as an array with a read and write index
o C DataStructures::Queue< AutopatcherRepositoryInterface * > |
o C DataStructures::Queue< BadResponse > |
o C DataStructures::Queue< bool > |
o C DataStructures::Queue< BufferedCommandStruct * > |
o C DataStructures::Queue< DatagramHistoryNode > |
o C DataStructures::Queue< double > |
o C DataStructures::Queue< DSTAndFac > |
o C DataStructures::Queue< FileToPush * > |
o C DataStructures::Queue< InputType > |
o C DataStructures::Queue< int > |
o C DataStructures::Queue< int(*)(ThreadData, bool *, void *)> |
o C DataStructures::Queue< InternalPacket * > |
o C DataStructures::Queue< Lobby2ServerCommand > |
o C DataStructures::Queue< Lobby2ServerCommand(*)(Lobby2ServerCommand, bool *, void *)> |
o C DataStructures::Queue< OutgoingCommand > |
o C DataStructures::Queue< OutputType > |
o C DataStructures::Queue< OutputType(*)(InputType, bool *, void *)> |
o C DataStructures::Queue< Packet * > |
o C DataStructures::Queue< PendingChallenge > |
o C DataStructures::Queue< RakNet::RakString > |
o C DataStructures::Queue< RemoteClient ** > |
o C DataStructures::Queue< Request * > |
o C DataStructures::Queue< RequestedConnectionStruct * > |
o C DataStructures::Queue< ResultTypeAndBitstream * > |
o C DataStructures::Queue< ResultTypeAndBitstream *(*)(ThreadData, bool *, void *)> |
o C DataStructures::Queue< RNS2RecvStruct * > |
o C DataStructures::Queue< SocketQueryOutput * > |
o C DataStructures::Queue< SQLExecThreadInput > |
o C DataStructures::Queue< SQLExecThreadOutput > |
o C DataStructures::Queue< SQLExecThreadOutput(*)(SQLExecThreadInput, bool *, void *)> |
o C DataStructures::Queue< StartForwardingInputStruct * > |
o C DataStructures::Queue< StartForwardingOutputStruct > |
o C DataStructures::Queue< StopForwardingStruct * > |
o C DataStructures::Queue< structureType * > |
o C DataStructures::Queue< SystemAddress * > |
o C DataStructures::Queue< SystemAddress > |
o C DataStructures::Queue< ThreadAction > |
o C DataStructures::Queue< ThreadData > |
o C DataStructures::Queue< TimeAndValue > |
o C DataStructures::Queue< TimeAndValue2 > |
o C DataStructures::Queue< unsigned int > |
o C DataStructures::QueueLinkedList< QueueType > | A queue implemented using a linked list. Rarely used
o C RakNet::Rackspace | Code that uses the TCPInterface class to communicate with the Rackspace API servers
o C RakNet::Rackspace2EventCallback | Callback interface to receive the results of operations
| \ C RakNet::RackspaceEventCallback_Default | Callback interface to receive the results of operations, with a default result
o C RakNet::RakNetGUID |
o C RakNet::RakNetStatistics | Network Statisics Usage
o C RakNet::RakPeerInterface | The main interface for network communications
| \ C RakNet::RakPeer | Main interface for network communications
o C RakNet::RakString | String class
o C RakNet::RakWString | String class for Unicode
o C RefCountedObj | World's simplest class :)
o C RakNet::ReliabilityLayer | Datagram reliable, ordered, unordered and sequenced sends. Flow control. Message splitting, reassembly, and coalescence
o C RakNet::RemoteClient | Stores information about a remote client
o C RakNet::AutopatcherServer::ResultTypeAndBitstream |
o C RakNet::RoomsPluginFunc | Base class for rooms functionality
| o C RakNet::AcceptInvite_Func | Accept an invitation from a user to a room
| o C RakNet::AddUserToQuickJoin_Func | Enter quick join mode
| o C RakNet::AreAllMembersReady_Func | If all members have been set to ready using SetReadyStatus_Func, this operation will set allReady to true
| o C RakNet::Bitstream_Func | Send an arbitrary binary message
| o C RakNet::ChangeHandle_Func | Change your handle
| o C RakNet::ChangeRoomName_Func | Change the name of the room
| o C RakNet::ChangeSlotCounts_Func | Change the allowed slot counts for the room. Setting fewer slot counts than the number of players does not kick out players, though it may prevent changing spectator status
| o C RakNet::Chat_Func | Send a chat message
| o C RakNet::CreateRoom_Func | Create a room. Each user can be in at most one room, so will fail if the user is already in a room
| o C RakNet::EnterRoom_Func | Joins a room if possible. If not, creates a room
| o C RakNet::GetBanReason_Func | For a given room, get the reason parameter of KickMember_Func when we were kicked out
| o C RakNet::GetInvitesToParticipant_Func |
| o C RakNet::GetReadyStatus_Func | Gets the ready states for every user in the room, excluding spectators
| o C RakNet::GetRoomLockState_Func | Gets the lock state of the room
| o C RakNet::GetRoomProperties_Func | Given a named room, return the properties of that room, including member list
| o C RakNet::GrantModerator_Func | Give moderator to another player. Moderators cannot be spectators
| o C RakNet::IsInQuickJoin_Func | Returns if you are waiting in quick join mode
| o C RakNet::JoinByFilter_Func | Joins a room given the filter parameters and desired room member mode
| o C RakNet::KickMember_Func | Kick a member out of the room. This will also automatically ban that member from rejoining as long as the moderator does not change, or the member is unbanned
| o C RakNet::LeaveRoom_Func | Leaves a room. You can leave at any time, even if the room is locked
| o C RakNet::RemoveUserFromQuickJoin_Func | Leave quick join mode
| o C RakNet::SearchByFilter_Func | Return all rooms that pass the roomQuery filter
| o C RakNet::SendInvite_Func | Sends an invitation to someone
| o C RakNet::SetCustomRoomProperties_Func | Sets a table of user-defined room properties
| o C RakNet::SetDestroyOnModeratorLeave_Func | Sets or unsets to destroy the room when the moderator leaves the room
| o C RakNet::SetHiddenFromSearches_Func | Set or unset the room hidden from searches. If a room is hidden from searches, it can only be joined through invitations
| o C RakNet::SetReadyStatus_Func | Sets or unsets the user as flagged 'ready'
| o C RakNet::SetRoomLockState_Func | Lock or unlock the room
| o C RakNet::StartSpectating_Func | Begin spectating. Spectators are considered room members that are not playing the game, only watching
| o C RakNet::StopSpectating_Func | Stop spectating. This will rejoin the room as a player, using a reserved slot if we were invited, and a public slot if not or if there are no reserved slots
| \ C RakNet::UnbanMember_Func | Allow a member previously kicked out of the room to rejoin
o C RakNet::RoomsPluginNotification | Base class for notification callbacks
| o C RakNet::Bitstream_Notification | You got a generic bitstream message from another user
| o C RakNet::Chat_Notification | You got a chat message from another user
| o C RakNet::CustomRoomPropertiesSet_Notification | The custom properties for the room has changed
| o C RakNet::HiddenFromSearchesSet_Notification | The room is now hidden, or no longer hidden, from searches
| o C RakNet::ModeratorChanged_Notification | The room has a new moderator (possibly you)
| o C RakNet::QuickJoinEnteredRoom_Notification | Quick join succeeded, and you are now in a room
| o C RakNet::QuickJoinExpired_Notification | The quick join duration has expired without joining or creating any rooms
| o C RakNet::RoomDestroyedOnModeratorLeft_Notification | The moderator has left the room, and everyone left is a spectator, or the room was set to be destroyed when the moderator leftYou are no longer in the room
| o C RakNet::RoomInvitationSent_Notification | You have received an invitation to a room
| o C RakNet::RoomInvitationWithdrawn_Notification | A previous room invitation is no longer valid (possibly due to moderator change, or the room no longer exists)
| o C RakNet::RoomLockStateSet_Notification | The room is now, or is no longer, locked
| o C RakNet::RoomMemberHandleSet_Notification | A room member has changed their handle
| o C RakNet::RoomMemberJoinedRoom_Notification | A room member has joined the room
| o C RakNet::RoomMemberKicked_Notification | A room member has been kicked out of the room (possibly you)
| o C RakNet::RoomMemberLeftRoom_Notification |
| o C RakNet::RoomMemberReadyStatusSet_Notification | Another room member has changed their ready status
| o C RakNet::RoomMemberStartedSpectating_Notification | Another room member has started spectating
| o C RakNet::RoomMemberStoppedSpectating_Notification | Another room member has stopped spectating
| o C RakNet::RoomNameSet_Notification | The name of the room has been changed
| \ C RakNet::SlotCountsSet_Notification | The slot counts in the room has changed
o C DataStructures::Table::Row | Stores the list of cells for this row, and a special flag used for internal sorting
o C RakNet::RPC4GlobalRegistration | Instantiate this class globally if you want to register a function with RPC4 at the global space
o C RakNet::SerializeParameters |
o C RakNet::SimpleMutex | An easy to use mutex
o C DataStructures::SingleProducerConsumer< SingleProducerConsumerType > | A single producer consumer implementation without critical sections
o C DataStructures::SingleProducerConsumer< char * > |
o C RakNet::SocketDescriptor | Describes the local socket to use for RakPeer::Startup
o C RakNet::SQLite3PluginResultInterface | Handles results of calls to SQLite3Plugin::_sqlite3_exec() Results from calling SQLite3Plugin::_sqlite3_exec() are handled in this callback. You should implement the callback, and let the plugin know about it via SQLite3Plugin::AddResultHandler() Be sure to call SQLite3Plugin::RemoveResultHandler() or SQLite3Plugin::ClearResultHandlers() if you delete the callback
| \ C RakNet::SQLite3PluginResultInterface_Printf |
o C SQLite3Row |
o C SQLite3Table |
o C RakNet::StatisticsHistory | Input numerical values over time. Get sum, average, highest, lowest, standard deviation on recent or all-time values
o C StrAndBool | The string plus a bool telling us if this string was copied or not
o C RakNet::StringCompressor | Writes and reads strings to and from bitstreams
o C RakNet::StringTable | Writes a string index, instead of the whole string
o C RakNet::SystemAddress | Network address for a system
o C RakNet::LogCommandParser::SystemAddressAndChannel | One of these structures is created per player
o C DataStructures::Table | Holds a set of columns, a set of rows, and rows times columns cells
o C RakNet::TeamSelection | Parameter to TM_World::ReferenceTeamMember()
o C ThreadPool< InputType, OutputType > |
o C ThreadPool< Lobby2ServerCommand, Lobby2ServerCommand > |
o C ThreadPool< SQLExecThreadInput, SQLExecThreadOutput > |
o C ThreadPool< ThreadData, int > |
o C ThreadPool< ThreadData, ResultTypeAndBitstream * > |
o C RakNet::TM_Team | A team, containing a list of TM_TeamMember instances
o C RakNet::TM_TeamMember | A member of one or more teams
o C RakNet::TM_World | Stores a list of teams which may be enforcing a balanced number of members
o C RakNet::TransportInterface | Defines an interface that is used to send and receive null-terminated strings
| o C RakNet::RakNetTransport2 | Use RakNetTransport if you need a secure connection between the client and the console server
| \ C RakNet::TelnetTransport | Use TelnetTransport to easily allow windows telnet to connect to your ConsoleServer
o C RakNet::UDPForwarder | Forwards UDP datagrams. Independent of RakNet's protocol
o C RakNet::UDPProxyClientResultHandler |
o C RakNet::UDPProxyServerResultHandler |
o C RakNet::VariableDeltaSerializer | Class to compare memory values of variables in a current state to a prior state Results of the comparisons will be written to a bitStream, such that only changed variables get written Can be used with ReplicaManager3 to Serialize a Replica3 per-variable, rather than comparing the entire object against itself Usage: BR>
\ C RakNet::VariableListDeltaTracker |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: RakNet::AutopatcherServerLoadNotifier::AutopatcherState Struct Reference

  • AutopatcherServerLoadNotifier
  • AutopatcherState
Public Attributes | List of all members
RakNet::AutopatcherServerLoadNotifier::AutopatcherState Struct Reference

Current queue state of the autopatcher. More...

#include <AutopatcherServer.h>

Public Attributes

unsigned int | requestsQueued
How many requests have been queued to be processed later.
unsigned int | requestsWorking

Detailed Description

Current queue state of the autopatcher.

Member Data Documentation

unsigned int RakNet::AutopatcherServerLoadNotifier::AutopatcherState::requestsWorking

How many requests are currently working (including downloading files). This will not normally exceed AutopatcherServer::SetMaxConurrentUsers()

The documentation for this struct was generated from the following file:
  • D:/temp/RakNet_PC/DependentExtensions/Autopatcher/AutopatcherServer.h
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- _ -

  • _sqlite3_exec()
: RakNet::SQLite3PluginResultInterface
, RakNet::SQLite3ClientPlugin
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • accountRegistrationRequiredAgeYears : RakNet::Lobby2Server::ConfigurationProperties
  • accountRegistrationRequiresCDKey : RakNet::Lobby2Server::ConfigurationProperties
  • AckTimeout() : RakNet::ReliabilityLayer
  • activeSystemList : RakNet::RakPeer
  • AddAdminAddress() : RakNet::Lobby2Server
  • AddApplication()
: RakNet::AutopatcherPostgreRepository
, RakNet::AutopatcherMySQLRepository
  • AddBitsAndReallocate() : RakNet::BitStream
  • AddCallback() : RakNet::FileListTransfer
  • AddCallbackInterface() : RakNet::Lobby2Plugin
  • AddChannel() : RakNet::LogCommandParser
  • AddColumn() : DataStructures::Table
  • AddCommandParser() : RakNet::ConsoleServer
  • AddDBHandle() : RakNet::SQLite3ServerPlugin
  • AddEventCallback() : RakNet::Rackspace
  • AddInput() : ThreadPool< InputType, OutputType >
  • AddInputFromThread() : RakNet::Lobby2Server_PGSQL
  • AddLoginServerAddress() : RakNet::RoomsPlugin
  • AddOperation() : RakNet::Rackspace
  • AddOutput() : ThreadPool< InputType, OutputType >
  • AddOutputFromThread() : RakNet::Lobby2Server_PGSQL
  • AddParticipant()
: RakNet::ConnectionGraph2
, RakNet::TM_World
  • AddParticipantOnServer() : RakNet::RelayPlugin
  • AddParticipantRequestFromClient() : RakNet::RelayPlugin
  • AddPassword() : RakNet::TwoWayAuthentication
  • AddQueryFilter() : RakNet::CloudServer
  • addr4 : RakNet::SystemAddress
  • AddRankingAddress() : RakNet::Lobby2Server
  • AddReference()
: RakNet::StringCompressor
, RakNet::StringTable
  • AddRemoteSystemVariableHistory() : RakNet::VariableDeltaSerializer
  • AddResultHandler() : RakNet::SQLite3ClientPlugin
  • AddRoomsCallback() : RakNet::RoomsPlugin
  • AddRow() : DataStructures::Table
  • AddServer() : RakNet::CloudServer
  • AddString() : RakNet::StringTable
  • AddToBanList()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • AddToFrequencyTable() : RakNet::HuffmanEncodingTreeFactory
  • AddToSecurityExceptionList()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • AddToWaitList() : RakNet::ReadyEvent
  • AddWorld()
: RakNet::ReplicaManager3
, RakNet::TeamManager
  • AdvertiseSystem()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • AlignReadToByteBoundary() : RakNet::BitStream
  • AlignWriteToByteBoundary() : RakNet::BitStream
  • AllocateCloudQueryRow() : RakNet::CloudAllocator
  • AllocatePacket()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • AllocateRowData() : RakNet::CloudAllocator
  • AllocationScheme : RakNet::InternalPacket
  • allocationSize : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • AllocConnection() : RakNet::ReplicaManager3
  • AllocReplica() : RakNet::Connection_RM3
  • allowConnectionResponseIPMigration : RakNet::RakPeer
  • AllowConnectionResponseIPMigration()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • AnyAvailable() : RakNet::TeamSelection
  • ApplyNetworkSimulator()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • AssertCopyData() : RakNet::BitStream
  • AssertStreamEmpty() : RakNet::BitStream
  • Assign() : RakNet::RakString
  • AssignSystemAddressToRemoteSystemList() : RakNet::RakPeer
  • AttachPlugin()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • Authenticate() : RakNet::Rackspace
  • AutoCreateConnectionList() : RakNet::ReplicaManager3
  • AWAY : RakNet::Lobby2Presence
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • BeginDeserialize() : RakNet::VariableDeltaSerializer
  • BeginIdenticalSerialize() : RakNet::VariableDeltaSerializer
  • BeginUniqueSerialize() : RakNet::VariableDeltaSerializer
  • BeginUnreliableAckedSerialize() : RakNet::VariableDeltaSerializer
  • binaryData : RakNet::Client_PerTitleBinaryStorage
  • bitSize : RakNet::Packet
  • BitStream() : RakNet::BitStream
  • bitsWrittenSoFar : RakNet::SerializeParameters
  • bookmarkedUsers : RakNet::BookmarkedUsers_Get
  • BPSLimitByCongestionControl : RakNet::RakNetStatistics
  • BPSLimitByOutgoingBandwidthLimit : RakNet::RakNetStatistics
  • BroadcastDestruction() : RakNet::Replica3
  • BroadcastDestructionList() : RakNet::ReplicaManager3
  • bytesInResendBuffer : RakNet::RakNetStatistics
  • bytesInSendBuffer : RakNet::RakNetStatistics
  • bytesSentPerSecond : RakNet::RakPeer
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • C_String()
: RakNet::RakString
, RakNet::RakWString
  • CacheMostRecentPatch() : RakNet::AutopatcherServer
  • Call()
: RakNet::RPC4
, RakNet::RPC3
  • callbackId : RakNet::Lobby2Message
  • CallBlocking() : RakNet::RPC4
  • CallCallback() : RakNet::Lobby2Message
  • CallExplicit() : RakNet::RPC3
  • CallLoopback() : RakNet::RPC4
  • CancelConnectionAttempt()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • CancelOnDisconnect()
: RakNet::System_CreateDatabase
, RakNet::System_SetEmailAddressValidated
, RakNet::Ranking_GetTotalScore
, RakNet::Ranking_WipeScoresForPlayer
, RakNet::Client_ValidateHandle
, RakNet::Ranking_WipeMatches
, RakNet::Ranking_PruneMatches
, RakNet::System_DestroyDatabase
, RakNet::System_DeleteAccount
, RakNet::Ranking_UpdateRating
, RakNet::Ranking_WipeRatings
, RakNet::System_PruneAccounts
, RakNet::Ranking_GetRating
, RakNet::Clans_Create
, RakNet::System_CreateTitle
, RakNet::Client_GetEmailAddress
, RakNet::Clans_SetProperties
, RakNet::Clans_GetProperties
, RakNet::Client_GetPasswordRecoveryQuestionByHandle
, RakNet::Clans_SetMyMemberProperties
, RakNet::Clans_GrantLeader
, RakNet::System_DestroyTitle
, RakNet::Client_GetPasswordByPasswordRecoveryAnswer
, RakNet::Clans_SetSubleaderStatus
, RakNet::Clans_SetMemberRank
, RakNet::Client_ChangeHandle
, RakNet::Clans_GetMemberProperties
, RakNet::Clans_ChangeHandle
, RakNet::System_GetTitleRequiredAge
, RakNet::Client_UpdateAccount
, RakNet::Clans_Leave
, RakNet::Clans_Get
, RakNet::Client_GetAccountDetails
, RakNet::Clans_SendJoinInvitation
, RakNet::Clans_WithdrawJoinInvitation
, RakNet::System_GetTitleBinaryData
, RakNet::Client_StartIgnore
, RakNet::Clans_AcceptJoinInvitation
, RakNet::Clans_RejectJoinInvitation
, RakNet::Client_StopIgnore
, RakNet::Clans_DownloadInvitationList
, RakNet::Clans_SendJoinRequest
, RakNet::System_RegisterProfanity
, RakNet::Client_GetIgnoreList
, RakNet::Clans_WithdrawJoinRequest
, RakNet::Clans_AcceptJoinRequest
, RakNet::Client_PerTitleBinaryStorage
, RakNet::Clans_RejectJoinRequest
, RakNet::Clans_DownloadRequestList
, RakNet::System_BanUser
, RakNet::Client_SetPresence
, RakNet::Clans_KickAndBlacklistUser
, RakNet::Clans_UnblacklistUser
, RakNet::Client_GetPresence
, RakNet::Clans_GetBlacklist
, RakNet::Clans_GetMembers
, RakNet::System_UnbanUser
, RakNet::Friends_SendInvite
, RakNet::Clans_GetList
, RakNet::Clans_CreateBoard
, RakNet::Friends_AcceptInvite
, RakNet::Clans_DestroyBoard
, RakNet::Clans_CreateNewTopic
, RakNet::CDKey_Add
, RakNet::Friends_RejectInvite
, RakNet::Clans_GetPosts
, RakNet::Clans_ReplyToTopic
, RakNet::Clans_RemovePost
, RakNet::Friends_GetInvites
, RakNet::Clans_GetBoards
, RakNet::Clans_GetTopics
, RakNet::Lobby2Message
, RakNet::CDKey_GetStatus
, RakNet::Friends_GetFriends
, RakNet::Friends_Remove
, RakNet::CDKey_Use
, RakNet::BookmarkedUsers_Add
, RakNet::BookmarkedUsers_Remove
, RakNet::Platform_Startup
, RakNet::CDKey_FlagStolen
, RakNet::BookmarkedUsers_Get
, RakNet::Emails_Send
, RakNet::Client_Login
, RakNet::Emails_Get
, RakNet::Emails_Delete
, RakNet::Platform_Shutdown
, RakNet::Client_Logoff
, RakNet::Emails_SetStatus
, RakNet::Ranking_SubmitMatch
, RakNet::Client_RegisterAccount
, RakNet::Ranking_GetMatches
, RakNet::Ranking_GetMatchBinaryData
  • CancelReadLock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • CancelReceive() : RakNet::FileListTransfer
  • CancelRequestSpecificTeam() : RakNet::TeamBalancer
  • CancelTeamRequest() : RakNet::TM_TeamMember
  • CancelWriteLock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • Challenge() : RakNet::TwoWayAuthentication
  • ChangeHandle() : RakNet::RoomsPlugin
  • channelNames : RakNet::LogCommandParser
  • channels : RakNet::LogCommandParser::SystemAddressAndChannel
  • chatDirectedToRoom : RakNet::Chat_Func
  • CheckReadUnlockOrder() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • CheckSum() : CheckSum
  • Clear()
: RakNet::TwoWayAuthentication
, RakNet::AutopatcherServer
, MemoryCompressor
, DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
, RakNet::TM_World
, RakNet::CloudServer
, DataStructures::Table
, DataStructures::Hash< key_type, data_type, HASH_SIZE, hashFunction >
, RakNet::RakString
, DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
, DataStructures::List< list_type >
, RakNet::TeamManager
, RakNet::RakWString
, ThreadPool< InputType, OutputType >
  • ClearAdminAddresses() : RakNet::Lobby2Server
  • ClearBanList()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • ClearCallbackInterfaces() : RakNet::Lobby2Plugin
  • ClearCallbacks() : RakNet::FileListTransfer
  • ClearEventCallbacks() : RakNet::Rackspace
  • ClearInput() : ThreadPool< InputType, OutputType >
  • ClearLoginServerAdddresses() : RakNet::RoomsPlugin
  • ClearOutput() : ThreadPool< InputType, OutputType >
  • ClearPointer() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • ClearPointers() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • ClearRankingAddresses() : RakNet::Lobby2Server
  • ClearRoomMembers() : RakNet::RoomsPlugin
  • ClientImpl()
: RakNet::Lobby2Message
, RakNet::Client_StartIgnore
, RakNet::Client_StopIgnore
, RakNet::Client_GetIgnoreList
  • CloseAllChannels() : RakNet::RakVoice
  • CloseConnection()
: RakNet::RakNetTransport2
, RakNet::TransportInterface
, RakNet::RakPeerInterface
, RakNet::TelnetTransport
, RakNet::RakPeer
  • CloseVoiceChannel() : RakNet::RakVoice
  • ColumnIndex() : DataStructures::Table
  • ColumnName() : DataStructures::Table
  • Compress() : MemoryCompressor , DataStructures::List< list_type >
  • ConfirmResizedServer() : RakNet::Rackspace
  • Connect()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • ConnectionExists() : RakNet::ConnectionGraph2
  • connectionStartTime : RakNet::RakNetStatistics
  • ConnectToDB()
: RakNet::Lobby2Server
, RakNet::Lobby2Server_PGSQL
  • ConnectWithSocket()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • ConstructionMode : RakNet::Connection_RM3
  • ContainsNonprintableExceptSpaces() : RakNet::RakString
  • context : RakNet::FileListNode
  • CopyData() : RakNet::BitStream
  • CopyPort() : RakNet::SystemAddress
  • CreateAutopatcherTables()
: RakNet::AutopatcherPostgreRepository
, RakNet::AutopatcherMySQLRepository
  • CreateImage() : RakNet::Rackspace
  • CreateServer() : RakNet::Rackspace
  • creatingSystemGUID : RakNet::Replica3
  • creationTime : RakNet::InternalPacket
  • currentRating : RakNet::Ranking_GetRating
  • curTime : RakNet::SerializeParameters
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • data
: DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
, RakNet::FileListNode
, RakNet::Packet
, RakNet::InternalPacket
  • dataLengthBytes : RakNet::FileListNode
  • dataSize : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • DC_CONTINUOUS : RakNet::StatisticsHistory
  • DC_DISCRETE : RakNet::StatisticsHistory
  • DeallocateCloudQueryRow() : RakNet::CloudAllocator
  • DeallocatePacket()
: RakNet::RakNetTransport2
, RakNet::RakPeer
, RakNet::RakPeerInterface
, RakNet::TelnetTransport
, RakNet::TransportInterface
  • DeallocateRowData() : RakNet::CloudAllocator
  • DeallocateWithDefaultAllocator() : RakNet::CloudClient
  • DeallocConnection() : RakNet::ReplicaManager3
  • DeallocReplica()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • DebugMsg() : RakNet::Lobby2Message
  • debugPort : RakNet::SystemAddress
  • DebugPrintf() : RakNet::Lobby2Message
  • DecodeString()
: RakNet::StringCompressor
, RakNet::StringTable
  • DecodeTeamAssigned() : RakNet::TeamManager
  • DecodeTeamCancelled() : RakNet::TeamManager
  • DecomposeTeamFull() : RakNet::TeamManager
  • DecomposeTeamLocked() : RakNet::TeamManager
  • DefaultAssigmentAlgorithm : RakNet::TeamBalancer
  • Deinit() : RakNet::RakVoice
  • DeleteEvent() : RakNet::ReadyEvent
  • DeleteFilterSet() : RakNet::MessageFilter
  • DeleteImage() : RakNet::Rackspace
  • DeleteMember() : RakNet::TeamBalancer
  • DeleteServer() : RakNet::Rackspace
  • DeleteServerAddress() : RakNet::Rackspace
  • deletingSystemGUID : RakNet::Replica3
  • Dereference() : RakNet::ReplicaManager3
  • DereferenceList() : RakNet::ReplicaManager3
  • DereferenceTeam() : RakNet::TM_World
  • DereferenceTeamMember() : RakNet::TM_World
  • Deserialize()
: RakNet::RakString
, RakNet::RakWString
, RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
, RakNet::RakWString
  • DeserializeCompressed() : RakNet::RakString
  • DeserializeConstruction()
: RakNet::Replica3Composite< parent_type >
, RakNet::TM_Team
, RakNet::Replica3
, RakNet::TM_TeamMember
  • DeserializeConstructionExisting()
: RakNet::Replica3Composite< parent_type >
, RakNet::Replica3
  • DeserializeDestruction()
: RakNet::Replica3Composite< parent_type >
, RakNet::Replica3
  • DeserializeOnDownloadComplete() : RakNet::Connection_RM3
  • DeserializeOnDownloadStarted() : RakNet::Connection_RM3
  • DeserializeVariable() : RakNet::VariableDeltaSerializer
  • destinationConnection : RakNet::SerializeParameters
  • DestroyAutopatcherTables()
: RakNet::AutopatcherPostgreRepository
, RakNet::AutopatcherMySQLRepository
  • DetachPlugin()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • DetectNATType() : RakNet::NatTypeDetectionClient
  • directedToRoom : RakNet::Bitstream_Func
  • DisableSecurity()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • DO_NOT_DISTURB : RakNet::Lobby2Presence
  • DoEndianSwap() : RakNet::BitStream
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • EDITING_PROFILE : RakNet::Lobby2Presence
  • emailResults : RakNet::Emails_Get
  • EncodeArray() : RakNet::HuffmanEncodingTree
  • EncodeString()
: RakNet::StringCompressor
, RakNet::StringTable
  • EndDeserialize() : RakNet::VariableDeltaSerializer
  • EndSerialize() : RakNet::VariableDeltaSerializer
  • endThreads : RakNet::RakPeer
  • EqualsExcludingPort() : RakNet::SystemAddress
  • Erase() : RakNet::RakString
  • EstablishRouting() : RakNet::Router2
  • EventTypeToString() : RakNet::Rackspace
  • ExecuteCommand() : RakNet::Lobby2Server
  • ExecuteFunc() : RakNet::RoomsPlugin
  • extendedResultCode : RakNet::Lobby2Message
  • extraSocketOptions : RakNet::SocketDescriptor
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • fileLengthBytes : RakNet::FileListNode
  • filename : RakNet::FileListNode
  • FILL_IN_ORDER : RakNet::TeamBalancer
  • Find() : RakNet::RakString
  • FindIntersection() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • FindRouterPortStride() : RakNet::NatPunchthroughClient
  • FlagDirtyFromBitArray() : RakNet::VariableListDeltaTracker
  • ForceCompletion() : RakNet::ReadyEvent
  • ForceExternalSystemAddress() : RakNet::CloudServer
  • ForEach() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • FormatForDELETE() : RakNet::RakString
  • FormatForGET() : RakNet::RakString
  • FormatForPOST() : RakNet::RakString
  • FPrintf()
: RakNet::RakWString
, RakNet::RakString
  • FreeMemory()
: RakNet::HuffmanEncodingTree
, RakNet::RakString
  • FromString() : RakNet::SystemAddress
  • FromStringExplicitPort() : RakNet::SystemAddress
  • fullPathToFile : RakNet::FileListNode
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • GenerateFromFrequencyTable() : RakNet::HuffmanEncodingTree
  • GenerateTree() : RakNet::HuffmanEncodingTreeFactory
  • GenerateTreeFromStrings() : RakNet::StringCompressor
  • Get()
: RakNet::CloudClient
, DataStructures::Table::Cell
, RakNet::HTTPConnection
, DataStructures::List< list_type >
, DataStructures::Table::Cell
  • Get64BitUniqueRandomNumber() : RakNet::RakPeerInterface
  • GET_OBJECT_FROM_ID() : RakNet::NetworkIDManager
  • GetAllConnectionDownloadsCompleted() : RakNet::ReplicaManager3
  • GetAutoCreateConnections() : RakNet::ReplicaManager3
  • GetAutoDestroyConnections() : RakNet::ReplicaManager3
  • GetAutoProcessNewConnections() : RakNet::ConnectionGraph2
  • GetAvailableRowId() : DataStructures::Table
  • GetAveragePing()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetBalanceTeams() : RakNet::TM_World
  • GetBalancingApplies() : RakNet::TM_Team
  • GetBestClockDifferential() : RakNet::RakPeer
  • GetBufferedBytesToReturn() : RakNet::RakVoice
  • GetBufferedBytesToSend() : RakNet::RakVoice
  • GetBufferSizeBytes() : RakNet::RakVoice
  • GetCallbacks() : RakNet::FileListTransfer
  • GetCellValueByIndex() : DataStructures::Table
  • GetChangelistSinceDate()
: RakNet::AutopatcherRepositoryInterface
, RakNet::AutopatcherPostgreRepository
, RakNet::AutopatcherMySQLRepository
  • GetChannelIndexFromName() : RakNet::LogCommandParser
  • GetCharacterCount() : RakNet::RakString
  • GetClientPublicKeyFromSystemAddress()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetClockDifferential()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetColumnCount() : DataStructures::Table
  • GetColumns() : DataStructures::Table
  • GetColumnType() : DataStructures::Table
  • GetCommandParser()
: RakNet::RakNetTransport2
, RakNet::TelnetTransport
, RakNet::TransportInterface
  • GetConfigurationProperties() : RakNet::Lobby2Server
  • GetConnectionAtIndex() : RakNet::ReplicaManager3
  • GetConnectionByGUID() : RakNet::ReplicaManager3
  • GetConnectionBySystemAddress() : RakNet::ReplicaManager3
  • GetConnectionCount() : RakNet::ReplicaManager3
  • GetConnectionList()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetConnectionListForRemoteSystem() : RakNet::ConnectionGraph2
  • GetConnectionState()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetConnectionsThatHaveReplicaConstructed() : RakNet::ReplicaManager3
  • GetConstructedReplicas() : RakNet::Connection_RM3
  • GetCreatingSystemGUID() : RakNet::Replica3
  • GetCurrentExecution() : RakNet::RPC3
  • GetCurrentTeam() : RakNet::TM_TeamMember
  • GetCurrentTeamByIndex() : RakNet::TM_TeamMember
  • GetCurrentTeamCount() : RakNet::TM_TeamMember
  • GetCurrentTeams() : RakNet::TM_TeamMember
  • GetData() : RakNet::BitStream
  • GetDebugInterface() : RakNet::Router2
  • GetDownloadWasCompleted() : RakNet::Connection_RM3
  • GetEncoderComplexity() : RakNet::RakVoice
  • GetEventAtIndex() : RakNet::ReadyEvent
  • GetEventListSize() : RakNet::ReadyEvent
  • GetExternalID()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetFilePart()
: RakNet::AutopatcherPostgreRepository
, RakNet::AutopatcherMySQLRepository
  • GetFilterSetCount() : RakNet::MessageFilter
  • GetFilterSetIDByIndex() : RakNet::MessageFilter
  • GetFlavorDetails() : RakNet::Rackspace
  • GetFrequencyTable() : RakNet::HuffmanEncodingTreeFactory
  • GetFromWaitListAtIndex() : RakNet::ReadyEvent
  • GetGUIDFromIndex()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetGuidFromSystemAddress()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetHost() : RakNet::TM_World
  • GetID() : RakNet::Lobby2Message
  • GetImageDetails() : RakNet::Rackspace
  • GetIncomingPassword()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetIncrementalReadChunkSize()
: RakNet::AutopatcherRepositoryInterface
, RakNet::AutopatcherPostgreRepository
, RakNet::AutopatcherMySQLRepository
  • GetIndexFromSystemAddress()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetIndexOf() : DataStructures::List< list_type > , DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • GetInputAtIndex() : ThreadPool< InputType, OutputType >
  • GetInsertionIndex() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • GetInternalID()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetIPVersion() : RakNet::SystemAddress
  • GetJoinPermissions() : RakNet::TM_Team
  • GetLastError()
: RakNet::AutopatcherRepositoryInterface
, RakNet::AutopatcherPostgreRepository
, RakNet::AutopatcherMySQLRepository
  • GetLastPing()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetLastSenderAddress() : RakNet::RPC3
  • GetLastSenderTimestamp() : RakNet::RPC3
  • GetLastTeams() : RakNet::TM_TeamMember
  • GetLength()
: RakNet::RakString
, RakNet::RakWString
  • GetListHead() : DataStructures::Table
  • GetLocalIP()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetLowestAveragePingSystem() : RakNet::ConnectionGraph2
  • GetLowestPing()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetMaxConurrentUsers() : RakNet::AutopatcherServer
  • GetMaxForwardEntries() : RakNet::UDPForwarder
  • GetMaximumIncomingConnections()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetMaximumNumberOfPeers()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetMemberLimit() : RakNet::TM_Team
  • GetMemberLimitSetting() : RakNet::TM_Team
  • GetMessageFactory() : RakNet::Lobby2Plugin
  • GetMostRecentChangelistWithPatches()
: RakNet::AutopatcherRepositoryInterface
, RakNet::AutopatcherPostgreRepository
, RakNet::AutopatcherMySQLRepository
  • GetMTUSize()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetMultilistType() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • GetMyBoundAddress()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetMyGUID()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetMyTeam() : RakNet::TeamBalancer
  • GetName()
: RakNet::CommandParserInterface
, RakNet::RakNetCommandParser
, RakNet::Lobby2Message
, RakNet::LogCommandParser
  • GetNetworkID()
: RakNet::NetworkIDObject
, RakNet::TM_Team
, RakNet::TM_TeamMember
  • GetNetworkIDManager()
: RakNet::NetworkIDObject
, RakNet::ReplicaManager3
  • GetNextSendReceipt()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • GetNoTeamId() : RakNet::TM_TeamMember
  • GetNumberOfAddresses()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetNumberOfBitsUsed() : RakNet::BitStream
  • GetNumberOfBytesUsed() : RakNet::BitStream
  • GetNumberOfRemoteInitiatedConnections() : RakNet::RakPeer
  • GetNumberOfUnreadBits() : RakNet::BitStream
  • GetOfflinePingResponse()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetOutput() : ThreadPool< InputType, OutputType >
  • GetOutputAtIndex() : ThreadPool< InputType, OutputType >
  • GetOwner()
: RakNet::TM_TeamMember
, RakNet::TM_Team
  • GetParent() : RakNet::NetworkIDObject
  • GetParticipantList()
: RakNet::TM_World
, RakNet::ConnectionGraph2
  • GetPatches()
: RakNet::AutopatcherRepositoryInterface
, RakNet::AutopatcherPostgreRepository
, RakNet::AutopatcherMySQLRepository
  • GetPendingFilesToAddress() : RakNet::FileListTransfer
  • GetPingBetweenSystems() : RakNet::ConnectionGraph2
  • GetPort() : RakNet::SystemAddress
  • GetPresence() : RakNet::Lobby2Server
  • GetPtr() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • GetPunchthroughConfiguration() : RakNet::NatPunchthroughClient
  • GetRakNetGUID() : RakNet::Connection_RM3
  • GetRakPeer() : RakNet::RPC3
  • GetRakPeerInterface() : RakNet::RakVoice
  • GetReadOffset() : RakNet::BitStream
  • GetReadyStatus() : RakNet::ReadyEvent
  • GetReceiveBufferSize()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetReferencedReplicaList() : RakNet::ReplicaManager3
  • GetRemoteServers() : RakNet::CloudServer
  • GetRemoteSystemFromSystemAddress() : RakNet::RakPeer
  • GetRemoteWaitListSize() : RakNet::ReadyEvent
  • GetReplicaAtIndex() : RakNet::ReplicaManager3
  • GetReplicaCount() : RakNet::ReplicaManager3
  • GetReplicasCreatedByGuid() : RakNet::ReplicaManager3
  • GetReplicasCreatedByMe() : RakNet::ReplicaManager3
  • GetRequestedSpecificTeams() : RakNet::TM_TeamMember
  • GetRequestedTeam() : RakNet::TM_TeamMember
  • GetRequestedTeamCount() : RakNet::TM_TeamMember
  • GetRequestedTeamIndex() : RakNet::TM_TeamMember
  • GetResponse() : RakNet::HTTPConnection2
  • GetRowByID() : DataStructures::Table
  • GetRowByIndex() : DataStructures::Table
  • GetRowCount() : DataStructures::Table
  • GetRows() : DataStructures::Table
  • GetSampleRate() : RakNet::RakVoice
  • GetServerAddress() : RakNet::HTTPConnection
  • GetServerDetails() : RakNet::Rackspace
  • GetSize() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • GetSocket()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetSockets()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetSortOrder() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • GetSplitMessageProgressInterval()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • GetStatistics()
: RakNet::RakPeerInterface
, RakNet::ReliabilityLayer
, RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetStatisticsList()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • GetSystemAddress() : RakNet::Connection_RM3
  • GetSystemAddressFromGuid()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • GetSystemAddressFromIndex()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetSystemCount() : RakNet::MessageFilter
  • GetSystemFilterSet() : RakNet::MessageFilter
  • GetSystemList()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetTeamByIndex() : RakNet::TM_World
  • GetTeamByNetworkID() : RakNet::TM_World
  • GetTeamCount() : RakNet::TM_World
  • GetTeamIndex() : RakNet::TM_World
  • GetTeamManager() : RakNet::TM_World
  • GetTeamMemberByIndex()
: RakNet::TM_Team
, RakNet::TM_World
  • GetTeamMemberByNetworkID() : RakNet::TM_World
  • GetTeamMemberCount() : RakNet::TM_World
  • GetTeamMemberIDByIndex() : RakNet::TM_World
  • GetTeamMemberIndex() : RakNet::TM_World
  • GetTeamMembers() : RakNet::TM_Team
  • GetTeamMembersCount() : RakNet::TM_Team
  • GetTimeoutTime()
: RakNet::ReliabilityLayer
, RakNet::RakPeerInterface
, RakNet::RakPeer
  • GetTM_World()
: RakNet::TM_Team
, RakNet::TM_TeamMember
  • GetUPNPPortMappings() : RakNet::NatPunchthroughClient
  • GetUsedForwardEntries() : RakNet::UDPForwarder
  • GetWorldAtIndex() : RakNet::TeamManager
  • GetWorldCount()
: RakNet::ReplicaManager3
, RakNet::TeamManager
  • GetWorldId() : RakNet::TM_World
  • GetWorldIdAtIndex() : RakNet::ReplicaManager3
  • GetWorldIndex()
: RakNet::TM_TeamMember
, RakNet::TM_Team
  • GetWorldWithId() : RakNet::TeamManager
  • guid : RakNet::Packet
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • HandleSocketReceiveFromConnectedPlayer() : RakNet::ReliabilityLayer
  • HasAdminAddress() : RakNet::Lobby2Server
  • HasBadResponse() : RakNet::HTTPConnection
  • HasData() : DataStructures::OrderedList< key_type, data_type, default_comparison_function >
  • HasEvent() : RakNet::ReadyEvent
  • Hash() : DataStructures::Hash< key_type, data_type, HASH_SIZE, hashFunction >
  • HasInput() : ThreadPool< InputType, OutputType >
  • HasInputFast() : ThreadPool< InputType, OutputType >
  • HasLostConnection()
: RakNet::RakNetTransport2
, RakNet::TelnetTransport
, RakNet::TransportInterface
  • HasNewIncomingConnection()
: RakNet::RakNetTransport2
, RakNet::TelnetTransport
, RakNet::TransportInterface
  • HasOutput() : ThreadPool< InputType, OutputType >
  • HasOutputFast() : ThreadPool< InputType, OutputType >
  • HasRankingAddress() : RakNet::Lobby2Server
  • HasRead() : RakNet::HTTPConnection
  • HasReplicaConstructed() : RakNet::Connection_RM3
  • HasRequestedTeam() : RakNet::TM_TeamMember
  • HasResponse() : RakNet::HTTPConnection2
  • hostAddress : RakNet::SocketDescriptor
  • HTTPConnection() : RakNet::HTTPConnection
  • HuffmanEncodingTreeFactory() : RakNet::HuffmanEncodingTreeFactory
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • IgnoreBits() : RakNet::BitStream
  • IgnoreBytes() : RakNet::BitStream
  • IN_GAME : RakNet::Lobby2Presence
  • IN_LOBBY : RakNet::Lobby2Presence
  • IN_ROOM : RakNet::Lobby2Presence
  • incomingPassword : RakNet::RakPeer
  • IncrementNextSendReceipt()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • index : RakNet::IndexedIntegerValue , RakNet::IndexedBinaryValue
  • Init()
: RakNet::HTTPConnection
, RakNet::RakVoice
  • InitializeSecurity()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • InputSize() : ThreadPool< InputType, OutputType >
  • Insert() : DataStructures::List< list_type >
  • InsertAtIndex() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • Instance()
: RakNet::StringCompressor
, RakNet::StringTable
  • instance : RakNet::StringTable
  • InterruptSignal()
: RakNet::RPC4
, RakNet::RPC3
  • invitesSent : RakNet::Friends_GetInvites
  • InvokeSignal() : RakNet::RPC3
  • IPAddressMatch() : RakNet::RakString
  • IsActive()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • isAReference : RakNet::FileListNode
  • IsBanned()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • IsBusy()
: RakNet::HTTPConnection
, RakNet::HTTPConnection2
  • IsDeadConnection() : RakNet::ReliabilityLayer
  • IsEmailAddress() : RakNet::RakString
  • IsEmpty() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > , RakNet::RakString , RakNet::RakWString
  • IsEventCompleted() : RakNet::ReadyEvent
  • IsEventCompletionProcessing() : RakNet::ReadyEvent
  • IsEventSet() : RakNet::ReadyEvent
  • IsFunctionRegistered() : RakNet::RPC3
  • IsHandlerActive() : RakNet::FileListTransfer
  • IsInitialized() : RakNet::RakVoice
  • IsInSecurityExceptionList()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • IsInWaitList() : RakNet::ReadyEvent
  • isLimitedByCongestionControl : RakNet::RakNetStatistics
  • isLimitedByOutgoingBandwidthLimit : RakNet::RakNetStatistics
  • IsLocalIP()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • IsLoopback() : RakNet::SystemAddress
  • IsLoopbackMode() : RakNet::RakVoice
  • isMainLoopThreadActive : RakNet::RakPeer
  • IsNetworkSimulatorActive()
: RakNet::ReliabilityLayer
, RakNet::RakPeerInterface
, RakNet::RakPeer
  • IsNoiseFilterActive() : RakNet::RakVoice
  • IsOnTeam() : RakNet::TM_TeamMember
  • IsOutgoingDataWaiting() : RakNet::ReliabilityLayer
  • IsSendingVoiceDataTo() : RakNet::RakVoice
  • IsSorted() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • IsVADActive() : RakNet::RakVoice
  • IsVBRActive() : RakNet::RakVoice
  • isVisible : RakNet::Lobby2Presence
  • IsWorking() : ThreadPool< InputType, OutputType >
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • keys : RakNet::CloudQuery
  • KillConnection() : RakNet::ReliabilityLayer
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • lastSentBitstream : RakNet::SerializeParameters
  • LeaveAllTeams() : RakNet::TM_TeamMember
  • LeaveTeam()
: RakNet::TM_Team
, RakNet::TM_TeamMember
  • length : RakNet::Packet
  • List() : DataStructures::List< list_type >
  • ListFlavors() : RakNet::Rackspace
  • ListImages() : RakNet::Rackspace
  • ListServerAddresses() : RakNet::Rackspace
  • ListServers() : RakNet::Rackspace
  • ListServersWithDetails() : RakNet::Rackspace
  • ListSharedIPGroups() : RakNet::Rackspace
  • ListSharedIPGroupsWithDetails() : RakNet::Rackspace
  • LockInput() : ThreadPool< InputType, OutputType >
  • LockOutput() : ThreadPool< InputType, OutputType >
  • LogHeader() : RakNet::PacketLogger
  • LoginRoomsParticipant() : RakNet::RoomsPlugin
  • LoginToCoordinator() : RakNet::UDPProxyServer
  • LogoffRoomsParticipant() : RakNet::RoomsPlugin
  • LogStringNotFound() : RakNet::StringTable
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • MakeFilePath() : RakNet::RakString
  • maximumIncomingConnections : RakNet::RakPeer
  • maximumNumberOfPeers : RakNet::RakPeer
  • maxRowsToReturn : RakNet::CloudQuery
  • messageInSendBuffer : RakNet::RakNetStatistics
  • messageInternalOrder : RakNet::InternalPacket
  • messageNumberAssigned : RakNet::InternalPacket
  • messagesInResendBuffer : RakNet::RakNetStatistics
  • messageTimestamp : RakNet::SerializeParameters
  • MINIMIZED : RakNet::Lobby2Presence
  • myPrivateKey : RakNet::PublicKey
  • myPublicKey : RakNet::PublicKey
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • networkID : RakNet::NetworkIDObject
  • nextActionTime : RakNet::InternalPacket
  • nextSlotRegistrationCount : RakNet::RPC3 , RakNet::RPC4
  • NonVariadic() : RakNet::RakString
  • NORMAL : RakNet::InternalPacket
  • NOT_ONLINE : RakNet::Lobby2Presence
  • NoTeam() : RakNet::TeamSelection
  • NotifyAndFlagForShutdown() : RakNet::RakPeer
  • NumberOfConnections()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • NumberOfLeadingZeroes() : RakNet::BitStream
  • NumThreadsWorking() : ThreadPool< InputType, OutputType >
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • OnAck()
: RakNet::PacketLogger
, RakNet::PluginInterface2
  • OnAddFilesFromDirectoryStarted()
: RakNet::FLP_Printf
, RakNet::FileListProgress
  • OnAllServersBusy() : RakNet::UDPProxyClientResultHandler
  • OnAlreadyLoggedIn() : RakNet::UDPProxyServerResultHandler
  • OnAttach()
: RakNet::PluginInterface2
, RakNet::RPC4
, RakNet::TeamBalancer
, RakNet::UDPProxyServer
, RakNet::AutopatcherServer
, RakNet::RPC3
, RakNet::NatPunchthroughClient
, RakNet::SQLite3ServerPlugin
  • OnClosedConnection()
: RakNet::ConnectionGraph2
, RakNet::TeamBalancer
, RakNet::TeamManager
, RakNet::FileListTransfer
, RakNet::TwoWayAuthentication
, RakNet::UDPProxyCoordinator
, RakNet::HTTPConnection2
, RakNet::UDPProxyServer
, RakNet::RakVoice
, RakNet::MessageFilter
, RakNet::AutopatcherServer
, RakNet::Lobby2Client
, RakNet::NatPunchthroughClient
, RakNet::Lobby2Server
, RakNet::RoomsPlugin
, RakNet::NatPunchthroughServer
, RakNet::RPC3
, RakNet::NatTypeDetectionClient
, RakNet::NatTypeDetectionServer
, RakNet::PluginInterface2
, RakNet::Rackspace
, RakNet::RakNetTransport2
, RakNet::ReadyEvent
, RakNet::RelayPlugin
, RakNet::ReplicaManager3
, RakNet::CloudServer
, RakNet::Router2
, RakNet::StatisticsHistoryPlugin
  • OnCommand()
: RakNet::CommandParserInterface
, RakNet::LogCommandParser
, RakNet::RakNetCommandParser
  • OnConnectionLost()
: RakNet::CommandParserInterface
, RakNet::LogCommandParser
  • OnDereference() : RakNet::FileListTransferCBInterface
  • OnDetach()
: RakNet::NatPunchthroughClient
, RakNet::NatTypeDetectionClient
, RakNet::PluginInterface2
, RakNet::ReplicaManager3
, RakNet::UDPProxyServer
, RakNet::AutopatcherServer
, RakNet::RoomsPlugin
, RakNet::SQLite3ServerPlugin
  • OnDirectory()
: RakNet::FileListProgress
, RakNet::FLP_Printf
  • OnDirectSocketReceive()
: RakNet::PacketLogger
, RakNet::PluginInterface2
  • OnDirectSocketSend()
: RakNet::PacketLogger
, RakNet::PluginInterface2
  • OnDownloadComplete() : RakNet::FileListTransferCBInterface
  • OnFailedConnectionAttempt()
: RakNet::HTTPConnection2
, RakNet::PluginInterface2
, RakNet::Router2
  • OnFile()
: RakNet::FileListProgress
, RakNet::FileListTransferCBInterface
  • OnFileProgress() : RakNet::FileListTransferCBInterface
  • OnFilePush() : RakNet::FileListProgress
  • OnFilePushesComplete()
: RakNet::FileListProgress
, RakNet::FLP_Printf
, RakNet::AutopatcherServer
  • OnForwardingInProgress() : RakNet::UDPProxyClientResultHandler
  • OnForwardingNotification() : RakNet::UDPProxyClientResultHandler
  • OnForwardingSuccess() : RakNet::UDPProxyClientResultHandler
  • OnGet() : RakNet::CloudClientCallback
  • OnGetReponse() : RakNet::CloudClient
  • OnGetRequest() : RakNet::CloudServerQueryFilter
  • OnInternalPacket()
: RakNet::PacketLogger
, RakNet::PluginInterface2
  • OnLoginSuccess() : RakNet::UDPProxyServerResultHandler
  • OnMessageReceipt() : RakNet::VariableDeltaSerializer
  • OnNewConnection()
: RakNet::ConnectionGraph2
, RakNet::HTTPConnection2
, RakNet::MessageFilter
, RakNet::NatPunchthroughClient
, RakNet::NatPunchthroughServer
, RakNet::PluginInterface2
, RakNet::RakNetTransport2
, RakNet::ReplicaManager3
, RakNet::StatisticsHistoryPlugin
, RakNet::TeamManager
  • OnNewIncomingConnection()
: RakNet::CommandParserInterface
, RakNet::LogCommandParser
  • OnNoPasswordSet() : RakNet::UDPProxyServerResultHandler
  • OnNoServersOnline() : RakNet::UDPProxyClientResultHandler
  • OnPoppedConnection()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • OnPostRequest() : RakNet::CloudServerQueryFilter
  • OnPreSerializeTick() : RakNet::VariableDeltaSerializer
  • OnPushBackPacket()
: RakNet::PacketLogger
, RakNet::PluginInterface2
  • OnRakPeerShutdown()
: RakNet::NatPunchthroughClient
, RakNet::ReplicaManager3
, RakNet::CloudServer
, RakNet::FileListTransfer
, RakNet::NatTypeDetectionClient
, RakNet::PluginInterface2
, RakNet::ReadyEvent
, RakNet::Router2
, RakNet::TwoWayAuthentication
, RakNet::UDPProxyClient
, RakNet::UDPProxyServer
  • OnRakPeerStartup()
: RakNet::PluginInterface2
, RakNet::UDPProxyServer
  • OnReceive()
: RakNet::Router2
, RakNet::ReplicaManager3
, RakNet::FileListTransfer
, RakNet::PluginInterface2
, RakNet::NatTypeDetectionClient
, RakNet::NatPunchthroughClient
, RakNet::HTTPConnection2
, RakNet::ConnectionGraph2
, RakNet::Rackspace
, RakNet::RakNetTransport2
, RakNet::RelayPlugin
, RakNet::TeamBalancer
, RakNet::TwoWayAuthentication
, RakNet::UDPProxyCoordinator
, RakNet::Lobby2Client
, RakNet::Lobby2Server
, RakNet::RoomsPlugin
, RakNet::SQLite3ClientPlugin
, RakNet::UDPProxyClient
, RakNet::TeamManager
, RakNet::AutopatcherServer
, RakNet::UDPProxyServer
, RakNet::RakVoice
, RakNet::MessageFilter
, RakNet::SQLite3ServerPlugin
, RakNet::ReadyEvent
, RakNet::RPC4
, RakNet::CloudServer
, RakNet::CloudClient
, RakNet::NatTypeDetectionServer
, RakNet::RPC3
, RakNet::NatPunchthroughServer
  • OnRecipientNotConnected() : RakNet::UDPProxyClientResultHandler
  • OnReleaseRequest() : RakNet::CloudServerQueryFilter
  • OnReliabilityLayerNotification()
: RakNet::PacketLogger
, RakNet::PluginInterface2
  • OnSendAborted()
: RakNet::AutopatcherServer
, RakNet::FLP_Printf
, RakNet::FileListProgress
  • OnSerializeTransmission() : RakNet::Replica3
  • OnSubscriptionNotification()
: RakNet::CloudClientCallback
, RakNet::CloudClient
  • OnTransportChange()
: RakNet::LogCommandParser
, RakNet::CommandParserInterface
  • OnUnknownDBIdentifier() : RakNet::SQLite3PluginResultInterface
  • OnUnsubscribeRequest() : RakNet::CloudServerQueryFilter
  • OnUserReplicaPreSerializeTick()
: RakNet::Replica3Composite< parent_type >
, RakNet::Replica3
  • OnWrongPassword() : RakNet::UDPProxyServerResultHandler
  • OpenNAT() : RakNet::NatPunchthroughClient
  • operator const char *() : RakNet::RakString
  • operator wchar_t *() : RakNet::RakWString
  • operator!=() : RakNet::RakWString , RakNet::RakString
  • operator+=()
: RakNet::RakString
, RakNet::RakWString
  • operator=()
: DataStructures::List< list_type >
, RakNet::RakString
, RakNet::RakWString
  • operator==() : RakNet::RakString , RakNet::RakWString
  • operator[]() : DataStructures::List< list_type > , RakNet::RakString
  • outputBitstream : RakNet::SerializeParameters
  • OutputSize() : ThreadPool< InputType, OutputType >
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • packetlossLastSecond : RakNet::RakNetStatistics
  • packetlossTotal : RakNet::RakNetStatistics
  • PadWithZeroToByteLength() : RakNet::BitStream
  • parent : RakNet::NetworkIDObject
  • ParseConnectionRequestPacket() : RakNet::RakPeer
  • peer : RakNet::RakNetCommandParser
  • Ping()
: RakNet::RakPeer
, RakNet::RakPeerInterface
, RakNet::RakPeer
  • Pop() : DataStructures::List< list_type > , DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • PopConnection() : RakNet::ReplicaManager3
  • PopOpposite() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • port : RakNet::SocketDescriptor
  • Post()
: RakNet::CloudClient
, RakNet::HTTPConnection
  • PostDeserializeConstruction()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • PostDeserializeConstructionExisting()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • PostSerializeConstruction()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • PostSerializeConstructionExisting()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • Preallocate() : DataStructures::List< list_type >
  • preallocationSize : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • PreDestruction()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • presence : RakNet::Client_SetPresence , RakNet::Client_GetPresence
  • PrevalidateInput()
: RakNet::Clans_AcceptJoinRequest
, RakNet::Clans_WithdrawJoinRequest
, RakNet::Clans_SendJoinRequest
, RakNet::Clans_RejectJoinInvitation
, RakNet::Clans_AcceptJoinInvitation
, RakNet::Clans_WithdrawJoinInvitation
, RakNet::Clans_ReplyToTopic
, RakNet::Clans_Leave
, RakNet::Clans_ChangeHandle
, RakNet::Clans_GetMemberProperties
, RakNet::Lobby2Message
, RakNet::Clans_SetSubleaderStatus
, RakNet::Clans_GrantLeader
, RakNet::Friends_RejectInvite
, RakNet::Friends_Remove
, RakNet::Clans_SetProperties
, RakNet::Clans_Create
, RakNet::Ranking_GetRating
, RakNet::Platform_Startup
, RakNet::Ranking_UpdateRating
, RakNet::Ranking_WipeMatches
, RakNet::BookmarkedUsers_Add
, RakNet::BookmarkedUsers_Remove
, RakNet::Ranking_GetMatches
, RakNet::Platform_Shutdown
, RakNet::Emails_Send
, RakNet::Emails_SetStatus
, RakNet::System_CreateDatabase
, RakNet::Ranking_SubmitMatch
, RakNet::System_DestroyDatabase
, RakNet::Ranking_GetTotalScore
, RakNet::Friends_AcceptInvite
, RakNet::Friends_SendInvite
, RakNet::Ranking_WipeScoresForPlayer
, RakNet::System_CreateTitle
, RakNet::Client_StartIgnore
, RakNet::System_DestroyTitle
, RakNet::Ranking_WipeRatings
, RakNet::System_GetTitleRequiredAge
, RakNet::Client_GetPasswordRecoveryQuestionByHandle
, RakNet::Client_GetEmailAddress
, RakNet::System_PruneAccounts
, RakNet::Clans_GetBoards
, RakNet::Client_ValidateHandle
, RakNet::Clans_CreateBoard
, RakNet::Client_RegisterAccount
, RakNet::System_GetTitleBinaryData
, RakNet::CDKey_FlagStolen
, RakNet::CDKey_Use
, RakNet::CDKey_GetStatus
, RakNet::Clans_SendJoinInvitation
, RakNet::System_UnbanUser
, RakNet::Clans_SetMemberRank
, RakNet::Clans_GetProperties
, RakNet::Clans_SetMyMemberProperties
, RakNet::System_RegisterProfanity
, RakNet::System_BanUser
, RakNet::Clans_GetTopics
, RakNet::CDKey_Add
, RakNet::Clans_GetPosts
, RakNet::Clans_RejectJoinRequest
, RakNet::Client_Login
, RakNet::Clans_KickAndBlacklistUser
, RakNet::Clans_GetBlacklist
, RakNet::Client_PerTitleBinaryStorage
, RakNet::Client_UpdateAccount
, RakNet::Client_ChangeHandle
, RakNet::Clans_CreateNewTopic
, RakNet::System_DeleteAccount
, RakNet::Clans_UnblacklistUser
, RakNet::System_SetEmailAddressValidated
, RakNet::Clans_DestroyBoard
, RakNet::Clans_GetMembers
, RakNet::Client_GetPasswordByPasswordRecoveryAnswer
, RakNet::Client_StopIgnore
  • primaryKey : RakNet::CloudKey
  • PrintBits() : RakNet::BitStream
  • PrintChannels() : RakNet::LogCommandParser
  • PrintColumnHeaders() : DataStructures::Table
  • Printf()
: RakNet::RakString
, RakNet::RakWString
  • PrintRow() : DataStructures::Table
  • priority : RakNet::InternalPacket
  • pro : RakNet::SerializeParameters
  • ProcessTCPPacket() : RakNet::HTTPConnection
  • PTIS_Operation : RakNet::Client_PerTitleBinaryStorage
  • publicKeyMode : RakNet::PublicKey
  • Push() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > , DataStructures::List< list_type >
  • PushBackPacket()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • PushConnection() : RakNet::ReplicaManager3
  • PushOpposite() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- q -

  • QUERY_CONNECTION_FOR_REPLICA_LIST : RakNet::Connection_RM3
  • QUERY_REPLICA_FOR_CONSTRUCTION : RakNet::Connection_RM3
  • QUERY_REPLICA_FOR_CONSTRUCTION_AND_DESTRUCTION : RakNet::Connection_RM3
  • QueryActionOnPopConnection()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • QueryActionOnPopConnection_Client() : RakNet::Replica3
  • QueryActionOnPopConnection_PeerToPeer() : RakNet::Replica3
  • QueryActionOnPopConnection_Server() : RakNet::Replica3
  • QueryConstruction()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • QueryConstruction_ClientConstruction() : RakNet::Replica3
  • QueryConstruction_PeerToPeer() : RakNet::Replica3
  • QueryConstruction_ServerConstruction() : RakNet::Replica3
  • QueryConstructionMode() : RakNet::Connection_RM3
  • QueryDestruction()
: RakNet::Replica3Composite< parent_type >
, RakNet::Replica3
  • QueryGroupDownloadMessages() : RakNet::Connection_RM3
  • QueryRelayDestruction()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • QueryRemoteConstruction()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • QueryRemoteConstruction_ClientConstruction() : RakNet::Replica3
  • QueryRemoteConstruction_PeerToPeer() : RakNet::Replica3
  • QueryRemoteConstruction_ServerConstruction() : RakNet::Replica3
  • QueryReplicaList() : RakNet::Connection_RM3
  • QuerySerialization()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • QuerySerialization_ClientSerializable() : RakNet::Replica3
  • QuerySerialization_PeerToPeer() : RakNet::Replica3
  • QuerySerialization_ServerSerializable() : RakNet::Replica3
  • QuerySerializationList() : RakNet::Connection_RM3
  • QueryTable() : DataStructures::Table
  • queueHead : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • queueTail : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • RakPeer() : RakNet::RakPeer
  • Read()
: RakNet::BitStream
, RakNet::HTTPConnection
, RakNet::BitStream
  • ReadAlignedBytes() : RakNet::BitStream
  • ReadAlignedBytesSafe() : RakNet::BitStream
  • ReadAlignedBytesSafeAlloc() : RakNet::BitStream
  • ReadBit() : RakNet::BitStream
  • ReadBits() : RakNet::BitStream
  • ReadBitsFromIntegerRange() : RakNet::BitStream
  • ReadCasted() : RakNet::BitStream
  • ReadCompressed() : RakNet::BitStream
  • ReadCompressedDelta() : RakNet::BitStream
  • ReadDelta() : RakNet::BitStream
  • ReadFloat16() : RakNet::BitStream
  • ReadIntFromSubstring() : RakNet::RakString
  • ReadIsLocked() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • ReadLock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • ReadNormQuat() : RakNet::BitStream
  • ReadNormVector() : RakNet::BitStream
  • ReadOrthMatrix() : RakNet::BitStream
  • ReadUnlock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • ReadVarFromBitstream() : RakNet::VariableListDeltaTracker
  • ReadVector() : RakNet::BitStream
  • Reallocate() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • RebootServer() : RakNet::Rackspace
  • RebuildServer() : RakNet::Rackspace
  • Receive()
: RakNet::RakNetTransport2
, RakNet::RakPeer
, RakNet::RakPeerInterface
, RakNet::ReliabilityLayer
, RakNet::TelnetTransport
, RakNet::TransportInterface
  • ReceiveFrame() : RakNet::RakVoice
  • recipient : RakNet::RoomsPluginNotification
  • REF_COUNTED : RakNet::InternalPacket
  • Reference() : RakNet::ReplicaManager3
  • ReferenceTeam() : RakNet::TM_World
  • ReferenceTeamMember() : RakNet::TM_World
  • RegisterBlockingFunction() : RakNet::RPC4
  • RegisterCommand() : RakNet::CommandParserInterface
  • RegisterFunction()
: RakNet::RPC4
, RakNet::RPC3
  • RegisterLocalCallback() : RakNet::RPC4
  • RegisterSlot()
: RakNet::RPC4
, RakNet::RPC3
  • RelayPlugin() : RakNet::RelayPlugin
  • Release() : RakNet::CloudClient
  • remoteServerPublicKey : RakNet::PublicKey
  • remoteSystemList : RakNet::RakPeer
  • remoteSystemVariableHistoryList : RakNet::VariableDeltaSerializer
  • remoteUsers : RakNet::LogCommandParser
  • RemoveAdminAddress() : RakNet::Lobby2Server
  • RemoveAllQueryFilters() : RakNet::CloudServer
  • RemoveApplication()
: RakNet::AutopatcherPostgreRepository
, RakNet::AutopatcherMySQLRepository
  • RemoveAtIndex() : DataStructures::List< list_type > , DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • RemoveAtIndexFast() : DataStructures::List< list_type >
  • RemoveAtKey() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • RemoveCallback() : RakNet::FileListTransfer
  • RemoveCallbackInterface() : RakNet::Lobby2Plugin
  • RemoveCharacter() : RakNet::RakString
  • RemoveColumn() : DataStructures::Table
  • RemoveCommandParser() : RakNet::ConsoleServer
  • RemoveDBHandle() : RakNet::SQLite3ServerPlugin
  • RemoveEventCallback() : RakNet::Rackspace
  • RemoveFromBanList()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • RemoveFromEnd() : DataStructures::List< list_type >
  • RemoveFromSecurityExceptionList()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • RemoveFromWaitList() : RakNet::ReadyEvent
  • RemoveInputAtIndex() : ThreadPool< InputType, OutputType >
  • RemoveLoginServerAddress() : RakNet::RoomsPlugin
  • RemoveOutputAtIndex() : ThreadPool< InputType, OutputType >
  • RemoveParticipant() : RakNet::TM_World
  • RemoveParticipantOnServer() : RakNet::RelayPlugin
  • RemoveParticipantRequestFromClient() : RakNet::RelayPlugin
  • RemoveQueryFilter() : RakNet::CloudServer
  • RemoveRankingAddress() : RakNet::Lobby2Server
  • RemoveReceiver() : RakNet::FileListTransfer
  • RemoveReference()
: RakNet::StringCompressor
, RakNet::StringTable
  • RemoveRemoteSystemVariableHistory() : RakNet::VariableDeltaSerializer
  • RemoveRoomsCallback() : RakNet::RoomsPlugin
  • RemoveRow() : DataStructures::Table
  • RemoveRows() : DataStructures::Table
  • RemoveServer() : RakNet::CloudServer
  • RemoveWorld()
: RakNet::ReplicaManager3
, RakNet::TeamManager
  • Replace()
: DataStructures::List< list_type >
, RakNet::RakString
  • replica : RakNet::LastSerializationResult
  • RequestAnyTeam() : RakNet::TeamBalancer
  • RequestForwarding() : RakNet::UDPProxyClient
  • requestId : RakNet::Lobby2Message
  • RequestSpecificTeam() : RakNet::TeamBalancer
  • requestsQueued : RakNet::AutopatcherServerLoadNotifier::AutopatcherState
  • requestsWorking : RakNet::AutopatcherServerLoadNotifier::AutopatcherState
  • RequestTeam() : RakNet::TM_TeamMember
  • RequestTeamSwitch() : RakNet::TM_TeamMember
  • RequestVoiceChannel() : RakNet::RakVoice
  • RequiresAdmin()
: RakNet::CDKey_Add
, RakNet::CDKey_GetStatus
, RakNet::CDKey_Use
, RakNet::CDKey_FlagStolen
, RakNet::Client_Login
, RakNet::Client_Logoff
, RakNet::Client_RegisterAccount
, RakNet::System_SetEmailAddressValidated
, RakNet::Client_ValidateHandle
, RakNet::System_DeleteAccount
, RakNet::System_PruneAccounts
, RakNet::Client_GetEmailAddress
, RakNet::Client_GetPasswordRecoveryQuestionByHandle
, RakNet::Client_GetPasswordByPasswordRecoveryAnswer
, RakNet::Client_ChangeHandle
, RakNet::Client_UpdateAccount
, RakNet::Client_GetAccountDetails
, RakNet::Client_StartIgnore
, RakNet::Client_StopIgnore
, RakNet::Client_GetIgnoreList
, RakNet::Client_PerTitleBinaryStorage
, RakNet::Client_SetPresence
, RakNet::Client_GetPresence
, RakNet::Friends_SendInvite
, RakNet::Friends_AcceptInvite
, RakNet::Friends_RejectInvite
, RakNet::Friends_GetInvites
, RakNet::Friends_GetFriends
, RakNet::Friends_Remove
, RakNet::BookmarkedUsers_Add
, RakNet::BookmarkedUsers_Remove
, RakNet::BookmarkedUsers_Get
, RakNet::Emails_Send
, RakNet::Emails_Get
, RakNet::Emails_Delete
, RakNet::Emails_SetStatus
, RakNet::Ranking_SubmitMatch
, RakNet::Ranking_GetMatches
, RakNet::Ranking_GetMatchBinaryData
, RakNet::Ranking_GetTotalScore
, RakNet::Ranking_WipeScoresForPlayer
, RakNet::Ranking_WipeMatches
, RakNet::Ranking_PruneMatches
, RakNet::Ranking_UpdateRating
, RakNet::Ranking_WipeRatings
, RakNet::Ranking_GetRating
, RakNet::Clans_Create
, RakNet::Clans_SetProperties
, RakNet::Clans_GetProperties
, RakNet::Clans_SetMyMemberProperties
, RakNet::Clans_GrantLeader
, RakNet::Clans_SetSubleaderStatus
, RakNet::Clans_SetMemberRank
, RakNet::Clans_GetMemberProperties
, RakNet::Clans_ChangeHandle
, RakNet::Clans_Leave
, RakNet::Clans_Get
, RakNet::Clans_SendJoinInvitation
, RakNet::Clans_WithdrawJoinInvitation
, RakNet::Clans_AcceptJoinInvitation
, RakNet::Clans_RejectJoinInvitation
, RakNet::Clans_DownloadInvitationList
, RakNet::Clans_SendJoinRequest
, RakNet::Clans_WithdrawJoinRequest
, RakNet::Clans_AcceptJoinRequest
, RakNet::Clans_RejectJoinRequest
, RakNet::Clans_DownloadRequestList
, RakNet::Clans_KickAndBlacklistUser
, RakNet::Clans_UnblacklistUser
, RakNet::Clans_GetBlacklist
, RakNet::Clans_GetMembers
, RakNet::Clans_GetList
, RakNet::Clans_CreateBoard
, RakNet::Clans_DestroyBoard
, RakNet::Clans_CreateNewTopic
, RakNet::Clans_ReplyToTopic
, RakNet::Clans_RemovePost
, RakNet::Clans_GetBoards
, RakNet::Clans_GetTopics
, RakNet::Clans_GetPosts
, RakNet::Lobby2Message
, RakNet::Platform_Startup
, RakNet::Platform_Shutdown
, RakNet::System_CreateDatabase
, RakNet::System_DestroyDatabase
, RakNet::System_CreateTitle
, RakNet::System_DestroyTitle
, RakNet::System_GetTitleRequiredAge
, RakNet::System_GetTitleBinaryData
, RakNet::System_RegisterProfanity
, RakNet::System_BanUser
, RakNet::System_UnbanUser
  • requiresEmailAddressValidationToLogin : RakNet::Lobby2Server::ConfigurationProperties
  • RequiresLogin()
: RakNet::Client_ChangeHandle
, RakNet::Emails_SetStatus
, RakNet::Ranking_SubmitMatch
, RakNet::Ranking_GetMatches
, RakNet::Ranking_GetMatchBinaryData
, RakNet::Ranking_GetTotalScore
, RakNet::Ranking_WipeScoresForPlayer
, RakNet::Ranking_WipeMatches
, RakNet::Clans_CreateNewTopic
, RakNet::Ranking_UpdateRating
, RakNet::Ranking_WipeRatings
, RakNet::Ranking_GetRating
, RakNet::Clans_SetProperties
, RakNet::Clans_GetProperties
, RakNet::Clans_RemovePost
, RakNet::Clans_GetMembers
, RakNet::Clans_SetSubleaderStatus
, RakNet::Clans_SetMemberRank
, RakNet::Clans_GetMemberProperties
, RakNet::Clans_Leave
, RakNet::Clans_Get
, RakNet::Clans_CreateBoard
, RakNet::Clans_DownloadRequestList
, RakNet::Clans_AcceptJoinInvitation
, RakNet::Clans_RejectJoinInvitation
, RakNet::Clans_DownloadInvitationList
, RakNet::Clans_WithdrawJoinRequest
, RakNet::Clans_AcceptJoinRequest
, RakNet::Clans_RejectJoinRequest
, RakNet::Clans_SendJoinInvitation
, RakNet::Clans_SendJoinRequest
, RakNet::Clans_KickAndBlacklistUser
, RakNet::Clans_UnblacklistUser
, RakNet::Clans_GetBlacklist
, RakNet::Clans_GetList
, RakNet::Clans_DestroyBoard
, RakNet::Clans_WithdrawJoinInvitation
, RakNet::Clans_ReplyToTopic
, RakNet::Clans_GetBoards
, RakNet::Clans_GetPosts
, RakNet::Clans_SetMyMemberProperties
, RakNet::Clans_ChangeHandle
, RakNet::Clans_GrantLeader
, RakNet::Emails_Send
, RakNet::Clans_Create
, RakNet::Ranking_PruneMatches
, RakNet::Emails_Get
, RakNet::Emails_Delete
, RakNet::Client_GetAccountDetails
, RakNet::Friends_RejectInvite
, RakNet::BookmarkedUsers_Remove
, RakNet::Friends_GetInvites
, RakNet::Friends_Remove
, RakNet::Client_GetPresence
, RakNet::Friends_AcceptInvite
, RakNet::Client_StopIgnore
, RakNet::Clans_GetTopics
, RakNet::System_PruneAccounts
, RakNet::Client_RegisterAccount
, RakNet::CDKey_Use
, RakNet::Lobby2Message
, RakNet::Platform_Startup
, RakNet::Platform_Shutdown
, RakNet::System_CreateDatabase
, RakNet::System_DestroyDatabase
, RakNet::System_CreateTitle
, RakNet::System_GetTitleRequiredAge
, RakNet::System_GetTitleBinaryData
, RakNet::System_RegisterProfanity
, RakNet::System_UnbanUser
, RakNet::CDKey_Add
, RakNet::CDKey_GetStatus
, RakNet::CDKey_FlagStolen
, RakNet::Client_Login
, RakNet::Client_Logoff
, RakNet::System_SetEmailAddressValidated
, RakNet::Client_ValidateHandle
, RakNet::System_DeleteAccount
, RakNet::Client_GetEmailAddress
, RakNet::Client_GetPasswordRecoveryQuestionByHandle
, RakNet::Client_GetPasswordByPasswordRecoveryAnswer
, RakNet::System_BanUser
, RakNet::Client_UpdateAccount
, RakNet::Friends_SendInvite
, RakNet::Client_StartIgnore
, RakNet::Client_GetIgnoreList
, RakNet::Client_PerTitleBinaryStorage
, RakNet::Client_SetPresence
, RakNet::System_DestroyTitle
, RakNet::Friends_GetFriends
, RakNet::BookmarkedUsers_Add
, RakNet::BookmarkedUsers_Get
  • RequiresRankingPermission()
: RakNet::Client_UpdateAccount
, RakNet::Client_ValidateHandle
, RakNet::Clans_GetMemberProperties
, RakNet::Clans_WithdrawJoinRequest
, RakNet::Client_RegisterAccount
, RakNet::System_CreateTitle
, RakNet::Clans_UnblacklistUser
, RakNet::Platform_Shutdown
, RakNet::Clans_GrantLeader
, RakNet::CDKey_Add
, RakNet::CDKey_FlagStolen
, RakNet::CDKey_Use
, RakNet::Clans_CreateNewTopic
, RakNet::Client_Login
, RakNet::Lobby2Message
, RakNet::Ranking_GetRating
, RakNet::Clans_GetPosts
, RakNet::Clans_SetProperties
, RakNet::Ranking_WipeScoresForPlayer
, RakNet::Ranking_UpdateRating
, RakNet::BookmarkedUsers_Get
, RakNet::System_DeleteAccount
, RakNet::Clans_WithdrawJoinInvitation
, RakNet::Ranking_WipeMatches
, RakNet::Ranking_PruneMatches
, RakNet::BookmarkedUsers_Add
, RakNet::Ranking_GetMatches
, RakNet::System_PruneAccounts
, RakNet::Clans_DownloadInvitationList
, RakNet::Client_StartIgnore
, RakNet::Client_GetIgnoreList
, RakNet::Clans_ChangeHandle
, RakNet::Client_GetEmailAddress
, RakNet::Client_SetPresence
, RakNet::Friends_GetFriends
, RakNet::Ranking_SubmitMatch
, RakNet::Clans_GetBlacklist
, RakNet::System_CreateDatabase
, RakNet::Clans_GetTopics
, RakNet::Client_StopIgnore
, RakNet::Emails_SetStatus
, RakNet::Clans_AcceptJoinInvitation
, RakNet::Client_ChangeHandle
, RakNet::Client_GetPasswordRecoveryQuestionByHandle
, RakNet::Clans_Leave
, RakNet::Client_GetPresence
, RakNet::Client_PerTitleBinaryStorage
, RakNet::Clans_Get
, RakNet::Emails_Delete
, RakNet::Friends_SendInvite
, RakNet::Friends_RejectInvite
, RakNet::BookmarkedUsers_Remove
, RakNet::Clans_GetProperties
, RakNet::Clans_AcceptJoinRequest
, RakNet::System_DestroyDatabase
, RakNet::Clans_SetMyMemberProperties
, RakNet::System_SetEmailAddressValidated
, RakNet::Client_GetAccountDetails
, RakNet::Clans_CreateBoard
, RakNet::Clans_SendJoinInvitation
, RakNet::Emails_Send
, RakNet::System_RegisterProfanity
, RakNet::Clans_GetMembers
, RakNet::CDKey_GetStatus
, RakNet::System_DestroyTitle
, RakNet::Clans_ReplyToTopic
, RakNet::Clans_RejectJoinRequest
, RakNet::Clans_KickAndBlacklistUser
, RakNet::Friends_GetInvites
, RakNet::Client_GetPasswordByPasswordRecoveryAnswer
, RakNet::Clans_Create
, RakNet::Clans_RejectJoinInvitation
, RakNet::Friends_AcceptInvite
, RakNet::Clans_SendJoinRequest
, RakNet::Clans_DownloadRequestList
, RakNet::Emails_Get
, RakNet::Friends_Remove
, RakNet::Ranking_GetMatchBinaryData
, RakNet::Ranking_WipeRatings
, RakNet::Client_Logoff
, RakNet::Clans_GetList
, RakNet::System_GetTitleRequiredAge
, RakNet::Clans_RemovePost
, RakNet::Clans_GetBoards
, RakNet::Clans_SetSubleaderStatus
, RakNet::System_GetTitleBinaryData
, RakNet::Clans_DestroyBoard
, RakNet::Ranking_GetTotalScore
, RakNet::Clans_SetMemberRank
, RakNet::System_BanUser
, RakNet::Platform_Startup
, RakNet::System_UnbanUser
  • requiresTitleToLogin : RakNet::Lobby2Server::ConfigurationProperties
  • Reset()
: RakNet::HuffmanEncodingTreeFactory
, RakNet::ReliabilityLayer
, RakNet::BitStream
  • ResetReadPointer() : RakNet::BitStream
  • ResetWritePointer() : RakNet::BitStream
  • ResizeServer() : RakNet::Rackspace
  • ResponseCodes : RakNet::HTTPConnection
  • resultCode : RakNet::RoomsPluginFunc , RakNet::Lobby2Message
  • ReturnResult() : RakNet::CommandParserInterface
  • ReverseList() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • RevertResizedServer() : RakNet::Rackspace
  • roomsContainer : RakNet::RoomsPlugin
  • RPC4GlobalRegistration() : RakNet::RPC4GlobalRegistration
  • runningTotal : RakNet::RakNetStatistics
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • searchOperator : RakNet::IndexedIntegerValue , RakNet::IndexedBinaryValue
  • secondaryKey : RakNet::CloudKey
  • Send()
: RakNet::EmailSender
, RakNet::RakPeer
, RakNet::RakPeerInterface
, RakNet::FileListTransfer
, RakNet::RakPeerInterface
, RakNet::ReliabilityLayer
, RakNet::RakNetTransport2
, RakNet::TelnetTransport
, RakNet::TransportInterface
, RakNet::RakPeer
  • SendFrame() : RakNet::RakVoice
  • SendHelp()
: RakNet::LogCommandParser
, RakNet::RakNetCommandParser
, RakNet::CommandParserInterface
  • SendList()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • SendLoopback()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • SendMsg()
: RakNet::Lobby2Client
, RakNet::Lobby2Server
  • SendMsgAndDealloc() : RakNet::Lobby2Client
  • sendReceiptSerial : RakNet::InternalPacket
  • sendReceiptSerialMutex : RakNet::RakPeer
  • SendToParticipant() : RakNet::RelayPlugin
  • SendTTL()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • Serialize()
: RakNet::RakString
, RakNet::Client_GetIgnoreList
, RakNet::Client_PerTitleBinaryStorage
, RakNet::RakString
, RakNet::Client_SetPresence
, RakNet::Client_GetPresence
, RakNet::RakWString
, RakNet::Friends_SendInvite
, RakNet::Friends_AcceptInvite
, RakNet::RakWString
, RakNet::Friends_RejectInvite
, RakNet::Friends_GetInvites
, RakNet::Replica3
, RakNet::Friends_GetFriends
, RakNet::Friends_Remove
, RakNet::Replica3Composite< parent_type >
, RakNet::BookmarkedUsers_Add
, RakNet::BookmarkedUsers_Remove
, RakNet::Lobby2Message
, RakNet::BookmarkedUsers_Get
, RakNet::Emails_Send
, RakNet::System_CreateTitle
, RakNet::Emails_Get
, RakNet::Emails_Delete
, RakNet::System_DestroyTitle
, RakNet::Emails_SetStatus
, RakNet::Ranking_SubmitMatch
, RakNet::System_GetTitleRequiredAge
, RakNet::Ranking_GetMatches
, RakNet::Ranking_GetMatchBinaryData
, RakNet::System_GetTitleBinaryData
, RakNet::Ranking_GetTotalScore
, RakNet::Ranking_WipeScoresForPlayer
, RakNet::System_RegisterProfanity
, RakNet::Ranking_WipeMatches
, RakNet::Ranking_PruneMatches
, RakNet::System_BanUser
, RakNet::Ranking_UpdateRating
, RakNet::Ranking_WipeRatings
, RakNet::System_UnbanUser
, RakNet::Ranking_GetRating
, RakNet::Clans_Create
, RakNet::CDKey_Add
, RakNet::Clans_SetProperties
, RakNet::Clans_GetProperties
, RakNet::CDKey_GetStatus
, RakNet::Clans_SetMyMemberProperties
, RakNet::Clans_GrantLeader
, RakNet::CDKey_Use
, RakNet::Clans_SetSubleaderStatus
, RakNet::Clans_SetMemberRank
, RakNet::CDKey_FlagStolen
, RakNet::Clans_GetMemberProperties
, RakNet::Clans_ChangeHandle
, RakNet::Client_Login
, RakNet::Clans_Leave
, RakNet::Clans_Get
, RakNet::Client_RegisterAccount
, RakNet::Clans_SendJoinInvitation
, RakNet::Clans_WithdrawJoinInvitation
, RakNet::System_SetEmailAddressValidated
, RakNet::Clans_AcceptJoinInvitation
, RakNet::Clans_RejectJoinInvitation
, RakNet::Client_ValidateHandle
, RakNet::Clans_DownloadInvitationList
, RakNet::Clans_SendJoinRequest
, RakNet::System_DeleteAccount
, RakNet::Clans_WithdrawJoinRequest
, RakNet::Clans_AcceptJoinRequest
, RakNet::System_PruneAccounts
, RakNet::Clans_RejectJoinRequest
, RakNet::Clans_DownloadRequestList
, RakNet::Client_GetEmailAddress
, RakNet::Clans_KickAndBlacklistUser
, RakNet::Clans_UnblacklistUser
, RakNet::Client_GetPasswordRecoveryQuestionByHandle
, RakNet::Clans_GetBlacklist
, RakNet::Clans_GetMembers
, RakNet::Client_GetPasswordByPasswordRecoveryAnswer
, RakNet::Clans_GetList
, RakNet::Clans_CreateBoard
, RakNet::Client_ChangeHandle
, RakNet::Clans_DestroyBoard
, RakNet::Clans_CreateNewTopic
, RakNet::BitStream
, RakNet::Client_UpdateAccount
, RakNet::Clans_ReplyToTopic
, RakNet::Clans_RemovePost
, RakNet::Client_GetAccountDetails
, RakNet::Clans_GetBoards
, RakNet::Clans_GetTopics
, RakNet::BitStream
, RakNet::Client_StartIgnore
, RakNet::Clans_GetPosts
, RakNet::Client_StopIgnore
  • SerializeBits() : RakNet::BitStream
  • SerializeBitsFromIntegerRange() : RakNet::BitStream
  • SerializeCasted() : RakNet::BitStream
  • SerializeChangeHandle() : RakNet::RoomsPlugin
  • SerializeCompressed()
: RakNet::BitStream
, RakNet::RakString
  • SerializeCompressedDelta() : RakNet::BitStream
  • SerializeConstruction()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
, RakNet::TM_TeamMember
, RakNet::TM_Team
  • SerializeConstructionExisting()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • SerializeDelta() : RakNet::BitStream
  • SerializeDestruction()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • SerializeFloat16() : RakNet::BitStream
  • SerializeLogin() : RakNet::RoomsPlugin
  • SerializeLogoff() : RakNet::RoomsPlugin
  • SerializeNormQuat() : RakNet::BitStream
  • SerializeNormVector() : RakNet::BitStream
  • SerializeOnDownloadComplete() : RakNet::Connection_RM3
  • SerializeOnDownloadStarted() : RakNet::Connection_RM3
  • SerializeOrthMatrix() : RakNet::BitStream
  • SerializeVariable() : RakNet::VariableDeltaSerializer
  • SerializeVector() : RakNet::BitStream
  • ServerDBImpl() : RakNet::Lobby2Message
  • ServerPostDBMemoryImpl() : RakNet::Lobby2Message
  • ServerPreDBMemoryImpl()
: RakNet::Lobby2Message
, RakNet::Platform_Startup
, RakNet::Platform_Shutdown
  • Set()
: DataStructures::Table::Cell
, RakNet::RakString
, RakNet::RakWString
  • SetAcceptAddParticipantRequests() : RakNet::RelayPlugin
  • SetActionOnDisallowedMessage() : RakNet::MessageFilter
  • SetAllowDownloadOfOriginalUnmodifiedFiles() : RakNet::AutopatcherServer
  • SetAllowMessageID() : RakNet::MessageFilter
  • SetAllowRPC4() : RakNet::MessageFilter
  • SetAutoAddNewConnectionsToFilter() : RakNet::MessageFilter
  • SetAutoManageConnections()
: RakNet::ReplicaManager3
, RakNet::TM_World
, RakNet::TeamManager
  • SetAutoProcessNewConnections() : RakNet::ConnectionGraph2
  • SetAutoSerializeInterval() : RakNet::ReplicaManager3
  • SetBalanceTeams() : RakNet::TM_World
  • SetBinaryAddress() : RakNet::SystemAddress
  • SetCallbackInterface() : RakNet::Lobby2Plugin
  • SetChar() : RakNet::RakString
  • SetConfigurationProperties() : RakNet::Lobby2Server
  • SetDebugInterface()
: RakNet::NatPunchthroughServer
, RakNet::NatPunchthroughClient
, RakNet::Router2
  • SetDefaultAssignmentAlgorithm() : RakNet::TeamBalancer
  • SetDefaultCallbacks() : RakNet::CloudClient
  • SetDefaultOrderingChannel() : RakNet::ReplicaManager3
  • SetDefaultPacketPriority() : RakNet::ReplicaManager3
  • SetDefaultPacketReliability() : RakNet::ReplicaManager3
  • SetDisallowedMessageCallback() : RakNet::MessageFilter
  • SetEncoderComplexity() : RakNet::RakVoice
  • SetEvent() : RakNet::ReadyEvent
  • SetFileListTransferPlugin() : RakNet::AutopatcherServer
  • SetFilterMaxTime() : RakNet::MessageFilter
  • SetForceEvenTeams() : RakNet::TeamBalancer
  • SetHost() : RakNet::TM_World
  • SetIncomingDatagramEventHandler()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • SetIncomingPassword()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • SetInternalID()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • SetJoinPermissions() : RakNet::TM_Team
  • SetLimitIPConnectionFrequency()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • SetLoadManagementCallback() : RakNet::AutopatcherServer
  • SetLockTeams() : RakNet::TeamBalancer
  • SetLogDirectMessages() : RakNet::PacketLogger
  • SetLoopbackMode() : RakNet::RakVoice
  • SetMaxBytesPerDownload() : RakNet::CloudServer
  • SetMaxConurrentUsers() : RakNet::AutopatcherServer
  • SetMaxForwardEntries() : RakNet::UDPForwarder
  • SetMaximumForwardingRequests() : RakNet::Router2
  • SetMaximumIncomingConnections()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • SetMaxUploadBytesPerClient() : RakNet::CloudServer
  • SetMemberLimit() : RakNet::TM_Team
  • SetMessageFactory() : RakNet::Lobby2Plugin
  • SetMultilistType() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • SetNetworkID() : RakNet::NetworkIDObject
  • SetNetworkIDManager()
: RakNet::NetworkIDObject
, RakNet::ReplicaManager3
, RakNet::RPC3
  • SetNoiseFilter() : RakNet::RakVoice
  • SetNumberOfBitsAllocated() : RakNet::BitStream
  • SetOccasionalPing()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • SetOfflinePingResponse()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • SetOrderingChannel()
: RakNet::Lobby2Plugin
, RakNet::RoomsPlugin
  • SetOwner()
: RakNet::TM_TeamMember
, RakNet::TM_Team
  • SetParent() : RakNet::NetworkIDObject
  • SetPerConnectionOutgoingBandwidthLimit()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • SetPortHostOrder() : RakNet::SystemAddress
  • SetPrefix() : RakNet::PacketLogger
  • SetPresence() : RakNet::Lobby2Server
  • SetProfanityFilter() : RakNet::RoomsPlugin
  • SetPrompt() : RakNet::ConsoleServer
  • SetPtr() : DataStructures::Table::Cell
  • SetRakPeerInterface() : RakNet::RakNetCommandParser
  • SetReadOffset() : RakNet::BitStream
  • SetRecipientAddress() : RakNet::RPC3
  • SetRecipientObject() : RakNet::RPC3
  • SetRemoteLoginPassword() : RakNet::UDPProxyCoordinator
  • SetResultHandler()
: RakNet::UDPProxyServer
, RakNet::UDPProxyClient
  • SetRoomsCallback() : RakNet::RoomsPlugin
  • SetRoomsPlugin() : RakNet::Lobby2Server
  • SetRoomsPluginAddress() : RakNet::Lobby2Server
  • SetSendChannel() : RakNet::ReadyEvent
  • SetSendParams() : RakNet::RPC3
  • SetSendPriority()
: RakNet::RoomsPlugin
, RakNet::Lobby2Plugin
  • SetServerAddress()
: RakNet::Lobby2Client
, RakNet::RoomsPlugin
  • SetServerPublicIP() : RakNet::UDPProxyServer
  • SetSocketFamily()
: RakNet::Router2
, RakNet::UDPProxyServer
  • SetSortOrder() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • SetSplitMessageProgressInterval()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • SetSuffix() : RakNet::PacketLogger
  • SetSystemFilterSet() : RakNet::MessageFilter
  • SetTeamSizeLimit() : RakNet::TeamBalancer
  • SetTimeoutCallback() : RakNet::MessageFilter
  • SetTimeoutTime()
: RakNet::RakPeer
, RakNet::RakPeerInterface
, RakNet::ReliabilityLayer
  • SetTimestamp() : RakNet::RPC3
  • SetToLoopback() : RakNet::SystemAddress
  • SetTopology() : RakNet::TeamManager
  • SetTransportProvider() : RakNet::ConsoleServer
  • SetUnreliableTimeout()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • SetUploadSendParameters() : RakNet::AutopatcherServer
  • SetupReceive() : RakNet::FileListTransfer
  • SetUserUpdateThread()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • SetVAD() : RakNet::RakVoice
  • SetVBR() : RakNet::RakVoice
  • SetWriteOffset() : RakNet::BitStream
  • ShareServerAddress() : RakNet::Rackspace
  • SHDataCategory : RakNet::StatisticsHistory
  • ShiftIncomingTimestamp() : RakNet::RakPeer
  • Shutdown()
: RakNet::RakPeer
, RakNet::UDPForwarder
, RakNet::RakPeerInterface
  • Signal()
: RakNet::RPC3
, RakNet::RPC4
  • SignalExplicit() : RakNet::RPC3
  • Size()
: DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
, DataStructures::List< list_type >
  • slotIndex : RakNet::Client_PerTitleBinaryStorage
  • SMALLEST_TEAM : RakNet::TeamBalancer
  • socketFamily : RakNet::SocketDescriptor
  • Sort() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • SortQueryType : DataStructures::Table
  • SortTable() : DataStructures::Table
  • SpecificTeam() : RakNet::TeamSelection
  • SplitURI() : RakNet::RakString
  • SQLEscape() : RakNet::RakString
  • STACK : RakNet::InternalPacket
  • Start()
: RakNet::TransportInterface
, RakNet::RakNetTransport2
, RakNet::TelnetTransport
  • StartForwarding() : RakNet::UDPForwarder
  • StartIncrementalReadThreads() : RakNet::FileListTransfer
  • startingRowIndex : RakNet::CloudQuery
  • StartThreads() : ThreadPool< InputType, OutputType > , RakNet::AutopatcherServer
  • Startup()
: RakNet::RakPeer
, RakNet::RakPeerInterface
, RakNet::UDPForwarder
, RakNet::NatTypeDetectionServer
  • Status : RakNet::Lobby2Presence
  • statusString : RakNet::Lobby2Presence
  • Stop()
: RakNet::RakNetTransport2
, RakNet::TransportInterface
, RakNet::TelnetTransport
  • StopForwarding() : RakNet::UDPForwarder
  • StopThreads() : ThreadPool< InputType, OutputType >
  • StrCmp()
: RakNet::RakWString
, RakNet::RakString
  • StrICmp()
: RakNet::RakWString
, RakNet::RakString
  • StringTable() : RakNet::StringTable
  • StrNCmp() : RakNet::RakString
  • submittedMatches : RakNet::Ranking_GetMatches
  • Subscribe() : RakNet::LogCommandParser
  • subscribeToResults : RakNet::CloudQuery
  • systemAddress : RakNet::LogCommandParser::SystemAddressAndChannel , RakNet::Packet
  • SystemAddress() : RakNet::SystemAddress
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • TagSorted() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • TerminateAtFirstCharacter() : RakNet::RakString
  • TerminateAtLastCharacter() : RakNet::RakString
  • timesSent : RakNet::InternalPacket
  • titleName : RakNet::Client_PerTitleBinaryStorage
  • titleNameOrID : RakNet::Lobby2Presence
  • ToInteger()
: RakNet::RakString
, RakNet::RakWString
, RakNet::SystemAddress
  • ToLower() : RakNet::RakString
  • ToString_Old() : RakNet::SystemAddress
  • ToUpper() : RakNet::RakString
  • trans : RakNet::LogCommandParser
  • TransmitRequest() : RakNet::HTTPConnection2
  • Truncate() : RakNet::RakString
  • type : RakNet::IndexedBinaryValue
  • TYPING : RakNet::Lobby2Presence
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • udpForwarder : RakNet::UDPProxyServer
  • UNDEFINED : RakNet::Lobby2Presence
  • UnlockInput() : ThreadPool< InputType, OutputType >
  • UnlockOutput() : ThreadPool< InputType, OutputType >
  • UnregisterBlockingFunction() : RakNet::RPC4
  • UnregisterFunction()
: RakNet::RPC4
, RakNet::RPC3
  • UnregisterLocalCallback() : RakNet::RPC4
  • UnregisterSlot() : RakNet::RPC4
  • Unsubscribe()
: RakNet::CloudClient
, RakNet::LogCommandParser
  • Update()
: RakNet::HTTPConnection
, RakNet::UDPProxyServer
, RakNet::RakVoice
, RakNet::MessageFilter
, RakNet::SQLite3ServerPlugin
, RakNet::AutopatcherServer
, RakNet::Lobby2Server
, RakNet::NatPunchthroughClient
, RakNet::RoomsPlugin
, RakNet::NatPunchthroughServer
, RakNet::UDPProxyCoordinator
, RakNet::UDPProxyClient
, RakNet::TwoWayAuthentication
, RakNet::NatTypeDetectionClient
, RakNet::TeamManager
, RakNet::StatisticsHistoryPlugin
, RakNet::NatTypeDetectionServer
, RakNet::PluginInterface2
, RakNet::ReliabilityLayer
, RakNet::CloudServer
, RakNet::ReplicaManager3
, RakNet::Router2
, RakNet::ConsoleServer
, RakNet::FileListTransfer
, RakNet::ThreadsafePacketLogger
, RakNet::FileListTransferCBInterface
  • UpdateApplicationFiles()
: RakNet::AutopatcherPostgreRepository
, RakNet::AutopatcherMySQLRepository
  • UpdateCell()
: DataStructures::Table::Row
, DataStructures::Table
  • updateCycleIsRunning : RakNet::RakPeer
  • UpdateServerNameOrPassword() : RakNet::Rackspace
  • URLDecode() : RakNet::RakString
  • URLEncode() : RakNet::RakString
  • userHandle : RakNet::Client_GetPresence
  • userName : RakNet::RoomsPluginFunc
  • UsesReliabilityLayer()
: RakNet::PacketLogger
, RakNet::PluginInterface2
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • ValidateBinary() : RakNet::Lobby2Message
  • ValidateEmailAddress() : RakNet::Lobby2Message
  • ValidateHandle() : RakNet::Lobby2Message
  • ValidatePassword() : RakNet::Lobby2Message
  • ValidateRequiredText() : RakNet::Lobby2Message
  • value : RakNet::IndexedBinaryValue , RakNet::IndexedIntegerValue
  • valueByteLength : RakNet::IndexedBinaryValue
  • valueOverLastSecond : RakNet::RakNetStatistics
  • VIEWING_PROFILE : RakNet::Lobby2Presence
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • WasReferenced() : RakNet::Replica3
  • WasStarted() : ThreadPool< InputType, OutputType >
  • whenLastSerialized : RakNet::SerializeParameters
  • Write() : RakNet::BitStream
  • Write0() : RakNet::BitStream
  • Write1() : RakNet::BitStream
  • WriteAlignedBytes() : RakNet::BitStream
  • WriteAlignedBytesSafe() : RakNet::BitStream
  • WriteAllocationID()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • WriteBits() : RakNet::BitStream
  • WriteBitsFromIntegerRange() : RakNet::BitStream
  • WriteCasted() : RakNet::BitStream
  • WriteCompressed() : RakNet::BitStream
  • WriteCompressedDelta() : RakNet::BitStream
  • WriteDelta() : RakNet::BitStream
  • WriteFloat16() : RakNet::BitStream
  • WriteLock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • WriteLog()
: RakNet::PacketConsoleLogger
, RakNet::PacketOutputWindowLogger
, RakNet::PacketFileLogger
, RakNet::PacketLogger
, RakNet::LogCommandParser
  • WriteNormQuat() : RakNet::BitStream
  • WriteNormVector() : RakNet::BitStream
  • WriteOrthMatrix() : RakNet::BitStream
  • WritePtr() : RakNet::BitStream
  • WriteUnlock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • WriteVar() : RakNet::VariableListDeltaTracker
  • WriteVarToBitstream() : RakNet::VariableListDeltaTracker
  • WriteVector() : RakNet::BitStream
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- ~ -

  • ~RakPeer() : RakNet::RakPeer
  • ~RakPeerInterface() : RakNet::RakPeerInterface
  • ~RelayPlugin() : RakNet::RelayPlugin
  • ~Replica3() : RakNet::Replica3
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- _ -

  • _sqlite3_exec()
: RakNet::SQLite3PluginResultInterface
, RakNet::SQLite3ClientPlugin
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- a -

  • AckTimeout() : RakNet::ReliabilityLayer
  • AddAdminAddress() : RakNet::Lobby2Server
  • AddApplication()
: RakNet::AutopatcherMySQLRepository
, RakNet::AutopatcherPostgreRepository
  • AddBitsAndReallocate() : RakNet::BitStream
  • AddCallback() : RakNet::FileListTransfer
  • AddCallbackInterface() : RakNet::Lobby2Plugin
  • AddChannel() : RakNet::LogCommandParser
  • AddColumn() : DataStructures::Table
  • AddCommandParser() : RakNet::ConsoleServer
  • AddDBHandle() : RakNet::SQLite3ServerPlugin
  • AddEventCallback() : RakNet::Rackspace
  • AddInput() : ThreadPool< InputType, OutputType >
  • AddInputFromThread() : RakNet::Lobby2Server_PGSQL
  • AddLoginServerAddress() : RakNet::RoomsPlugin
  • AddOperation() : RakNet::Rackspace
  • AddOutput() : ThreadPool< InputType, OutputType >
  • AddOutputFromThread() : RakNet::Lobby2Server_PGSQL
  • AddParticipant()
: RakNet::ConnectionGraph2
, RakNet::TM_World
  • AddParticipantOnServer() : RakNet::RelayPlugin
  • AddParticipantRequestFromClient() : RakNet::RelayPlugin
  • AddPassword() : RakNet::TwoWayAuthentication
  • AddQueryFilter() : RakNet::CloudServer
  • AddRankingAddress() : RakNet::Lobby2Server
  • AddReference()
: RakNet::StringCompressor
, RakNet::StringTable
  • AddRemoteSystemVariableHistory() : RakNet::VariableDeltaSerializer
  • AddResultHandler() : RakNet::SQLite3ClientPlugin
  • AddRoomsCallback() : RakNet::RoomsPlugin
  • AddRow() : DataStructures::Table
  • AddServer() : RakNet::CloudServer
  • AddString() : RakNet::StringTable
  • AddToBanList()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • AddToFrequencyTable() : RakNet::HuffmanEncodingTreeFactory
  • AddToSecurityExceptionList()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • AddToWaitList() : RakNet::ReadyEvent
  • AddWorld()
: RakNet::ReplicaManager3
, RakNet::TeamManager
  • AdvertiseSystem()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • AlignReadToByteBoundary() : RakNet::BitStream
  • AlignWriteToByteBoundary() : RakNet::BitStream
  • AllocateCloudQueryRow() : RakNet::CloudAllocator
  • AllocatePacket()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • AllocateRowData() : RakNet::CloudAllocator
  • AllocConnection() : RakNet::ReplicaManager3
  • AllocReplica() : RakNet::Connection_RM3
  • AllowConnectionResponseIPMigration()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • AnyAvailable() : RakNet::TeamSelection
  • ApplyNetworkSimulator()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • AssertCopyData() : RakNet::BitStream
  • AssertStreamEmpty() : RakNet::BitStream
  • Assign() : RakNet::RakString
  • AssignSystemAddressToRemoteSystemList() : RakNet::RakPeer
  • AttachPlugin()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • Authenticate() : RakNet::Rackspace
  • AutoCreateConnectionList() : RakNet::ReplicaManager3
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- b -

  • BeginDeserialize() : RakNet::VariableDeltaSerializer
  • BeginIdenticalSerialize() : RakNet::VariableDeltaSerializer
  • BeginUniqueSerialize() : RakNet::VariableDeltaSerializer
  • BeginUnreliableAckedSerialize() : RakNet::VariableDeltaSerializer
  • BitStream() : RakNet::BitStream
  • BroadcastDestruction() : RakNet::Replica3
  • BroadcastDestructionList() : RakNet::ReplicaManager3
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- c -

  • C_String()
: RakNet::RakString
, RakNet::RakWString
  • CacheMostRecentPatch() : RakNet::AutopatcherServer
  • Call()
: RakNet::RPC4
, RakNet::RPC3
  • CallBlocking() : RakNet::RPC4
  • CallCallback() : RakNet::Lobby2Message
  • CallExplicit() : RakNet::RPC3
  • CallLoopback() : RakNet::RPC4
  • CancelConnectionAttempt()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • CancelOnDisconnect()
: RakNet::System_DestroyDatabase
, RakNet::Client_ValidateHandle
, RakNet::Ranking_WipeScoresForPlayer
, RakNet::Ranking_WipeMatches
, RakNet::System_DeleteAccount
, RakNet::Ranking_PruneMatches
, RakNet::Ranking_UpdateRating
, RakNet::System_CreateTitle
, RakNet::System_PruneAccounts
, RakNet::Ranking_WipeRatings
, RakNet::Ranking_GetRating
, RakNet::Client_GetEmailAddress
, RakNet::Clans_Create
, RakNet::Clans_SetProperties
, RakNet::System_DestroyTitle
, RakNet::Client_GetPasswordRecoveryQuestionByHandle
, RakNet::Clans_GetProperties
, RakNet::Clans_SetMyMemberProperties
, RakNet::Client_GetPasswordByPasswordRecoveryAnswer
, RakNet::Clans_GrantLeader
, RakNet::Clans_SetSubleaderStatus
, RakNet::System_GetTitleRequiredAge
, RakNet::Client_ChangeHandle
, RakNet::Clans_SetMemberRank
, RakNet::Clans_GetMemberProperties
, RakNet::Client_UpdateAccount
, RakNet::Clans_ChangeHandle
, RakNet::Clans_Leave
, RakNet::System_GetTitleBinaryData
, RakNet::Client_GetAccountDetails
, RakNet::Clans_Get
, RakNet::Clans_SendJoinInvitation
, RakNet::Client_StartIgnore
, RakNet::Clans_WithdrawJoinInvitation
, RakNet::Clans_AcceptJoinInvitation
, RakNet::System_RegisterProfanity
, RakNet::Client_StopIgnore
, RakNet::Clans_RejectJoinInvitation
, RakNet::Clans_DownloadInvitationList
, RakNet::Client_GetIgnoreList
, RakNet::Clans_SendJoinRequest
, RakNet::Clans_WithdrawJoinRequest
, RakNet::System_BanUser
, RakNet::Client_PerTitleBinaryStorage
, RakNet::Clans_AcceptJoinRequest
, RakNet::Clans_RejectJoinRequest
, RakNet::Client_SetPresence
, RakNet::Clans_DownloadRequestList
, RakNet::Clans_KickAndBlacklistUser
, RakNet::System_UnbanUser
, RakNet::Client_GetPresence
, RakNet::Clans_UnblacklistUser
, RakNet::Clans_GetBlacklist
, RakNet::Friends_SendInvite
, RakNet::Clans_GetMembers
, RakNet::Clans_GetList
, RakNet::Clans_GetPosts
, RakNet::Clans_GetTopics
, RakNet::Clans_GetBoards
, RakNet::Clans_RemovePost
, RakNet::Clans_ReplyToTopic
, RakNet::Clans_CreateNewTopic
, RakNet::Lobby2Message
, RakNet::CDKey_Add
, RakNet::Friends_AcceptInvite
, RakNet::Clans_CreateBoard
, RakNet::Clans_DestroyBoard
, RakNet::Friends_RejectInvite
, RakNet::CDKey_GetStatus
, RakNet::Friends_GetInvites
, RakNet::Friends_GetFriends
, RakNet::Platform_Startup
, RakNet::CDKey_Use
, RakNet::Friends_Remove
, RakNet::BookmarkedUsers_Add
, RakNet::CDKey_FlagStolen
, RakNet::BookmarkedUsers_Remove
, RakNet::BookmarkedUsers_Get
, RakNet::Platform_Shutdown
, RakNet::Client_Login
, RakNet::Emails_Send
, RakNet::Emails_Get
, RakNet::Client_Logoff
, RakNet::Emails_Delete
, RakNet::Emails_SetStatus
, RakNet::System_CreateDatabase
, RakNet::Client_RegisterAccount
, RakNet::Ranking_SubmitMatch
, RakNet::Ranking_GetMatches
, RakNet::System_SetEmailAddressValidated
, RakNet::Ranking_GetMatchBinaryData
, RakNet::Ranking_GetTotalScore
  • CancelReadLock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • CancelReceive() : RakNet::FileListTransfer
  • CancelRequestSpecificTeam() : RakNet::TeamBalancer
  • CancelTeamRequest() : RakNet::TM_TeamMember
  • CancelWriteLock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • Challenge() : RakNet::TwoWayAuthentication
  • ChangeHandle() : RakNet::RoomsPlugin
  • CheckReadUnlockOrder() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • CheckSum() : CheckSum
  • Clear()
: DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
, RakNet::TM_World
, RakNet::AutopatcherServer
, RakNet::TwoWayAuthentication
, ThreadPool< InputType, OutputType >
, RakNet::TeamManager
, DataStructures::Hash< key_type, data_type, HASH_SIZE, hashFunction >
, RakNet::RakString
, DataStructures::List< list_type >
, DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
, RakNet::CloudServer
, DataStructures::Table
, RakNet::RakWString
, MemoryCompressor
  • ClearAdminAddresses() : RakNet::Lobby2Server
  • ClearBanList()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • ClearCallbackInterfaces() : RakNet::Lobby2Plugin
  • ClearCallbacks() : RakNet::FileListTransfer
  • ClearEventCallbacks() : RakNet::Rackspace
  • ClearInput() : ThreadPool< InputType, OutputType >
  • ClearLoginServerAdddresses() : RakNet::RoomsPlugin
  • ClearOutput() : ThreadPool< InputType, OutputType >
  • ClearPointer() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • ClearPointers() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • ClearRankingAddresses() : RakNet::Lobby2Server
  • ClearRoomMembers() : RakNet::RoomsPlugin
  • ClientImpl()
: RakNet::Lobby2Message
, RakNet::Client_GetIgnoreList
, RakNet::Client_StartIgnore
, RakNet::Client_StopIgnore
  • CloseAllChannels() : RakNet::RakVoice
  • CloseConnection()
: RakNet::RakNetTransport2
, RakNet::RakPeer
, RakNet::TelnetTransport
, RakNet::TransportInterface
, RakNet::RakPeerInterface
  • CloseVoiceChannel() : RakNet::RakVoice
  • ColumnIndex() : DataStructures::Table
  • ColumnName() : DataStructures::Table
  • Compress() : MemoryCompressor , DataStructures::List< list_type >
  • ConfirmResizedServer() : RakNet::Rackspace
  • Connect()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • ConnectionExists() : RakNet::ConnectionGraph2
  • ConnectToDB()
: RakNet::Lobby2Server_PGSQL
, RakNet::Lobby2Server
  • ConnectWithSocket()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • ContainsNonprintableExceptSpaces() : RakNet::RakString
  • CopyData() : RakNet::BitStream
  • CopyPort() : RakNet::SystemAddress
  • CreateAutopatcherTables()
: RakNet::AutopatcherMySQLRepository
, RakNet::AutopatcherPostgreRepository
  • CreateImage() : RakNet::Rackspace
  • CreateServer() : RakNet::Rackspace
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- d -

  • DeallocateCloudQueryRow() : RakNet::CloudAllocator
  • DeallocatePacket()
: RakNet::RakNetTransport2
, RakNet::RakPeerInterface
, RakNet::TelnetTransport
, RakNet::RakPeer
, RakNet::TransportInterface
  • DeallocateRowData() : RakNet::CloudAllocator
  • DeallocateWithDefaultAllocator() : RakNet::CloudClient
  • DeallocConnection() : RakNet::ReplicaManager3
  • DeallocReplica()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • DebugMsg() : RakNet::Lobby2Message
  • DebugPrintf() : RakNet::Lobby2Message
  • DecodeString()
: RakNet::StringTable
, RakNet::StringCompressor
  • DecodeTeamAssigned() : RakNet::TeamManager
  • DecodeTeamCancelled() : RakNet::TeamManager
  • DecomposeTeamFull() : RakNet::TeamManager
  • DecomposeTeamLocked() : RakNet::TeamManager
  • Deinit() : RakNet::RakVoice
  • DeleteEvent() : RakNet::ReadyEvent
  • DeleteFilterSet() : RakNet::MessageFilter
  • DeleteImage() : RakNet::Rackspace
  • DeleteMember() : RakNet::TeamBalancer
  • DeleteServer() : RakNet::Rackspace
  • DeleteServerAddress() : RakNet::Rackspace
  • Dereference() : RakNet::ReplicaManager3
  • DereferenceList() : RakNet::ReplicaManager3
  • DereferenceTeam() : RakNet::TM_World
  • DereferenceTeamMember() : RakNet::TM_World
  • Deserialize()
: RakNet::RakString
, RakNet::RakWString
, RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • DeserializeCompressed() : RakNet::RakString
  • DeserializeConstruction()
: RakNet::TM_TeamMember
, RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
, RakNet::TM_Team
  • DeserializeConstructionExisting()
: RakNet::Replica3Composite< parent_type >
, RakNet::Replica3
  • DeserializeDestruction()
: RakNet::Replica3Composite< parent_type >
, RakNet::Replica3
  • DeserializeOnDownloadComplete() : RakNet::Connection_RM3
  • DeserializeOnDownloadStarted() : RakNet::Connection_RM3
  • DeserializeVariable() : RakNet::VariableDeltaSerializer
  • DestroyAutopatcherTables()
: RakNet::AutopatcherPostgreRepository
, RakNet::AutopatcherMySQLRepository
  • DetachPlugin()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • DetectNATType() : RakNet::NatTypeDetectionClient
  • DisableSecurity()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • DoEndianSwap() : RakNet::BitStream
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- e -

  • EncodeArray() : RakNet::HuffmanEncodingTree
  • EncodeString()
: RakNet::StringCompressor
, RakNet::StringTable
  • EndDeserialize() : RakNet::VariableDeltaSerializer
  • EndSerialize() : RakNet::VariableDeltaSerializer
  • EqualsExcludingPort() : RakNet::SystemAddress
  • Erase() : RakNet::RakString
  • EstablishRouting() : RakNet::Router2
  • EventTypeToString() : RakNet::Rackspace
  • ExecuteCommand() : RakNet::Lobby2Server
  • ExecuteFunc() : RakNet::RoomsPlugin
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- f -

  • Find() : RakNet::RakString
  • FindIntersection() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • FindRouterPortStride() : RakNet::NatPunchthroughClient
  • FlagDirtyFromBitArray() : RakNet::VariableListDeltaTracker
  • ForceCompletion() : RakNet::ReadyEvent
  • ForceExternalSystemAddress() : RakNet::CloudServer
  • ForEach() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • FormatForDELETE() : RakNet::RakString
  • FormatForGET() : RakNet::RakString
  • FormatForPOST() : RakNet::RakString
  • FPrintf()
: RakNet::RakString
, RakNet::RakWString
  • FreeMemory()
: RakNet::HuffmanEncodingTree
, RakNet::RakString
  • FromString() : RakNet::SystemAddress
  • FromStringExplicitPort() : RakNet::SystemAddress
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- g -

  • GenerateFromFrequencyTable() : RakNet::HuffmanEncodingTree
  • GenerateTree() : RakNet::HuffmanEncodingTreeFactory
  • GenerateTreeFromStrings() : RakNet::StringCompressor
  • Get()
: RakNet::CloudClient
, DataStructures::Table::Cell
, RakNet::HTTPConnection
, DataStructures::List< list_type >
, DataStructures::Table::Cell
  • Get64BitUniqueRandomNumber() : RakNet::RakPeerInterface
  • GET_OBJECT_FROM_ID() : RakNet::NetworkIDManager
  • GetAllConnectionDownloadsCompleted() : RakNet::ReplicaManager3
  • GetAutoCreateConnections() : RakNet::ReplicaManager3
  • GetAutoDestroyConnections() : RakNet::ReplicaManager3
  • GetAutoProcessNewConnections() : RakNet::ConnectionGraph2
  • GetAvailableRowId() : DataStructures::Table
  • GetAveragePing()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetBalanceTeams() : RakNet::TM_World
  • GetBalancingApplies() : RakNet::TM_Team
  • GetBestClockDifferential() : RakNet::RakPeer
  • GetBufferedBytesToReturn() : RakNet::RakVoice
  • GetBufferedBytesToSend() : RakNet::RakVoice
  • GetBufferSizeBytes() : RakNet::RakVoice
  • GetCallbacks() : RakNet::FileListTransfer
  • GetCellValueByIndex() : DataStructures::Table
  • GetChangelistSinceDate()
: RakNet::AutopatcherRepositoryInterface
, RakNet::AutopatcherPostgreRepository
, RakNet::AutopatcherMySQLRepository
  • GetChannelIndexFromName() : RakNet::LogCommandParser
  • GetCharacterCount() : RakNet::RakString
  • GetClientPublicKeyFromSystemAddress()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetClockDifferential()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetColumnCount() : DataStructures::Table
  • GetColumns() : DataStructures::Table
  • GetColumnType() : DataStructures::Table
  • GetCommandParser()
: RakNet::RakNetTransport2
, RakNet::TelnetTransport
, RakNet::TransportInterface
  • GetConfigurationProperties() : RakNet::Lobby2Server
  • GetConnectionAtIndex() : RakNet::ReplicaManager3
  • GetConnectionByGUID() : RakNet::ReplicaManager3
  • GetConnectionBySystemAddress() : RakNet::ReplicaManager3
  • GetConnectionCount() : RakNet::ReplicaManager3
  • GetConnectionList()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetConnectionListForRemoteSystem() : RakNet::ConnectionGraph2
  • GetConnectionState()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetConnectionsThatHaveReplicaConstructed() : RakNet::ReplicaManager3
  • GetConstructedReplicas() : RakNet::Connection_RM3
  • GetCreatingSystemGUID() : RakNet::Replica3
  • GetCurrentExecution() : RakNet::RPC3
  • GetCurrentTeam() : RakNet::TM_TeamMember
  • GetCurrentTeamByIndex() : RakNet::TM_TeamMember
  • GetCurrentTeamCount() : RakNet::TM_TeamMember
  • GetCurrentTeams() : RakNet::TM_TeamMember
  • GetData() : RakNet::BitStream
  • GetDebugInterface() : RakNet::Router2
  • GetDownloadWasCompleted() : RakNet::Connection_RM3
  • GetEncoderComplexity() : RakNet::RakVoice
  • GetEventAtIndex() : RakNet::ReadyEvent
  • GetEventListSize() : RakNet::ReadyEvent
  • GetExternalID()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetFilePart()
: RakNet::AutopatcherPostgreRepository
, RakNet::AutopatcherMySQLRepository
  • GetFilterSetCount() : RakNet::MessageFilter
  • GetFilterSetIDByIndex() : RakNet::MessageFilter
  • GetFlavorDetails() : RakNet::Rackspace
  • GetFrequencyTable() : RakNet::HuffmanEncodingTreeFactory
  • GetFromWaitListAtIndex() : RakNet::ReadyEvent
  • GetGUIDFromIndex()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetGuidFromSystemAddress()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetHost() : RakNet::TM_World
  • GetID() : RakNet::Lobby2Message
  • GetImageDetails() : RakNet::Rackspace
  • GetIncomingPassword()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetIncrementalReadChunkSize()
: RakNet::AutopatcherRepositoryInterface
, RakNet::AutopatcherPostgreRepository
, RakNet::AutopatcherMySQLRepository
  • GetIndexFromSystemAddress()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetIndexOf() : DataStructures::List< list_type > , DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • GetInputAtIndex() : ThreadPool< InputType, OutputType >
  • GetInsertionIndex() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • GetInternalID()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetIPVersion() : RakNet::SystemAddress
  • GetJoinPermissions() : RakNet::TM_Team
  • GetLastError()
: RakNet::AutopatcherRepositoryInterface
, RakNet::AutopatcherPostgreRepository
, RakNet::AutopatcherMySQLRepository
  • GetLastPing()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetLastSenderAddress() : RakNet::RPC3
  • GetLastSenderTimestamp() : RakNet::RPC3
  • GetLastTeams() : RakNet::TM_TeamMember
  • GetLength()
: RakNet::RakString
, RakNet::RakWString
  • GetListHead() : DataStructures::Table
  • GetLocalIP()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetLowestAveragePingSystem() : RakNet::ConnectionGraph2
  • GetLowestPing()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetMaxConurrentUsers() : RakNet::AutopatcherServer
  • GetMaxForwardEntries() : RakNet::UDPForwarder
  • GetMaximumIncomingConnections()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetMaximumNumberOfPeers()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetMemberLimit() : RakNet::TM_Team
  • GetMemberLimitSetting() : RakNet::TM_Team
  • GetMessageFactory() : RakNet::Lobby2Plugin
  • GetMostRecentChangelistWithPatches()
: RakNet::AutopatcherRepositoryInterface
, RakNet::AutopatcherPostgreRepository
, RakNet::AutopatcherMySQLRepository
  • GetMTUSize()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetMultilistType() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • GetMyBoundAddress()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetMyGUID()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetMyTeam() : RakNet::TeamBalancer
  • GetName()
: RakNet::CommandParserInterface
, RakNet::RakNetCommandParser
, RakNet::Lobby2Message
, RakNet::LogCommandParser
  • GetNetworkID()
: RakNet::NetworkIDObject
, RakNet::TM_Team
, RakNet::TM_TeamMember
  • GetNetworkIDManager()
: RakNet::NetworkIDObject
, RakNet::ReplicaManager3
  • GetNextSendReceipt()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • GetNoTeamId() : RakNet::TM_TeamMember
  • GetNumberOfAddresses()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetNumberOfBitsUsed() : RakNet::BitStream
  • GetNumberOfBytesUsed() : RakNet::BitStream
  • GetNumberOfRemoteInitiatedConnections() : RakNet::RakPeer
  • GetNumberOfUnreadBits() : RakNet::BitStream
  • GetOfflinePingResponse()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetOutput() : ThreadPool< InputType, OutputType >
  • GetOutputAtIndex() : ThreadPool< InputType, OutputType >
  • GetOwner()
: RakNet::TM_TeamMember
, RakNet::TM_Team
  • GetParent() : RakNet::NetworkIDObject
  • GetParticipantList()
: RakNet::TM_World
, RakNet::ConnectionGraph2
  • GetPatches()
: RakNet::AutopatcherRepositoryInterface
, RakNet::AutopatcherPostgreRepository
, RakNet::AutopatcherMySQLRepository
  • GetPendingFilesToAddress() : RakNet::FileListTransfer
  • GetPingBetweenSystems() : RakNet::ConnectionGraph2
  • GetPort() : RakNet::SystemAddress
  • GetPresence() : RakNet::Lobby2Server
  • GetPtr() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • GetPunchthroughConfiguration() : RakNet::NatPunchthroughClient
  • GetRakNetGUID() : RakNet::Connection_RM3
  • GetRakPeer() : RakNet::RPC3
  • GetRakPeerInterface() : RakNet::RakVoice
  • GetReadOffset() : RakNet::BitStream
  • GetReadyStatus() : RakNet::ReadyEvent
  • GetReceiveBufferSize()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • GetReferencedReplicaList() : RakNet::ReplicaManager3
  • GetRemoteServers() : RakNet::CloudServer
  • GetRemoteSystemFromSystemAddress() : RakNet::RakPeer
  • GetRemoteWaitListSize() : RakNet::ReadyEvent
  • GetReplicaAtIndex() : RakNet::ReplicaManager3
  • GetReplicaCount() : RakNet::ReplicaManager3
  • GetReplicasCreatedByGuid() : RakNet::ReplicaManager3
  • GetReplicasCreatedByMe() : RakNet::ReplicaManager3
  • GetRequestedSpecificTeams() : RakNet::TM_TeamMember
  • GetRequestedTeam() : RakNet::TM_TeamMember
  • GetRequestedTeamCount() : RakNet::TM_TeamMember
  • GetRequestedTeamIndex() : RakNet::TM_TeamMember
  • GetResponse() : RakNet::HTTPConnection2
  • GetRowByID() : DataStructures::Table
  • GetRowByIndex() : DataStructures::Table
  • GetRowCount() : DataStructures::Table
  • GetRows() : DataStructures::Table
  • GetSampleRate() : RakNet::RakVoice
  • GetServerAddress() : RakNet::HTTPConnection
  • GetServerDetails() : RakNet::Rackspace
  • GetSize() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • GetSocket()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • GetSockets()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetSortOrder() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • GetSplitMessageProgressInterval()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • GetStatistics()
: RakNet::RakPeer
, RakNet::ReliabilityLayer
, RakNet::RakPeerInterface
  • GetStatisticsList()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetSystemAddress() : RakNet::Connection_RM3
  • GetSystemAddressFromGuid()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • GetSystemAddressFromIndex()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • GetSystemCount() : RakNet::MessageFilter
  • GetSystemFilterSet() : RakNet::MessageFilter
  • GetSystemList()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • GetTeamByIndex() : RakNet::TM_World
  • GetTeamByNetworkID() : RakNet::TM_World
  • GetTeamCount() : RakNet::TM_World
  • GetTeamIndex() : RakNet::TM_World
  • GetTeamManager() : RakNet::TM_World
  • GetTeamMemberByIndex()
: RakNet::TM_World
, RakNet::TM_Team
  • GetTeamMemberByNetworkID() : RakNet::TM_World
  • GetTeamMemberCount() : RakNet::TM_World
  • GetTeamMemberIDByIndex() : RakNet::TM_World
  • GetTeamMemberIndex() : RakNet::TM_World
  • GetTeamMembers() : RakNet::TM_Team
  • GetTeamMembersCount() : RakNet::TM_Team
  • GetTimeoutTime()
: RakNet::RakPeer
, RakNet::RakPeerInterface
, RakNet::ReliabilityLayer
  • GetTM_World()
: RakNet::TM_Team
, RakNet::TM_TeamMember
  • GetUPNPPortMappings() : RakNet::NatPunchthroughClient
  • GetUsedForwardEntries() : RakNet::UDPForwarder
  • GetWorldAtIndex() : RakNet::TeamManager
  • GetWorldCount()
: RakNet::ReplicaManager3
, RakNet::TeamManager
  • GetWorldId() : RakNet::TM_World
  • GetWorldIdAtIndex() : RakNet::ReplicaManager3
  • GetWorldIndex()
: RakNet::TM_TeamMember
, RakNet::TM_Team
  • GetWorldWithId() : RakNet::TeamManager
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- h -

  • HandleSocketReceiveFromConnectedPlayer() : RakNet::ReliabilityLayer
  • HasAdminAddress() : RakNet::Lobby2Server
  • HasBadResponse() : RakNet::HTTPConnection
  • HasData() : DataStructures::OrderedList< key_type, data_type, default_comparison_function >
  • HasEvent() : RakNet::ReadyEvent
  • Hash() : DataStructures::Hash< key_type, data_type, HASH_SIZE, hashFunction >
  • HasInput() : ThreadPool< InputType, OutputType >
  • HasInputFast() : ThreadPool< InputType, OutputType >
  • HasLostConnection()
: RakNet::RakNetTransport2
, RakNet::TelnetTransport
, RakNet::TransportInterface
  • HasNewIncomingConnection()
: RakNet::RakNetTransport2
, RakNet::TelnetTransport
, RakNet::TransportInterface
  • HasOutput() : ThreadPool< InputType, OutputType >
  • HasOutputFast() : ThreadPool< InputType, OutputType >
  • HasRankingAddress() : RakNet::Lobby2Server
  • HasRead() : RakNet::HTTPConnection
  • HasReplicaConstructed() : RakNet::Connection_RM3
  • HasRequestedTeam() : RakNet::TM_TeamMember
  • HasResponse() : RakNet::HTTPConnection2
  • HTTPConnection() : RakNet::HTTPConnection
  • HuffmanEncodingTreeFactory() : RakNet::HuffmanEncodingTreeFactory
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- i -

  • IgnoreBits() : RakNet::BitStream
  • IgnoreBytes() : RakNet::BitStream
  • IncrementNextSendReceipt()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • Init()
: RakNet::HTTPConnection
, RakNet::RakVoice
  • InitializeSecurity()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • InputSize() : ThreadPool< InputType, OutputType >
  • Insert() : DataStructures::List< list_type >
  • InsertAtIndex() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • Instance()
: RakNet::StringCompressor
, RakNet::StringTable
  • InterruptSignal()
: RakNet::RPC3
, RakNet::RPC4
  • InvokeSignal() : RakNet::RPC3
  • IPAddressMatch() : RakNet::RakString
  • IsActive()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • IsBanned()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • IsBusy()
: RakNet::HTTPConnection
, RakNet::HTTPConnection2
  • IsDeadConnection() : RakNet::ReliabilityLayer
  • IsEmailAddress() : RakNet::RakString
  • IsEmpty() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > , RakNet::RakString , RakNet::RakWString
  • IsEventCompleted() : RakNet::ReadyEvent
  • IsEventCompletionProcessing() : RakNet::ReadyEvent
  • IsEventSet() : RakNet::ReadyEvent
  • IsFunctionRegistered() : RakNet::RPC3
  • IsHandlerActive() : RakNet::FileListTransfer
  • IsInitialized() : RakNet::RakVoice
  • IsInSecurityExceptionList()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • IsInWaitList() : RakNet::ReadyEvent
  • IsLocalIP()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • IsLoopback() : RakNet::SystemAddress
  • IsLoopbackMode() : RakNet::RakVoice
  • IsNetworkSimulatorActive()
: RakNet::RakPeerInterface
, RakNet::RakPeer
, RakNet::ReliabilityLayer
  • IsNoiseFilterActive() : RakNet::RakVoice
  • IsOnTeam() : RakNet::TM_TeamMember
  • IsOutgoingDataWaiting() : RakNet::ReliabilityLayer
  • IsSendingVoiceDataTo() : RakNet::RakVoice
  • IsSorted() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • IsVADActive() : RakNet::RakVoice
  • IsVBRActive() : RakNet::RakVoice
  • IsWorking() : ThreadPool< InputType, OutputType >
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- k -

  • KillConnection() : RakNet::ReliabilityLayer
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- l -

  • LeaveAllTeams() : RakNet::TM_TeamMember
  • LeaveTeam()
: RakNet::TM_TeamMember
, RakNet::TM_Team
  • List() : DataStructures::List< list_type >
  • ListFlavors() : RakNet::Rackspace
  • ListImages() : RakNet::Rackspace
  • ListServerAddresses() : RakNet::Rackspace
  • ListServers() : RakNet::Rackspace
  • ListServersWithDetails() : RakNet::Rackspace
  • ListSharedIPGroups() : RakNet::Rackspace
  • ListSharedIPGroupsWithDetails() : RakNet::Rackspace
  • LockInput() : ThreadPool< InputType, OutputType >
  • LockOutput() : ThreadPool< InputType, OutputType >
  • LogHeader() : RakNet::PacketLogger
  • LoginRoomsParticipant() : RakNet::RoomsPlugin
  • LoginToCoordinator() : RakNet::UDPProxyServer
  • LogoffRoomsParticipant() : RakNet::RoomsPlugin
  • LogStringNotFound() : RakNet::StringTable
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- m -

  • MakeFilePath() : RakNet::RakString
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- n -

  • NonVariadic() : RakNet::RakString
  • NoTeam() : RakNet::TeamSelection
  • NotifyAndFlagForShutdown() : RakNet::RakPeer
  • NumberOfConnections()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • NumberOfLeadingZeroes() : RakNet::BitStream
  • NumThreadsWorking() : ThreadPool< InputType, OutputType >
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- o -

  • OnAck()
: RakNet::PacketLogger
, RakNet::PluginInterface2
  • OnAddFilesFromDirectoryStarted()
: RakNet::FLP_Printf
, RakNet::FileListProgress
  • OnAllServersBusy() : RakNet::UDPProxyClientResultHandler
  • OnAlreadyLoggedIn() : RakNet::UDPProxyServerResultHandler
  • OnAttach()
: RakNet::PluginInterface2
, RakNet::RPC4
, RakNet::TeamBalancer
, RakNet::UDPProxyServer
, RakNet::AutopatcherServer
, RakNet::RPC3
, RakNet::NatPunchthroughClient
, RakNet::SQLite3ServerPlugin
  • OnClosedConnection()
: RakNet::ConnectionGraph2
, RakNet::TeamBalancer
, RakNet::TeamManager
, RakNet::FileListTransfer
, RakNet::TwoWayAuthentication
, RakNet::UDPProxyCoordinator
, RakNet::HTTPConnection2
, RakNet::UDPProxyServer
, RakNet::RakVoice
, RakNet::MessageFilter
, RakNet::AutopatcherServer
, RakNet::Lobby2Client
, RakNet::NatPunchthroughClient
, RakNet::Lobby2Server
, RakNet::RoomsPlugin
, RakNet::NatPunchthroughServer
, RakNet::RPC3
, RakNet::NatTypeDetectionClient
, RakNet::NatTypeDetectionServer
, RakNet::PluginInterface2
, RakNet::Rackspace
, RakNet::RakNetTransport2
, RakNet::ReadyEvent
, RakNet::RelayPlugin
, RakNet::ReplicaManager3
, RakNet::CloudServer
, RakNet::Router2
, RakNet::StatisticsHistoryPlugin
  • OnCommand()
: RakNet::CommandParserInterface
, RakNet::LogCommandParser
, RakNet::RakNetCommandParser
  • OnConnectionLost()
: RakNet::CommandParserInterface
, RakNet::LogCommandParser
  • OnDereference() : RakNet::FileListTransferCBInterface
  • OnDetach()
: RakNet::NatPunchthroughClient
, RakNet::NatTypeDetectionClient
, RakNet::PluginInterface2
, RakNet::ReplicaManager3
, RakNet::UDPProxyServer
, RakNet::AutopatcherServer
, RakNet::RoomsPlugin
, RakNet::SQLite3ServerPlugin
  • OnDirectory()
: RakNet::FileListProgress
, RakNet::FLP_Printf
  • OnDirectSocketReceive()
: RakNet::PacketLogger
, RakNet::PluginInterface2
  • OnDirectSocketSend()
: RakNet::PacketLogger
, RakNet::PluginInterface2
  • OnDownloadComplete() : RakNet::FileListTransferCBInterface
  • OnFailedConnectionAttempt()
: RakNet::HTTPConnection2
, RakNet::PluginInterface2
, RakNet::Router2
  • OnFile()
: RakNet::FileListProgress
, RakNet::FileListTransferCBInterface
  • OnFileProgress() : RakNet::FileListTransferCBInterface
  • OnFilePush() : RakNet::FileListProgress
  • OnFilePushesComplete()
: RakNet::FileListProgress
, RakNet::FLP_Printf
, RakNet::AutopatcherServer
  • OnForwardingInProgress() : RakNet::UDPProxyClientResultHandler
  • OnForwardingNotification() : RakNet::UDPProxyClientResultHandler
  • OnForwardingSuccess() : RakNet::UDPProxyClientResultHandler
  • OnGet() : RakNet::CloudClientCallback
  • OnGetReponse() : RakNet::CloudClient
  • OnGetRequest() : RakNet::CloudServerQueryFilter
  • OnInternalPacket()
: RakNet::PacketLogger
, RakNet::PluginInterface2
  • OnLoginSuccess() : RakNet::UDPProxyServerResultHandler
  • OnMessageReceipt() : RakNet::VariableDeltaSerializer
  • OnNewConnection()
: RakNet::ConnectionGraph2
, RakNet::HTTPConnection2
, RakNet::MessageFilter
, RakNet::NatPunchthroughClient
, RakNet::NatPunchthroughServer
, RakNet::PluginInterface2
, RakNet::RakNetTransport2
, RakNet::ReplicaManager3
, RakNet::StatisticsHistoryPlugin
, RakNet::TeamManager
  • OnNewIncomingConnection()
: RakNet::CommandParserInterface
, RakNet::LogCommandParser
  • OnNoPasswordSet() : RakNet::UDPProxyServerResultHandler
  • OnNoServersOnline() : RakNet::UDPProxyClientResultHandler
  • OnPoppedConnection()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • OnPostRequest() : RakNet::CloudServerQueryFilter
  • OnPreSerializeTick() : RakNet::VariableDeltaSerializer
  • OnPushBackPacket()
: RakNet::PacketLogger
, RakNet::PluginInterface2
  • OnRakPeerShutdown()
: RakNet::NatPunchthroughClient
, RakNet::ReplicaManager3
, RakNet::CloudServer
, RakNet::FileListTransfer
, RakNet::NatTypeDetectionClient
, RakNet::PluginInterface2
, RakNet::ReadyEvent
, RakNet::Router2
, RakNet::TwoWayAuthentication
, RakNet::UDPProxyClient
, RakNet::UDPProxyServer
  • OnRakPeerStartup()
: RakNet::PluginInterface2
, RakNet::UDPProxyServer
  • OnReceive()
: RakNet::PluginInterface2
, RakNet::Rackspace
, RakNet::RakNetTransport2
, RakNet::NatPunchthroughServer
, RakNet::TeamManager
, RakNet::HTTPConnection2
, RakNet::ConnectionGraph2
, RakNet::RelayPlugin
, RakNet::CloudServer
, RakNet::TeamBalancer
, RakNet::UDPProxyCoordinator
, RakNet::Lobby2Client
, RakNet::Lobby2Server
, RakNet::RoomsPlugin
, RakNet::AutopatcherServer
, RakNet::SQLite3ServerPlugin
, RakNet::ReplicaManager3
, RakNet::RakVoice
, RakNet::UDPProxyClient
, RakNet::UDPProxyServer
, RakNet::Router2
, RakNet::SQLite3ClientPlugin
, RakNet::RPC4
, RakNet::FileListTransfer
, RakNet::RPC3
, RakNet::ReadyEvent
, RakNet::TwoWayAuthentication
, RakNet::NatTypeDetectionServer
, RakNet::CloudClient
, RakNet::MessageFilter
, RakNet::NatTypeDetectionClient
, RakNet::NatPunchthroughClient
  • OnRecipientNotConnected() : RakNet::UDPProxyClientResultHandler
  • OnReleaseRequest() : RakNet::CloudServerQueryFilter
  • OnReliabilityLayerNotification()
: RakNet::PluginInterface2
, RakNet::PacketLogger
  • OnSendAborted()
: RakNet::AutopatcherServer
, RakNet::FileListProgress
, RakNet::FLP_Printf
  • OnSerializeTransmission() : RakNet::Replica3
  • OnSubscriptionNotification()
: RakNet::CloudClientCallback
, RakNet::CloudClient
  • OnTransportChange()
: RakNet::CommandParserInterface
, RakNet::LogCommandParser
  • OnUnknownDBIdentifier() : RakNet::SQLite3PluginResultInterface
  • OnUnsubscribeRequest() : RakNet::CloudServerQueryFilter
  • OnUserReplicaPreSerializeTick()
: RakNet::Replica3Composite< parent_type >
, RakNet::Replica3
  • OnWrongPassword() : RakNet::UDPProxyServerResultHandler
  • OpenNAT() : RakNet::NatPunchthroughClient
  • operator const char *() : RakNet::RakString
  • operator wchar_t *() : RakNet::RakWString
  • operator!=() : RakNet::RakWString , RakNet::RakString
  • operator+=()
: RakNet::RakWString
, RakNet::RakString
  • operator=()
: DataStructures::List< list_type >
, RakNet::RakString
, RakNet::RakWString
  • operator==() : RakNet::RakWString , RakNet::RakString
  • operator[]() : DataStructures::List< list_type > , RakNet::RakString
  • OutputSize() : ThreadPool< InputType, OutputType >
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- p -

  • PadWithZeroToByteLength() : RakNet::BitStream
  • ParseConnectionRequestPacket() : RakNet::RakPeer
  • Ping()
: RakNet::RakPeer
, RakNet::RakPeerInterface
, RakNet::RakPeer
, RakNet::RakPeerInterface
  • Pop() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > , DataStructures::List< list_type >
  • PopConnection() : RakNet::ReplicaManager3
  • PopOpposite() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • Post()
: RakNet::CloudClient
, RakNet::HTTPConnection
  • PostDeserializeConstruction()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • PostDeserializeConstructionExisting()
: RakNet::Replica3Composite< parent_type >
, RakNet::Replica3
  • PostSerializeConstruction()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • PostSerializeConstructionExisting()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • Preallocate() : DataStructures::List< list_type >
  • PreDestruction()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • PrevalidateInput()
: RakNet::Clans_UnblacklistUser
, RakNet::Clans_GetBlacklist
, RakNet::Clans_RejectJoinRequest
, RakNet::Clans_AcceptJoinRequest
, RakNet::Clans_WithdrawJoinRequest
, RakNet::Clans_ReplyToTopic
, RakNet::Clans_RejectJoinInvitation
, RakNet::Clans_AcceptJoinInvitation
, RakNet::Clans_WithdrawJoinInvitation
, RakNet::System_GetTitleBinaryData
, RakNet::Clans_Leave
, RakNet::Clans_ChangeHandle
, RakNet::Clans_GetMemberProperties
, RakNet::Clans_SetMemberRank
, RakNet::Clans_SetSubleaderStatus
, RakNet::Clans_GrantLeader
, RakNet::Ranking_GetTotalScore
, RakNet::Ranking_WipeScoresForPlayer
, RakNet::Clans_SetProperties
, RakNet::Clans_Create
, RakNet::Ranking_GetRating
, RakNet::System_RegisterProfanity
, RakNet::Ranking_WipeMatches
, RakNet::Ranking_UpdateRating
, RakNet::System_BanUser
, RakNet::Ranking_WipeRatings
, RakNet::Ranking_GetMatches
, RakNet::Ranking_SubmitMatch
, RakNet::Emails_SetStatus
, RakNet::System_UnbanUser
, RakNet::BookmarkedUsers_Remove
, RakNet::BookmarkedUsers_Add
, RakNet::CDKey_Add
, RakNet::Clans_GetProperties
, RakNet::Friends_AcceptInvite
, RakNet::Friends_SendInvite
, RakNet::Client_PerTitleBinaryStorage
, RakNet::Clans_SetMyMemberProperties
, RakNet::Client_StartIgnore
, RakNet::Client_UpdateAccount
, RakNet::Client_ChangeHandle
, RakNet::CDKey_GetStatus
, RakNet::Client_GetPasswordRecoveryQuestionByHandle
, RakNet::Client_GetEmailAddress
, RakNet::System_PruneAccounts
, RakNet::Clans_KickAndBlacklistUser
, RakNet::Client_ValidateHandle
, RakNet::Clans_SendJoinRequest
, RakNet::Client_RegisterAccount
, RakNet::Clans_SendJoinInvitation
, RakNet::Clans_GetPosts
, RakNet::CDKey_Use
, RakNet::CDKey_FlagStolen
, RakNet::Clans_GetMembers
, RakNet::Clans_CreateNewTopic
, RakNet::Client_Login
, RakNet::System_SetEmailAddressValidated
, RakNet::Clans_CreateBoard
, RakNet::System_GetTitleRequiredAge
, RakNet::Emails_Send
, RakNet::System_CreateTitle
, RakNet::Friends_Remove
, RakNet::System_CreateDatabase
, RakNet::Client_StopIgnore
, RakNet::Platform_Startup
, RakNet::Clans_GetTopics
, RakNet::System_DeleteAccount
, RakNet::Clans_DestroyBoard
, RakNet::Lobby2Message
, RakNet::Client_GetPasswordByPasswordRecoveryAnswer
, RakNet::Clans_GetBoards
, RakNet::Platform_Shutdown
, RakNet::System_DestroyDatabase
, RakNet::Friends_RejectInvite
, RakNet::System_DestroyTitle
  • PrintBits() : RakNet::BitStream
  • PrintChannels() : RakNet::LogCommandParser
  • PrintColumnHeaders() : DataStructures::Table
  • Printf()
: RakNet::RakString
, RakNet::RakWString
  • PrintRow() : DataStructures::Table
  • ProcessTCPPacket() : RakNet::HTTPConnection
  • Push() : DataStructures::List< list_type > , DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • PushBackPacket()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • PushConnection() : RakNet::ReplicaManager3
  • PushOpposite() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- q -

  • QueryActionOnPopConnection()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • QueryActionOnPopConnection_Client() : RakNet::Replica3
  • QueryActionOnPopConnection_PeerToPeer() : RakNet::Replica3
  • QueryActionOnPopConnection_Server() : RakNet::Replica3
  • QueryConstruction()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • QueryConstruction_ClientConstruction() : RakNet::Replica3
  • QueryConstruction_PeerToPeer() : RakNet::Replica3
  • QueryConstruction_ServerConstruction() : RakNet::Replica3
  • QueryConstructionMode() : RakNet::Connection_RM3
  • QueryDestruction()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • QueryGroupDownloadMessages() : RakNet::Connection_RM3
  • QueryRelayDestruction()
: RakNet::Replica3Composite< parent_type >
, RakNet::Replica3
  • QueryRemoteConstruction()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • QueryRemoteConstruction_ClientConstruction() : RakNet::Replica3
  • QueryRemoteConstruction_PeerToPeer() : RakNet::Replica3
  • QueryRemoteConstruction_ServerConstruction() : RakNet::Replica3
  • QueryReplicaList() : RakNet::Connection_RM3
  • QuerySerialization()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • QuerySerialization_ClientSerializable() : RakNet::Replica3
  • QuerySerialization_PeerToPeer() : RakNet::Replica3
  • QuerySerialization_ServerSerializable() : RakNet::Replica3
  • QuerySerializationList() : RakNet::Connection_RM3
  • QueryTable() : DataStructures::Table
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- r -

  • RakPeer() : RakNet::RakPeer
  • Read()
: RakNet::BitStream
, RakNet::HTTPConnection
, RakNet::BitStream
  • ReadAlignedBytes() : RakNet::BitStream
  • ReadAlignedBytesSafe() : RakNet::BitStream
  • ReadAlignedBytesSafeAlloc() : RakNet::BitStream
  • ReadBit() : RakNet::BitStream
  • ReadBits() : RakNet::BitStream
  • ReadBitsFromIntegerRange() : RakNet::BitStream
  • ReadCasted() : RakNet::BitStream
  • ReadCompressed() : RakNet::BitStream
  • ReadCompressedDelta() : RakNet::BitStream
  • ReadDelta() : RakNet::BitStream
  • ReadFloat16() : RakNet::BitStream
  • ReadIntFromSubstring() : RakNet::RakString
  • ReadIsLocked() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • ReadLock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • ReadNormQuat() : RakNet::BitStream
  • ReadNormVector() : RakNet::BitStream
  • ReadOrthMatrix() : RakNet::BitStream
  • ReadUnlock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • ReadVarFromBitstream() : RakNet::VariableListDeltaTracker
  • ReadVector() : RakNet::BitStream
  • Reallocate() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • RebootServer() : RakNet::Rackspace
  • RebuildServer() : RakNet::Rackspace
  • Receive()
: RakNet::RakNetTransport2
, RakNet::RakPeer
, RakNet::RakPeerInterface
, RakNet::ReliabilityLayer
, RakNet::TelnetTransport
, RakNet::TransportInterface
  • ReceiveFrame() : RakNet::RakVoice
  • Reference() : RakNet::ReplicaManager3
  • ReferenceTeam() : RakNet::TM_World
  • ReferenceTeamMember() : RakNet::TM_World
  • RegisterBlockingFunction() : RakNet::RPC4
  • RegisterCommand() : RakNet::CommandParserInterface
  • RegisterFunction()
: RakNet::RPC4
, RakNet::RPC3
  • RegisterLocalCallback() : RakNet::RPC4
  • RegisterSlot()
: RakNet::RPC4
, RakNet::RPC3
  • RelayPlugin() : RakNet::RelayPlugin
  • Release() : RakNet::CloudClient
  • RemoveAdminAddress() : RakNet::Lobby2Server
  • RemoveAllQueryFilters() : RakNet::CloudServer
  • RemoveApplication()
: RakNet::AutopatcherPostgreRepository
, RakNet::AutopatcherMySQLRepository
  • RemoveAtIndex() : DataStructures::List< list_type > , DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • RemoveAtIndexFast() : DataStructures::List< list_type >
  • RemoveAtKey() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • RemoveCallback() : RakNet::FileListTransfer
  • RemoveCallbackInterface() : RakNet::Lobby2Plugin
  • RemoveCharacter() : RakNet::RakString
  • RemoveColumn() : DataStructures::Table
  • RemoveCommandParser() : RakNet::ConsoleServer
  • RemoveDBHandle() : RakNet::SQLite3ServerPlugin
  • RemoveEventCallback() : RakNet::Rackspace
  • RemoveFromBanList()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • RemoveFromEnd() : DataStructures::List< list_type >
  • RemoveFromSecurityExceptionList()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • RemoveFromWaitList() : RakNet::ReadyEvent
  • RemoveInputAtIndex() : ThreadPool< InputType, OutputType >
  • RemoveLoginServerAddress() : RakNet::RoomsPlugin
  • RemoveOutputAtIndex() : ThreadPool< InputType, OutputType >
  • RemoveParticipant() : RakNet::TM_World
  • RemoveParticipantOnServer() : RakNet::RelayPlugin
  • RemoveParticipantRequestFromClient() : RakNet::RelayPlugin
  • RemoveQueryFilter() : RakNet::CloudServer
  • RemoveRankingAddress() : RakNet::Lobby2Server
  • RemoveReceiver() : RakNet::FileListTransfer
  • RemoveReference()
: RakNet::StringCompressor
, RakNet::StringTable
  • RemoveRemoteSystemVariableHistory() : RakNet::VariableDeltaSerializer
  • RemoveRoomsCallback() : RakNet::RoomsPlugin
  • RemoveRow() : DataStructures::Table
  • RemoveRows() : DataStructures::Table
  • RemoveServer() : RakNet::CloudServer
  • RemoveWorld()
: RakNet::ReplicaManager3
, RakNet::TeamManager
  • Replace()
: DataStructures::List< list_type >
, RakNet::RakString
  • RequestAnyTeam() : RakNet::TeamBalancer
  • RequestForwarding() : RakNet::UDPProxyClient
  • RequestSpecificTeam() : RakNet::TeamBalancer
  • RequestTeam() : RakNet::TM_TeamMember
  • RequestTeamSwitch() : RakNet::TM_TeamMember
  • RequestVoiceChannel() : RakNet::RakVoice
  • RequiresAdmin()
: RakNet::System_PruneAccounts
, RakNet::Client_GetEmailAddress
, RakNet::Client_GetPasswordRecoveryQuestionByHandle
, RakNet::Client_GetPasswordByPasswordRecoveryAnswer
, RakNet::Client_ChangeHandle
, RakNet::Client_UpdateAccount
, RakNet::Client_GetAccountDetails
, RakNet::Client_StartIgnore
, RakNet::Client_StopIgnore
, RakNet::Client_GetIgnoreList
, RakNet::Client_PerTitleBinaryStorage
, RakNet::Client_SetPresence
, RakNet::Client_GetPresence
, RakNet::Friends_SendInvite
, RakNet::Friends_AcceptInvite
, RakNet::Friends_RejectInvite
, RakNet::Friends_GetInvites
, RakNet::Friends_GetFriends
, RakNet::Friends_Remove
, RakNet::BookmarkedUsers_Add
, RakNet::BookmarkedUsers_Remove
, RakNet::BookmarkedUsers_Get
, RakNet::Emails_Send
, RakNet::Emails_Get
, RakNet::Emails_Delete
, RakNet::Emails_SetStatus
, RakNet::Ranking_SubmitMatch
, RakNet::Ranking_GetMatches
, RakNet::Ranking_GetMatchBinaryData
, RakNet::Ranking_GetTotalScore
, RakNet::Ranking_WipeScoresForPlayer
, RakNet::Ranking_WipeMatches
, RakNet::Ranking_PruneMatches
, RakNet::Ranking_UpdateRating
, RakNet::Ranking_WipeRatings
, RakNet::Ranking_GetRating
, RakNet::Clans_Create
, RakNet::Clans_SetProperties
, RakNet::Clans_GetProperties
, RakNet::Clans_SetMyMemberProperties
, RakNet::Clans_GrantLeader
, RakNet::Clans_SetSubleaderStatus
, RakNet::Clans_SetMemberRank
, RakNet::Clans_GetMemberProperties
, RakNet::Clans_ChangeHandle
, RakNet::Clans_Leave
, RakNet::Clans_Get
, RakNet::Clans_SendJoinInvitation
, RakNet::Clans_WithdrawJoinInvitation
, RakNet::Clans_AcceptJoinInvitation
, RakNet::Clans_RejectJoinInvitation
, RakNet::Clans_DownloadInvitationList
, RakNet::Clans_SendJoinRequest
, RakNet::Clans_WithdrawJoinRequest
, RakNet::Clans_AcceptJoinRequest
, RakNet::Clans_RejectJoinRequest
, RakNet::Clans_DownloadRequestList
, RakNet::Clans_KickAndBlacklistUser
, RakNet::Clans_UnblacklistUser
, RakNet::Clans_GetBlacklist
, RakNet::Clans_GetMembers
, RakNet::Clans_GetList
, RakNet::Clans_CreateBoard
, RakNet::Clans_DestroyBoard
, RakNet::Clans_CreateNewTopic
, RakNet::Clans_ReplyToTopic
, RakNet::Clans_RemovePost
, RakNet::Clans_GetBoards
, RakNet::Clans_GetTopics
, RakNet::Clans_GetPosts
, RakNet::Lobby2Message
, RakNet::Platform_Startup
, RakNet::Platform_Shutdown
, RakNet::System_CreateDatabase
, RakNet::System_DestroyDatabase
, RakNet::System_CreateTitle
, RakNet::System_DestroyTitle
, RakNet::System_GetTitleRequiredAge
, RakNet::System_GetTitleBinaryData
, RakNet::System_RegisterProfanity
, RakNet::System_BanUser
, RakNet::System_UnbanUser
, RakNet::CDKey_Add
, RakNet::CDKey_GetStatus
, RakNet::CDKey_Use
, RakNet::CDKey_FlagStolen
, RakNet::Client_Login
, RakNet::Client_Logoff
, RakNet::Client_RegisterAccount
, RakNet::System_SetEmailAddressValidated
, RakNet::Client_ValidateHandle
, RakNet::System_DeleteAccount
  • RequiresLogin()
: RakNet::Clans_UnblacklistUser
, RakNet::Clans_GetBoards
, RakNet::Clans_Create
, RakNet::Clans_SetProperties
, RakNet::Clans_GetProperties
, RakNet::Clans_SetMyMemberProperties
, RakNet::Clans_GrantLeader
, RakNet::Clans_SetSubleaderStatus
, RakNet::Clans_SetMemberRank
, RakNet::Clans_ChangeHandle
, RakNet::Clans_Leave
, RakNet::Clans_Get
, RakNet::Clans_WithdrawJoinInvitation
, RakNet::Clans_AcceptJoinInvitation
, RakNet::Clans_RejectJoinInvitation
, RakNet::Clans_GetBlacklist
, RakNet::Clans_SendJoinRequest
, RakNet::Clans_WithdrawJoinRequest
, RakNet::Clans_AcceptJoinRequest
, RakNet::Clans_ReplyToTopic
, RakNet::Clans_DownloadRequestList
, RakNet::Clans_RemovePost
, RakNet::Clans_DestroyBoard
, RakNet::Clans_GetMembers
, RakNet::Clans_CreateBoard
, RakNet::Clans_GetList
, RakNet::Clans_CreateNewTopic
, RakNet::Clans_DownloadInvitationList
, RakNet::Clans_GetTopics
, RakNet::Clans_GetPosts
, RakNet::Clans_KickAndBlacklistUser
, RakNet::Clans_RejectJoinRequest
, RakNet::Clans_GetMemberProperties
, RakNet::Clans_SendJoinInvitation
, RakNet::Client_GetIgnoreList
, RakNet::Ranking_SubmitMatch
, RakNet::Ranking_GetRating
, RakNet::Ranking_GetMatches
, RakNet::Ranking_UpdateRating
, RakNet::Ranking_WipeRatings
, RakNet::Ranking_WipeMatches
, RakNet::Ranking_GetTotalScore
, RakNet::BookmarkedUsers_Add
, RakNet::Emails_SetStatus
, RakNet::Emails_Get
, RakNet::Client_SetPresence
, RakNet::Friends_GetFriends
, RakNet::Friends_Remove
, RakNet::Friends_RejectInvite
, RakNet::Friends_SendInvite
, RakNet::System_SetEmailAddressValidated
, RakNet::Client_StartIgnore
, RakNet::Lobby2Message
, RakNet::Platform_Startup
, RakNet::Platform_Shutdown
, RakNet::System_CreateDatabase
, RakNet::System_DestroyDatabase
, RakNet::System_DestroyTitle
, RakNet::System_GetTitleRequiredAge
, RakNet::System_GetTitleBinaryData
, RakNet::Client_GetPasswordByPasswordRecoveryAnswer
, RakNet::System_BanUser
, RakNet::System_UnbanUser
, RakNet::CDKey_Add
, RakNet::CDKey_Use
, RakNet::CDKey_FlagStolen
, RakNet::Client_Login
, RakNet::System_DeleteAccount
, RakNet::Client_GetPasswordRecoveryQuestionByHandle
, RakNet::Client_RegisterAccount
, RakNet::Client_ValidateHandle
, RakNet::System_PruneAccounts
, RakNet::Client_GetEmailAddress
, RakNet::Client_Logoff
, RakNet::Ranking_WipeScoresForPlayer
, RakNet::Client_ChangeHandle
, RakNet::Client_UpdateAccount
, RakNet::Client_GetAccountDetails
, RakNet::Emails_Send
, RakNet::Client_StopIgnore
, RakNet::Client_PerTitleBinaryStorage
, RakNet::CDKey_GetStatus
, RakNet::Client_GetPresence
, RakNet::Friends_AcceptInvite
, RakNet::Friends_GetInvites
, RakNet::System_RegisterProfanity
, RakNet::BookmarkedUsers_Remove
, RakNet::BookmarkedUsers_Get
, RakNet::Emails_Delete
, RakNet::System_CreateTitle
, RakNet::Ranking_GetMatchBinaryData
, RakNet::Ranking_PruneMatches
  • RequiresRankingPermission()
: RakNet::Client_RegisterAccount
, RakNet::Clans_ReplyToTopic
, RakNet::Friends_RejectInvite
, RakNet::Clans_SendJoinRequest
, RakNet::Clans_WithdrawJoinInvitation
, RakNet::Clans_DownloadInvitationList
, RakNet::Emails_SetStatus
, RakNet::System_GetTitleRequiredAge
, RakNet::Ranking_WipeMatches
, RakNet::Emails_Send
, RakNet::System_DestroyTitle
, RakNet::Ranking_GetMatchBinaryData
, RakNet::Lobby2Message
, RakNet::Clans_SetMemberRank
, RakNet::Client_PerTitleBinaryStorage
, RakNet::CDKey_Add
, RakNet::System_DeleteAccount
, RakNet::Clans_CreateNewTopic
, RakNet::Clans_DownloadRequestList
, RakNet::Client_Login
, RakNet::System_PruneAccounts
, RakNet::Clans_KickAndBlacklistUser
, RakNet::Client_GetAccountDetails
, RakNet::Clans_Create
, RakNet::BookmarkedUsers_Get
, RakNet::Clans_RemovePost
, RakNet::CDKey_GetStatus
, RakNet::Client_UpdateAccount
, RakNet::Client_SetPresence
, RakNet::Clans_RejectJoinInvitation
, RakNet::Friends_SendInvite
, RakNet::Client_GetIgnoreList
, RakNet::Friends_GetFriends
, RakNet::Clans_GetTopics
, RakNet::Client_GetPasswordByPasswordRecoveryAnswer
, RakNet::Friends_GetInvites
, RakNet::Clans_GetMemberProperties
, RakNet::Client_ValidateHandle
, RakNet::Client_Logoff
, RakNet::Clans_GrantLeader
, RakNet::Clans_SetSubleaderStatus
, RakNet::BookmarkedUsers_Add
, RakNet::Ranking_GetMatches
, RakNet::Clans_CreateBoard
, RakNet::Emails_Delete
, RakNet::System_BanUser
, RakNet::Ranking_SubmitMatch
, RakNet::Client_GetPasswordRecoveryQuestionByHandle
, RakNet::Clans_GetMembers
, RakNet::System_CreateTitle
, RakNet::System_RegisterProfanity
, RakNet::Clans_Get
, RakNet::Ranking_WipeRatings
, RakNet::Ranking_GetTotalScore
, RakNet::Ranking_WipeScoresForPlayer
, RakNet::Client_ChangeHandle
, RakNet::Clans_WithdrawJoinRequest
, RakNet::System_DestroyDatabase
, RakNet::Clans_RejectJoinRequest
, RakNet::System_CreateDatabase
, RakNet::Clans_AcceptJoinInvitation
, RakNet::CDKey_FlagStolen
, RakNet::Clans_GetProperties
, RakNet::System_SetEmailAddressValidated
, RakNet::Clans_DestroyBoard
, RakNet::Client_GetEmailAddress
, RakNet::Client_StartIgnore
, RakNet::Clans_GetBoards
, RakNet::Clans_SendJoinInvitation
, RakNet::Clans_Leave
, RakNet::BookmarkedUsers_Remove
, RakNet::Client_StopIgnore
, RakNet::Clans_SetMyMemberProperties
, RakNet::Clans_ChangeHandle
, RakNet::Clans_GetPosts
, RakNet::Emails_Get
, RakNet::Platform_Startup
, RakNet::Clans_AcceptJoinRequest
, RakNet::Clans_SetProperties
, RakNet::Ranking_GetRating
, RakNet::Clans_GetBlacklist
, RakNet::Ranking_UpdateRating
, RakNet::Friends_Remove
, RakNet::System_UnbanUser
, RakNet::Client_GetPresence
, RakNet::CDKey_Use
, RakNet::Friends_AcceptInvite
, RakNet::Platform_Shutdown
, RakNet::Clans_UnblacklistUser
, RakNet::Ranking_PruneMatches
, RakNet::System_GetTitleBinaryData
, RakNet::Clans_GetList
  • Reset()
: RakNet::BitStream
, RakNet::HuffmanEncodingTreeFactory
, RakNet::ReliabilityLayer
  • ResetReadPointer() : RakNet::BitStream
  • ResetWritePointer() : RakNet::BitStream
  • ResizeServer() : RakNet::Rackspace
  • ReturnResult() : RakNet::CommandParserInterface
  • ReverseList() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • RevertResizedServer() : RakNet::Rackspace
  • RPC4GlobalRegistration() : RakNet::RPC4GlobalRegistration
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- s -

  • Send()
: RakNet::EmailSender
, RakNet::FileListTransfer
, RakNet::RakPeer
, RakNet::ReliabilityLayer
, RakNet::TelnetTransport
, RakNet::RakPeer
, RakNet::TransportInterface
, RakNet::RakNetTransport2
, RakNet::RakPeerInterface
  • SendFrame() : RakNet::RakVoice
  • SendHelp()
: RakNet::CommandParserInterface
, RakNet::LogCommandParser
, RakNet::RakNetCommandParser
  • SendList()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • SendLoopback()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • SendMsg()
: RakNet::Lobby2Client
, RakNet::Lobby2Server
  • SendMsgAndDealloc() : RakNet::Lobby2Client
  • SendToParticipant() : RakNet::RelayPlugin
  • SendTTL()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • Serialize()
: RakNet::Replica3Composite< parent_type >
, RakNet::Friends_AcceptInvite
, RakNet::Friends_RejectInvite
, RakNet::Lobby2Message
, RakNet::Friends_GetInvites
, RakNet::Friends_GetFriends
, RakNet::System_CreateTitle
, RakNet::Friends_Remove
, RakNet::BookmarkedUsers_Add
, RakNet::System_DestroyTitle
, RakNet::BookmarkedUsers_Remove
, RakNet::BookmarkedUsers_Get
, RakNet::System_GetTitleRequiredAge
, RakNet::Emails_Send
, RakNet::Emails_Get
, RakNet::System_GetTitleBinaryData
, RakNet::Emails_Delete
, RakNet::Emails_SetStatus
, RakNet::System_RegisterProfanity
, RakNet::Ranking_SubmitMatch
, RakNet::Ranking_GetMatches
, RakNet::System_BanUser
, RakNet::Ranking_GetMatchBinaryData
, RakNet::Ranking_GetTotalScore
, RakNet::System_UnbanUser
, RakNet::Ranking_WipeScoresForPlayer
, RakNet::Ranking_WipeMatches
, RakNet::CDKey_Add
, RakNet::Ranking_PruneMatches
, RakNet::Ranking_UpdateRating
, RakNet::CDKey_GetStatus
, RakNet::Ranking_WipeRatings
, RakNet::Ranking_GetRating
, RakNet::CDKey_Use
, RakNet::Clans_Create
, RakNet::Clans_SetProperties
, RakNet::CDKey_FlagStolen
, RakNet::Clans_GetProperties
, RakNet::Clans_SetMyMemberProperties
, RakNet::Client_Login
, RakNet::Clans_GrantLeader
, RakNet::Clans_SetSubleaderStatus
, RakNet::Client_RegisterAccount
, RakNet::Clans_SetMemberRank
, RakNet::Clans_GetMemberProperties
, RakNet::System_SetEmailAddressValidated
, RakNet::Clans_ChangeHandle
, RakNet::Clans_Leave
, RakNet::Client_ValidateHandle
, RakNet::Clans_Get
, RakNet::Clans_SendJoinInvitation
, RakNet::System_DeleteAccount
, RakNet::Clans_WithdrawJoinInvitation
, RakNet::Clans_AcceptJoinInvitation
, RakNet::BitStream
, RakNet::System_PruneAccounts
, RakNet::Clans_RejectJoinInvitation
, RakNet::Clans_DownloadInvitationList
, RakNet::Client_GetEmailAddress
, RakNet::Clans_SendJoinRequest
, RakNet::Clans_WithdrawJoinRequest
, RakNet::BitStream
, RakNet::Client_GetPasswordRecoveryQuestionByHandle
, RakNet::Clans_AcceptJoinRequest
, RakNet::Clans_RejectJoinRequest
, RakNet::Client_GetPasswordByPasswordRecoveryAnswer
, RakNet::Clans_DownloadRequestList
, RakNet::Clans_KickAndBlacklistUser
, RakNet::RakString
, RakNet::Client_ChangeHandle
, RakNet::Clans_UnblacklistUser
, RakNet::Clans_GetBlacklist
, RakNet::Client_UpdateAccount
, RakNet::Clans_GetMembers
, RakNet::Clans_GetList
, RakNet::RakString
, RakNet::Client_GetAccountDetails
, RakNet::Clans_CreateBoard
, RakNet::Clans_DestroyBoard
, RakNet::Client_StartIgnore
, RakNet::Clans_CreateNewTopic
, RakNet::Clans_ReplyToTopic
, RakNet::RakWString
, RakNet::Client_StopIgnore
, RakNet::Clans_RemovePost
, RakNet::Clans_GetBoards
, RakNet::Client_GetIgnoreList
, RakNet::Clans_GetTopics
, RakNet::Clans_GetPosts
, RakNet::RakWString
, RakNet::Client_PerTitleBinaryStorage
, RakNet::Client_SetPresence
, RakNet::Replica3
, RakNet::Client_GetPresence
, RakNet::Friends_SendInvite
  • SerializeBits() : RakNet::BitStream
  • SerializeBitsFromIntegerRange() : RakNet::BitStream
  • SerializeCasted() : RakNet::BitStream
  • SerializeChangeHandle() : RakNet::RoomsPlugin
  • SerializeCompressed()
: RakNet::BitStream
, RakNet::RakString
  • SerializeCompressedDelta() : RakNet::BitStream
  • SerializeConstruction()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
, RakNet::TM_TeamMember
, RakNet::TM_Team
  • SerializeConstructionExisting()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • SerializeDelta() : RakNet::BitStream
  • SerializeDestruction()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • SerializeFloat16() : RakNet::BitStream
  • SerializeLogin() : RakNet::RoomsPlugin
  • SerializeLogoff() : RakNet::RoomsPlugin
  • SerializeNormQuat() : RakNet::BitStream
  • SerializeNormVector() : RakNet::BitStream
  • SerializeOnDownloadComplete() : RakNet::Connection_RM3
  • SerializeOnDownloadStarted() : RakNet::Connection_RM3
  • SerializeOrthMatrix() : RakNet::BitStream
  • SerializeVariable() : RakNet::VariableDeltaSerializer
  • SerializeVector() : RakNet::BitStream
  • ServerDBImpl() : RakNet::Lobby2Message
  • ServerPostDBMemoryImpl() : RakNet::Lobby2Message
  • ServerPreDBMemoryImpl()
: RakNet::Lobby2Message
, RakNet::Platform_Startup
, RakNet::Platform_Shutdown
  • Set()
: DataStructures::Table::Cell
, RakNet::RakString
, RakNet::RakWString
  • SetAcceptAddParticipantRequests() : RakNet::RelayPlugin
  • SetActionOnDisallowedMessage() : RakNet::MessageFilter
  • SetAllowDownloadOfOriginalUnmodifiedFiles() : RakNet::AutopatcherServer
  • SetAllowMessageID() : RakNet::MessageFilter
  • SetAllowRPC4() : RakNet::MessageFilter
  • SetAutoAddNewConnectionsToFilter() : RakNet::MessageFilter
  • SetAutoManageConnections()
: RakNet::TM_World
, RakNet::ReplicaManager3
, RakNet::TeamManager
  • SetAutoProcessNewConnections() : RakNet::ConnectionGraph2
  • SetAutoSerializeInterval() : RakNet::ReplicaManager3
  • SetBalanceTeams() : RakNet::TM_World
  • SetBinaryAddress() : RakNet::SystemAddress
  • SetCallbackInterface() : RakNet::Lobby2Plugin
  • SetChar() : RakNet::RakString
  • SetConfigurationProperties() : RakNet::Lobby2Server
  • SetDebugInterface()
: RakNet::NatPunchthroughClient
, RakNet::NatPunchthroughServer
, RakNet::Router2
  • SetDefaultAssignmentAlgorithm() : RakNet::TeamBalancer
  • SetDefaultCallbacks() : RakNet::CloudClient
  • SetDefaultOrderingChannel() : RakNet::ReplicaManager3
  • SetDefaultPacketPriority() : RakNet::ReplicaManager3
  • SetDefaultPacketReliability() : RakNet::ReplicaManager3
  • SetDisallowedMessageCallback() : RakNet::MessageFilter
  • SetEncoderComplexity() : RakNet::RakVoice
  • SetEvent() : RakNet::ReadyEvent
  • SetFileListTransferPlugin() : RakNet::AutopatcherServer
  • SetFilterMaxTime() : RakNet::MessageFilter
  • SetForceEvenTeams() : RakNet::TeamBalancer
  • SetHost() : RakNet::TM_World
  • SetIncomingDatagramEventHandler()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • SetIncomingPassword()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • SetInternalID()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • SetJoinPermissions() : RakNet::TM_Team
  • SetLimitIPConnectionFrequency()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • SetLoadManagementCallback() : RakNet::AutopatcherServer
  • SetLockTeams() : RakNet::TeamBalancer
  • SetLogDirectMessages() : RakNet::PacketLogger
  • SetLoopbackMode() : RakNet::RakVoice
  • SetMaxBytesPerDownload() : RakNet::CloudServer
  • SetMaxConurrentUsers() : RakNet::AutopatcherServer
  • SetMaxForwardEntries() : RakNet::UDPForwarder
  • SetMaximumForwardingRequests() : RakNet::Router2
  • SetMaximumIncomingConnections()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • SetMaxUploadBytesPerClient() : RakNet::CloudServer
  • SetMemberLimit() : RakNet::TM_Team
  • SetMessageFactory() : RakNet::Lobby2Plugin
  • SetMultilistType() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • SetNetworkID() : RakNet::NetworkIDObject
  • SetNetworkIDManager()
: RakNet::RPC3
, RakNet::NetworkIDObject
, RakNet::ReplicaManager3
  • SetNoiseFilter() : RakNet::RakVoice
  • SetNumberOfBitsAllocated() : RakNet::BitStream
  • SetOccasionalPing()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • SetOfflinePingResponse()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • SetOrderingChannel()
: RakNet::Lobby2Plugin
, RakNet::RoomsPlugin
  • SetOwner()
: RakNet::TM_TeamMember
, RakNet::TM_Team
  • SetParent() : RakNet::NetworkIDObject
  • SetPerConnectionOutgoingBandwidthLimit()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • SetPortHostOrder() : RakNet::SystemAddress
  • SetPrefix() : RakNet::PacketLogger
  • SetPresence() : RakNet::Lobby2Server
  • SetProfanityFilter() : RakNet::RoomsPlugin
  • SetPrompt() : RakNet::ConsoleServer
  • SetPtr() : DataStructures::Table::Cell
  • SetRakPeerInterface() : RakNet::RakNetCommandParser
  • SetReadOffset() : RakNet::BitStream
  • SetRecipientAddress() : RakNet::RPC3
  • SetRecipientObject() : RakNet::RPC3
  • SetRemoteLoginPassword() : RakNet::UDPProxyCoordinator
  • SetResultHandler()
: RakNet::UDPProxyServer
, RakNet::UDPProxyClient
  • SetRoomsCallback() : RakNet::RoomsPlugin
  • SetRoomsPlugin() : RakNet::Lobby2Server
  • SetRoomsPluginAddress() : RakNet::Lobby2Server
  • SetSendChannel() : RakNet::ReadyEvent
  • SetSendParams() : RakNet::RPC3
  • SetSendPriority()
: RakNet::RoomsPlugin
, RakNet::Lobby2Plugin
  • SetServerAddress()
: RakNet::RoomsPlugin
, RakNet::Lobby2Client
  • SetServerPublicIP() : RakNet::UDPProxyServer
  • SetSocketFamily()
: RakNet::UDPProxyServer
, RakNet::Router2
  • SetSortOrder() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • SetSplitMessageProgressInterval()
: RakNet::RakPeerInterface
, RakNet::RakPeer
  • SetSuffix() : RakNet::PacketLogger
  • SetSystemFilterSet() : RakNet::MessageFilter
  • SetTeamSizeLimit() : RakNet::TeamBalancer
  • SetTimeoutCallback() : RakNet::MessageFilter
  • SetTimeoutTime()
: RakNet::RakPeer
, RakNet::RakPeerInterface
, RakNet::ReliabilityLayer
  • SetTimestamp() : RakNet::RPC3
  • SetToLoopback() : RakNet::SystemAddress
  • SetTopology() : RakNet::TeamManager
  • SetTransportProvider() : RakNet::ConsoleServer
  • SetUnreliableTimeout()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • SetUploadSendParameters() : RakNet::AutopatcherServer
  • SetupReceive() : RakNet::FileListTransfer
  • SetUserUpdateThread()
: RakNet::RakPeer
, RakNet::RakPeerInterface
  • SetVAD() : RakNet::RakVoice
  • SetVBR() : RakNet::RakVoice
  • SetWriteOffset() : RakNet::BitStream
  • ShareServerAddress() : RakNet::Rackspace
  • ShiftIncomingTimestamp() : RakNet::RakPeer
  • Shutdown()
: RakNet::UDPForwarder
, RakNet::RakPeerInterface
, RakNet::RakPeer
  • Signal()
: RakNet::RPC4
, RakNet::RPC3
  • SignalExplicit() : RakNet::RPC3
  • Size()
: DataStructures::List< list_type >
, DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • Sort() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • SortTable() : DataStructures::Table
  • SpecificTeam() : RakNet::TeamSelection
  • SplitURI() : RakNet::RakString
  • SQLEscape() : RakNet::RakString
  • Start()
: RakNet::TelnetTransport
, RakNet::TransportInterface
, RakNet::RakNetTransport2
  • StartForwarding() : RakNet::UDPForwarder
  • StartIncrementalReadThreads() : RakNet::FileListTransfer
  • StartThreads() : ThreadPool< InputType, OutputType > , RakNet::AutopatcherServer
  • Startup()
: RakNet::RakPeer
, RakNet::UDPForwarder
, RakNet::RakPeerInterface
, RakNet::NatTypeDetectionServer
  • Stop()
: RakNet::RakNetTransport2
, RakNet::TransportInterface
, RakNet::TelnetTransport
  • StopForwarding() : RakNet::UDPForwarder
  • StopThreads() : ThreadPool< InputType, OutputType >
  • StrCmp()
: RakNet::RakWString
, RakNet::RakString
  • StrICmp()
: RakNet::RakString
, RakNet::RakWString
  • StringTable() : RakNet::StringTable
  • StrNCmp() : RakNet::RakString
  • Subscribe() : RakNet::LogCommandParser
  • SystemAddress() : RakNet::SystemAddress
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- t -

  • TagSorted() : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • TerminateAtFirstCharacter() : RakNet::RakString
  • TerminateAtLastCharacter() : RakNet::RakString
  • ToInteger()
: RakNet::SystemAddress
, RakNet::RakString
, RakNet::RakWString
  • ToLower() : RakNet::RakString
  • ToString_Old() : RakNet::SystemAddress
  • ToUpper() : RakNet::RakString
  • TransmitRequest() : RakNet::HTTPConnection2
  • Truncate() : RakNet::RakString
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- u -

  • UnlockInput() : ThreadPool< InputType, OutputType >
  • UnlockOutput() : ThreadPool< InputType, OutputType >
  • UnregisterBlockingFunction() : RakNet::RPC4
  • UnregisterFunction()
: RakNet::RPC4
, RakNet::RPC3
  • UnregisterLocalCallback() : RakNet::RPC4
  • UnregisterSlot() : RakNet::RPC4
  • Unsubscribe()
: RakNet::CloudClient
, RakNet::LogCommandParser
  • Update()
: RakNet::NatPunchthroughClient
, RakNet::AutopatcherServer
, RakNet::Lobby2Server
, RakNet::NatPunchthroughServer
, RakNet::RoomsPlugin
, RakNet::SQLite3ServerPlugin
, RakNet::NatTypeDetectionClient
, RakNet::RakVoice
, RakNet::UDPProxyServer
, RakNet::UDPProxyCoordinator
, RakNet::NatTypeDetectionServer
, RakNet::TwoWayAuthentication
, RakNet::ThreadsafePacketLogger
, RakNet::CloudServer
, RakNet::PluginInterface2
, RakNet::Router2
, RakNet::ReliabilityLayer
, RakNet::ConsoleServer
, RakNet::ReplicaManager3
, RakNet::FileListTransfer
, RakNet::StatisticsHistoryPlugin
, RakNet::TeamManager
, RakNet::FileListTransferCBInterface
, RakNet::MessageFilter
, RakNet::HTTPConnection
, RakNet::UDPProxyClient
  • UpdateApplicationFiles()
: RakNet::AutopatcherMySQLRepository
, RakNet::AutopatcherPostgreRepository
  • UpdateCell()
: DataStructures::Table::Row
, DataStructures::Table
, DataStructures::Table::Row
  • UpdateServerNameOrPassword() : RakNet::Rackspace
  • URLDecode() : RakNet::RakString
  • URLEncode() : RakNet::RakString
  • UsesReliabilityLayer()
: RakNet::PacketLogger
, RakNet::PluginInterface2
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- v -

  • ValidateBinary() : RakNet::Lobby2Message
  • ValidateEmailAddress() : RakNet::Lobby2Message
  • ValidateHandle() : RakNet::Lobby2Message
  • ValidatePassword() : RakNet::Lobby2Message
  • ValidateRequiredText() : RakNet::Lobby2Message
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- w -

  • WasReferenced() : RakNet::Replica3
  • WasStarted() : ThreadPool< InputType, OutputType >
  • Write() : RakNet::BitStream
  • Write0() : RakNet::BitStream
  • Write1() : RakNet::BitStream
  • WriteAlignedBytes() : RakNet::BitStream
  • WriteAlignedBytesSafe() : RakNet::BitStream
  • WriteAllocationID()
: RakNet::Replica3
, RakNet::Replica3Composite< parent_type >
  • WriteBits() : RakNet::BitStream
  • WriteBitsFromIntegerRange() : RakNet::BitStream
  • WriteCasted() : RakNet::BitStream
  • WriteCompressed() : RakNet::BitStream
  • WriteCompressedDelta() : RakNet::BitStream
  • WriteDelta() : RakNet::BitStream
  • WriteFloat16() : RakNet::BitStream
  • WriteLock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • WriteLog()
: RakNet::LogCommandParser
, RakNet::PacketConsoleLogger
, RakNet::PacketOutputWindowLogger
, RakNet::PacketFileLogger
, RakNet::PacketLogger
  • WriteNormQuat() : RakNet::BitStream
  • WriteNormVector() : RakNet::BitStream
  • WriteOrthMatrix() : RakNet::BitStream
  • WritePtr() : RakNet::BitStream
  • WriteUnlock() : DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
  • WriteVar() : RakNet::VariableListDeltaTracker
  • WriteVarToBitstream() : RakNet::VariableListDeltaTracker
  • WriteVector() : RakNet::BitStream
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • ~

- ~ -

  • ~RakPeer() : RakNet::RakPeer
  • ~RakPeerInterface() : RakNet::RakPeerInterface
  • ~RelayPlugin() : RakNet::RelayPlugin
  • ~Replica3() : RakNet::Replica3
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • accountRegistrationRequiredAgeYears : RakNet::Lobby2Server::ConfigurationProperties
  • accountRegistrationRequiresCDKey : RakNet::Lobby2Server::ConfigurationProperties
  • activeSystemList : RakNet::RakPeer
  • addr4 : RakNet::SystemAddress
  • allocationSize : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • allowConnectionResponseIPMigration : RakNet::RakPeer

- b -

  • binaryData : RakNet::Client_PerTitleBinaryStorage
  • bitSize : RakNet::Packet
  • bitsWrittenSoFar : RakNet::SerializeParameters
  • bookmarkedUsers : RakNet::BookmarkedUsers_Get
  • BPSLimitByCongestionControl : RakNet::RakNetStatistics
  • BPSLimitByOutgoingBandwidthLimit : RakNet::RakNetStatistics
  • bytesInResendBuffer : RakNet::RakNetStatistics
  • bytesInSendBuffer : RakNet::RakNetStatistics
  • bytesSentPerSecond : RakNet::RakPeer

- c -

  • callbackId : RakNet::Lobby2Message
  • channelNames : RakNet::LogCommandParser
  • channels : RakNet::LogCommandParser::SystemAddressAndChannel
  • chatDirectedToRoom : RakNet::Chat_Func
  • connectionStartTime : RakNet::RakNetStatistics
  • context : RakNet::FileListNode
  • creatingSystemGUID : RakNet::Replica3
  • creationTime : RakNet::InternalPacket
  • currentRating : RakNet::Ranking_GetRating
  • curTime : RakNet::SerializeParameters

- d -

  • data
: DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
, RakNet::FileListNode
, RakNet::Packet
, RakNet::InternalPacket
  • dataLengthBytes : RakNet::FileListNode
  • dataSize : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • debugPort : RakNet::SystemAddress
  • deletingSystemGUID : RakNet::Replica3
  • destinationConnection : RakNet::SerializeParameters
  • directedToRoom : RakNet::Bitstream_Func

- e -

  • emailResults : RakNet::Emails_Get
  • endThreads : RakNet::RakPeer
  • extendedResultCode : RakNet::Lobby2Message
  • extraSocketOptions : RakNet::SocketDescriptor

- f -

  • fileLengthBytes : RakNet::FileListNode
  • filename : RakNet::FileListNode
  • fullPathToFile : RakNet::FileListNode

- g -

  • guid : RakNet::Packet

- h -

  • hostAddress : RakNet::SocketDescriptor

- i -

  • incomingPassword : RakNet::RakPeer
  • index : RakNet::IndexedIntegerValue , RakNet::IndexedBinaryValue
  • instance : RakNet::StringTable
  • invitesSent : RakNet::Friends_GetInvites
  • isAReference : RakNet::FileListNode
  • isLimitedByCongestionControl : RakNet::RakNetStatistics
  • isLimitedByOutgoingBandwidthLimit : RakNet::RakNetStatistics
  • isMainLoopThreadActive : RakNet::RakPeer
  • isVisible : RakNet::Lobby2Presence

- k -

  • keys : RakNet::CloudQuery

- l -

  • lastSentBitstream : RakNet::SerializeParameters
  • length : RakNet::Packet

- m -

  • maximumIncomingConnections : RakNet::RakPeer
  • maximumNumberOfPeers : RakNet::RakPeer
  • maxRowsToReturn : RakNet::CloudQuery
  • messageInSendBuffer : RakNet::RakNetStatistics
  • messageInternalOrder : RakNet::InternalPacket
  • messageNumberAssigned : RakNet::InternalPacket
  • messagesInResendBuffer : RakNet::RakNetStatistics
  • messageTimestamp : RakNet::SerializeParameters
  • myPrivateKey : RakNet::PublicKey
  • myPublicKey : RakNet::PublicKey

- n -

  • networkID : RakNet::NetworkIDObject
  • nextActionTime : RakNet::InternalPacket
  • nextSlotRegistrationCount : RakNet::RPC4 , RakNet::RPC3

- o -

  • outputBitstream : RakNet::SerializeParameters

- p -

  • packetlossLastSecond : RakNet::RakNetStatistics
  • packetlossTotal : RakNet::RakNetStatistics
  • parent : RakNet::NetworkIDObject
  • peer : RakNet::RakNetCommandParser
  • port : RakNet::SocketDescriptor
  • preallocationSize : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • presence : RakNet::Client_GetPresence , RakNet::Client_SetPresence
  • primaryKey : RakNet::CloudKey
  • priority : RakNet::InternalPacket
  • pro : RakNet::SerializeParameters
  • publicKeyMode : RakNet::PublicKey

- q -

  • queueHead : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
  • queueTail : DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >

- r -

  • recipient : RakNet::RoomsPluginNotification
  • remoteServerPublicKey : RakNet::PublicKey
  • remoteSystemList : RakNet::RakPeer
  • remoteSystemVariableHistoryList : RakNet::VariableDeltaSerializer
  • remoteUsers : RakNet::LogCommandParser
  • replica : RakNet::LastSerializationResult
  • requestId : RakNet::Lobby2Message
  • requestsQueued : RakNet::AutopatcherServerLoadNotifier::AutopatcherState
  • requestsWorking : RakNet::AutopatcherServerLoadNotifier::AutopatcherState
  • requiresEmailAddressValidationToLogin : RakNet::Lobby2Server::ConfigurationProperties
  • requiresTitleToLogin : RakNet::Lobby2Server::ConfigurationProperties
  • resultCode : RakNet::RoomsPluginFunc , RakNet::Lobby2Message
  • roomsContainer : RakNet::RoomsPlugin
  • runningTotal : RakNet::RakNetStatistics

- s -

  • searchOperator : RakNet::IndexedIntegerValue , RakNet::IndexedBinaryValue
  • secondaryKey : RakNet::CloudKey
  • sendReceiptSerial : RakNet::InternalPacket
  • sendReceiptSerialMutex : RakNet::RakPeer
  • slotIndex : RakNet::Client_PerTitleBinaryStorage
  • socketFamily : RakNet::SocketDescriptor
  • startingRowIndex : RakNet::CloudQuery
  • statusString : RakNet::Lobby2Presence
  • submittedMatches : RakNet::Ranking_GetMatches
  • subscribeToResults : RakNet::CloudQuery
  • systemAddress : RakNet::Packet , RakNet::LogCommandParser::SystemAddressAndChannel

- t -

  • timesSent : RakNet::InternalPacket
  • titleName : RakNet::Client_PerTitleBinaryStorage
  • titleNameOrID : RakNet::Lobby2Presence
  • trans : RakNet::LogCommandParser
  • type : RakNet::IndexedBinaryValue

- u -

  • udpForwarder : RakNet::UDPProxyServer
  • updateCycleIsRunning : RakNet::RakPeer
  • userHandle : RakNet::Client_GetPresence
  • userName : RakNet::RoomsPluginFunc

- v -

  • value : RakNet::IndexedIntegerValue , RakNet::IndexedBinaryValue
  • valueByteLength : RakNet::IndexedBinaryValue
  • valueOverLastSecond : RakNet::RakNetStatistics

- w -

  • whenLastSerialized : RakNet::SerializeParameters
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: Class Members - Enumerations

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • AllocationScheme : RakNet::InternalPacket
  • ConstructionMode : RakNet::Connection_RM3
  • DefaultAssigmentAlgorithm : RakNet::TeamBalancer
  • PTIS_Operation : RakNet::Client_PerTitleBinaryStorage
  • ResponseCodes : RakNet::HTTPConnection
  • SHDataCategory : RakNet::StatisticsHistory
  • SortQueryType : DataStructures::Table
  • Status : RakNet::Lobby2Presence
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: Class Members - Enumerator

  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • AWAY : RakNet::Lobby2Presence
  • DC_CONTINUOUS : RakNet::StatisticsHistory
  • DC_DISCRETE : RakNet::StatisticsHistory
  • DO_NOT_DISTURB : RakNet::Lobby2Presence
  • EDITING_PROFILE : RakNet::Lobby2Presence
  • FILL_IN_ORDER : RakNet::TeamBalancer
  • IN_GAME : RakNet::Lobby2Presence
  • IN_LOBBY : RakNet::Lobby2Presence
  • IN_ROOM : RakNet::Lobby2Presence
  • MINIMIZED : RakNet::Lobby2Presence
  • NORMAL : RakNet::InternalPacket
  • NOT_ONLINE : RakNet::Lobby2Presence
  • QUERY_CONNECTION_FOR_REPLICA_LIST : RakNet::Connection_RM3
  • QUERY_REPLICA_FOR_CONSTRUCTION : RakNet::Connection_RM3
  • QUERY_REPLICA_FOR_CONSTRUCTION_AND_DESTRUCTION : RakNet::Connection_RM3
  • REF_COUNTED : RakNet::InternalPacket
  • SMALLEST_TEAM : RakNet::TeamBalancer
  • STACK : RakNet::InternalPacket
  • TYPING : RakNet::Lobby2Presence
  • UNDEFINED : RakNet::Lobby2Presence
  • VIEWING_PROFILE : RakNet::Lobby2Presence
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: File List

  • File List
  • File Members
File List
Here is a list of all documented files with brief descriptions:
[detail level 1234567]
\ - D: |
\ - temp |
\ - RakNet_PC |
o + DependentExtensions |
| o + Autopatcher |
| | o + AutopatcherMySQLRepository |
| | | \ * AutopatcherMySQLRepository.h | An implementation of the AutopatcherRepositoryInterface to use MySQL to store the relevant data
| | o + AutopatcherPostgreRepository |
| | | \ * AutopatcherPostgreRepository.h | An implementation of the AutopatcherRepositoryInterface to use PostgreSQL to store the relevant data
| | o * AutopatcherClient.h | Client plugin for the autopatcher
| | \ * AutopatcherServer.h | The server plugin for the autopatcher. Must be running for the client to get patches
| o + Lobby2 |
| | \ + Rooms |
| | \ * RoomsPlugin.h | Adds networking to AllGamesRoomsContainer. Lets you create, join, search, and destroy matchmaking rooms for players
| o + RPC3 |
| | \ * RPC3.h | Automatically serializing and deserializing RPC system. Third generation of RPC
| o + SQLite3Plugin |
| | o * SQLite3ClientPlugin.h | Contains code to call sqlite3_exec over a network that does not support shared file handles
| | \ * SQLite3ServerPlugin.h | Contains code to call sqlite3_exec over a network that does not support shared file handles
| \ * RakVoice.h | Voice compression and transmission interface
\ + Source |
o * AutopatcherRepositoryInterface.h | An interface used by AutopatcherServer to get the data necessary to run an autopatcher
o * BitStream.h | This class allows you to write and read native types as a string of bits
o * CloudClient.h | Queries CloudMemoryServer to download data that other clients have uploaded
o * CloudServer.h | Stores client data, and allows cross-server communication to retrieve this data
o * CommandParserInterface.h | Contains CommandParserInterface , from which you derive custom command parsers
o * ConnectionGraph2.h | Connection graph plugin, version 2. Tells new systems about existing and new connections
o * ConsoleServer.h | Contains ConsoleServer , used to plugin to your game to accept remote console-based connections
o * DataCompressor.h | DataCompressor does compression on a block of data
o * DirectoryDeltaTransfer.h | Simple class to send changes between directories
o * DS_BinarySearchTree.h |
o * DS_BPlusTree.h |
o * DS_BytePool.h |
o * DS_ByteQueue.h |
o * DS_Heap.h |
o * DS_HuffmanEncodingTree.h | [Internal] Generates a huffman encoding tree, used for string and global compression
o * DS_HuffmanEncodingTreeFactory.h |
o * DS_HuffmanEncodingTreeNode.h | [Internal] A single node in the Huffman Encoding Tree
o * DS_LinkedList.h |
o * DS_List.h |
o * DS_Map.h |
o * DS_MemoryPool.h |
o * DS_Multilist.h |
o * DS_OrderedChannelHeap.h |
o * DS_OrderedList.h |
o * DS_Queue.h |
o * DS_QueueLinkedList.h |
o * DS_RangeList.h |
o * DS_Table.h |
o * DS_ThreadsafeAllocatingQueue.h |
o * DS_Tree.h |
o * DS_WeightedGraph.h |
o * DynDNS.h | Helper to class to update DynDNS This can be used to determine what permissions are should be allowed to the other system
o * EmailSender.h | Rudimentary class to send email from code. Don't expect anything fancy
o * EpochTimeToString.h |
o * FileList.h |
o * FileListNodeContext.h |
o * FileListTransfer.h | A plugin to provide a simple way to compress and incrementally send the files in the FileList structure
o * FileListTransferCBInterface.h |
o * FileOperations.h |
o * FormatString.h |
o * FullyConnectedMesh2.h | Fully connected mesh plugin, revision 2
o * GetTime.h | Returns the value from QueryPerformanceCounter. This is the function RakNet uses to represent time. This time won't match the time returned by GetTimeCount(). See http://www.jenkinssoftware.com/forum/index.php?topic=2798.0
o * HTTPConnection.h | Contains HTTPConnection, used to communicate with web servers
o * HTTPConnection2.h | Contains HTTPConnection2, used to communicate with web servers
o * InternalPacket.h | [Internal] A class which stores a user message, and all information associated with sending and receiving that message
o * LogCommandParser.h | Contains LogCommandParser , Used to send logs to connected consoles
o * MessageFilter.h | Message filter plugin. Assigns systems to FilterSets. Each FilterSet limits what messages are allowed. This is a security related plugin
o * MessageIdentifiers.h | All the message identifiers used by RakNet. Message identifiers comprise the first byte of any message
o * MTUSize.h | [Internal] Defines the default maximum transfer unit
o * NatPunchthroughClient.h | Contains the NAT-punchthrough plugin for the client
o * NatPunchthroughServer.h | Contains the NAT-punchthrough plugin for the server
o * NatTypeDetectionClient.h | Contains the NAT-type detection code for the client
o * NatTypeDetectionServer.h | Contains the NAT-type detection code for the server
o * NetworkIDManager.h |
o * NetworkIDObject.h | A class you can derive from to make it easier to represent every networked object with an integer. This way you can refer to objects over the network
o * PacketConsoleLogger.h | This will write all incoming and outgoing network messages to the log command parser, which can be accessed through Telnet
o * PacketFileLogger.h | This will write all incoming and outgoing network messages to a file
o * PacketizedTCP.h | A simple TCP based server allowing sends and receives. Can be connected by any TCP client, including telnet
o * PacketLogger.h | This will write all incoming and outgoing network messages to the local console screen. See derived functions for other outputs
o * PacketOutputWindowLogger.h | This will write all incoming and outgoing network messages to a file
o * PacketPriority.h | This file contains enumerations for packet priority and reliability enumerations
o * PluginInterface2.h | RakNet's plugin functionality system, version 2. You can derive from this to create your own plugins
o * Rackspace.h | Helper to class to manage Rackspace servers
o * RakMemoryOverride.h | If _USE_RAK_MEMORY_OVERRIDE is defined, memory allocations go through rakMalloc, rakRealloc, and rakFree
o * RakNetCommandParser.h | Contains RakNetCommandParser , used to send commands to an instance of RakPeer
o * RakNetStatistics.h | A structure that holds all statistical data returned by RakNet
o * RakNetTransport2.h | Contains RakNetTransportCommandParser and RakNetTransport used to provide a secure console connection
o * RakNetTypes.h | Types used by RakNet, most of which involve user code
o * RakPeer.h | Declares RakPeer class
o * RakPeerInterface.h | An interface for RakPeer. Simply contains all user functions as pure virtuals
o * Rand.h | [Internal] Random number generator
o * RandSync.h | [Internal] Random number generator
o * ReadyEvent.h | Ready event plugin. This enables a set of systems to create a signal event, set this signal as ready or unready, and to trigger the event when all systems are ready
o * RefCountedObj.h | Reference counted object. Very simple class for quick and dirty uses
o * RelayPlugin.h | Contains the class RelayPlugin
o * ReliabilityLayer.h | [Internal] Datagram reliable, ordered, unordered and sequenced sends. Flow control. Message splitting, reassembly, and coalescence
o * ReplicaEnums.h | Contains enumerations used by the ReplicaManager system. This file is a lightweight header, so you can include it without worrying about linking in lots of other crap
o * ReplicaManager3.h | Contains the third iteration of the ReplicaManager class
o * Router2.h | Router2 plugin. Allows you to connect to a system by routing packets through another system that is connected to both you and the destination. Useful for getting around NATs
o * RPC4Plugin.h | Remote procedure call, supporting C functions only. No external dependencies required
o * SecureHandshake.h |
o * SimpleMutex.h | [Internal] Encapsulates a mutex
o * SingleProducerConsumer.h | [Internal] Passes queued data between threads using a circular buffer with read and write pointers
o * SocketLayer.h | SocketLayer class implementation
o * StatisticsHistory.h | Input numerical values over time. Get sum, average, highest, lowest, standard deviation on recent or all-time values This file is part of RakNet Copyright 2003 Jenkins Software LLC
o * StringCompressor.h | Compresses/Decompresses ASCII strings and writes/reads them to BitStream class instances. You can use this to easily serialize and deserialize your own strings
o * StringTable.h | A simple class to encode and decode known strings based on a lookup table. Similar to the StringCompressor class
o * TCPInterface.h | A simple TCP based server allowing sends and receives. Can be connected by any TCP client, including telnet
o * TeamBalancer.h | Set and network team selection (supports peer to peer or client/server)
o * TeamManager.h | Automates networking and list management for teams
o * TelnetTransport.h | Contains TelnetTransport , used to supports the telnet transport protocol. Insecure
o * ThreadsafePacketLogger.h | Derivation of the packet logger to defer the call to WriteLog until the user thread
o * TransportInterface.h | Contains TransportInterface from which you can derive custom transport providers for ConsoleServer
o * TwoWayAuthentication.h | Implements two way authentication
o * UDPForwarder.h | Forwards UDP datagrams. Independent of RakNet's protocol
o * UDPProxyClient.h | A RakNet plugin performing networking to communicate with UDPProxyCoordinator. Ultimately used to tell UDPProxyServer to forward UDP packets
o * UDPProxyCoordinator.h | Essentially maintains a list of servers running UDPProxyServer, and some state management for UDPProxyClient to find a free server to forward datagrams
\ * UDPProxyServer.h | A RakNet plugin performing networking to communicate with UDPProxyServer. It allows UDPProxyServer to control our instance of UDPForwarder
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: D: Directory Reference

  • D:
D: Directory Reference

Directories

directory temp
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: D:/temp Directory Reference

  • D:
  • temp
temp Directory Reference

Directories

directory RakNet_PC
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC Directory Reference

  • D:
  • temp
  • RakNet_PC
RakNet_PC Directory Reference

Directories

directory | DependentExtensions
directory | Source
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/DependentExtensions Directory Reference

  • D:
  • temp
  • RakNet_PC
  • DependentExtensions
DependentExtensions Directory Reference

Directories

directory | Autopatcher
directory | Lobby2
directory | MySQLInterface
directory | PostgreSQLInterface
directory | RPC3
directory | SQLite3Plugin

Files

file RakVoice.h
Voice compression and transmission interface.
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/DependentExtensions/Autopatcher Directory Reference

  • D:
  • temp
  • RakNet_PC
  • DependentExtensions
  • Autopatcher
Autopatcher Directory Reference

Directories

directory | AutopatcherMySQLRepository
directory | AutopatcherPostgreRepository

Files

file | ApplyPatch.h
file | AutopatcherClient.h
Client plugin for the autopatcher.
file | AutopatcherServer.h
The server plugin for the autopatcher. Must be running for the client to get patches.
file | CreatePatch.h
file | MemoryCompressor.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/DependentExtensions/Autopatcher/AutopatcherMySQLRepository Directory Reference

  • D:
  • temp
  • RakNet_PC
  • DependentExtensions
  • Autopatcher
  • AutopatcherMySQLRepository
AutopatcherMySQLRepository Directory Reference

Files

file AutopatcherMySQLRepository.h
An implementation of the AutopatcherRepositoryInterface to use MySQL to store the relevant data.
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/DependentExtensions/Autopatcher/AutopatcherMySQLRepository/AutopatcherMySQLRepository.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • DependentExtensions
  • Autopatcher
  • AutopatcherMySQLRepository
Classes | Namespaces
AutopatcherMySQLRepository.h File Reference

An implementation of the AutopatcherRepositoryInterface to use MySQL to store the relevant data. More...

#include "AutopatcherRepositoryInterface.h"
#include "MySQLInterface.h"
#include "Export.h"

Classes

class RakNet::AutopatcherMySQLRepository

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

An implementation of the AutopatcherRepositoryInterface to use MySQL to store the relevant data.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/DependentExtensions/Autopatcher/AutopatcherPostgreRepository Directory Reference

  • D:
  • temp
  • RakNet_PC
  • DependentExtensions
  • Autopatcher
  • AutopatcherPostgreRepository
AutopatcherPostgreRepository Directory Reference

Files

file AutopatcherPostgreRepository.h
An implementation of the AutopatcherRepositoryInterface to use PostgreSQL to store the relevant data.
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/DependentExtensions/Autopatcher/AutopatcherPostgreRepository/AutopatcherPostgreRepository.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • DependentExtensions
  • Autopatcher
  • AutopatcherPostgreRepository
Classes | Namespaces
AutopatcherPostgreRepository.h File Reference

An implementation of the AutopatcherRepositoryInterface to use PostgreSQL to store the relevant data. More...

#include "AutopatcherRepositoryInterface.h"
#include "PostgreSQLInterface.h"
#include "Export.h"

Classes

class RakNet::AutopatcherPostgreRepository

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

An implementation of the AutopatcherRepositoryInterface to use PostgreSQL to store the relevant data.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/DependentExtensions/Autopatcher/AutopatcherClient.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • DependentExtensions
  • Autopatcher
Namespaces
AutopatcherClient.h File Reference

Client plugin for the autopatcher. More...

#include "RakNetTypes.h"
#include "Export.h"
#include "PluginInterface2.h"
#include "PacketPriority.h"
#include "FileList.h"
#include "SimpleMutex.h"
#include "FileListTransferCBInterface.h"
#include "AutopatcherPatchContext.h"

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Client plugin for the autopatcher.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/DependentExtensions/Autopatcher/AutopatcherServer.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • DependentExtensions
  • Autopatcher
Classes | Namespaces
AutopatcherServer.h File Reference

The server plugin for the autopatcher. Must be running for the client to get patches. More...

#include "RakNetTypes.h"
#include "Export.h"
#include "PluginInterface2.h"
#include "PacketPriority.h"
#include "ThreadPool.h"
#include "BitStream.h"
#include "RakString.h"
#include "FileList.h"
#include "IncrementalReadInterface.h"

Classes

struct | RakNet::AutopatcherServerLoadNotifier::AutopatcherState
Current queue state of the autopatcher. More...
class | RakNet::AutopatcherServerLoadNotifier_Printf
Sample implementation of AutopatcherServerLoadNotifier using printf. More...
class | RakNet::AutopatcherServer
The server plugin for the autopatcher. Must be running for the client to get patches. More...
struct | RakNet::AutopatcherServer::ResultTypeAndBitstream

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

The server plugin for the autopatcher. Must be running for the client to get patches.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/DependentExtensions/Lobby2 Directory Reference

  • D:
  • temp
  • RakNet_PC
  • DependentExtensions
  • Lobby2
Lobby2 Directory Reference

Directories

directory | PGSQL
directory | Rooms
directory | Steam

Files

file | Lobby2Client.h
file | Lobby2Message.h
file | Lobby2Plugin.h
file | Lobby2Presence.h
file | Lobby2ResultCode.h
file | Lobby2Server.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms Directory Reference

  • D:
  • temp
  • RakNet_PC
  • DependentExtensions
  • Lobby2
  • Rooms
Rooms Directory Reference

Files

file | IntervalTimer.h
file | ProfanityFilter.h
file | RoomsContainer.h
file | RoomsErrorCodes.h
file | RoomsPlugin.h
Adds networking to AllGamesRoomsContainer. Lets you create, join, search, and destroy matchmaking rooms for players.
file | RoomTypes.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/DependentExtensions/Lobby2/Rooms/RoomsPlugin.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • DependentExtensions
  • Lobby2
  • Rooms
Classes | Namespaces
RoomsPlugin.h File Reference

Adds networking to AllGamesRoomsContainer. Lets you create, join, search, and destroy matchmaking rooms for players. More...

#include "RakNetTypes.h"
#include "PluginInterface2.h"
#include "DS_OrderedList.h"
#include "Export.h"
#include "RoomsContainer.h"
#include "PacketPriority.h"
#include "BitStream.h"

Classes

struct | RakNet::RoomsPluginFunc
Base class for rooms functionality. More...
struct | RakNet::CreateRoom_Func
Create a room. Each user can be in at most one room, so will fail if the user is already in a room. More...
struct | RakNet::EnterRoom_Func
Joins a room if possible. If not, creates a room. More...
struct | RakNet::JoinByFilter_Func
Joins a room given the filter parameters and desired room member mode. More...
struct | RakNet::LeaveRoom_Func
Leaves a room. You can leave at any time, even if the room is locked. More...
struct | RakNet::GetInvitesToParticipant_Func
struct | RakNet::SendInvite_Func
Sends an invitation to someone. More...
struct | RakNet::AcceptInvite_Func
Accept an invitation from a user to a room. More...
struct | RakNet::StartSpectating_Func
Begin spectating. Spectators are considered room members that are not playing the game, only watching. More...
struct | RakNet::StopSpectating_Func
Stop spectating. This will rejoin the room as a player, using a reserved slot if we were invited, and a public slot if not or if there are no reserved slots. More...
struct | RakNet::GrantModerator_Func
Give moderator to another player. Moderators cannot be spectators. More...
struct | RakNet::ChangeSlotCounts_Func
Change the allowed slot counts for the room. Setting fewer slot counts than the number of players does not kick out players, though it may prevent changing spectator status. More...
struct | RakNet::SetCustomRoomProperties_Func
Sets a table of user-defined room properties. More...
struct | RakNet::GetRoomProperties_Func
Given a named room, return the properties of that room, including member list. More...
struct | RakNet::ChangeRoomName_Func
Change the name of the room. More...
struct | RakNet::SetHiddenFromSearches_Func
Set or unset the room hidden from searches. If a room is hidden from searches, it can only be joined through invitations. More...
struct | RakNet::SetDestroyOnModeratorLeave_Func
Sets or unsets to destroy the room when the moderator leaves the room. More...
struct | RakNet::SetReadyStatus_Func
Sets or unsets the user as flagged 'ready'. More...
struct | RakNet::GetReadyStatus_Func
Gets the ready states for every user in the room, excluding spectators. More...
struct | RakNet::SetRoomLockState_Func
Lock or unlock the room. More...
struct | RakNet::GetRoomLockState_Func
Gets the lock state of the room. More...
struct | RakNet::AreAllMembersReady_Func
If all members have been set to ready using SetReadyStatus_Func, this operation will set allReady to true. More...
struct | RakNet::KickMember_Func
Kick a member out of the room. This will also automatically ban that member from rejoining as long as the moderator does not change, or the member is unbanned. More...
struct | RakNet::UnbanMember_Func
Allow a member previously kicked out of the room to rejoin. More...
struct | RakNet::GetBanReason_Func
For a given room, get the reason parameter of KickMember_Func when we were kicked out. More...
struct | RakNet::AddUserToQuickJoin_Func
Enter quick join mode. More...
struct | RakNet::RemoveUserFromQuickJoin_Func
Leave quick join mode. More...
struct | RakNet::IsInQuickJoin_Func
Returns if you are waiting in quick join mode. More...
struct | RakNet::SearchByFilter_Func
Return all rooms that pass the roomQuery filter. More...
struct | RakNet::ChangeHandle_Func
Change your handle. More...
struct | RakNet::Chat_Func
Send a chat message. More...
struct | RakNet::Bitstream_Func
Send an arbitrary binary message. More...
struct | RakNet::RoomsPluginNotification
Base class for notification callbacks. More...
struct | RakNet::QuickJoinExpired_Notification
The quick join duration has expired without joining or creating any rooms. More...
struct | RakNet::QuickJoinEnteredRoom_Notification
Quick join succeeded, and you are now in a room. More...
struct | RakNet::RoomMemberStartedSpectating_Notification
Another room member has started spectating. More...
struct | RakNet::RoomMemberStoppedSpectating_Notification
Another room member has stopped spectating. More...
struct | RakNet::ModeratorChanged_Notification
The room has a new moderator (possibly you) More...
struct | RakNet::SlotCountsSet_Notification
The slot counts in the room has changed. More...
struct | RakNet::CustomRoomPropertiesSet_Notification
The custom properties for the room has changed. More...
struct | RakNet::RoomNameSet_Notification
The name of the room has been changed. More...
struct | RakNet::HiddenFromSearchesSet_Notification
The room is now hidden, or no longer hidden, from searches. More...
struct | RakNet::RoomMemberReadyStatusSet_Notification
Another room member has changed their ready status. More...
struct | RakNet::RoomLockStateSet_Notification
The room is now, or is no longer, locked. More...
struct | RakNet::RoomMemberKicked_Notification
A room member has been kicked out of the room (possibly you) More...
struct | RakNet::RoomMemberHandleSet_Notification
A room member has changed their handle. More...
struct | RakNet::RoomMemberLeftRoom_Notification
struct | RakNet::RoomMemberJoinedRoom_Notification
A room member has joined the room. More...
struct | RakNet::RoomInvitationSent_Notification
You have received an invitation to a room. More...
struct | RakNet::RoomInvitationWithdrawn_Notification
A previous room invitation is no longer valid (possibly due to moderator change, or the room no longer exists) More...
struct | RakNet::RoomDestroyedOnModeratorLeft_Notification
The moderator has left the room, and everyone left is a spectator, or the room was set to be destroyed when the moderator leftYou are no longer in the room. More...
struct | RakNet::Chat_Notification
You got a chat message from another user. More...
struct | RakNet::Bitstream_Notification
You got a generic bitstream message from another user. More...
class | RakNet::RoomsPlugin
Used to create rooms for players where they can matchmake. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Adds networking to AllGamesRoomsContainer. Lets you create, join, search, and destroy matchmaking rooms for players.

See Also
TeamManager TeamManager performs some of the same functions as RoomsPlugin in a more flexible way

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/DependentExtensions/RPC3 Directory Reference

  • D:
  • temp
  • RakNet_PC
  • DependentExtensions
  • RPC3
RPC3 Directory Reference

Files

file | RPC3.h
Automatically serializing and deserializing RPC system. Third generation of RPC.
file | RPC3_Boost.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/DependentExtensions/RPC3/RPC3.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • DependentExtensions
  • RPC3
Classes | Namespaces | Enumerations
RPC3.h File Reference

Automatically serializing and deserializing RPC system. Third generation of RPC. More...

#include "RPC3_Boost.h"
#include "PluginInterface2.h"
#include "PacketPriority.h"
#include "RakNetTypes.h"
#include "BitStream.h"
#include "RakString.h"
#include "NetworkIDObject.h"
#include "DS_Hash.h"
#include "DS_OrderedList.h"

Classes

class RakNet::RPC3
The RPC3 plugin allows you to call remote functions as if they were local functions, using the standard function call syntax. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Enumerations

enum RakNet::RPCErrorCodes {
RakNet::RPC_ERROR_FUNCTION_NOT_REGISTERED, RakNet::RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RakNet::RPC_ERROR_OBJECT_DOES_NOT_EXIST, RakNet::RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE,
RakNet::RPC_ERROR_FUNCTION_NOT_REGISTERED, RakNet::RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RakNet::RPC_ERROR_CALLING_CPP_AS_C, RakNet::RPC_ERROR_CALLING_C_AS_CPP
}
Error codes returned by a remote system as to why an RPC function call cannot execute. More...

Detailed Description

Automatically serializing and deserializing RPC system. Third generation of RPC.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/DependentExtensions/SQLite3Plugin Directory Reference

  • D:
  • temp
  • RakNet_PC
  • DependentExtensions
  • SQLite3Plugin
SQLite3Plugin Directory Reference

Files

file | sqlite3.c
file | sqlite3.h
file | SQLite3ClientPlugin.h
Contains code to call sqlite3_exec over a network that does not support shared file handles.
file | sqlite3ext.h
file | SQLite3PluginCommon.h
file | SQLite3ServerPlugin.h
Contains code to call sqlite3_exec over a network that does not support shared file handles.
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/DependentExtensions/SQLite3Plugin/SQLite3ClientPlugin.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • DependentExtensions
  • SQLite3Plugin
Classes | Namespaces
SQLite3ClientPlugin.h File Reference

Contains code to call sqlite3_exec over a network that does not support shared file handles. More...

#include "RakNetTypes.h"
#include "Export.h"
#include "PluginInterface2.h"
#include "PacketPriority.h"
#include "SocketIncludes.h"
#include "DS_Multilist.h"
#include "RakString.h"
#include "SQLite3PluginCommon.h"

Classes

class | RakNet::SQLite3PluginResultInterface
Handles results of calls to SQLite3Plugin::_sqlite3_exec() Results from calling SQLite3Plugin::_sqlite3_exec() are handled in this callback. You should implement the callback, and let the plugin know about it via SQLite3Plugin::AddResultHandler() Be sure to call SQLite3Plugin::RemoveResultHandler() or SQLite3Plugin::ClearResultHandlers() if you delete the callback. More...
class | RakNet::SQLite3PluginResultInterface_Printf
class | RakNet::SQLite3ClientPlugin

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Contains code to call sqlite3_exec over a network that does not support shared file handles.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/DependentExtensions/SQLite3Plugin/SQLite3ServerPlugin.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • DependentExtensions
  • SQLite3Plugin
Classes | Namespaces | Macros
SQLite3ServerPlugin.h File Reference

Contains code to call sqlite3_exec over a network that does not support shared file handles. More...

#include "RakNetTypes.h"
#include "Export.h"
#include "PluginInterface2.h"
#include "PacketPriority.h"
#include "SocketIncludes.h"
#include "DS_Multilist.h"
#include "RakString.h"
#include "sqlite3.h"
#include "SQLite3PluginCommon.h"
#include "ThreadPool.h"

Classes

class RakNet::SQLite3ServerPlugin
Exec SQLLite commands over the network. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Macros

#define SQLite3_STATEMENT_EXECUTE_THREADED
Control if SQLite3 statements execute in a thread.

Detailed Description

Contains code to call sqlite3_exec over a network that does not support shared file handles.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/DependentExtensions/RakVoice.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • DependentExtensions
Classes | Namespaces
RakVoice.h File Reference

Voice compression and transmission interface. More...

#include "RakNetTypes.h"
#include "PluginInterface2.h"
#include "DS_OrderedList.h"
#include "NativeTypes.h"

Classes

class RakNet::RakVoice
Voice compression and transmission interface. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Voice compression and transmission interface.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source Directory Reference

  • D:
  • temp
  • RakNet_PC
  • Source
Source Directory Reference

Files

file | _FindFirst.h
file | AutopatcherPatchContext.h
file | AutopatcherRepositoryInterface.h
An interface used by AutopatcherServer to get the data necessary to run an autopatcher.
file | Base64Encoder.h
file | BitStream.h
This class allows you to write and read native types as a string of bits.
file | CCRakNetSlidingWindow.h
file | CCRakNetUDT.h
file | CheckSum.h
file | CloudClient.h
Queries CloudMemoryServer to download data that other clients have uploaded.
file | CloudCommon.h
file | CloudServer.h
Stores client data, and allows cross-server communication to retrieve this data.
file | CommandParserInterface.h
Contains CommandParserInterface , from which you derive custom command parsers.
file | ConnectionGraph2.h
Connection graph plugin, version 2. Tells new systems about existing and new connections.
file | ConsoleServer.h
Contains ConsoleServer , used to plugin to your game to accept remote console-based connections.
file | DataCompressor.h
DataCompressor does compression on a block of data.
file | DirectoryDeltaTransfer.h
Simple class to send changes between directories.
file | DR_SHA1.h
file | DS_BinarySearchTree.h
file | DS_BPlusTree.h
file | DS_BytePool.h
file | DS_ByteQueue.h
file | DS_Hash.h
file | DS_Heap.h
file | DS_HuffmanEncodingTree.h
[Internal] Generates a huffman encoding tree, used for string and global compression.
file | DS_HuffmanEncodingTreeFactory.h
file | DS_HuffmanEncodingTreeNode.h
[Internal] A single node in the Huffman Encoding Tree.
file | DS_LinkedList.h
file | DS_List.h
file | DS_Map.h
file | DS_MemoryPool.h
file | DS_Multilist.h
file | DS_OrderedChannelHeap.h
file | DS_OrderedList.h
file | DS_Queue.h
file | DS_QueueLinkedList.h
file | DS_RangeList.h
file | DS_Table.h
file | DS_ThreadsafeAllocatingQueue.h
file | DS_Tree.h
file | DS_WeightedGraph.h
file | DynDNS.h
Helper to class to update DynDNS This can be used to determine what permissions are should be allowed to the other system.
file | EmailSender.h
Rudimentary class to send email from code. Don't expect anything fancy.
file | EmptyHeader.h
file | EpochTimeToString.h
file | Export.h
file | FileList.h
file | FileListNodeContext.h
file | FileListTransfer.h
A plugin to provide a simple way to compress and incrementally send the files in the FileList structure.
file | FileListTransferCBInterface.h
file | FileOperations.h
file | FormatString.h
file | FullyConnectedMesh2.h
Fully connected mesh plugin, revision 2.
file | Getche.h
file | Gets.h
file | GetTime.h
Returns the value from QueryPerformanceCounter. This is the function RakNet uses to represent time. This time won't match the time returned by GetTimeCount(). See http://www.jenkinssoftware.com/forum/index.php?topic=2798.0.
file | gettimeofday.h
file | GridSectorizer.h
file | HTTPConnection.h
Contains HTTPConnection, used to communicate with web servers.
file | HTTPConnection2.h
Contains HTTPConnection2, used to communicate with web servers.
file | IncrementalReadInterface.h
file | InternalPacket.h
[Internal] A class which stores a user message, and all information associated with sending and receiving that message.
file | Itoa.h
file | Kbhit.h
file | LinuxStrings.h
file | LocklessTypes.h
file | LogCommandParser.h
Contains LogCommandParser , Used to send logs to connected consoles.
file | MessageFilter.h
Message filter plugin. Assigns systems to FilterSets. Each FilterSet limits what messages are allowed. This is a security related plugin.
file | MessageIdentifiers.h
All the message identifiers used by RakNet. Message identifiers comprise the first byte of any message.
file | MTUSize.h
[Internal] Defines the default maximum transfer unit.
file | NativeFeatureIncludes.h
file | NativeFeatureIncludesOverrides.h
file | NativeTypes.h
file | NatPunchthroughClient.h
Contains the NAT-punchthrough plugin for the client.
file | NatPunchthroughServer.h
Contains the NAT-punchthrough plugin for the server.
file | NatTypeDetectionClient.h
Contains the NAT-type detection code for the client.
file | NatTypeDetectionCommon.h
file | NatTypeDetectionServer.h
Contains the NAT-type detection code for the server.
file | NetworkIDManager.h
file | NetworkIDObject.h
A class you can derive from to make it easier to represent every networked object with an integer. This way you can refer to objects over the network.
file | PacketConsoleLogger.h
This will write all incoming and outgoing network messages to the log command parser, which can be accessed through Telnet.
file | PacketFileLogger.h
This will write all incoming and outgoing network messages to a file.
file | PacketizedTCP.h
A simple TCP based server allowing sends and receives. Can be connected by any TCP client, including telnet.
file | PacketLogger.h
This will write all incoming and outgoing network messages to the local console screen. See derived functions for other outputs.
file | PacketOutputWindowLogger.h
This will write all incoming and outgoing network messages to a file.
file | PacketPool.h
file | PacketPriority.h
This file contains enumerations for packet priority and reliability enumerations.
file | PluginInterface2.h
RakNet's plugin functionality system, version 2. You can derive from this to create your own plugins.
file | PS3Includes.h
file | PS4Includes.h
file | Rackspace.h
Helper to class to manage Rackspace servers.
file | RakAlloca.h
file | RakAssert.h
file | RakMemoryOverride.h
If _USE_RAK_MEMORY_OVERRIDE is defined, memory allocations go through rakMalloc, rakRealloc, and rakFree.
file | RakNetCommandParser.h
Contains RakNetCommandParser , used to send commands to an instance of RakPeer.
file | RakNetDefines.h
file | RakNetDefinesOverrides.h
file | RakNetSmartPtr.h
file | RakNetSocket.h
file | RakNetSocket2.h
file | RakNetStatistics.h
A structure that holds all statistical data returned by RakNet.
file | RakNetTime.h
file | RakNetTransport2.h
Contains RakNetTransportCommandParser and RakNetTransport used to provide a secure console connection.
file | RakNetTypes.h
Types used by RakNet, most of which involve user code.
file | RakNetVersion.h
file | RakPeer.h
Declares RakPeer class.
file | RakPeerInterface.h
An interface for RakPeer. Simply contains all user functions as pure virtuals.
file | RakSleep.h
file | RakString.h
file | RakThread.h
file | RakWString.h
file | Rand.h
[Internal] Random number generator
file | RandSync.h
[Internal] Random number generator
file | ReadyEvent.h
Ready event plugin. This enables a set of systems to create a signal event, set this signal as ready or unready, and to trigger the event when all systems are ready.
file | RefCountedObj.h
Reference counted object. Very simple class for quick and dirty uses.
file | RelayPlugin.h
Contains the class RelayPlugin.
file | ReliabilityLayer.h
[Internal] Datagram reliable, ordered, unordered and sequenced sends. Flow control. Message splitting, reassembly, and coalescence.
file | ReplicaEnums.h
Contains enumerations used by the ReplicaManager system. This file is a lightweight header, so you can include it without worrying about linking in lots of other crap.
file | ReplicaManager3.h
Contains the third iteration of the ReplicaManager class.
file | Router2.h
Router2 plugin. Allows you to connect to a system by routing packets through another system that is connected to both you and the destination. Useful for getting around NATs.
file | RPC4Plugin.h
Remote procedure call, supporting C functions only. No external dependencies required.
file | SecureHandshake.h
file | SendToThread.h
file | SignaledEvent.h
file | SimpleMutex.h
[Internal] Encapsulates a mutex
file | SimpleTCPServer.h
file | SingleProducerConsumer.h
[Internal] Passes queued data between threads using a circular buffer with read and write pointers
file | SocketDefines.h
file | SocketIncludes.h
file | SocketLayer.h
SocketLayer class implementation.
file | StatisticsHistory.h
Input numerical values over time. Get sum, average, highest, lowest, standard deviation on recent or all-time values This file is part of RakNet Copyright 2003 Jenkins Software LLC.
file | StringCompressor.h
Compresses/Decompresses ASCII strings and writes/reads them to BitStream class instances. You can use this to easily serialize and deserialize your own strings.
file | StringTable.h
A simple class to encode and decode known strings based on a lookup table. Similar to the StringCompressor class.
file | SuperFastHash.h
file | TableSerializer.h
file | TCPInterface.h
A simple TCP based server allowing sends and receives. Can be connected by any TCP client, including telnet.
file | TeamBalancer.h
Set and network team selection (supports peer to peer or client/server)
file | TeamManager.h
Automates networking and list management for teams.
file | TelnetTransport.h
Contains TelnetTransport , used to supports the telnet transport protocol. Insecure.
file | ThreadPool.h
file | ThreadsafePacketLogger.h
Derivation of the packet logger to defer the call to WriteLog until the user thread.
file | TransportInterface.h
Contains TransportInterface from which you can derive custom transport providers for ConsoleServer.
file | TwoWayAuthentication.h
Implements two way authentication.
file | UDPForwarder.h
Forwards UDP datagrams. Independent of RakNet's protocol.
file | UDPProxyClient.h
A RakNet plugin performing networking to communicate with UDPProxyCoordinator. Ultimately used to tell UDPProxyServer to forward UDP packets.
file | UDPProxyCommon.h
file | UDPProxyCoordinator.h
Essentially maintains a list of servers running UDPProxyServer, and some state management for UDPProxyClient to find a free server to forward datagrams.
file | UDPProxyServer.h
A RakNet plugin performing networking to communicate with UDPProxyServer. It allows UDPProxyServer to control our instance of UDPForwarder.
file | VariableDeltaSerializer.h
file | VariableListDeltaTracker.h
file | VariadicSQLParser.h
file | VitaIncludes.h
file | WindowsIncludes.h
file | WSAStartupSingleton.h
file | XBox360Includes.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/AutopatcherRepositoryInterface.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
AutopatcherRepositoryInterface.h File Reference

An interface used by AutopatcherServer to get the data necessary to run an autopatcher. More...

#include "IncrementalReadInterface.h"
#include "SimpleMutex.h"

Classes

class RakNet::AutopatcherRepositoryInterface
An interface used by AutopatcherServer to get the data necessary to run an autopatcher. This is up to you to implement for custom repository solutions. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

An interface used by AutopatcherServer to get the data necessary to run an autopatcher.

This file is part of RakNet Copyright 2003 Jenkins Software LLC Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/BitStream.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
BitStream.h File Reference

This class allows you to write and read native types as a string of bits. More...

#include "RakMemoryOverride.h"
#include "RakNetDefines.h"
#include "Export.h"
#include "RakNetTypes.h"
#include "RakString.h"
#include "RakWString.h"
#include "RakAssert.h"
#include <math.h>
#include <float.h>

Classes

class RakNet::BitStream

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

This class allows you to write and read native types as a string of bits.

BitStream is used extensively throughout RakNet and is designed to be used by users as well.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/CloudClient.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
CloudClient.h File Reference

Queries CloudMemoryServer to download data that other clients have uploaded. More...

#include "NativeFeatureIncludes.h"
#include "PluginInterface2.h"
#include "CloudCommon.h"
#include "RakMemoryOverride.h"
#include "DS_Hash.h"

Classes

class | RakNet::CloudClient
Performs Post() and Get() operations on CloudMemoryServer. More...
class | RakNet::CloudClientCallback

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Queries CloudMemoryServer to download data that other clients have uploaded.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/CloudServer.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces | Macros
CloudServer.h File Reference

Stores client data, and allows cross-server communication to retrieve this data. More...

#include "NativeFeatureIncludes.h"
#include "PluginInterface2.h"
#include "RakMemoryOverride.h"
#include "NativeTypes.h"
#include "RakString.h"
#include "DS_Hash.h"
#include "CloudCommon.h"
#include "DS_OrderedList.h"

Classes

class | RakNet::CloudServerQueryFilter
Zero or more instances of CloudServerQueryFilter can be attached to CloudServer to restrict client queries All attached instances of CloudServerQueryFilter on each corresponding operation, from all directly connected clients If any attached instance returns false for a given operation, that operation is silently rejected. More...
class | RakNet::CloudServer
Stores client data, and allows cross-server communication to retrieve this data. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Macros

#define CLOUD_SERVER_DATA_STACK_SIZE 32
If the data is smaller than this value, an allocation is avoid. However, this value exists for every row.

Detailed Description

Stores client data, and allows cross-server communication to retrieve this data.

TODO

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/CommandParserInterface.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces | Functions
CommandParserInterface.h File Reference

Contains CommandParserInterface , from which you derive custom command parsers. More...

#include "RakMemoryOverride.h"
#include "RakNetTypes.h"
#include "DS_OrderedList.h"
#include "Export.h"

Classes

class RakNet::CommandParserInterface
The interface used by command parsers. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Functions

int RAK_DLL_EXPORT RakNet::RegisteredCommandComp (const char *const &key, const RegisteredCommand &data)
List of commands registered with RegisterCommand()

Detailed Description

Contains CommandParserInterface , from which you derive custom command parsers.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/ConnectionGraph2.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
ConnectionGraph2.h File Reference

Connection graph plugin, version 2. Tells new systems about existing and new connections. More...

#include "NativeFeatureIncludes.h"
#include "RakMemoryOverride.h"
#include "RakNetTypes.h"
#include "PluginInterface2.h"
#include "DS_List.h"
#include "DS_WeightedGraph.h"
#include "GetTime.h"
#include "Export.h"

Classes

class RakNet::ConnectionGraph2
A one hop connection graph. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Connection graph plugin, version 2. Tells new systems about existing and new connections.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/ConsoleServer.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
ConsoleServer.h File Reference

Contains ConsoleServer , used to plugin to your game to accept remote console-based connections. More...

#include "NativeFeatureIncludes.h"
#include "RakMemoryOverride.h"
#include "DS_List.h"
#include "RakNetTypes.h"
#include "Export.h"

Classes

class RakNet::ConsoleServer
The main entry point for the server portion of your remote console application support. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Contains ConsoleServer , used to plugin to your game to accept remote console-based connections.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DataCompressor.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
DataCompressor.h File Reference

DataCompressor does compression on a block of data. More...

#include "RakMemoryOverride.h"
#include "DS_HuffmanEncodingTree.h"
#include "Export.h"

Classes

class RakNet::DataCompressor
Does compression on a block of data. Not very good compression, but it's small and fast so is something you can compute at runtime. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

DataCompressor does compression on a block of data.

Not very good compression, but it's small and fast so is something you can use per-message at runtime.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DirectoryDeltaTransfer.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Namespaces
DirectoryDeltaTransfer.h File Reference

Simple class to send changes between directories. More...

#include "NativeFeatureIncludes.h"
#include "RakMemoryOverride.h"
#include "RakNetTypes.h"
#include "Export.h"
#include "PluginInterface2.h"
#include "DS_Map.h"
#include "PacketPriority.h"

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Simple class to send changes between directories.

In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DS_BinarySearchTree.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
DS_BinarySearchTree.h File Reference
#include "DS_QueueLinkedList.h"
#include "RakMemoryOverride.h"
#include "Export.h"

Classes

class | DataStructures::BinarySearchTree< BinarySearchTreeType >
A binary search tree and an AVL balanced binary search tree. More...
class | DataStructures::AVLBalancedBinarySearchTree< BinarySearchTreeType >
An AVLBalancedBinarySearchTree is a binary tree that is always balanced. More...

Namespaces

namespace DataStructures
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DS_BPlusTree.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
DS_BPlusTree.h File Reference
#include "DS_MemoryPool.h"
#include "DS_Queue.h"
#include <stdio.h>
#include "Export.h"
#include "RakMemoryOverride.h"

Classes

struct | DataStructures::Page< KeyType, DataType, order >
class | DataStructures::BPlusTree< KeyType, DataType, order >

Namespaces

namespace DataStructures

Detailed Description

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DS_BytePool.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Namespaces
DS_BytePool.h File Reference
#include "RakMemoryOverride.h"
#include "DS_MemoryPool.h"
#include "Export.h"
#include "SimpleMutex.h"
#include "RakAssert.h"

Namespaces

namespace DataStructures

Detailed Description

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DS_ByteQueue.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Namespaces
DS_ByteQueue.h File Reference
#include "RakMemoryOverride.h"
#include "Export.h"

Namespaces

namespace DataStructures
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DS_Heap.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Namespaces
DS_Heap.h File Reference
#include "RakMemoryOverride.h"
#include "DS_List.h"
#include "Export.h"
#include "RakAssert.h"

Namespaces

namespace DataStructures
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DS_HuffmanEncodingTree.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
DS_HuffmanEncodingTree.h File Reference

[Internal] Generates a huffman encoding tree, used for string and global compression. More...

#include "RakMemoryOverride.h"
#include "DS_HuffmanEncodingTreeNode.h"
#include "BitStream.h"
#include "Export.h"
#include "DS_LinkedList.h"

Classes

class RakNet::HuffmanEncodingTree
This generates special cases of the huffman encoding tree using 8 bit keys with the additional condition that unused combinations of 8 bits are treated as a frequency of 1. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

[Internal] Generates a huffman encoding tree, used for string and global compression.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DS_HuffmanEncodingTreeFactory.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
DS_HuffmanEncodingTreeFactory.h File Reference
#include "RakMemoryOverride.h"

Classes

class RakNet::HuffmanEncodingTreeFactory
Creates instances of the class HuffmanEncodingTree. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DS_HuffmanEncodingTreeNode.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
DS_HuffmanEncodingTreeNode.h File Reference

[Internal] A single node in the Huffman Encoding Tree. More...

Detailed Description

[Internal] A single node in the Huffman Encoding Tree.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DS_LinkedList.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
DS_LinkedList.h File Reference
#include "Export.h"
#include "RakMemoryOverride.h"

Classes

class DataStructures::CircularLinkedList< CircularLinkedListType >
(Circular) Linked List ADT (Doubly Linked Pointer to Node Style) - More...

Namespaces

namespace DataStructures
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DS_List.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
DS_List.h File Reference
#include "RakAssert.h"
#include <string.h>
#include "Export.h"
#include "RakMemoryOverride.h"

Classes

class DataStructures::List< list_type >
Array based implementation of a list. More...

Namespaces

namespace DataStructures
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DS_Map.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces | Functions
DS_Map.h File Reference
#include "DS_OrderedList.h"
#include "Export.h"
#include "RakMemoryOverride.h"
#include "RakAssert.h"

Classes

class DataStructures::Map< key_type, data_type, key_comparison_func >

Namespaces

namespace DataStructures

Functions

template<class key_type >
int DataStructures::defaultMapKeyComparison (const key_type &a, const key_type &b)
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DS_MemoryPool.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
DS_MemoryPool.h File Reference
#include <stdlib.h>
#include "RakAssert.h"
#include "Export.h"
#include "RakMemoryOverride.h"

Classes

class DataStructures::MemoryPool< MemoryBlockType >

Namespaces

namespace DataStructures

Detailed Description

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DS_Multilist.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces | Macros | Enumerations | Functions
DS_Multilist.h File Reference
#include "RakAssert.h"
#include <string.h>
#include "Export.h"
#include "RakMemoryOverride.h"
#include "NativeTypes.h"

Classes

class | DataStructures::MLKeyRef< templateType >
class | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >
The multilist, representing an abstract data type that generally holds lists. More...

Namespaces

namespace DataStructures

Macros

#define DEFINE_MULTILIST_PTR_TO_MEMBER_COMPARISONS(_CLASS_NAME_, _KEY_TYPE_, _MEMBER_VARIABLE_NAME_)

Enumerations

enum MultilistType {
ML_UNORDERED_LIST, ML_STACK, ML_QUEUE, ML_ORDERED_LIST,
ML_VARIABLE_DURING_RUNTIME
}
What algorithm to use to store the data for the Multilist. More...

Functions

template<class templateType >
void | DataStructures::DeletePtr_RakNet (templateType &ptr, const char *file, unsigned int line)
template<class templateType >
void | DataStructures::DeletePtr (templateType &ptr)

Macro Definition Documentation

#define DEFINE_MULTILIST_PTR_TO_MEMBER_COMPARISONS | ( | _CLASS_NAME_,
 |  | _KEY_TYPE_,
 |  | _MEMBER_VARIABLE_NAME_
 | ) |
Value:
bool operator<( const DataStructures::MLKeyRef<_KEY_TYPE_> &inputKey, const _CLASS_NAME_ *cls ) {return inputKey.Get() < cls->_MEMBER_VARIABLE_NAME_;} \
bool operator>( const DataStructures::MLKeyRef<_KEY_TYPE_> &inputKey, const _CLASS_NAME_ *cls ) {return inputKey.Get() > cls->_MEMBER_VARIABLE_NAME_;} \
bool operator==( const DataStructures::MLKeyRef<_KEY_TYPE_> &inputKey, const _CLASS_NAME_ *cls ) {return inputKey.Get() == cls->_MEMBER_VARIABLE_NAME_;}

For the Multilist, when _DataType != _KeyType, you must define the comparison operators between the key and the data This is non-trivial due to the need to use MLKeyRef in case the type held is a pointer to a structure or class and the key type is not a class For convenience, this macro will implement the comparison operators under the following conditions

  1. _DataType is a pointer to a class or structure
  2. The key is a member variable of _DataType

Enumeration Type Documentation

enum MultilistType

What algorithm to use to store the data for the Multilist.

Enumerator:
ML_UNORDERED_LIST

Removing from the middle of the list will swap the end of the list rather than shift the elements. Push and Pop operate on the tail.

ML_STACK

A normal list, with the list order preserved. Push and Pop operate on the tail.

ML_QUEUE

A queue. Push and Pop operate on the head.

ML_ORDERED_LIST

A list that is always kept in order. Elements must be unique, and compare against each other consistently using <, ==, and >

ML_VARIABLE_DURING_RUNTIME

A list whose type can change at runtime.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DS_OrderedChannelHeap.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Namespaces
DS_OrderedChannelHeap.h File Reference
#include "DS_Heap.h"
#include "DS_Map.h"
#include "DS_Queue.h"
#include "Export.h"
#include "RakAssert.h"
#include "Rand.h"

Namespaces

namespace DataStructures
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DS_OrderedList.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
DS_OrderedList.h File Reference
#include "DS_List.h"
#include "RakMemoryOverride.h"
#include "Export.h"

Classes

class DataStructures::OrderedList< key_type, data_type, default_comparison_function >

Namespaces

namespace DataStructures
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DS_Queue.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
DS_Queue.h File Reference
#include "RakAssert.h"
#include "Export.h"
#include "RakMemoryOverride.h"

Classes

class DataStructures::Queue< queue_type >
A queue implemented as an array with a read and write index. More...

Namespaces

namespace DataStructures
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DS_QueueLinkedList.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
DS_QueueLinkedList.h File Reference
#include "DS_LinkedList.h"
#include "Export.h"
#include "RakMemoryOverride.h"

Classes

class DataStructures::QueueLinkedList< QueueType >
A queue implemented using a linked list. Rarely used. More...

Namespaces

namespace DataStructures
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DS_RangeList.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Namespaces
DS_RangeList.h File Reference
#include "DS_OrderedList.h"
#include "BitStream.h"
#include "RakMemoryOverride.h"
#include "RakAssert.h"

Namespaces

namespace DataStructures
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DS_Table.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
DS_Table.h File Reference
#include "DS_List.h"
#include "DS_BPlusTree.h"
#include "RakMemoryOverride.h"
#include "Export.h"
#include "RakString.h"

Classes

class | DataStructures::Table
Holds a set of columns, a set of rows, and rows times columns cells. More...
struct | DataStructures::Table::Cell
Holds the actual data in the table. More...
struct | DataStructures::Table::ColumnDescriptor
struct | DataStructures::Table::Row
Stores the list of cells for this row, and a special flag used for internal sorting. More...

Namespaces

namespace DataStructures

Detailed Description

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DS_ThreadsafeAllocatingQueue.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Namespaces
DS_ThreadsafeAllocatingQueue.h File Reference
#include "DS_Queue.h"
#include "SimpleMutex.h"
#include "DS_MemoryPool.h"

Namespaces

namespace DataStructures
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DS_Tree.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Namespaces
DS_Tree.h File Reference
#include "Export.h"
#include "DS_List.h"
#include "DS_Queue.h"
#include "RakMemoryOverride.h"

Namespaces

namespace DataStructures
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DS_WeightedGraph.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Namespaces
DS_WeightedGraph.h File Reference
#include "DS_OrderedList.h"
#include "DS_Map.h"
#include "DS_Heap.h"
#include "DS_Queue.h"
#include "DS_Tree.h"
#include "RakAssert.h"
#include "RakMemoryOverride.h"

Namespaces

namespace DataStructures
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/DynDNS.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Namespaces
DynDNS.h File Reference

Helper to class to update DynDNS This can be used to determine what permissions are should be allowed to the other system. More...

#include "NativeFeatureIncludes.h"
#include "RakString.h"

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Helper to class to update DynDNS This can be used to determine what permissions are should be allowed to the other system.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/EmailSender.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
EmailSender.h File Reference

Rudimentary class to send email from code. Don't expect anything fancy. More...

#include "NativeFeatureIncludes.h"
#include "RakNetTypes.h"
#include "RakMemoryOverride.h"
#include "Export.h"
#include "Rand.h"
#include "TCPInterface.h"

Classes

class RakNet::EmailSender
Rudimentary class to send email from code. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Rudimentary class to send email from code. Don't expect anything fancy.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/EpochTimeToString.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
EpochTimeToString.h File Reference
#include "Export.h"

Detailed Description

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/FileList.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
FileList.h File Reference
#include "NativeFeatureIncludes.h"
#include "Export.h"
#include "DS_List.h"
#include "RakMemoryOverride.h"
#include "RakNetTypes.h"
#include "FileListNodeContext.h"
#include "RakString.h"

Classes

struct | RakNet::FileListNode
Represents once instance of a file. More...
class | RakNet::FileListProgress
Callback interface set with FileList::SetCallback() in case you want progress notifications when FileList::AddFilesFromDirectory() is called. More...
class | RakNet::FLP_Printf
Implementation of FileListProgress to use RAKNET_DEBUG_PRINTF. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/FileListNodeContext.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
FileListNodeContext.h File Reference
#include "BitStream.h"

Detailed Description

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/FileListTransfer.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
FileListTransfer.h File Reference

A plugin to provide a simple way to compress and incrementally send the files in the FileList structure. More...

#include "NativeFeatureIncludes.h"
#include "RakNetTypes.h"
#include "Export.h"
#include "PluginInterface2.h"
#include "DS_Map.h"
#include "PacketPriority.h"
#include "RakMemoryOverride.h"
#include "FileList.h"
#include "DS_Queue.h"
#include "SimpleMutex.h"
#include "ThreadPool.h"

Classes

class RakNet::FileListTransfer
A plugin to provide a simple way to compress and incrementally send the files in the FileList structure. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

A plugin to provide a simple way to compress and incrementally send the files in the FileList structure.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/FileListTransferCBInterface.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
FileListTransferCBInterface.h File Reference
#include "RakMemoryOverride.h"
#include "FileListNodeContext.h"

Classes

class RakNet::FileListTransferCBInterface
Used by FileListTransfer plugin as a callback for when we get a file. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/FileOperations.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
FileOperations.h File Reference
#include "NativeFeatureIncludes.h"
#include "Export.h"

Detailed Description

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/FormatString.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
FormatString.h File Reference
#include "Export.h"

Detailed Description

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/FullyConnectedMesh2.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
FullyConnectedMesh2.h File Reference

Fully connected mesh plugin, revision 2. More...

#include "NativeFeatureIncludes.h"
#include "PluginInterface2.h"
#include "RakMemoryOverride.h"
#include "NativeTypes.h"
#include "DS_List.h"
#include "RakString.h"
#include "BitStream.h"

Detailed Description

Fully connected mesh plugin, revision 2.

This will connect RakPeer to all connecting peers, and all peers the connecting peer knows about.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/GetTime.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Namespaces | Functions
GetTime.h File Reference

Returns the value from QueryPerformanceCounter. This is the function RakNet uses to represent time. This time won't match the time returned by GetTimeCount(). See http://www.jenkinssoftware.com/forum/index.php?topic=2798.0. More...

#include "Export.h"
#include "RakNetTime.h"

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Functions

RakNet::Time RAK_DLL_EXPORT | RakNet::GetTime (void)
RakNet::TimeMS RAK_DLL_EXPORT | RakNet::GetTimeMS (void)
RakNet::TimeUS RAK_DLL_EXPORT | RakNet::GetTimeUS (void)
RAK_DLL_EXPORT bool | RakNet::GreaterThan (RakNet::Time a, RakNet::Time b)
a > b?
RAK_DLL_EXPORT bool | RakNet::LessThan (RakNet::Time a, RakNet::Time b)
a < b?

Detailed Description

Returns the value from QueryPerformanceCounter. This is the function RakNet uses to represent time. This time won't match the time returned by GetTimeCount(). See http://www.jenkinssoftware.com/forum/index.php?topic=2798.0.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/HTTPConnection.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
HTTPConnection.h File Reference

Contains HTTPConnection, used to communicate with web servers. More...

#include "NativeFeatureIncludes.h"
#include "Export.h"
#include "RakString.h"
#include "RakMemoryOverride.h"
#include "RakNetTypes.h"
#include "DS_Queue.h"

Classes

class | RakNet::HTTPConnection
Use HTTPConnection to communicate with a web server. More...
struct | RakNet::HTTPConnection::BadResponse
Encapsulates a raw HTTP response and response code. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Contains HTTPConnection, used to communicate with web servers.

This file is part of RakNet Copyright 2008 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/HTTPConnection2.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
HTTPConnection2.h File Reference

Contains HTTPConnection2, used to communicate with web servers. More...

#include "NativeFeatureIncludes.h"
#include "Export.h"
#include "RakString.h"
#include "RakMemoryOverride.h"
#include "RakNetTypes.h"
#include "DS_List.h"
#include "DS_Queue.h"
#include "PluginInterface2.h"
#include "SimpleMutex.h"

Classes

class RakNet::HTTPConnection2
Use HTTPConnection2 to communicate with a web server. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Contains HTTPConnection2, used to communicate with web servers.

This file is part of RakNet Copyright 2008 Kevin Jenkins.

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/InternalPacket.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces | Typedefs
InternalPacket.h File Reference

[Internal] A class which stores a user message, and all information associated with sending and receiving that message. More...

#include "PacketPriority.h"
#include "RakNetTypes.h"
#include "RakMemoryOverride.h"
#include "RakNetDefines.h"
#include "NativeTypes.h"
#include "CCRakNetSlidingWindow.h"

Classes

struct | RakNet::InternalPacketRefCountedData
Used in InternalPacket when pointing to sharedDataBlock, rather than allocating itself. More...
struct | RakNet::InternalPacket

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Typedefs

typedef uint24_t | RakNet::MessageNumberType
typedef MessageNumberType | RakNet::OrderingIndexType

Detailed Description

[Internal] A class which stores a user message, and all information associated with sending and receiving that message.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/LogCommandParser.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
LogCommandParser.h File Reference

Contains LogCommandParser , Used to send logs to connected consoles. More...

#include "NativeFeatureIncludes.h"
#include "CommandParserInterface.h"
#include "Export.h"

Classes

class | RakNet::LogCommandParser
Adds the ability to send logging output to a remote console. More...
struct | RakNet::LogCommandParser::SystemAddressAndChannel
One of these structures is created per player. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Contains LogCommandParser , Used to send logs to connected consoles.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/MessageFilter.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces | Macros
MessageFilter.h File Reference

Message filter plugin. Assigns systems to FilterSets. Each FilterSet limits what messages are allowed. This is a security related plugin. More...

#include "NativeFeatureIncludes.h"
#include "RakNetTypes.h"
#include "PluginInterface2.h"
#include "DS_OrderedList.h"
#include "DS_Hash.h"
#include "Export.h"

Classes

class RakNet::MessageFilter
Assigns systems to FilterSets. Each FilterSet limits what kinds of messages are allowed. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Macros

#define MESSAGE_FILTER_MAX_MESSAGE_ID 256
MessageIdentifier (ID_*) values shoudln't go higher than this. Change it if you do.

Detailed Description

Message filter plugin. Assigns systems to FilterSets. Each FilterSet limits what messages are allowed. This is a security related plugin.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/MessageIdentifiers.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Enumerations
MessageIdentifiers.h File Reference

All the message identifiers used by RakNet. Message identifiers comprise the first byte of any message. More...

Enumerations

enum DefaultMessageIDTypes {
ID_CONNECTED_PING, ID_UNCONNECTED_PING, ID_UNCONNECTED_PING_OPEN_CONNECTIONS, ID_CONNECTED_PONG,
ID_DETECT_LOST_CONNECTIONS, ID_OPEN_CONNECTION_REQUEST_1, ID_OPEN_CONNECTION_REPLY_1, ID_OPEN_CONNECTION_REQUEST_2,
ID_OPEN_CONNECTION_REPLY_2, ID_CONNECTION_REQUEST, ID_REMOTE_SYSTEM_REQUIRES_PUBLIC_KEY, ID_OUR_SYSTEM_REQUIRES_SECURITY,
ID_PUBLIC_KEY_MISMATCH, ID_OUT_OF_BAND_INTERNAL, ID_SND_RECEIPT_ACKED, ID_SND_RECEIPT_LOSS,
ID_CONNECTION_REQUEST_ACCEPTED, ID_CONNECTION_ATTEMPT_FAILED, ID_ALREADY_CONNECTED, ID_NEW_INCOMING_CONNECTION,
ID_NO_FREE_INCOMING_CONNECTIONS, ID_DISCONNECTION_NOTIFICATION, ID_CONNECTION_LOST, ID_CONNECTION_BANNED,
ID_INVALID_PASSWORD , ID_IP_RECENTLY_CONNECTED, ID_TIMESTAMP, ID_UNCONNECTED_PONG,
ID_ADVERTISE_SYSTEM, ID_DOWNLOAD_PROGRESS, ID_REMOTE_DISCONNECTION_NOTIFICATION, ID_REMOTE_CONNECTION_LOST,
ID_REMOTE_NEW_INCOMING_CONNECTION, ID_FILE_LIST_TRANSFER_HEADER, ID_FILE_LIST_TRANSFER_FILE , ID_DDT_DOWNLOAD_REQUEST,
ID_TRANSPORT_STRING, ID_REPLICA_MANAGER_CONSTRUCTION, ID_REPLICA_MANAGER_SCOPE_CHANGE, ID_REPLICA_MANAGER_SERIALIZE,
ID_REPLICA_MANAGER_DOWNLOAD_STARTED, ID_REPLICA_MANAGER_DOWNLOAD_COMPLETE, ID_RAKVOICE_OPEN_CHANNEL_REQUEST, ID_RAKVOICE_OPEN_CHANNEL_REPLY,
ID_RAKVOICE_CLOSE_CHANNEL, ID_RAKVOICE_DATA, ID_AUTOPATCHER_GET_CHANGELIST_SINCE_DATE, ID_AUTOPATCHER_CREATION_LIST,
ID_AUTOPATCHER_DELETION_LIST, ID_AUTOPATCHER_GET_PATCH, ID_AUTOPATCHER_PATCH_LIST, ID_AUTOPATCHER_REPOSITORY_FATAL_ERROR,
ID_AUTOPATCHER_CANNOT_DOWNLOAD_ORIGINAL_UNMODIFIED_FILES, ID_AUTOPATCHER_FINISHED_INTERNAL , ID_AUTOPATCHER_RESTART_APPLICATION, ID_NAT_PUNCHTHROUGH_REQUEST,
ID_NAT_CONNECT_AT_TIME, ID_NAT_GET_MOST_RECENT_PORT, ID_NAT_CLIENT_READY, ID_NAT_TARGET_NOT_CONNECTED,
ID_NAT_TARGET_UNRESPONSIVE, ID_NAT_CONNECTION_TO_TARGET_LOST, ID_NAT_ALREADY_IN_PROGRESS, ID_NAT_PUNCHTHROUGH_FAILED,
ID_NAT_PUNCHTHROUGH_SUCCEEDED, ID_READY_EVENT_SET, ID_READY_EVENT_UNSET, ID_READY_EVENT_ALL_SET ,
ID_LOBBY_GENERAL , ID_RPC_PLUGIN, ID_FILE_LIST_REFERENCE_PUSH, ID_READY_EVENT_FORCE_ALL_SET,
ID_ROOMS_EXECUTE_FUNC , ID_LOBBY2_SEND_MESSAGE , ID_FCM2_NEW_HOST , ID_FCM2_VERIFIED_JOIN_START ,
ID_FCM2_VERIFIED_JOIN_FAILED, ID_FCM2_VERIFIED_JOIN_ACCEPTED, ID_FCM2_VERIFIED_JOIN_REJECTED, ID_UDP_PROXY_GENERAL,
ID_SQLite3_EXEC, ID_SQLite3_UNKNOWN_DB, ID_SQLLITE_LOGGER, ID_NAT_TYPE_DETECTION_REQUEST,
ID_NAT_TYPE_DETECTION_RESULT, ID_ROUTER_2_INTERNAL, ID_ROUTER_2_FORWARDING_NO_PATH, ID_ROUTER_2_FORWARDING_ESTABLISHED,
ID_ROUTER_2_REROUTED , ID_TEAM_BALANCER_REQUESTED_TEAM_FULL, ID_TEAM_BALANCER_REQUESTED_TEAM_LOCKED , ID_TEAM_BALANCER_TEAM_ASSIGNED,
ID_LIGHTSPEED_INTEGRATION, ID_XBOX_LOBBY, ID_TWO_WAY_AUTHENTICATION_INCOMING_CHALLENGE_SUCCESS , ID_TWO_WAY_AUTHENTICATION_INCOMING_CHALLENGE_FAILURE,
ID_TWO_WAY_AUTHENTICATION_OUTGOING_CHALLENGE_FAILURE, ID_TWO_WAY_AUTHENTICATION_OUTGOING_CHALLENGE_TIMEOUT , ID_CLOUD_POST_REQUEST
}

Detailed Description

All the message identifiers used by RakNet. Message identifiers comprise the first byte of any message.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Enumeration Type Documentation

enum DefaultMessageIDTypes

You should not edit the file MessageIdentifiers.h as it is a part of RakNet static library To define your own message id, define an enum following the code example that follows.

enum {
ID_MYPROJECT_MSG_1 = ID_USER_PACKET_ENUM,
ID_MYPROJECT_MSG_2,
...
};
Note
All these enumerations should be casted to (unsigned char) before writing them to RakNet::BitStream
Enumerator:
ID_CONNECTED_PING

These types are never returned to the user. Ping from a connected system. Update timestamps (internal use only)

ID_UNCONNECTED_PING

Ping from an unconnected system. Reply but do not update timestamps. (internal use only)

ID_UNCONNECTED_PING_OPEN_CONNECTIONS

Ping from an unconnected system. Only reply if we have open connections. Do not update timestamps. (internal use only)

ID_CONNECTED_PONG

Pong from a connected system. Update timestamps (internal use only)

ID_DETECT_LOST_CONNECTIONS

A reliable packet to detect lost connections (internal use only)

ID_OPEN_CONNECTION_REQUEST_1

C2S: Initial query: Header(1), OfflineMesageID(16), Protocol number(1), Pad(toMTU), sent with no fragment set. If protocol fails on server, returns ID_INCOMPATIBLE_PROTOCOL_VERSION to client

ID_OPEN_CONNECTION_REPLY_1

S2C: Header(1), OfflineMesageID(16), server GUID(8), HasSecurity(1), Cookie(4, if HasSecurity) , public key (if do security is true), MTU(2). If public key fails on client, returns ID_PUBLIC_KEY_MISMATCH

ID_OPEN_CONNECTION_REQUEST_2

C2S: Header(1), OfflineMesageID(16), Cookie(4, if HasSecurity is true on the server), clientSupportsSecurity(1 bit), handshakeChallenge (if has security on both server and client), remoteBindingAddress(6), MTU(2), client GUID(8) Connection slot allocated if cookie is valid, server is not full, GUID and IP not already in use.

ID_OPEN_CONNECTION_REPLY_2

S2C: Header(1), OfflineMesageID(16), server GUID(8), mtu(2), doSecurity(1 bit), handshakeAnswer (if do security is true)

ID_CONNECTION_REQUEST

C2S: Header(1), GUID(8), Timestamp, HasSecurity(1), Proof(32)

ID_REMOTE_SYSTEM_REQUIRES_PUBLIC_KEY

RakPeer - Remote system requires secure connections, pass a public key to RakPeerInterface::Connect()

ID_OUR_SYSTEM_REQUIRES_SECURITY

RakPeer - We passed a public key to RakPeerInterface::Connect(), but the other system did not have security turned on.

ID_PUBLIC_KEY_MISMATCH

RakPeer - Wrong public key passed to RakPeerInterface::Connect()

ID_OUT_OF_BAND_INTERNAL

RakPeer - Same as ID_ADVERTISE_SYSTEM, but intended for internal use rather than being passed to the user. Second byte indicates type. Used currently for NAT punchthrough for receiver port advertisement. See ID_NAT_ADVERTISE_RECIPIENT_PORT

ID_SND_RECEIPT_ACKED

If RakPeerInterface::Send() is called where PacketReliability contains _WITH_ACK_RECEIPT, then on a later call to RakPeerInterface::Receive() you will get ID_SND_RECEIPT_ACKED or ID_SND_RECEIPT_LOSS. The message will be 5 bytes long, and bytes 1-4 inclusive will contain a number in native order containing a number that identifies this message. This number will be returned by RakPeerInterface::Send() or RakPeerInterface::SendList(). ID_SND_RECEIPT_ACKED means that the message arrived

ID_SND_RECEIPT_LOSS

If RakPeerInterface::Send() is called where PacketReliability contains UNRELIABLE_WITH_ACK_RECEIPT, then on a later call to RakPeerInterface::Receive() you will get ID_SND_RECEIPT_ACKED or ID_SND_RECEIPT_LOSS. The message will be 5 bytes long, and bytes 1-4 inclusive will contain a number in native order containing a number that identifies this message. This number will be returned by RakPeerInterface::Send() or RakPeerInterface::SendList(). ID_SND_RECEIPT_LOSS means that an ack for the message did not arrive (it may or may not have been delivered, probably not). On disconnect or shutdown, you will not get ID_SND_RECEIPT_LOSS for unsent messages, you should consider those messages as all lost.

ID_CONNECTION_REQUEST_ACCEPTED

RakPeer - In a client/server environment, our connection request to the server has been accepted.

ID_CONNECTION_ATTEMPT_FAILED

RakPeer - Sent to the player when a connection request cannot be completed due to inability to connect.

ID_ALREADY_CONNECTED

RakPeer - Sent a connect request to a system we are currently connected to.

ID_NEW_INCOMING_CONNECTION

RakPeer - A remote system has successfully connected.

ID_NO_FREE_INCOMING_CONNECTIONS

RakPeer - The system we attempted to connect to is not accepting new connections.

ID_DISCONNECTION_NOTIFICATION

RakPeer - The system specified in Packet::systemAddress has disconnected from us. For the client, this would mean the server has shutdown.

ID_CONNECTION_LOST

RakPeer - Reliable packets cannot be delivered to the system specified in Packet::systemAddress. The connection to that system has been closed.

ID_CONNECTION_BANNED

RakPeer - We are banned from the system we attempted to connect to.

ID_INVALID_PASSWORD

RakPeer - The remote system is using a password and has refused our connection because we did not set the correct password.

ID_IP_RECENTLY_CONNECTED

RakPeer::SetLimitIPConnectionFrequency()

ID_TIMESTAMP

RakPeer - The sizeof(RakNetTime) bytes following this byte represent a value which is automatically modified by the difference in system times between the sender and the recipient. Requires that you call SetOccasionalPing.

ID_UNCONNECTED_PONG

RakPeer - Pong from an unconnected system. First byte is ID_UNCONNECTED_PONG, second sizeof(RakNet::TimeMS) bytes is the ping, following bytes is system specific enumeration data. Read using bitstreams

ID_ADVERTISE_SYSTEM

RakPeer - Inform a remote system of our IP/Port. On the recipient, all data past ID_ADVERTISE_SYSTEM is whatever was passed to the data parameter

ID_DOWNLOAD_PROGRESS

partTotal (unsigned int), partLength (unsigned int), first part data (length <= MAX_MTU_SIZE). See the three parameters partCount, partTotal and partLength in OnFileProgress in FileListTransferCBInterface.h

ID_REMOTE_DISCONNECTION_NOTIFICATION

ConnectionGraph2 plugin - In a client/server environment, a client other than ourselves has disconnected gracefully. Packet::systemAddress is modified to reflect the systemAddress of this client.

ID_REMOTE_CONNECTION_LOST

ConnectionGraph2 plugin - In a client/server environment, a client other than ourselves has been forcefully dropped. Packet::systemAddress is modified to reflect the systemAddress of this client.

ID_REMOTE_NEW_INCOMING_CONNECTION

ConnectionGraph2 plugin: Bytes 1-4 = count. for (count items) contains {SystemAddress, RakNetGUID, 2 byte ping}.

ID_FILE_LIST_TRANSFER_HEADER

FileListTransfer plugin - Setup data.

ID_FILE_LIST_TRANSFER_FILE

FileListTransfer plugin - A file.

ID_DDT_DOWNLOAD_REQUEST

DirectoryDeltaTransfer plugin - Request from a remote system for a download of a directory.

ID_TRANSPORT_STRING

RakNetTransport plugin - Transport provider message, used for remote console.

ID_REPLICA_MANAGER_CONSTRUCTION

ReplicaManager plugin - Create an object.

ID_REPLICA_MANAGER_SCOPE_CHANGE

ReplicaManager plugin - Changed scope of an object.

ID_REPLICA_MANAGER_SERIALIZE

ReplicaManager plugin - Serialized data of an object.

ID_REPLICA_MANAGER_DOWNLOAD_STARTED

ReplicaManager plugin - New connection, about to send all world objects.

ID_REPLICA_MANAGER_DOWNLOAD_COMPLETE

ReplicaManager plugin - Finished downloading all serialized objects.

ID_RAKVOICE_OPEN_CHANNEL_REQUEST

RakVoice plugin - Open a communication channel.

ID_RAKVOICE_OPEN_CHANNEL_REPLY

RakVoice plugin - Communication channel accepted.

ID_RAKVOICE_CLOSE_CHANNEL

RakVoice plugin - Close a communication channel.

ID_RAKVOICE_DATA

RakVoice plugin - Voice data.

ID_AUTOPATCHER_GET_CHANGELIST_SINCE_DATE

Autopatcher plugin - Get a list of files that have changed since a certain date.

ID_AUTOPATCHER_CREATION_LIST

Autopatcher plugin - A list of files to create.

ID_AUTOPATCHER_DELETION_LIST

Autopatcher plugin - A list of files to delete.

ID_AUTOPATCHER_GET_PATCH

Autopatcher plugin - A list of files to get patches for.

ID_AUTOPATCHER_PATCH_LIST

Autopatcher plugin - A list of patches for a list of files.

ID_AUTOPATCHER_REPOSITORY_FATAL_ERROR

Autopatcher plugin - Returned to the user: An error from the database repository for the autopatcher.

ID_AUTOPATCHER_CANNOT_DOWNLOAD_ORIGINAL_UNMODIFIED_FILES

Autopatcher plugin - Returned to the user: The server does not allow downloading unmodified game files.

ID_AUTOPATCHER_FINISHED_INTERNAL

Autopatcher plugin - Finished getting all files from the autopatcher.

ID_AUTOPATCHER_RESTART_APPLICATION

Autopatcher plugin - Returned to the user: You must restart the application to finish patching.

ID_NAT_PUNCHTHROUGH_REQUEST

NATPunchthrough plugin: internal.

ID_NAT_CONNECT_AT_TIME

NATPunchthrough plugin: internal.

NATPunchthrough plugin: internal NATPunchthrough plugin: internal

ID_NAT_GET_MOST_RECENT_PORT

NATPunchthrough plugin: internal.

ID_NAT_CLIENT_READY

NATPunchthrough plugin: internal.

ID_NAT_TARGET_NOT_CONNECTED

NATPunchthrough plugin: internal.

NATPunchthrough plugin: Destination system is not connected to the server. Bytes starting at offset 1 contains the RakNetGUID destination field of NatPunchthroughClient::OpenNAT().

ID_NAT_TARGET_UNRESPONSIVE

NATPunchthrough plugin: Destination system is not responding to ID_NAT_GET_MOST_RECENT_PORT. Possibly the plugin is not installed. Bytes starting at offset 1 contains the RakNetGUID destination field of NatPunchthroughClient::OpenNAT().

ID_NAT_CONNECTION_TO_TARGET_LOST

NATPunchthrough plugin: The server lost the connection to the destination system while setting up punchthrough. Possibly the plugin is not installed. Bytes starting at offset 1 contains the RakNetGUID destination field of NatPunchthroughClient::OpenNAT().

ID_NAT_ALREADY_IN_PROGRESS

NATPunchthrough plugin: This punchthrough is already in progress. Possibly the plugin is not installed. Bytes starting at offset 1 contains the RakNetGUID destination field of NatPunchthroughClient::OpenNAT().

ID_NAT_PUNCHTHROUGH_FAILED

NATPunchthrough plugin: This message is generated on the local system, and does not come from the network. packet::guid contains the destination field of NatPunchthroughClient::OpenNAT(). Byte 1 contains 1 if you are the sender, 0 if not

ID_NAT_PUNCHTHROUGH_SUCCEEDED

NATPunchthrough plugin: Punchthrough succeeded. See packet::systemAddress and packet::guid. Byte 1 contains 1 if you are the sender, 0 if not. You can now use RakPeer::Connect() or other calls to communicate with this system.

ID_READY_EVENT_SET

ReadyEvent plugin - Set the ready state for a particular system First 4 bytes after the message contains the id

ID_READY_EVENT_UNSET

ReadyEvent plugin - Unset the ready state for a particular system First 4 bytes after the message contains the id

ID_READY_EVENT_ALL_SET

All systems are in state ID_READY_EVENT_SET First 4 bytes after the message contains the id

ID_LOBBY_GENERAL

Lobby packets. Second byte indicates type.

ID_RPC_PLUGIN

Plugin based replacement for RPC system.

ID_FILE_LIST_REFERENCE_PUSH

FileListTransfer transferring large files in chunks that are read only when needed, to save memory.

ID_READY_EVENT_FORCE_ALL_SET

Force the ready event to all set.

ID_ROOMS_EXECUTE_FUNC

Rooms function.

ID_LOBBY2_SEND_MESSAGE

Lobby2 message.

ID_FCM2_NEW_HOST

Informs user of a new host GUID. Packet::Guid contains this new host RakNetGuid. The old host can be read out using BitStream->Read(RakNetGuid) starting on byte 1 This is not returned until connected to a remote system If the oldHost is UNASSIGNED_RAKNET_GUID, then this is the first time the host has been determined

ID_FCM2_VERIFIED_JOIN_START

A remote system (not necessarily the host) called FullyConnectedMesh2::StartVerifiedJoin() with our system as the client Use FullyConnectedMesh2::GetVerifiedJoinRequiredProcessingList() to read systems For each system, attempt NatPunchthroughClient::OpenNAT() and/or RakPeerInterface::Connect() When this has been done for all systems, the remote system will automatically be informed of the results

Note
Only the designated client gets this message
You won't get this message if you are already connected to all target systems
If you fail to connect to a system, this does not automatically mean you will get ID_FCM2_VERIFIED_JOIN_FAILED as that system may have been shutting down from the host too
See Also
FullyConnectedMesh2::StartVerifiedJoin()
ID_FCM2_VERIFIED_JOIN_FAILED

Client failed to connect to a required systems notified via FullyConnectedMesh2::StartVerifiedJoin() RakPeerInterface::CloseConnection() was automatically called for all systems connected due to ID_FCM2_VERIFIED_JOIN_START Programmer should inform the player via the UI that they cannot join this session, and to choose a different session

Note
Server normally sends us this message, however if connection to the server was lost, message will be returned locally
Only the designated client gets this message
ID_FCM2_VERIFIED_JOIN_ACCEPTED

The system that called StartVerifiedJoin() got ID_FCM2_VERIFIED_JOIN_CAPABLE from the client and then called RespondOnVerifiedJoinCapable() with true AddParticipant() has automatically been called for this system Use GetVerifiedJoinAcceptedAdditionalData() to read any additional data passed to RespondOnVerifiedJoinCapable()

Note
All systems in the mesh get this message
See Also
RespondOnVerifiedJoinCapable()
ID_FCM2_VERIFIED_JOIN_REJECTED

The system that called StartVerifiedJoin() got ID_FCM2_VERIFIED_JOIN_CAPABLE from the client and then called RespondOnVerifiedJoinCapable() with false CloseConnection() has been automatically called for each system connected to since ID_FCM2_VERIFIED_JOIN_START. The connection is NOT automatically closed to the original host that sent StartVerifiedJoin() Use GetVerifiedJoinRejectedAdditionalData() to read any additional data passed to RespondOnVerifiedJoinCapable()

Note
Only the designated client gets this message
See Also
RespondOnVerifiedJoinCapable()
ID_UDP_PROXY_GENERAL

UDP proxy messages. Second byte indicates type.

ID_SQLite3_EXEC

SQLite3Plugin - execute.

ID_SQLite3_UNKNOWN_DB

SQLite3Plugin - Remote database is unknown.

ID_SQLLITE_LOGGER

Events happening with SQLiteClientLoggerPlugin.

ID_NAT_TYPE_DETECTION_REQUEST

Sent to NatTypeDetectionServer.

ID_NAT_TYPE_DETECTION_RESULT

Sent to NatTypeDetectionClient. Byte 1 contains the type of NAT detected.

ID_ROUTER_2_INTERNAL

Used by the router2 plugin.

ID_ROUTER_2_FORWARDING_NO_PATH

No path is available or can be established to the remote system Packet::guid contains the endpoint guid that we were trying to reach

ID_ROUTER_2_FORWARDING_ESTABLISHED

You can now call connect, ping, or other operations to the destination system.

Connect as follows:

RakNet::BitStream bs(packet->data, packet->length, false); bs.IgnoreBytes(sizeof(MessageID)); RakNetGUID endpointGuid; bs.Read(endpointGuid); unsigned short sourceToDestPort; bs.Read(sourceToDestPort); char ipAddressString[32]; packet->systemAddress.ToString(false, ipAddressString); rakPeerInterface->Connect(ipAddressString, sourceToDestPort, 0,0);

ID_ROUTER_2_REROUTED

The IP address for a forwarded connection has changed Read endpointGuid and port as per ID_ROUTER_2_FORWARDING_ESTABLISHED

ID_TEAM_BALANCER_REQUESTED_TEAM_FULL

Cannot switch to the desired team because it is full. However, if someone on that team leaves, you will get ID_TEAM_BALANCER_TEAM_ASSIGNED later. For TeamBalancer: Byte 1 contains the team you requested to join. Following bytes contain NetworkID of which member

ID_TEAM_BALANCER_REQUESTED_TEAM_LOCKED

Cannot switch to the desired team because all teams are locked. However, if someone on that team leaves, you will get ID_TEAM_BALANCER_SET_TEAM later. For TeamBalancer: Byte 1 contains the team you requested to join.

ID_TEAM_BALANCER_TEAM_ASSIGNED

Team balancer plugin informing you of your team. Byte 1 contains the team you requested to join. Following bytes contain NetworkID of which member.

ID_LIGHTSPEED_INTEGRATION

Gamebryo Lightspeed integration.

ID_XBOX_LOBBY

XBOX integration.

ID_TWO_WAY_AUTHENTICATION_INCOMING_CHALLENGE_SUCCESS

The password we used to challenge the other system passed, meaning the other system has called TwoWayAuthentication::AddPassword() with the same password we passed to TwoWayAuthentication::Challenge() You can read the identifier used to challenge as follows: RakNet::BitStream bs(packet->data, packet->length, false); bs.IgnoreBytes(sizeof(RakNet::MessageID)); RakNet::RakString password; bs.Read(password);

ID_TWO_WAY_AUTHENTICATION_INCOMING_CHALLENGE_FAILURE

A remote system sent us a challenge using TwoWayAuthentication::Challenge(), and the challenge failed. If the other system must pass the challenge to stay connected, you should call RakPeer::CloseConnection() to terminate the connection to the other system.

ID_TWO_WAY_AUTHENTICATION_OUTGOING_CHALLENGE_FAILURE

The other system did not add the password we used to TwoWayAuthentication::AddPassword() You can read the identifier used to challenge as follows: RakNet::BitStream bs(packet->data, packet->length, false); bs.IgnoreBytes(sizeof(MessageID)); RakNet::RakString password; bs.Read(password);

ID_TWO_WAY_AUTHENTICATION_OUTGOING_CHALLENGE_TIMEOUT

The other system did not respond within a timeout threshhold. Either the other system is not running the plugin or the other system was blocking on some operation for a long time. You can read the identifier used to challenge as follows: RakNet::BitStream bs(packet->data, packet->length, false); bs.IgnoreBytes(sizeof(MessageID)); RakNet::RakString password; bs.Read(password);

ID_CLOUD_POST_REQUEST

CloudClient / CloudServer.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/MTUSize.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Macros
MTUSize.h File Reference

[Internal] Defines the default maximum transfer unit. More...

Macros

#define MAXIMUM_MTU_SIZE 1492

Detailed Description

[Internal] Defines the default maximum transfer unit.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Macro Definition Documentation

#define MAXIMUM_MTU_SIZE 1492
  • 17914 16 Mbit/Sec Token Ring
  • 4464 4 Mbits/Sec Token Ring
  • 4352 FDDI
  • 1500. The largest Ethernet packet size recommended. This is the typical setting for non-PPPoE, non-VPN connections. The default value for NETGEAR routers, adapters and switches.
  • 1492. The size PPPoE prefers.
  • 1472. Maximum size to use for pinging. (Bigger packets are fragmented.)
  • 1468. The size DHCP prefers.
  • 1460. Usable by AOL if you don't have large email attachments, etc.
  • 1430. The size VPN and PPTP prefer.
  • 1400. Maximum size for AOL DSL.
  • 576. Typical value to connect to dial-up ISPs. The largest value for an UDP datagram
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/NatPunchthroughClient.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
NatPunchthroughClient.h File Reference

Contains the NAT-punchthrough plugin for the client. More...

#include "NativeFeatureIncludes.h"
#include "RakNetTypes.h"
#include "Export.h"
#include "PluginInterface2.h"
#include "PacketPriority.h"
#include "SocketIncludes.h"
#include "DS_List.h"
#include "RakString.h"
#include "DS_Queue.h"

Classes

class RakNet::NatPunchthroughClient
Client code for NATPunchthrough. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Contains the NAT-punchthrough plugin for the client.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/NatPunchthroughServer.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
NatPunchthroughServer.h File Reference

Contains the NAT-punchthrough plugin for the server. More...

#include "NativeFeatureIncludes.h"
#include "RakNetTypes.h"
#include "Export.h"
#include "PluginInterface2.h"
#include "PacketPriority.h"
#include "SocketIncludes.h"
#include "DS_OrderedList.h"
#include "RakString.h"

Classes

class RakNet::NatPunchthroughServer
Server code for NATPunchthrough. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Contains the NAT-punchthrough plugin for the server.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/NatTypeDetectionClient.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
NatTypeDetectionClient.h File Reference

Contains the NAT-type detection code for the client. More...

#include "NativeFeatureIncludes.h"
#include "RakNetTypes.h"
#include "Export.h"
#include "PluginInterface2.h"
#include "PacketPriority.h"
#include "SocketIncludes.h"
#include "DS_OrderedList.h"
#include "RakString.h"
#include "NatTypeDetectionCommon.h"

Classes

class RakNet::NatTypeDetectionClient
Client code for NatTypeDetection. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Contains the NAT-type detection code for the client.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/NatTypeDetectionServer.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
NatTypeDetectionServer.h File Reference

Contains the NAT-type detection code for the server. More...

#include "NativeFeatureIncludes.h"
#include "RakNetTypes.h"
#include "Export.h"
#include "PluginInterface2.h"
#include "PacketPriority.h"
#include "SocketIncludes.h"
#include "DS_OrderedList.h"
#include "RakString.h"
#include "NatTypeDetectionCommon.h"

Classes

class RakNet::NatTypeDetectionServer
Server code for NatTypeDetection. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Contains the NAT-type detection code for the server.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/NetworkIDManager.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces | Macros
NetworkIDManager.h File Reference
#include "RakNetTypes.h"
#include "Export.h"
#include "RakMemoryOverride.h"
#include "NetworkIDObject.h"
#include "Rand.h"

Classes

class RakNet::NetworkIDManager

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Macros

#define NETWORK_ID_MANAGER_HASH_LENGTH 1024

Detailed Description

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Macro Definition Documentation

#define NETWORK_ID_MANAGER_HASH_LENGTH 1024

Increase this value if you plan to have many persistent objects This value must match on all systems

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/NetworkIDObject.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
NetworkIDObject.h File Reference

A class you can derive from to make it easier to represent every networked object with an integer. This way you can refer to objects over the network. More...

#include "RakNetTypes.h"
#include "RakMemoryOverride.h"
#include "Export.h"

Classes

class RakNet::NetworkIDObject
Unique shared ids for each object instance. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

A class you can derive from to make it easier to represent every networked object with an integer. This way you can refer to objects over the network.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/PacketConsoleLogger.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
PacketConsoleLogger.h File Reference

This will write all incoming and outgoing network messages to the log command parser, which can be accessed through Telnet. More...

#include "NativeFeatureIncludes.h"
#include "PacketLogger.h"

Classes

class RakNet::PacketConsoleLogger
Packetlogger that logs to a remote command console. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

This will write all incoming and outgoing network messages to the log command parser, which can be accessed through Telnet.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/PacketFileLogger.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
PacketFileLogger.h File Reference

This will write all incoming and outgoing network messages to a file. More...

#include "NativeFeatureIncludes.h"
#include "PacketLogger.h"
#include <stdio.h>

Classes

class RakNet::PacketFileLogger
Packetlogger that outputs to a file. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

This will write all incoming and outgoing network messages to a file.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/PacketizedTCP.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Namespaces
PacketizedTCP.h File Reference

A simple TCP based server allowing sends and receives. Can be connected by any TCP client, including telnet. More...

#include "NativeFeatureIncludes.h"
#include "TCPInterface.h"
#include "DS_ByteQueue.h"
#include "DS_Map.h"

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

A simple TCP based server allowing sends and receives. Can be connected by any TCP client, including telnet.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/PacketLogger.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
PacketLogger.h File Reference

This will write all incoming and outgoing network messages to the local console screen. See derived functions for other outputs. More...

#include "NativeFeatureIncludes.h"
#include "RakNetTypes.h"
#include "PluginInterface2.h"
#include "Export.h"

Classes

class RakNet::PacketLogger
Writes incoming and outgoing messages to the screen. This will write all incoming and outgoing messages to the console window, or to a file if you override it and give it this functionality. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

This will write all incoming and outgoing network messages to the local console screen. See derived functions for other outputs.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/PacketOutputWindowLogger.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
PacketOutputWindowLogger.h File Reference

This will write all incoming and outgoing network messages to a file. More...

#include "NativeFeatureIncludes.h"
#include "PacketLogger.h"

Classes

class RakNet::PacketOutputWindowLogger
Packetlogger that outputs to the output window in the debugger. Windows only. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

This will write all incoming and outgoing network messages to a file.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/PacketPriority.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Enumerations
PacketPriority.h File Reference

This file contains enumerations for packet priority and reliability enumerations. More...

Enumerations

enum PacketPriority { IMMEDIATE_PRIORITY, HIGH_PRIORITY, MEDIUM_PRIORITY, LOW_PRIORITY }
These enumerations are used to describe when packets are delivered. More...
enum PacketReliability {
UNRELIABLE, UNRELIABLE_SEQUENCED, RELIABLE, RELIABLE_ORDERED,
RELIABLE_SEQUENCED, UNRELIABLE_WITH_ACK_RECEIPT, RELIABLE_WITH_ACK_RECEIPT, RELIABLE_ORDERED_WITH_ACK_RECEIPT,
NUMBER_OF_RELIABILITIES
}

Detailed Description

This file contains enumerations for packet priority and reliability enumerations.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Enumeration Type Documentation

enum PacketPriority

These enumerations are used to describe when packets are delivered.

Enumerator:
IMMEDIATE_PRIORITY

The highest possible priority. These message trigger sends immediately, and are generally not buffered or aggregated into a single datagram.

HIGH_PRIORITY

For every 2 IMMEDIATE_PRIORITY messages, 1 HIGH_PRIORITY will be sent. Messages at this priority and lower are buffered to be sent in groups at 10 millisecond intervals to reduce UDP overhead and better measure congestion control.

MEDIUM_PRIORITY

For every 2 HIGH_PRIORITY messages, 1 MEDIUM_PRIORITY will be sent. Messages at this priority and lower are buffered to be sent in groups at 10 millisecond intervals to reduce UDP overhead and better measure congestion control.

LOW_PRIORITY

For every 2 MEDIUM_PRIORITY messages, 1 LOW_PRIORITY will be sent. Messages at this priority and lower are buffered to be sent in groups at 10 millisecond intervals to reduce UDP overhead and better measure congestion control.

enum PacketReliability

These enumerations are used to describe how packets are delivered.

Note
Note to self: I write this with 3 bits in the stream. If I add more remember to change that
In ReliabilityLayer::WriteToBitStreamFromInternalPacket I assume there are 5 major types
Do not reorder, I check on >= UNRELIABLE_WITH_ACK_RECEIPT
Enumerator:
UNRELIABLE

Same as regular UDP, except that it will also discard duplicate datagrams. RakNet adds (6 to 17) + 21 bits of overhead, 16 of which is used to detect duplicate packets and 6 to 17 of which is used for message length.

UNRELIABLE_SEQUENCED

Regular UDP with a sequence counter. Out of order messages will be discarded. Sequenced and ordered messages sent on the same channel will arrive in the order sent.

RELIABLE

The message is sent reliably, but not necessarily in any order. Same overhead as UNRELIABLE.

RELIABLE_ORDERED

This message is reliable and will arrive in the order you sent it. Messages will be delayed while waiting for out of order messages. Same overhead as UNRELIABLE_SEQUENCED. Sequenced and ordered messages sent on the same channel will arrive in the order sent.

RELIABLE_SEQUENCED

This message is reliable and will arrive in the sequence you sent it. Out or order messages will be dropped. Same overhead as UNRELIABLE_SEQUENCED. Sequenced and ordered messages sent on the same channel will arrive in the order sent.

UNRELIABLE_WITH_ACK_RECEIPT

Same as UNRELIABLE, however the user will get either ID_SND_RECEIPT_ACKED or ID_SND_RECEIPT_LOSS based on the result of sending this message when calling RakPeerInterface::Receive(). Bytes 1-4 will contain the number returned from the Send() function. On disconnect or shutdown, all messages not previously acked should be considered lost.

RELIABLE_WITH_ACK_RECEIPT

Same as RELIABLE. The user will also get ID_SND_RECEIPT_ACKED after the message is delivered when calling RakPeerInterface::Receive(). ID_SND_RECEIPT_ACKED is returned when the message arrives, not necessarily the order when it was sent. Bytes 1-4 will contain the number returned from the Send() function. On disconnect or shutdown, all messages not previously acked should be considered lost. This does not return ID_SND_RECEIPT_LOSS.

Same as UNRELIABLE_SEQUENCED, however the user will get either ID_SND_RECEIPT_ACKED or ID_SND_RECEIPT_LOSS based on the result of sending this message when calling RakPeerInterface::Receive(). Bytes 1-4 will contain the number returned from the Send() function. On disconnect or shutdown, all messages not previously acked should be considered lost. 05/04/10 You can't have sequenced and ack receipts, because you don't know if the other system discarded the message, meaning you don't know if the message was processed

RELIABLE_ORDERED_WITH_ACK_RECEIPT

Same as RELIABLE_ORDERED_ACK_RECEIPT. The user will also get ID_SND_RECEIPT_ACKED after the message is delivered when calling RakPeerInterface::Receive(). ID_SND_RECEIPT_ACKED is returned when the message arrives, not necessarily the order when it was sent. Bytes 1-4 will contain the number returned from the Send() function. On disconnect or shutdown, all messages not previously acked should be considered lost. This does not return ID_SND_RECEIPT_LOSS.

NUMBER_OF_RELIABILITIES

Same as RELIABLE_SEQUENCED. The user will also get ID_SND_RECEIPT_ACKED after the message is delivered when calling RakPeerInterface::Receive(). Bytes 1-4 will contain the number returned from the Send() function. On disconnect or shutdown, all messages not previously acked should be considered lost. 05/04/10 You can't have sequenced and ack receipts, because you don't know if the other system discarded the message, meaning you don't know if the message was processed

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/PluginInterface2.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces | Enumerations
PluginInterface2.h File Reference

RakNet's plugin functionality system, version 2. You can derive from this to create your own plugins. More...

#include "NativeFeatureIncludes.h"
#include "RakNetTypes.h"
#include "Export.h"
#include "PacketPriority.h"

Classes

class RakNet::PluginInterface2

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Enumerations

enum | RakNet::PluginReceiveResult { RakNet::RR_STOP_PROCESSING_AND_DEALLOCATE =0, RakNet::RR_CONTINUE_PROCESSING, RakNet::RR_STOP_PROCESSING }
enum | RakNet::PI2_LostConnectionReason { RakNet::LCR_CLOSED_BY_USER, RakNet::LCR_DISCONNECTION_NOTIFICATION, RakNet::LCR_CONNECTION_LOST }
enum | RakNet::PI2_FailedConnectionAttemptReason

Detailed Description

RakNet's plugin functionality system, version 2. You can derive from this to create your own plugins.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/Rackspace.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces | Enumerations
Rackspace.h File Reference

Helper to class to manage Rackspace servers. More...

#include "NativeFeatureIncludes.h"
#include "Export.h"
#include "DS_List.h"
#include "RakNetTypes.h"
#include "DS_Queue.h"
#include "RakString.h"

Classes

class | RakNet::Rackspace2EventCallback
Callback interface to receive the results of operations. More...
class | RakNet::RackspaceEventCallback_Default
Callback interface to receive the results of operations, with a default result. More...
class | RakNet::Rackspace
Code that uses the TCPInterface class to communicate with the Rackspace API servers. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Enumerations

enum RakNet::RackspaceEventType
Result codes for Rackspace commands /sa Rackspace::EventTypeToString()

Detailed Description

Helper to class to manage Rackspace servers.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/RakMemoryOverride.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Namespaces
RakMemoryOverride.h File Reference

If _USE_RAK_MEMORY_OVERRIDE is defined, memory allocations go through rakMalloc, rakRealloc, and rakFree. More...

#include "Export.h"
#include "RakNetDefines.h"
#include <new>
#include "RakAlloca.h"

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

If _USE_RAK_MEMORY_OVERRIDE is defined, memory allocations go through rakMalloc, rakRealloc, and rakFree.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/RakNetCommandParser.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
RakNetCommandParser.h File Reference

Contains RakNetCommandParser , used to send commands to an instance of RakPeer. More...

#include "NativeFeatureIncludes.h"
#include "CommandParserInterface.h"
#include "Export.h"

Classes

class RakNet::RakNetCommandParser
This allows a console client to call most of the functions in RakPeer. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Contains RakNetCommandParser , used to send commands to an instance of RakPeer.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/RakNetStatistics.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces | Enumerations | Functions
RakNetStatistics.h File Reference

A structure that holds all statistical data returned by RakNet. More...

#include "PacketPriority.h"
#include "Export.h"
#include "RakNetTypes.h"

Classes

struct RakNet::RakNetStatistics
Network Statisics Usage. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Enumerations

enum RakNet::RNSPerSecondMetrics {
RakNet::USER_MESSAGE_BYTES_PUSHED, RakNet::USER_MESSAGE_BYTES_SENT, RakNet::USER_MESSAGE_BYTES_RESENT, RakNet::USER_MESSAGE_BYTES_RECEIVED_PROCESSED,
RakNet::USER_MESSAGE_BYTES_RECEIVED_IGNORED, RakNet::ACTUAL_BYTES_SENT, RakNet::ACTUAL_BYTES_RECEIVED
}

Functions

void RAK_DLL_EXPORT RakNet::StatisticsToString (RakNetStatistics *s, char *buffer, int verbosityLevel)

Detailed Description

A structure that holds all statistical data returned by RakNet.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/RakNetTransport2.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
RakNetTransport2.h File Reference

Contains RakNetTransportCommandParser and RakNetTransport used to provide a secure console connection. More...

#include "NativeFeatureIncludes.h"
#include "TransportInterface.h"
#include "DS_Queue.h"
#include "CommandParserInterface.h"
#include "PluginInterface2.h"
#include "Export.h"

Classes

class RakNet::RakNetTransport2
Use RakNetTransport if you need a secure connection between the client and the console server. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Contains RakNetTransportCommandParser and RakNetTransport used to provide a secure console connection.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/RakNetTypes.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces | Macros | Typedefs | Enumerations | Variables
RakNetTypes.h File Reference

Types used by RakNet, most of which involve user code. More...

#include "RakNetDefines.h"
#include "NativeTypes.h"
#include "RakNetTime.h"
#include "Export.h"
#include "WindowsIncludes.h"
#include "XBox360Includes.h"
#include "SocketIncludes.h"

Classes

struct | RakNet::PublicKey
Passed to RakPeerInterface::Connect() More...
struct | RakNet::SocketDescriptor
Describes the local socket to use for RakPeer::Startup. More...
struct | RakNet::SystemAddress
Network address for a system. More...
struct | RakNet::RakNetGUID
struct | RakNet::Packet
This represents a user message from another system. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Macros

#define BITS_TO_BYTES(x) (((x)+7)>>3)
Given a number of bits, return how many bytes are needed to represent that.

Typedefs

typedef unsigned char | RakNet::UniqueIDType
typedef unsigned char | RakNet::MessageID
First byte of a network message.

Enumerations

enum RakNet::ConnectionState {
RakNet::IS_PENDING, RakNet::IS_CONNECTING, RakNet::IS_CONNECTED, RakNet::IS_DISCONNECTING,
RakNet::IS_SILENTLY_DISCONNECTING, RakNet::IS_DISCONNECTED, RakNet::IS_NOT_CONNECTED
}
Returned from RakPeerInterface::GetConnectionState() More...
enum RakNet::PublicKeyMode { RakNet::PKM_INSECURE_CONNECTION, RakNet::PKM_ACCEPT_ANY_PUBLIC_KEY, RakNet::PKM_USE_KNOWN_PUBLIC_KEY, RakNet::PKM_USE_TWO_WAY_AUTHENTICATION }
Used with the PublicKey structure. More...

Variables

const SystemAddress | RakNet::UNASSIGNED_SYSTEM_ADDRESS
Index of an invalid SystemAddress.
const SystemIndex | RakNet::UNASSIGNED_PLAYER_INDEX = 65535
Index of an unassigned player.
const NetworkID | RakNet::UNASSIGNED_NETWORK_ID = (uint64_t) -1
Unassigned object ID.

Detailed Description

Types used by RakNet, most of which involve user code.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/RakPeer.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
RakPeer.h File Reference

Declares RakPeer class. More...

#include "ReliabilityLayer.h"
#include "RakPeerInterface.h"
#include "BitStream.h"
#include "SingleProducerConsumer.h"
#include "SimpleMutex.h"
#include "DS_OrderedList.h"
#include "Export.h"
#include "RakString.h"
#include "RakThread.h"
#include "RakNetSmartPtr.h"
#include "DS_ThreadsafeAllocatingQueue.h"
#include "SignaledEvent.h"
#include "NativeFeatureIncludes.h"
#include "SecureHandshake.h"
#include "LocklessTypes.h"
#include "DS_Queue.h"

Classes

class RakNet::RakPeer
Main interface for network communications. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Declares RakPeer class.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/RakPeerInterface.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
RakPeerInterface.h File Reference

An interface for RakPeer. Simply contains all user functions as pure virtuals. More...

#include "PacketPriority.h"
#include "RakNetTypes.h"
#include "RakMemoryOverride.h"
#include "Export.h"
#include "DS_List.h"
#include "RakNetSmartPtr.h"
#include "RakNetSocket2.h"

Classes

class RakNet::RakPeerInterface
The main interface for network communications. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

An interface for RakPeer. Simply contains all user functions as pure virtuals.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/Rand.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Namespaces | Functions
Rand.h File Reference

[Internal] Random number generator More...

#include "Export.h"

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Functions

void RAK_DLL_EXPORT | seedMT (unsigned int seed)
unsigned int RAK_DLL_EXPORT | randomMT (void)
float RAK_DLL_EXPORT | frandomMT (void)
void RAK_DLL_EXPORT | fillBufferMT (void *buffer, unsigned int bytes)

Detailed Description

[Internal] Random number generator

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Function Documentation

void RAK_DLL_EXPORT fillBufferMT | ( | void * | buffer,
 |  | unsigned int | bytes
 | ) |  |

Randomizes a buffer

Note
not threadSafe, use an instance of RakNetRandom if necessary per thread
float RAK_DLL_EXPORT frandomMT ( void )

Gets a random float

Note
not threadSafe, use an instance of RakNetRandom if necessary per thread
Returns
0 to 1.0f, inclusive
unsigned int RAK_DLL_EXPORT randomMT ( void )

Gets a random unsigned int

Note
not threadSafe, use an instance of RakNetRandom if necessary per thread
Returns
an integer random value.
void RAK_DLL_EXPORT seedMT ( unsigned int seed )

Initialise seed for Random Generator

Note
not threadSafe, use an instance of RakNetRandom if necessary per thread
Parameters
[in] seed The seed value for the random number generator.
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/RandSync.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Namespaces
RandSync.h File Reference

[Internal] Random number generator More...

#include "Export.h"
#include "Rand.h"
#include "DS_Queue.h"
#include "NativeTypes.h"

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

[Internal] Random number generator

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/ReadyEvent.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces | Enumerations
ReadyEvent.h File Reference

Ready event plugin. This enables a set of systems to create a signal event, set this signal as ready or unready, and to trigger the event when all systems are ready. More...

#include "NativeFeatureIncludes.h"
#include "PluginInterface2.h"
#include "DS_OrderedList.h"

Classes

class RakNet::ReadyEvent
Peer to peer synchronized ready and unready events. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Enumerations

enum RakNet::ReadyEventSystemStatus {
RakNet::RES_NOT_WAITING, RakNet::RES_WAITING, RakNet::RES_READY, RakNet::RES_ALL_READY,
RakNet::RES_UNKNOWN_EVENT
}

Detailed Description

Ready event plugin. This enables a set of systems to create a signal event, set this signal as ready or unready, and to trigger the event when all systems are ready.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/RefCountedObj.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes
RefCountedObj.h File Reference

Reference counted object. Very simple class for quick and dirty uses. More...

#include "RakMemoryOverride.h"

Classes

class RefCountedObj
World's simplest class :) More...

Detailed Description

Reference counted object. Very simple class for quick and dirty uses.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/RelayPlugin.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
RelayPlugin.h File Reference

Contains the class RelayPlugin. More...

#include "NativeFeatureIncludes.h"
#include "PluginInterface2.h"
#include "RakString.h"
#include "DS_Hash.h"

Classes

class RakNet::RelayPlugin
A simple class to relay messages from one system to another, identifying remote systems by a string. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Contains the class RelayPlugin.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/ReliabilityLayer.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces | Macros
ReliabilityLayer.h File Reference

[Internal] Datagram reliable, ordered, unordered and sequenced sends. Flow control. Message splitting, reassembly, and coalescence. More...

#include "RakMemoryOverride.h"
#include "MTUSize.h"
#include "DS_LinkedList.h"
#include "DS_List.h"
#include "SocketLayer.h"
#include "PacketPriority.h"
#include "DS_Queue.h"
#include "BitStream.h"
#include "InternalPacket.h"
#include "RakNetStatistics.h"
#include "DR_SHA1.h"
#include "DS_OrderedList.h"
#include "DS_RangeList.h"
#include "DS_BPlusTree.h"
#include "DS_MemoryPool.h"
#include "RakNetDefines.h"
#include "DS_Heap.h"
#include "NativeFeatureIncludes.h"
#include "SecureHandshake.h"
#include "PluginInterface2.h"
#include "Rand.h"
#include "RakNetSocket2.h"
#include "CCRakNetSlidingWindow.h"

Classes

class RakNet::ReliabilityLayer
Datagram reliable, ordered, unordered and sequenced sends. Flow control. Message splitting, reassembly, and coalescence. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Macros

#define NUMBER_OF_ORDERED_STREAMS 32
Number of ordered streams available. You can use up to 32 ordered streams.

Detailed Description

[Internal] Datagram reliable, ordered, unordered and sequenced sends. Flow control. Message splitting, reassembly, and coalescence.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein. GPL license users are subject to the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/ReplicaEnums.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Enumerations
ReplicaEnums.h File Reference

Contains enumerations used by the ReplicaManager system. This file is a lightweight header, so you can include it without worrying about linking in lots of other crap. More...

Enumerations

enum
enum ReplicaReturnResult {
REPLICA_PROCESS_LATER, REPLICA_PROCESSING_DONE, REPLICA_CANCEL_PROCESS, REPLICA_PROCESS_AGAIN,
REPLICA_PROCESS_IMPLICIT
}

Detailed Description

Contains enumerations used by the ReplicaManager system. This file is a lightweight header, so you can include it without worrying about linking in lots of other crap.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Enumeration Type Documentation

anonymous enum

Replica interface flags, used to enable and disable function calls on the Replica object Passed to ReplicaManager::EnableReplicaInterfaces and ReplicaManager::DisableReplicaInterfaces

enum ReplicaReturnResult
Enumerator:
REPLICA_PROCESS_LATER

This means call the function again later, with the same parameters.

REPLICA_PROCESSING_DONE

This means we are done processing (the normal result to return)

REPLICA_CANCEL_PROCESS

This means cancel the processing - don't send any network messages and don't change the current state.

REPLICA_PROCESS_AGAIN

Same as REPLICA_PROCESSING_DONE, where a message is sent, but does not clear the send bit. Useful for multi-part sends with different reliability levels. Only currently used by Replica::Serialize

REPLICA_PROCESS_IMPLICIT

Only returned from the Replica::SendConstruction interface, means act as if the other system had this object but don't actually Send a construction packet. This way you will still send scope and serialize packets to that system

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/ReplicaManager3.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces | Typedefs | Enumerations
ReplicaManager3.h File Reference

Contains the third iteration of the ReplicaManager class. More...

#include "NativeFeatureIncludes.h"
#include "RakNetTypes.h"
#include "RakNetTime.h"
#include "BitStream.h"
#include "PacketPriority.h"
#include "PluginInterface2.h"
#include "NetworkIDObject.h"
#include "DS_OrderedList.h"
#include "DS_Queue.h"

Classes

class | RakNet::ReplicaManager3
System to help automate game object construction, destruction, and serialization. More...
struct | RakNet::LastSerializationResult
struct | RakNet::SerializeParameters
class | RakNet::Connection_RM3
Each remote system is represented by Connection_RM3. Used to allocate Replica3 and track which instances have been allocated. More...
class | RakNet::Replica3
Base class for your replicated objects for the ReplicaManager3 system. More...
class | RakNet::Replica3Composite< parent_type >
Use Replica3 through composition instead of inheritance by containing an instance of this templated class Calls to parent class for all functions Parent class must still define and functions though! More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Typedefs

typedef uint8_t RakNet::WorldId

Enumerations

enum RakNet::RM3ConstructionState {
RakNet::RM3CS_SEND_CONSTRUCTION, RakNet::RM3CS_ALREADY_EXISTS_REMOTELY, RakNet::RM3CS_ALREADY_EXISTS_REMOTELY_DO_NOT_CONSTRUCT, RakNet::RM3CS_NEVER_CONSTRUCT,
RakNet::RM3CS_NO_ACTION, RakNet::RM3CS_MAX
}
Return codes for Connection_RM3::GetConstructionState() and Replica3::QueryConstruction() More...
enum | RakNet::RM3DestructionState { RakNet::RM3DS_SEND_DESTRUCTION, RakNet::RM3DS_DO_NOT_QUERY_DESTRUCTION, RakNet::RM3DS_NO_ACTION, RakNet::RM3DS_MAX }
enum RakNet::RM3SerializationResult {
RakNet::RM3SR_BROADCAST_IDENTICALLY, RakNet::RM3SR_BROADCAST_IDENTICALLY_FORCE_SERIALIZATION, RakNet::RM3SR_SERIALIZED_UNIQUELY, RakNet::RM3SR_SERIALIZED_ALWAYS,
RakNet::RM3SR_SERIALIZED_ALWAYS_IDENTICALLY, RakNet::RM3SR_DO_NOT_SERIALIZE, RakNet::RM3SR_NEVER_SERIALIZE_FOR_THIS_CONNECTION, RakNet::RM3SR_MAX
}
enum | RakNet::RM3QuerySerializationResult { RakNet::RM3QSR_CALL_SERIALIZE, RakNet::RM3QSR_DO_NOT_CALL_SERIALIZE, RakNet::RM3QSR_NEVER_CALL_SERIALIZE, RakNet::RM3QSR_MAX }
enum RakNet::Replica3P2PMode {
RakNet::R3P2PM_SINGLE_OWNER, RakNet::R3P2PM_MULTI_OWNER_CURRENTLY_AUTHORITATIVE, RakNet::R3P2PM_MULTI_OWNER_NOT_CURRENTLY_AUTHORITATIVE, RakNet::R3P2PM_STATIC_OBJECT_CURRENTLY_AUTHORITATIVE,
RakNet::R3P2PM_STATIC_OBJECT_NOT_CURRENTLY_AUTHORITATIVE
}

Detailed Description

Contains the third iteration of the ReplicaManager class.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/Router2.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
Router2.h File Reference

Router2 plugin. Allows you to connect to a system by routing packets through another system that is connected to both you and the destination. Useful for getting around NATs. More...

#include "NativeFeatureIncludes.h"
#include "RakNetTypes.h"
#include "PluginInterface2.h"
#include "PacketPriority.h"
#include "Export.h"
#include "UDPForwarder.h"
#include "MessageIdentifiers.h"
#include "DS_List.h"
#include "SimpleMutex.h"

Classes

class RakNet::Router2
Class interface for the Router2 system. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Router2 plugin. Allows you to connect to a system by routing packets through another system that is connected to both you and the destination. Useful for getting around NATs.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/RPC4Plugin.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces | Enumerations
RPC4Plugin.h File Reference

Remote procedure call, supporting C functions only. No external dependencies required. More...

#include "NativeFeatureIncludes.h"
#include "PluginInterface2.h"
#include "PacketPriority.h"
#include "RakNetTypes.h"
#include "BitStream.h"
#include "RakString.h"
#include "NetworkIDObject.h"
#include "DS_Hash.h"
#include "DS_OrderedList.h"

Classes

class | RakNet::RPC4GlobalRegistration
Instantiate this class globally if you want to register a function with RPC4 at the global space. More...
class | RakNet::RPC4
The RPC4 plugin is just an association between a C function pointer and a string. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Enumerations

enum RakNet::RPCErrorCodes {
RakNet::RPC_ERROR_FUNCTION_NOT_REGISTERED, RakNet::RPC_ERROR_NETWORK_ID_MANAGER_UNAVAILABLE, RakNet::RPC_ERROR_OBJECT_DOES_NOT_EXIST, RakNet::RPC_ERROR_FUNCTION_INDEX_OUT_OF_RANGE,
RakNet::RPC_ERROR_FUNCTION_NOT_REGISTERED, RakNet::RPC_ERROR_FUNCTION_NO_LONGER_REGISTERED, RakNet::RPC_ERROR_CALLING_CPP_AS_C, RakNet::RPC_ERROR_CALLING_C_AS_CPP
}
Error codes returned by a remote system as to why an RPC function call cannot execute. More...

Detailed Description

Remote procedure call, supporting C functions only. No external dependencies required.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/SecureHandshake.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
SecureHandshake.h File Reference
#include "NativeFeatureIncludes.h"

Detailed Description

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/SimpleMutex.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
SimpleMutex.h File Reference

[Internal] Encapsulates a mutex More...

#include "RakMemoryOverride.h"
#include <pthread.h>
#include <sys/types.h>
#include "Export.h"

Classes

class RakNet::SimpleMutex
An easy to use mutex. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

[Internal] Encapsulates a mutex

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/SingleProducerConsumer.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
SingleProducerConsumer.h File Reference

[Internal] Passes queued data between threads using a circular buffer with read and write pointers More...

#include "RakAssert.h"
#include "RakMemoryOverride.h"
#include "Export.h"

Classes

class DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
A single producer consumer implementation without critical sections. More...

Namespaces

namespace DataStructures

Detailed Description

[Internal] Passes queued data between threads using a circular buffer with read and write pointers

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/SocketLayer.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Namespaces
SocketLayer.h File Reference

SocketLayer class implementation. More...

#include "RakMemoryOverride.h"
#include "RakNetTypes.h"
#include "RakNetSmartPtr.h"
#include "Export.h"
#include "MTUSize.h"
#include "RakString.h"

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

SocketLayer class implementation.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/StatisticsHistory.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
StatisticsHistory.h File Reference

Input numerical values over time. Get sum, average, highest, lowest, standard deviation on recent or all-time values This file is part of RakNet Copyright 2003 Jenkins Software LLC. More...

#include "NativeFeatureIncludes.h"
#include "PluginInterface2.h"
#include "RakMemoryOverride.h"
#include "NativeTypes.h"
#include "DS_List.h"
#include "RakNetTypes.h"
#include "DS_OrderedList.h"
#include "RakString.h"
#include "DS_Queue.h"
#include "DS_Hash.h"
#include <float.h>

Classes

class | RakNet::StatisticsHistory
Input numerical values over time. Get sum, average, highest, lowest, standard deviation on recent or all-time values. More...
class | RakNet::StatisticsHistoryPlugin
Input numerical values over time. Get sum, average, highest, lowest, standard deviation on recent or all-time values. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Input numerical values over time. Get sum, average, highest, lowest, standard deviation on recent or all-time values This file is part of RakNet Copyright 2003 Jenkins Software LLC.

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/StringCompressor.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
StringCompressor.h File Reference

Compresses/Decompresses ASCII strings and writes/reads them to BitStream class instances. You can use this to easily serialize and deserialize your own strings. More...

#include "Export.h"
#include "DS_Map.h"
#include "RakMemoryOverride.h"
#include "NativeTypes.h"

Classes

class RakNet::StringCompressor
Writes and reads strings to and from bitstreams. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Compresses/Decompresses ASCII strings and writes/reads them to BitStream class instances. You can use this to easily serialize and deserialize your own strings.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/StringTable.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces | Typedefs
StringTable.h File Reference

A simple class to encode and decode known strings based on a lookup table. Similar to the StringCompressor class. More...

#include "DS_OrderedList.h"
#include "Export.h"
#include "RakMemoryOverride.h"

Classes

struct | StrAndBool
The string plus a bool telling us if this string was copied or not. More...
class | RakNet::StringTable
Writes a string index, instead of the whole string. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Typedefs

typedef unsigned char StringTableType
StringTableType should be the smallest type possible, or else it defeats the purpose of the StringTable class, which is to save bandwidth.

Detailed Description

A simple class to encode and decode known strings based on a lookup table. Similar to the StringCompressor class.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/TCPInterface.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
TCPInterface.h File Reference

A simple TCP based server allowing sends and receives. Can be connected by any TCP client, including telnet. More...

#include "NativeFeatureIncludes.h"
#include "RakMemoryOverride.h"
#include "DS_List.h"
#include "RakNetTypes.h"
#include "Export.h"
#include "RakThread.h"
#include "DS_Queue.h"
#include "SimpleMutex.h"
#include "RakNetDefines.h"
#include "SocketIncludes.h"
#include "DS_ByteQueue.h"
#include "DS_ThreadsafeAllocatingQueue.h"
#include "LocklessTypes.h"
#include "PluginInterface2.h"

Classes

struct RakNet::RemoteClient
Stores information about a remote client. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

A simple TCP based server allowing sends and receives. Can be connected by any TCP client, including telnet.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/TeamBalancer.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces | Typedefs
TeamBalancer.h File Reference

Set and network team selection (supports peer to peer or client/server) More...

#include "NativeFeatureIncludes.h"
#include "PluginInterface2.h"
#include "RakMemoryOverride.h"
#include "NativeTypes.h"
#include "DS_List.h"
#include "RakString.h"

Classes

class RakNet::TeamBalancer
Set and network team selection (supports peer to peer or client/server) More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Typedefs

typedef unsigned char RakNet::TeamId

Detailed Description

Set and network team selection (supports peer to peer or client/server)

Automatically handles transmission and resolution of team selection, including team switching and balancing

Deprecated:
Use TeamManager intead

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/TeamManager.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces | Macros | Typedefs | Enumerations
TeamManager.h File Reference

Automates networking and list management for teams. More...

#include "NativeFeatureIncludes.h"
#include "PluginInterface2.h"
#include "RakMemoryOverride.h"
#include "NativeTypes.h"
#include "DS_List.h"
#include "RakNetTypes.h"
#include "DS_Hash.h"
#include "DS_OrderedList.h"

Classes

struct | RakNet::TeamSelection
Parameter to TM_World::ReferenceTeamMember() More...
class | RakNet::TM_TeamMember
A member of one or more teams. More...
class | RakNet::TM_Team
A team, containing a list of TM_TeamMember instances. More...
class | RakNet::TM_World
Stores a list of teams which may be enforcing a balanced number of members. More...
class | RakNet::TeamManager
Automates networking and list management for teams. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Macros

#define | ALLOW_JOIN_ANY_AVAILABLE_TEAM (1<<0)
Allow members to join this team when they specify TeamSelection::JOIN_ANY_AVAILABLE_TEAM.
#define | ALLOW_JOIN_SPECIFIC_TEAM (1<<1)
Allow members to join this team when they specify TeamSelection::JOIN_SPECIFIC_TEAM.
#define | ALLOW_JOIN_REBALANCING (1<<2)
Allow the host to put members on this team when rebalancing with TM_World::SetBalanceTeams()

Typedefs

typedef unsigned char | RakNet::NoTeamId
A subcategory of not being on a team. For example, 0 may mean no team for a player, while 1 may mean no team for a spectator. Defined by the user.
typedef uint16_t | RakNet::TeamMemberLimit

Enumerations

enum RakNet::JoinTeamType { RakNet::JOIN_ANY_AVAILABLE_TEAM, RakNet::JOIN_SPECIFIC_TEAM, RakNet::JOIN_NO_TEAM }

Detailed Description

Automates networking and list management for teams.

TeamManager provides support for teams. A team is a list of team members. Teams contain properties including the number of team members per team, whether or not tagged teams must have equal numbers of members, and if a team is locked or not to certain entry conditions Team members contain properties including which teams they are on and which teams they want to join if a team is not immediately joinable Advanced functionality includes the ability for a team member to be on multiple teams simultaneously, the ability to swap teams with other members, and the ability to resize the number of members supported per team

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/TelnetTransport.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
TelnetTransport.h File Reference

Contains TelnetTransport , used to supports the telnet transport protocol. Insecure. More...

#include "NativeFeatureIncludes.h"
#include "TransportInterface.h"
#include "DS_List.h"
#include "Export.h"

Classes

class RakNet::TelnetTransport
Use TelnetTransport to easily allow windows telnet to connect to your ConsoleServer. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Contains TelnetTransport , used to supports the telnet transport protocol. Insecure.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/ThreadsafePacketLogger.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
ThreadsafePacketLogger.h File Reference

Derivation of the packet logger to defer the call to WriteLog until the user thread. More...

#include "NativeFeatureIncludes.h"
#include "PacketLogger.h"
#include "SingleProducerConsumer.h"

Classes

class RakNet::ThreadsafePacketLogger
Same as PacketLogger, but writes output in the user thread. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Derivation of the packet logger to defer the call to WriteLog until the user thread.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/TransportInterface.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
TransportInterface.h File Reference

Contains TransportInterface from which you can derive custom transport providers for ConsoleServer. More...

#include "RakNetTypes.h"
#include "Export.h"
#include "RakMemoryOverride.h"

Classes

class RakNet::TransportInterface
Defines an interface that is used to send and receive null-terminated strings. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Contains TransportInterface from which you can derive custom transport providers for ConsoleServer.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/TwoWayAuthentication.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
TwoWayAuthentication.h File Reference

Implements two way authentication. More...

#include "NativeFeatureIncludes.h"
#include "DR_SHA1.h"
#include "PluginInterface2.h"
#include "RakMemoryOverride.h"
#include "NativeTypes.h"
#include "RakString.h"
#include "DS_Hash.h"
#include "DS_Queue.h"

Classes

class RakNet::TwoWayAuthentication
Implements two way authentication. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Implements two way authentication.

Given two systems, each of whom known a common password, verify the password without transmitting it This can be used to determine what permissions are should be allowed to the other system

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/UDPForwarder.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
UDPForwarder.h File Reference

Forwards UDP datagrams. Independent of RakNet's protocol. More...

#include "NativeFeatureIncludes.h"
#include "Export.h"
#include "RakNetTypes.h"
#include "SocketIncludes.h"
#include "UDPProxyCommon.h"
#include "SimpleMutex.h"
#include "RakString.h"
#include "RakThread.h"
#include "DS_Queue.h"
#include "DS_OrderedList.h"
#include "LocklessTypes.h"
#include "DS_ThreadsafeAllocatingQueue.h"

Classes

class RakNet::UDPForwarder
Forwards UDP datagrams. Independent of RakNet's protocol. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Forwards UDP datagrams. Independent of RakNet's protocol.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/UDPProxyClient.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
UDPProxyClient.h File Reference

A RakNet plugin performing networking to communicate with UDPProxyCoordinator. Ultimately used to tell UDPProxyServer to forward UDP packets. More...

#include "NativeFeatureIncludes.h"
#include "Export.h"
#include "RakNetTypes.h"
#include "PluginInterface2.h"
#include "DS_List.h"

Classes

struct | RakNet::UDPProxyClientResultHandler
class | RakNet::UDPProxyClient
Communicates with UDPProxyCoordinator, in order to find a UDPProxyServer to forward our datagrams. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

A RakNet plugin performing networking to communicate with UDPProxyCoordinator. Ultimately used to tell UDPProxyServer to forward UDP packets.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/UDPProxyCoordinator.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
UDPProxyCoordinator.h File Reference

Essentially maintains a list of servers running UDPProxyServer, and some state management for UDPProxyClient to find a free server to forward datagrams. More...

#include "NativeFeatureIncludes.h"
#include "Export.h"
#include "RakNetTypes.h"
#include "PluginInterface2.h"
#include "RakString.h"
#include "BitStream.h"
#include "DS_Queue.h"
#include "DS_OrderedList.h"

Classes

class RakNet::UDPProxyCoordinator
Middleman between UDPProxyServer and UDPProxyClient, maintaining a list of UDPProxyServer, and managing state for clients to find an available forwarding server. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

Essentially maintains a list of servers running UDPProxyServer, and some state management for UDPProxyClient to find a free server to forward datagrams.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/Source/UDPProxyServer.h File Reference

  • File List
  • File Members
  • D:
  • temp
  • RakNet_PC
  • Source
Classes | Namespaces
UDPProxyServer.h File Reference

A RakNet plugin performing networking to communicate with UDPProxyServer. It allows UDPProxyServer to control our instance of UDPForwarder. More...

#include "NativeFeatureIncludes.h"
#include "Export.h"
#include "RakNetTypes.h"
#include "PluginInterface2.h"
#include "UDPForwarder.h"
#include "RakString.h"

Classes

struct | RakNet::UDPProxyServerResultHandler
class | RakNet::UDPProxyServer
UDPProxyServer to control our instance of UDPForwarder. More...

Namespaces

namespace RakNet
Simple class to send changes between directories. In essence, a simple autopatcher that can be used for transmitting levels, skins, etc.

Detailed Description

A RakNet plugin performing networking to communicate with UDPProxyServer. It allows UDPProxyServer to control our instance of UDPForwarder.

This file is part of RakNet Copyright 2003 Jenkins Software LLC

Usage of RakNet is subject to the appropriate license agreement. Creative Commons Licensees are subject to the license found at http://creativecommons.org/licenses/by-nc/2.5/ Single application licensees are subject to the license found at http://www.jenkinssoftware.com/SingleApplicationLicense.html Custom license users are subject to the terms therein.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: File Members

  • File List
  • File Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • f
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • u
Here is a list of all documented file members with links to the documentation:

- a -

  • ALLOW_JOIN_ANY_AVAILABLE_TEAM : TeamManager.h
  • ALLOW_JOIN_REBALANCING : TeamManager.h
  • ALLOW_JOIN_SPECIFIC_TEAM : TeamManager.h

- b -

  • BITS_TO_BYTES : RakNetTypes.h

- c -

  • CLOUD_SERVER_DATA_STACK_SIZE : CloudServer.h

- d -

  • DefaultMessageIDTypes : MessageIdentifiers.h
  • DEFINE_MULTILIST_PTR_TO_MEMBER_COMPARISONS : DS_Multilist.h

- f -

  • fillBufferMT() : Rand.h
  • frandomMT() : Rand.h

- h -

  • HIGH_PRIORITY : PacketPriority.h

- i -

  • ID_ADVERTISE_SYSTEM : MessageIdentifiers.h
  • ID_ALREADY_CONNECTED : MessageIdentifiers.h
  • ID_AUTOPATCHER_CANNOT_DOWNLOAD_ORIGINAL_UNMODIFIED_FILES : MessageIdentifiers.h
  • ID_AUTOPATCHER_CREATION_LIST : MessageIdentifiers.h
  • ID_AUTOPATCHER_DELETION_LIST : MessageIdentifiers.h
  • ID_AUTOPATCHER_FINISHED_INTERNAL : MessageIdentifiers.h
  • ID_AUTOPATCHER_GET_CHANGELIST_SINCE_DATE : MessageIdentifiers.h
  • ID_AUTOPATCHER_GET_PATCH : MessageIdentifiers.h
  • ID_AUTOPATCHER_PATCH_LIST : MessageIdentifiers.h
  • ID_AUTOPATCHER_REPOSITORY_FATAL_ERROR : MessageIdentifiers.h
  • ID_AUTOPATCHER_RESTART_APPLICATION : MessageIdentifiers.h
  • ID_CLOUD_POST_REQUEST : MessageIdentifiers.h
  • ID_CONNECTED_PING : MessageIdentifiers.h
  • ID_CONNECTED_PONG : MessageIdentifiers.h
  • ID_CONNECTION_ATTEMPT_FAILED : MessageIdentifiers.h
  • ID_CONNECTION_BANNED : MessageIdentifiers.h
  • ID_CONNECTION_LOST : MessageIdentifiers.h
  • ID_CONNECTION_REQUEST : MessageIdentifiers.h
  • ID_CONNECTION_REQUEST_ACCEPTED : MessageIdentifiers.h
  • ID_DDT_DOWNLOAD_REQUEST : MessageIdentifiers.h
  • ID_DETECT_LOST_CONNECTIONS : MessageIdentifiers.h
  • ID_DISCONNECTION_NOTIFICATION : MessageIdentifiers.h
  • ID_DOWNLOAD_PROGRESS : MessageIdentifiers.h
  • ID_FCM2_NEW_HOST : MessageIdentifiers.h
  • ID_FCM2_VERIFIED_JOIN_ACCEPTED : MessageIdentifiers.h
  • ID_FCM2_VERIFIED_JOIN_FAILED : MessageIdentifiers.h
  • ID_FCM2_VERIFIED_JOIN_REJECTED : MessageIdentifiers.h
  • ID_FCM2_VERIFIED_JOIN_START : MessageIdentifiers.h
  • ID_FILE_LIST_REFERENCE_PUSH : MessageIdentifiers.h
  • ID_FILE_LIST_TRANSFER_FILE : MessageIdentifiers.h
  • ID_FILE_LIST_TRANSFER_HEADER : MessageIdentifiers.h
  • ID_INVALID_PASSWORD : MessageIdentifiers.h
  • ID_IP_RECENTLY_CONNECTED : MessageIdentifiers.h
  • ID_LIGHTSPEED_INTEGRATION : MessageIdentifiers.h
  • ID_LOBBY2_SEND_MESSAGE : MessageIdentifiers.h
  • ID_LOBBY_GENERAL : MessageIdentifiers.h
  • ID_NAT_ALREADY_IN_PROGRESS : MessageIdentifiers.h
  • ID_NAT_CLIENT_READY : MessageIdentifiers.h
  • ID_NAT_CONNECT_AT_TIME : MessageIdentifiers.h
  • ID_NAT_CONNECTION_TO_TARGET_LOST : MessageIdentifiers.h
  • ID_NAT_GET_MOST_RECENT_PORT : MessageIdentifiers.h
  • ID_NAT_PUNCHTHROUGH_FAILED : MessageIdentifiers.h
  • ID_NAT_PUNCHTHROUGH_REQUEST : MessageIdentifiers.h
  • ID_NAT_PUNCHTHROUGH_SUCCEEDED : MessageIdentifiers.h
  • ID_NAT_TARGET_NOT_CONNECTED : MessageIdentifiers.h
  • ID_NAT_TARGET_UNRESPONSIVE : MessageIdentifiers.h
  • ID_NAT_TYPE_DETECTION_REQUEST : MessageIdentifiers.h
  • ID_NAT_TYPE_DETECTION_RESULT : MessageIdentifiers.h
  • ID_NEW_INCOMING_CONNECTION : MessageIdentifiers.h
  • ID_NO_FREE_INCOMING_CONNECTIONS : MessageIdentifiers.h
  • ID_OPEN_CONNECTION_REPLY_1 : MessageIdentifiers.h
  • ID_OPEN_CONNECTION_REPLY_2 : MessageIdentifiers.h
  • ID_OPEN_CONNECTION_REQUEST_1 : MessageIdentifiers.h
  • ID_OPEN_CONNECTION_REQUEST_2 : MessageIdentifiers.h
  • ID_OUR_SYSTEM_REQUIRES_SECURITY : MessageIdentifiers.h
  • ID_OUT_OF_BAND_INTERNAL : MessageIdentifiers.h
  • ID_PUBLIC_KEY_MISMATCH : MessageIdentifiers.h
  • ID_RAKVOICE_CLOSE_CHANNEL : MessageIdentifiers.h
  • ID_RAKVOICE_DATA : MessageIdentifiers.h
  • ID_RAKVOICE_OPEN_CHANNEL_REPLY : MessageIdentifiers.h
  • ID_RAKVOICE_OPEN_CHANNEL_REQUEST : MessageIdentifiers.h
  • ID_READY_EVENT_ALL_SET : MessageIdentifiers.h
  • ID_READY_EVENT_FORCE_ALL_SET : MessageIdentifiers.h
  • ID_READY_EVENT_SET : MessageIdentifiers.h
  • ID_READY_EVENT_UNSET : MessageIdentifiers.h
  • ID_REMOTE_CONNECTION_LOST : MessageIdentifiers.h
  • ID_REMOTE_DISCONNECTION_NOTIFICATION : MessageIdentifiers.h
  • ID_REMOTE_NEW_INCOMING_CONNECTION : MessageIdentifiers.h
  • ID_REMOTE_SYSTEM_REQUIRES_PUBLIC_KEY : MessageIdentifiers.h
  • ID_REPLICA_MANAGER_CONSTRUCTION : MessageIdentifiers.h
  • ID_REPLICA_MANAGER_DOWNLOAD_COMPLETE : MessageIdentifiers.h
  • ID_REPLICA_MANAGER_DOWNLOAD_STARTED : MessageIdentifiers.h
  • ID_REPLICA_MANAGER_SCOPE_CHANGE : MessageIdentifiers.h
  • ID_REPLICA_MANAGER_SERIALIZE : MessageIdentifiers.h
  • ID_ROOMS_EXECUTE_FUNC : MessageIdentifiers.h
  • ID_ROUTER_2_FORWARDING_ESTABLISHED : MessageIdentifiers.h
  • ID_ROUTER_2_FORWARDING_NO_PATH : MessageIdentifiers.h
  • ID_ROUTER_2_INTERNAL : MessageIdentifiers.h
  • ID_ROUTER_2_REROUTED : MessageIdentifiers.h
  • ID_RPC_PLUGIN : MessageIdentifiers.h
  • ID_SND_RECEIPT_ACKED : MessageIdentifiers.h
  • ID_SND_RECEIPT_LOSS : MessageIdentifiers.h
  • ID_SQLite3_EXEC : MessageIdentifiers.h
  • ID_SQLite3_UNKNOWN_DB : MessageIdentifiers.h
  • ID_SQLLITE_LOGGER : MessageIdentifiers.h
  • ID_TEAM_BALANCER_REQUESTED_TEAM_FULL : MessageIdentifiers.h
  • ID_TEAM_BALANCER_REQUESTED_TEAM_LOCKED : MessageIdentifiers.h
  • ID_TEAM_BALANCER_TEAM_ASSIGNED : MessageIdentifiers.h
  • ID_TIMESTAMP : MessageIdentifiers.h
  • ID_TRANSPORT_STRING : MessageIdentifiers.h
  • ID_TWO_WAY_AUTHENTICATION_INCOMING_CHALLENGE_FAILURE : MessageIdentifiers.h
  • ID_TWO_WAY_AUTHENTICATION_INCOMING_CHALLENGE_SUCCESS : MessageIdentifiers.h
  • ID_TWO_WAY_AUTHENTICATION_OUTGOING_CHALLENGE_FAILURE : MessageIdentifiers.h
  • ID_TWO_WAY_AUTHENTICATION_OUTGOING_CHALLENGE_TIMEOUT : MessageIdentifiers.h
  • ID_UDP_PROXY_GENERAL : MessageIdentifiers.h
  • ID_UNCONNECTED_PING : MessageIdentifiers.h
  • ID_UNCONNECTED_PING_OPEN_CONNECTIONS : MessageIdentifiers.h
  • ID_UNCONNECTED_PONG : MessageIdentifiers.h
  • ID_XBOX_LOBBY : MessageIdentifiers.h
  • IMMEDIATE_PRIORITY : PacketPriority.h

- l -

  • LOW_PRIORITY : PacketPriority.h

- m -

  • MAXIMUM_MTU_SIZE : MTUSize.h
  • MEDIUM_PRIORITY : PacketPriority.h
  • MESSAGE_FILTER_MAX_MESSAGE_ID : MessageFilter.h
  • ML_ORDERED_LIST : DS_Multilist.h
  • ML_QUEUE : DS_Multilist.h
  • ML_STACK : DS_Multilist.h
  • ML_UNORDERED_LIST : DS_Multilist.h
  • ML_VARIABLE_DURING_RUNTIME : DS_Multilist.h
  • MultilistType : DS_Multilist.h

- n -

  • NETWORK_ID_MANAGER_HASH_LENGTH : NetworkIDManager.h
  • NUMBER_OF_ORDERED_STREAMS : ReliabilityLayer.h
  • NUMBER_OF_RELIABILITIES : PacketPriority.h

- p -

  • PacketPriority : PacketPriority.h
  • PacketReliability : PacketPriority.h

- r -

  • randomMT() : Rand.h
  • RELIABLE : PacketPriority.h
  • RELIABLE_ORDERED : PacketPriority.h
  • RELIABLE_ORDERED_WITH_ACK_RECEIPT : PacketPriority.h
  • RELIABLE_SEQUENCED : PacketPriority.h
  • RELIABLE_WITH_ACK_RECEIPT : PacketPriority.h
  • REPLICA_CANCEL_PROCESS : ReplicaEnums.h
  • REPLICA_PROCESS_AGAIN : ReplicaEnums.h
  • REPLICA_PROCESS_IMPLICIT : ReplicaEnums.h
  • REPLICA_PROCESS_LATER : ReplicaEnums.h
  • REPLICA_PROCESSING_DONE : ReplicaEnums.h
  • ReplicaReturnResult : ReplicaEnums.h

- s -

  • seedMT() : Rand.h
  • SQLite3_STATEMENT_EXECUTE_THREADED : SQLite3ServerPlugin.h
  • StringTableType : StringTable.h

- u -

  • UNRELIABLE : PacketPriority.h
  • UNRELIABLE_SEQUENCED : PacketPriority.h
  • UNRELIABLE_WITH_ACK_RECEIPT : PacketPriority.h
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: File Members

  • File List
  • File Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • fillBufferMT() : Rand.h
  • frandomMT() : Rand.h
  • randomMT() : Rand.h
  • seedMT() : Rand.h
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: File Members

  • File List
  • File Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • StringTableType : StringTable.h
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: File Members

  • File List
  • File Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • DefaultMessageIDTypes : MessageIdentifiers.h
  • MultilistType : DS_Multilist.h
  • PacketPriority : PacketPriority.h
  • PacketReliability : PacketPriority.h
  • ReplicaReturnResult : ReplicaEnums.h
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: File Members

  • File List
  • File Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • h
  • i
  • l
  • m
  • n
  • r
  • u

- h -

  • HIGH_PRIORITY : PacketPriority.h

- i -

  • ID_ADVERTISE_SYSTEM : MessageIdentifiers.h
  • ID_ALREADY_CONNECTED : MessageIdentifiers.h
  • ID_AUTOPATCHER_CANNOT_DOWNLOAD_ORIGINAL_UNMODIFIED_FILES : MessageIdentifiers.h
  • ID_AUTOPATCHER_CREATION_LIST : MessageIdentifiers.h
  • ID_AUTOPATCHER_DELETION_LIST : MessageIdentifiers.h
  • ID_AUTOPATCHER_FINISHED_INTERNAL : MessageIdentifiers.h
  • ID_AUTOPATCHER_GET_CHANGELIST_SINCE_DATE : MessageIdentifiers.h
  • ID_AUTOPATCHER_GET_PATCH : MessageIdentifiers.h
  • ID_AUTOPATCHER_PATCH_LIST : MessageIdentifiers.h
  • ID_AUTOPATCHER_REPOSITORY_FATAL_ERROR : MessageIdentifiers.h
  • ID_AUTOPATCHER_RESTART_APPLICATION : MessageIdentifiers.h
  • ID_CLOUD_POST_REQUEST : MessageIdentifiers.h
  • ID_CONNECTED_PING : MessageIdentifiers.h
  • ID_CONNECTED_PONG : MessageIdentifiers.h
  • ID_CONNECTION_ATTEMPT_FAILED : MessageIdentifiers.h
  • ID_CONNECTION_BANNED : MessageIdentifiers.h
  • ID_CONNECTION_LOST : MessageIdentifiers.h
  • ID_CONNECTION_REQUEST : MessageIdentifiers.h
  • ID_CONNECTION_REQUEST_ACCEPTED : MessageIdentifiers.h
  • ID_DDT_DOWNLOAD_REQUEST : MessageIdentifiers.h
  • ID_DETECT_LOST_CONNECTIONS : MessageIdentifiers.h
  • ID_DISCONNECTION_NOTIFICATION : MessageIdentifiers.h
  • ID_DOWNLOAD_PROGRESS : MessageIdentifiers.h
  • ID_FCM2_NEW_HOST : MessageIdentifiers.h
  • ID_FCM2_VERIFIED_JOIN_ACCEPTED : MessageIdentifiers.h
  • ID_FCM2_VERIFIED_JOIN_FAILED : MessageIdentifiers.h
  • ID_FCM2_VERIFIED_JOIN_REJECTED : MessageIdentifiers.h
  • ID_FCM2_VERIFIED_JOIN_START : MessageIdentifiers.h
  • ID_FILE_LIST_REFERENCE_PUSH : MessageIdentifiers.h
  • ID_FILE_LIST_TRANSFER_FILE : MessageIdentifiers.h
  • ID_FILE_LIST_TRANSFER_HEADER : MessageIdentifiers.h
  • ID_INVALID_PASSWORD : MessageIdentifiers.h
  • ID_IP_RECENTLY_CONNECTED : MessageIdentifiers.h
  • ID_LIGHTSPEED_INTEGRATION : MessageIdentifiers.h
  • ID_LOBBY2_SEND_MESSAGE : MessageIdentifiers.h
  • ID_LOBBY_GENERAL : MessageIdentifiers.h
  • ID_NAT_ALREADY_IN_PROGRESS : MessageIdentifiers.h
  • ID_NAT_CLIENT_READY : MessageIdentifiers.h
  • ID_NAT_CONNECT_AT_TIME : MessageIdentifiers.h
  • ID_NAT_CONNECTION_TO_TARGET_LOST : MessageIdentifiers.h
  • ID_NAT_GET_MOST_RECENT_PORT : MessageIdentifiers.h
  • ID_NAT_PUNCHTHROUGH_FAILED : MessageIdentifiers.h
  • ID_NAT_PUNCHTHROUGH_REQUEST : MessageIdentifiers.h
  • ID_NAT_PUNCHTHROUGH_SUCCEEDED : MessageIdentifiers.h
  • ID_NAT_TARGET_NOT_CONNECTED : MessageIdentifiers.h
  • ID_NAT_TARGET_UNRESPONSIVE : MessageIdentifiers.h
  • ID_NAT_TYPE_DETECTION_REQUEST : MessageIdentifiers.h
  • ID_NAT_TYPE_DETECTION_RESULT : MessageIdentifiers.h
  • ID_NEW_INCOMING_CONNECTION : MessageIdentifiers.h
  • ID_NO_FREE_INCOMING_CONNECTIONS : MessageIdentifiers.h
  • ID_OPEN_CONNECTION_REPLY_1 : MessageIdentifiers.h
  • ID_OPEN_CONNECTION_REPLY_2 : MessageIdentifiers.h
  • ID_OPEN_CONNECTION_REQUEST_1 : MessageIdentifiers.h
  • ID_OPEN_CONNECTION_REQUEST_2 : MessageIdentifiers.h
  • ID_OUR_SYSTEM_REQUIRES_SECURITY : MessageIdentifiers.h
  • ID_OUT_OF_BAND_INTERNAL : MessageIdentifiers.h
  • ID_PUBLIC_KEY_MISMATCH : MessageIdentifiers.h
  • ID_RAKVOICE_CLOSE_CHANNEL : MessageIdentifiers.h
  • ID_RAKVOICE_DATA : MessageIdentifiers.h
  • ID_RAKVOICE_OPEN_CHANNEL_REPLY : MessageIdentifiers.h
  • ID_RAKVOICE_OPEN_CHANNEL_REQUEST : MessageIdentifiers.h
  • ID_READY_EVENT_ALL_SET : MessageIdentifiers.h
  • ID_READY_EVENT_FORCE_ALL_SET : MessageIdentifiers.h
  • ID_READY_EVENT_SET : MessageIdentifiers.h
  • ID_READY_EVENT_UNSET : MessageIdentifiers.h
  • ID_REMOTE_CONNECTION_LOST : MessageIdentifiers.h
  • ID_REMOTE_DISCONNECTION_NOTIFICATION : MessageIdentifiers.h
  • ID_REMOTE_NEW_INCOMING_CONNECTION : MessageIdentifiers.h
  • ID_REMOTE_SYSTEM_REQUIRES_PUBLIC_KEY : MessageIdentifiers.h
  • ID_REPLICA_MANAGER_CONSTRUCTION : MessageIdentifiers.h
  • ID_REPLICA_MANAGER_DOWNLOAD_COMPLETE : MessageIdentifiers.h
  • ID_REPLICA_MANAGER_DOWNLOAD_STARTED : MessageIdentifiers.h
  • ID_REPLICA_MANAGER_SCOPE_CHANGE : MessageIdentifiers.h
  • ID_REPLICA_MANAGER_SERIALIZE : MessageIdentifiers.h
  • ID_ROOMS_EXECUTE_FUNC : MessageIdentifiers.h
  • ID_ROUTER_2_FORWARDING_ESTABLISHED : MessageIdentifiers.h
  • ID_ROUTER_2_FORWARDING_NO_PATH : MessageIdentifiers.h
  • ID_ROUTER_2_INTERNAL : MessageIdentifiers.h
  • ID_ROUTER_2_REROUTED : MessageIdentifiers.h
  • ID_RPC_PLUGIN : MessageIdentifiers.h
  • ID_SND_RECEIPT_ACKED : MessageIdentifiers.h
  • ID_SND_RECEIPT_LOSS : MessageIdentifiers.h
  • ID_SQLite3_EXEC : MessageIdentifiers.h
  • ID_SQLite3_UNKNOWN_DB : MessageIdentifiers.h
  • ID_SQLLITE_LOGGER : MessageIdentifiers.h
  • ID_TEAM_BALANCER_REQUESTED_TEAM_FULL : MessageIdentifiers.h
  • ID_TEAM_BALANCER_REQUESTED_TEAM_LOCKED : MessageIdentifiers.h
  • ID_TEAM_BALANCER_TEAM_ASSIGNED : MessageIdentifiers.h
  • ID_TIMESTAMP : MessageIdentifiers.h
  • ID_TRANSPORT_STRING : MessageIdentifiers.h
  • ID_TWO_WAY_AUTHENTICATION_INCOMING_CHALLENGE_FAILURE : MessageIdentifiers.h
  • ID_TWO_WAY_AUTHENTICATION_INCOMING_CHALLENGE_SUCCESS : MessageIdentifiers.h
  • ID_TWO_WAY_AUTHENTICATION_OUTGOING_CHALLENGE_FAILURE : MessageIdentifiers.h
  • ID_TWO_WAY_AUTHENTICATION_OUTGOING_CHALLENGE_TIMEOUT : MessageIdentifiers.h
  • ID_UDP_PROXY_GENERAL : MessageIdentifiers.h
  • ID_UNCONNECTED_PING : MessageIdentifiers.h
  • ID_UNCONNECTED_PING_OPEN_CONNECTIONS : MessageIdentifiers.h
  • ID_UNCONNECTED_PONG : MessageIdentifiers.h
  • ID_XBOX_LOBBY : MessageIdentifiers.h
  • IMMEDIATE_PRIORITY : PacketPriority.h

- l -

  • LOW_PRIORITY : PacketPriority.h

- m -

  • MEDIUM_PRIORITY : PacketPriority.h
  • ML_ORDERED_LIST : DS_Multilist.h
  • ML_QUEUE : DS_Multilist.h
  • ML_STACK : DS_Multilist.h
  • ML_UNORDERED_LIST : DS_Multilist.h
  • ML_VARIABLE_DURING_RUNTIME : DS_Multilist.h

- n -

  • NUMBER_OF_RELIABILITIES : PacketPriority.h

- r -

  • RELIABLE : PacketPriority.h
  • RELIABLE_ORDERED : PacketPriority.h
  • RELIABLE_ORDERED_WITH_ACK_RECEIPT : PacketPriority.h
  • RELIABLE_SEQUENCED : PacketPriority.h
  • RELIABLE_WITH_ACK_RECEIPT : PacketPriority.h
  • REPLICA_CANCEL_PROCESS : ReplicaEnums.h
  • REPLICA_PROCESS_AGAIN : ReplicaEnums.h
  • REPLICA_PROCESS_IMPLICIT : ReplicaEnums.h
  • REPLICA_PROCESS_LATER : ReplicaEnums.h
  • REPLICA_PROCESSING_DONE : ReplicaEnums.h

- u -

  • UNRELIABLE : PacketPriority.h
  • UNRELIABLE_SEQUENCED : PacketPriority.h
  • UNRELIABLE_WITH_ACK_RECEIPT : PacketPriority.h
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: File Members

  • File List
  • File Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • ALLOW_JOIN_ANY_AVAILABLE_TEAM : TeamManager.h
  • ALLOW_JOIN_REBALANCING : TeamManager.h
  • ALLOW_JOIN_SPECIFIC_TEAM : TeamManager.h
  • BITS_TO_BYTES : RakNetTypes.h
  • CLOUD_SERVER_DATA_STACK_SIZE : CloudServer.h
  • DEFINE_MULTILIST_PTR_TO_MEMBER_COMPARISONS : DS_Multilist.h
  • MAXIMUM_MTU_SIZE : MTUSize.h
  • MESSAGE_FILTER_MAX_MESSAGE_ID : MessageFilter.h
  • NETWORK_ID_MANAGER_HASH_LENGTH : NetworkIDManager.h
  • NUMBER_OF_ORDERED_STREAMS : ReliabilityLayer.h
  • SQLite3_STATEMENT_EXECUTE_THREADED : SQLite3ServerPlugin.h
Generated on Mon Jun 2 2014 20:10:31 for RakNet by doxygen 1.8.2


RakNet: Member List

CheckSum Member List

This is the complete list of members for CheckSum, including all inherited members.

CheckSum() CheckSum inline
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • DataStructures
  • AVLBalancedBinarySearchTree
DataStructures::AVLBalancedBinarySearchTree< BinarySearchTreeType > Member List

This is the complete list of members for DataStructures::AVLBalancedBinarySearchTree< BinarySearchTreeType >, including all inherited members.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • DataStructures
  • BinarySearchTree
DataStructures::BinarySearchTree< BinarySearchTreeType > Member List

This is the complete list of members for DataStructures::BinarySearchTree< BinarySearchTreeType >, including all inherited members.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • DataStructures
  • BPlusTree
DataStructures::BPlusTree< KeyType, DataType, order > Member List

This is the complete list of members for DataStructures::BPlusTree< KeyType, DataType, order >, including all inherited members.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • DataStructures
  • CircularLinkedList
DataStructures::CircularLinkedList< CircularLinkedListType > Member List

This is the complete list of members for DataStructures::CircularLinkedList< CircularLinkedListType >, including all inherited members.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • DataStructures
  • Hash
DataStructures::Hash< key_type, data_type, HASH_SIZE, hashFunction > Member List

This is the complete list of members for DataStructures::Hash< key_type, data_type, HASH_SIZE, hashFunction >, including all inherited members.

Clear(const char *file, unsigned int line) | DataStructures::Hash< key_type, data_type, HASH_SIZE, hashFunction >
Hash() | DataStructures::Hash< key_type, data_type, HASH_SIZE, hashFunction >
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • DataStructures
  • List
DataStructures::List< list_type > Member List

This is the complete list of members for DataStructures::List< list_type >, including all inherited members.

Clear(bool doNotDeallocateSmallBlocks, const char *file, unsigned int line) | DataStructures::List< list_type > |
Compress(const char *file, unsigned int line) | DataStructures::List< list_type > |
Get(const unsigned int position) const | DataStructures::List< list_type > | inline
GetIndexOf(const list_type &input) const | DataStructures::List< list_type > |
Insert(const list_type &input, const unsigned int position, const char *file, unsigned int line) | DataStructures::List< list_type > |
Insert(const list_type &input, const char *file, unsigned int line) | DataStructures::List< list_type > |
List() | DataStructures::List< list_type > |
List(const List &original_copy) | DataStructures::List< list_type > |
operator=(const List &original_copy) | DataStructures::List< list_type > |
operator[](const unsigned int position) const | DataStructures::List< list_type > | inline
Pop(void) | DataStructures::List< list_type > | inline
Preallocate(unsigned countNeeded, const char *file, unsigned int line) | DataStructures::List< list_type > |
Push(const list_type &input, const char *file, unsigned int line) | DataStructures::List< list_type > |
RemoveAtIndex(const unsigned int position) | DataStructures::List< list_type > |
RemoveAtIndexFast(const unsigned int position) | DataStructures::List< list_type > |
RemoveFromEnd(const unsigned num=1) | DataStructures::List< list_type > | inline
Replace(const list_type &input, const list_type filler, const unsigned int position, const char *file, unsigned int line) | DataStructures::List< list_type > | inline
Replace(const list_type &input) | DataStructures::List< list_type > | inline
Size(void) const | DataStructures::List< list_type > | inline
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • DataStructures
  • Map
DataStructures::Map< key_type, data_type, key_comparison_func > Member List

This is the complete list of members for DataStructures::Map< key_type, data_type, key_comparison_func >, including all inherited members.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • DataStructures
  • MemoryPool
DataStructures::MemoryPool< MemoryBlockType > Member List

This is the complete list of members for DataStructures::MemoryPool< MemoryBlockType >, including all inherited members.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • DataStructures
  • MLKeyRef
DataStructures::MLKeyRef< templateType > Member List

This is the complete list of members for DataStructures::MLKeyRef< templateType >, including all inherited members.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • DataStructures
  • Multilist
DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > Member List

This is the complete list of members for DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType >, including all inherited members.

allocationSize | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > | protected
Clear(bool deallocateSmallBlocks=true, const char *file=__FILE__, unsigned int line=__LINE__) | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
ClearPointer(_KeyType key, const char *file=__FILE__, unsigned int line=__LINE__) | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
ClearPointers(bool deallocateSmallBlocks=true, const char *file=__FILE__, unsigned int line=__LINE__) | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
data | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > | protected
dataSize | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > | protected
FindIntersection(Multilist &source1, Multilist &source2, Multilist &intersection, Multilist &uniqueToSource1, Multilist &uniqueToSource2) | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > | static
ForEach(void(*func)(_DataType &item, const char *file, unsigned int line), const char *file, unsigned int line) | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
GetIndexOf(_KeyType key) const | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
GetInsertionIndex(_KeyType key) const | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
GetMultilistType(void) const | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
GetPtr(_KeyType key) const | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
GetSize(void) const | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
GetSortOrder(void) const | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
InsertAtIndex(const _DataType &d, _IndexType index, const char *file=__FILE__, unsigned int line=__LINE__) | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
IsEmpty(void) const | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
IsSorted(void) const | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
Pop(const char *file=__FILE__, unsigned int line=__LINE__) | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
PopOpposite(const char *file=__FILE__, unsigned int line=__LINE__) | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
preallocationSize | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > | protected
Push(const _DataType &d, const char *file=__FILE__, unsigned int line=__LINE__) | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
PushOpposite(const _DataType &d, const char *file=__FILE__, unsigned int line=__LINE__) | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
queueHead | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > | protected
queueTail | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > | protected
Reallocate(_IndexType size, const char *file=__FILE__, unsigned int line=__LINE__) | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
RemoveAtIndex(_IndexType position, const char *file=__FILE__, unsigned int line=__LINE__) | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
RemoveAtKey(_KeyType key, bool assertIfDoesNotExist, const char *file=__FILE__, unsigned int line=__LINE__) | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
ReverseList(void) | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
SetMultilistType(MultilistType newType) | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
SetSortOrder(bool ascending) | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
Sort(bool force) | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
TagSorted(void) | DataStructures::Multilist< _MultilistType, _DataType, _KeyType, _IndexType > |
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • DataStructures
  • OrderedList
DataStructures::OrderedList< key_type, data_type, default_comparison_function > Member List

This is the complete list of members for DataStructures::OrderedList< key_type, data_type, default_comparison_function >, including all inherited members.

HasData(const key_type &key, int(*cf)(const key_type &, const data_type &)=default_comparison_function) const DataStructures::OrderedList< key_type, data_type, default_comparison_function >
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • DataStructures
  • Queue
DataStructures::Queue< queue_type > Member List

This is the complete list of members for DataStructures::Queue< queue_type >, including all inherited members.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • DataStructures
  • QueueLinkedList
DataStructures::QueueLinkedList< QueueType > Member List

This is the complete list of members for DataStructures::QueueLinkedList< QueueType >, including all inherited members.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • DataStructures
  • SingleProducerConsumer
DataStructures::SingleProducerConsumer< SingleProducerConsumerType > Member List

This is the complete list of members for DataStructures::SingleProducerConsumer< SingleProducerConsumerType >, including all inherited members.

CancelReadLock(SingleProducerConsumerType *cancelToLocation) | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
CancelWriteLock(SingleProducerConsumerType *cancelToLocation) | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
CheckReadUnlockOrder(const SingleProducerConsumerType *data) const | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
Clear(void) | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
ReadIsLocked(void) const | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
ReadLock(void) | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
ReadUnlock(void) | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
Size(void) const | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
WriteLock(void) | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
WriteUnlock(void) | DataStructures::SingleProducerConsumer< SingleProducerConsumerType >
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • DataStructures
  • Table
DataStructures::Table Member List

This is the complete list of members for DataStructures::Table, including all inherited members.

AddColumn(const char columnName[_TABLE_MAX_COLUMN_NAME_LENGTH], ColumnType columnType) | DataStructures::Table
AddRow(unsigned rowId) | DataStructures::Table
Clear(void) | DataStructures::Table
ColumnIndex(char columnName[_TABLE_MAX_COLUMN_NAME_LENGTH]) const | DataStructures::Table
ColumnName(unsigned index) const | DataStructures::Table
GetAvailableRowId(void) const | DataStructures::Table
GetCellValueByIndex(unsigned rowIndex, unsigned columnIndex, int *output) | DataStructures::Table
GetColumnCount(void) const | DataStructures::Table
GetColumns(void) const | DataStructures::Table
GetColumnType(unsigned index) const | DataStructures::Table
GetListHead(void) | DataStructures::Table
GetRowByID(unsigned rowId) const | DataStructures::Table
GetRowByIndex(unsigned rowIndex, unsigned *key) const | DataStructures::Table
GetRowCount(void) const | DataStructures::Table
GetRows(void) const | DataStructures::Table
PrintColumnHeaders(char *out, int outLength, char columnDelineator) const | DataStructures::Table
PrintRow(char *out, int outLength, char columnDelineator, bool printDelineatorForBinary, Table::Row *inputRow) const | DataStructures::Table
QueryTable(unsigned *columnIndicesSubset, unsigned numColumnSubset, FilterQuery *inclusionFilters, unsigned numInclusionFilters, unsigned *rowIds, unsigned numRowIDs, Table *result) | DataStructures::Table
RemoveColumn(unsigned columnIndex) | DataStructures::Table
RemoveRow(unsigned rowId) | DataStructures::Table
RemoveRows(Table *tableContainingRowIDs) | DataStructures::Table
SortQueryType enum name | DataStructures::Table
SortTable(Table::SortQuery *sortQueries, unsigned numSortQueries, Table::Row **out) | DataStructures::Table
UpdateCell(unsigned rowId, unsigned columnIndex, int value) | DataStructures::Table
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

MemoryCompressor Member List

This is the complete list of members for MemoryCompressor, including all inherited members.

Clear(void) | MemoryCompressor
Compress(char *input, const unsigned inputLength, bool finish) | MemoryCompressor
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • AutopatcherMySQLRepository
RakNet::AutopatcherMySQLRepository Member List

This is the complete list of members for RakNet::AutopatcherMySQLRepository, including all inherited members.

AddApplication(const char *applicationName, const char *userName) | RakNet::AutopatcherMySQLRepository |
CreateAutopatcherTables(void) | RakNet::AutopatcherMySQLRepository |
DestroyAutopatcherTables(void) | RakNet::AutopatcherMySQLRepository |
GetChangelistSinceDate(const char *applicationName, FileList *addedOrModifiedFilesWithHashData, FileList *deletedFiles, double sinceDate) | RakNet::AutopatcherMySQLRepository | virtual
GetFilePart(const char *filename, unsigned int startReadBytes, unsigned int numBytesToRead, void *preallocatedDestination, FileListNodeContext context) | RakNet::AutopatcherMySQLRepository | virtual
GetIncrementalReadChunkSize(void) const | RakNet::AutopatcherMySQLRepository | virtual
GetLastError(void) const | RakNet::AutopatcherMySQLRepository | virtual
GetMostRecentChangelistWithPatches(RakNet::RakString &applicationName, FileList *patchedFiles, FileList *addedFiles, FileList *addedOrModifiedFileHashes, FileList *deletedFiles, double *priorRowPatchTime, double *mostRecentRowPatchTime) | RakNet::AutopatcherMySQLRepository | virtual
GetPatches(const char *applicationName, FileList *input, bool allowDownloadOfOriginalUnmodifiedFiles, FileList *patchList) | RakNet::AutopatcherMySQLRepository | virtual
RemoveApplication(const char *applicationName) | RakNet::AutopatcherMySQLRepository |
UpdateApplicationFiles(const char *applicationName, const char *applicationDirectory, const char *userName, FileListProgress *cb) | RakNet::AutopatcherMySQLRepository |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • AutopatcherPostgreRepository
RakNet::AutopatcherPostgreRepository Member List

This is the complete list of members for RakNet::AutopatcherPostgreRepository, including all inherited members.

AddApplication(const char *applicationName, const char *userName) | RakNet::AutopatcherPostgreRepository |
CreateAutopatcherTables(void) | RakNet::AutopatcherPostgreRepository | virtual
DestroyAutopatcherTables(void) | RakNet::AutopatcherPostgreRepository |
GetChangelistSinceDate(const char *applicationName, FileList *addedOrModifiedFilesWithHashData, FileList *deletedFiles, double sinceDate) | RakNet::AutopatcherPostgreRepository | virtual
GetFilePart(const char *filename, unsigned int startReadBytes, unsigned int numBytesToRead, void *preallocatedDestination, FileListNodeContext context) | RakNet::AutopatcherPostgreRepository | virtual
GetIncrementalReadChunkSize(void) const | RakNet::AutopatcherPostgreRepository | virtual
GetLastError(void) const | RakNet::AutopatcherPostgreRepository | virtual
GetMostRecentChangelistWithPatches(RakNet::RakString &applicationName, FileList *patchedFiles, FileList *addedFiles, FileList *addedOrModifiedFileHashes, FileList *deletedFiles, double *priorRowPatchTime, double *mostRecentRowPatchTime) | RakNet::AutopatcherPostgreRepository | virtual
GetPatches(const char *applicationName, FileList *input, bool allowDownloadOfOriginalUnmodifiedFiles, FileList *patchList) | RakNet::AutopatcherPostgreRepository | virtual
RemoveApplication(const char *applicationName) | RakNet::AutopatcherPostgreRepository |
UpdateApplicationFiles(const char *applicationName, const char *applicationDirectory, const char *userName, FileListProgress *cb) | RakNet::AutopatcherPostgreRepository | virtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • AutopatcherRepositoryInterface
RakNet::AutopatcherRepositoryInterface Member List

This is the complete list of members for RakNet::AutopatcherRepositoryInterface, including all inherited members.

GetChangelistSinceDate(const char *applicationName, FileList *addedOrModifiedFilesWithHashData, FileList *deletedFiles, double sinceDate)=0 | RakNet::AutopatcherRepositoryInterface | pure virtual
GetIncrementalReadChunkSize(void) const =0 | RakNet::AutopatcherRepositoryInterface | pure virtual
GetLastError(void) const =0 | RakNet::AutopatcherRepositoryInterface | pure virtual
GetMostRecentChangelistWithPatches(RakNet::RakString &applicationName, FileList *patchedFiles, FileList *updatedFiles, FileList *addedOrModifiedFileHashes, FileList *deletedFiles, double *priorRowPatchTime, double *mostRecentRowPatchTime)=0 | RakNet::AutopatcherRepositoryInterface | pure virtual
GetPatches(const char *applicationName, FileList *input, bool allowDownloadOfOriginalUnmodifiedFiles, FileList *patchList)=0 | RakNet::AutopatcherRepositoryInterface | pure virtual
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • AutopatcherServer
RakNet::AutopatcherServer Member List

This is the complete list of members for RakNet::AutopatcherServer, including all inherited members.

CacheMostRecentPatch(const char *applicationName) | RakNet::AutopatcherServer |
Clear(void) | RakNet::AutopatcherServer |
GetMaxConurrentUsers(void) const | RakNet::AutopatcherServer |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAddFilesFromDirectoryStarted(FileList *fileList, char *dir) | RakNet::FileListProgress | inlineprivatevirtual
OnAttach(void) | RakNet::AutopatcherServer | virtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::AutopatcherServer | virtual
OnDetach(void) | RakNet::AutopatcherServer | virtual
OnDirectory(FileList *fileList, char *dir, unsigned int directoriesRemaining) | RakNet::FileListProgress | inlineprivatevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnFile(FileList *fileList, char *dir, char *fileName, unsigned int fileSize) | RakNet::FileListProgress | inlineprivatevirtual
OnFilePush(const char *fileName, unsigned int fileLengthBytes, unsigned int offset, unsigned int bytesBeingSent, bool done, SystemAddress targetSystem, unsigned short setId) | RakNet::FileListProgress | inlineprivatevirtual
OnFilePushesComplete(SystemAddress systemAddress, unsigned short setID) | RakNet::AutopatcherServer | protectedvirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::AutopatcherServer | virtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
OnSendAborted(SystemAddress systemAddress) | RakNet::AutopatcherServer | protectedvirtual
SetAllowDownloadOfOriginalUnmodifiedFiles(bool allow) | RakNet::AutopatcherServer |
SetFileListTransferPlugin(FileListTransfer *flt) | RakNet::AutopatcherServer |
SetLoadManagementCallback(AutopatcherServerLoadNotifier *asumc) | RakNet::AutopatcherServer |
SetMaxConurrentUsers(unsigned int _maxConcurrentUsers) | RakNet::AutopatcherServer |
SetUploadSendParameters(PacketPriority _priority, char _orderingChannel) | RakNet::AutopatcherServer |
StartThreads(int numThreads, int numSQLConnections, AutopatcherRepositoryInterface **sqlConnectionPtrArray) | RakNet::AutopatcherServer |
Update(void) | RakNet::AutopatcherServer | virtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • AutopatcherServerLoadNotifier_Printf
RakNet::AutopatcherServerLoadNotifier_Printf Member List

This is the complete list of members for RakNet::AutopatcherServerLoadNotifier_Printf, including all inherited members.

Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • BitStream
RakNet::BitStream Member List

This is the complete list of members for RakNet::BitStream, including all inherited members.

AddBitsAndReallocate(const BitSize_t numberOfBitsToWrite) | RakNet::BitStream |
AlignReadToByteBoundary(void) | RakNet::BitStream | inline
AlignWriteToByteBoundary(void) | RakNet::BitStream | inline
AssertCopyData(void) | RakNet::BitStream |
AssertStreamEmpty(void) | RakNet::BitStream |
BitStream() | RakNet::BitStream |
BitStream(const unsigned int initialBytesToAllocate) | RakNet::BitStream |
BitStream(unsigned char *_data, const unsigned int lengthInBytes, bool _copyData) | RakNet::BitStream |
CopyData(unsigned char **_data) const | RakNet::BitStream |
DoEndianSwap(void) | RakNet::BitStream | inlinestatic
GetData(void) const | RakNet::BitStream | inline
GetNumberOfBitsUsed(void) const | RakNet::BitStream | inline
GetNumberOfBytesUsed(void) const | RakNet::BitStream | inline
GetNumberOfUnreadBits(void) const | RakNet::BitStream | inline
GetReadOffset(void) const | RakNet::BitStream | inline
IgnoreBits(const BitSize_t numberOfBits) | RakNet::BitStream |
IgnoreBytes(const unsigned int numberOfBytes) | RakNet::BitStream |
NumberOfLeadingZeroes(uint8_t x) | RakNet::BitStream | static
PadWithZeroToByteLength(unsigned int bytes) | RakNet::BitStream |
PrintBits(char *out) const | RakNet::BitStream |
Read(templateType &outTemplateVar) | RakNet::BitStream | inline
Read(BitStream *bitStream, BitSize_t numberOfBits) | RakNet::BitStream |
Read(char *output, const unsigned int numberOfBytes) | RakNet::BitStream |
Read(char *varString) | RakNet::BitStream |
Read(bool &outTemplateVar) | RakNet::BitStream | inline
Read(SystemAddress &outTemplateVar) | RakNet::BitStream | inline
ReadAlignedBytes(unsigned char *inOutByteArray, const unsigned int numberOfBytesToRead) | RakNet::BitStream |
ReadAlignedBytesSafe(char *inOutByteArray, int &inputLength, const int maxBytesToRead) | RakNet::BitStream |
ReadAlignedBytesSafeAlloc(char **outByteArray, int &inputLength, const unsigned int maxBytesToRead) | RakNet::BitStream |
ReadBit(void) | RakNet::BitStream |
ReadBits(unsigned char *inOutByteArray, BitSize_t numberOfBitsToRead, const bool alignBitsToRight=true) | RakNet::BitStream |
ReadBitsFromIntegerRange(templateType &value, const templateType minimum, const templateType maximum, bool allowOutsideRange=false) | RakNet::BitStream |
ReadBitsFromIntegerRange(templateType &value, const templateType minimum, const templateType maximum, const int requiredBits, bool allowOutsideRange=false) | RakNet::BitStream |
ReadCasted(sourceType &value) | RakNet::BitStream |
ReadCompressed(templateType &outTemplateVar) | RakNet::BitStream | inline
ReadCompressed(float &outTemplateVar) | RakNet::BitStream | inline
ReadCompressed(double &outTemplateVar) | RakNet::BitStream | inline
ReadCompressed(RakString &outTemplateVar) | RakNet::BitStream | inline
ReadCompressedDelta(templateType &outTemplateVar) | RakNet::BitStream | inline
ReadCompressedDelta(bool &outTemplateVar) | RakNet::BitStream | inline
ReadDelta(templateType &outTemplateVar) | RakNet::BitStream | inline
ReadDelta(bool &outTemplateVar) | RakNet::BitStream | inline
ReadFloat16(float &outFloat, float floatMin, float floatMax) | RakNet::BitStream |
ReadNormQuat(templateType &w, templateType &x, templateType &y, templateType &z) | RakNet::BitStream |
ReadNormVector(templateType &x, templateType &y, templateType &z) | RakNet::BitStream |
ReadOrthMatrix(templateType &m00, templateType &m01, templateType &m02, templateType &m10, templateType &m11, templateType &m12, templateType &m20, templateType &m21, templateType &m22) | RakNet::BitStream |
ReadVector(templateType &x, templateType &y, templateType &z) | RakNet::BitStream |
Reset(void) | RakNet::BitStream |
ResetReadPointer(void) | RakNet::BitStream |
ResetWritePointer(void) | RakNet::BitStream |
Serialize(bool writeToBitstream, templateType &inOutTemplateVar) | RakNet::BitStream | inline
Serialize(bool writeToBitstream, char *inOutByteArray, const unsigned int numberOfBytes) | RakNet::BitStream | inline
SerializeBits(bool writeToBitstream, unsigned char *inOutByteArray, const BitSize_t numberOfBitsToSerialize, const bool rightAlignedBits=true) | RakNet::BitStream | inline
SerializeBitsFromIntegerRange(bool writeToBitstream, templateType &value, const templateType minimum, const templateType maximum, bool allowOutsideRange=false) | RakNet::BitStream |
SerializeBitsFromIntegerRange(bool writeToBitstream, templateType &value, const templateType minimum, const templateType maximum, const int requiredBits, bool allowOutsideRange=false) | RakNet::BitStream |
SerializeCasted(bool writeToBitstream, sourceType &value) | RakNet::BitStream |
SerializeCompressed(bool writeToBitstream, templateType &inOutTemplateVar) | RakNet::BitStream | inline
SerializeCompressedDelta(bool writeToBitstream, templateType &inOutCurrentValue, const templateType &lastValue) | RakNet::BitStream | inline
SerializeCompressedDelta(bool writeToBitstream, templateType &inOutTemplateVar) | RakNet::BitStream | inline
SerializeDelta(bool writeToBitstream, templateType &inOutCurrentValue, const templateType &lastValue) | RakNet::BitStream | inline
SerializeDelta(bool writeToBitstream, templateType &inOutCurrentValue) | RakNet::BitStream | inline
SerializeFloat16(bool writeToBitstream, float &inOutFloat, float floatMin, float floatMax) | RakNet::BitStream |
SerializeNormQuat(bool writeToBitstream, templateType &w, templateType &x, templateType &y, templateType &z) | RakNet::BitStream | inline
SerializeNormVector(bool writeToBitstream, templateType &x, templateType &y, templateType &z) | RakNet::BitStream | inline
SerializeOrthMatrix(bool writeToBitstream, templateType &m00, templateType &m01, templateType &m02, templateType &m10, templateType &m11, templateType &m12, templateType &m20, templateType &m21, templateType &m22) | RakNet::BitStream | inline
SerializeVector(bool writeToBitstream, templateType &x, templateType &y, templateType &z) | RakNet::BitStream | inline
SetNumberOfBitsAllocated(const BitSize_t lengthInBits) | RakNet::BitStream |
SetReadOffset(const BitSize_t newReadOffset) | RakNet::BitStream | inline
SetWriteOffset(const BitSize_t offset) | RakNet::BitStream |
Write(const templateType &inTemplateVar) | RakNet::BitStream | inline
Write(const char *inputByteArray, const unsigned int numberOfBytes) | RakNet::BitStream |
Write(BitStream *bitStream, BitSize_t numberOfBits) | RakNet::BitStream |
Write(const bool &inTemplateVar) | RakNet::BitStream | inline
Write(const SystemAddress &inTemplateVar) | RakNet::BitStream | inline
Write(const RakString &inTemplateVar) | RakNet::BitStream | inline
Write0(void) | RakNet::BitStream |
Write1(void) | RakNet::BitStream |
WriteAlignedBytes(const unsigned char *inByteArray, const unsigned int numberOfBytesToWrite) | RakNet::BitStream |
WriteAlignedBytesSafe(const char *inByteArray, const unsigned int inputLength, const unsigned int maxBytesToWrite) | RakNet::BitStream |
WriteBits(const unsigned char *inByteArray, BitSize_t numberOfBitsToWrite, const bool rightAlignedBits=true) | RakNet::BitStream |
WriteBitsFromIntegerRange(const templateType value, const templateType minimum, const templateType maximum, bool allowOutsideRange=false) | RakNet::BitStream |
WriteBitsFromIntegerRange(const templateType value, const templateType minimum, const templateType maximum, const int requiredBits, bool allowOutsideRange=false) | RakNet::BitStream |
WriteCasted(const sourceType &value) | RakNet::BitStream |
WriteCompressed(const templateType &inTemplateVar) | RakNet::BitStream | inline
WriteCompressed(const float &inTemplateVar) | RakNet::BitStream | inline
WriteCompressed(const double &inTemplateVar) | RakNet::BitStream | inline
WriteCompressed(const RakString &inTemplateVar) | RakNet::BitStream | inline
WriteCompressedDelta(const templateType &currentValue, const templateType &lastValue) | RakNet::BitStream | inline
WriteCompressedDelta(const templateType &currentValue) | RakNet::BitStream | inline
WriteCompressedDelta(const bool &currentValue, const bool &lastValue) | RakNet::BitStream | inline
WriteCompressedDelta(const bool &currentValue) | RakNet::BitStream | inline
WriteDelta(const templateType &currentValue, const templateType &lastValue) | RakNet::BitStream | inline
WriteDelta(const templateType &currentValue) | RakNet::BitStream | inline
WriteDelta(const bool &currentValue, const bool &lastValue) | RakNet::BitStream | inline
WriteFloat16(float x, float floatMin, float floatMax) | RakNet::BitStream |
WriteNormQuat(templateType w, templateType x, templateType y, templateType z) | RakNet::BitStream |
WriteNormVector(templateType x, templateType y, templateType z) | RakNet::BitStream |
WriteOrthMatrix(templateType m00, templateType m01, templateType m02, templateType m10, templateType m11, templateType m12, templateType m20, templateType m21, templateType m22) | RakNet::BitStream |
WritePtr(templateType *inTemplateVar) | RakNet::BitStream | inline
WriteVector(templateType x, templateType y, templateType z) | RakNet::BitStream |
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • CloudAllocator
RakNet::CloudAllocator Member List

This is the complete list of members for RakNet::CloudAllocator, including all inherited members.

AllocateCloudQueryRow(void) | RakNet::CloudAllocator | virtual
AllocateRowData(uint32_t bytesNeededForData) | RakNet::CloudAllocator | virtual
DeallocateCloudQueryRow(CloudQueryRow *row) | RakNet::CloudAllocator | virtual
DeallocateRowData(void *data) | RakNet::CloudAllocator | virtual
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • CloudClient
RakNet::CloudClient Member List

This is the complete list of members for RakNet::CloudClient, including all inherited members.

DeallocateWithDefaultAllocator(CloudQueryResult *cloudQueryResult) | RakNet::CloudClient | virtual
DeallocateWithDefaultAllocator(CloudQueryRow *row) | RakNet::CloudClient | virtual
Get(CloudQuery *cloudQuery, RakNetGUID systemIdentifier) | RakNet::CloudClient | virtual
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::PluginInterface2 | inlinevirtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnGetReponse(Packet *packet, CloudClientCallback *_callback=0, CloudAllocator *_allocator=0) | RakNet::CloudClient | virtual
OnGetReponse(CloudQueryResult *cloudQueryResult, Packet *packet, CloudAllocator *_allocator=0) | RakNet::CloudClient | virtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::CloudClient | protectedvirtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
OnSubscriptionNotification(Packet *packet, CloudClientCallback *_callback=0, CloudAllocator *_allocator=0) | RakNet::CloudClient | virtual
OnSubscriptionNotification(bool *wasUpdated, CloudQueryRow *row, Packet *packet, CloudAllocator *_allocator=0) | RakNet::CloudClient | virtual
Post(CloudKey *cloudKey, const unsigned char *data, uint32_t dataLengthBytes, RakNetGUID systemIdentifier) | RakNet::CloudClient | virtual
Release(DataStructures::List< CloudKey > &keys, RakNetGUID systemIdentifier) | RakNet::CloudClient | virtual
SetDefaultCallbacks(CloudAllocator *_allocator, CloudClientCallback *_callback) | RakNet::CloudClient | virtual
Unsubscribe(DataStructures::List< CloudKey > &keys, RakNetGUID systemIdentifier) | RakNet::CloudClient | virtual
Update(void) | RakNet::PluginInterface2 | inlinevirtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • CloudClientCallback
RakNet::CloudClientCallback Member List

This is the complete list of members for RakNet::CloudClientCallback, including all inherited members.

OnGet(RakNet::CloudQueryResult *result, bool *deallocateRowsAfterReturn) | RakNet::CloudClientCallback | inlinevirtual
OnSubscriptionNotification(RakNet::CloudQueryRow *result, bool wasUpdated, bool *deallocateRowAfterReturn) | RakNet::CloudClientCallback | inlinevirtual
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • CloudServer
RakNet::CloudServer Member List

This is the complete list of members for RakNet::CloudServer, including all inherited members.

AddQueryFilter(CloudServerQueryFilter *filter) | RakNet::CloudServer |
AddServer(RakNetGUID systemIdentifier) | RakNet::CloudServer |
AllocateCloudQueryRow(void) | RakNet::CloudAllocator | privatevirtual
AllocateRowData(uint32_t bytesNeededForData) | RakNet::CloudAllocator | privatevirtual
Clear(void) | RakNet::CloudServer |
DeallocateCloudQueryRow(CloudQueryRow *row) | RakNet::CloudAllocator | privatevirtual
DeallocateRowData(void *data) | RakNet::CloudAllocator | privatevirtual
ForceExternalSystemAddress(SystemAddress forcedAddress) | RakNet::CloudServer |
GetRemoteServers(DataStructures::List< RakNetGUID > &remoteServersOut) | RakNet::CloudServer |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::CloudServer | protectedvirtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::CloudServer | protectedvirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::CloudServer | protectedvirtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
RemoveAllQueryFilters(void) | RakNet::CloudServer |
RemoveQueryFilter(CloudServerQueryFilter *filter) | RakNet::CloudServer |
RemoveServer(RakNetGUID systemIdentifier) | RakNet::CloudServer |
SetMaxBytesPerDownload(uint64_t bytes) | RakNet::CloudServer |
SetMaxUploadBytesPerClient(uint64_t bytes) | RakNet::CloudServer |
Update(void) | RakNet::CloudServer | protectedvirtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • CloudServerQueryFilter
RakNet::CloudServerQueryFilter Member List

This is the complete list of members for RakNet::CloudServerQueryFilter, including all inherited members.

OnGetRequest(RakNetGUID clientGuid, SystemAddress clientAddress, CloudQuery &query, DataStructures::List< RakNetGUID > &specificSystems)=0 | RakNet::CloudServerQueryFilter | pure virtual
OnPostRequest(RakNetGUID clientGuid, SystemAddress clientAddress, CloudKey key, uint32_t dataLength, const char *data)=0 | RakNet::CloudServerQueryFilter | pure virtual
OnReleaseRequest(RakNetGUID clientGuid, SystemAddress clientAddress, DataStructures::List< CloudKey > &cloudKeys)=0 | RakNet::CloudServerQueryFilter | pure virtual
OnUnsubscribeRequest(RakNetGUID clientGuid, SystemAddress clientAddress, DataStructures::List< CloudKey > &cloudKeys, DataStructures::List< RakNetGUID > &specificSystems)=0 | RakNet::CloudServerQueryFilter | pure virtual
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • CommandParserInterface
RakNet::CommandParserInterface Member List

This is the complete list of members for RakNet::CommandParserInterface, including all inherited members.

GetName(void) const =0 | RakNet::CommandParserInterface | pure virtual
OnCommand(const char *command, unsigned numParameters, char **parameterList, TransportInterface *transport, const SystemAddress &systemAddress, const char *originalString)=0 | RakNet::CommandParserInterface | pure virtual
OnConnectionLost(const SystemAddress &systemAddress, TransportInterface *transport) | RakNet::CommandParserInterface | virtual
OnNewIncomingConnection(const SystemAddress &systemAddress, TransportInterface *transport) | RakNet::CommandParserInterface | virtual
OnTransportChange(TransportInterface *transport) | RakNet::CommandParserInterface | virtual
RegisterCommand(unsigned char parameterCount, const char *command, const char *commandHelp) | RakNet::CommandParserInterface | virtual
ReturnResult(bool res, const char *command, TransportInterface *transport, const SystemAddress &systemAddress) | RakNet::CommandParserInterface | virtual
ReturnResult(const char *command, TransportInterface *transport, const SystemAddress &systemAddress) | RakNet::CommandParserInterface | virtual
SendHelp(TransportInterface *transport, const SystemAddress &systemAddress)=0 | RakNet::CommandParserInterface | pure virtual
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Connection_RM3
RakNet::Connection_RM3 Member List

This is the complete list of members for RakNet::Connection_RM3, including all inherited members.

AllocReplica(RakNet::BitStream *allocationIdBitstream, ReplicaManager3 *replicaManager3)=0 | RakNet::Connection_RM3 | pure virtual
ConstructionMode enum name | RakNet::Connection_RM3 |
DeserializeOnDownloadComplete(RakNet::BitStream *bitStream) | RakNet::Connection_RM3 | inlinevirtual
DeserializeOnDownloadStarted(RakNet::BitStream *bitStream) | RakNet::Connection_RM3 | inlinevirtual
GetConstructedReplicas(DataStructures::List< Replica3 * > &objectsTheyDoHave) | RakNet::Connection_RM3 | virtual
GetDownloadWasCompleted(void) const | RakNet::Connection_RM3 | inline
GetRakNetGUID(void) const | RakNet::Connection_RM3 | inline
GetSystemAddress(void) const | RakNet::Connection_RM3 | inline
HasReplicaConstructed(RakNet::Replica3 *replica) | RakNet::Connection_RM3 |
QUERY_CONNECTION_FOR_REPLICA_LIST enum value | RakNet::Connection_RM3 |
QUERY_REPLICA_FOR_CONSTRUCTION enum value | RakNet::Connection_RM3 |
QUERY_REPLICA_FOR_CONSTRUCTION_AND_DESTRUCTION enum value | RakNet::Connection_RM3 |
QueryConstructionMode(void) const | RakNet::Connection_RM3 | inlinevirtual
QueryGroupDownloadMessages(void) const | RakNet::Connection_RM3 | inlinevirtual
QueryReplicaList(DataStructures::List< Replica3 * > &newReplicasToCreate, DataStructures::List< Replica3 * > &existingReplicasToDestroy) | RakNet::Connection_RM3 | inlinevirtual
QuerySerializationList(DataStructures::List< Replica3 * > &replicasToSerialize) | RakNet::Connection_RM3 | inlinevirtual
SerializeOnDownloadComplete(RakNet::BitStream *bitStream) | RakNet::Connection_RM3 | inlinevirtual
SerializeOnDownloadStarted(RakNet::BitStream *bitStream) | RakNet::Connection_RM3 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • ConnectionGraph2
RakNet::ConnectionGraph2 Member List

This is the complete list of members for RakNet::ConnectionGraph2, including all inherited members.

AddParticipant(const SystemAddress &systemAddress, RakNetGUID rakNetGUID) | RakNet::ConnectionGraph2 |
ConnectionExists(RakNetGUID g1, RakNetGUID g2) | RakNet::ConnectionGraph2 |
GetAutoProcessNewConnections(void) const | RakNet::ConnectionGraph2 |
GetConnectionListForRemoteSystem(RakNetGUID remoteSystemGuid, SystemAddress *saOut, RakNetGUID *guidOut, unsigned int *outLength) | RakNet::ConnectionGraph2 |
GetLowestAveragePingSystem(void) const | RakNet::ConnectionGraph2 |
GetParticipantList(DataStructures::OrderedList< RakNetGUID, RakNetGUID > &participantList) | RakNet::ConnectionGraph2 |
GetPingBetweenSystems(RakNetGUID g1, RakNetGUID g2) const | RakNet::ConnectionGraph2 |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::ConnectionGraph2 | protectedvirtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::ConnectionGraph2 | protectedvirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::ConnectionGraph2 | protectedvirtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
SetAutoProcessNewConnections(bool b) | RakNet::ConnectionGraph2 |
Update(void) | RakNet::PluginInterface2 | inlinevirtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • ConsoleServer
RakNet::ConsoleServer Member List

This is the complete list of members for RakNet::ConsoleServer, including all inherited members.

AddCommandParser(CommandParserInterface *commandParserInterface) | RakNet::ConsoleServer
RemoveCommandParser(CommandParserInterface *commandParserInterface) | RakNet::ConsoleServer
SetPrompt(const char *_prompt) | RakNet::ConsoleServer
SetTransportProvider(TransportInterface *transportInterface, unsigned short port) | RakNet::ConsoleServer
Update(void) | RakNet::ConsoleServer
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • DataCompressor
RakNet::DataCompressor Member List

This is the complete list of members for RakNet::DataCompressor, including all inherited members.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • EmailSender
RakNet::EmailSender Member List

This is the complete list of members for RakNet::EmailSender, including all inherited members.

Send(const char *hostAddress, unsigned short hostPort, const char *sender, const char *recipient, const char *senderName, const char *recipientName, const char *subject, const char *body, FileList *attachedFiles, bool doPrintf, const char *password) RakNet::EmailSender
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • FileListProgress
RakNet::FileListProgress Member List

This is the complete list of members for RakNet::FileListProgress, including all inherited members.

OnAddFilesFromDirectoryStarted(FileList *fileList, char *dir) | RakNet::FileListProgress | inlinevirtual
OnDirectory(FileList *fileList, char *dir, unsigned int directoriesRemaining) | RakNet::FileListProgress | inlinevirtual
OnFile(FileList *fileList, char *dir, char *fileName, unsigned int fileSize) | RakNet::FileListProgress | inlinevirtual
OnFilePush(const char *fileName, unsigned int fileLengthBytes, unsigned int offset, unsigned int bytesBeingSent, bool done, SystemAddress targetSystem, unsigned short setId) | RakNet::FileListProgress | inlinevirtual
OnFilePushesComplete(SystemAddress systemAddress, unsigned short setId) | RakNet::FileListProgress | inlinevirtual
OnSendAborted(SystemAddress systemAddress) | RakNet::FileListProgress | inlinevirtual
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • FileListTransfer
RakNet::FileListTransfer Member List

This is the complete list of members for RakNet::FileListTransfer, including all inherited members.

AddCallback(FileListProgress *cb) | RakNet::FileListTransfer |
CancelReceive(unsigned short setId) | RakNet::FileListTransfer |
ClearCallbacks(void) | RakNet::FileListTransfer |
GetCallbacks(DataStructures::List< FileListProgress * > &callbacks) | RakNet::FileListTransfer |
GetPendingFilesToAddress(SystemAddress recipient) | RakNet::FileListTransfer |
IsHandlerActive(unsigned short setId) | RakNet::FileListTransfer |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::FileListTransfer | virtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::FileListTransfer | virtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::FileListTransfer | virtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
RemoveCallback(FileListProgress *cb) | RakNet::FileListTransfer |
RemoveReceiver(SystemAddress systemAddress) | RakNet::FileListTransfer |
Send(FileList *fileList, RakNet::RakPeerInterface *rakPeer, SystemAddress recipient, unsigned short setID, PacketPriority priority, char orderingChannel, IncrementalReadInterface *_incrementalReadInterface=0, unsigned int _chunkSize=262144 *4 *16) | RakNet::FileListTransfer |
SetupReceive(FileListTransferCBInterface *handler, bool deleteHandler, SystemAddress allowedSender) | RakNet::FileListTransfer |
StartIncrementalReadThreads(int numThreads, int threadPriority=-99999) | RakNet::FileListTransfer |
Update(void) | RakNet::FileListTransfer | virtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • FileListTransferCBInterface
RakNet::FileListTransferCBInterface Member List

This is the complete list of members for RakNet::FileListTransferCBInterface, including all inherited members.

OnDereference(void) | RakNet::FileListTransferCBInterface | inlinevirtual
OnDownloadComplete(DownloadCompleteStruct *dcs) | RakNet::FileListTransferCBInterface | inlinevirtual
OnFile(OnFileStruct *onFileStruct)=0 | RakNet::FileListTransferCBInterface | pure virtual
OnFileProgress(FileProgressStruct *fps)=0 | RakNet::FileListTransferCBInterface | pure virtual
Update(void) | RakNet::FileListTransferCBInterface | inlinevirtual
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • FLP_Printf
RakNet::FLP_Printf Member List

This is the complete list of members for RakNet::FLP_Printf, including all inherited members.

OnAddFilesFromDirectoryStarted(FileList *fileList, char *dir) | RakNet::FLP_Printf | virtual
OnDirectory(FileList *fileList, char *dir, unsigned int directoriesRemaining) | RakNet::FLP_Printf | virtual
OnFile(FileList *fileList, char *dir, char *fileName, unsigned int fileSize) | RakNet::FileListProgress | inlinevirtual
OnFilePush(const char *fileName, unsigned int fileLengthBytes, unsigned int offset, unsigned int bytesBeingSent, bool done, SystemAddress targetSystem, unsigned short setId) | RakNet::FileListProgress | inlinevirtual
OnFilePushesComplete(SystemAddress systemAddress, unsigned short setID) | RakNet::FLP_Printf | virtual
OnSendAborted(SystemAddress systemAddress) | RakNet::FLP_Printf | virtual
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • HTTPConnection2
RakNet::HTTPConnection2 Member List

This is the complete list of members for RakNet::HTTPConnection2, including all inherited members.

GetResponse(RakString &stringTransmitted, RakString &hostTransmitted, RakString &responseReceived, SystemAddress &hostReceived, int &contentOffset, void **userData) | RakNet::HTTPConnection2 |
HasResponse(void) const | RakNet::HTTPConnection2 |
IsBusy(void) const | RakNet::HTTPConnection2 |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::HTTPConnection2 | virtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::HTTPConnection2 | virtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::HTTPConnection2 | virtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::HTTPConnection2 | virtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
TransmitRequest(const char *stringToTransmit, const char *host, unsigned short port=80, bool useSSL=false, int ipVersion=4, SystemAddress useAddress=UNASSIGNED_SYSTEM_ADDRESS, void *userData=0) | RakNet::HTTPConnection2 |
Update(void) | RakNet::PluginInterface2 | inlinevirtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • HTTPConnection
RakNet::HTTPConnection Member List

This is the complete list of members for RakNet::HTTPConnection, including all inherited members.

Get(const char *path) | RakNet::HTTPConnection
GetServerAddress(void) const | RakNet::HTTPConnection
HasBadResponse(int *code, RakNet::RakString *data) | RakNet::HTTPConnection
HasRead(void) const | RakNet::HTTPConnection
HTTPConnection() | RakNet::HTTPConnection
Init(TCPInterface *_tcp, const char *host, unsigned short port=80) | RakNet::HTTPConnection
IsBusy(void) const | RakNet::HTTPConnection
Post(const char *path, const char *data, const char *_contentType="application/x-www-form-urlencoded") | RakNet::HTTPConnection
ProcessTCPPacket(Packet *packet) | RakNet::HTTPConnection
Read(void) | RakNet::HTTPConnection
ResponseCodes enum name | RakNet::HTTPConnection
Update(void) | RakNet::HTTPConnection
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • HuffmanEncodingTree
RakNet::HuffmanEncodingTree Member List

This is the complete list of members for RakNet::HuffmanEncodingTree, including all inherited members.

EncodeArray(unsigned char *input, size_t sizeInBytes, RakNet::BitStream *output) | RakNet::HuffmanEncodingTree
FreeMemory(void) | RakNet::HuffmanEncodingTree
GenerateFromFrequencyTable(unsigned int frequencyTable[256]) | RakNet::HuffmanEncodingTree
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • HuffmanEncodingTreeFactory
RakNet::HuffmanEncodingTreeFactory Member List

This is the complete list of members for RakNet::HuffmanEncodingTreeFactory, including all inherited members.

AddToFrequencyTable(unsigned char *array, int size) | RakNet::HuffmanEncodingTreeFactory
GenerateTree(void) | RakNet::HuffmanEncodingTreeFactory
GetFrequencyTable(unsigned int _frequency[256]) | RakNet::HuffmanEncodingTreeFactory
GetFrequencyTable(void) | RakNet::HuffmanEncodingTreeFactory
HuffmanEncodingTreeFactory() | RakNet::HuffmanEncodingTreeFactory
Reset(void) | RakNet::HuffmanEncodingTreeFactory
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Lobby2Client
RakNet::Lobby2Client Member List

This is the complete list of members for RakNet::Lobby2Client, including all inherited members.

AddCallbackInterface(Lobby2Callbacks *cb) | RakNet::Lobby2Plugin | virtual
ClearCallbackInterfaces() | RakNet::Lobby2Plugin | virtual
GetMessageFactory(void) const | RakNet::Lobby2Plugin |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::Lobby2Client | protectedvirtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::Lobby2Client | protectedvirtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
RemoveCallbackInterface(Lobby2Callbacks *cb) | RakNet::Lobby2Plugin | virtual
SendMsg(Lobby2Message *msg) | RakNet::Lobby2Client | virtual
SendMsgAndDealloc(Lobby2Message *msg) | RakNet::Lobby2Client | virtual
SetCallbackInterface(Lobby2Callbacks *cb) | RakNet::Lobby2Plugin | virtual
SetMessageFactory(Lobby2MessageFactory *f) | RakNet::Lobby2Plugin |
SetOrderingChannel(char oc) | RakNet::Lobby2Plugin |
SetSendPriority(PacketPriority pp) | RakNet::Lobby2Plugin |
SetServerAddress(SystemAddress addr) | RakNet::Lobby2Client |
Update(void) | RakNet::PluginInterface2 | inlinevirtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Lobby2Plugin
RakNet::Lobby2Plugin Member List

This is the complete list of members for RakNet::Lobby2Plugin, including all inherited members.

AddCallbackInterface(Lobby2Callbacks *cb) | RakNet::Lobby2Plugin | virtual
ClearCallbackInterfaces() | RakNet::Lobby2Plugin | virtual
GetMessageFactory(void) const | RakNet::Lobby2Plugin |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::PluginInterface2 | inlinevirtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::PluginInterface2 | inlinevirtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
RemoveCallbackInterface(Lobby2Callbacks *cb) | RakNet::Lobby2Plugin | virtual
SetCallbackInterface(Lobby2Callbacks *cb) | RakNet::Lobby2Plugin | virtual
SetMessageFactory(Lobby2MessageFactory *f) | RakNet::Lobby2Plugin |
SetOrderingChannel(char oc) | RakNet::Lobby2Plugin |
SetSendPriority(PacketPriority pp) | RakNet::Lobby2Plugin |
Update(void) | RakNet::PluginInterface2 | inlinevirtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Lobby2Server
RakNet::Lobby2Server Member List

This is the complete list of members for RakNet::Lobby2Server, including all inherited members.

AddAdminAddress(SystemAddress addr) | RakNet::Lobby2Server |
AddCallbackInterface(Lobby2Callbacks *cb) | RakNet::Lobby2Plugin | virtual
AddRankingAddress(SystemAddress addr) | RakNet::Lobby2Server |
ClearAdminAddresses(void) | RakNet::Lobby2Server |
ClearCallbackInterfaces() | RakNet::Lobby2Plugin | virtual
ClearRankingAddresses(void) | RakNet::Lobby2Server |
ConnectToDB(const char *conninfo, int numWorkerThreads)=0 | RakNet::Lobby2Server | pure virtual
ExecuteCommand(Lobby2ServerCommand *command) | RakNet::Lobby2Server |
GetConfigurationProperties(void) const | RakNet::Lobby2Server |
GetMessageFactory(void) const | RakNet::Lobby2Plugin |
GetPresence(RakNet::Lobby2Presence &presence, RakNet::RakString userHandle) | RakNet::Lobby2Server |
HasAdminAddress(const DataStructures::List< SystemAddress > &addresses) | RakNet::Lobby2Server |
HasRankingAddress(const DataStructures::List< SystemAddress > &addresses) | RakNet::Lobby2Server |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::Lobby2Server | protectedvirtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::Lobby2Server | protectedvirtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
RemoveAdminAddress(SystemAddress addr) | RakNet::Lobby2Server |
RemoveCallbackInterface(Lobby2Callbacks *cb) | RakNet::Lobby2Plugin | virtual
RemoveRankingAddress(SystemAddress addr) | RakNet::Lobby2Server |
SendMsg(Lobby2Message *msg, const DataStructures::List< SystemAddress > &recipients) | RakNet::Lobby2Server |
SetCallbackInterface(Lobby2Callbacks *cb) | RakNet::Lobby2Plugin | virtual
SetConfigurationProperties(ConfigurationProperties c) | RakNet::Lobby2Server |
SetMessageFactory(Lobby2MessageFactory *f) | RakNet::Lobby2Plugin |
SetOrderingChannel(char oc) | RakNet::Lobby2Plugin |
SetPresence(const RakNet::Lobby2Presence &presence, RakNet::RakString userHandle) | RakNet::Lobby2Server |
SetRoomsPlugin(RoomsPlugin *rp) | RakNet::Lobby2Server |
SetRoomsPluginAddress(SystemAddress address) | RakNet::Lobby2Server |
SetSendPriority(PacketPriority pp) | RakNet::Lobby2Plugin |
Update(void) | RakNet::Lobby2Server | protectedvirtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Lobby2Server_PGSQL
RakNet::Lobby2Server_PGSQL Member List

This is the complete list of members for RakNet::Lobby2Server_PGSQL, including all inherited members.

AddAdminAddress(SystemAddress addr) | RakNet::Lobby2Server |
AddCallbackInterface(Lobby2Callbacks *cb) | RakNet::Lobby2Plugin | virtual
AddInputFromThread(Lobby2Message *msg, unsigned int targetUserId, RakNet::RakString targetUserHandle) | RakNet::Lobby2Server_PGSQL | virtual
AddOutputFromThread(Lobby2Message *msg, unsigned int targetUserId, RakNet::RakString targetUserHandle) | RakNet::Lobby2Server_PGSQL | virtual
AddRankingAddress(SystemAddress addr) | RakNet::Lobby2Server |
ClearAdminAddresses(void) | RakNet::Lobby2Server |
ClearCallbackInterfaces() | RakNet::Lobby2Plugin | virtual
ClearRankingAddresses(void) | RakNet::Lobby2Server |
ConnectToDB(const char *conninfo, int numWorkerThreads) | RakNet::Lobby2Server_PGSQL | virtual
ExecuteCommand(Lobby2ServerCommand *command) | RakNet::Lobby2Server |
GetConfigurationProperties(void) const | RakNet::Lobby2Server |
GetMessageFactory(void) const | RakNet::Lobby2Plugin |
GetPresence(RakNet::Lobby2Presence &presence, RakNet::RakString userHandle) | RakNet::Lobby2Server |
HasAdminAddress(const DataStructures::List< SystemAddress > &addresses) | RakNet::Lobby2Server |
HasRankingAddress(const DataStructures::List< SystemAddress > &addresses) | RakNet::Lobby2Server |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::Lobby2Server | protectedvirtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::Lobby2Server | protectedvirtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
RemoveAdminAddress(SystemAddress addr) | RakNet::Lobby2Server |
RemoveCallbackInterface(Lobby2Callbacks *cb) | RakNet::Lobby2Plugin | virtual
RemoveRankingAddress(SystemAddress addr) | RakNet::Lobby2Server |
SendMsg(Lobby2Message *msg, const DataStructures::List< SystemAddress > &recipients) | RakNet::Lobby2Server |
SetCallbackInterface(Lobby2Callbacks *cb) | RakNet::Lobby2Plugin | virtual
SetConfigurationProperties(ConfigurationProperties c) | RakNet::Lobby2Server |
SetMessageFactory(Lobby2MessageFactory *f) | RakNet::Lobby2Plugin |
SetOrderingChannel(char oc) | RakNet::Lobby2Plugin |
SetPresence(const RakNet::Lobby2Presence &presence, RakNet::RakString userHandle) | RakNet::Lobby2Server |
SetRoomsPlugin(RoomsPlugin *rp) | RakNet::Lobby2Server |
SetRoomsPluginAddress(SystemAddress address) | RakNet::Lobby2Server |
SetSendPriority(PacketPriority pp) | RakNet::Lobby2Plugin |
Update(void) | RakNet::Lobby2Server | protectedvirtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • LogCommandParser
RakNet::LogCommandParser Member List

This is the complete list of members for RakNet::LogCommandParser, including all inherited members.

AddChannel(const char *channelName) | RakNet::LogCommandParser |
channelNames | RakNet::LogCommandParser | protected
GetChannelIndexFromName(const char *channelName) | RakNet::LogCommandParser | protected
GetName(void) const | RakNet::LogCommandParser | virtual
OnCommand(const char *command, unsigned numParameters, char **parameterList, TransportInterface *transport, const SystemAddress &systemAddress, const char *originalString) | RakNet::LogCommandParser | virtual
OnConnectionLost(const SystemAddress &systemAddress, TransportInterface *transport) | RakNet::LogCommandParser | virtual
OnNewIncomingConnection(const SystemAddress &systemAddress, TransportInterface *transport) | RakNet::LogCommandParser | virtual
OnTransportChange(TransportInterface *transport) | RakNet::LogCommandParser | virtual
PrintChannels(const SystemAddress &systemAddress, TransportInterface *transport) const | RakNet::LogCommandParser | protected
RegisterCommand(unsigned char parameterCount, const char *command, const char *commandHelp) | RakNet::CommandParserInterface | virtual
remoteUsers | RakNet::LogCommandParser | protected
ReturnResult(bool res, const char *command, TransportInterface *transport, const SystemAddress &systemAddress) | RakNet::CommandParserInterface | virtual
ReturnResult(const char *command, TransportInterface *transport, const SystemAddress &systemAddress) | RakNet::CommandParserInterface | virtual
SendHelp(TransportInterface *transport, const SystemAddress &systemAddress) | RakNet::LogCommandParser | virtual
Subscribe(const SystemAddress &systemAddress, const char *channelName) | RakNet::LogCommandParser | protected
trans | RakNet::LogCommandParser | protected
Unsubscribe(const SystemAddress &systemAddress, const char *channelName) | RakNet::LogCommandParser | protected
WriteLog(const char *channelName, const char *format,...) | RakNet::LogCommandParser |
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • MessageFilter
RakNet::MessageFilter Member List

This is the complete list of members for RakNet::MessageFilter, including all inherited members.

DeleteFilterSet(int filterSetID) | RakNet::MessageFilter |
GetFilterSetCount(void) const | RakNet::MessageFilter |
GetFilterSetIDByIndex(unsigned index) | RakNet::MessageFilter |
GetSystemCount(int filterSetID) const | RakNet::MessageFilter |
GetSystemFilterSet(AddressOrGUID addressOrGUID) | RakNet::MessageFilter |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::MessageFilter | virtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::MessageFilter | virtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::MessageFilter | virtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
SetActionOnDisallowedMessage(bool kickOnDisallowed, bool banOnDisallowed, RakNet::TimeMS banTimeMS, int filterSetID) | RakNet::MessageFilter |
SetAllowMessageID(bool allow, int messageIDStart, int messageIDEnd, int filterSetID) | RakNet::MessageFilter |
SetAllowRPC4(bool allow, const char *uniqueID, int filterSetID) | RakNet::MessageFilter |
SetAutoAddNewConnectionsToFilter(int filterSetID) | RakNet::MessageFilter |
SetDisallowedMessageCallback(int filterSetID, void *userData, void(*invalidMessageCallback)(RakPeerInterface *peer, AddressOrGUID addressOrGUID, int filterSetID, void *userData, unsigned char messageID)) | RakNet::MessageFilter |
SetFilterMaxTime(int allowedTimeMS, bool banOnExceed, RakNet::TimeMS banTimeMS, int filterSetID) | RakNet::MessageFilter |
SetSystemFilterSet(AddressOrGUID addressOrGUID, int filterSetID) | RakNet::MessageFilter |
SetTimeoutCallback(int filterSetID, void *userData, void(*invalidMessageCallback)(RakPeerInterface *peer, AddressOrGUID addressOrGUID, int filterSetID, void *userData)) | RakNet::MessageFilter |
Update(void) | RakNet::MessageFilter | virtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • NatPunchthroughClient
RakNet::NatPunchthroughClient Member List

This is the complete list of members for RakNet::NatPunchthroughClient, including all inherited members.

FindRouterPortStride(const SystemAddress &facilitator) | RakNet::NatPunchthroughClient |
GetPunchthroughConfiguration(void) | RakNet::NatPunchthroughClient |
GetUPNPPortMappings(char *externalPort, char *internalPort, const SystemAddress &natPunchthroughServerAddress) | RakNet::NatPunchthroughClient |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::NatPunchthroughClient | virtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::NatPunchthroughClient | virtual
OnDetach(void) | RakNet::NatPunchthroughClient | virtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::NatPunchthroughClient | virtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::NatPunchthroughClient | virtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::NatPunchthroughClient | virtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
OpenNAT(RakNetGUID destination, const SystemAddress &facilitator) | RakNet::NatPunchthroughClient |
SetDebugInterface(NatPunchthroughDebugInterface *i) | RakNet::NatPunchthroughClient |
Update(void) | RakNet::NatPunchthroughClient | virtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • NatPunchthroughServer
RakNet::NatPunchthroughServer Member List

This is the complete list of members for RakNet::NatPunchthroughServer, including all inherited members.

OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::NatPunchthroughServer | virtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::NatPunchthroughServer | virtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::NatPunchthroughServer | virtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
SetDebugInterface(NatPunchthroughServerDebugInterface *i) | RakNet::NatPunchthroughServer |
Update(void) | RakNet::NatPunchthroughServer | virtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • NatTypeDetectionClient
RakNet::NatTypeDetectionClient Member List

This is the complete list of members for RakNet::NatTypeDetectionClient, including all inherited members.

DetectNATType(SystemAddress _serverAddress) | RakNet::NatTypeDetectionClient |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::NatTypeDetectionClient | virtual
OnDetach(void) | RakNet::NatTypeDetectionClient | virtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::NatTypeDetectionClient | virtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::NatTypeDetectionClient | virtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
Update(void) | RakNet::NatTypeDetectionClient | virtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • NatTypeDetectionServer
RakNet::NatTypeDetectionServer Member List

This is the complete list of members for RakNet::NatTypeDetectionServer, including all inherited members.

OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::NatTypeDetectionServer | virtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::NatTypeDetectionServer | virtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
Startup(const char *nonRakNetIP2, const char *nonRakNetIP3, const char *nonRakNetIP4) | RakNet::NatTypeDetectionServer |
Update(void) | RakNet::NatTypeDetectionServer | virtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • NetworkIDManager
RakNet::NetworkIDManager Member List

This is the complete list of members for RakNet::NetworkIDManager, including all inherited members.

GET_OBJECT_FROM_ID(NetworkID x) RakNet::NetworkIDManager inline
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • NetworkIDObject
RakNet::NetworkIDObject Member List

This is the complete list of members for RakNet::NetworkIDObject, including all inherited members.

GetNetworkID(void) | RakNet::NetworkIDObject | virtual
GetNetworkIDManager(void) const | RakNet::NetworkIDObject | virtual
GetParent(void) const | RakNet::NetworkIDObject | virtual
networkID | RakNet::NetworkIDObject | protected
parent | RakNet::NetworkIDObject | protected
SetNetworkID(NetworkID id) | RakNet::NetworkIDObject | virtual
SetNetworkIDManager(NetworkIDManager *manager) | RakNet::NetworkIDObject | virtual
SetParent(void *_parent) | RakNet::NetworkIDObject | virtual
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • PacketConsoleLogger
RakNet::PacketConsoleLogger Member List

This is the complete list of members for RakNet::PacketConsoleLogger, including all inherited members.

LogHeader(void) | RakNet::PacketLogger | virtual
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PacketLogger | virtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::PluginInterface2 | inlinevirtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PacketLogger | virtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PacketLogger | virtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PacketLogger | virtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PacketLogger | virtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::PluginInterface2 | inlinevirtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PacketLogger | virtual
SetLogDirectMessages(bool send) | RakNet::PacketLogger |
SetPrefix(const char *_prefix) | RakNet::PacketLogger | virtual
SetSuffix(const char *_suffix) | RakNet::PacketLogger | virtual
Update(void) | RakNet::PluginInterface2 | inlinevirtual
UsesReliabilityLayer(void) const | RakNet::PacketLogger | inlineprotectedvirtual
WriteLog(const char *str) | RakNet::PacketConsoleLogger | virtual
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • PacketFileLogger
RakNet::PacketFileLogger Member List

This is the complete list of members for RakNet::PacketFileLogger, including all inherited members.

LogHeader(void) | RakNet::PacketLogger | virtual
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PacketLogger | virtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::PluginInterface2 | inlinevirtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PacketLogger | virtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PacketLogger | virtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PacketLogger | virtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PacketLogger | virtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::PluginInterface2 | inlinevirtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PacketLogger | virtual
SetLogDirectMessages(bool send) | RakNet::PacketLogger |
SetPrefix(const char *_prefix) | RakNet::PacketLogger | virtual
SetSuffix(const char *_suffix) | RakNet::PacketLogger | virtual
Update(void) | RakNet::PluginInterface2 | inlinevirtual
UsesReliabilityLayer(void) const | RakNet::PacketLogger | inlineprotectedvirtual
WriteLog(const char *str) | RakNet::PacketFileLogger | virtual
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • PacketLogger
RakNet::PacketLogger Member List

This is the complete list of members for RakNet::PacketLogger, including all inherited members.

LogHeader(void) | RakNet::PacketLogger | virtual
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PacketLogger | virtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::PluginInterface2 | inlinevirtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PacketLogger | virtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PacketLogger | virtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PacketLogger | virtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PacketLogger | virtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::PluginInterface2 | inlinevirtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PacketLogger | virtual
SetLogDirectMessages(bool send) | RakNet::PacketLogger |
SetPrefix(const char *_prefix) | RakNet::PacketLogger | virtual
SetSuffix(const char *_suffix) | RakNet::PacketLogger | virtual
Update(void) | RakNet::PluginInterface2 | inlinevirtual
UsesReliabilityLayer(void) const | RakNet::PacketLogger | inlineprotectedvirtual
WriteLog(const char *str) | RakNet::PacketLogger | virtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • PacketOutputWindowLogger
RakNet::PacketOutputWindowLogger Member List

This is the complete list of members for RakNet::PacketOutputWindowLogger, including all inherited members.

LogHeader(void) | RakNet::PacketLogger | virtual
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PacketLogger | virtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::PluginInterface2 | inlinevirtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PacketLogger | virtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PacketLogger | virtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PacketLogger | virtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PacketLogger | virtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::PluginInterface2 | inlinevirtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PacketLogger | virtual
SetLogDirectMessages(bool send) | RakNet::PacketLogger |
SetPrefix(const char *_prefix) | RakNet::PacketLogger | virtual
SetSuffix(const char *_suffix) | RakNet::PacketLogger | virtual
Update(void) | RakNet::PluginInterface2 | inlinevirtual
UsesReliabilityLayer(void) const | RakNet::PacketLogger | inlineprotectedvirtual
WriteLog(const char *str) | RakNet::PacketOutputWindowLogger | virtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • PluginInterface2
RakNet::PluginInterface2 Member List

This is the complete list of members for RakNet::PluginInterface2, including all inherited members.

OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::PluginInterface2 | inlinevirtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::PluginInterface2 | inlinevirtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
Update(void) | RakNet::PluginInterface2 | inlinevirtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Rackspace2EventCallback
RakNet::Rackspace2EventCallback Member List

This is the complete list of members for RakNet::Rackspace2EventCallback, including all inherited members.

Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Rackspace
RakNet::Rackspace Member List

This is the complete list of members for RakNet::Rackspace, including all inherited members.

AddEventCallback(Rackspace2EventCallback *callback) | RakNet::Rackspace |
AddOperation(RackspaceOperationType type, RakNet::RakString httpCommand, RakNet::RakString operation, RakNet::RakString xml) | RakNet::Rackspace |
Authenticate(TCPInterface *_tcpInterface, const char *_authenticationURL, const char *_rackspaceCloudUsername, const char *_apiAccessKey) | RakNet::Rackspace |
ClearEventCallbacks(void) | RakNet::Rackspace |
ConfirmResizedServer(RakNet::RakString serverId) | RakNet::Rackspace |
CreateImage(RakNet::RakString serverId, RakNet::RakString imageName) | RakNet::Rackspace |
CreateServer(RakNet::RakString name, RakNet::RakString imageId, RakNet::RakString flavorId) | RakNet::Rackspace |
DeleteImage(RakNet::RakString imageId) | RakNet::Rackspace |
DeleteServer(RakNet::RakString serverId) | RakNet::Rackspace |
DeleteServerAddress(RakNet::RakString serverId, RakNet::RakString ipAddress) | RakNet::Rackspace |
EventTypeToString(RackspaceEventType eventType) | RakNet::Rackspace | static
GetFlavorDetails(RakNet::RakString flavorId) | RakNet::Rackspace |
GetImageDetails(RakNet::RakString imageId) | RakNet::Rackspace |
GetServerDetails(RakNet::RakString serverId) | RakNet::Rackspace |
ListFlavors(void) | RakNet::Rackspace |
ListImages(void) | RakNet::Rackspace |
ListServerAddresses(RakNet::RakString serverId) | RakNet::Rackspace |
ListServers(void) | RakNet::Rackspace |
ListServersWithDetails(void) | RakNet::Rackspace |
ListSharedIPGroups(void) | RakNet::Rackspace |
ListSharedIPGroupsWithDetails(void) | RakNet::Rackspace |
OnClosedConnection(SystemAddress systemAddress) | RakNet::Rackspace |
OnReceive(Packet *packet) | RakNet::Rackspace |
RebootServer(RakNet::RakString serverId, RakNet::RakString rebootType) | RakNet::Rackspace |
RebuildServer(RakNet::RakString serverId, RakNet::RakString imageId) | RakNet::Rackspace |
RemoveEventCallback(Rackspace2EventCallback *callback) | RakNet::Rackspace |
ResizeServer(RakNet::RakString serverId, RakNet::RakString flavorId) | RakNet::Rackspace |
RevertResizedServer(RakNet::RakString serverId) | RakNet::Rackspace |
ShareServerAddress(RakNet::RakString serverId, RakNet::RakString ipAddress) | RakNet::Rackspace |
UpdateServerNameOrPassword(RakNet::RakString serverId, RakNet::RakString newName, RakNet::RakString newPassword) | RakNet::Rackspace |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RackspaceEventCallback_Default
RakNet::RackspaceEventCallback_Default Member List

This is the complete list of members for RakNet::RackspaceEventCallback_Default, including all inherited members.

Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RakNetCommandParser
RakNet::RakNetCommandParser Member List

This is the complete list of members for RakNet::RakNetCommandParser, including all inherited members.

GetName(void) const | RakNet::RakNetCommandParser | virtual
OnCommand(const char *command, unsigned numParameters, char **parameterList, TransportInterface *transport, const SystemAddress &systemAddress, const char *originalString) | RakNet::RakNetCommandParser | virtual
OnConnectionLost(const SystemAddress &systemAddress, TransportInterface *transport) | RakNet::CommandParserInterface | virtual
OnNewIncomingConnection(const SystemAddress &systemAddress, TransportInterface *transport) | RakNet::CommandParserInterface | virtual
OnTransportChange(TransportInterface *transport) | RakNet::CommandParserInterface | virtual
peer | RakNet::RakNetCommandParser | protected
RegisterCommand(unsigned char parameterCount, const char *command, const char *commandHelp) | RakNet::CommandParserInterface | virtual
ReturnResult(bool res, const char *command, TransportInterface *transport, const SystemAddress &systemAddress) | RakNet::CommandParserInterface | virtual
ReturnResult(const char *command, TransportInterface *transport, const SystemAddress &systemAddress) | RakNet::CommandParserInterface | virtual
SendHelp(TransportInterface *transport, const SystemAddress &systemAddress) | RakNet::RakNetCommandParser | virtual
SetRakPeerInterface(RakNet::RakPeerInterface *rakPeer) | RakNet::RakNetCommandParser |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RakNetTransport2
RakNet::RakNetTransport2 Member List

This is the complete list of members for RakNet::RakNetTransport2, including all inherited members.

CloseConnection(SystemAddress systemAddress) | RakNet::RakNetTransport2 | virtual
DeallocatePacket(Packet *packet) | RakNet::RakNetTransport2 | virtual
GetCommandParser(void) | RakNet::RakNetTransport2 | inlinevirtual
HasLostConnection(void) | RakNet::RakNetTransport2 | virtual
HasNewIncomingConnection(void) | RakNet::RakNetTransport2 | virtual
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::RakNetTransport2 | virtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::RakNetTransport2 | virtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::RakNetTransport2 | virtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
Receive(void) | RakNet::RakNetTransport2 | virtual
Send(SystemAddress systemAddress, const char *data,...) | RakNet::RakNetTransport2 | virtual
Start(unsigned short port, bool serverMode) | RakNet::RakNetTransport2 | virtual
Stop(void) | RakNet::RakNetTransport2 | virtual
Update(void) | RakNet::PluginInterface2 | inlinevirtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RakPeer
RakNet::RakPeer Member List

This is the complete list of members for RakNet::RakPeer, including all inherited members.

activeSystemList | RakNet::RakPeer | protected
AddToBanList(const char *IP, RakNet::TimeMS milliseconds=0) | RakNet::RakPeer | virtual
AddToSecurityExceptionList(const char *ip) | RakNet::RakPeer | virtual
AdvertiseSystem(const char *host, unsigned short remotePort, const char *data, int dataLength, unsigned connectionSocketIndex=0) | RakNet::RakPeer | virtual
AllocatePacket(unsigned dataSize) | RakNet::RakPeer | virtual
allowConnectionResponseIPMigration | RakNet::RakPeer | protected
AllowConnectionResponseIPMigration(bool allow) | RakNet::RakPeer | virtual
ApplyNetworkSimulator(float packetloss, unsigned short minExtraPing, unsigned short extraPingVariance) | RakNet::RakPeer | virtual
AssignSystemAddressToRemoteSystemList(const SystemAddress systemAddress, RemoteSystemStruct::ConnectMode connectionMode, RakNetSocket2 *incomingRakNetSocket, bool *thisIPConnectedRecently, SystemAddress bindingAddress, int incomingMTU, RakNetGUID guid, bool useSecurity) | RakNet::RakPeer | protected
AttachPlugin(PluginInterface2 *plugin) | RakNet::RakPeer | virtual
bytesSentPerSecond | RakNet::RakPeer | protected
CancelConnectionAttempt(const SystemAddress target) | RakNet::RakPeer | virtual
ClearBanList(void) | RakNet::RakPeer | virtual
CloseConnection(const AddressOrGUID target, bool sendDisconnectionNotification, unsigned char orderingChannel=0, PacketPriority disconnectionNotificationPriority=LOW_PRIORITY) | RakNet::RakPeer | virtual
Connect(const char *host, unsigned short remotePort, const char *passwordData, int passwordDataLength, PublicKey *publicKey=0, unsigned connectionSocketIndex=0, unsigned sendConnectionAttemptCount=6, unsigned timeBetweenSendConnectionAttemptsMS=1000, RakNet::TimeMS timeoutTime=0) | RakNet::RakPeer | virtual
ConnectWithSocket(const char *host, unsigned short remotePort, const char *passwordData, int passwordDataLength, RakNetSocket2 *socket, PublicKey *publicKey=0, unsigned sendConnectionAttemptCount=6, unsigned timeBetweenSendConnectionAttemptsMS=1000, RakNet::TimeMS timeoutTime=0) | RakNet::RakPeer | virtual
DeallocatePacket(Packet *packet) | RakNet::RakPeer | virtual
DetachPlugin(PluginInterface2 *messageHandler) | RakNet::RakPeer | virtual
DisableSecurity(void) | RakNet::RakPeer | virtual
endThreads | RakNet::RakPeer | protected
Get64BitUniqueRandomNumber(void) | RakNet::RakPeerInterface | static
GetAveragePing(const AddressOrGUID systemIdentifier) | RakNet::RakPeer | virtual
GetBestClockDifferential(const SystemAddress systemAddress) const | RakNet::RakPeer | protected
GetClientPublicKeyFromSystemAddress(const SystemAddress input, char *client_public_key) const | RakNet::RakPeer | virtual
GetClockDifferential(const AddressOrGUID systemIdentifier) | RakNet::RakPeer | virtual
GetConnectionList(SystemAddress *remoteSystems, unsigned short *numberOfSystems) const | RakNet::RakPeer | virtual
GetConnectionState(const AddressOrGUID systemIdentifier) | RakNet::RakPeer | virtual
GetExternalID(const SystemAddress target) const | RakNet::RakPeer | virtual
GetGUIDFromIndex(unsigned int index) | RakNet::RakPeer | virtual
GetGuidFromSystemAddress(const SystemAddress input) const | RakNet::RakPeer | virtual
GetIncomingPassword(char *passwordData, int *passwordDataLength) | RakNet::RakPeer | virtual
GetIndexFromSystemAddress(const SystemAddress systemAddress) const | RakNet::RakPeer | virtual
GetInternalID(const SystemAddress systemAddress=UNASSIGNED_SYSTEM_ADDRESS, const int index=0) const | RakNet::RakPeer | virtual
GetLastPing(const AddressOrGUID systemIdentifier) const | RakNet::RakPeer | virtual
GetLocalIP(unsigned int index) | RakNet::RakPeer | virtual
GetLowestPing(const AddressOrGUID systemIdentifier) const | RakNet::RakPeer | virtual
GetMaximumIncomingConnections(void) const | RakNet::RakPeer | virtual
GetMaximumNumberOfPeers(void) const | RakNet::RakPeer | virtual
GetMTUSize(const SystemAddress target) const | RakNet::RakPeer | virtual
GetMyBoundAddress(const int socketIndex=0) | RakNet::RakPeer | virtual
GetMyGUID(void) const | RakNet::RakPeer | virtual
GetNextSendReceipt(void) | RakNet::RakPeer | virtual
GetNumberOfAddresses(void) | RakNet::RakPeer | virtual
GetNumberOfRemoteInitiatedConnections(void) const | RakNet::RakPeer | protected
GetOfflinePingResponse(char **data, unsigned int *length) | RakNet::RakPeer | virtual
GetReceiveBufferSize(void) | RakNet::RakPeer | virtual
GetRemoteSystemFromSystemAddress(const SystemAddress systemAddress, bool calledFromNetworkThread, bool onlyActive) const | RakNet::RakPeer | protected
GetSocket(const SystemAddress target) | RakNet::RakPeer | virtual
GetSockets(DataStructures::List< RakNetSocket2 * > &sockets) | RakNet::RakPeer | virtual
GetSplitMessageProgressInterval(void) const | RakNet::RakPeer | virtual
GetStatistics(const SystemAddress systemAddress, RakNetStatistics *rns=0) | RakNet::RakPeer | virtual
GetStatistics(const unsigned int index, RakNetStatistics *rns) | RakNet::RakPeer | virtual
GetStatisticsList(DataStructures::List< SystemAddress > &addresses, DataStructures::List< RakNetGUID > &guids, DataStructures::List< RakNetStatistics > &statistics) | RakNet::RakPeer | virtual
GetSystemAddressFromGuid(const RakNetGUID input) const | RakNet::RakPeer | virtual
GetSystemAddressFromIndex(unsigned int index) | RakNet::RakPeer | virtual
GetSystemList(DataStructures::List< SystemAddress > &addresses, DataStructures::List< RakNetGUID > &guids) const | RakNet::RakPeer | virtual
GetTimeoutTime(const SystemAddress target) | RakNet::RakPeer | virtual
incomingPassword | RakNet::RakPeer | protected
IncrementNextSendReceipt(void) | RakNet::RakPeer | virtual
InitializeSecurity(const char *publicKey, const char *privateKey, bool bRequireClientKey=false) | RakNet::RakPeer | virtual
IsActive(void) const | RakNet::RakPeer | virtual
IsBanned(const char *IP) | RakNet::RakPeer | virtual
IsInSecurityExceptionList(const char *ip) | RakNet::RakPeer | virtual
IsLocalIP(const char *ip) | RakNet::RakPeer | virtual
isMainLoopThreadActive | RakNet::RakPeer | protected
IsNetworkSimulatorActive(void) | RakNet::RakPeer | virtual
maximumIncomingConnections | RakNet::RakPeer | protected
maximumNumberOfPeers | RakNet::RakPeer | protected
NotifyAndFlagForShutdown(const SystemAddress systemAddress, bool performImmediate, unsigned char orderingChannel, PacketPriority disconnectionNotificationPriority) | RakNet::RakPeer | protected
NumberOfConnections(void) const | RakNet::RakPeer | virtual
ParseConnectionRequestPacket(RakPeer::RemoteSystemStruct *remoteSystem, const SystemAddress &systemAddress, const char *data, int byteSize) | RakNet::RakPeer | protected
Ping(const SystemAddress target) | RakNet::RakPeer | virtual
Ping(const char *host, unsigned short remotePort, bool onlyReplyOnAcceptingConnections, unsigned connectionSocketIndex=0) | RakNet::RakPeer | virtual
PushBackPacket(Packet *packet, bool pushAtHead) | RakNet::RakPeer | virtual
RakPeer() | RakNet::RakPeer |
Receive(void) | RakNet::RakPeer | virtual
remoteSystemList | RakNet::RakPeer | protected
RemoveFromBanList(const char *IP) | RakNet::RakPeer | virtual
RemoveFromSecurityExceptionList(const char *ip) | RakNet::RakPeer | virtual
Send(const char *data, const int length, PacketPriority priority, PacketReliability reliability, char orderingChannel, const AddressOrGUID systemIdentifier, bool broadcast, uint32_t forceReceiptNumber=0) | RakNet::RakPeer | virtual
Send(const RakNet::BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel, const AddressOrGUID systemIdentifier, bool broadcast, uint32_t forceReceiptNumber=0) | RakNet::RakPeer | virtual
SendList(const char **data, const int *lengths, const int numParameters, PacketPriority priority, PacketReliability reliability, char orderingChannel, const AddressOrGUID systemIdentifier, bool broadcast, uint32_t forceReceiptNumber=0) | RakNet::RakPeer | virtual
SendLoopback(const char *data, const int length) | RakNet::RakPeer | virtual
sendReceiptSerialMutex | RakNet::RakPeer | protected
SendTTL(const char *host, unsigned short remotePort, int ttl, unsigned connectionSocketIndex=0) | RakNet::RakPeer | virtual
SetIncomingDatagramEventHandler(bool(*_incomingDatagramEventHandler)(RNS2RecvStruct *)) | RakNet::RakPeer | virtual
SetIncomingPassword(const char *passwordData, int passwordDataLength) | RakNet::RakPeer | virtual
SetInternalID(SystemAddress systemAddress, int index=0) | RakNet::RakPeer | virtual
SetLimitIPConnectionFrequency(bool b) | RakNet::RakPeer | virtual
SetMaximumIncomingConnections(unsigned short numberAllowed) | RakNet::RakPeer | virtual
SetOccasionalPing(bool doPing) | RakNet::RakPeer | virtual
SetOfflinePingResponse(const char *data, const unsigned int length) | RakNet::RakPeer | virtual
SetPerConnectionOutgoingBandwidthLimit(unsigned maxBitsPerSecond) | RakNet::RakPeer | virtual
SetSplitMessageProgressInterval(int interval) | RakNet::RakPeer | virtual
SetTimeoutTime(RakNet::TimeMS timeMS, const SystemAddress target) | RakNet::RakPeer | virtual
SetUnreliableTimeout(RakNet::TimeMS timeoutMS) | RakNet::RakPeer | virtual
SetUserUpdateThread(void(*_userUpdateThreadPtr)(RakPeerInterface *, void *), void *_userUpdateThreadData) | RakNet::RakPeer | virtual
ShiftIncomingTimestamp(unsigned char *data, const SystemAddress &systemAddress) const | RakNet::RakPeer | protected
Shutdown(unsigned int blockDuration, unsigned char orderingChannel=0, PacketPriority disconnectionNotificationPriority=LOW_PRIORITY) | RakNet::RakPeer | virtual
Startup(unsigned int maxConnections, SocketDescriptor *socketDescriptors, unsigned socketDescriptorCount, int threadPriority=-99999) | RakNet::RakPeer | virtual
updateCycleIsRunning | RakNet::RakPeer | protected
~RakPeer() | RakNet::RakPeer | virtual
~RakPeerInterface() | RakNet::RakPeerInterface | inlinevirtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RakPeerInterface
RakNet::RakPeerInterface Member List

This is the complete list of members for RakNet::RakPeerInterface, including all inherited members.

AddToBanList(const char *IP, RakNet::TimeMS milliseconds=0)=0 | RakNet::RakPeerInterface | pure virtual
AddToSecurityExceptionList(const char *ip)=0 | RakNet::RakPeerInterface | pure virtual
AdvertiseSystem(const char *host, unsigned short remotePort, const char *data, int dataLength, unsigned connectionSocketIndex=0)=0 | RakNet::RakPeerInterface | pure virtual
AllocatePacket(unsigned dataSize)=0 | RakNet::RakPeerInterface | pure virtual
AllowConnectionResponseIPMigration(bool allow)=0 | RakNet::RakPeerInterface | pure virtual
ApplyNetworkSimulator(float packetloss, unsigned short minExtraPing, unsigned short extraPingVariance)=0 | RakNet::RakPeerInterface | pure virtual
AttachPlugin(PluginInterface2 *plugin)=0 | RakNet::RakPeerInterface | pure virtual
CancelConnectionAttempt(const SystemAddress target)=0 | RakNet::RakPeerInterface | pure virtual
ClearBanList(void)=0 | RakNet::RakPeerInterface | pure virtual
CloseConnection(const AddressOrGUID target, bool sendDisconnectionNotification, unsigned char orderingChannel=0, PacketPriority disconnectionNotificationPriority=LOW_PRIORITY)=0 | RakNet::RakPeerInterface | pure virtual
Connect(const char *host, unsigned short remotePort, const char *passwordData, int passwordDataLength, PublicKey *publicKey=0, unsigned connectionSocketIndex=0, unsigned sendConnectionAttemptCount=12, unsigned timeBetweenSendConnectionAttemptsMS=500, RakNet::TimeMS timeoutTime=0)=0 | RakNet::RakPeerInterface | pure virtual
ConnectWithSocket(const char *host, unsigned short remotePort, const char *passwordData, int passwordDataLength, RakNetSocket2 *socket, PublicKey *publicKey=0, unsigned sendConnectionAttemptCount=12, unsigned timeBetweenSendConnectionAttemptsMS=500, RakNet::TimeMS timeoutTime=0)=0 | RakNet::RakPeerInterface | pure virtual
DeallocatePacket(Packet *packet)=0 | RakNet::RakPeerInterface | pure virtual
DetachPlugin(PluginInterface2 *messageHandler)=0 | RakNet::RakPeerInterface | pure virtual
DisableSecurity(void)=0 | RakNet::RakPeerInterface | pure virtual
Get64BitUniqueRandomNumber(void) | RakNet::RakPeerInterface | static
GetAveragePing(const AddressOrGUID systemIdentifier)=0 | RakNet::RakPeerInterface | pure virtual
GetClientPublicKeyFromSystemAddress(const SystemAddress input, char *client_public_key) const =0 | RakNet::RakPeerInterface | pure virtual
GetClockDifferential(const AddressOrGUID systemIdentifier)=0 | RakNet::RakPeerInterface | pure virtual
GetConnectionList(SystemAddress *remoteSystems, unsigned short *numberOfSystems) const =0 | RakNet::RakPeerInterface | pure virtual
GetConnectionState(const AddressOrGUID systemIdentifier)=0 | RakNet::RakPeerInterface | pure virtual
GetExternalID(const SystemAddress target) const =0 | RakNet::RakPeerInterface | pure virtual
GetGUIDFromIndex(unsigned int index)=0 | RakNet::RakPeerInterface | pure virtual
GetGuidFromSystemAddress(const SystemAddress input) const =0 | RakNet::RakPeerInterface | pure virtual
GetIncomingPassword(char *passwordData, int *passwordDataLength)=0 | RakNet::RakPeerInterface | pure virtual
GetIndexFromSystemAddress(const SystemAddress systemAddress) const =0 | RakNet::RakPeerInterface | pure virtual
GetInternalID(const SystemAddress systemAddress=UNASSIGNED_SYSTEM_ADDRESS, const int index=0) const =0 | RakNet::RakPeerInterface | pure virtual
GetLastPing(const AddressOrGUID systemIdentifier) const =0 | RakNet::RakPeerInterface | pure virtual
GetLocalIP(unsigned int index)=0 | RakNet::RakPeerInterface | pure virtual
GetLowestPing(const AddressOrGUID systemIdentifier) const =0 | RakNet::RakPeerInterface | pure virtual
GetMaximumIncomingConnections(void) const =0 | RakNet::RakPeerInterface | pure virtual
GetMaximumNumberOfPeers(void) const =0 | RakNet::RakPeerInterface | pure virtual
GetMTUSize(const SystemAddress target) const =0 | RakNet::RakPeerInterface | pure virtual
GetMyBoundAddress(const int socketIndex=0)=0 | RakNet::RakPeerInterface | pure virtual
GetMyGUID(void) const =0 | RakNet::RakPeerInterface | pure virtual
GetNextSendReceipt(void)=0 | RakNet::RakPeerInterface | pure virtual
GetNumberOfAddresses(void)=0 | RakNet::RakPeerInterface | pure virtual
GetOfflinePingResponse(char **data, unsigned int *length)=0 | RakNet::RakPeerInterface | pure virtual
GetReceiveBufferSize(void)=0 | RakNet::RakPeerInterface | pure virtual
GetSocket(const SystemAddress target)=0 | RakNet::RakPeerInterface | pure virtual
GetSockets(DataStructures::List< RakNetSocket2 * > &sockets)=0 | RakNet::RakPeerInterface | pure virtual
GetSplitMessageProgressInterval(void) const =0 | RakNet::RakPeerInterface | pure virtual
GetStatistics(const SystemAddress systemAddress, RakNetStatistics *rns=0)=0 | RakNet::RakPeerInterface | pure virtual
GetStatistics(const unsigned int index, RakNetStatistics *rns)=0 | RakNet::RakPeerInterface | pure virtual
GetStatisticsList(DataStructures::List< SystemAddress > &addresses, DataStructures::List< RakNetGUID > &guids, DataStructures::List< RakNetStatistics > &statistics)=0 | RakNet::RakPeerInterface | pure virtual
GetSystemAddressFromGuid(const RakNetGUID input) const =0 | RakNet::RakPeerInterface | pure virtual
GetSystemAddressFromIndex(unsigned int index)=0 | RakNet::RakPeerInterface | pure virtual
GetSystemList(DataStructures::List< SystemAddress > &addresses, DataStructures::List< RakNetGUID > &guids) const =0 | RakNet::RakPeerInterface | pure virtual
GetTimeoutTime(const SystemAddress target)=0 | RakNet::RakPeerInterface | pure virtual
IncrementNextSendReceipt(void)=0 | RakNet::RakPeerInterface | pure virtual
InitializeSecurity(const char *publicKey, const char *privateKey, bool bRequireClientKey=false)=0 | RakNet::RakPeerInterface | pure virtual
IsActive(void) const =0 | RakNet::RakPeerInterface | pure virtual
IsBanned(const char *IP)=0 | RakNet::RakPeerInterface | pure virtual
IsInSecurityExceptionList(const char *ip)=0 | RakNet::RakPeerInterface | pure virtual
IsLocalIP(const char *ip)=0 | RakNet::RakPeerInterface | pure virtual
IsNetworkSimulatorActive(void)=0 | RakNet::RakPeerInterface | pure virtual
NumberOfConnections(void) const =0 | RakNet::RakPeerInterface | pure virtual
Ping(const SystemAddress target)=0 | RakNet::RakPeerInterface | pure virtual
Ping(const char *host, unsigned short remotePort, bool onlyReplyOnAcceptingConnections, unsigned connectionSocketIndex=0)=0 | RakNet::RakPeerInterface | pure virtual
PushBackPacket(Packet *packet, bool pushAtHead)=0 | RakNet::RakPeerInterface | pure virtual
Receive(void)=0 | RakNet::RakPeerInterface | pure virtual
RemoveFromBanList(const char *IP)=0 | RakNet::RakPeerInterface | pure virtual
RemoveFromSecurityExceptionList(const char *ip)=0 | RakNet::RakPeerInterface | pure virtual
Send(const char *data, const int length, PacketPriority priority, PacketReliability reliability, char orderingChannel, const AddressOrGUID systemIdentifier, bool broadcast, uint32_t forceReceiptNumber=0)=0 | RakNet::RakPeerInterface | pure virtual
Send(const RakNet::BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel, const AddressOrGUID systemIdentifier, bool broadcast, uint32_t forceReceiptNumber=0)=0 | RakNet::RakPeerInterface | pure virtual
SendList(const char **data, const int *lengths, const int numParameters, PacketPriority priority, PacketReliability reliability, char orderingChannel, const AddressOrGUID systemIdentifier, bool broadcast, uint32_t forceReceiptNumber=0)=0 | RakNet::RakPeerInterface | pure virtual
SendLoopback(const char *data, const int length)=0 | RakNet::RakPeerInterface | pure virtual
SendTTL(const char *host, unsigned short remotePort, int ttl, unsigned connectionSocketIndex=0)=0 | RakNet::RakPeerInterface | pure virtual
SetIncomingDatagramEventHandler(bool(*_incomingDatagramEventHandler)(RNS2RecvStruct *))=0 | RakNet::RakPeerInterface | pure virtual
SetIncomingPassword(const char *passwordData, int passwordDataLength)=0 | RakNet::RakPeerInterface | pure virtual
SetInternalID(SystemAddress systemAddress, int index=0)=0 | RakNet::RakPeerInterface | pure virtual
SetLimitIPConnectionFrequency(bool b)=0 | RakNet::RakPeerInterface | pure virtual
SetMaximumIncomingConnections(unsigned short numberAllowed)=0 | RakNet::RakPeerInterface | pure virtual
SetOccasionalPing(bool doPing)=0 | RakNet::RakPeerInterface | pure virtual
SetOfflinePingResponse(const char *data, const unsigned int length)=0 | RakNet::RakPeerInterface | pure virtual
SetPerConnectionOutgoingBandwidthLimit(unsigned maxBitsPerSecond)=0 | RakNet::RakPeerInterface | pure virtual
SetSplitMessageProgressInterval(int interval)=0 | RakNet::RakPeerInterface | pure virtual
SetTimeoutTime(RakNet::TimeMS timeMS, const SystemAddress target)=0 | RakNet::RakPeerInterface | pure virtual
SetUnreliableTimeout(RakNet::TimeMS timeoutMS)=0 | RakNet::RakPeerInterface | pure virtual
SetUserUpdateThread(void(*_userUpdateThreadPtr)(RakPeerInterface *, void *), void *_userUpdateThreadData)=0 | RakNet::RakPeerInterface | pure virtual
Shutdown(unsigned int blockDuration, unsigned char orderingChannel=0, PacketPriority disconnectionNotificationPriority=LOW_PRIORITY)=0 | RakNet::RakPeerInterface | pure virtual
Startup(unsigned int maxConnections, SocketDescriptor *socketDescriptors, unsigned socketDescriptorCount, int threadPriority=-99999)=0 | RakNet::RakPeerInterface | pure virtual
~RakPeerInterface() | RakNet::RakPeerInterface | inlinevirtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RakString
RakNet::RakString Member List

This is the complete list of members for RakNet::RakString, including all inherited members.

Assign(const char *str, size_t pos, size_t n) | RakNet::RakString |
C_String(void) const | RakNet::RakString | inline
Clear(void) | RakNet::RakString |
ContainsNonprintableExceptSpaces(void) const | RakNet::RakString |
Deserialize(BitStream *bs) | RakNet::RakString |
Deserialize(char *str, BitStream *bs) | RakNet::RakString | static
DeserializeCompressed(BitStream *bs, bool readLanguageId=false) | RakNet::RakString |
DeserializeCompressed(char *str, BitStream *bs, bool readLanguageId=false) | RakNet::RakString | static
Erase(unsigned int index, unsigned int count) | RakNet::RakString |
Find(const char *stringToFind, size_t pos=0) | RakNet::RakString |
FormatForDELETE(const char *uri, const char *extraHeaders="") | RakNet::RakString | static
FormatForGET(const char *uri, const char *extraHeaders="") | RakNet::RakString | static
FormatForPOST(const char *uri, const char *contentType, const char *body, const char *extraHeaders="") | RakNet::RakString | static
FPrintf(FILE *fp) | RakNet::RakString |
FreeMemory(void) | RakNet::RakString | static
GetCharacterCount(char c) | RakNet::RakString |
GetLength(void) const | RakNet::RakString |
IPAddressMatch(const char *IP) | RakNet::RakString |
IsEmailAddress(void) const | RakNet::RakString |
IsEmpty(void) const | RakNet::RakString |
MakeFilePath(void) | RakNet::RakString |
NonVariadic(const char *str) | RakNet::RakString | static
operator const char *() const | RakNet::RakString | inline
operator!=(const RakString &rhs) const | RakNet::RakString |
operator+=(const RakString &rhs) | RakNet::RakString |
operator=(const RakString &rhs) | RakNet::RakString |
operator==(const RakString &rhs) const | RakNet::RakString |
operator[](const unsigned int position) const | RakNet::RakString |
Printf(void) | RakNet::RakString |
ReadIntFromSubstring(const char *str, size_t pos, size_t n) | RakNet::RakString | static
RemoveCharacter(char c) | RakNet::RakString |
Replace(unsigned index, unsigned count, unsigned char c) | RakNet::RakString |
Serialize(BitStream *bs) const | RakNet::RakString |
Serialize(const char *str, BitStream *bs) | RakNet::RakString | static
SerializeCompressed(BitStream *bs, uint8_t languageId=0, bool writeLanguageId=false) const | RakNet::RakString |
SerializeCompressed(const char *str, BitStream *bs, uint8_t languageId=0, bool writeLanguageId=false) | RakNet::RakString | static
Set(const char *format,...) | RakNet::RakString |
SetChar(unsigned index, unsigned char c) | RakNet::RakString |
SetChar(unsigned index, RakNet::RakString s) | RakNet::RakString |
SplitURI(RakNet::RakString &header, RakNet::RakString &domain, RakNet::RakString &path) | RakNet::RakString |
SQLEscape(void) | RakNet::RakString |
StrCmp(const RakString &rhs) const | RakNet::RakString |
StrICmp(const RakString &rhs) const | RakNet::RakString |
StrNCmp(const RakString &rhs, size_t num) const | RakNet::RakString |
TerminateAtFirstCharacter(char c) | RakNet::RakString |
TerminateAtLastCharacter(char c) | RakNet::RakString |
ToInteger(const char *str) | RakNet::RakString | static
ToLower(void) | RakNet::RakString |
ToUpper(void) | RakNet::RakString |
Truncate(unsigned int length) | RakNet::RakString |
URLDecode(void) | RakNet::RakString |
URLEncode(void) | RakNet::RakString |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RakVoice
RakNet::RakVoice Member List

This is the complete list of members for RakNet::RakVoice, including all inherited members.

CloseAllChannels(void) | RakNet::RakVoice |
CloseVoiceChannel(RakNetGUID recipient) | RakNet::RakVoice |
Deinit(void) | RakNet::RakVoice |
GetBufferedBytesToReturn(RakNetGUID guid) const | RakNet::RakVoice |
GetBufferedBytesToSend(RakNetGUID guid) const | RakNet::RakVoice |
GetBufferSizeBytes(void) const | RakNet::RakVoice |
GetEncoderComplexity(void) | RakNet::RakVoice |
GetRakPeerInterface(void) const | RakNet::RakVoice |
GetSampleRate(void) const | RakNet::RakVoice |
Init(unsigned short speexSampleRate, unsigned bufferSizeBytes) | RakNet::RakVoice |
IsInitialized(void) const | RakNet::RakVoice |
IsLoopbackMode(void) const | RakNet::RakVoice |
IsNoiseFilterActive() | RakNet::RakVoice |
IsSendingVoiceDataTo(RakNetGUID recipient) | RakNet::RakVoice |
IsVADActive(void) | RakNet::RakVoice |
IsVBRActive() | RakNet::RakVoice |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::RakVoice | virtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::RakVoice | virtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
ReceiveFrame(void *outputBuffer) | RakNet::RakVoice |
RequestVoiceChannel(RakNetGUID recipient) | RakNet::RakVoice |
SendFrame(RakNetGUID recipient, void *inputBuffer) | RakNet::RakVoice |
SetEncoderComplexity(int complexity) | RakNet::RakVoice |
SetLoopbackMode(bool enabled) | RakNet::RakVoice |
SetNoiseFilter(bool enable) | RakNet::RakVoice |
SetVAD(bool enable) | RakNet::RakVoice |
SetVBR(bool enable) | RakNet::RakVoice |
Update(void) | RakNet::RakVoice | virtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RakWString
RakNet::RakWString Member List

This is the complete list of members for RakNet::RakWString, including all inherited members.

C_String(void) const | RakNet::RakWString | inline
Clear(void) | RakNet::RakWString |
Deserialize(BitStream *bs) | RakNet::RakWString |
Deserialize(wchar_t *str, BitStream *bs) | RakNet::RakWString | static
FPrintf(FILE *fp) | RakNet::RakWString |
GetLength(void) const | RakNet::RakWString |
IsEmpty(void) const | RakNet::RakWString |
operator wchar_t *() const | RakNet::RakWString | inline
operator!=(const RakWString &right) const | RakNet::RakWString |
operator+=(const RakWString &right) | RakNet::RakWString |
operator=(const RakWString &right) | RakNet::RakWString |
operator==(const RakWString &right) const | RakNet::RakWString |
Printf(void) | RakNet::RakWString |
Serialize(BitStream *bs) const | RakNet::RakWString |
Serialize(const wchar_t *const str, BitStream *bs) | RakNet::RakWString | static
Set(wchar_t *str) | RakNet::RakWString |
StrCmp(const RakWString &right) const | RakNet::RakWString |
StrICmp(const RakWString &right) const | RakNet::RakWString |
ToInteger(const RakWString &rs) | RakNet::RakWString | static
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • ReadyEvent
RakNet::ReadyEvent Member List

This is the complete list of members for RakNet::ReadyEvent, including all inherited members.

AddToWaitList(int eventId, RakNetGUID guid) | RakNet::ReadyEvent |
DeleteEvent(int eventId) | RakNet::ReadyEvent |
ForceCompletion(int eventId) | RakNet::ReadyEvent |
GetEventAtIndex(unsigned index) const | RakNet::ReadyEvent |
GetEventListSize(void) const | RakNet::ReadyEvent |
GetFromWaitListAtIndex(int eventId, unsigned index) const | RakNet::ReadyEvent |
GetReadyStatus(int eventId, RakNetGUID guid) | RakNet::ReadyEvent |
GetRemoteWaitListSize(int eventId) const | RakNet::ReadyEvent |
HasEvent(int eventId) | RakNet::ReadyEvent |
IsEventCompleted(int eventId) const | RakNet::ReadyEvent |
IsEventCompletionProcessing(int eventId) const | RakNet::ReadyEvent |
IsEventSet(int eventId) | RakNet::ReadyEvent |
IsInWaitList(int eventId, RakNetGUID guid) | RakNet::ReadyEvent |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::ReadyEvent | protectedvirtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::ReadyEvent | protectedvirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::ReadyEvent | protectedvirtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
RemoveFromWaitList(int eventId, RakNetGUID guid) | RakNet::ReadyEvent |
SetEvent(int eventId, bool isReady) | RakNet::ReadyEvent |
SetSendChannel(unsigned char newChannel) | RakNet::ReadyEvent |
Update(void) | RakNet::PluginInterface2 | inlinevirtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RelayPlugin
RakNet::RelayPlugin Member List

This is the complete list of members for RakNet::RelayPlugin, including all inherited members.

AddParticipantOnServer(const RakString &key, const RakNetGUID &guid) | RakNet::RelayPlugin |
AddParticipantRequestFromClient(const RakString &key, const RakNetGUID &relayPluginServerGuid) | RakNet::RelayPlugin |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::RelayPlugin | virtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::RelayPlugin | virtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
RelayPlugin() | RakNet::RelayPlugin |
RemoveParticipantOnServer(const RakNetGUID &guid) | RakNet::RelayPlugin |
RemoveParticipantRequestFromClient(const RakNetGUID &relayPluginServerGuid) | RakNet::RelayPlugin |
SendToParticipant(const RakNetGUID &relayPluginServerGuid, const RakString &destinationGuid, BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel) | RakNet::RelayPlugin |
SetAcceptAddParticipantRequests(bool accept) | RakNet::RelayPlugin |
Update(void) | RakNet::PluginInterface2 | inlinevirtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
~RelayPlugin() | RakNet::RelayPlugin | virtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • ReliabilityLayer
RakNet::ReliabilityLayer Member List

This is the complete list of members for RakNet::ReliabilityLayer, including all inherited members.

AckTimeout(RakNet::Time curTime) | RakNet::ReliabilityLayer
GetStatistics(RakNetStatistics *rns) | RakNet::ReliabilityLayer
GetTimeoutTime(void) | RakNet::ReliabilityLayer
HandleSocketReceiveFromConnectedPlayer(const char *buffer, unsigned int length, SystemAddress &systemAddress, DataStructures::List< PluginInterface2 * > &messageHandlerList, int MTUSize, RakNetSocket2 *s, RakNetRandom *rnr, CCTimeType timeRead, BitStream &updateBitStream) | RakNet::ReliabilityLayer
IsDeadConnection(void) const | RakNet::ReliabilityLayer
IsNetworkSimulatorActive(void) | RakNet::ReliabilityLayer
IsOutgoingDataWaiting(void) | RakNet::ReliabilityLayer
KillConnection(void) | RakNet::ReliabilityLayer
Receive(unsigned char **data) | RakNet::ReliabilityLayer
Reset(bool resetVariables, int MTUSize, bool _useSecurity) | RakNet::ReliabilityLayer
Send(char *data, BitSize_t numberOfBitsToSend, PacketPriority priority, PacketReliability reliability, unsigned char orderingChannel, bool makeDataCopy, int MTUSize, CCTimeType currentTime, uint32_t receipt) | RakNet::ReliabilityLayer
SetTimeoutTime(RakNet::TimeMS time) | RakNet::ReliabilityLayer
Update(RakNetSocket2 *s, SystemAddress &systemAddress, int MTUSize, CCTimeType time, unsigned bitsPerSecondLimit, DataStructures::List< PluginInterface2 * > &messageHandlerList, RakNetRandom *rnr, BitStream &updateBitStream) | RakNet::ReliabilityLayer
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Replica3
RakNet::Replica3 Member List

This is the complete list of members for RakNet::Replica3, including all inherited members.

BroadcastDestruction(void) | RakNet::Replica3 | virtual
creatingSystemGUID | RakNet::Replica3 |
DeallocReplica(RakNet::Connection_RM3 *sourceConnection)=0 | RakNet::Replica3 | pure virtual
deletingSystemGUID | RakNet::Replica3 |
Deserialize(RakNet::DeserializeParameters *deserializeParameters)=0 | RakNet::Replica3 | pure virtual
DeserializeConstruction(RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *sourceConnection)=0 | RakNet::Replica3 | pure virtual
DeserializeConstructionExisting(RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *sourceConnection) | RakNet::Replica3 | inlinevirtual
DeserializeDestruction(RakNet::BitStream *destructionBitstream, RakNet::Connection_RM3 *sourceConnection)=0 | RakNet::Replica3 | pure virtual
GetCreatingSystemGUID(void) const | RakNet::Replica3 |
GetNetworkID(void) | RakNet::NetworkIDObject | virtual
GetNetworkIDManager(void) const | RakNet::NetworkIDObject | virtual
GetParent(void) const | RakNet::NetworkIDObject | virtual
networkID | RakNet::NetworkIDObject | protected
OnPoppedConnection(RakNet::Connection_RM3 *droppedConnection) | RakNet::Replica3 | inlinevirtual
OnSerializeTransmission(RakNet::BitStream *bitStream, RakNet::Connection_RM3 *destinationConnection, BitSize_t bitsPerChannel[RM3_NUM_OUTPUT_BITSTREAM_CHANNELS], RakNet::Time curTime) | RakNet::Replica3 | inlinevirtual
OnUserReplicaPreSerializeTick(void) | RakNet::Replica3 | inlinevirtual
parent | RakNet::NetworkIDObject | protected
PostDeserializeConstruction(RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *sourceConnection) | RakNet::Replica3 | inlinevirtual
PostDeserializeConstructionExisting(RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *sourceConnection) | RakNet::Replica3 | inlinevirtual
PostSerializeConstruction(RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *destinationConnection) | RakNet::Replica3 | inlinevirtual
PostSerializeConstructionExisting(RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *destinationConnection) | RakNet::Replica3 | inlinevirtual
PreDestruction(RakNet::Connection_RM3 *sourceConnection) | RakNet::Replica3 | inlinevirtual
QueryActionOnPopConnection(RakNet::Connection_RM3 *droppedConnection) const =0 | RakNet::Replica3 | pure virtual
QueryActionOnPopConnection_Client(RakNet::Connection_RM3 *droppedConnection) const | RakNet::Replica3 | virtual
QueryActionOnPopConnection_PeerToPeer(RakNet::Connection_RM3 *droppedConnection) const | RakNet::Replica3 | virtual
QueryActionOnPopConnection_Server(RakNet::Connection_RM3 *droppedConnection) const | RakNet::Replica3 | virtual
QueryConstruction(RakNet::Connection_RM3 *destinationConnection, ReplicaManager3 *replicaManager3)=0 | RakNet::Replica3 | pure virtual
QueryConstruction_ClientConstruction(RakNet::Connection_RM3 *destinationConnection, bool isThisTheServer) | RakNet::Replica3 | virtual
QueryConstruction_PeerToPeer(RakNet::Connection_RM3 *destinationConnection, Replica3P2PMode p2pMode=R3P2PM_SINGLE_OWNER) | RakNet::Replica3 | virtual
QueryConstruction_ServerConstruction(RakNet::Connection_RM3 *destinationConnection, bool isThisTheServer) | RakNet::Replica3 | virtual
QueryDestruction(RakNet::Connection_RM3 *destinationConnection, ReplicaManager3 *replicaManager3) | RakNet::Replica3 | inlinevirtual
QueryRelayDestruction(Connection_RM3 *sourceConnection) const | RakNet::Replica3 | inlinevirtual
QueryRemoteConstruction(RakNet::Connection_RM3 *sourceConnection)=0 | RakNet::Replica3 | pure virtual
QueryRemoteConstruction_ClientConstruction(RakNet::Connection_RM3 *sourceConnection, bool isThisTheServer) | RakNet::Replica3 | virtual
QueryRemoteConstruction_PeerToPeer(RakNet::Connection_RM3 *sourceConnection) | RakNet::Replica3 | virtual
QueryRemoteConstruction_ServerConstruction(RakNet::Connection_RM3 *sourceConnection, bool isThisTheServer) | RakNet::Replica3 | virtual
QuerySerialization(RakNet::Connection_RM3 *destinationConnection)=0 | RakNet::Replica3 | pure virtual
QuerySerialization_ClientSerializable(RakNet::Connection_RM3 *destinationConnection, bool isThisTheServer) | RakNet::Replica3 | virtual
QuerySerialization_PeerToPeer(RakNet::Connection_RM3 *destinationConnection, Replica3P2PMode p2pMode=R3P2PM_SINGLE_OWNER) | RakNet::Replica3 | virtual
QuerySerialization_ServerSerializable(RakNet::Connection_RM3 *destinationConnection, bool isThisTheServer) | RakNet::Replica3 | virtual
Serialize(RakNet::SerializeParameters *serializeParameters)=0 | RakNet::Replica3 | pure virtual
SerializeConstruction(RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *destinationConnection)=0 | RakNet::Replica3 | pure virtual
SerializeConstructionExisting(RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *destinationConnection) | RakNet::Replica3 | inlinevirtual
SerializeDestruction(RakNet::BitStream *destructionBitstream, RakNet::Connection_RM3 *destinationConnection)=0 | RakNet::Replica3 | pure virtual
SetNetworkID(NetworkID id) | RakNet::NetworkIDObject | virtual
SetNetworkIDManager(NetworkIDManager *manager) | RakNet::NetworkIDObject | virtual
SetParent(void *_parent) | RakNet::NetworkIDObject | virtual
WasReferenced(void) const | RakNet::Replica3 | inline
WriteAllocationID(RakNet::Connection_RM3 *destinationConnection, RakNet::BitStream *allocationIdBitstream) const =0 | RakNet::Replica3 | pure virtual
~Replica3() | RakNet::Replica3 | virtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Replica3Composite
RakNet::Replica3Composite< parent_type > Member List

This is the complete list of members for RakNet::Replica3Composite< parent_type >, including all inherited members.

BroadcastDestruction(void) | RakNet::Replica3 | virtual
creatingSystemGUID | RakNet::Replica3 |
DeallocReplica(RakNet::Connection_RM3 *sourceConnection) | RakNet::Replica3Composite< parent_type > | inlinevirtual
deletingSystemGUID | RakNet::Replica3 |
Deserialize(RakNet::DeserializeParameters *deserializeParameters) | RakNet::Replica3Composite< parent_type > | inlinevirtual
DeserializeConstruction(RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *sourceConnection) | RakNet::Replica3Composite< parent_type > | inlinevirtual
DeserializeConstructionExisting(RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *sourceConnection) | RakNet::Replica3Composite< parent_type > | inlinevirtual
DeserializeDestruction(RakNet::BitStream *destructionBitstream, RakNet::Connection_RM3 *sourceConnection) | RakNet::Replica3Composite< parent_type > | inlinevirtual
GetCreatingSystemGUID(void) const | RakNet::Replica3 |
GetNetworkID(void) | RakNet::NetworkIDObject | virtual
GetNetworkIDManager(void) const | RakNet::NetworkIDObject | virtual
GetParent(void) const | RakNet::NetworkIDObject | virtual
networkID | RakNet::NetworkIDObject | protected
OnPoppedConnection(RakNet::Connection_RM3 *droppedConnection) | RakNet::Replica3Composite< parent_type > | inlinevirtual
RakNet::Replica3::OnSerializeTransmission(RakNet::BitStream *bitStream, RakNet::Connection_RM3 *destinationConnection, BitSize_t bitsPerChannel[RM3_NUM_OUTPUT_BITSTREAM_CHANNELS], RakNet::Time curTime) | RakNet::Replica3 | inlinevirtual
OnUserReplicaPreSerializeTick(void) | RakNet::Replica3Composite< parent_type > | inlinevirtual
parent | RakNet::NetworkIDObject | protected
PostDeserializeConstruction(RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *sourceConnection) | RakNet::Replica3Composite< parent_type > | inlinevirtual
PostDeserializeConstructionExisting(RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *sourceConnection) | RakNet::Replica3Composite< parent_type > | inlinevirtual
PostSerializeConstruction(RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *destinationConnection) | RakNet::Replica3Composite< parent_type > | inlinevirtual
PostSerializeConstructionExisting(RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *destinationConnection) | RakNet::Replica3Composite< parent_type > | inlinevirtual
PreDestruction(RakNet::Connection_RM3 *sourceConnection) | RakNet::Replica3Composite< parent_type > | inlinevirtual
QueryActionOnPopConnection(RakNet::Connection_RM3 *droppedConnection) const | RakNet::Replica3Composite< parent_type > | inlinevirtual
QueryActionOnPopConnection_Client(RakNet::Connection_RM3 *droppedConnection) const | RakNet::Replica3 | virtual
QueryActionOnPopConnection_PeerToPeer(RakNet::Connection_RM3 *droppedConnection) const | RakNet::Replica3 | virtual
QueryActionOnPopConnection_Server(RakNet::Connection_RM3 *droppedConnection) const | RakNet::Replica3 | virtual
QueryConstruction(RakNet::Connection_RM3 *destinationConnection, RakNet::ReplicaManager3 *replicaManager3) | RakNet::Replica3Composite< parent_type > | inlinevirtual
QueryConstruction_ClientConstruction(RakNet::Connection_RM3 *destinationConnection, bool isThisTheServer) | RakNet::Replica3 | virtual
QueryConstruction_PeerToPeer(RakNet::Connection_RM3 *destinationConnection, Replica3P2PMode p2pMode=R3P2PM_SINGLE_OWNER) | RakNet::Replica3 | virtual
QueryConstruction_ServerConstruction(RakNet::Connection_RM3 *destinationConnection, bool isThisTheServer) | RakNet::Replica3 | virtual
QueryDestruction(RakNet::Connection_RM3 *destinationConnection, RakNet::ReplicaManager3 *replicaManager3) | RakNet::Replica3Composite< parent_type > | inlinevirtual
QueryRelayDestruction(RakNet::Connection_RM3 *sourceConnection) const | RakNet::Replica3Composite< parent_type > | inlinevirtual
QueryRemoteConstruction(RakNet::Connection_RM3 *sourceConnection) | RakNet::Replica3Composite< parent_type > | inlinevirtual
QueryRemoteConstruction_ClientConstruction(RakNet::Connection_RM3 *sourceConnection, bool isThisTheServer) | RakNet::Replica3 | virtual
QueryRemoteConstruction_PeerToPeer(RakNet::Connection_RM3 *sourceConnection) | RakNet::Replica3 | virtual
QueryRemoteConstruction_ServerConstruction(RakNet::Connection_RM3 *sourceConnection, bool isThisTheServer) | RakNet::Replica3 | virtual
QuerySerialization(RakNet::Connection_RM3 *destinationConnection) | RakNet::Replica3Composite< parent_type > | inlinevirtual
QuerySerialization_ClientSerializable(RakNet::Connection_RM3 *destinationConnection, bool isThisTheServer) | RakNet::Replica3 | virtual
QuerySerialization_PeerToPeer(RakNet::Connection_RM3 *destinationConnection, Replica3P2PMode p2pMode=R3P2PM_SINGLE_OWNER) | RakNet::Replica3 | virtual
QuerySerialization_ServerSerializable(RakNet::Connection_RM3 *destinationConnection, bool isThisTheServer) | RakNet::Replica3 | virtual
Serialize(RakNet::SerializeParameters *serializeParameters) | RakNet::Replica3Composite< parent_type > | inlinevirtual
SerializeConstruction(RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *destinationConnection) | RakNet::Replica3Composite< parent_type > | inlinevirtual
SerializeConstructionExisting(RakNet::BitStream *constructionBitstream, RakNet::Connection_RM3 *destinationConnection) | RakNet::Replica3Composite< parent_type > | inlinevirtual
SerializeDestruction(RakNet::BitStream *destructionBitstream, RakNet::Connection_RM3 *destinationConnection) | RakNet::Replica3Composite< parent_type > | inlinevirtual
SetNetworkID(NetworkID id) | RakNet::NetworkIDObject | virtual
SetNetworkIDManager(NetworkIDManager *manager) | RakNet::NetworkIDObject | virtual
SetParent(void *_parent) | RakNet::NetworkIDObject | virtual
WasReferenced(void) const | RakNet::Replica3 | inline
WriteAllocationID(RakNet::Connection_RM3 *destinationConnection, RakNet::BitStream *allocationIdBitstream) const | RakNet::Replica3Composite< parent_type > | inlinevirtual
~Replica3() | RakNet::Replica3 | virtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • ReplicaManager3
RakNet::ReplicaManager3 Member List

This is the complete list of members for RakNet::ReplicaManager3, including all inherited members.

AddWorld(WorldId worldId) | RakNet::ReplicaManager3 |
AllocConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID) const =0 | RakNet::ReplicaManager3 | pure virtual
AutoCreateConnectionList(DataStructures::List< RakNetGUID > &participantListIn, DataStructures::List< Connection_RM3 * > &participantListOut, WorldId worldId=0) | RakNet::ReplicaManager3 |
BroadcastDestructionList(DataStructures::List< Replica3 * > &replicaListSource, const SystemAddress &exclusionAddress, WorldId worldId=0) | RakNet::ReplicaManager3 |
DeallocConnection(Connection_RM3 *connection) const =0 | RakNet::ReplicaManager3 | pure virtual
Dereference(RakNet::Replica3 *replica3, WorldId worldId=0) | RakNet::ReplicaManager3 |
DereferenceList(DataStructures::List< Replica3 * > &replicaListIn, WorldId worldId=0) | RakNet::ReplicaManager3 |
GetAllConnectionDownloadsCompleted(WorldId worldId=0) const | RakNet::ReplicaManager3 |
GetAutoCreateConnections(void) const | RakNet::ReplicaManager3 |
GetAutoDestroyConnections(void) const | RakNet::ReplicaManager3 |
GetConnectionAtIndex(unsigned index, WorldId worldId=0) const | RakNet::ReplicaManager3 |
GetConnectionByGUID(RakNetGUID guid, WorldId worldId=0) const | RakNet::ReplicaManager3 |
GetConnectionBySystemAddress(const SystemAddress &sa, WorldId worldId=0) const | RakNet::ReplicaManager3 |
GetConnectionCount(WorldId worldId=0) const | RakNet::ReplicaManager3 |
GetConnectionsThatHaveReplicaConstructed(Replica3 *replica, DataStructures::List< Connection_RM3 * > &connectionsThatHaveConstructedThisReplica, WorldId worldId=0) | RakNet::ReplicaManager3 |
GetNetworkIDManager(WorldId worldId=0) const | RakNet::ReplicaManager3 |
GetReferencedReplicaList(DataStructures::List< Replica3 * > &replicaListOut, WorldId worldId=0) | RakNet::ReplicaManager3 |
GetReplicaAtIndex(unsigned index, WorldId worldId=0) | RakNet::ReplicaManager3 |
GetReplicaCount(WorldId worldId=0) const | RakNet::ReplicaManager3 |
GetReplicasCreatedByGuid(RakNetGUID guid, DataStructures::List< Replica3 * > &replicaListOut, WorldId worldId=0) | RakNet::ReplicaManager3 |
GetReplicasCreatedByMe(DataStructures::List< Replica3 * > &replicaListOut, WorldId worldId=0) | RakNet::ReplicaManager3 |
GetWorldCount(void) const | RakNet::ReplicaManager3 |
GetWorldIdAtIndex(unsigned int index) | RakNet::ReplicaManager3 |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::ReplicaManager3 | protectedvirtual
OnDetach(void) | RakNet::ReplicaManager3 | protectedvirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::ReplicaManager3 | protectedvirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::ReplicaManager3 | protectedvirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::ReplicaManager3 | protectedvirtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
PopConnection(RakNetGUID guid, WorldId worldId=0) | RakNet::ReplicaManager3 |
PushConnection(RakNet::Connection_RM3 *newConnection, WorldId worldId=0) | RakNet::ReplicaManager3 |
Reference(RakNet::Replica3 *replica3, WorldId worldId=0) | RakNet::ReplicaManager3 |
RemoveWorld(WorldId worldId) | RakNet::ReplicaManager3 |
SetAutoManageConnections(bool autoCreate, bool autoDestroy) | RakNet::ReplicaManager3 |
SetAutoSerializeInterval(RakNet::Time intervalMS) | RakNet::ReplicaManager3 |
SetDefaultOrderingChannel(char def) | RakNet::ReplicaManager3 |
SetDefaultPacketPriority(PacketPriority def) | RakNet::ReplicaManager3 |
SetDefaultPacketReliability(PacketReliability def) | RakNet::ReplicaManager3 |
SetNetworkIDManager(NetworkIDManager *_networkIDManager, WorldId worldId=0) | RakNet::ReplicaManager3 |
Update(void) | RakNet::ReplicaManager3 | virtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RoomsPlugin
RakNet::RoomsPlugin Member List

This is the complete list of members for RakNet::RoomsPlugin, including all inherited members.

AddLoginServerAddress(SystemAddress systemAddress) | RakNet::RoomsPlugin |
AddRoomsCallback(RoomsCallback *_roomsCallback) | RakNet::RoomsPlugin |
ChangeHandle(RakNet::RakString oldHandle, RakNet::RakString newHandle) | RakNet::RoomsPlugin |
ClearLoginServerAdddresses(void) | RakNet::RoomsPlugin |
ClearRoomMembers() | RakNet::RoomsPlugin |
ExecuteFunc(RoomsPluginFunc *func) | RakNet::RoomsPlugin |
ExecuteFunc(RoomsPluginFunc *func, SystemAddress remoteAddress) | RakNet::RoomsPlugin |
LoginRoomsParticipant(RakNet::RakString userName, SystemAddress roomsParticipantAddress, RakNetGUID guid, SystemAddress loginServerAddress) | RakNet::RoomsPlugin |
LogoffRoomsParticipant(RakNet::RakString userName, SystemAddress loginServerAddress) | RakNet::RoomsPlugin |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::RoomsPlugin | virtual
OnDetach(void) | RakNet::RoomsPlugin | virtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::RoomsPlugin | virtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
RemoveLoginServerAddress(SystemAddress systemAddress) | RakNet::RoomsPlugin |
RemoveRoomsCallback(RoomsCallback *_roomsCallback) | RakNet::RoomsPlugin |
roomsContainer | RakNet::RoomsPlugin |
SerializeChangeHandle(RakNet::RakString oldHandle, RakNet::RakString newHandle, RakNet::BitStream *bs) | RakNet::RoomsPlugin | static
SerializeLogin(RakNet::RakString userName, SystemAddress userAddress, RakNetGUID guid, RakNet::BitStream *bs) | RakNet::RoomsPlugin | static
SerializeLogoff(RakNet::RakString userName, RakNet::BitStream *bs) | RakNet::RoomsPlugin | static
SetOrderingChannel(char oc) | RakNet::RoomsPlugin |
SetProfanityFilter(ProfanityFilter *pf) | RakNet::RoomsPlugin |
SetRoomsCallback(RoomsCallback *_roomsCallback) | RakNet::RoomsPlugin |
SetSendPriority(PacketPriority pp) | RakNet::RoomsPlugin |
SetServerAddress(SystemAddress systemAddress) | RakNet::RoomsPlugin |
Update(void) | RakNet::RoomsPlugin | virtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Router2
RakNet::Router2 Member List

This is the complete list of members for RakNet::Router2, including all inherited members.

EstablishRouting(RakNetGUID endpointGuid) | RakNet::Router2 |
GetDebugInterface(void) const | RakNet::Router2 |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::Router2 | virtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::Router2 | virtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::Router2 | virtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::Router2 | virtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
SetDebugInterface(Router2DebugInterface *_debugInterface) | RakNet::Router2 |
SetMaximumForwardingRequests(int max) | RakNet::Router2 |
SetSocketFamily(unsigned short _socketFamily) | RakNet::Router2 |
Update(void) | RakNet::Router2 | virtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RPC3
RakNet::RPC3 Member List

This is the complete list of members for RakNet::RPC3, including all inherited members.

Call(const char *uniqueIdentifier) | RakNet::RPC3 | inline
CallExplicit(const char *uniqueIdentifier, const CallExplicitParameters *const callExplicitParameters) | RakNet::RPC3 | inline
GetCurrentExecution(void) const | RakNet::RPC3 |
GetLastSenderAddress(void) const | RakNet::RPC3 |
GetLastSenderTimestamp(void) const | RakNet::RPC3 |
GetRakPeer(void) const | RakNet::RPC3 |
InterruptSignal(void) | RakNet::RPC3 |
InvokeSignal(DataStructures::HashIndex functionIndex, RakNet::BitStream *serializedParameters, bool temporarilySetUSA) | RakNet::RPC3 |
IsFunctionRegistered(const char *uniqueIdentifier) | RakNet::RPC3 |
nextSlotRegistrationCount | RakNet::RPC3 | protected
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::RPC3 | protectedvirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::RPC3 | protectedvirtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::RPC3 | protectedvirtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
RegisterFunction(const char *uniqueIdentifier, Function functionPtr) | RakNet::RPC3 | inline
RegisterSlot(const char *sharedIdentifier, Function functionPtr, NetworkID objectInstanceId, int callPriority) | RakNet::RPC3 | inline
SetNetworkIDManager(NetworkIDManager *idMan) | RakNet::RPC3 |
SetRecipientAddress(const SystemAddress &systemAddress, bool broadcast) | RakNet::RPC3 |
SetRecipientObject(NetworkID networkID) | RakNet::RPC3 |
SetSendParams(PacketPriority priority, PacketReliability reliability, char orderingChannel) | RakNet::RPC3 |
SetTimestamp(RakNet::Time timeStamp) | RakNet::RPC3 |
Signal(const char *sharedIdentifier) | RakNet::RPC3 | inline
SignalExplicit(const char *sharedIdentifier, const SignalExplicitParameters *const signalExplicitParameters) | RakNet::RPC3 | inline
UnregisterFunction(const char *uniqueIdentifier) | RakNet::RPC3 |
Update(void) | RakNet::PluginInterface2 | inlinevirtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RPC4
RakNet::RPC4 Member List

This is the complete list of members for RakNet::RPC4, including all inherited members.

Call(const char *uniqueID, RakNet::BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel, const AddressOrGUID systemIdentifier, bool broadcast) | RakNet::RPC4 |
CallBlocking(const char *uniqueID, RakNet::BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel, const AddressOrGUID systemIdentifier, RakNet::BitStream *returnData) | RakNet::RPC4 |
CallLoopback(const char *uniqueID, RakNet::BitStream *bitStream) | RakNet::RPC4 |
InterruptSignal(void) | RakNet::RPC4 |
nextSlotRegistrationCount | RakNet::RPC4 | protected
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::RPC4 | protectedvirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::PluginInterface2 | inlinevirtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::RPC4 | protectedvirtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
RegisterBlockingFunction(const char *uniqueID, void(*functionPointer)(RakNet::BitStream *userData, RakNet::BitStream *returnData, Packet *packet)) | RakNet::RPC4 |
RegisterFunction(const char *uniqueID, void(*functionPointer)(RakNet::BitStream *userData, Packet *packet)) | RakNet::RPC4 |
RegisterLocalCallback(const char *uniqueID, MessageID messageId) | RakNet::RPC4 |
RegisterSlot(const char *sharedIdentifier, void(*functionPointer)(RakNet::BitStream *userData, Packet *packet), int callPriority) | RakNet::RPC4 |
Signal(const char *sharedIdentifier, RakNet::BitStream *bitStream, PacketPriority priority, PacketReliability reliability, char orderingChannel, const AddressOrGUID systemIdentifier, bool broadcast, bool invokeLocal) | RakNet::RPC4 |
UnregisterBlockingFunction(const char *uniqueID) | RakNet::RPC4 |
UnregisterFunction(const char *uniqueID) | RakNet::RPC4 |
UnregisterLocalCallback(const char *uniqueID, MessageID messageId) | RakNet::RPC4 |
UnregisterSlot(const char *sharedIdentifier) | RakNet::RPC4 |
Update(void) | RakNet::PluginInterface2 | inlinevirtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RPC4GlobalRegistration
RakNet::RPC4GlobalRegistration Member List

This is the complete list of members for RakNet::RPC4GlobalRegistration, including all inherited members.

RPC4GlobalRegistration(const char *uniqueID, void(*functionPointer)(RakNet::BitStream *userData, Packet *packet)) | RakNet::RPC4GlobalRegistration
RPC4GlobalRegistration(const char *uniqueID, void(*functionPointer)(RakNet::BitStream *userData, Packet *packet), int callPriority) | RakNet::RPC4GlobalRegistration
RPC4GlobalRegistration(const char *uniqueID, void(*functionPointer)(RakNet::BitStream *userData, RakNet::BitStream *returnData, Packet *packet)) | RakNet::RPC4GlobalRegistration
RPC4GlobalRegistration(const char *uniqueID, MessageID messageId) | RakNet::RPC4GlobalRegistration
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • SimpleMutex
RakNet::SimpleMutex Member List

This is the complete list of members for RakNet::SimpleMutex, including all inherited members.

Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • SQLite3ClientPlugin
RakNet::SQLite3ClientPlugin Member List

This is the complete list of members for RakNet::SQLite3ClientPlugin, including all inherited members.

_sqlite3_exec(RakNet::RakString dbIdentifier, RakNet::RakString inputStatement, PacketPriority priority, PacketReliability reliability, char orderingChannel, const SystemAddress &systemAddress) | RakNet::SQLite3ClientPlugin |
AddResultHandler(SQLite3PluginResultInterface *res) | RakNet::SQLite3ClientPlugin |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::PluginInterface2 | inlinevirtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::SQLite3ClientPlugin | virtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
Update(void) | RakNet::PluginInterface2 | inlinevirtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • SQLite3PluginResultInterface
RakNet::SQLite3PluginResultInterface Member List

This is the complete list of members for RakNet::SQLite3PluginResultInterface, including all inherited members.

_sqlite3_exec(RakNet::RakString inputStatement, unsigned int queryId, RakNet::RakString dbIdentifier, const SQLite3Table &table, RakNet::RakString errorMsg)=0 | RakNet::SQLite3PluginResultInterface | pure virtual
OnUnknownDBIdentifier(RakNet::RakString inputStatement, unsigned int queryId, RakNet::RakString dbIdentifier)=0 | RakNet::SQLite3PluginResultInterface | pure virtual
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • SQLite3PluginResultInterface_Printf
RakNet::SQLite3PluginResultInterface_Printf Member List

This is the complete list of members for RakNet::SQLite3PluginResultInterface_Printf, including all inherited members.

Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • SQLite3ServerPlugin
RakNet::SQLite3ServerPlugin Member List

This is the complete list of members for RakNet::SQLite3ServerPlugin, including all inherited members.

AddDBHandle(RakNet::RakString dbIdentifier, sqlite3 *dbHandle, bool dbAutoCreated=false) | RakNet::SQLite3ServerPlugin | virtual
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::SQLite3ServerPlugin | virtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::PluginInterface2 | inlinevirtual
OnDetach(void) | RakNet::SQLite3ServerPlugin | virtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::SQLite3ServerPlugin | virtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
RemoveDBHandle(RakNet::RakString dbIdentifier, bool alsoCloseConnection=false) | RakNet::SQLite3ServerPlugin |
Update(void) | RakNet::SQLite3ServerPlugin | virtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • StatisticsHistory
RakNet::StatisticsHistory Member List

This is the complete list of members for RakNet::StatisticsHistory, including all inherited members.

DC_CONTINUOUS enum value | RakNet::StatisticsHistory
DC_DISCRETE enum value | RakNet::StatisticsHistory
SHDataCategory enum name | RakNet::StatisticsHistory
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • StatisticsHistoryPlugin
RakNet::StatisticsHistoryPlugin Member List

This is the complete list of members for RakNet::StatisticsHistoryPlugin, including all inherited members.

OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::StatisticsHistoryPlugin | protectedvirtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::StatisticsHistoryPlugin | protectedvirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::PluginInterface2 | inlinevirtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
Update(void) | RakNet::StatisticsHistoryPlugin | protectedvirtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • StringCompressor
RakNet::StringCompressor Member List

This is the complete list of members for RakNet::StringCompressor, including all inherited members.

AddReference(void) | RakNet::StringCompressor | static
DecodeString(char *output, int maxCharsToWrite, RakNet::BitStream *input, uint8_t languageId=0) | RakNet::StringCompressor |
EncodeString(const char *input, int maxCharsToWrite, RakNet::BitStream *output, uint8_t languageId=0) | RakNet::StringCompressor |
GenerateTreeFromStrings(unsigned char *input, unsigned inputLength, uint8_t languageId) | RakNet::StringCompressor |
Instance(void) | RakNet::StringCompressor | static
RemoveReference(void) | RakNet::StringCompressor | static
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • StringTable
RakNet::StringTable Member List

This is the complete list of members for RakNet::StringTable, including all inherited members.

AddReference(void) | RakNet::StringTable | static
AddString(const char *str, bool copyString) | RakNet::StringTable |
DecodeString(char *output, int maxCharsToWrite, RakNet::BitStream *input) | RakNet::StringTable |
EncodeString(const char *input, int maxCharsToWrite, RakNet::BitStream *output) | RakNet::StringTable |
Instance(void) | RakNet::StringTable | static
instance | RakNet::StringTable | protectedstatic
LogStringNotFound(const char *strName) | RakNet::StringTable | protected
RemoveReference(void) | RakNet::StringTable | static
StringTable() | RakNet::StringTable |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • TeamBalancer
RakNet::TeamBalancer Member List

This is the complete list of members for RakNet::TeamBalancer, including all inherited members.

CancelRequestSpecificTeam(NetworkID memberId) | RakNet::TeamBalancer |
DefaultAssigmentAlgorithm enum name | RakNet::TeamBalancer |
DeleteMember(NetworkID memberId) | RakNet::TeamBalancer |
FILL_IN_ORDER enum value | RakNet::TeamBalancer |
GetMyTeam(NetworkID memberId) const | RakNet::TeamBalancer |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::TeamBalancer | protectedvirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::TeamBalancer | protectedvirtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::TeamBalancer | protectedvirtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
RequestAnyTeam(NetworkID memberId) | RakNet::TeamBalancer |
RequestSpecificTeam(NetworkID memberId, TeamId desiredTeam) | RakNet::TeamBalancer |
SetDefaultAssignmentAlgorithm(DefaultAssigmentAlgorithm daa) | RakNet::TeamBalancer |
SetForceEvenTeams(bool force) | RakNet::TeamBalancer |
SetLockTeams(bool lock) | RakNet::TeamBalancer |
SetTeamSizeLimit(TeamId team, unsigned short limit) | RakNet::TeamBalancer |
SMALLEST_TEAM enum value | RakNet::TeamBalancer |
Update(void) | RakNet::PluginInterface2 | inlinevirtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • TeamManager
RakNet::TeamManager Member List

This is the complete list of members for RakNet::TeamManager, including all inherited members.

AddWorld(WorldId worldId) | RakNet::TeamManager |
Clear(void) | RakNet::TeamManager |
DecodeTeamAssigned(Packet *packet, TM_World **world, TM_TeamMember **teamMember) | RakNet::TeamManager |
DecodeTeamAssigned(RakNet::BitStream *bsIn, TM_World **world, TM_TeamMember **teamMember, NoTeamId &noTeamSubcategory, JoinTeamType &joinTeamType, DataStructures::List< TM_Team * > &newTeam, DataStructures::List< TM_Team * > &teamsLeft, DataStructures::List< TM_Team * > &teamsJoined) | RakNet::TeamManager | protected
DecodeTeamCancelled(Packet *packet, TM_World **world, TM_TeamMember **teamMember, TM_Team **teamCancelled) | RakNet::TeamManager |
DecomposeTeamFull(Packet *packet, TM_World **world, TM_TeamMember **teamMember, TM_Team **team, uint16_t &currentMembers, uint16_t &memberLimitIncludingBalancing, bool &balancingIsActive, JoinPermissions &joinPermissions) | RakNet::TeamManager |
DecomposeTeamLocked(Packet *packet, TM_World **world, TM_TeamMember **teamMember, TM_Team **team, uint16_t &currentMembers, uint16_t &memberLimitIncludingBalancing, bool &balancingIsActive, JoinPermissions &joinPermissions) | RakNet::TeamManager |
GetWorldAtIndex(unsigned int index) const | RakNet::TeamManager |
GetWorldCount(void) const | RakNet::TeamManager |
GetWorldWithId(WorldId worldId) const | RakNet::TeamManager |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::TeamManager | protectedvirtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::TeamManager | protectedvirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::TeamManager | protectedvirtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
RemoveWorld(WorldId worldId) | RakNet::TeamManager |
SetAutoManageConnections(bool autoAdd) | RakNet::TeamManager |
SetTopology(TMTopology _topology) | RakNet::TeamManager |
Update(void) | RakNet::TeamManager | protectedvirtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • TelnetTransport
RakNet::TelnetTransport Member List

This is the complete list of members for RakNet::TelnetTransport, including all inherited members.

CloseConnection(SystemAddress systemAddress) | RakNet::TelnetTransport | virtual
DeallocatePacket(Packet *packet) | RakNet::TelnetTransport | virtual
GetCommandParser(void) | RakNet::TelnetTransport | virtual
HasLostConnection(void) | RakNet::TelnetTransport | virtual
HasNewIncomingConnection(void) | RakNet::TelnetTransport | virtual
Receive(void) | RakNet::TelnetTransport | virtual
Send(SystemAddress systemAddress, const char *data,...) | RakNet::TelnetTransport | virtual
Start(unsigned short port, bool serverMode) | RakNet::TelnetTransport | virtual
Stop(void) | RakNet::TelnetTransport | virtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • ThreadsafePacketLogger
RakNet::ThreadsafePacketLogger Member List

This is the complete list of members for RakNet::ThreadsafePacketLogger, including all inherited members.

LogHeader(void) | RakNet::PacketLogger | virtual
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PacketLogger | virtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::PluginInterface2 | inlinevirtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PacketLogger | virtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PacketLogger | virtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PacketLogger | virtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PacketLogger | virtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::PluginInterface2 | inlinevirtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PacketLogger | virtual
SetLogDirectMessages(bool send) | RakNet::PacketLogger |
SetPrefix(const char *_prefix) | RakNet::PacketLogger | virtual
SetSuffix(const char *_suffix) | RakNet::PacketLogger | virtual
Update(void) | RakNet::ThreadsafePacketLogger | virtual
UsesReliabilityLayer(void) const | RakNet::PacketLogger | inlineprotectedvirtual
WriteLog(const char *str) | RakNet::PacketLogger | virtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • TM_Team
RakNet::TM_Team Member List

This is the complete list of members for RakNet::TM_Team, including all inherited members.

DeserializeConstruction(TeamManager *teamManager, BitStream *constructionBitstream) | RakNet::TM_Team
GetBalancingApplies(void) const | RakNet::TM_Team
GetJoinPermissions(void) const | RakNet::TM_Team
GetMemberLimit(void) const | RakNet::TM_Team
GetMemberLimitSetting(void) const | RakNet::TM_Team
GetNetworkID(void) const | RakNet::TM_Team
GetOwner(void) const | RakNet::TM_Team
GetTeamMemberByIndex(unsigned int index) const | RakNet::TM_Team
GetTeamMembers(DataStructures::List< TM_TeamMember * > &_teamMembers) const | RakNet::TM_Team
GetTeamMembersCount(void) const | RakNet::TM_Team
GetTM_World(void) const | RakNet::TM_Team
GetWorldIndex(void) const | RakNet::TM_Team
LeaveTeam(TM_TeamMember *teamMember, NoTeamId noTeamSubcategory) | RakNet::TM_Team
SerializeConstruction(BitStream *constructionBitstream) | RakNet::TM_Team
SetJoinPermissions(JoinPermissions _joinPermissions) | RakNet::TM_Team
SetMemberLimit(TeamMemberLimit _teamMemberLimit, NoTeamId noTeamSubcategory) | RakNet::TM_Team
SetOwner(void *o) | RakNet::TM_Team
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • TM_TeamMember
RakNet::TM_TeamMember Member List

This is the complete list of members for RakNet::TM_TeamMember, including all inherited members.

CancelTeamRequest(TM_Team *specificTeamToCancel) | RakNet::TM_TeamMember
DeserializeConstruction(TeamManager *teamManager, BitStream *constructionBitstream) | RakNet::TM_TeamMember
GetCurrentTeam(void) const | RakNet::TM_TeamMember
GetCurrentTeamByIndex(unsigned int index) | RakNet::TM_TeamMember
GetCurrentTeamCount(void) const | RakNet::TM_TeamMember
GetCurrentTeams(DataStructures::List< TM_Team * > &_teams) const | RakNet::TM_TeamMember
GetLastTeams(DataStructures::List< TM_Team * > &_teams) const | RakNet::TM_TeamMember
GetNetworkID(void) const | RakNet::TM_TeamMember
GetNoTeamId(void) const | RakNet::TM_TeamMember
GetOwner(void) const | RakNet::TM_TeamMember
GetRequestedSpecificTeams(DataStructures::List< TM_Team * > &requestedTeams) const | RakNet::TM_TeamMember
GetRequestedTeam(void) const | RakNet::TM_TeamMember
GetRequestedTeamCount(void) const | RakNet::TM_TeamMember
GetRequestedTeamIndex(TM_Team *team) const | RakNet::TM_TeamMember
GetTM_World(void) const | RakNet::TM_TeamMember
GetWorldIndex(void) const | RakNet::TM_TeamMember
HasRequestedTeam(TM_Team *team) const | RakNet::TM_TeamMember
IsOnTeam(TM_Team *team) const | RakNet::TM_TeamMember
LeaveAllTeams(NoTeamId noTeamSubcategory) | RakNet::TM_TeamMember
LeaveTeam(TM_Team *team, NoTeamId _noTeamSubcategory) | RakNet::TM_TeamMember
RequestTeam(TeamSelection teamSelection) | RakNet::TM_TeamMember
RequestTeamSwitch(TM_Team *teamToJoin, TM_Team *teamToLeave) | RakNet::TM_TeamMember
SerializeConstruction(BitStream *constructionBitstream) | RakNet::TM_TeamMember
SetOwner(void *o) | RakNet::TM_TeamMember
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • TM_World
RakNet::TM_World Member List

This is the complete list of members for RakNet::TM_World, including all inherited members.

AddParticipant(RakNetGUID rakNetGUID) | RakNet::TM_World
Clear(void) | RakNet::TM_World
DereferenceTeam(TM_Team *team, NoTeamId noTeamSubcategory) | RakNet::TM_World
DereferenceTeamMember(TM_TeamMember *teamMember) | RakNet::TM_World
GetBalanceTeams(void) const | RakNet::TM_World
GetHost(void) const | RakNet::TM_World
GetParticipantList(DataStructures::List< RakNetGUID > &participantList) | RakNet::TM_World
GetTeamByIndex(unsigned int index) const | RakNet::TM_World
GetTeamByNetworkID(NetworkID teamId) | RakNet::TM_World
GetTeamCount(void) const | RakNet::TM_World
GetTeamIndex(const TM_Team *team) const | RakNet::TM_World
GetTeamManager(void) const | RakNet::TM_World
GetTeamMemberByIndex(unsigned int index) const | RakNet::TM_World
GetTeamMemberByNetworkID(NetworkID teamMemberId) | RakNet::TM_World
GetTeamMemberCount(void) const | RakNet::TM_World
GetTeamMemberIDByIndex(unsigned int index) const | RakNet::TM_World
GetTeamMemberIndex(const TM_TeamMember *teamMember) const | RakNet::TM_World
GetWorldId(void) const | RakNet::TM_World
ReferenceTeam(TM_Team *team, NetworkID networkId, bool applyBalancing) | RakNet::TM_World
ReferenceTeamMember(TM_TeamMember *teamMember, NetworkID networkId) | RakNet::TM_World
RemoveParticipant(RakNetGUID rakNetGUID) | RakNet::TM_World
SetAutoManageConnections(bool autoAdd) | RakNet::TM_World
SetBalanceTeams(bool balanceTeams, NoTeamId noTeamSubcategory) | RakNet::TM_World
SetHost(RakNetGUID _hostGuid) | RakNet::TM_World
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • TransportInterface
RakNet::TransportInterface Member List

This is the complete list of members for RakNet::TransportInterface, including all inherited members.

CloseConnection(SystemAddress systemAddress)=0 | RakNet::TransportInterface | pure virtual
DeallocatePacket(Packet *packet)=0 | RakNet::TransportInterface | pure virtual
GetCommandParser(void)=0 | RakNet::TransportInterface | pure virtual
HasLostConnection(void)=0 | RakNet::TransportInterface | pure virtual
HasNewIncomingConnection(void)=0 | RakNet::TransportInterface | pure virtual
Receive(void)=0 | RakNet::TransportInterface | pure virtual
Send(SystemAddress systemAddress, const char *data,...)=0 | RakNet::TransportInterface | pure virtual
Start(unsigned short port, bool serverMode)=0 | RakNet::TransportInterface | pure virtual
Stop(void)=0 | RakNet::TransportInterface | pure virtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • TwoWayAuthentication
RakNet::TwoWayAuthentication Member List

This is the complete list of members for RakNet::TwoWayAuthentication, including all inherited members.

AddPassword(RakNet::RakString identifier, RakNet::RakString password) | RakNet::TwoWayAuthentication |
Challenge(RakNet::RakString identifier, AddressOrGUID remoteSystem) | RakNet::TwoWayAuthentication |
Clear(void) | RakNet::TwoWayAuthentication |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::TwoWayAuthentication | virtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::TwoWayAuthentication | virtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::TwoWayAuthentication | virtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
Update(void) | RakNet::TwoWayAuthentication | virtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • UDPForwarder
RakNet::UDPForwarder Member List

This is the complete list of members for RakNet::UDPForwarder, including all inherited members.

GetMaxForwardEntries(void) const | RakNet::UDPForwarder
GetUsedForwardEntries(void) const | RakNet::UDPForwarder
SetMaxForwardEntries(unsigned short maxEntries) | RakNet::UDPForwarder
Shutdown(void) | RakNet::UDPForwarder
StartForwarding(SystemAddress source, SystemAddress destination, RakNet::TimeMS timeoutOnNoDataMS, const char *forceHostAddress, unsigned short socketFamily, unsigned short *forwardingPort, __UDPSOCKET__ *forwardingSocket) | RakNet::UDPForwarder
Startup(void) | RakNet::UDPForwarder
StopForwarding(SystemAddress source, SystemAddress destination) | RakNet::UDPForwarder
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • UDPProxyClient
RakNet::UDPProxyClient Member List

This is the complete list of members for RakNet::UDPProxyClient, including all inherited members.

OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::PluginInterface2 | inlinevirtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::UDPProxyClient | virtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::UDPProxyClient | virtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
RequestForwarding(SystemAddress proxyCoordinator, SystemAddress sourceAddress, SystemAddress targetAddressAsSeenFromCoordinator, RakNet::TimeMS timeoutOnNoDataMS, RakNet::BitStream *serverSelectionBitstream=0) | RakNet::UDPProxyClient |
RequestForwarding(SystemAddress proxyCoordinator, SystemAddress sourceAddress, RakNetGUID targetGuid, RakNet::TimeMS timeoutOnNoDataMS, RakNet::BitStream *serverSelectionBitstream=0) | RakNet::UDPProxyClient |
SetResultHandler(UDPProxyClientResultHandler *rh) | RakNet::UDPProxyClient |
Update(void) | RakNet::UDPProxyClient | virtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • UDPProxyCoordinator
RakNet::UDPProxyCoordinator Member List

This is the complete list of members for RakNet::UDPProxyCoordinator, including all inherited members.

OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::PluginInterface2 | inlinevirtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::UDPProxyCoordinator | virtual
OnDetach(void) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerStartup(void) | RakNet::PluginInterface2 | inlinevirtual
OnReceive(Packet *packet) | RakNet::UDPProxyCoordinator | virtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
SetRemoteLoginPassword(RakNet::RakString password) | RakNet::UDPProxyCoordinator |
Update(void) | RakNet::UDPProxyCoordinator | virtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • UDPProxyServer
RakNet::UDPProxyServer Member List

This is the complete list of members for RakNet::UDPProxyServer, including all inherited members.

LoginToCoordinator(RakNet::RakString password, SystemAddress coordinatorAddress) | RakNet::UDPProxyServer |
OnAck(unsigned int messageNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time) | RakNet::PluginInterface2 | inlinevirtual
OnAttach(void) | RakNet::UDPProxyServer | virtual
OnClosedConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, PI2_LostConnectionReason lostConnectionReason) | RakNet::UDPProxyServer | virtual
OnDetach(void) | RakNet::UDPProxyServer | virtual
OnDirectSocketReceive(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnDirectSocketSend(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnFailedConnectionAttempt(Packet *packet, PI2_FailedConnectionAttemptReason failedConnectionAttemptReason) | RakNet::PluginInterface2 | inlinevirtual
OnInternalPacket(InternalPacket *internalPacket, unsigned frameNumber, SystemAddress remoteSystemAddress, RakNet::TimeMS time, int isSend) | RakNet::PluginInterface2 | inlinevirtual
OnNewConnection(const SystemAddress &systemAddress, RakNetGUID rakNetGUID, bool isIncoming) | RakNet::PluginInterface2 | inlinevirtual
OnPushBackPacket(const char *data, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress) | RakNet::PluginInterface2 | inlinevirtual
OnRakPeerShutdown(void) | RakNet::UDPProxyServer | virtual
OnRakPeerStartup(void) | RakNet::UDPProxyServer | virtual
OnReceive(Packet *packet) | RakNet::UDPProxyServer | virtual
OnReliabilityLayerNotification(const char *errorMessage, const BitSize_t bitsUsed, SystemAddress remoteSystemAddress, bool isError) | RakNet::PluginInterface2 | inlinevirtual
SetResultHandler(UDPProxyServerResultHandler *rh) | RakNet::UDPProxyServer |
SetServerPublicIP(RakString ip) | RakNet::UDPProxyServer |
SetSocketFamily(unsigned short _socketFamily) | RakNet::UDPProxyServer |
udpForwarder | RakNet::UDPProxyServer |
Update(void) | RakNet::UDPProxyServer | virtual
UsesReliabilityLayer(void) const | RakNet::PluginInterface2 | inlinevirtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • VariableDeltaSerializer
RakNet::VariableDeltaSerializer Member List

This is the complete list of members for RakNet::VariableDeltaSerializer, including all inherited members.

AddRemoteSystemVariableHistory(RakNetGUID guid) | RakNet::VariableDeltaSerializer |
BeginDeserialize(DeserializationContext *context, BitStream *_bitStream) | RakNet::VariableDeltaSerializer |
BeginIdenticalSerialize(SerializationContext *context, bool _isFirstSerializeToThisSystem, BitStream *_bitStream) | RakNet::VariableDeltaSerializer |
BeginUniqueSerialize(SerializationContext *context, RakNetGUID _guid, BitStream *_bitStream) | RakNet::VariableDeltaSerializer |
BeginUnreliableAckedSerialize(SerializationContext *context, RakNetGUID _guid, BitStream *_bitStream, uint32_t _sendReceipt) | RakNet::VariableDeltaSerializer |
DeserializeVariable(DeserializationContext *context, VarType &variable) | RakNet::VariableDeltaSerializer | inline
EndDeserialize(DeserializationContext *context) | RakNet::VariableDeltaSerializer |
EndSerialize(SerializationContext *context) | RakNet::VariableDeltaSerializer |
OnMessageReceipt(RakNetGUID guid, uint32_t receiptId, bool messageArrived) | RakNet::VariableDeltaSerializer |
OnPreSerializeTick(void) | RakNet::VariableDeltaSerializer |
remoteSystemVariableHistoryList | RakNet::VariableDeltaSerializer | protected
RemoveRemoteSystemVariableHistory(RakNetGUID guid) | RakNet::VariableDeltaSerializer |
SerializeVariable(SerializationContext *context, const VarType &variable) | RakNet::VariableDeltaSerializer | inline
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • VariableListDeltaTracker
RakNet::VariableListDeltaTracker Member List

This is the complete list of members for RakNet::VariableListDeltaTracker, including all inherited members.

FlagDirtyFromBitArray(unsigned char *bArray) | RakNet::VariableListDeltaTracker |
ReadVarFromBitstream(VarType &varData, RakNet::BitStream *bitStream) | RakNet::VariableListDeltaTracker | inlinestatic
WriteVar(const VarType &varData) | RakNet::VariableListDeltaTracker | inline
WriteVarToBitstream(const VarType &varData, RakNet::BitStream *bitStream) | RakNet::VariableListDeltaTracker | inline
WriteVarToBitstream(const VarType &varData, RakNet::BitStream *bitStream, unsigned char *bArray, unsigned short writeOffset) | RakNet::VariableListDeltaTracker | inline
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

RefCountedObj Member List

This is the complete list of members for RefCountedObj, including all inherited members.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/DependentExtensions/MySQLInterface Directory Reference

  • D:
  • temp
  • RakNet_PC
  • DependentExtensions
  • MySQLInterface
MySQLInterface Directory Reference

Files

file MySQLInterface.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/DependentExtensions/Lobby2/PGSQL Directory Reference

  • D:
  • temp
  • RakNet_PC
  • DependentExtensions
  • Lobby2
  • PGSQL
PGSQL Directory Reference

Files

file | Lobby2Message_PGSQL.h
file | Lobby2Server_PGSQL.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/DependentExtensions/PostgreSQLInterface Directory Reference

  • D:
  • temp
  • RakNet_PC
  • DependentExtensions
  • PostgreSQLInterface
PostgreSQLInterface Directory Reference

Files

file PostgreSQLInterface.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: D:/temp/RakNet_PC/DependentExtensions/Lobby2/Steam Directory Reference

  • D:
  • temp
  • RakNet_PC
  • DependentExtensions
  • Lobby2
  • Steam
Steam Directory Reference

Files

file | Lobby2Client_Steam.h
file | Lobby2Client_Steam_Impl.h
file | Lobby2Message_Steam.h
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Main Page

RakNet Documentation
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Related Pages

Related Pages
Here is a list of all related documentation pages:
\ Deprecated List
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • DataStructures
  • Page
DataStructures::Page< KeyType, DataType, order > Member List

This is the complete list of members for DataStructures::Page< KeyType, DataType, order >, including all inherited members.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • DataStructures
  • Table
  • Cell
DataStructures::Table::Cell Member List

This is the complete list of members for DataStructures::Table::Cell, including all inherited members.

Get(int *output) | DataStructures::Table::Cell
Get(char *output) | DataStructures::Table::Cell
Get(char *output, int *outputLength) | DataStructures::Table::Cell
Set(int input) | DataStructures::Table::Cell
Set(const char *input) | DataStructures::Table::Cell
Set(const char *input, int inputLength) | DataStructures::Table::Cell
SetPtr(void *p) | DataStructures::Table::Cell
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • DataStructures
  • Table
  • ColumnDescriptor
DataStructures::Table::ColumnDescriptor Member List

This is the complete list of members for DataStructures::Table::ColumnDescriptor, including all inherited members.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • DataStructures
  • Table
  • Row
DataStructures::Table::Row Member List

This is the complete list of members for DataStructures::Table::Row, including all inherited members.

UpdateCell(unsigned columnIndex, double value) | DataStructures::Table::Row
UpdateCell(unsigned columnIndex, const char *str) | DataStructures::Table::Row
UpdateCell(unsigned columnIndex, int byteLength, const char *data) | DataStructures::Table::Row
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • AcceptInvite_Func
RakNet::AcceptInvite_Func Member List

This is the complete list of members for RakNet::AcceptInvite_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • AddUserToQuickJoin_Func
RakNet::AddUserToQuickJoin_Func Member List

This is the complete list of members for RakNet::AddUserToQuickJoin_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • AreAllMembersReady_Func
RakNet::AreAllMembersReady_Func Member List

This is the complete list of members for RakNet::AreAllMembersReady_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • AutopatcherServer
  • ResultTypeAndBitstream
RakNet::AutopatcherServer::ResultTypeAndBitstream Member List

This is the complete list of members for RakNet::AutopatcherServer::ResultTypeAndBitstream, including all inherited members.

Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • AutopatcherServerLoadNotifier
  • AutopatcherState
RakNet::AutopatcherServerLoadNotifier::AutopatcherState Member List

This is the complete list of members for RakNet::AutopatcherServerLoadNotifier::AutopatcherState, including all inherited members.

requestsQueued | RakNet::AutopatcherServerLoadNotifier::AutopatcherState
requestsWorking | RakNet::AutopatcherServerLoadNotifier::AutopatcherState
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Bitstream_Func
RakNet::Bitstream_Func Member List

This is the complete list of members for RakNet::Bitstream_Func, including all inherited members.

directedToRoom | RakNet::Bitstream_Func
resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Bitstream_Notification
RakNet::Bitstream_Notification Member List

This is the complete list of members for RakNet::Bitstream_Notification, including all inherited members.

recipient RakNet::RoomsPluginNotification
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • BookmarkedUsers_Add
RakNet::BookmarkedUsers_Add Member List

This is the complete list of members for RakNet::BookmarkedUsers_Add, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::BookmarkedUsers_Add | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::BookmarkedUsers_Add | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::BookmarkedUsers_Add | inlinevirtual
RequiresLogin(void) const | RakNet::BookmarkedUsers_Add | inlinevirtual
RequiresRankingPermission(void) const | RakNet::BookmarkedUsers_Add | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::BookmarkedUsers_Add | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • BookmarkedUsers_Get
RakNet::BookmarkedUsers_Get Member List

This is the complete list of members for RakNet::BookmarkedUsers_Get, including all inherited members.

bookmarkedUsers | RakNet::BookmarkedUsers_Get |
callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::BookmarkedUsers_Get | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Lobby2Message | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::BookmarkedUsers_Get | inlinevirtual
RequiresLogin(void) const | RakNet::BookmarkedUsers_Get | inlinevirtual
RequiresRankingPermission(void) const | RakNet::BookmarkedUsers_Get | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::BookmarkedUsers_Get | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • BookmarkedUsers_Remove
RakNet::BookmarkedUsers_Remove Member List

This is the complete list of members for RakNet::BookmarkedUsers_Remove, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::BookmarkedUsers_Remove | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::BookmarkedUsers_Remove | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::BookmarkedUsers_Remove | inlinevirtual
RequiresLogin(void) const | RakNet::BookmarkedUsers_Remove | inlinevirtual
RequiresRankingPermission(void) const | RakNet::BookmarkedUsers_Remove | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::BookmarkedUsers_Remove | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • CDKey_Add
RakNet::CDKey_Add Member List

This is the complete list of members for RakNet::CDKey_Add, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::CDKey_Add | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::CDKey_Add | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::CDKey_Add | inlinevirtual
RequiresLogin(void) const | RakNet::CDKey_Add | inlinevirtual
RequiresRankingPermission(void) const | RakNet::CDKey_Add | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::CDKey_Add | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • CDKey_FlagStolen
RakNet::CDKey_FlagStolen Member List

This is the complete list of members for RakNet::CDKey_FlagStolen, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::CDKey_FlagStolen | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::CDKey_FlagStolen | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::CDKey_FlagStolen | inlinevirtual
RequiresLogin(void) const | RakNet::CDKey_FlagStolen | inlinevirtual
RequiresRankingPermission(void) const | RakNet::CDKey_FlagStolen | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::CDKey_FlagStolen | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • CDKey_GetStatus
RakNet::CDKey_GetStatus Member List

This is the complete list of members for RakNet::CDKey_GetStatus, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::CDKey_GetStatus | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::CDKey_GetStatus | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::CDKey_GetStatus | inlinevirtual
RequiresLogin(void) const | RakNet::CDKey_GetStatus | inlinevirtual
RequiresRankingPermission(void) const | RakNet::CDKey_GetStatus | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::CDKey_GetStatus | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • CDKey_Use
RakNet::CDKey_Use Member List

This is the complete list of members for RakNet::CDKey_Use, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::CDKey_Use | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::CDKey_Use | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::CDKey_Use | inlinevirtual
RequiresLogin(void) const | RakNet::CDKey_Use | inlinevirtual
RequiresRankingPermission(void) const | RakNet::CDKey_Use | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::CDKey_Use | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • ChangeHandle_Func
RakNet::ChangeHandle_Func Member List

This is the complete list of members for RakNet::ChangeHandle_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • ChangeRoomName_Func
RakNet::ChangeRoomName_Func Member List

This is the complete list of members for RakNet::ChangeRoomName_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • ChangeSlotCounts_Func
RakNet::ChangeSlotCounts_Func Member List

This is the complete list of members for RakNet::ChangeSlotCounts_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Chat_Func
RakNet::Chat_Func Member List

This is the complete list of members for RakNet::Chat_Func, including all inherited members.

chatDirectedToRoom | RakNet::Chat_Func
resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Chat_Notification
RakNet::Chat_Notification Member List

This is the complete list of members for RakNet::Chat_Notification, including all inherited members.

recipient RakNet::RoomsPluginNotification
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_AcceptJoinInvitation
RakNet::Clans_AcceptJoinInvitation Member List

This is the complete list of members for RakNet::Clans_AcceptJoinInvitation, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_AcceptJoinInvitation | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_AcceptJoinInvitation | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_AcceptJoinInvitation | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_AcceptJoinInvitation | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_AcceptJoinInvitation | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_AcceptJoinInvitation | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_AcceptJoinRequest
RakNet::Clans_AcceptJoinRequest Member List

This is the complete list of members for RakNet::Clans_AcceptJoinRequest, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_AcceptJoinRequest | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_AcceptJoinRequest | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_AcceptJoinRequest | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_AcceptJoinRequest | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_AcceptJoinRequest | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_AcceptJoinRequest | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_ChangeHandle
RakNet::Clans_ChangeHandle Member List

This is the complete list of members for RakNet::Clans_ChangeHandle, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_ChangeHandle | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_ChangeHandle | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_ChangeHandle | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_ChangeHandle | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_ChangeHandle | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_ChangeHandle | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_Create
RakNet::Clans_Create Member List

This is the complete list of members for RakNet::Clans_Create, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_Create | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_Create | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_Create | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_Create | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_Create | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_Create | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_CreateBoard
RakNet::Clans_CreateBoard Member List

This is the complete list of members for RakNet::Clans_CreateBoard, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_CreateBoard | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_CreateBoard | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_CreateBoard | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_CreateBoard | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_CreateBoard | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_CreateBoard | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_CreateNewTopic
RakNet::Clans_CreateNewTopic Member List

This is the complete list of members for RakNet::Clans_CreateNewTopic, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_CreateNewTopic | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_CreateNewTopic | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_CreateNewTopic | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_CreateNewTopic | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_CreateNewTopic | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_CreateNewTopic | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_DestroyBoard
RakNet::Clans_DestroyBoard Member List

This is the complete list of members for RakNet::Clans_DestroyBoard, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_DestroyBoard | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_DestroyBoard | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_DestroyBoard | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_DestroyBoard | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_DestroyBoard | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_DestroyBoard | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_DownloadInvitationList
RakNet::Clans_DownloadInvitationList Member List

This is the complete list of members for RakNet::Clans_DownloadInvitationList, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_DownloadInvitationList | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Lobby2Message | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_DownloadInvitationList | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_DownloadInvitationList | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_DownloadInvitationList | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_DownloadInvitationList | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_DownloadRequestList
RakNet::Clans_DownloadRequestList Member List

This is the complete list of members for RakNet::Clans_DownloadRequestList, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_DownloadRequestList | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Lobby2Message | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_DownloadRequestList | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_DownloadRequestList | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_DownloadRequestList | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_DownloadRequestList | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_Get
RakNet::Clans_Get Member List

This is the complete list of members for RakNet::Clans_Get, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_Get | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Lobby2Message | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_Get | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_Get | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_Get | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_Get | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_GetBlacklist
RakNet::Clans_GetBlacklist Member List

This is the complete list of members for RakNet::Clans_GetBlacklist, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_GetBlacklist | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_GetBlacklist | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_GetBlacklist | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_GetBlacklist | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_GetBlacklist | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_GetBlacklist | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_GetBoards
RakNet::Clans_GetBoards Member List

This is the complete list of members for RakNet::Clans_GetBoards, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_GetBoards | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_GetBoards | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_GetBoards | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_GetBoards | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_GetBoards | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_GetBoards | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_GetList
RakNet::Clans_GetList Member List

This is the complete list of members for RakNet::Clans_GetList, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_GetList | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Lobby2Message | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_GetList | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_GetList | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_GetList | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_GetList | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_GetMemberProperties
RakNet::Clans_GetMemberProperties Member List

This is the complete list of members for RakNet::Clans_GetMemberProperties, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_GetMemberProperties | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_GetMemberProperties | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_GetMemberProperties | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_GetMemberProperties | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_GetMemberProperties | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_GetMemberProperties | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_GetMembers
RakNet::Clans_GetMembers Member List

This is the complete list of members for RakNet::Clans_GetMembers, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_GetMembers | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_GetMembers | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_GetMembers | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_GetMembers | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_GetMembers | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_GetMembers | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_GetPosts
RakNet::Clans_GetPosts Member List

This is the complete list of members for RakNet::Clans_GetPosts, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_GetPosts | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_GetPosts | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_GetPosts | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_GetPosts | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_GetPosts | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_GetPosts | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_GetProperties
RakNet::Clans_GetProperties Member List

This is the complete list of members for RakNet::Clans_GetProperties, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_GetProperties | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_GetProperties | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_GetProperties | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_GetProperties | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_GetProperties | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_GetProperties | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_GetTopics
RakNet::Clans_GetTopics Member List

This is the complete list of members for RakNet::Clans_GetTopics, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_GetTopics | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_GetTopics | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_GetTopics | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_GetTopics | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_GetTopics | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_GetTopics | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_GrantLeader
RakNet::Clans_GrantLeader Member List

This is the complete list of members for RakNet::Clans_GrantLeader, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_GrantLeader | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_GrantLeader | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_GrantLeader | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_GrantLeader | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_GrantLeader | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_GrantLeader | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_KickAndBlacklistUser
RakNet::Clans_KickAndBlacklistUser Member List

This is the complete list of members for RakNet::Clans_KickAndBlacklistUser, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_KickAndBlacklistUser | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_KickAndBlacklistUser | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_KickAndBlacklistUser | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_KickAndBlacklistUser | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_KickAndBlacklistUser | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_KickAndBlacklistUser | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_Leave
RakNet::Clans_Leave Member List

This is the complete list of members for RakNet::Clans_Leave, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_Leave | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_Leave | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_Leave | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_Leave | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_Leave | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_Leave | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_RejectJoinInvitation
RakNet::Clans_RejectJoinInvitation Member List

This is the complete list of members for RakNet::Clans_RejectJoinInvitation, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_RejectJoinInvitation | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_RejectJoinInvitation | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_RejectJoinInvitation | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_RejectJoinInvitation | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_RejectJoinInvitation | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_RejectJoinInvitation | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_RejectJoinRequest
RakNet::Clans_RejectJoinRequest Member List

This is the complete list of members for RakNet::Clans_RejectJoinRequest, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_RejectJoinRequest | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_RejectJoinRequest | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_RejectJoinRequest | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_RejectJoinRequest | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_RejectJoinRequest | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_RejectJoinRequest | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_RemovePost
RakNet::Clans_RemovePost Member List

This is the complete list of members for RakNet::Clans_RemovePost, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_RemovePost | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Lobby2Message | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_RemovePost | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_RemovePost | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_RemovePost | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_RemovePost | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_ReplyToTopic
RakNet::Clans_ReplyToTopic Member List

This is the complete list of members for RakNet::Clans_ReplyToTopic, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_ReplyToTopic | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_ReplyToTopic | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_ReplyToTopic | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_ReplyToTopic | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_ReplyToTopic | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_ReplyToTopic | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_SendJoinInvitation
RakNet::Clans_SendJoinInvitation Member List

This is the complete list of members for RakNet::Clans_SendJoinInvitation, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_SendJoinInvitation | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_SendJoinInvitation | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_SendJoinInvitation | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_SendJoinInvitation | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_SendJoinInvitation | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_SendJoinInvitation | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_SendJoinRequest
RakNet::Clans_SendJoinRequest Member List

This is the complete list of members for RakNet::Clans_SendJoinRequest, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_SendJoinRequest | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_SendJoinRequest | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_SendJoinRequest | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_SendJoinRequest | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_SendJoinRequest | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_SendJoinRequest | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_SetMemberRank
RakNet::Clans_SetMemberRank Member List

This is the complete list of members for RakNet::Clans_SetMemberRank, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_SetMemberRank | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_SetMemberRank | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_SetMemberRank | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_SetMemberRank | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_SetMemberRank | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_SetMemberRank | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_SetMyMemberProperties
RakNet::Clans_SetMyMemberProperties Member List

This is the complete list of members for RakNet::Clans_SetMyMemberProperties, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_SetMyMemberProperties | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_SetMyMemberProperties | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_SetMyMemberProperties | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_SetMyMemberProperties | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_SetMyMemberProperties | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_SetMyMemberProperties | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_SetProperties
RakNet::Clans_SetProperties Member List

This is the complete list of members for RakNet::Clans_SetProperties, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_SetProperties | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_SetProperties | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_SetProperties | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_SetProperties | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_SetProperties | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_SetProperties | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_SetSubleaderStatus
RakNet::Clans_SetSubleaderStatus Member List

This is the complete list of members for RakNet::Clans_SetSubleaderStatus, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_SetSubleaderStatus | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_SetSubleaderStatus | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_SetSubleaderStatus | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_SetSubleaderStatus | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_SetSubleaderStatus | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_SetSubleaderStatus | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_UnblacklistUser
RakNet::Clans_UnblacklistUser Member List

This is the complete list of members for RakNet::Clans_UnblacklistUser, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_UnblacklistUser | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_UnblacklistUser | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_UnblacklistUser | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_UnblacklistUser | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_UnblacklistUser | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_UnblacklistUser | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_WithdrawJoinInvitation
RakNet::Clans_WithdrawJoinInvitation Member List

This is the complete list of members for RakNet::Clans_WithdrawJoinInvitation, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_WithdrawJoinInvitation | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_WithdrawJoinInvitation | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_WithdrawJoinInvitation | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_WithdrawJoinInvitation | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_WithdrawJoinInvitation | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_WithdrawJoinInvitation | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Clans_WithdrawJoinRequest
RakNet::Clans_WithdrawJoinRequest Member List

This is the complete list of members for RakNet::Clans_WithdrawJoinRequest, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Clans_WithdrawJoinRequest | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Clans_WithdrawJoinRequest | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Clans_WithdrawJoinRequest | inlinevirtual
RequiresLogin(void) const | RakNet::Clans_WithdrawJoinRequest | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Clans_WithdrawJoinRequest | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Clans_WithdrawJoinRequest | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Client_ChangeHandle
RakNet::Client_ChangeHandle Member List

This is the complete list of members for RakNet::Client_ChangeHandle, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Client_ChangeHandle | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Client_ChangeHandle | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Client_ChangeHandle | inlinevirtual
RequiresLogin(void) const | RakNet::Client_ChangeHandle | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Client_ChangeHandle | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Client_ChangeHandle | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Client_GetAccountDetails
RakNet::Client_GetAccountDetails Member List

This is the complete list of members for RakNet::Client_GetAccountDetails, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Client_GetAccountDetails | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Lobby2Message | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Client_GetAccountDetails | inlinevirtual
RequiresLogin(void) const | RakNet::Client_GetAccountDetails | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Client_GetAccountDetails | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Client_GetAccountDetails | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Client_GetEmailAddress
RakNet::Client_GetEmailAddress Member List

This is the complete list of members for RakNet::Client_GetEmailAddress, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Client_GetEmailAddress | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Client_GetEmailAddress | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Client_GetEmailAddress | inlinevirtual
RequiresLogin(void) const | RakNet::Client_GetEmailAddress | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Client_GetEmailAddress | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Client_GetEmailAddress | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Client_GetIgnoreList
RakNet::Client_GetIgnoreList Member List

This is the complete list of members for RakNet::Client_GetIgnoreList, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Client_GetIgnoreList | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Client_GetIgnoreList | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Lobby2Message | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Client_GetIgnoreList | inlinevirtual
RequiresLogin(void) const | RakNet::Client_GetIgnoreList | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Client_GetIgnoreList | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Client_GetIgnoreList | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Client_GetPasswordByPasswordRecoveryAnswer
RakNet::Client_GetPasswordByPasswordRecoveryAnswer Member List

This is the complete list of members for RakNet::Client_GetPasswordByPasswordRecoveryAnswer, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Client_GetPasswordByPasswordRecoveryAnswer | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Client_GetPasswordByPasswordRecoveryAnswer | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Client_GetPasswordByPasswordRecoveryAnswer | inlinevirtual
RequiresLogin(void) const | RakNet::Client_GetPasswordByPasswordRecoveryAnswer | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Client_GetPasswordByPasswordRecoveryAnswer | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Client_GetPasswordByPasswordRecoveryAnswer | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Client_GetPasswordRecoveryQuestionByHandle
RakNet::Client_GetPasswordRecoveryQuestionByHandle Member List

This is the complete list of members for RakNet::Client_GetPasswordRecoveryQuestionByHandle, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Client_GetPasswordRecoveryQuestionByHandle | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Client_GetPasswordRecoveryQuestionByHandle | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Client_GetPasswordRecoveryQuestionByHandle | inlinevirtual
RequiresLogin(void) const | RakNet::Client_GetPasswordRecoveryQuestionByHandle | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Client_GetPasswordRecoveryQuestionByHandle | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Client_GetPasswordRecoveryQuestionByHandle | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Client_GetPresence
RakNet::Client_GetPresence Member List

This is the complete list of members for RakNet::Client_GetPresence, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Client_GetPresence | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
presence | RakNet::Client_GetPresence |
PrevalidateInput(void) | RakNet::Lobby2Message | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Client_GetPresence | inlinevirtual
RequiresLogin(void) const | RakNet::Client_GetPresence | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Client_GetPresence | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Client_GetPresence | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
userHandle | RakNet::Client_GetPresence |
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Client_Login
RakNet::Client_Login Member List

This is the complete list of members for RakNet::Client_Login, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Client_Login | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Client_Login | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Client_Login | inlinevirtual
RequiresLogin(void) const | RakNet::Client_Login | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Client_Login | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Client_Login | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Client_Logoff
RakNet::Client_Logoff Member List

This is the complete list of members for RakNet::Client_Logoff, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Client_Logoff | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Lobby2Message | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Client_Logoff | inlinevirtual
RequiresLogin(void) const | RakNet::Client_Logoff | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Client_Logoff | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Lobby2Message | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Client_PerTitleBinaryStorage
RakNet::Client_PerTitleBinaryStorage Member List

This is the complete list of members for RakNet::Client_PerTitleBinaryStorage, including all inherited members.

binaryData | RakNet::Client_PerTitleBinaryStorage |
callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Client_PerTitleBinaryStorage | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Client_PerTitleBinaryStorage | virtual
PTIS_Operation enum name | RakNet::Client_PerTitleBinaryStorage |
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Client_PerTitleBinaryStorage | inlinevirtual
RequiresLogin(void) const | RakNet::Client_PerTitleBinaryStorage | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Client_PerTitleBinaryStorage | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Client_PerTitleBinaryStorage | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
slotIndex | RakNet::Client_PerTitleBinaryStorage |
titleName | RakNet::Client_PerTitleBinaryStorage |
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Client_RegisterAccount
RakNet::Client_RegisterAccount Member List

This is the complete list of members for RakNet::Client_RegisterAccount, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Client_RegisterAccount | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Client_RegisterAccount | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Client_RegisterAccount | inlinevirtual
RequiresLogin(void) const | RakNet::Client_RegisterAccount | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Client_RegisterAccount | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Client_RegisterAccount | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Client_SetPresence
RakNet::Client_SetPresence Member List

This is the complete list of members for RakNet::Client_SetPresence, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Client_SetPresence | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
presence | RakNet::Client_SetPresence |
PrevalidateInput(void) | RakNet::Lobby2Message | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Client_SetPresence | inlinevirtual
RequiresLogin(void) const | RakNet::Client_SetPresence | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Client_SetPresence | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Client_SetPresence | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Client_StartIgnore
RakNet::Client_StartIgnore Member List

This is the complete list of members for RakNet::Client_StartIgnore, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Client_StartIgnore | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Client_StartIgnore | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Client_StartIgnore | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Client_StartIgnore | inlinevirtual
RequiresLogin(void) const | RakNet::Client_StartIgnore | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Client_StartIgnore | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Client_StartIgnore | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Client_StopIgnore
RakNet::Client_StopIgnore Member List

This is the complete list of members for RakNet::Client_StopIgnore, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Client_StopIgnore | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Client_StopIgnore | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Client_StopIgnore | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Client_StopIgnore | inlinevirtual
RequiresLogin(void) const | RakNet::Client_StopIgnore | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Client_StopIgnore | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Client_StopIgnore | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Client_UpdateAccount
RakNet::Client_UpdateAccount Member List

This is the complete list of members for RakNet::Client_UpdateAccount, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Client_UpdateAccount | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Client_UpdateAccount | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Client_UpdateAccount | inlinevirtual
RequiresLogin(void) const | RakNet::Client_UpdateAccount | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Client_UpdateAccount | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Client_UpdateAccount | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Client_ValidateHandle
RakNet::Client_ValidateHandle Member List

This is the complete list of members for RakNet::Client_ValidateHandle, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Client_ValidateHandle | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Client_ValidateHandle | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Client_ValidateHandle | inlinevirtual
RequiresLogin(void) const | RakNet::Client_ValidateHandle | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Client_ValidateHandle | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Client_ValidateHandle | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • CloudKey
RakNet::CloudKey Member List

This is the complete list of members for RakNet::CloudKey, including all inherited members.

primaryKey | RakNet::CloudKey
secondaryKey | RakNet::CloudKey
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • CloudQuery
RakNet::CloudQuery Member List

This is the complete list of members for RakNet::CloudQuery, including all inherited members.

keys | RakNet::CloudQuery
maxRowsToReturn | RakNet::CloudQuery
startingRowIndex | RakNet::CloudQuery
subscribeToResults | RakNet::CloudQuery
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • CreateRoom_Func
RakNet::CreateRoom_Func Member List

This is the complete list of members for RakNet::CreateRoom_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • CustomRoomPropertiesSet_Notification
RakNet::CustomRoomPropertiesSet_Notification Member List

This is the complete list of members for RakNet::CustomRoomPropertiesSet_Notification, including all inherited members.

recipient RakNet::RoomsPluginNotification
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Emails_Delete
RakNet::Emails_Delete Member List

This is the complete list of members for RakNet::Emails_Delete, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Emails_Delete | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Lobby2Message | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Emails_Delete | inlinevirtual
RequiresLogin(void) const | RakNet::Emails_Delete | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Emails_Delete | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Emails_Delete | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Emails_Get
RakNet::Emails_Get Member List

This is the complete list of members for RakNet::Emails_Get, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Emails_Get | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
emailResults | RakNet::Emails_Get |
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Lobby2Message | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Emails_Get | inlinevirtual
RequiresLogin(void) const | RakNet::Emails_Get | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Emails_Get | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Emails_Get | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Emails_Send
RakNet::Emails_Send Member List

This is the complete list of members for RakNet::Emails_Send, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Emails_Send | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Emails_Send | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Emails_Send | inlinevirtual
RequiresLogin(void) const | RakNet::Emails_Send | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Emails_Send | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Emails_Send | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Emails_SetStatus
RakNet::Emails_SetStatus Member List

This is the complete list of members for RakNet::Emails_SetStatus, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Emails_SetStatus | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Emails_SetStatus | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Emails_SetStatus | inlinevirtual
RequiresLogin(void) const | RakNet::Emails_SetStatus | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Emails_SetStatus | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Emails_SetStatus | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • EnterRoom_Func
RakNet::EnterRoom_Func Member List

This is the complete list of members for RakNet::EnterRoom_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • FileListNode
RakNet::FileListNode Member List

This is the complete list of members for RakNet::FileListNode, including all inherited members.

context | RakNet::FileListNode
data | RakNet::FileListNode
dataLengthBytes | RakNet::FileListNode
fileLengthBytes | RakNet::FileListNode
filename | RakNet::FileListNode
fullPathToFile | RakNet::FileListNode
isAReference | RakNet::FileListNode
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Friends_AcceptInvite
RakNet::Friends_AcceptInvite Member List

This is the complete list of members for RakNet::Friends_AcceptInvite, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Friends_AcceptInvite | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Friends_AcceptInvite | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Friends_AcceptInvite | inlinevirtual
RequiresLogin(void) const | RakNet::Friends_AcceptInvite | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Friends_AcceptInvite | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Friends_AcceptInvite | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Friends_GetFriends
RakNet::Friends_GetFriends Member List

This is the complete list of members for RakNet::Friends_GetFriends, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Friends_GetFriends | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Lobby2Message | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Friends_GetFriends | inlinevirtual
RequiresLogin(void) const | RakNet::Friends_GetFriends | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Friends_GetFriends | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Friends_GetFriends | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Friends_GetInvites
RakNet::Friends_GetInvites Member List

This is the complete list of members for RakNet::Friends_GetInvites, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Friends_GetInvites | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
invitesSent | RakNet::Friends_GetInvites |
PrevalidateInput(void) | RakNet::Lobby2Message | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Friends_GetInvites | inlinevirtual
RequiresLogin(void) const | RakNet::Friends_GetInvites | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Friends_GetInvites | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Friends_GetInvites | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Friends_RejectInvite
RakNet::Friends_RejectInvite Member List

This is the complete list of members for RakNet::Friends_RejectInvite, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Friends_RejectInvite | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Friends_RejectInvite | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Friends_RejectInvite | inlinevirtual
RequiresLogin(void) const | RakNet::Friends_RejectInvite | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Friends_RejectInvite | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Friends_RejectInvite | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Friends_Remove
RakNet::Friends_Remove Member List

This is the complete list of members for RakNet::Friends_Remove, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Friends_Remove | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Friends_Remove | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Friends_Remove | inlinevirtual
RequiresLogin(void) const | RakNet::Friends_Remove | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Friends_Remove | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Friends_Remove | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Friends_SendInvite
RakNet::Friends_SendInvite Member List

This is the complete list of members for RakNet::Friends_SendInvite, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Friends_SendInvite | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Friends_SendInvite | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Friends_SendInvite | inlinevirtual
RequiresLogin(void) const | RakNet::Friends_SendInvite | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Friends_SendInvite | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Friends_SendInvite | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • GetBanReason_Func
RakNet::GetBanReason_Func Member List

This is the complete list of members for RakNet::GetBanReason_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • GetInvitesToParticipant_Func
RakNet::GetInvitesToParticipant_Func Member List

This is the complete list of members for RakNet::GetInvitesToParticipant_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • GetReadyStatus_Func
RakNet::GetReadyStatus_Func Member List

This is the complete list of members for RakNet::GetReadyStatus_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • GetRoomLockState_Func
RakNet::GetRoomLockState_Func Member List

This is the complete list of members for RakNet::GetRoomLockState_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • GetRoomProperties_Func
RakNet::GetRoomProperties_Func Member List

This is the complete list of members for RakNet::GetRoomProperties_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • GrantModerator_Func
RakNet::GrantModerator_Func Member List

This is the complete list of members for RakNet::GrantModerator_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • HiddenFromSearchesSet_Notification
RakNet::HiddenFromSearchesSet_Notification Member List

This is the complete list of members for RakNet::HiddenFromSearchesSet_Notification, including all inherited members.

recipient RakNet::RoomsPluginNotification
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • HTTPConnection
  • BadResponse
RakNet::HTTPConnection::BadResponse Member List

This is the complete list of members for RakNet::HTTPConnection::BadResponse, including all inherited members.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • IndexedBinaryValue
RakNet::IndexedBinaryValue Member List

This is the complete list of members for RakNet::IndexedBinaryValue, including all inherited members.

index | RakNet::IndexedBinaryValue
searchOperator | RakNet::IndexedBinaryValue
type | RakNet::IndexedBinaryValue
value | RakNet::IndexedBinaryValue
valueByteLength | RakNet::IndexedBinaryValue
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • IndexedIntegerValue
RakNet::IndexedIntegerValue Member List

This is the complete list of members for RakNet::IndexedIntegerValue, including all inherited members.

index | RakNet::IndexedIntegerValue
searchOperator | RakNet::IndexedIntegerValue
value | RakNet::IndexedIntegerValue
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • InternalPacket
RakNet::InternalPacket Member List

This is the complete list of members for RakNet::InternalPacket, including all inherited members.

AllocationScheme enum name | RakNet::InternalPacket
creationTime | RakNet::InternalPacket
data | RakNet::InternalPacket
messageInternalOrder | RakNet::InternalPacket
messageNumberAssigned | RakNet::InternalPacket
nextActionTime | RakNet::InternalPacket
NORMAL enum value | RakNet::InternalPacket
priority | RakNet::InternalPacket
REF_COUNTED enum value | RakNet::InternalPacket
sendReceiptSerial | RakNet::InternalPacket
STACK enum value | RakNet::InternalPacket
timesSent | RakNet::InternalPacket
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • InternalPacketRefCountedData
RakNet::InternalPacketRefCountedData Member List

This is the complete list of members for RakNet::InternalPacketRefCountedData, including all inherited members.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • IsInQuickJoin_Func
RakNet::IsInQuickJoin_Func Member List

This is the complete list of members for RakNet::IsInQuickJoin_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • JoinByFilter_Func
RakNet::JoinByFilter_Func Member List

This is the complete list of members for RakNet::JoinByFilter_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • KickMember_Func
RakNet::KickMember_Func Member List

This is the complete list of members for RakNet::KickMember_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • LastSerializationResult
RakNet::LastSerializationResult Member List

This is the complete list of members for RakNet::LastSerializationResult, including all inherited members.

replica RakNet::LastSerializationResult
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • LeaveRoom_Func
RakNet::LeaveRoom_Func Member List

This is the complete list of members for RakNet::LeaveRoom_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Lobby2Callbacks
RakNet::Lobby2Callbacks Member List

This is the complete list of members for RakNet::Lobby2Callbacks, including all inherited members.

Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Lobby2Message
RakNet::Lobby2Message Member List

This is the complete list of members for RakNet::Lobby2Message, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const =0 | RakNet::Lobby2Message | pure virtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Lobby2Message | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const =0 | RakNet::Lobby2Message | pure virtual
RequiresLogin(void) const =0 | RakNet::Lobby2Message | pure virtual
RequiresRankingPermission(void) const =0 | RakNet::Lobby2Message | pure virtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Lobby2Message | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Lobby2Presence
RakNet::Lobby2Presence Member List

This is the complete list of members for RakNet::Lobby2Presence, including all inherited members.

AWAY enum value | RakNet::Lobby2Presence
DO_NOT_DISTURB enum value | RakNet::Lobby2Presence
EDITING_PROFILE enum value | RakNet::Lobby2Presence
IN_GAME enum value | RakNet::Lobby2Presence
IN_LOBBY enum value | RakNet::Lobby2Presence
IN_ROOM enum value | RakNet::Lobby2Presence
isVisible | RakNet::Lobby2Presence
MINIMIZED enum value | RakNet::Lobby2Presence
NOT_ONLINE enum value | RakNet::Lobby2Presence
Status enum name | RakNet::Lobby2Presence
statusString | RakNet::Lobby2Presence
titleNameOrID | RakNet::Lobby2Presence
TYPING enum value | RakNet::Lobby2Presence
UNDEFINED enum value | RakNet::Lobby2Presence
VIEWING_PROFILE enum value | RakNet::Lobby2Presence
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Lobby2Printf
RakNet::Lobby2Printf Member List

This is the complete list of members for RakNet::Lobby2Printf, including all inherited members.

Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Lobby2Server
  • ConfigurationProperties
RakNet::Lobby2Server::ConfigurationProperties Member List

This is the complete list of members for RakNet::Lobby2Server::ConfigurationProperties, including all inherited members.

accountRegistrationRequiredAgeYears | RakNet::Lobby2Server::ConfigurationProperties
accountRegistrationRequiresCDKey | RakNet::Lobby2Server::ConfigurationProperties
requiresEmailAddressValidationToLogin | RakNet::Lobby2Server::ConfigurationProperties
requiresTitleToLogin | RakNet::Lobby2Server::ConfigurationProperties
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Lobby2ServerCommand
RakNet::Lobby2ServerCommand Member List

This is the complete list of members for RakNet::Lobby2ServerCommand, including all inherited members.

Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • LogCommandParser
  • SystemAddressAndChannel
RakNet::LogCommandParser::SystemAddressAndChannel Member List

This is the complete list of members for RakNet::LogCommandParser::SystemAddressAndChannel, including all inherited members.

channels | RakNet::LogCommandParser::SystemAddressAndChannel
systemAddress | RakNet::LogCommandParser::SystemAddressAndChannel
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

  • ModeratorChanged_Notification
RakNet::ModeratorChanged_Notification Member List

This is the complete list of members for RakNet::ModeratorChanged_Notification, including all inherited members.

recipient RakNet::RoomsPluginNotification
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Packet
RakNet::Packet Member List

This is the complete list of members for RakNet::Packet, including all inherited members.

bitSize | RakNet::Packet
data | RakNet::Packet
guid | RakNet::Packet
length | RakNet::Packet
systemAddress | RakNet::Packet
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Platform_Shutdown
RakNet::Platform_Shutdown Member List

This is the complete list of members for RakNet::Platform_Shutdown, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Platform_Shutdown | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Platform_Shutdown | inlinevirtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Platform_Shutdown | inlinevirtual
RequiresLogin(void) const | RakNet::Platform_Shutdown | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Platform_Shutdown | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Lobby2Message | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Platform_Shutdown | inlinevirtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Platform_Startup
RakNet::Platform_Startup Member List

This is the complete list of members for RakNet::Platform_Startup, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Platform_Startup | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Platform_Startup | inlinevirtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Platform_Startup | inlinevirtual
RequiresLogin(void) const | RakNet::Platform_Startup | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Platform_Startup | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Lobby2Message | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Platform_Startup | inlinevirtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • PublicKey
RakNet::PublicKey Member List

This is the complete list of members for RakNet::PublicKey, including all inherited members.

myPrivateKey | RakNet::PublicKey
myPublicKey | RakNet::PublicKey
publicKeyMode | RakNet::PublicKey
remoteServerPublicKey | RakNet::PublicKey
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • QuickJoinEnteredRoom_Notification
RakNet::QuickJoinEnteredRoom_Notification Member List

This is the complete list of members for RakNet::QuickJoinEnteredRoom_Notification, including all inherited members.

recipient RakNet::RoomsPluginNotification
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • QuickJoinExpired_Notification
RakNet::QuickJoinExpired_Notification Member List

This is the complete list of members for RakNet::QuickJoinExpired_Notification, including all inherited members.

recipient RakNet::RoomsPluginNotification
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RakNetGUID
RakNet::RakNetGUID Member List

This is the complete list of members for RakNet::RakNetGUID, including all inherited members.

Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RakNetStatistics
RakNet::RakNetStatistics Member List

This is the complete list of members for RakNet::RakNetStatistics, including all inherited members.

BPSLimitByCongestionControl | RakNet::RakNetStatistics
BPSLimitByOutgoingBandwidthLimit | RakNet::RakNetStatistics
bytesInResendBuffer | RakNet::RakNetStatistics
bytesInSendBuffer | RakNet::RakNetStatistics
connectionStartTime | RakNet::RakNetStatistics
isLimitedByCongestionControl | RakNet::RakNetStatistics
isLimitedByOutgoingBandwidthLimit | RakNet::RakNetStatistics
messageInSendBuffer | RakNet::RakNetStatistics
messagesInResendBuffer | RakNet::RakNetStatistics
packetlossLastSecond | RakNet::RakNetStatistics
packetlossTotal | RakNet::RakNetStatistics
runningTotal | RakNet::RakNetStatistics
valueOverLastSecond | RakNet::RakNetStatistics
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Ranking_GetMatchBinaryData
RakNet::Ranking_GetMatchBinaryData Member List

This is the complete list of members for RakNet::Ranking_GetMatchBinaryData, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Ranking_GetMatchBinaryData | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Lobby2Message | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Ranking_GetMatchBinaryData | inlinevirtual
RequiresLogin(void) const | RakNet::Ranking_GetMatchBinaryData | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Ranking_GetMatchBinaryData | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Ranking_GetMatchBinaryData | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Ranking_GetMatches
RakNet::Ranking_GetMatches Member List

This is the complete list of members for RakNet::Ranking_GetMatches, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Ranking_GetMatches | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Ranking_GetMatches | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Ranking_GetMatches | inlinevirtual
RequiresLogin(void) const | RakNet::Ranking_GetMatches | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Ranking_GetMatches | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Ranking_GetMatches | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
submittedMatches | RakNet::Ranking_GetMatches |
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Ranking_GetRating
RakNet::Ranking_GetRating Member List

This is the complete list of members for RakNet::Ranking_GetRating, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Ranking_GetRating | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
currentRating | RakNet::Ranking_GetRating |
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Ranking_GetRating | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Ranking_GetRating | inlinevirtual
RequiresLogin(void) const | RakNet::Ranking_GetRating | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Ranking_GetRating | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Ranking_GetRating | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Ranking_GetTotalScore
RakNet::Ranking_GetTotalScore Member List

This is the complete list of members for RakNet::Ranking_GetTotalScore, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Ranking_GetTotalScore | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Ranking_GetTotalScore | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Ranking_GetTotalScore | inlinevirtual
RequiresLogin(void) const | RakNet::Ranking_GetTotalScore | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Ranking_GetTotalScore | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Ranking_GetTotalScore | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Ranking_PruneMatches
RakNet::Ranking_PruneMatches Member List

This is the complete list of members for RakNet::Ranking_PruneMatches, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Ranking_PruneMatches | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Lobby2Message | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Ranking_PruneMatches | inlinevirtual
RequiresLogin(void) const | RakNet::Ranking_PruneMatches | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Ranking_PruneMatches | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Ranking_PruneMatches | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Ranking_SubmitMatch
RakNet::Ranking_SubmitMatch Member List

This is the complete list of members for RakNet::Ranking_SubmitMatch, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Ranking_SubmitMatch | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Ranking_SubmitMatch | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Ranking_SubmitMatch | inlinevirtual
RequiresLogin(void) const | RakNet::Ranking_SubmitMatch | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Ranking_SubmitMatch | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Ranking_SubmitMatch | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Ranking_UpdateRating
RakNet::Ranking_UpdateRating Member List

This is the complete list of members for RakNet::Ranking_UpdateRating, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Ranking_UpdateRating | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Ranking_UpdateRating | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Ranking_UpdateRating | inlinevirtual
RequiresLogin(void) const | RakNet::Ranking_UpdateRating | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Ranking_UpdateRating | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Ranking_UpdateRating | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Ranking_WipeMatches
RakNet::Ranking_WipeMatches Member List

This is the complete list of members for RakNet::Ranking_WipeMatches, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Ranking_WipeMatches | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Ranking_WipeMatches | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Ranking_WipeMatches | inlinevirtual
RequiresLogin(void) const | RakNet::Ranking_WipeMatches | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Ranking_WipeMatches | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Ranking_WipeMatches | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Ranking_WipeRatings
RakNet::Ranking_WipeRatings Member List

This is the complete list of members for RakNet::Ranking_WipeRatings, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Ranking_WipeRatings | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Ranking_WipeRatings | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Ranking_WipeRatings | inlinevirtual
RequiresLogin(void) const | RakNet::Ranking_WipeRatings | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Ranking_WipeRatings | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Ranking_WipeRatings | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • Ranking_WipeScoresForPlayer
RakNet::Ranking_WipeScoresForPlayer Member List

This is the complete list of members for RakNet::Ranking_WipeScoresForPlayer, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::Ranking_WipeScoresForPlayer | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::Ranking_WipeScoresForPlayer | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::Ranking_WipeScoresForPlayer | inlinevirtual
RequiresLogin(void) const | RakNet::Ranking_WipeScoresForPlayer | inlinevirtual
RequiresRankingPermission(void) const | RakNet::Ranking_WipeScoresForPlayer | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Ranking_WipeScoresForPlayer | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RemoteClient
RakNet::RemoteClient Member List

This is the complete list of members for RakNet::RemoteClient, including all inherited members.

Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RemoveUserFromQuickJoin_Func
RakNet::RemoveUserFromQuickJoin_Func Member List

This is the complete list of members for RakNet::RemoveUserFromQuickJoin_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RoomDestroyedOnModeratorLeft_Notification
RakNet::RoomDestroyedOnModeratorLeft_Notification Member List

This is the complete list of members for RakNet::RoomDestroyedOnModeratorLeft_Notification, including all inherited members.

recipient RakNet::RoomsPluginNotification
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RoomInvitationSent_Notification
RakNet::RoomInvitationSent_Notification Member List

This is the complete list of members for RakNet::RoomInvitationSent_Notification, including all inherited members.

recipient RakNet::RoomsPluginNotification
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RoomInvitationWithdrawn_Notification
RakNet::RoomInvitationWithdrawn_Notification Member List

This is the complete list of members for RakNet::RoomInvitationWithdrawn_Notification, including all inherited members.

recipient RakNet::RoomsPluginNotification
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RoomLockStateSet_Notification
RakNet::RoomLockStateSet_Notification Member List

This is the complete list of members for RakNet::RoomLockStateSet_Notification, including all inherited members.

recipient RakNet::RoomsPluginNotification
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RoomMemberHandleSet_Notification
RakNet::RoomMemberHandleSet_Notification Member List

This is the complete list of members for RakNet::RoomMemberHandleSet_Notification, including all inherited members.

recipient RakNet::RoomsPluginNotification
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RoomMemberJoinedRoom_Notification
RakNet::RoomMemberJoinedRoom_Notification Member List

This is the complete list of members for RakNet::RoomMemberJoinedRoom_Notification, including all inherited members.

recipient RakNet::RoomsPluginNotification
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RoomMemberKicked_Notification
RakNet::RoomMemberKicked_Notification Member List

This is the complete list of members for RakNet::RoomMemberKicked_Notification, including all inherited members.

recipient RakNet::RoomsPluginNotification
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RoomMemberLeftRoom_Notification
RakNet::RoomMemberLeftRoom_Notification Member List

This is the complete list of members for RakNet::RoomMemberLeftRoom_Notification, including all inherited members.

recipient RakNet::RoomsPluginNotification
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RoomMemberReadyStatusSet_Notification
RakNet::RoomMemberReadyStatusSet_Notification Member List

This is the complete list of members for RakNet::RoomMemberReadyStatusSet_Notification, including all inherited members.

recipient RakNet::RoomsPluginNotification
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RoomMemberStartedSpectating_Notification
RakNet::RoomMemberStartedSpectating_Notification Member List

This is the complete list of members for RakNet::RoomMemberStartedSpectating_Notification, including all inherited members.

recipient RakNet::RoomsPluginNotification
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RoomMemberStoppedSpectating_Notification
RakNet::RoomMemberStoppedSpectating_Notification Member List

This is the complete list of members for RakNet::RoomMemberStoppedSpectating_Notification, including all inherited members.

recipient RakNet::RoomsPluginNotification
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RoomNameSet_Notification
RakNet::RoomNameSet_Notification Member List

This is the complete list of members for RakNet::RoomNameSet_Notification, including all inherited members.

recipient RakNet::RoomsPluginNotification
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RoomsPluginFunc
RakNet::RoomsPluginFunc Member List

This is the complete list of members for RakNet::RoomsPluginFunc, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • RoomsPluginNotification
RakNet::RoomsPluginNotification Member List

This is the complete list of members for RakNet::RoomsPluginNotification, including all inherited members.

recipient RakNet::RoomsPluginNotification
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • SearchByFilter_Func
RakNet::SearchByFilter_Func Member List

This is the complete list of members for RakNet::SearchByFilter_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • SendInvite_Func
RakNet::SendInvite_Func Member List

This is the complete list of members for RakNet::SendInvite_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • SerializeParameters
RakNet::SerializeParameters Member List

This is the complete list of members for RakNet::SerializeParameters, including all inherited members.

bitsWrittenSoFar | RakNet::SerializeParameters
curTime | RakNet::SerializeParameters
destinationConnection | RakNet::SerializeParameters
lastSentBitstream | RakNet::SerializeParameters
messageTimestamp | RakNet::SerializeParameters
outputBitstream | RakNet::SerializeParameters
pro | RakNet::SerializeParameters
whenLastSerialized | RakNet::SerializeParameters
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • SetCustomRoomProperties_Func
RakNet::SetCustomRoomProperties_Func Member List

This is the complete list of members for RakNet::SetCustomRoomProperties_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • SetDestroyOnModeratorLeave_Func
RakNet::SetDestroyOnModeratorLeave_Func Member List

This is the complete list of members for RakNet::SetDestroyOnModeratorLeave_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • SetHiddenFromSearches_Func
RakNet::SetHiddenFromSearches_Func Member List

This is the complete list of members for RakNet::SetHiddenFromSearches_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • SetReadyStatus_Func
RakNet::SetReadyStatus_Func Member List

This is the complete list of members for RakNet::SetReadyStatus_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • SetRoomLockState_Func
RakNet::SetRoomLockState_Func Member List

This is the complete list of members for RakNet::SetRoomLockState_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • SlotCountsSet_Notification
RakNet::SlotCountsSet_Notification Member List

This is the complete list of members for RakNet::SlotCountsSet_Notification, including all inherited members.

recipient RakNet::RoomsPluginNotification
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • SocketDescriptor
RakNet::SocketDescriptor Member List

This is the complete list of members for RakNet::SocketDescriptor, including all inherited members.

extraSocketOptions | RakNet::SocketDescriptor
hostAddress | RakNet::SocketDescriptor
port | RakNet::SocketDescriptor
socketFamily | RakNet::SocketDescriptor
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • StartSpectating_Func
RakNet::StartSpectating_Func Member List

This is the complete list of members for RakNet::StartSpectating_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • StopSpectating_Func
RakNet::StopSpectating_Func Member List

This is the complete list of members for RakNet::StopSpectating_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

  • System_BanUser
RakNet::System_BanUser Member List

This is the complete list of members for RakNet::System_BanUser, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::System_BanUser | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::System_BanUser | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::System_BanUser | inlinevirtual
RequiresLogin(void) const | RakNet::System_BanUser | inlinevirtual
RequiresRankingPermission(void) const | RakNet::System_BanUser | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::System_BanUser | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • System_CreateDatabase
RakNet::System_CreateDatabase Member List

This is the complete list of members for RakNet::System_CreateDatabase, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::System_CreateDatabase | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::System_CreateDatabase | inlinevirtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::System_CreateDatabase | inlinevirtual
RequiresLogin(void) const | RakNet::System_CreateDatabase | inlinevirtual
RequiresRankingPermission(void) const | RakNet::System_CreateDatabase | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Lobby2Message | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • System_CreateTitle
RakNet::System_CreateTitle Member List

This is the complete list of members for RakNet::System_CreateTitle, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::System_CreateTitle | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::System_CreateTitle | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::System_CreateTitle | inlinevirtual
RequiresLogin(void) const | RakNet::System_CreateTitle | inlinevirtual
RequiresRankingPermission(void) const | RakNet::System_CreateTitle | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::System_CreateTitle | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • System_DeleteAccount
RakNet::System_DeleteAccount Member List

This is the complete list of members for RakNet::System_DeleteAccount, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::System_DeleteAccount | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::System_DeleteAccount | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::System_DeleteAccount | inlinevirtual
RequiresLogin(void) const | RakNet::System_DeleteAccount | inlinevirtual
RequiresRankingPermission(void) const | RakNet::System_DeleteAccount | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::System_DeleteAccount | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • System_DestroyDatabase
RakNet::System_DestroyDatabase Member List

This is the complete list of members for RakNet::System_DestroyDatabase, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::System_DestroyDatabase | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::System_DestroyDatabase | inlinevirtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::System_DestroyDatabase | inlinevirtual
RequiresLogin(void) const | RakNet::System_DestroyDatabase | inlinevirtual
RequiresRankingPermission(void) const | RakNet::System_DestroyDatabase | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::Lobby2Message | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • System_DestroyTitle
RakNet::System_DestroyTitle Member List

This is the complete list of members for RakNet::System_DestroyTitle, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::System_DestroyTitle | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::System_DestroyTitle | inlinevirtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::System_DestroyTitle | inlinevirtual
RequiresLogin(void) const | RakNet::System_DestroyTitle | inlinevirtual
RequiresRankingPermission(void) const | RakNet::System_DestroyTitle | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::System_DestroyTitle | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • System_GetTitleBinaryData
RakNet::System_GetTitleBinaryData Member List

This is the complete list of members for RakNet::System_GetTitleBinaryData, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::System_GetTitleBinaryData | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::System_GetTitleBinaryData | inlinevirtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::System_GetTitleBinaryData | inlinevirtual
RequiresLogin(void) const | RakNet::System_GetTitleBinaryData | inlinevirtual
RequiresRankingPermission(void) const | RakNet::System_GetTitleBinaryData | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::System_GetTitleBinaryData | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • System_GetTitleRequiredAge
RakNet::System_GetTitleRequiredAge Member List

This is the complete list of members for RakNet::System_GetTitleRequiredAge, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::System_GetTitleRequiredAge | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::System_GetTitleRequiredAge | inlinevirtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::System_GetTitleRequiredAge | inlinevirtual
RequiresLogin(void) const | RakNet::System_GetTitleRequiredAge | inlinevirtual
RequiresRankingPermission(void) const | RakNet::System_GetTitleRequiredAge | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::System_GetTitleRequiredAge | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • System_PruneAccounts
RakNet::System_PruneAccounts Member List

This is the complete list of members for RakNet::System_PruneAccounts, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::System_PruneAccounts | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::System_PruneAccounts | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::System_PruneAccounts | inlinevirtual
RequiresLogin(void) const | RakNet::System_PruneAccounts | inlinevirtual
RequiresRankingPermission(void) const | RakNet::System_PruneAccounts | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::System_PruneAccounts | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • System_RegisterProfanity
RakNet::System_RegisterProfanity Member List

This is the complete list of members for RakNet::System_RegisterProfanity, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::System_RegisterProfanity | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::System_RegisterProfanity | inlinevirtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::System_RegisterProfanity | inlinevirtual
RequiresLogin(void) const | RakNet::System_RegisterProfanity | inlinevirtual
RequiresRankingPermission(void) const | RakNet::System_RegisterProfanity | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::System_RegisterProfanity | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • System_SetEmailAddressValidated
RakNet::System_SetEmailAddressValidated Member List

This is the complete list of members for RakNet::System_SetEmailAddressValidated, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::System_SetEmailAddressValidated | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::System_SetEmailAddressValidated | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::System_SetEmailAddressValidated | inlinevirtual
RequiresLogin(void) const | RakNet::System_SetEmailAddressValidated | inlinevirtual
RequiresRankingPermission(void) const | RakNet::System_SetEmailAddressValidated | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::System_SetEmailAddressValidated | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • System_UnbanUser
RakNet::System_UnbanUser Member List

This is the complete list of members for RakNet::System_UnbanUser, including all inherited members.

callbackId | RakNet::Lobby2Message |
CallCallback(Lobby2Callbacks *cb)=0 | RakNet::Lobby2Message | pure virtual
CancelOnDisconnect(void) const | RakNet::System_UnbanUser | inlinevirtual
ClientImpl(RakNet::Lobby2Plugin *client) | RakNet::Lobby2Message | virtual
DebugMsg(RakNet::RakString &out) const =0 | RakNet::Lobby2Message | pure virtual
DebugPrintf(void) const | RakNet::Lobby2Message | inlinevirtual
extendedResultCode | RakNet::Lobby2Message |
GetID(void) const =0 | RakNet::Lobby2Message | pure virtual
GetName(void) const =0 | RakNet::Lobby2Message | pure virtual
PrevalidateInput(void) | RakNet::System_UnbanUser | virtual
requestId | RakNet::Lobby2Message |
RequiresAdmin(void) const | RakNet::System_UnbanUser | inlinevirtual
RequiresLogin(void) const | RakNet::System_UnbanUser | inlinevirtual
RequiresRankingPermission(void) const | RakNet::System_UnbanUser | inlinevirtual
resultCode | RakNet::Lobby2Message |
Serialize(bool writeToBitstream, bool serializeOutput, RakNet::BitStream *bitStream) | RakNet::System_UnbanUser | virtual
ServerDBImpl(Lobby2ServerCommand *command, void *databaseInterface) | RakNet::Lobby2Message | virtual
ServerPostDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ServerPreDBMemoryImpl(Lobby2Server *server, RakString userHandle) | RakNet::Lobby2Message | virtual
ValidateBinary(RakNetSmartPtr< BinaryDataBlock >binaryDataBlock) | RakNet::Lobby2Message |
ValidateEmailAddress(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateHandle(RakNet::RakString *handle) | RakNet::Lobby2Message |
ValidatePassword(RakNet::RakString *text) | RakNet::Lobby2Message |
ValidateRequiredText(RakNet::RakString *text) | RakNet::Lobby2Message |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • SystemAddress
RakNet::SystemAddress Member List

This is the complete list of members for RakNet::SystemAddress, including all inherited members.

addr4 | RakNet::SystemAddress |
CopyPort(const SystemAddress &right) | RakNet::SystemAddress |
debugPort | RakNet::SystemAddress |
EqualsExcludingPort(const SystemAddress &right) const | RakNet::SystemAddress |
FromString(const char *str, char portDelineator='|', int ipVersion=0) | RakNet::SystemAddress |
FromStringExplicitPort(const char *str, unsigned short port, int ipVersion=0) | RakNet::SystemAddress |
GetIPVersion(void) const | RakNet::SystemAddress |
GetPort(void) const | RakNet::SystemAddress |
IsLoopback(void) const | RakNet::SystemAddress |
SetBinaryAddress(const char *str, char portDelineator=':') | RakNet::SystemAddress |
SetPortHostOrder(unsigned short s) | RakNet::SystemAddress |
SetToLoopback(void) | RakNet::SystemAddress |
SetToLoopback(unsigned char ipVersion) | RakNet::SystemAddress |
SystemAddress() | RakNet::SystemAddress |
ToInteger(const SystemAddress &sa) | RakNet::SystemAddress | static
ToString_Old(bool writePort, char *dest, char portDelineator=':') const | RakNet::SystemAddress |
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • TeamSelection
RakNet::TeamSelection Member List

This is the complete list of members for RakNet::TeamSelection, including all inherited members.

AnyAvailable(void) | RakNet::TeamSelection | static
NoTeam(NoTeamId noTeamSubcategory) | RakNet::TeamSelection | static
SpecificTeam(TM_Team *specificTeamToJoin) | RakNet::TeamSelection | static
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • UDPProxyClientResultHandler
RakNet::UDPProxyClientResultHandler Member List

This is the complete list of members for RakNet::UDPProxyClientResultHandler, including all inherited members.

OnAllServersBusy(SystemAddress proxyCoordinator, SystemAddress sourceAddress, SystemAddress targetAddress, RakNetGUID targetGuid, RakNet::UDPProxyClient *proxyClientPlugin)=0 | RakNet::UDPProxyClientResultHandler | pure virtual
OnForwardingInProgress(const char *proxyIPAddress, unsigned short proxyPort, SystemAddress proxyCoordinator, SystemAddress sourceAddress, SystemAddress targetAddress, RakNetGUID targetGuid, RakNet::UDPProxyClient *proxyClientPlugin)=0 | RakNet::UDPProxyClientResultHandler | pure virtual
OnForwardingNotification(const char *proxyIPAddress, unsigned short proxyPort, SystemAddress proxyCoordinator, SystemAddress sourceAddress, SystemAddress targetAddress, RakNetGUID targetGuid, RakNet::UDPProxyClient *proxyClientPlugin)=0 | RakNet::UDPProxyClientResultHandler | pure virtual
OnForwardingSuccess(const char *proxyIPAddress, unsigned short proxyPort, SystemAddress proxyCoordinator, SystemAddress sourceAddress, SystemAddress targetAddress, RakNetGUID targetGuid, RakNet::UDPProxyClient *proxyClientPlugin)=0 | RakNet::UDPProxyClientResultHandler | pure virtual
OnNoServersOnline(SystemAddress proxyCoordinator, SystemAddress sourceAddress, SystemAddress targetAddress, RakNetGUID targetGuid, RakNet::UDPProxyClient *proxyClientPlugin)=0 | RakNet::UDPProxyClientResultHandler | pure virtual
OnRecipientNotConnected(SystemAddress proxyCoordinator, SystemAddress sourceAddress, SystemAddress targetAddress, RakNetGUID targetGuid, RakNet::UDPProxyClient *proxyClientPlugin)=0 | RakNet::UDPProxyClientResultHandler | pure virtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • UDPProxyServerResultHandler
RakNet::UDPProxyServerResultHandler Member List

This is the complete list of members for RakNet::UDPProxyServerResultHandler, including all inherited members.

OnAlreadyLoggedIn(RakNet::RakString usedPassword, RakNet::UDPProxyServer *proxyServerPlugin)=0 | RakNet::UDPProxyServerResultHandler | pure virtual
OnLoginSuccess(RakNet::RakString usedPassword, RakNet::UDPProxyServer *proxyServerPlugin)=0 | RakNet::UDPProxyServerResultHandler | pure virtual
OnNoPasswordSet(RakNet::RakString usedPassword, RakNet::UDPProxyServer *proxyServerPlugin)=0 | RakNet::UDPProxyServerResultHandler | pure virtual
OnWrongPassword(RakNet::RakString usedPassword, RakNet::UDPProxyServer *proxyServerPlugin)=0 | RakNet::UDPProxyServerResultHandler | pure virtual
Generated on Mon Jun 2 2014 20:10:29 for RakNet by doxygen 1.8.2


RakNet: Member List

  • UnbanMember_Func
RakNet::UnbanMember_Func Member List

This is the complete list of members for RakNet::UnbanMember_Func, including all inherited members.

resultCode | RakNet::RoomsPluginFunc
userName | RakNet::RoomsPluginFunc
Generated on Mon Jun 2 2014 20:10:30 for RakNet by doxygen 1.8.2


RakNet: Member List

SQLite3Row Member List

This is the complete list of members for SQLite3Row, including all inherited members.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

SQLite3Table Member List

This is the complete list of members for SQLite3Table, including all inherited members.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

StrAndBool Member List

This is the complete list of members for StrAndBool, including all inherited members.

Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2


RakNet: Member List

ThreadPool< InputType, OutputType > Member List

This is the complete list of members for ThreadPool< InputType, OutputType >, including all inherited members.

AddInput(OutputType(*workerThreadCallback)(InputType, bool *returnOutput, void *perThreadData), InputType inputData) | ThreadPool< InputType, OutputType >
AddOutput(OutputType outputData) | ThreadPool< InputType, OutputType >
Clear(void) | ThreadPool< InputType, OutputType >
ClearInput(void) | ThreadPool< InputType, OutputType >
ClearOutput(void) | ThreadPool< InputType, OutputType >
GetInputAtIndex(unsigned index) | ThreadPool< InputType, OutputType >
GetOutput(void) | ThreadPool< InputType, OutputType >
GetOutputAtIndex(unsigned index) | ThreadPool< InputType, OutputType >
HasInput(void) | ThreadPool< InputType, OutputType >
HasInputFast(void) | ThreadPool< InputType, OutputType >
HasOutput(void) | ThreadPool< InputType, OutputType >
HasOutputFast(void) | ThreadPool< InputType, OutputType >
InputSize(void) | ThreadPool< InputType, OutputType >
IsWorking(void) | ThreadPool< InputType, OutputType >
LockInput(void) | ThreadPool< InputType, OutputType >
LockOutput(void) | ThreadPool< InputType, OutputType >
NumThreadsWorking(void) | ThreadPool< InputType, OutputType >
OutputSize(void) | ThreadPool< InputType, OutputType >
RemoveInputAtIndex(unsigned index) | ThreadPool< InputType, OutputType >
RemoveOutputAtIndex(unsigned index) | ThreadPool< InputType, OutputType >
StartThreads(int numThreads, int stackSize, void *(*_perThreadInit)()=0, void(*_perThreadDeinit)(void *)=0) | ThreadPool< InputType, OutputType >
StopThreads(void) | ThreadPool< InputType, OutputType >
UnlockInput(void) | ThreadPool< InputType, OutputType >
UnlockOutput(void) | ThreadPool< InputType, OutputType >
WasStarted(void) | ThreadPool< InputType, OutputType >
Generated on Mon Jun 2 2014 20:10:28 for RakNet by doxygen 1.8.2